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SSRS Reports
SQL Server Reporting Services (SSRS) is a server-based reporting platform that you can use to create and manage 
tabular, matrix, graphical, and free-form reports that contain data from relational and multi-dimensional data sources. 
The reports that you create can be viewed and managed over a World Wide Web-based connection (Report Manager). 
They can be run from within Microsoft Dynamics GP, as with any standard report.Reporting Services includes the 
following core components:

A complete set of tools that you can use to create, manage, and view reports.
A Report Server component that hosts and processes reports in a variety of formats. Output formats include 
HTML, PDF, TIFF, Excel, CSV, and more.
An API that allows developers to integrate or extend data and report processing in custom applications, or 
create custom tools to build and manage reports.

SSRS reports are provided for Microsoft Dynamics GP products and Signature products. For additional information on 
SQL Server Reporting Services, refer to the Microsoft SQL Server documentation.

Signature SSRS Reports Setup

System Requirements
To find a complete list of system requirements across all the Signature modules, refer to Signature System 
Requirements1.

Prerequisites
Certain IIS features must be installed before you can enable SQL Server Reporting Services to be installed with SQL 
Server. For SQL Server 2012 or later, select all the System Requirements, as well as the additional features below. Select 
Start > Administrative Tools > Server Manager > Roles > Add Roles, and select the Web Server (IIS)role to configure.

Web Management Tools
IIS 6 Management Compatibility

IIS 6 WMI Compatibility
IIS Metabase and IIS 6 configuration compatibility

IIS Management Console
IIS Management Scripts and Tools
IIS Management Service

World Wide Web Services
Application Development Features

.NET Extensibility
ASP.NET
ISAPI Extensions

https://docs.key2act.io/display/1805b07/Signature+System+Requirements
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ISAPI Filters
Common HTTP Features

Default Document
Directory Browsing
HTTP Redirection
HTTOP Errors
Static Content

Security
Request Filtering
Windows Authentication

Health and Diagnostics
HTTP Logging and Request Monitor

Performance
Static Content Compression

Before You Begin
Before deploying the latest Signature reports, you must have SSRS reports set up. This setup requires the following 
steps:

Step 1: Install SQL Server Reporting Services
SQL Server Reporting Services is part of the Microsoft SQL Server installation pack. You must install this to be able to 
use SSRS reports in Microsoft Dynamics GP and Signature. Refer to the Microsoft SQL Server documentation for 
information on installing SQL Reporting Services.

Step 2: Enable Use of Microsoft Dynamics GP SSRS Reports
If you have not done so already, you must run the Microsoft SQL Server Reporting Services wizard to enable access to 
SSRS reports within Microsoft Dynamics GP.

Launch the file Microsoft.Dynamics.GP.BusinessIntelligence.SRSDeployment.exe
On the Welcome Screen, select Next >.
Enter the Microsoft Dynamics GP Server name and instance. For example, if the server name is Fred and the 
instance Fred1, you would enter Fred\Fred1.
Enter your server User Name and Password, then select Next >.
Select the company database for which to enable reports, for example, TWO. In addition, select the Microsoft 
Dynamics GP products to enable reports for, by marking the appropriate checkboxes. Mark Select All to select 
ALL products. Select Next >.
Enter the Target Server URL as http://MyMachineName/ReportServerName_2 where _MyMachine is your machine 
name and MyReportServerName is the name of the report server given when you installed SQL Reporting 
Services. To determine the name of the report server, select Start > All Programs > Microsoft SQL> Configuration 
Tools > Reporting Services Configuration. Connect to your server and select Web Service URL. The Virtual 
Directory field contains the name of the report server. When you are ready to deploy reports, select Finish.

http://mymachinename/ReportServerName_
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When processing is complete, if you want to deploy reports for another company, mark the checkbox and 
select OK to start the wizard again. If you are finished deploying reports, leave the checkbox unmarked and 
select OK.

Step 3: Define the Location of SSRS Reports Server and Report Manager
Select Microsoft Dynamics GP > Tools > Setup > System > Reporting Tools Setup. The Reporting Tools Setup 
window opens.
Complete the following fields on the Reporting Services tab:

SQL Server Mode
Select Native mode. Signature SSRS reports do not currently support SharePoint Integrated mode.
Report Server URL
This is the location of the reporting server site that hosts the web service. You specified this location 
when you installed SQL Server Reporting Services. Enter: http://MyMachine/
MyReportServerName3where MyMachine is your machine name and MyReportServerName is the name of 
the report server given when you installed SQL Reporting Services. To determine the name of the report 
server, select Start > All Programs > Microsoft SQL> Configuration Tools > Reporting Services Configuration. 
Connect to your server and select Web Service URL. The Virtual Directory field contains the name of the 
report server. The instructions for finding the report manager URL may vary depending on which version 
of SQL Server you are running.
Report Manager URL
Enter the Web location where the Report Manager is accessed. Enter: http://MyMachine/
MyReportsFolder4 where MyMachine is your machine name and MyReportsFolder is the name of the 
virtual directory of the Report Manager. To determine the name of the report server, select Start > All 
Programs > Microsoft SQL> Configuration Tools > Reporting Services Configuration. Connect to your server 
and select Report Manager URL. The Virtual Directory field contains the name of the report server. The 
instructions for finding the report manager URL may vary depending on which version of SQL Server you 
are running.

When you are finished, select OK to save the Reporting Tools Setup window.

Setting up Signature Reports
Complete the following steps to enable the use of Signature SSRS reports.

Step 1: Deploy Signature SSRS Reports
To deploy Signature SSRS reports, you must run the Signature SQL Reporting Wizard.

To ensure a clean installation and deployment of the new reports, you should have removed any existing Signature 
SSRS reports from both the Microsoft Dynamics GP install directory and the Report Manager. Refer to the Signature 
Install and Upgrade manual for more information.

Before you begin, determine the name of your SQL report server, which was set up when SQL Server Reporting Services 
was installed. Select Start > All Programs > Microsoft SQL> Configuration Tools > Reporting Services Configuration. 
Connect to your server and select Web Service URL. The Virtual Directory field contains the name of the report server; 
write down this name, as you must enter it in the steps that follow.

The instructions for finding the report manager URL may vary depending on which version of SQL Server you are 
running.

http://mymachine/MyReportServerName
http://mymachine/MyReportsFolder
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To start the Signature SQL Reporting Wizard, navigate to your Microsoft Dynamics GP install directory, then open 
the Signature\SRS Reports folder and launch the 
file Signature.Dynamics.GP.BusinessIntelligence.SRSDeployment.exe.

You can also run this wizard from the following locations within Microsoft Dynamics GP:

From Service Management, select Run Wizard in the Service Options window.
From Job Cost, select Run Wizard in the Job Cost Setup Options window.
From Equipment Management, select SRS Wizard in the System Setup window.
On the Welcome screen, select Next >.

Enter the Microsoft Dynamics GP Server name and instance. For example, if the server name is Fred and the 
instance Fred1, you would enter Fred\Fred1.
Enter your server User Name and Password, then select Next >.
Select the company database for which to enable reports, for example, TWO. You must run the wizard multiple 
times if you wish to deploy SRS reports for multiple companies.
Enter the Report server URL. This is the location of the reporting server site that hosts the web service. You 
specified this location when you installed SQL Server Reporting Services. Enter: http://MyMachine/
MyReportServerName5 where MyMachine is your machine name and MyReportServerName is the name of the 
report server given when you installed SQL Reporting Services.
Enter the Dynamics/Signature Directory. This is the directory where Microsoft Dynamics GP and Signature are 
installed.
Select Next >.
All SSRS report folders found in the Dynamics/Signature directory appear on the next wizard screen. Unmark the 
checkbox next to any folder, or expand a folder and unmark the checkbox next to any report, that you do not 
want to deploy. 
To use KPI reports and report templates, you must be running SQL Server Reporting Services 2008 R2 or later. 
Additionally, you must have SQL 2008 R2 Business Intelligence Studio installed to deploy the Signature 
Template Pivot report template.
Select Deploy. It will take a few moments to deploy the reports. A message appears when the deployment is 
successful. Select OK. The Signature SQL Reporting Wizard starts over again. You can either deploy reports for an 
additional company database by choosing Next, or you can exit the wizard by choosing Cancel.

Additional Setup for Equipment Management Reports

For Equipment Management, you must also set up your SSRS reports in the Report Definition Setup window (Microsoft 
Dynamics GP > Tools > Setup > Equipment > System > Report Definitions). For step-by-step instructions, refer to the 
Advanced Rental feature section of the Equipment Management User Guide.

Step 2: Set up Company Logo (optional)
You can customize the company logo that appears on some of your customer-facing reports, for example, invoices.
For each of the reports that display a logo, the .rdl file points to the subfolder Signature Images and the file Company 
Logo. The default logo is a transparent image that appears on the reports as blank.

If you want your own company logo to appear on the reports, you can replace this image; however, DO NOT delete the 
default logo unless you are replacing it. If the .rdl cannot locate Signature Images\Company Logo, the logo appears on 

http://mymachine/MyReportServerName
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In Report Manager, locate the company where reports are deployed, and open the folder Signature Images.
Rename or delete the default Company Logo file by choosing Show Details, then Edit or Delete.
Return to the Signature Images folder and select Upload File. Before uploading, change the name of your new 
logo to Company Logo (no file extension), then select OK.

   

Step 3: Set up Signature SRS Reports to Print from GP
To set up Signature SSRS reports to print from the appropriate window in the GP application, you must replace the 
provided Dexterity reports with the corresponding Signature SSRS reports. This requires that you either manually 
populate the WSRepts table with the pathname to the replacement report, or run the stored 
procedure WS_SetReplacementReportsForSRS, which populates all applicable Signature SSRS report pathnames into 
the table.

About the WSRepts Table

The table WSRepts stores the path location for replacement reports. This table is created in each company 
database during the Signature installation or upgrade process.


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A select statement on this table yields something like the following:

The ReportReference column identifies the name of the report you want to replace, most likely a Dexterity 
report name.
The ReportLocation column stores the full path and file name of the report being referenced. This could be a 
local SSRS report or the URL of a remote SRS report. A blank column assumes the system is running the 
Dexterity version of the report. To replace the Dexterity report with the SSRS report, you must populate this 
column with the SSRS report location.
In the example below, an existing Dexterity report is replaced with an SSRS report using the stored procedures.
UPDATE WSRepts Set ReportLocation = 'http://localhost/ReportServerNew/TWO/Signature Service/Service 
Cost Audit' where ReportReference ='SV_Service_Cost_Audit_Report'
If you are replacing reports individually, you can determine the name of the Dexterity report by printing that 
report from within the Signature system. For SSRS reports, you also need to know the machine name on which 
your report server resides.

Running the SQL Stored Procedure

The SQL procedure WS_SetReplacementReportsForSRS globally replaces all applicable Dexterity reports 
with the SSRS report equivalent.
Running this procedure DOES NOT update a ReportLocation that already contains a value; it only applies to 
blank ReportLocation columns, which assumes that the Dexterity report is being used. If you already have a 
custom report specified to replace the Dexterity report, it will not be overwritten.

http://localhost/ReportServerNew/TWO/Signature
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Accessing SSRS Reports
After setting up Signature SSRS reports to print from GP, some SSRS reports are accessible via Signature application 
windows using the Print button. In addition, SSRS reports can be accessed via the Custom Report List page in Microsoft 
Dynamics GP.

Launch Microsoft Dynamics GP.
Select the Administration icon in the navigation pane.
Select Custom Report List. The right pane populates with all SSRS reports available from Microsoft Dynamics GP 
and Signature. This takes a few moments. Signature SSRS reports are commingled with the Microsoft Dynamics 
GP SSRS reports in the list. To locate Signature reports, identify the column and look for Signature Service, 
Signature Job Cost, and Signature Equipment.
To launch a report, double click on the report name, then select the View icon (or just double-click on the 
report). The Report Viewer (web-based) window opens. For most reports, you must enter report criteria. For 
others, you can leave a criteria field blank (ex. job number) to apply to all entities (such as printing a report for 
ALL agreements or ALL jobs). For information on additional SSRS report features, refer to the Microsoft 
Dynamics GP documentation.

Signature SSRS Reports Reference
Below is a list of all the Signature SSRS reports available.

Service Management (page 7)
Job Cost (page 8)
TimeTrack (page 9)
Equipment Management (page 9)
Shared (page 10)

Service Management

Annualized Labor Loading (page 10)
Appointment Summary (page 11)
Call Summary (page 12)
Contract Equipment PM Tasks (page 14)
Dispatch List (page 14)
Field Invoice (page 15)
GL Not Match Service (page 17)
GL Transactions Not In Service (page 18)
Inspection Report (page 18)
Job Appointment Summary (page 19)
Job Safety Analysis (page 21)
Job Safety Audit (2013) (page 23)
Maintenance Contract Deferred Revenue (page 26)

To replace Dexterity reports, run the following command against the company database to call on the stored 
procedure: exec WS_SetReplacementReportsForSRS
The common printing DLL Signature.ReportControl.dll provides the WSRepts table and the two SQL 
procedures that can be used to set up SQL reporting. For more information on this DLL, refer to the user 
manual.
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Maintenance Contract Invoice (page 26)
Maintenance Contract Profile (page 31)
Maintenance Contract Profitability with Pull Through (page 33)
Maintenance Contract Quote Reports (page 34)
Maintenance Contract Scheduled Materials (page 40)
Maintenance Contracts Over or Under Billed (page 41)
Maintenance Contract Statistics (page 42)
Profit by Customer (page 44)
Recognized Revenue (page 45)
Refrigerant Tracking Leak Analysis (page 46)
Refrigerant Tracking List (page 47)
Refrigerant Tracking Report (page 48)
Resource Schedule (page 49)
Sales Tax - Material Purchases (page 50)
Schedule Technician Board (page 51)
Service Call Analysis - Unbilled Quotes (page 52)
Service Call Analysis - Unbilled T&M (page 53)
Service Call Cost Audit (page 53)
Service Call Cost Reconciliation (page 54)
Service Call Cost Reconciliation by Account (page 55)
Service Call Gross Profit (page 56)
Service Call Invoices (page 57)
Service Call Maintenance Workorder (page 69)
Service Call Quote (page 70)
Service Call Revenue Statistics by Call Type (page 71)
Service Call Statistics by Call Type (page 73)
Service Call Status (page 74)
Service Call Status Statistics (page 74)
Service Call Vendor Quote (page 75)
Service Call Workorders (page 76)
Service Invoice Summary (page 82)
Service Invoice Trailing Costs (page 85)
Service Invoice Trailing PPV Costs (page 86)
Service Profitability (page 87)
Service Revenue Recap (page 89)
Service Transactions Not in GL (page 90)
Service WIP (page 91)
Technician Forecast (page 94)
Top and Bottom Customers by Sales (page 96)
Top Technicians by Billed Hours (page 96)
WIP SSRS reports (page 98)

Job Cost

Application for Payment (page 98)
AR Retention Trial Balance (page 100)
Closed Jobs (page 101)
Custom SSRS Job Cost Reports (page 102)
GL Not Match Job Cost (page 102)
GL Transactions Not in Job Cost (page 103)
Job Analysis (page 104)
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Job Audit Billing (page 106)
Job Audit Costs (page 107)
Job Change Order (page 108)
Job Closing Preparation (page 109)
Job Committed Costs (page 110)
Job Cost Transactions Not in GL (page 111)
Job Invoice (page 112)
Job Lien Waiver (page 126)
Job Percentage of Completion (page 128)
Job Plan (page 128)
Job Profit and Loss (page 130)
Job Profit and Loss Key Performance Indicator (page 132)
Job RPO Profit and Loss (page 133)
Jobs Available to Close (page 134)
Job Schedule by Cost Code (page 134)
Jobs Not Available to Close (page 136)
Job WIP Reconciliation (page 136)
Payables Aged Trial Balance (page 139)
Project Invoice (page 140)
Subcontract Agreement (page 141)
Subcontractor Claims (page 142)
Subcontractor Insurance Expiration (page 142)
Subcontractor Supporting Statement (page 143)
Subcontractor Transaction Detail (page 144)
Union Report (page 145)
WIP Reports in Job Cost (page 149)

TimeTrack

Certified Payroll (page 149)
Certified Payroll for Public Works (page 151)
Employee Utilization (page 155)
Time Sheet (page 157)

Equipment Management

Equipment Attributes (page 158)
Equipment Profit and Loss (page 159)

Equipment Profit and Loss Sub Report (page 160)
Equipment Profit and Loss Details (page 161)

Equipment Profit and Loss Key Performance Indicator (page 162)
Inspection (page 163)
Rental Agreement, Booking, and Invoice Reports (page 163)

Rental Agreement (page 163)
Rental Agreement Standdown Lines (Subreport) (page 168)

Rental Line Agreement (page 168)
Rental Booking (page 168)
Rental Invoice (page 169)

Rental Invoice Misc Lines (Subreport) (page 171)
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Rental Invoice Standdown Lines (Subreport) (page 171)
Rental Line Invoice (page 171)

Rental Utilization (page 172)
Scheduled Maintenance Forecast (page 173)

Shared

Equipment Service Cost per Meter UOM (page 172)
Receivables Aged Trial Balance (page 175)
Receivables Historical Aged Trial Balance (page 178)
WennSoft Billing Customer Profitability (page 179)
SSRS Report Templates (page 180)

Configuring a Report (page 180)
Signature Report Templates (page 184)

Signature Template Chart 1 (page 184)
Signature Template Chart 2 (page 185)
Signature Template Chart 5 (page 185)
Signature Template Group (page 186)
Signature Template Group Filter (page 187)
Signature Template Group Filter Date (page 188)
Signature Template Pivot (page 189)

Service Management SSRS Reports

Annualized Labor Loading
This report allows you to view annual labor by month. You can filter the report by Tech Team, Division, and Technician, 
and total monthly hours display by technician. You can select to show or hide tasking details. The detailed report 
breaks down technician hours by service call, where the summary version shows only technician totals by month.
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Appointment Summary
This report is generated when a service appointment has been completed in MobileTech. This report displays the 
service call, appointment, labor, inventory information, XOi resolution hyperlink, resolution note, and technician/
customer signatures related to the completed appointment.

This report is attached to the Cost Code and is automatically sent by email to the recipients who are designated in the 
MobileTech setup.
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Call Summary
This report is generated when a service appointment has been completed in MobileTech. This report displays the 
service call, appointment(s), labor, inventory information, XOi resolution hyperlink, resolution note, and technician/
customer signatures related to the completed appointment. This report is attached to the Cost Code and is 
automatically sent by email to the recipients who are designated in the MobileTech setup.
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Contract Equipment PM Tasks
This report allows you to view preventative maintenance tasks for equipment on a contract. You can view the tasks, 
schedule, assigned technician, and estimated hours. Select the Customer, Location, and Contract to view preventative 
maintenance tasks for equipment.

Dispatch List
This report provides a detailed list of service call appointments; this is useful for technicians and dispatchers who 
manage workload and appointment priority. You can use various filters to review historical job appointments and hours 
counts without needing to log in to the GP application. You can print this report from Report Manager and the Custom 
Reports list, filtering and sorting on any column, including Date Range, Service Area, Technician, Appointment Status, 
and User Defined.
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Field Invoice
In MobileTech, your technician can generate a field invoice and then collect payment for the invoice for a service call 
appointment that is created in Service Management or for a new service call appointment that is created on their 
mobile device.

This functionality is available only if your organization uses Field Invoicing and Field Payments. 

Invoices and payments that are generated from MobileTech are processed and posted in Microsoft Dynamics GP and in 
Service Management using the same tasks and procedures for invoices that are created in Service Management.

If you have set up Third Party Billing in Service Management, the field invoice respects the Bill to information provided 
in the Service Call. For more information about setting up Third Party Billing, see "Using Third Party Billing" in Service 
Management help.
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GL Not Match Service
This WIP report, GL Transaction Amounts Not Matching in Service, allows you to identify discrepancies between journal 
entry amounts in the General Ledger and in Service when you are posting to the GL in summary. You cannot compare 
amounts at the transaction level when you are posting one GL journal per batch; instead, you can use this report to 
compare the sum of all transactions in the batch from Service to the GL journal entry amount. Refer to the user manual 
for more information on using WIP reports at month's end. This report can be printed from its location in the Report 
Manager, or from Microsoft Dynamics GP by opening the Administration page and locating this report on the Custom 
Reports list. You can filter the report by account number or view all accounts for the specified date range.
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GL Transactions Not In Service
This WIP report shows a breakdown of the transactions that have been posted to the GL but were not posted to your 
Service accounts. Transactions are grouped by account number, and debits and credits are listed for each transaction 
as well as totaled for each account. The GL Transactions Not in Service report can be run as part of the month end 
closing process, to help identify the costs that have been posted to the GL but have not been posted in Service 
Management. Refer to the user manual for more information on using WIP reports at month's end. To print, 
select Reports > Service Management > Service > WIP Reports. On the Service WIP Reports window, mark the Exception 
Reports radio button, then mark the GL Costs Not in Service radio button. You can filter this report by account number 
if there is a specific account you want to look at.

Inspection Report
This report displays the vehicle reading data that is entered either in the Equipment Management Vehicle Readings 
window or from Mobile Tech. You can also print out the Inspection report if no data has been entered so that you can 
manually complete the inspection on the paper.
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Job Appointment Summary
The Job Appointment Summary Report is generated when a job appointment has been completed in MobileTech. This 
report displays the job, appointment, labor, inventory information, resolution note, and technician/customer 
signatures related to the completed appointment. This report is attached to the Job Cost Code and is automatically 
sent by email to the recipients who are designated in the MobileTech setup.

The Job Appointment Summary report only displays labor, expense, and travel information if entered by the 
technician assigned to the job appointment within MobileTech. If the information is entered outside of 
MobileTech or by another technician, the information will not display on the report.


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Job Safety Analysis
If you are using Resco Inspections, you have the option to use the Job Safety Analysis (JSA) inspection from the service 
and/or job appointment completion form in MobileTech. The inspection is tailored to ask specific questions about the 
site, to allow the Technician to identify hazards, and to document the steps they will take to remove risk. When the 
inspection is completed, a Job Safety Analysis report is generated as a PDF file and is attached to the service call on the 
device. When synced to Signature, the JSA is attached to the service call (for service appointments) or the job's cost 
code (for job appointments). This option is available with MobileTech 8.5 or higher.
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Job Safety Audit (2013)
Depending on the MobileTech setup, job safety audit (JSA) tasks might be available to help you assess the safety of a 
work location before you complete a service appointment in MobileTech.

Job safety tasks identify safety standards and potential risks and hazards. After a job safety audit is complete, you can 
create a Job Safety Audit report.
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Maintenance Contract Deferred Revenue
This report summarizes the amount of deferred revenue for a maintenance contract that uses the Revenue Schedule 
method of revenue recognition. You can compare the amount of revenue that has been recognized to the amount that a 
customer has been billed, as well as view revenue that will be recognized in the future. You can also compare the 
financial details of the contracts in this report to the balance in the General Ledger Deferred Revenue account during 
reconciliation. When a preventative maintenance invoice is generated, the Progress Billing or Deferred Revenue 
account is credited. The account is debited when revenue is recognized.

You can view these transactions by contract or account, and this report can be compared to GL activity on the Summary 
Inquiry window (Inquiry > Financial > Summary). If the Net Change for a GL account does not match the transaction 
detail on this report, the exception reports GL Transactions Not in Service and Service Transactions Not in GL can help 
you identify issues in Progress Billing accounts, as well as any account that is set up for any division in Maintenance 
Accounts setup. This report can only be printed from Report Manager or the Custom Reports list and can be filtered by 
date, customer, location, contract number, division, and contract status.

Maintenance Contract Invoice
This customer-facing report allows you to invoice maintenance contracts and master contracts.

Maintenance contract invoices summarize billing information, amounts, taxes, and totals for each invoice 
associated with the contract, as well as the contract total for all invoices.
Master contract invoices show the invoices and amounts for each maintenance contract assigned to the master 
contract, as well as the master contract total for all maintenance contracts. 
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If you have SRS reports set up to print from GP, this report can be printed from the Maintenance Invoicing window 
during the maintenance invoice creation process (Microsoft Dynamics GP > Tools > Routines > Service Management > 
Maintenance Contract > Create Invoices). The maintenance contract invoice is generated first, followed by any master 
contract invoices. The invoices that are generated can be filtered per a date range, a branch range, customer, address, 
and/or contract number.

Maintenance Contract Invoice 1 (page 27)
Maintenance Contract Invoice 2 (page 28)
Maintenance Contract Invoice 3 (page 29)
Maintenance Contract Invoice 4 (page 30)
Master Contract Invoice (page 31)

Maintenance Contract Invoice 1
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Maintenance Contract Invoice 2
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Maintenance Contract Invoice 3
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Maintenance Contract Invoice 4
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Master Contract Invoice

Maintenance Contract Profile
This report allows you to view a summary of a contract's invoice, billing, and revenue amounts over time. Contract 
amounts are broken down into categories, allowing you to view invoice, current billing, historical billing, current 
revenue, and historical revenue records and subtotals. You can also view contract totals. Select a division range to view 
the contracts in each division. Invoice, billing, and revenue amounts display for the contract by year.
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Maintenance Contract Profitability with Pull Through
You can use this report to analyze the profitability of a maintenance contract based on costs and revenue amounts per 
cost category. This report also includes revenue and costs for any billable calls that are assigned to a contract. These 
amounts display as "pull through." Maintenance contracts can be grouped by customer, bill to customer, salesperson, 
master contract, or technician team. You can select a Start Year and contract End Date to view the contracts in that 
range, or select a Contract Number to view. For each contract, open and historical profitability information is 
summarized by date; previous versions of renewed contracts display, allowing you to compare profitability over time. 
Selecting the expand button allows you to Open contract detail by call type, with contract totals at the bottom. You can 
then expand a call type to view service call detail, with call type totals at the bottom. Zooming on a service call opens 
the Service Call Cost Audit report.
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Maintenance Contract Quote Reports
This report compiles maintenance contract quote information such as costs, billing amounts, and hours, and provides a 
total of all quote amounts by cost code, along with individual quote totals, profit amounts, and task details including 
material requirements. This report can be used internally to view profit, or you can filter down to a single quote or 
customer, hiding internal information such as costs and hours, and print a quote to give to a customer. 
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To print, select a customer in Service Manager and use the Quote button to create a new quote or the Quote icon to 
open an existing quote. The Maintenance Contract Quote report is printed from the Contract Quote window. You can 
filter this report by customer, location, quote number, and quote expiration date. You can select whether you want to 
include estimated and calculated hours, billing amounts (including profit), estimated and calculated costs (including 
profit), and task details.

Maintenance Contract Quote Reports

Quote Summary 1 - Quote Summary Report (page 35)
Quote Summary 2 - Quote Summary Report with Estimated Costs (Dexterity) (page 36)
Quote Detail 1 - Quote Detail Schedule Report (page 36)
Quote Detail 2 - Quote Detail Report with Estimated Costs (Dexterity) (page 38)
Quote Detail 3 - Quote Detail Report with Estimated Hours (Dexterity) (page 40)

Quote Summary 1 - Quote Summary Report

Lists information from the Contract Quote window. The report includes the billing amount. 



36

Quote Summary 2 - Quote Summary Report with Estimated Costs (Dexterity)

Lists information from the Contract Quote window, including billing amounts, estimated costs and hours, and task-
based costs and hours.

Quote Detail 1 - Quote Detail Schedule Report

Lists information from the Contract Quote window, as well as billing amounts and the equipment and tasks attached to 
the quote. 
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Quote Detail 2 - Quote Detail Report with Estimated Costs (Dexterity)

Lists information from the Contract Quote window, including billing amounts, estimated costs and hours, and task-
based costs and hours. It also lists the equipment and tasks attached to the quote, as well as the cost estimates for the 
tasks.



39



40

Quote Detail 3 - Quote Detail Report with Estimated Hours (Dexterity)

Lists information from the Contract Quote window, including billing amounts, estimated costs and hours, and task-
based costs and hours. It also lists the equipment and tasks attached to the quote, as well as the estimated hours for 
the tasks.

Maintenance Contract Scheduled Materials
This report displays a list of the materials that will be needed to perform tasks for upcoming maintenance contract 
service calls. This is useful for purchasing planning; you can view the required materials by division, customer, or month 
and year, including quantities, so you know what inventory needs to be purchased. You must have task materials set up 
and tasks generated for a contract. The report will then show the materials that are needed to perform the tasks for any 
upcoming scheduled or unscheduled service calls within the specified date range.

If a maintenance contract is expiring and has not yet been renewed, no tasks will exist for that maintenance call, and 
the materials will not appear on the report. Materials only appear on the report if "Required = 1." Items that are not 
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required do not appear. This report can be printed from its location in the Report Manager, or from Microsoft Dynamics 
GP by opening the Administration page and locating this report on the Custom Reports list.

Maintenance Contracts Over or Under Billed
This report helps you identify contracts that are unbalanced before you recognize revenue. The report may be run prior 
to recognizing contract revenue at month-end.
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Maintenance Contract Statistics
This report shows monthly statistics for Preventative Maintenance service calls, per call type. This allows you to track 
costs for preventative maintenance. You can also view cost and revenue information by contract type, which allows you 
to keep track of margin percentage. This report shows service call costs, billed amounts, and revenue for the month to 
date, last month, and year to date, and contract type.
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Profit by Customer
The Profit by Customer SRS report can be printed detailing the profitability of all or specific service call types for one or 
all your customers. The service invoices must be posted for the call to be included in the report.

As service calls are completed and posted, this report displays the customer profitability based on up to five levels of 
detail and are displayed by choosing the expansion button:

Level 1: The report displays the profitability for each customer.
Level 2: The report can be expanded to show profitability for each location for each customer.
Level 3: The report can be expanded further to show the profitability for each division assigned to the location 
for each customer.
Level 4: The report can be further expanded to show each invoice for that customer location. 

Level 5: The report can be expanded one more time to show the cost transaction information for each invoice for 
that customer location. 

Contract Information
Profitability is based on recognized revenue, therefore for contracts, the supported recognition method is #2 – Revenue 
Schedule.

For contract information to appear on the report, the Call Types MC and/or MCC must be selected.
The data shown for the contract is based on the date range specified.
Because no invoice is tied to profitability, the Invoice information will show the contract number to sort the 
remaining information appropriately.
The Cost displays all the cost transactions posted during the date range specified. The roll-up will be the total of 
those transactions. Transactions which are billable only will not be included, for example, calculated trip 
charges based on extended pricing, as the report is based on recognized revenue. Purchase orders are displayed.
The Sales/Revenue will display all the revenue recognition journals posted during the date range. The Revenue 
total should be the total recognized for the contract during that date range.

To print the report:

Access the Profit by Customer report from the Report Manager.
Enter the following parameters for the report, as needed:

Start/End Dates: Specify the date range for the invoices to be included. The general ledger post date for 
the cost transactions may fall outside the specified date range but are shown to display the amounts that 
comprise the invoice amounts.
Sort by: Select to sort by customer name or ID.
Customer From/To: Select the range of customer by ID or name, depending on Sort by selection.
Call Type: Select the call type(s) to include in the report. 

This report is designed to work with simple grouping of costs from multiple service calls for a single customer 
at a single location. Results will be inconsistent with your actual invoice amounts on grouped invoices that 
contain multiple divisions.



Contracts are handled differently, see the Contract information section below for more information.

Contracts are handled differently, see the Contract information section below for more information.
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Recognized Revenue
The Recognized Revenue report summarizes the amount of deferred revenue for a maintenance contract that uses the 
Revenue Schedule method of revenue recognition. You can compare the amount of revenue that has been recognized 
to the amount that a customer has been billed up to the date that is entered in the report parameters. By expanding the 
contract line, you can view revenue and billed amounts recognized after the date entered in the report parameters. You 
can also compare the financial details of the contracts in this report to the balance in the General Ledger Deferred 
Revenue account during reconciliation. When a preventative maintenance invoice is generated, the Progress Billing or 
Deferred Revenue account is credited. The account is debited when revenue is recognized. You can view these 
transactions by contract or account, and this report can be compared to GL activity on the Summary Inquiry window 
(Inquiry > Financial > Summary). If the Net Change for a general ledger account does not match the transaction detail on 
this report, the exception reports GL Transactions Not in Service and Service Transactions Not in GL can help you 
identify issues in Progress Billing accounts, as well as any account that is set up for any division in Maintenance 
Accounts setup.

If the call type was changed at some point during the service call, only the current call type 
information will display. Historical information from previous call types will not display.


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To print the report:

Access the Recognized Revenue report from the Report Manager.
Enter the following parameters for the report, as needed:

Report Date: Specify the date to include only transactions that happen before or on the date of the 
report. Any transactions that happen after this date will not be included in the report.
Master Contract: Select a specific master contract or select All.
Customer Number: Specify a customer by ID select All.
Location: Specify a location or select All.
Show Detail: This defaults to No to display only one line per contract. You can select the expansion 
button to display the additional information on what comprises the total dollar amount for the 
Recognized Revenue and Billed Amount for the contract. To automatically expand the additional 
information, select Yes.

Refrigerant Tracking Leak Analysis
If you are using Refrigerant Tracking, you can print a report that displays the leak rate analysis. The report has a 
conditional box added to the bottom of the report to print when the equipment is a component of another piece of 
equipment. The message that displays is "This is a component of Master Equipment ID (xxxxxxxxxx) Description: 
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx". If the equipment is not a component, the box with comments does not display.

This report can only be printed from Report Manager and includes only Refrigerant Equipment Types 1-5. All other types 
(6 or higher) are excluded from this report. See Refrigerant Tracking6.

https://docs.key2act.io/display/1805b07/Refrigerant+Tracking
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Refrigerant Tracking List
If you are using Refrigerant Tracking, you can print a report that displays all refrigerant tracking records. This report can 
only be printed from Report Manager. Also included in this report are the new Section 908 EPA fields required for leak 
rate tracking including the refrigeration equipment type, maximum allowed leak rate, and the actual leak rate. The 
refrigerant tracking records on this report can be filtered by Customer, Location, Equipment ID, Cylinder Number, or 
Circuit Number. You can also select to display voided records, and filter the list of records by date. The report has a 
conditional box added to the bottom of the report to print when the equipment is a component of another piece of 
equipment. The message that displays is "This is a component of Master Equipment ID (xxxxxxxxxx) Description: 
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx". If the equipment is not a component, the box with comments does not display.
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Refrigerant Tracking Report
If you are using the refrigerant tracking feature, this report allows you to view refrigerant usage and leak information for 
equipment on a service call. This report contains information such as the certification number required to perform 
work, the equipment and leak or fault, and information about the work performed. The report includes new leak rate 
information such as the refrigeration equipment type, maximum allowed leak rate, and actual leak rate. The report 
indicates if the actual leak rate percentage exceeds the maximum leak rate percentage. In Report Manager, enter a 
Reference ID to print the report. The report has a conditional box added to the bottom of the report to print when the 
equipment is a component of another piece of equipment. The message that displays is "This is a component of Master 
Equipment ID (xxxxxxxxxx) Description: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx". If the equipment is not a component, the 
box with comments does not display.

This report can also be printed after creating a record on the Refrigerant Tracking window (Cards > Service Management 
> Service Manager > Customer > Service Call > Refrigerant Tracking button). You can also print this report from Microsoft 
Dynamics GP by opening the Administration page and locating this report on the Custom Report List.
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Resource Schedule
The Resource Schedule report can be printed for a specific resource or you can print this for multiple technicians. This 
report is printed from Schedule and you can also print this from the SSRS server.

From Schedule:

The Resource Schedule report can be printed for a specific resource or you can print this for multiple technicians.

Right-click on a resource name from the schedule board.
Select Print Resource Schedule and then select Schedule_Resource_Report_1.
A new tab is opened in your browser displaying the resource's schedule for the day.
If you want to see a range of dates, you can edit the Start/End Dates at the top of the report.
You can also select more than one technician from the Technician drop-down.
Select View Report.
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Sales Tax - Material Purchases
This report allows you to view material costs and tax details for service calls by division. Select a date range to view a 
list of service calls with the total document amounts, as well as a breakdown of the subtotal, tax, and material cost 
amounts. You can also view the tax schedule for each service call. This report includes division totals for material cost.
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Schedule Technician Board
The Schedule Technician Board report displays in table format and is available from the Report Server only. Schedule is 
required to view this report. The table displays the technician's name, day/date, and any relevant appointment 
information including service appointment ID, job ID, and/or activity, customer ID, and estimated hours. 

Report options include:

Start Day: This defaults to the current date.
Show Technicians with No Appointments: Defaults to No. Select Yes to show all technicians.
Enable Schedule Colors: Defaults to True. Schedule colors are set up in Schedule > Settings > Colors.
Hide Weekends: Defaults to No. Select Yes to only show weekdays.
Hide Estimated Hours: Defaults to No. Select Yes to hide the estimated hours on the report.
Technician: Defaults to the technicians currently on the schedule board in Schedule.
Technician Team: Defaults to the technician team(s) associated with the technicians.
Skill Level: Defaults to the skill level(s) associated with the technicians.
Hide Unscheduled: Defaults to True. Select False to show unscheduled appointments.
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Service Call Analysis - Unbilled Quotes
This report allows you to view unbilled QTE service calls, and the estimate cost amounts that are yet to be billed. Enter 
a date range to view a list of service call quotes with unbilled amounts. You can view the estimated cost, total cost, and 
amount billed for each service call, as well as total sale, percent complete, and accrued amount.
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Service Call Analysis - Unbilled T&M
This report allows you to view unbilled T&M service calls, and the amounts that are yet to be billed. Enter a cutoff date 
to view unbilled T&M service calls up to that date, listed by division. You can view the total cost and total billable 
amount for each service call, as well as division subtotals and report totals.

Service Call Cost Audit
This report shows all the costs that have been associated with a service call. You can see the total amounts by cost 
category, or expand the category to view all the transactions associated with that cost. The invoiced status also appears 
next to each transaction to provide you with information about which costs have been billed.
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Service Call Cost Reconciliation
This WIP report allows you to review the debits, credits, and extended costs in your WIP and COGS accounts, along with 
a summary of the debits and credits in the accounts for each contract. The Service Reconciliation report can be run as 
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part of the month end closing process, to reconcile the amounts posted to your Progress Billings accounts and Service 
WIP accounts. Refer to the user manual for more information on using WIP reports at month's end.

To print, select Reports > Service Management > Service > WIP Reports.
On the Service WIP Reports window, mark the Reconcile Report radio button, and select to print the report in 
summary. (To see the report in detail, go to Service Call Cost Reconciliation by Account (page 55).)

You can filter account and contract totals by division, customer, and location; you can also select a specific account 
and/or division to view. 

Service Call Cost Reconciliation by Account
This WIP report allows you to review the debits, credits, and extended costs in your WIP and COGS accounts, along with 
a summary of the debits and credits in the accounts for each contract. The Service Reconciliation report can be run as 
part of the month end closing process, to reconcile the amounts posted to your Progress Billings accounts and Service 
WIP accounts. Refer to the user manual for more information on using WIP reports at month's end.

To print, select Reports > Service Management > Service > WIP Reports.
On the Service WIP Reports window, mark the Reconcile Report radio button, and select to print the report in 
detail. (To see the summary report, go to Service Call Cost Reconciliation (page 54).)

You can filter account and contract totals by division, customer, and location; you can also select a specific account 
and/or division to view. 



56

Service Call Gross Profit
This report allows you to view a breakdown of profitability information for the transactions on a service call. For each 
cost code, you can view the transactions associated with the call and the billing amounts, total cost, expected gross 
profit, billed amount, and gross profit/loss to date for that transaction. You can also view subtotals by cost code and 
report totals for the entire service call.
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Service Call Invoices
This customer-facing report is used to detail an invoice or credit memo for a service call, including a cost breakdown 
and detail of charges. 

You can print this report either individually or by batch, for current or historical invoices and credit memos, from the 
following windows:

Service Invoice: Print an open or closed invoice individually
Receivables Batch Entry: Print invoices by batch.
Posted Service Invoice: Print a posted invoice individually.
Print Service Batch Invoices: Print multiple invoices in a batch.

Once all costs have been added to an invoice, you can print the invoice. Invoices can be printed individually or by 
batch. 

If you enter a billing note in the Document Number field, and mark it as Printable, the note will appear on the invoice 
next to Service Performed.

A Description will also display on the invoice if one is entered on the main invoice entry window.

If you want tax details to print on the job invoice, you must mark the Print Tax Details on Documents checkbox on the 
Receivables Management Setup window. Microsoft Dynamics GP > Tools > Setup > Sales > Receivables.

Invoices

Invoice 1 - Service Call Invoice Summary (page 58)
Invoice 2 - Service Call Invoice Detail (page 60)
Invoice 3 - Service Invoice Summary - Multi Currency (page 62)
Invoice 4 - Service Invoice Detail - Multi Currency (page 64)
Invoice 5 - Service Invoice Summary (Dexterity) (page 66)
Invoice 6 - Service Invoice Summary (Dexterity) (page 67)
Invoice 7 - Service Invoice Totals (Dexterity) (page 67)
Invoice 8 - Service Invoice Detail (Dexterity) (page 68)
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Invoice 1 - Service Call Invoice Summary

Only cost fields with costs entered are shown.
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Invoice 2 - Service Call Invoice Detail

This invoice is similar to the first format except the itemized costs are double-spaced.
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Invoice 3 - Service Invoice Summary - Multi Currency

The invoice description is printed below the "Description of Work Done" subtitle. If the Signature Multicurrency 
Management module is registered, invoice 3 is modified to print the originating amounts if your transaction is in the 
originating currency. If your transaction is in the functional currency, invoice 3 will print the functional amounts. 
Multicurrency amounts do not print when batch printing.
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Invoice 4 - Service Invoice Detail - Multi Currency

This is a two-page invoice. The invoice description is printed below the "Description" subtitle. If no cost was added for a 
cost category, $0.00 is listed. The second page lists the tax detail for each cost category, the total tax, and total invoice 
amount If the Signature Multicurrency Management module is registered, invoice 4 is modified to print the originating 
amounts if your transaction is in the originating currency. If your transaction is in the functional currency, invoice 4 will 
print the functional amounts. Multicurrency amounts do not print when batch printing.



65



66

Invoice 5 - Service Invoice Summary (Dexterity)

The invoice description prints in the center of the invoice. Below the description are the cost totals without descriptions 
for equipment, material, labor, subcontractor, and other costs. If no cost was added for a cost category, $0.00 is listed 
for that category. The comments are double-spaced below the total sales tax and invoice total.
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Invoice 6 - Service Invoice Summary (Dexterity)

The invoice description prints in the center of the invoice. Below the description are the cost totals without descriptions 
for equipment, material, labor, subcontractor, and other costs. If no cost was added for a cost category, $0.00 is listed 
for that category. The comments are double-spaced below the total sales tax and invoice total.

Invoice 7 - Service Invoice Totals (Dexterity)

This invoice format omits the individual cost totals and prints just the total sales tax and total invoice amounts.
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Invoice 8 - Service Invoice Detail (Dexterity)

This invoice style subtotals on cost codes. Labor also subtotals by job title and pay code.
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Service Call Maintenance Workorder
This report describes the work that is to be done for a scheduled maintenance service call. When MCC calls are 
generated for a month, you can print this report to view service call details, including hour estimates and required 
equipment, materials, and tool kits. When work is performed on site, tasks and subtasks can be marked as complete. If 
SRS reports are set up to print from GP, this report can be printed from the Maintenance Tasking window during the call 
creation process (Microsoft Dynamics GP > Tools > Routines > Service Management > Maintenance Contract > Create MCC 
Calls). This report replaces the Scheduled Maintenance Dexterity report. In Report Manager, you can select the year and 
month that you want to view MCC calls for. Calls can be filtered by a customer range, a technician range, location, or 
contract number.
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Service Call Quote
The Service Call Quote report compiles service call quote information such as costs, billing amounts, and hours, and 
provides a total of all quote amounts by cost code, along with individual quote totals, profit amounts, and task details 
including material requirements. This report can be used internally to view profit, or you can filter down to a single 
quote or customer, hiding internal information such as costs and hours, and print a quote to give to a customer. You 
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can filter this report by customer, location, quote number, or quote expiration date. You can select whether you want to 
include estimated and calculated hours, billing amounts (including profit), estimated and calculated costs (including 
profit), and task details. This report is printed from the Report Manager.

Service Call Revenue Statistics by Call Type
Shows revenue, total cost, number of service calls, and amounts billed for each service call type. Also shows these as 
percentages for each type compared to the total number of calls that month. This allows you to keep track of margin 
amount and margin percent.
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Service Call Statistics by Call Type
This report shows a count of the total, open, completed, and closed calls per call type for Preventative Maintenance call 
types, call types with quotes, and all other call types. These statistics are also shown as percentages for each type 
compared to all calls that month. This allows you to track the progress of each call type for the month.
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Service Call Status
This report displays unposted, committed and actual costs as well as anticipated billable information. The costs 
displayed are all costs for the service call, not for a specific invoice. Margin information is also displayed although tax 
information is not included. Use the Service Call Status window also provides zoom capability to the cost categories 
and cost types for the service call.  To print this report, go to Inquiry > Signature Service Management > Service Call 
Status.

Service Call Status Statistics
This report shows the number of service calls by call status for the last week, last two weeks, month to date, and year to 
date. Sorting service calls per status allows you to track progress over time. You can also see the average days open to 
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complete and complete to invoiced for the month to date, last month, and year to date.

Service Call Vendor Quote
This report is  sent to a vendor when you are requesting a quote to be returned based on the tasks assigned to the 
service call. The Vendor Quotation Request information is not stored in the system. This report is accessed by selecting 
the Vendor Quotation button in the Service Call window.



7 https://docs.key2act.io/display/1805b07/Printing+a+Workorder
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Service Call Workorders
You can print a workorder from the Service Call window by either choosing the Print button or the Quick button. If you 
select Print, you can select one of five workorder formats. The Quick button prints your workorder, in one step, in the 
format specified during setup in the Service Options window. The report prints directly to the printer. For more 
information, see Printing a Workorder7.

Select Cards > Service Management > Service Manager.
Select a customer and open a service call.
Do one of the following:

If the call has a call type other than MCC, select Print and select a workorder format.
If the call has an MCC call type, select Print > Workorder and select a workorder format.

Select a print destination.

Workorders
The following report examples also include the two Dexterity workorder reports (not available on the SSRS server).

Workorder 1 - Service Call Work Order (page 77)
Workorder 2 - Service Call Work Order with Appointments (page 78)
Workorder 3 - Service Call Work Order with Tasks (page 79)
Workorder 4 - Workorder with Tasks (Dexterity Report) (page 81)
Workorder 5 - Workorder with Appointments (Dexterity Report) (page 81)

https://docs.key2act.io/display/1805b07/Printing+a+Workorder
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Workorder 1 - Service Call Work Order
Workorder 1 breaks down key service call information. Technicians can quickly see the date and time a service call was 
received. This report lists the service call ID and invoice number along with brief service call details and the customer's 
address. The contact name, email address, and telephone number also included.
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Workorder 2 - Service Call Work Order with Appointments

Workorder 2 is useful for salespeople. It could be stored in your customer's file. It lists the customer's billing address, 
service call location, salesperson information, and service call details. The contact name, email address, and telephone 
number also included.
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Workorder 3 - Service Call Work Order with Tasks

Workorder 3 is a T-card, combining service call information with customer billing information. The contact name, email 
address, and telephone number also included.
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Workorder 4 - Workorder with Tasks (Dexterity Report)

Workorder 4 includes task detail with the service call information. The contact name, email address, and telephone 
number also included.

Workorder 5 - Workorder with Appointments (Dexterity Report)

Workorder 5 includes appointment detail with the service call information. The contact name, email address, and 
telephone number also included.
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Service Invoice Summary
The Service Invoice Summary report is generated from the Print Service Invoices window. (Microsoft Dynamics GP > 
Tools >Routines > Service Management > Service > Print Service Invoices ) This report prints a summary of the invoices 
associated with a Service Invoice Summary Number. Each invoice is printed in a linear style and includes the service call 
invoice number, service call, call description, purchase order number, customer name, location, completion date, 
billable equipment total, billable material total, billable labor total, billable subcontractor total, billable other, subtotal, 
tax and line total. At the end of the report, the totals for the included service invoices are summarized by cost code.
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In the example below, two invoices are associated with the same Service Invoice Summary Number.
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Service Invoice Trailing Costs
This WIP report prints trailing costs by division and service call. For each service call, you can view actual and 
committed costs at invoice time, the trailing cost after invoicing, and the committed cost remaining, along with division 
totals and totals for the whole report. The detailed invoice shows additional service call and transaction details. The 
Service Invoice Trailing Costs report can be run as part of the month end closing process, to help identify the committed 
costs that remain unposted after a service invoice is posted for a closed service call. Refer to the user manual for more 
information on using WIP reports at month's end.

To print, select Reports > Service Management > Service > WIP Reports.
On the Service WIP Reports window, mark the Trailing Cost and PPV radio button to print this report (along 
with the Service Invoice Trailing PPV Costs report), then select whether you want to print the summary or 
detailed version of this report.

You can filter this report by division and account number.

Summary (page 85)
Detail (page 86)

Summary
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Detail

Service Invoice Trailing PPV Costs
This WIP report lists trailing PPV costs by service call and identifies the transaction number, GL posting date, and cost 
code of each trailing PPV cost. Service calls are arranged by division, allowing you to view both service call and division 
totals, as well as trailing PPV cost totals for the entire report. The Service Invoice Trailing PPV Costs report can be run as 
part of the month end closing process to help identify the trailing costs that remain due to a purchase price variance 
(PPV) that appeared on a receipt. Refer to the user manual for more information on using WIP reports at month's end.

To print, select Reports > Service Management > Service > WIP Reports.
On the Service WIP Reports window, mark the Trailing Cost and PPV radio button to print this report (along 
with the summary or detailed Service Invoice Trailing Costs report).

You can filter this report by division and account number.
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Service Profitability
This report allows you to view profitability information for your service calls. You can view the quoted cost, cost, billed, 
profit, and markup percentage amounts for each service call, as well as subtotals and report totals. The detailed version 
of this report also displays actual costs and billing amounts for each cost code. This report can be grouped twice, by 
branch, division, call type, problem type, salesperson, primary technician, customer, bill to customer, or quote type. 
The subtotals that display are for the groups that you select. This report can also be filtered by the above criteria. You 
can select to show or hide details and service calls with zero amounts.

Summary (page 88)
Detail (page 89)
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Summary
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Detail

Service Revenue Recap
This report allows you to view revenue amounts by division and call type. You can view costs by category, the total cost, 
and the margin amount and percent for each call type in a division. Additionally, subtotals display for each division, and 
report totals summarize all revenue for the divisions displayed on the report.
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Service Transactions Not in GL
This WIP report shows transactions that have been posted to your Service accounts but were not posted to the GL. 
Transactions are grouped by customer and location, with the debit and credit account and extended cost listed for each 
transaction. Report totals are included, along with totals for each customer and location. The Service Transactions Not 
in GL report can be run as part of the month end closing process, to help identify the costs that have been posted in 
Service Management but have not been posted to the GL. Refer to the user manual for more information on using WIP 
reports at month's end. To print, select Reports > Service Management > Service > WIP Reports. On the Service WIP 
Reports window, mark the Exception Reports radio button, then mark the Service Costs Not in GL radio button. This 
report can be filtered by division, customer, location, and/or account number.
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Service WIP
This report prints service WIP account totals, allowing you to view unbilled service work and open maintenance calls. 
Service call billing amounts and costs are grouped by contract, then totaled by category for each contract. These 
contract totals are grouped by division, allowing you to review the service division account totals, as well as category 
totals for the entire report. The Service WIP report can be run as part of the month end closing process, to help ensure 
that your Service WIP accounts balance with the General Ledger WIP accounts. Refer to the user manual for more 
information on using WIP reports at month's end.

To print, select Reports > Service Management > Service > WIP Reports.
On the Service WIP Reports window, mark the WIP Report radio button, and select whether you want to print 
the report in summary or in detail.

You can filter this report by division, customer, location, account number, and contract.

Summary (page 92)
Detail (page 93)
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Summary
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Detail
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Technician Forecast
This report allows you to view a technician's forecasted appointments for a specified period, including service call 
information and estimated hours. Only forecasted calls show on this report; calls that have been closed or marked as 
complete do not appear. You can filter this report by technician and/or technician team; appointments are organized by 
technician team, then by technician and date. If no primary technician is assigned to a scheduled service call, that call is 
listed as Unassigned and is visible only when viewing All technician teams. If you wish to view only a summary of 
scheduled days and hours, you can use the collapse button next to a technician's name to hide service call detail.
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Top and Bottom Customers by Sales
This report shows the total sales amount and costs for the top and bottom customers in terms of sales, as well as each 
customer's percent of the company's total sales and costs. This allows you to track the top and bottom X number of 
customers, in terms of total sales amount, for a specific date range.

Top Technicians by Billed Hours
This report identifies the top technicians in terms of billed hours and summarizes those hours for a specified week, the 
previous week, the last two weeks, month to date, and year to date. This allows you to keep track of the top technicians 
in terms of billed hours, each technician's percent of the company's total year-to-date hours, and their total hours 
billed and unbilled over time.
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WIP SSRS reports
GL Not Match Service (page 17)
GL Transactions Not In Service (page 18)
Service Call Cost Reconciliation (page 54) (Summary)
Service Call Cost Reconciliation by Account (page 55) (Detail)
Service Invoice Trailing Costs (page 85) (Summary and Detail)
Service Invoice Trailing PPV Costs (page 86)
Service Transactions Not in GL (page 90)
Service WIP (page 91)

Job Cost SSRS Reports

Application for Payment
Contractors can use this report to apply for payment due, with architect certification, for jobs that use User Defined, 
Cost Code, and Project Bill Code billing types. To print on this report, change order bill codes must be added through 
the Change Order window. Change order bill codes that were added through Job Maintenance, as well as unposted 
change orders or change orders that were posted after the printed date of the invoice, do not appear on this report. This 
report can be printed at the job or project level for invoices that are open or that have already been posted, either 
individually or by batch, from the following windows:

Job Invoice Entry
Print an open job invoice individually.
Job Invoice Zoom
Print a posted job or project invoice individually
Project Invoice
Print an open project invoice individually.
Receivables Batch Entry
Print job and/or project invoices by batch.
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AR Retention Trial Balance
Displays the Job Number, Document Number, Document Type, Document Date, GL Post Date, Billed Amount, 
Document Subtotal, Retention Amount, Retention Billed and Net Retention by Division and Job Number.
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Closed Jobs
Prints a listing of jobs that were closed based on the Posting Date and any filter criteria. This report is printed from the 
new Job Close window (Microsoft Dynamics GP > Tools > Routines > Job Cost > Close Jobs).
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Custom SSRS Job Cost Reports
You can add up to four custom open job SSRS reports to display in the Print drop-down in the Job Maintenance and Job 
Status window. You can also add up to four custom history job SSRS reports in the Job History window.

We've added eight report placeholders in WSReports:

Open Job Cost Reports

JC Job Custom Report 1
JC Job Custom Report 2
JC Job Custom Report 3
JC Job Custom Report 4

History Job Cost Reports

JC Job History Custom Report 1
JC Job History Custom Report 2
JC Job History Custom Report 3
JC Job History Custom Report 4

For the custom report(s) to show in the Print drop-down, you need to add the Report Server URL in the ReportLocation 
field. The report name that displays in the Print drop-down is parsed from the URL string.

In order to take advantage of mapping custom reports from the Print drop-down on the Job Maintenance, Job Status, 
or Job History windows and have the Job Number parameter value passed to the report properly, you will need to have 
the Job Number parameter named “JobNumber” in the custom report.  If you do not use the job number parameter, 
you will have to pick the parameters when SRS Viewer comes up.

GL Not Match Job Cost
This WIP report allows you to identify discrepancies between journal entry amounts in the General Ledger and in Job 
Cost when you are posting to the GL in summary. You cannot compare amounts at the transaction level when you are 
posting one GL journal per batch; instead, you can use this report to compare the sum of all transactions in the batch 
from Job Cost to the GL journal entry amount. This report can be printed from its location in the Report Manager, or 
from Microsoft Dynamics GP by opening the Administration page and locating this report on the Custom Reports list. 
You can filter the report by account number or view all accounts for the specified date range.

If you have a report that can print either an Open or Closed job, you may want both “JC Job Custom Report 1” 
and “JC Job History Custom Report 1” to print the same report.


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GL Transactions Not in Job Cost
This WIP report shows transactions that have been posted to the General Ledger but have not been posted in Job Cost. 
You can view debit and credit amounts for each transaction by account, including account totals and grand totals for 
the report. The GL Transactions Not in Job Cost report can be run as part of the month end closing process, to help 
identify costs that have been posted to the GL but not in Job Cost. Refer to the user manual for more information on 
using WIP reports at month's end. To print, select Reports > Job Cost > Job Reports > Audit Reports > Job WIP Reports. On 
the JC WIP Reports window, mark the Exception Report radio button, then select GL Not in Job Cost. You can filter this 
report by account number.
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Job Analysis
This report allows you to analyze job information such as hours, costs, estimates, forecasts, and cost to complete. You 
can print a summary of job totals and subtotals per cost element, or you can print the detailed version of this report, 
which analyzes totals for each cost code. Select a value in the Project drop-down to enable the Job selection field and 
filter the jobs that display in the drop-down list. A blank selection in the Project filter displays all jobs, while choosing All
projects filters out any job that is not assigned to a project, and displays all project-related jobs. Selecting a project 
allows you to select from the jobs assigned to that project. The job selection menu can also be filtered by customer, 
division, and/or project manager. You can select a single job, multiple jobs, or all jobs from the Job filter.

Summary (page 105)
Detail (page 106)
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Summary
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Detail

Job Audit Billing
This report allows you to view contract amounts, billing amounts, and costs for an open job. You can also view 
transaction-level billing information including contract billed, amount due, retention withheld, and retention 
billed. You can filter the jobs that print on this report by job, customer, project, project manager, or division. Select a 
sort method in the Summarize By field to enable the appropriate drop-down filter. If you are summarizing by job, you 
can select all, one, or multiple jobs from the list of all open jobs in the Job filter. If you select a different sort option, the 
report prints all open jobs assigned to the customer(s), project(s), project manager(s), or division(s) that you specify in 
the appropriate drop-down filter.
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Job Audit Costs
This report shows cost transactions from all sources for a job, which allows field and accounting personnel to identify 
errors in cost transactions and/or understand cost sources for a job. Transactions can be sorted by cost code segment; 
you can also expand or collapse details and filter the report by PM, Customer, Division, Phase, and Step. You can also 
select to hide sensitive payroll hours and/or transactions, even as they are included in the summary totals.
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Job Change Order
This customer-facing form compiles information from the Job Customer Change Order window, including Bill Codes 
and an expanded scope of work description. By providing information from the Job Cost change order windows, this 
form reduces the effort needed to create a change order request for a general contractor or customer.
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Job Closing Preparation
This report shows which jobs may be ready for closing based on either percentage complete or a lack of GL postings 
over time. This helps you identify unposted costs and any other items that may need to be taken care of before a job 
can be closed. You specify the jobs that appear as ready for closing based on the date of the last GL post, the last billing 
date, the estimated percentage complete, and/or the actual percentage complete. You can also filter the report by Job 
Status and/or Job Number and sort the report by job then division, or division then job.
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Job Committed Costs
This report allows you to view the total outstanding amounts from saved purchase orders, sales orders, and sales 
invoices. The report also provides quantity and amount cost code details for ordered, back ordered, received, invoiced, 
and billed items. You can view committed costs by job, project, or project manager, including cost code and cost 
element totals and subtotals for jobs, and totals for projects.
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Job Cost Transactions Not in GL
This report shows transactions that have been posted in Job Cost but have not been posted to the General Ledger. You 
can view the amounts in your job accounts for each job transaction per division, including cost element and division 
totals. The Job Cost Transactions Not in GL report can be run as part of the month end closing process, to help identify 
costs that have been posted in Job Cost but not to the GL, for example, if you have posted to the GL but have not yet 
posted the GL batch. Refer to the user manual for more information on using WIP reports at month's end. To print, 
select Reports > Job Cost > Job Reports > Audit Reports > Job WIP Reports. On the JC WIP Reports window, mark 
the Exception Report radio button, then select Job Cost Not in GL. You can filter this report by division, job number, 
cost element, and account number.
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Job Invoice
This customer-facing report is used to detail an invoice or credit memo for a job, including a cost breakdown and detail 
of charges. This report can include bill code- or transaction-level detail and replaces the Dexterity-based job invoice 
reports Graphic Invoice, Text Invoice, Cost Elements, Tax Detail Inv, and Detail Billing. You can print this report for 
invoices either individually or by batch, for current, posted, or historical (closed job) invoices and credit memos, from 
the following windows:

Job Invoice Entry: Print an open job invoice individually
Job Invoice Zoom: Print a posted job or project invoice individually.
Project Invoice Entry: Print an open project invoice individually.
Receivables Batch Entry: Print job and/or project invoices by batch.

If you enter a billing note in the Document Number field, and mark it as Printable, the note will appear on the invoice 
next to Service Performed. A Description will also display on the invoice if one is entered on the main invoice entry 
window. If you want tax details to print on the job invoice, you must mark the Print Tax Details on 
Documents checkbox on the Receivables Management Setup window. Microsoft Dynamics GP > Tools > Setup > Sales > 
Receivables. The cost element summary prints when you select the Cost Elements Job Invoice.

Invoice Examples

Cost Elements Invoice (page 113)
Graphic Invoice (page 116)
Graphic Invoice 2 (page 118)
Text Invoice (page 120)
Text Invoice 2 (page 122)
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Tax Detail Invoice (page 124)

Application for Payment (page 98) (link to separate topic)
Project Invoice (page 140) (link to separate topic)

Cost Elements Invoice
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Graphic Invoice
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Graphic Invoice 2
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Text Invoice
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Text Invoice 2
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Tax Detail Invoice



124



125

Job Lien Waiver
You print this report as part of the check posting process in Microsoft Dynamics GP. Completed lien waivers are 
generated only for payables documents that are fully applied. If a payable has been processed but is not fully applied, a 
blank lien waiver prints. Printing lien waivers can be restricted for specific cost codes. If you have reports set up to print 
from GP, this report prints after processing and printing checks as you normally would (refer to the Microsoft Dynamics 
GP Payables Management documentation for more information). When the check processing is finished, the Print Lien 
Waivers window opens.

You can also mark a lien as received or view or reprint this report from the Manage Lien Waivers window (Cards > Job 
Cost > Job > Master Subcontractor > Manage Lien Waivers).

If checks are posted using series posting or master posting, the Print Lien Waivers window does not appear.
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Job Percentage of Completion
This report allows management and project managers to view totals and Year-to-Date and Month-to-Date summaries 
for all fields related to Percentage of Completion. This report helps tie WIP, COGS, Progress Billings, and Sales 
subledgers to GL balances and activity, as well as performance indicators such as Contract Backlog, Earned Margin, 
Future Margin, Cost to Complete, Under-Billed, and Billed in Excess of Earned. Users can view combinations of Active, 
Inactive, and Closed jobs for a period, sorted and subtotaled by Job, PM, or Division. Senior managers can view the 
details for each job in the period or display subtotals only.

Job Plan
This report allows you to view the job plan information including: Job number, description, divisions, scheduled start 
dates, scheduled completion dates, calculated % complete, as well as the following cost code information: estimated 
hours, actual hours, estimated remaining hours, scheduled appointment hours, unposted TimeTrack hours, remaining 
less scheduled hours. Scheduled Hours are a sum of the hours found in open appointments for the schedule range (6 
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wks from the Schedule Start date parameter) included on the report. Unposted TT Hours are the sum of hours from 
these tables: Uncommitted (WS10702) and Committed / Not Posted (JC10701).

You can include a Gantt-style schedule that displays a row for each job and lists the scheduled hours for each day, 
starting on the Schedule Start date and extending for six weeks.

If you are printing this by:

Division
Each division starts on its own page and has division totals at the end of each section.
Job Number
Each job number starts on its own page and has job totals at the end of each section.

The Job Plan report is available from the Report Server under Signature Job Cost. 

Print by Division (page 129)
Print by Job Number (page 129)
Schedule (page 129)

Print by Division
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Print by Job Number

Schedule
The Schedule displays to the right with a row that includes the scheduled hours for each cost code for the job. The 
screenshot below does not show the entire 6-weeks. The starting date correlates with the Schedule Start Date entered 
in the report parameters.

Job Profit and Loss
This report allows you to view revenue and cost incurred on a job, as well as profit and loss over a specific period of 
time. You can view profit and loss for all jobs, all open jobs, open and active jobs, open but inactive jobs, all inactive 
jobs, and closed jobs. This report includes information for both open and closed periods. The information on this report 
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can be summarized by job or project (Master ID), Customer, Project Manager, or Division. Your selection in the 
Summarize By field enables the appropriate filter. You can also specify a date range by selecting a start year and period 
and an end year and period. By default, the report returns results from the first fiscal year and period set up in Job Cost 
to the last fiscal year and period set up in Job Cost.

Summarized by Job (page 131)
Summarized by Customer (page 131)

The fields on the report are calculated as follows:

Actual % Complete: Actual Cost / Total Forecasted Cost
Expected Contract: For Fixed Amount jobs - based on the last day in the end period (end date) of the report. For 
Cost Plus jobs: Based on the range from the start date of the report to the end date of the report. 

Contract Earned: Actual % Complete x Expected Contract
Profit Amount: Contract Earned - Actual Cost
Markup Percent: (Expected Contract - Total Forecasted Cost) / Total Forecasted Cost
Margin Percent: (Expected Contract - Total Forecasted Cost) / Expected Contract

Summarized by Job

If you are viewing a Cost Plus job that began prior to the report start date, the Contract Earned amount 
is adjusted to reflect what was earned in the report range, rather than over the life of the job. For Cost 
Plus NTE jobs, the Contract Earned displays as zero if the NTE amount is exceeded prior to the report 
start date.


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Summarized by Customer

Job Profit and Loss Key Performance Indicator
This Key Performance Indicator (KPI) report allows you to visually depict the contract earned and profit amounts of the 
top earning jobs based on profit amount. You specify the sorting option, for example, job or customer, and the number 
of entities you would like to view, for example, top five jobs or top ten customers, for a specified period of 
time. Selecting on any of the bars opens the Job Profit and Loss report for this date range, which allows you to view 
numbers and more specific details for a job.

To view KPI reports, you must be running SQL Server Reporting Services 2008 R2 or higher.
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Job RPO Profit and Loss
The purpose of the RPO - Billing Profitability report is to provide a job-level view of the summary data "AS OF" a certain 
closed period for RPO jobs that have been recognized or billed. Only RPO revenue recognition method jobs are included 
and those RPO jobs that have summary data for the Closed Period.  RPO jobs without recognized revenue or billing to 
date will not show up on this particular report. Data is coming from JC20003 (Open Jobs), JC30003 (Closed Jobs), 
JC20008 (Open Jobs), JC30008 (Closed Jobs), JC00102, and JC30001.

Job % Comp = Revenue Recognized / Job Expected Contract
Job Expected Contract = The Job's Expected Contract Amt (Total)
Revenue Recognized = The amount of Revenue Code revenue recognized total to date through the closed 
period indicated.
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Jobs Available to Close
Prints a listing of jobs available to close based on the Posting Date and any filter criteria. This report lists the create 
date, manager, contract amount, actual cost, markup percent, billed amount, cash received, and contract earned 
amounts for all jobs you can close. This report is printed from the Job Close window (Microsoft Dynamics GP > Tools > 
Routines > Job Cost > Close Jobs).

Job Schedule by Cost Code
This report allows you to view the job information including: Job number, customer, bill to customer, project manager, 
project number, division, contract type, job address ID, bill to address ID, job start date, job completion date, project 
management percentage complete, and job status.

Also included are the job's cost code information including: the cost codes and descriptions, status, start and 
completion dates, estimated hours, actual hours, estimated remaining hours, scheduled appointment hours, unposted 
TimeTrack hours, remaining less scheduled hours. Each job's total hours are displayed beneath the job. The end-of-
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report footer includes hour totals for all jobs included in the report. Scheduled Hours are a sum of the hours found in 
open appointments for the schedule range (6 wks from the Schedule Start date parameter) included on the 
report. Unposted TT Hours are the sum of hours from these tables: Uncommitted (WS10702) and Committed / Not 
Posted (JC10701).

The Job Schedule by Cost Code report is available in Schedule by right-clicking on a job in the Job Panel. 

Print by Job Number (page 135)
Print by Division (page 135)
End-of-Report Footer (page 135)
Schedule (page 135)

Print by Job Number
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Print by Division

End-of-Report Footer

Schedule
The Schedule displays to the right with a row that includes the scheduled hours for each cost code for the job. The 
screenshot below does not show the entire 6-weeks. The starting date correlates with the Schedule Start Date entered 
in the report parameters.
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Jobs Not Available to Close
Prints a listing of jobs available to close based on the Posting Date and any filter criteria. This report is printed from the 
Job Close window (Microsoft Dynamics GP > Tools > Routines > Job Cost > Close Jobs).

Job WIP Reconciliation
This WIP report shows the amounts in your Job Cost division accounts for each cost element and includes division 
totals. The detailed report also shows a breakdown of job transactions for each cost element. The Job WIP 
Reconciliation report can be run as part of the month end closing process, to reconcile the amounts posted to your 
service WIP accounts. To print, select Reports > Job Cost > Job Reports > Audit Reports > Job WIP Reports. On the JC WIP 
Reports window, mark the WIP Report , then select whether you want to print the report in summary or in detail. You 
can filter this report by division, job number, cost element, and account number.

Summary (page 137)
Detail (page 138)
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Summary
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Detail

Payables Aged Trial Balance
The Payables Aged Trial Balance report contains payables transactions including Purchase Order Processing 
information for selected jobs and vendors. The transactions are aged per the age ranges set up in Microsoft Dynamics 
GP.

This report is intended to display the vouchers for one job at a time. If you have a voucher that is split between 
more than one job, the entire voucher amount will be displayed for each job, rather than showing the split 
amounts. Payments applied to the voucher will follow and be displayed as whole amounts with each voucher. 
Therefore, if you have a voucher split between jobs, your report totals will be overstated.


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Project Invoice
In the Project Invoice Entry window, you can create a schedule for billing multiple jobs on a single invoice. Project-level 
invoices can be created with or without bill codes.

To access the Project Invoice Entry window, go to Transactions > Job Cost > Project Invoice.
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Subcontract Agreement
This report consolidates job-level information from the Subcontractor Maintenance window into a form for 
subcontractors; this simplifies the process of putting together contractual agreements. The form includes the retention 
percent and description, as well as information from a linked purchase order such as the dollar amount and a detailed 
scope of work. In addition, the fields that print on the form allow you to see that the Job Cost system is set up with the 
correct terms and conditions.
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Subcontractor Claims
This report displays the cost code description, total amount of the payment claim and the scheduled amount. This 
report reflects all cost codes for each job as well as the comments entered in the Reason Note field of the Contract 
Claimed Amounts window. The report creates a separate page for each job.

Subcontractor Insurance Expiration
This report details insurance coverage amounts and expiration dates by vendor in the Subcontractor and Advanced 
Subcontractor features. Tracking subcontractor insurance information allows you to minimize exposure to uninsured or 
underinsured contractors. You can use this report to remind subcontractors of due dates for new insurance certificates 
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or required documents on a contract before a missed due date causes a payment hold. You can also display job details 
and the return status of job-level documents such as lien waivers, bonding, and Operations and Maintenance manuals.

Subcontractor Supporting Statement
This report provides for all the required Building and Construction Industry Security of Payment (Supporting 
Statement) Regulation 2014 supporting statement information.
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Subcontractor Transaction Detail
If you are using Purchase Order Processing, this report shows all invoices and payments made against a vendor 
purchase order, including retention billings and withholding, voids, and credit memos. This allows you to easily keep 
track of details such as a subcontractor's insurance coverage and the amount of retention withheld and released for 
single- or multiple-line purchase orders. In addition, tracking the amount invoiced enables you to keep a running total 
amount paid as well as the total contract balance. This report is not currently designed to work if you use tax on 
Contract Agreements.

For credit memos and invoices to appear correctly on the SRS Subcontractor Detail Report, the following steps must 
have been taken during Payables Transaction Entry:

The original PO number for a credit memo or invoice must have been entered in the Payables Transaction Entry 
window.
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A credit memo must have been distributed and posted to the job associated with the original purchasing 
transaction (Invoice/Shipment or Invoice Match) using the original subcontractor cost code associated with that 
job.
A credit memo must have been applied to the document created by the original purchasing transaction.

This report can be filtered by job, vendor, division, date, vendor type (subcontractors or non-subcontractor vendors), 
and transaction type (PO or AP). You can sort the information returned on this report by job then vendor or vendor then 
job, as well as by document date or payments following the invoice.

You can also select to show receipt line detail or a summary of vendor transactions only. This report can be printed from 
the Job Transaction Inquiry - Vendor window (Inquiry > Job Cost > Job Status > Vendor).

Union Report
This report allows you to view union payroll information such as benefit and deduction contributions and weekly pay 
amounts. Depending on your sort option, you can view union payroll details by employee, or by employee and position, 
as well as report totals for all union employees. The detailed version of this report prints by default, but you can select 
the summary view if you wish to view only position and union totals, without employee detail. For each week, hourly 
totals display per the employee's pay type: Actual Hours is a summary of all hours, regardless of pay type, while 
Converted Hours are calculated based on pay type. For example, 6 hours of double time converts to 6 actual hours, but 
12 converted hours. If you have reports set up to print from GP, print this report by choosing Reports > Job Cost > Labor 
Reports > Union, or, if you are using rate classes, Reports > Job Cost > Labor Reports > Rate Class Union.

To display purchase order payment information correctly, we recommend having just one line per PO, but if 
you have multiple lines, each line must have its own receipt and each receipt must have its own invoice.


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The detailed version of this report is a replacement for the Union and Union Summary Dexterity reports that 
were previously printed from this window when the Summary checkbox is marked. If you wish to view the 
summary version of this report, mark the Summary Only checkbox.
Gross wages can be calculated by transaction date or check date; however, if you are using rate classes, gross 
wages can only be calculated by transaction date.
In Report Manager, you can select whether to use the day of the week specified in TimeTrack as the week ending 
date. If you select this option, the first week on the report may be a partial week, depending on the Month Begin 
Date. If you do not select this option, week ending dates will be calculated based on the day of the week that is a 
full week from the Month Begin Date.

Reports:

Detail (Sorted by Position) (page 145)
Summary (Sorted by Employee) (page 149)

Detail (Sorted by Position)
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Summary (Sorted by Employee)

WIP Reports in Job Cost
GL Not Match Job Cost (page 102)
GL Transactions Not in Job Cost (page 103)
Job Cost Transactions Not in GL (page 111)
Job WIP Reconciliation (page 136)

TimeTrack SSRS Reports

Certified Payroll
The Certified Payroll report lists employee information, details of hours worked, hourly rate, gross earned in job, 
deductions, and net weekly pay for the selected jobs and service calls. To print accurate certified payroll reports, you 
must print your payroll checks using the Microsoft Dynamics GP Payroll module.

Some features include:

Cash fringe is broken out separately, making it easier to locate
Can select to include service calls (Service Management required)
Prints the statement of compliance page of the report
Prints totals by job or service call
Prints header information, such as address, contractor name, and week-ending date, eliminating the need for a 
cover page.
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In Job Cost, you can run this report from Reports > Job Cost > Labor Reports > Certified Payroll.

In Service Management, you must run this report using the SRS Report Manager.
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Certified Payroll for Public Works
The Certified Payroll for Public Works report allows you to provide weekly documentation of the hours worked and 
wages earned by your employees. This report meets the requirements for reporting payroll information for public works 
projects in the state of California. This report contains a certification form, employee information such as withholding 
exemptions, work classification, and social security number, the total hours for the week, hourly pay rate, gross amount 
earned, any deductions, contributions, and payments, and net wages paid.

•
•

•
•

Note the following information for using this report:
In California, you are required to report state disability insurance (SDI).
For SDI amounts to display correctly on the report, your local state disability insurance tax code must 
be named "SDI."
FICA social security amounts and FICA Medicare amounts are combined in the FICA social security box.
Other deductions and payments are listed separately.


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Employee Utilization
This report shows employee hours and T&M billing contribution by employee, with categories for Job, Service, and 
Internal Billed/Unbilled and Utilized/Non-utilized work. You can define non-utilized work based on Job, Cost Code, Pay 
Code, Customer, and/or Contract Type. By default, hours with a cost code of 1 (Labor) against a job or service call are 
considered utilized. Unbilled time is non-utilized. This report provides multiple expandable summary levels and sorting 
options, as well as graphs of the Top/Bottom 10 Customers and Employee hours. These graphs can be used to help 
determine if a customer site has a negative or positive effect on the utilization of any employee who works there; you 
may select to adjust pricing for that customer accordingly. This report helps leaders evaluate and share employee 
productivity levels in comparison with both personal goals and the productivity of other employees. Top and bottom 
performers can be identified in terms of billing generated, as well as total hours and percent of total hours spent on 
company-defined non-utilized jobs, contracts, pay codes, cost codes, or types.
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Time Sheet
The Time Sheet report displays the job/call number, appointment, location name, pay code, cost code, description, 
quantity, total cost, travel, and labor. The Time Sheet report is printed from the Reports Manager.



156

Equipment Management SSRS Reports

Equipment Attributes
This SSRS report allows you to view the attributes associated with your equipment records.
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Equipment Profit and Loss
This report displays the Profit and Loss information for a specified Year and Period for selected Equipment ID(s). 

You can filter the report by one or more of the following:

Profit Type
Contract ID
Equipment Type
Customer Number
Equipment Category
Equipment ID
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Equipment Profit and Loss Sub Report
This subreport displays information that is included in the Equipment Profit and Loss report. This subreport is not 
printed separately. 
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Equipment Profit and Loss Details
This report displays the details of the Profit and Loss report based on the Start/End Date, Cost Group, and Cost 
Category.

You can filter the results by one or more of the following:

Customer Number
Equipment Type
Equipment Category
Equipment ID
Open
Work
History
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Equipment Profit and Loss Key Performance Indicator
This Key Performance Indicator (KPI) report allows you to visually depict profit amounts for Equipment Management 
cost groups:

Rental (including Rental Expense and Rental Income)
Sales (including Sales Expense and Sales Income)
Total (including Total Expense and Total Income)

Profit amounts are determined by subtracting expense from income for each category. You specify the sorting option, 
for example, equipment or customer, and the number of entities you would like to view, for example, top five 
equipment records or top ten customers, for a specified period of time.

Selecting on any of the bars opens the Equipment Profit and Loss report for this date range, which allows you to view 
numbers and more specific details for a job.

To view KPI reports, you must be running SQL Server Reporting Services 2008 R2 or higher.
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Inspection
This report displays the vehicle reading data that is entered either in the Vehicle Readings window or from Mobile Tech. 
You can also print out the Inspection report if no data has been entered so that you can manually complete the 
inspection on paper.
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Rental Agreement, Booking, and Invoice Reports
In addition to the Rental Agreement, Rental Booking, and Rental Invoice reports, the following subreports are included 
for Equipment Management:

Rental Agreement Standdown Lines
Rental Invoice Standdown Lines
Rental Invoice Misc Lines

The information in the subreports listed above is required for the Rental Agreement and Invoice reports to run correctly; 
however, the subreports themselves are not run.

Rental Agreement (page 163)
Rental Agreement Standdown Lines (Subreport) (page 168)

Rental Line Agreement (page 168)
Rental Booking (page 168)
Rental Invoice (page 169)

Rental Invoice Misc Lines (Subreport) (page 171)
Rental Invoice Standdown Lines (Subreport) (page 171)

Rental Line Invoice (page 171)

Rental Agreement
This report is used to detail a rental agreement, including miscellaneous rental lines and any standdown information 
from the Rental Agreement Standdown Lines subreport. By default, billed information is included on the report; you 
may select to include billed information if you are printing this report for internal use or to send to a customer to 
confirm rental rates and totals, or you may elect to hide billed information if you are printing this report as a contract to 
send to a customer.

The Rental Agreement report can be printed for current or historical agreements, for job or customer rentals, from the 
following windows:

Rental Agreement Entry: Print a current rental agreement.
Rental Agreement Inquiry: Print a historical rental agreement.

Reports:

Not Including Billed Information (Default) (page 164)
Including Billed Information (page 165)
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Not Including Billed Information (Default)

By default, billed information is not included on the Agreement. If you want to show line-level and agreement-level total 
costs, as well as cost breakdowns for Standdowns, Insurance, Overage, Miscellaneous, Transport, Markdowns, and Tax, 
select to show billed information.
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Including Billed Information
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Rental Agreement Standdown Lines (Subreport)

This subreport displays the Standdown Lines for the selected Rental Agreement. This subreport is not printed 
separately. This information is included on the Rental Agreement.

Rental Line Agreement
This report displays the Rental Line Agreement for a Booked, On Rent, and or Historical rental type.

You can filter the results that display by one or more of the following: 

Model
Equipment ID
Item Number
Customer Number
Address ID

In this example, the results were filtered by Equipment ID, Customer ID, and the Rental Type was set to All to include 
Booked, On Rental, and Historical.

Rental Booking
This report is used to detail a rental booking agreement, either for internal use or for a customer. You can send this 
report to a customer to confirm quoted rental terms; customers can review the details of each rental booking line, 
including rental rates.

The Rental Booking report can be printed for current or historical bookings, for job or customer rentals, from the 
following windows:

Rental Booking Entry: Print a current rental booking.
Rental Booking Inquiry: Print a historical rental booking.
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Rental Invoice
This report is used to detail a rental invoice, either for internal use or for a customer. Along with rental line details, the 
invoice includes miscellaneous rental lines from the Rental Invoice Misc Lines subreport, as well as standdown 
information from the Rental Invoice Standdown Lines subreport.

The rental invoice report can be printed for current or historical invoices, for customer or job rentals, from the following 
windows:

Rental Invoice Entry: Print a current rental invoice individually.
Rental Invoice Batch Entry: Print current rental invoices by batch.
Rental Invoice Inquiry: Print a historical rental invoice.
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Rental Invoice Misc Lines (Subreport)

This subreport displays the Miscellaneous Lines of the selected invoice. This subreport is not printed separately. This 
information is included on the Rental Invoice.

Rental Invoice Standdown Lines (Subreport)

This subreport displays the Standdown Lines in the selected invoice. This subreport is not printed separately. This 
information is included on the Rental Invoice.

Rental Line Invoice
This report displays all rental invoice lines.

You can filter the results by one or more of the following:

Model
Equipment ID
Item Number
Customer ID
Customer Address

In this example, the results were filtered to only show the Customer ID of 101.  In the report window, you can select to 
view line details and the report that is printed will display only the details that were displayed in the report window. The 
example shows that the first line was select to show the details.
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Rental Utilization
This report compares actual rental usage to potential rental usage and displays rental utilization information for each 
equipment record by Month, Year to Date, and Life to Date. For each equipment ID, utilization is shown both in terms of 
days and amounts. Amounts are calculated using the following equation:

Rental Subtotal - Rental Credits - Standdowns + Overage - Markdowns (for Rate and Overage only)

Insurance and tax are not part of the Amount calculation. Standdown days and days that are marked on the Rental 
Setup window as Week End Days will not be included in the utilization Days.

The Rental Utilization report can be printed from its location in the Report Manager, or from Microsoft Dynamics GP by 
opening the Administration page and locating this report on the Custom Reports list.

You can group the equipment on the report by branch then category, branch then model, category then branch, or 
model then branch. The category and model will not show up on the report unless they are used to group the 
equipment.
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Scheduled Maintenance Forecast
Use this report to print a summary of the scheduled maintenance records that fit your criteria from the Scheduled 
Maintenance Forecast Inquiry window (Inquiry > Signature Equipment > Forecast Inquiry).

Shared SSRS Reports
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Equipment Service Cost per Meter UOM
This report shows service costs, including total cost and cost by category, for a piece of equipment over time, as well as 
the meter unit of measure for that equipment and the calculation of the cost per meter unit of measure. These costs are 
displayed by equipment record, and you can group the records by any 1-, 2-, or 3-group combination of Customer, 
Location, Branch, Category, and Model. The grand total and average cost per unit of measure for a group are calculated 
based on the group's total cost and total units of measure. Period usage is based on daily average use, as calculated 
based on the meter readings closest to the start and end dates of the period. This report can be printed from its location 
in the Report Manager, or from Microsoft Dynamics GP by opening the Administration page and locating this report on 
the Custom Reports list. By default, the detailed report displays. If you select to hide details, the report is limited to 
costs per equipment.

Summary (page 172)
Detail (page 173)

Summary
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Detail

Receivables Aged Trial Balance
This report shows the current and past due transaction amounts, retention withholding and retention billing, and 
overall invoice balance for a customer, either grouped by customer and totaled for all jobs/master IDs assigned to that 
customer, or grouped by job/master ID and listed individually for the customer of that specific job/master ID. You can 
also view report totals for all customers. This report can include information from Service Management, Job Cost, and/
or Equipment Management. A job/master ID can be a Job Cost job or project invoice, a Service Management 
maintenance contract, master contract, or service call invoice, or an Equipment Management rental invoice. The 
detailed version of this report allows you to review individual posted transactions in addition to total amounts. You can 
use this report to identify customers with outstanding and past-due balances and view the invoices that have not been 
paid. You can also use the transaction detail to reconcile your Accounts Receivable GL account. You can print this report 
from its location in the Report Manager, or from Microsoft Dynamics GP by opening the Administration page and 
locating this report on the Custom Report List.

Summary - Grouped by Customer (page 174)
Summary - Grouped by Job/Master ID (page 174)
Detail - Grouped by Customer (page 175)
Detail - Grouped by Job/Master ID (page 176)
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Summary - Grouped by Customer

Summary - Grouped by Job/Master ID
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Detail - Grouped by Customer
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Detail - Grouped by Job/Master ID

Receivables Historical Aged Trial Balance
This report shows a breakdown of customer balances on a previous date, including transaction amounts, retention 
withholding, retention billing, and aging. Similar to Receivables Aged Trial Balance, which reports the most recent aging 
and amounts that are currently outstanding, the Receivables Historical Aged Trial Balance report allows you to review 
past transactions, previous balances, and payment history. You can group information by job/master ID, or you can 
view transactions by customer, totaling all jobs/master IDs assigned to that customer. You can also view report totals 
for all customers. You can select to include information from Service Management, Job Cost, and/or Equipment 
Management. A job/master ID can be a Job Cost job or project invoice, a Service Management maintenance contract, 
master contract, or service call invoice, or an Equipment Management rental invoice. You can also specify whether you 
want to show credit balance and zero balance information, no activity, fully paid documents, and unposted applied 
credit documents. In addition to using this report to help with collections, the transaction detail on the Receivables 
Historical Aged Trial Balance report supports the balance in your Accounts Receivable and Retention Receivable GL 
accounts. You can print this report from its location in the Report Manager, or from Microsoft Dynamics GP by opening 
the Administration page and locating this report on the Custom Report List.

A payment that applies across multiple jobs does not appear under any of the jobs it was applied to; rather, it 
appears under a blank job number for the appropriate customer.


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WennSoft Billing Customer Profitability
This report allows you to view a customer's true profitability, regardless of whether sales or costs are attributed to a 
Signature or a GP module. You can also use this report to track profitability by product, with year to date, life to date, 
and last year's totals broken down and summarized per job, service call, maintenance contract, or non-Signature 
transactions.

Select whether to view information by fiscal year or calendar year, then select the year and a period range. Select a 
customer ID range and sort option; you can sort profitability information for each customer by customer ID or name, 
class, salesperson, sales territory, or state. You can also filter the report per a customer name, class, salesperson, 
territory, state, or user-defined field range. The summary version of this report prints by default, allowing you to view 
and profit margin totals for each customer. You can use the expansion button next to the ID field label to show detailed 
profitability for each customer by product.

Summary (page 178)
Detail (page 179)

Costs for jobs are only available on this report for posted periods. Current Job Cost transactions do not appear 
on this report.





178

Summary
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Detail
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SSRS Report Templates
You can use SSRS report templates to make basic reports and charts to fit any of your custom report needs. Report 
templates can be easily modified in Report Builder, a tool that comes free with SSRS, to display data from any view or 
table.

Prerequisites
In addition to the typical SSRS reports setup, before you can use Signature report templates to create your own custom 
SSRS reports, you must meet the system requirements. To find a complete list of system requirements across all the 
Signature modules, refer to Signature System Requirements8.

Configuring a Report
Before you begin customizing a report template, refer to Signature Report Templates (page 184) for descriptions that will 
help you select the template that is best suited for your needs. Consider the information that you want to get out of the 
report and the way that you want that information to display.

The following steps are required to customize a report template:

Step 1: Open the Report Template in Report Builder (page 180)
Step 2: Specify the Product Name (page 180)
Step 3: Set the Parameter Values (page 181)
Step 4: Specify the Data Source (page 181)
Step 5: Set Default Parameter Values (Optional) (page 181)
Step 6: Customize the Report Columns (Optional) (page 181)
Step 7: Save the Report (page 184)

Step 1: Open the Report Template in Report Builder

Go to your Report Manager and select the company you are creating the report for.
Open the Signature Shared folder to view the report templates available. 

Use the context menu to open the template in Report Builder.

Step 2: Specify the Product Name

On the Report Data sidebar, expand Parameters. Right-click Report Module, and select Parameter Properties.
On the Report Parameter Properties window, select Default Values.
Enter the product name as the Value, for example, Service Management, Equipment Management, or Job Cost.
Select OK.

The product name will appear at the top of the report.

If you do not see the report templates in this folder, verify you have run the wizard to deploy the latest 
Signature reports.



https://docs.key2act.io/display/1805b07/Signature+System+Requirements
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Step 3: Set the Parameter Values

Report parameters define the information that appears on the report. Parameter values are pulled from the table or 
view that you specify.

From the Parameters folder on the Report Data sidebar, right-click Main Table, and select Parameter Properties.
On the Report Parameter Properties window, select Default Values.
For the Value, enter the view or table on which the report is based.
Select OK.

The parameter values populate as selections in the parameter fields on the report.

Step 4: Specify the Data Source

The data source provides the information on the report. This must be the same table or view that populates the report 
parameter values.

Expand Datasets. Right-click Main Table and select Dataset Properties.
Replace the existing Name with the name of the table or view you are using.
Change the data source name in the Query from the default "MainTable" to the name of your table or view. This 
query pulls fields from the specified data source for use on the report; you can also customize the query if there 
are specific fields you want to use.
Select OK.

Step 5: Set Default Parameter Values (Optional)

You can specify the parameter values that default for the report. This is useful if you are creating a report for a specific 
purpose and do not want to select the parameter values every time the report is opened.

From the Parameters folder on the Report Data sidebar, right-click the name of the parameter field, for example, 
GroupBy1, and select Parameter Properties.
On the Report Parameter Properties window, select Default Values.
For the Value, enter the name of a field from the table or view that is set up as the data source. This field is the 
selection that defaults in the drop-down menu for this parameter.
Select OK.

The field that you specified defaults as the parameter value on the report. You can use the drop down to select a 
different parameter.

Step 6: Customize the Report Columns (Optional)

Once the data source is set up, you can add additional columns to the report if necessary. You may select to add 
columns to templates like SignatureTemplateGroup or SignatureTemplateGroupFilter if you want to view more data on 
the report than those found in the template columns provided.

If you are using Business Analyzer to view reports, you must set default parameter values to return results. You 
cannot select parameter values within this product; if no defaults are set, the report will not display in 
Business Analyzer.


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Expand Datasets and find the table or view that the report data is pulled from.
Select the name of the field that you want to add as a column on the report, and drag and drop it onto the 
template.
Repeat for any additional columns you wish to add.

Step 7: Save the Report

After the template is customized, you can save it as a new report.

Use the Report Builder menu at the top left of the window to select Save As, and save the report with a new file 
name. Close Report Builder when you are done.
Refresh Report Manager in your browser to view the new report. You can now run the report and manage the 
default parameters from Report Manager as necessary.

Signature Report Templates
The following Signature report templates can be used to create custom reports.

Signature Template Chart 1 (page 184)
Signature Template Chart 2 (page 185)
Signature Template Chart 5 (page 185)
Signature Template Group (page 186)
Signature Template Group Filter (page 187)
Signature Template Group Filter Date (page 188)
Signature Template Pivot (page 189)

Signature Template Chart 1

This template allows you to create a report for viewing the top X values of your choosing. There is a Show Details drill 
down that shows all the records for the report.

When you create a report based on this template, you can edit the following parameters in Report Manager:

You can define the number of values (Top X) to display.
You can use any text type field from your data source to group the values on the report (Group By).
You can use any number type field from your data source to measure the values on the report (Chart Value 1).
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Example: You may decide to use this template to create a Project Chart. Values are grouped by Project Number, Project 
Name, Customer Number, Customer Name, or Manager. Values are measured by Contract Earned, Total Actual Cost, or 
Billed Amount TTD.

Signature Template Chart 2

This template allows you to create a report for viewing and comparing the top X values of your choosing. There is 
a Show Detail drill down that shows all the records for the report.

When you create a report based on this template, you can edit the following parameters in Report Manager:

You can define the number of values (Top X) to display.
You can use any text type field from your data source to group the values on the report (Group By).
You can use any number type field from your data source to measure the values on the report and determine the 
top X groups based on this value (Chart Value 1)
Additionally, you can use any number type field from your data source to measure another value on the report 
(Chart Value 2).

Example: You may decide to use this template to create a Job Revenue Cost report. Values are grouped by Project Number, 
Project Name, Customer Number, Customer Name, or Estimator. Values are measured by Billed Amount TTD and Total 
Actual Cost.

Signature Template Chart 5

This template allows you to create a report for viewing and totaling the top X values of your choosing. There is a Show 
Detail drill down that shows all the records for the report.
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When you create a report based on this template, you can edit the following parameters in Report Manager:

You can define the number of values (Top X) to display.
You can use any text type field from your data source to group the values on the report (Group By).
You can use any number type fields from your data source to measure the values on the report and determine 
the top X groups based on a sum of these values (Chart Value 1 - Chart Value 5).

Example: You may decide to use this template to create a Job Estimated Cost report. Values are grouped by Project 
Number, Project Name, Customer Number, Customer Name, or Estimator. Values are measured by Estimated Labor Cost, 
Estimated Material Cost, Estimated Equipment Cost, Estimated Subs Cost, and Estimated Other Cost.

Signature Template Group

This template allows you to create a table-based report with information that can be sorted and grouped by any two 
fields. You can add fields from the data source as columns on the report; if you add a field with numeric values, subtotal 
and report totals are included on the report.
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When you create a report based on this template, you can edit the following parameters in Report Manager:

You can use any field from your data source to group and sort the values on the report (Group By and Group By 2).

Example: You may decide to use this template to create a Job Invoice Report. Additional fields such as Document Amount 
and Billed Amount are added as columns when you edit the report template in Report Builder. In Report Manager, values 
are grouped first by Project Number, Customer Number, Customer Name, or Batch Number. Values are grouped next by 
Job Number or Job Name.

Signature Template Group Filter

This template allows you to create a table-based report with information that can be sorted and grouped by any two 
fields, as well as filtered based on the first grouping field. You can add fields from the data source as columns on the 
report; if you add a field with numeric values, subtotal and report totals are included on the report.
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When you create a report based on this template, you can edit the following parameters in Report Manager:

You can use any field from your data source to group and sort the values on the report (Group By and Group By 
2).
You can select fields for filtering based on the first Group By value (FilterByStart and FilterByEnd).

Example: You may decide to use this template to create a Job Cost Code Report. Additional fields such as Cost Code Actual 
Cost TTD and Cost Code Actual Cost YTD are added as columns when editing the report template in Report Builder. In 
Report Manager, values are grouped first by Project Number. Values are grouped next by Cost Element Name, Cost Element 
ID, or Cost Code Alias. Values are filtered by Project Number, as this is the first Group By field.

Signature Template Group Filter Date

This template allows you to create a table-based report with information that can be sorted and grouped by any two 
fields, as well as filtered based on the first grouping field and any date fields from the data source. You can add fields 
from the data source as columns on the report; if you add a field with numeric values, subtotal and report totals are 
included on the report.
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When you create a report based on this template, you can edit the following parameters in Report Manager:

You can use any field from your data source to group and sort the values on the report (Group By and Group By 
2).
You can select fields for filtering based on the first Group By value (Starting Group and Ending Group).
You can select to show the date values that you are using as filters on the report (Show Date On Report).
You can select the date field you wish to use for filtering the report (Date Column), then select the date filter 
values (Starting Date and Ending Date).

Example: You may decide to use this template to create a Change Order Report. Additional fields such as Change Order 
Estimated Cost are added as columns when editing the report template in Report Builder. In Report Manager, values are 
grouped first by Project Number or Change Order Status Name. Values are grouped next by Job Number or Change Order 
Status Name. Values are filtered based on Project Number or Change Order Status Name, as this is the first Group By 
field. Values are also filtered based on the Posting Date or Last Modified Date.

Signature Template Pivot

This template allows you to create a matrix-based report that can pivot data into a column group and row group. You 
add numeric values to the body of the matrix, and totals appear based on the row and column criteria.

You must have SQL 2008 R2 Business Intelligence Studio installed to deploy and use this report template.
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When you create a report based on this template, you can edit the following parameters in Report Manager:

You can use any field from your data source for grouping the values by row (Row Group).
You can use any field from your data source for grouping the values by column (Column Group).

Example: You may decide to use this template to create a Service Calls report. Numeric fields such as Cost All or Billable All 
are added when editing the report template in Report Builder. Rows are grouped based on Profit Center ID. Columns are 
grouped based on Call Status Name.

Charts and Key Performance Indicators (KPIs)
The Business Analyzer (formerly called Metrics) displays graphical representations of data within your system. 
Signature provides five graphical reports for Job Cost, six graphical reports for Service Management, and six graphical 
reports for Equipment. See the full list along with descriptions at the end of this section.

Service Management graphical reports contain an SMS prefix. Job Cost graphical reports contain a JC prefix. Equipment 
Management graphical reports contain an EMS prefix.

Before you can view the Signature graphical reports on your home page, you must update each report's parameter to 
the specific user login name. This must be done for each user who needs to view the graphical report. The order of 
adding a graphical report to Business Analyzer in Microsoft GP Dynamics and updating the report parameters in Report 
Manager is not important, however, the graphical report will not display any data until the parameters have been 
updated.

Go to the Report Server (http://yourcomputername/Reports_yourservername).To update a graphic report's 
parameters:

From the Report Server, select yoursystemDB> yourcompanyDB > Signature Job Cost or Signature Service.
Open the Charts and KPIs folder.
In the Charts And KPIs window, hover your mouse over the report name and select the drop-down arrow that 
displays.
Select Manage.
From the navigation pane, select Parameters.
On the UserID line, select Override Default and then enter your login name.
Select Apply.
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Adding Graphical Reports on Your Home Page
For information on how to add a graphical report to Business Analyzer, see the Microsoft Dynamics GP documentation.

Viewing Graphical Reports on Your Home Page
To display a Signature graphical report on your home page, select the right or left arrow that appears at the bottom of 
the Business Analyzer tile. Every time you select the right arrow, the next graphical report in the list displays on your 
home page.

The following Signature graphical reports are available, organized by product:

Service Management 
Following is a list of graphical report names and an accompanying description.

12-MTH Analysis of Contract Costs and Revenue by Contract Type
Provides a side-by-side comparison of year-to-date costs and year-to-date revenue for contracts in the last 12 
months.
Analysis of Costs vs. Billed By Cost Type
Provides a side-by-side comparison of year-to-date costs vs. year-to-date billed for contracts, starting with the 
current user date and organized by call type. This graphical report does not include taxes in billed amounts.
MTD Appointments Completed by Technician
Shows the top 12 most month-to-date appointments completed by technician ID.
MTD Billing by Technician
Shows the top 10 most labor billed by technician ID.
Overdue PM Appointments by Contract Type
Shows the top 12 number of contract service calls for which there are overdue appointments, organized by 
contract type.
Six Month Analysis of Service Billed and Unbilled Dollars
Shows the billed and unbilled amounts for the last six months, starting with the current user date. This graphical 
report does not include taxes in billed amounts.

Job Cost

Top 10 Jobs Anticipated Loss
Shows the top 10 jobs based on anticipated loss.
Top 10 Jobs Over/Under Billed
Shows the top 10 most under-billed jobs displayed in ascending order.
Top 10 Jobs Anticipated Profit
Shows the top 10 jobs based on anticipated profit.
Top 5 Jobs Earned vs. Billed
Provides a side-by-side comparison between the amount earned and the amount billed for contracts.
Top 5 Jobs Based on Contract Earned
Shows the top 5 jobs based on highest contract earned.

Equipment Management

Top 12 Branch Division Totals
Shows the top 12 total number of equipment per branch, by division.
Top 12 Branch Totals
Shows the top 12 total number of equipment per branch.
Top 12 Division Totals
Shows the top 12 total number of equipment per division.
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Top 12 Model Rental Totals
Provides a side-by-side comparison of the number of equipment On Rent vs. the number of equipment 
Available.
Top 12 Model Totals
Shows the top 12 total number of equipment per model.
Top 12 Status Totals
Shows the top 12 total number of equipment per equipment status.

Dexterity Reports
Dexterity is the native language of Microsoft Dynamics GP. You can use the built-in report writer to create new reports or 
create a version of an existing report to use in place of the original Dynamics GP report (an Alternate Report). Reports 
allow you to retrieve data from your application's tables and present it to users in an organized manner. A report can be 
as simple as a mailing list or as complex as a year-end account reconciliation. It can be based on data in a single table or 
in multiple tables. See the Microsoft Dexterity documentation for more information.

Configuring System Reports
A common printing DLL - Signature.ReportControl.dll - has been provided to simplify the viewing of any type of report 
within Signature products. A table and two SQL procedures have been created for you to use to specify which type of 
report you want your users to run, Dexterity or SSRS.

WSRepts Table
A table called WSRepts stores the path location for reports. This table is created in each company database during the 
Signature installation or upgrade process.

The ReportLocation column stores the full path and filename of the report being referenced. This could be a local SSRS 
report or the URL of a remote SSRS report. A blank column assumes the system is running the Dexterity version of the 
report.

Below is an example of updating the WSRepts table with a replacement report than what is currently specified. You can 
determine the name of the Dexterity report by printing that report from within the system. Our examples will use the 
SV_Service_Audit_Cost_Report. For SSRS reports, you also need to know the machine name on which your report server 
resides.

UPDATE WSRepts Set ReportLocation = 'http://localhost/ReportServerNew/TWO/
Signature Service/Service Cost Audit'where ReportReference 
='SV_Service_Cost_Audit_Report'

SQL Procedures
Two SQL procedures allow you to globally replace Dexterity reports with the SSRS equivalent. The procedure for SSRS 
reports is WS_SetReplacementForSQL.

The information in this section is intended exclusively for a technical audience, such as IT personnel, computer 
programmer, or system administrator.


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You run these procedures against the company database, as in the example below:

exec WS_SetReplacementForSQL

Signature.ReportControl.dll Programmers Reference

Features
Previews / Prints a SQL Server Reporting Services (SSRS) Report.
Any report parameter that is not supplied by the calling procedure will prompt for user input.
Only uses parameters that are associated with the specific report, reducing the possibility of an error when too 
many parameters have been supplied.
Each Preview method has a Print method that mirrors the parameters but prompts the user with a Print Dialog 
window instead of previewing the report.
Replacement report information is stored in a database table for easy access.
Local SSRS Reports evaluate the Query section to fill the report.

Requirements
Net Framework 2.0
An ODBC System DSN pointing to the database server.
To use the replacement report database table, local SSRS Reports, one of two things must be setup on the 
database server: Existence of the WSMiscUser and/or WSEMSUser account with corresponding password. - OR -
Windows Authentication setup for each user of the database server.
To use Remote SSRS Reports: Windows Authentication must be used for each user on the database server.
To use with Local SSRS Sub-reports: The extension of the Local SSRS Subreport filename must be ".rdlc."
To use with a Dexterity product, the DLL must be registered as a COM object. Use RegAsm.exe, which is included 
with the .Net Framework. RegAsm.exe can be found in the C:\Windows\Microsoft.NET\Framework\v2.0.50727 
folder. Syntax: RegAsm.exe Signature.ReportControl.dll /tlb:Signature.ReportControl.tlb

Constructor

Reporting

Default constructor.
public Reporting();

Methods

ClearParameters (page 194)
AddParameter (page 194)
ParseToAddRestriction (page 194)
HasReplacement (page 194)
SetPreviewOptions (page 195)
PreviewReplacementUsingLocationAndConnection (page 195)

Running either of these procedures DOES NOT update a ReportLocation that already contains a value; it only 
applies to blank ReportLocation columns, which assumes that the Dexterity report is being used.


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PreviewReplacementUsingLocation (page 195)
PreviewReplacementUsingConnection (page 196)
PreviewReplacement (page 196)
PreviewUsingDsn (page 196)
PreviewUsingConnection (page 195)
PreviewRemote (page 195)
Preview (page 195)

ClearParameters
Clears the internal report parameter buffer.public void
ClearParameters ();

AddParameter
Adds a report parameter and value to the internal buffer. If the parameter name already exists in the buffer, the value 
will be changed to represent the most recent addition.

publi c void AddParameter(string parameterName, string parameterValue);

parameterName
Name of the parameter as defined by the report
parameterValue
Value for the parameter that is passed to the report.

ParseToAddRestriction
Adds a restriction to the report in the form of an SSRS Report parameter(s).
public void ParseToAddRestriction (string reportRestriction);

reportRestriction
SSRS Report parameter(s).

Selection Formula example:
{Service_ID} = 'ABC123' And {Invoice_Num} = 123

SSRS Report parameter example:
&Service_ID=ABC123&Invoice_Num=123

HasReplacement
Checks the WSRepts database table for a replacement report.
public bool HasReplacement(string reportName, string systemDsn, string 
databaseName);

reportName
Name of the report that may have a replacement.
systemDsn
System DataSource Name used to access the database.
databaseName
Name of the Database to access on the database server.
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SetPreviewOptions
Set which options are available to the user on the Preview window.
public void SetPreviewOptions(bool allowExport, bool allowPrint, bool 
allowRefresh, bool allowSearch, bool allowZoom);

allowExport
Allow the user to export the report to various formats.
allowPrint
Allow the user to print the report.
allowRefresh
Allow the user to refresh the report, which includes the ability to change the parameters to the report.
allowSearch
Allow the user to search for text inside the report.
allowZoom
Allow the user to make the report larger for easier reading.

PreviewReplacementUsingLocationAndConnection
Previews the passed replacement report reference, using the specified report location and database connection. 
Returns whether the replacement report was previewed.
public bool PreviewReplacementUsingLocationAndConnection(string reportRef, string 
reportLocation, IDbConnection dbConn);

public bool PrintReplacementUsingLocationAndConnection(string reportRef, string 
reportLocation, IDbConnection dbConn);

reportRef
Report reference to lookup in the WSRepts table.
reportLocation
The location or path to the report file that will be used instead of the location that resides with the report file in 
the database column ReportLocation.
dbConn
The database connection object used to access the database server.

PreviewReplacementUsingLocation
Previews the passed replacement report reference, using the specified report location, accessing the passed System 
DSN and database name. Returns whether the replacement report was previewed.
public bool PreviewReplacementUsingLocation(string reportRef, string 
reportLocation, string systemDsn, string databaseName);

public bool PrintReplacementUsingLocation(string reportRef, string reportLocation, 
string systemDsn, string databaseName);

reportRef
Report reference to lookup in the WSRepts table.
reportLocation
The location or path to the report file that will be used instead of the location that resides with the report file in 
the database column ReportLocation.
systemDsn
System DataSource Name used to access the database.
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databaseName
Name of the Database to access on the database server.

PreviewReplacementUsingConnection
Previews the passed replacement report reference, using the specified database connection. Returns whether the 
replacement report was previewed.
public bool PreviewReplacementUsingConnection(string reportRef, IDbConnection 
dbConn);

public bool PrintReplacementUsingConnection(string reportRef, IDbConnection 
dbConn);

reportRef
Report reference to lookup in the WSRepts table.
dbConn
The database connection object used to access the database server.

PreviewReplacement
Previews the passed replacement report reference, using the passed System DSN and database name. Returns whether 
the replacement report was previewed.
public bool PreviewReplacement(string reportRef, string systemDsn, string 
databaseName);

public bool PrintReplacement(string reportRef, string systemDsn, string 
databaseName);

reportRef
Report reference to lookup in the WSRepts table.
systemDsn
System DataSource Name used to access the database.
databaseName
Name of the database to access on the database server.

PreviewUsingDsn
Previews the passed report name (including full path) using the passed System DSN and database name.
public void PreviewUsingDsn(string reportPath, string systemDsn, string 
databaseName);

public void PrintUsingDsn(string reportPath, string systemDsn, string 
databaseName);

reportPath
Name of the report to preview, including the full path and filename.
systemDsn
System DataSource Name used to access the database.
databaseName
Name of the Database to access on the database server.
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PreviewUsingConnection
Previews the passed report name (including full path), using the specified database connection.
public void PreviewUsingConnection(string reportPath, IDbConnection dbConn);

public void PrintUsingConnection(string reportPath, IDbConnection dbConn);

reportPath
Report reference to lookup in the WSRepts table.
dbConn
The database connection object used to access the database server.

PreviewRemote
Previews the passed remote report specified as a URL.
public void PreviewRemote(string reportPath);

public void PrintRemote(string reportPath);

reportPath
URL of the SRS Report.

Preview
Previews the report as specified in the XML formatted data string.
public void Preview(string xmlData);

public void Print(string xmlData);

xmlData
XML Data that represents the information required to run the report.

See XML Structure (page 197) section for details.

XML Structure
The XML Element Structure is as follows with required elements boldfaced:

ReportControl
ConnectionInformation
SystemDSN
DatabaseName
ReportPath
PreviewOptions
AllowExport
AllowPrint
AllowRefresh
AllowSearch
AllowZoom
ReportParameters
Parameter Name="ParameterName"
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ParameterName
ReportRestriction

ReportControl and ReportPath are required elements.

The only time ConnectionInformation is not needed is for Remote SSRS reports, all other times it is required.

The "Parameter Name=" element is used when there are special characters in the name of the report parameter, such as 
spaces, but could be used for all report parameters.

Example: <Parameter Name="Service ID">123456</Parameter>

The ParameterName element is exactly that, the actual name of the report parameter without special characters (i.e. 
BatchNum or Service_ID).

Example: <Service_ID>123456</Service_ID>

The ReportRestriction element contains the information passed as if using the ParseToAddRestriction method which 
passes the SSRS Report Parameter(s).

Database Table

Table Name: WSRepts

Table Definition

Column Name Data Type Length Allow Null? Indexes

ReportReference Varchar 128 No Primary Key

ReportLocation Varchar 4096 No

The WSRepts table is created in the company database during the Signature installation process. This table should 
reside in each company database since there is a possibility to have different replacement reports for each company.

The ReportReference column refers to the name of the report that is being replaced, most likely a Dexterity report name.

The ReportLocation column contains the full path and filename of the Local SRS Report or the URL of the Remote SSRS 
Report that is replacing the report being referenced.

Job Cost Dexterity Reports
Job Cost Dexterity reports provide complete analysis of your business' job-related costs, billings, and profits. This 
enables you to make better decisions. The reports are always up-to-date and available for printing at any time in the job 
cycle.

Job Cost provides a complete audit trail that includes transaction numbers, source documents, and posting journals, 
allowing you to track any transaction back to its point of entry in the accounting system. You can also print a wide 
variety of reports that help you analyze your company's position on jobs. In addition, many reports provide you with 
general job, transaction, and feature setup information. You can modify reports using Report Writer, which is included 
with the Microsoft Dynamics GP System Manager module.
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Printing reports in Job Cost is similar to printing reports in Microsoft Dynamics GP. Once you select a report to print and 
select Print, the Report Destination window appears with the print destination marked per Microsoft Dynamics GP setup 
(Microsoft Dynamics GP > Tools > Setup > User Preferences).

You can save Job Cost reports in four file formats: data interchange format, tab-delimited fields format, comma-
delimited fields format, and text file.

Estimate Worksheet
The Estimate Worksheet lists all cost codes, estimated units, estimated amounts per unit, profit amounts, estimate 
amounts, and the estimated billing amounts for a job. The estimated billing amounts are calculated based on the 
estimate and profit type for each cost code. The report shows estimated amounts and estimated billing amounts 
totaled for each cost code phase. For example, if your first segment of the cost code is 1 and you set up cost codes 
1-00-1 and 1-00-4, the report shows those amounts totaled for each cost element. Use this report to determine the 
accuracy of your detail estimates for each cost element and phase of a job.

Select Reports > Job Cost > Estimate Worksheet.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.
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Printable Notes
You can print notes that have been added to Job Cost using the notepad button, if they have been marked printable. 
You can print the note text, transaction number, cost code, author, and index.

Select Reports > Job Cost > Printable Notes.
Use the Note Type drop-down list to select the Job Cost note type. 

Use the Ranges drop-down list to select a range type.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.

Job Reports
Job reports relate to the daily management and monitoring of a job, including schedules, backlogs, and change orders.

Audit Billing (page 201)
Audit Cash Receipts (page 202)
Audit Costs (page 203)
Audit Cost Variance (page 203)
Backlog (page 204)
Backlog by Period (page 205)
Change Order Summary (page 205)
Committed Costs (page 206)
Costs by Period (page 206)

Choosing All results in printing notes for all listed windows and all companies.
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Current Contract (page 207)
Current Year - Contracts Closed (page 208)
Current Year - Contracts in Progress (page 209)
Detail Codes List (page 209)
Estimate Analysis (page 210)
Estimate Cost Variance (page 210)
Job Analysis Report (page 211)
Job Posted Cost (page 211)
Job Reference (page 212)
Job Schedule (page 213)
Job Status Report (page 213)
Job Summary (page 214)
Job Unposted Cost (page 215)
Payables Aged Trial Balance (JC) (page 216)
Profit and Loss (page 217)
Profit and Loss by Period (page 217)
Projected Variance (page 218)
Project Status (page 218)
Quantity Variance (page 219)
WIP (page 220)

Audit Billing
The Audit Billing report contains billing information for a specified job, and includes change order amounts, net billed-
to-date amount, current amount due, gross billed-to-date amount, and estimated amounts.

Select Reports > Job Cost > Job Reports > Audit Reports > Audit Billing.
Enter a Job Number.
Select Print.
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Audit Cash Receipts
The Audit Cash Receipts report displays cash receipt information for the selected job, including transaction information 
and billable costs.

Select Reports > Job Cost > Job Reports > Audit Reports > Audit Cash Receipts.
Enter a Job Number.
Select Print.
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Audit Costs
The Audit Costs report contains detailed transaction information for a job with subtotals by cost element and cost code. 
You can sort this report by job, cost code, cost element, or a date range.

Select Reports > Job Cost > Job Reports > Audit Reports > Audit Costs.
Select a Job Number Range radio button. If you select Job Number, select a Job. If you select Range, enter 
a Range.
Select a Date Range radio button and enter the dates.
Select a Range radio button and enter a cost element type or cost code.
You can mark the Exclude Inactive checkbox to exclude inactive cost codes from the report.
Select Print.

Audit Cost Variance
The Audit Cost Variance report shows detailed transaction information for a job with estimate variances by cost code 
and cost element. The variance is between the expected costs and actual costs.

Select Reports > Job Cost > Job Reports > Audit Reports > Audit Cost Variance.
Select a Job Number Range radio button. If you select Job Number, select a Job. If you select Range, enter 
a Range.
Select a Date Range radio button. If you select Range, enter a Start Date and End Date.
Select a Range radio button and enter a cost element type or cost code.
You can mark the Exclude Inactive checkbox to exclude inactive cost codes from the report.
Select Print.
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Backlog
The Backlog report shows original contract amount, contract earned, and backlog amount for all jobs in the selected 
range. A backlog amount is determined by subtracting the contract earned amount from the job's contract-to-date 
amount.

Select Reports > Job Cost > Job Reports > Backlog.
Use the lookup buttons in the From and To fields to select the print range. Select Insert >>.
Select Print.
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Backlog by Period
The Backlog report shows original contract amount, contract earned, and backlog amount for all jobs in the selected 
range for a specified fiscal period. A backlog amount is determined by subtracting the contract earned amount from the 
job's contract-to-date amount. This report matches the contract earned with the POC posting.

Select Reports > Job Cost > Job Reports > Backlog by Period.
The Year fills automatically with the system year.
Enter a Fiscal Period.
Enter a Job Number.
Select Print.

Change Order Summary
The Change Order Summary report lists change orders, amounts, and status for the selected job.

Select Reports > Job Cost > Job Reports > Change Order Summary.
Select a Job.
Select Print.
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Committed Costs
You can print the Committed Costs report if you use a Purchase Order module that integrates with Job Cost. The report 
shows quantity ordered, expected unit costs, and committed costs for each purchase order.

Select Reports > Job Cost > Job Reports > Committed Costs.
Enter a Job Number.
Select Print.

Costs by Period
The Costs by Period report contains the actual costs of selected jobs or a range of years and periods within those years. 
The report also displays the amount billed for each job for each period within the selected range. The status of the jobs, 
customer numbers and names, and the totals are also displayed in this report.

Select Reports > Job Cost > Job Reports > Costs by Period.
Enter the range of years in the From and To fields. Use the lookup buttons to select a range of periods.
Select a radio button to include All jobs, Open jobs, or Active jobs.
Use the lookup buttons to select the print range. Select Insert >>.
Select Print.
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Current Contract
The Current Contract report contains the cost code number, quantity, and estimated amount for each cost code 
assigned to a job. Report totals include the total estimated amount and the contract amount.

Select Reports > Job Cost > Job Reports > Current Contract.
Use the lookup buttons in the From and To fields to select the print range. Select Insert >>.
Select Print.
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Current Year - Contracts Closed
The Current Year - Contracts Closed report for the current year shows revenue, costs, and margin. This report is similar 
to the Job Analysis report. To see data for closed contracts reports, the job must be closed.

Select Reports > Job Cost > Job Reports > Current Year - Contracts Closed.
Enter the Job Number. If the job number is left blank, the report will display all jobs.
Select to print All dates or a Range of dates. Enter start and end dates, if applicable.
Select Print.



207

1.
2.

3.

1.
2.
3.

Current Year - Contracts in Progress
The Current Year - Contracts in Progress report for the current year shows amounts recognized to date, recognized for 
the current year, and estimated to complete. This report is similar to the Job Analysis report. To see data in the Current 
Year - Contracts in Progress report, the periods must be closed for the months you are selecting. In addition, you must 
run the Year-End Closing routine in Job Cost (Microsoft Dynamics GP > Tools > Routines > Job Cost > Year-End Closing).

Select Reports > Job Cost > Job Reports > Current Year - Contracts in Progress.
Accept the current Year and enter the Period ID and Job Number. If the job number is left blank, the report will 
display all jobs. The date fields are disabled for this report.
Select Print.

Detail Codes List
The Detail Codes List report contains the setup information for a job's cost codes, sorted by cost element. This 
information includes the profit type and amount, the general ledger posting account assigned to the cost code, and the 
total cost-per-unit amount.

Select Reports > Job Cost > Job Reports > Detail Codes List.
Enter a Job Number.
Select Print.
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Estimate Analysis
The Estimate Analysis report compares the estimate amount with the actual amounts by job number, cost code 
number, cost element, and period. Costs must be posted and an estimate entry for a given period must be made for this 
report to show data.

Select Reports > Job Cost > Job Reports > Variance Reports > Estimate Analysis.
Enter the (R) and use the lookup button to select a (R).
Use the lookup button to select a Job and select Print.

Estimate Cost Variance
The Estimate Cost Variance report shows the cost estimate for each cost code, the actual cost to date, the percent 
variance, and estimate variance. The report also shows total amounts calculated for the entire cost element.

Select Reports > Job Cost > Job Reports > Variance Reports > Estimate Variance.
Use the lookup buttons in the From and To fields to select the print range. Select Insert >>.
Select Print.
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Job Analysis Report
The Job Analysis report provides cost element phase totals and cost code detail breakdown for the current period 
costs, and year-to-date costs of all cost codes. The report shows job-to-date totals, including the estimate, posted cost, 
percentage complete, and estimated cost remaining for each phase and totals for the entire job.

Select Reports > Job Cost > Job Reports > Variance Reports > Job Analysis.
Enter the Year and use the lookup button to select a Period.
Use the lookup button to select a Job and select Print.

Job Posted Cost
The Job Posted Cost report displays the posted costs to date for each cost code for each cost element. You can print the 
cost code list for actual costs. The report shows amounts totaled by cost code. You can also view the general ledger 
posting account debited as transactions post for each cost code.

Select Reports > Job Cost > Job Reports > Job Posted Cost.
Enter a Job Number.
Select Print.
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Job Reference
The Job Reference report contains information you enter in the Job Maintenance window, including estimate cost and 
estimated cost-plus-profit amounts by cost element for the selected job. You can print a Job Reference report for each 
job you set up. In addition, you can view actual and forecasted cost amounts by cost element.

Select Reports > Job Cost > Job Reports > Reference.
Use the lookup buttons in the From and To fields to select the print range. Select Insert >>.
Select Print.
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Job Schedule
The Job Schedule report contains the job status, costs, profit, and contract-to-date information.

Select Reports > Job Cost > Job Reports > Job Schedule.
Use the lookup buttons in the From and To fields to select the print range. Select Insert >>.
Select Print.

Job Status Report
The Job Status report lists the information displayed in the Job Status window. The report contains unposted, 
committed, posted, estimated, and forecasted costs for each cost element. In addition, you can view estimated gross 
profit, change order, and other job information.

Select Reports > Job Cost > Job Reports > Job Status.
Use the lookup buttons in the From and To fields to select the print range. Select Insert >>.
Select Print.
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Job Summary
The Job Summary report contains a summary of the all job information for a specified job within a specified fiscal 
period. This includes billing information, estimates, contracts, and customers. Labor for a job is broken down by labor 
hours, cost per hour, and total labor cost.

Select Reports > Job Cost > Job Reports > Job Summary.
In the Period ID field, use the lookup button to select a fiscal period ID.
Enter a Job Number. The date fields are disabled for this report.
Select Print.

The Applied Overhead field is calculated using the Overhead Labor % field in the Job Maintenance window.

Applied Overhead = Labor Cost x Overhead Labor % (Job Maintenance window)
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The Assessment field is the variance between the Applied Overhead and the overhead calculated using the overhead 
detail codes fixed rate or percentage in the Overhead Detail Codes window.

Assessment = Applied Overhead - (Labor Cost x fixed portion or percent 
portion)

Job Unposted Cost
The Job Unposted Cost report displays the unposted costs shown in the Job Unposted Cost window for the selected 
job. 

This window is accessed from the Job Status window and then either zooming on a cost element from the Unposted 
Costs column or by selecting the Unposted Costs button.
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Payables Aged Trial Balance (JC)
The Payables Aged Trial Balance report contains payables transactions — including payables from Purchase Order 
Processing (POP) — for the selected jobs and vendors. The transactions are aged per the age ranges set up in Microsoft 
Dynamics GP. You can sort this report by job number or vendor ID.

Select Reports > Job Cost > Job Reports > PM Aged Trial Balance.
Use the Sort drop-down to select the sorting method. You can sort by job number or vendor ID.
In the Age As Of field, enter a cutoff date for the aging. Vouchers entered after this date will not appear on the 
report.
Mark the appropriate Exclude checkboxes. You can exclude fully paid documents and zero balance vouchers.
Select a range from the Ranges drop-down list. You can select a range by job number, vendor ID, or document 
number. Define the range by completing the From and To fields.
Select Insert >>. You can create one range for each type of range.
Select Print.

This report includes only functional currency amounts, not multicurrency amounts. This report will not include 
closed jobs.


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Profit and Loss
The Profit and Loss report contains the actual percentage complete, contract earned amount, actual cost to date, 
actual billed to date, and amounts received for the selected job range. The report also provides a snapshot of whether a 
job is operating at a profit or loss. When you print the report for a single period, the percent complete is based on costs 
incurred for that period only. This is also true for cost accumulated and amount earned. To view this information for a 
specific job, the selected range must include all periods since the job was opened. For example, you may complete 40% 
of your job in Period 1 and 60% in Period 2. If the report is restricted to Period 2, it will only show the 60% that was 
completed in that period. If you include both periods in the report, it will show the job as 100% complete.

Select Reports > Job Cost > Job Reports > Profit and Loss.
Use the lookup buttons in the From and To fields to select the print range. Select Insert >>.
Select Print.

Profit and Loss by Period
The Profit and Loss report contains the actual percentage complete, contract earned amount, actual cost-to-date, 
billed-to-date, and profit amount for jobs within a designated period.

Select Reports > Job Cost > Job Reports > P and L by Period.
Enter From and To dates for the Year and Period.
Select to include All jobs, Open jobs, or Active jobs.
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Enter a range of job numbers.
Select Insert >>.
Select Print.

Projected Variance
The Projected Variance report includes the projected field cost-to-date amount, based on the estimated percent 
complete, for each cost code and compares the amount to actual cost-to-date amounts. The report shows a percentage 
variance and an estimated variance for each cost code, calculated for each phase of the job.

Select Reports > Job Cost > Job Reports > Variance Reports > Projected Variance.
Use the lookup buttons in the From and To fields to select the print range. Select Insert >>.
Select Print.

Project Status
The Project Status report lists the information displayed in the Project Unposted Cost by Job window. The report 
contains unposted, committed, posted, estimated, and forecasted costs for each cost element. In addition, you can 
view total cash received, total net received, total gross billed, and other job information. This report is printed from the 
Inquiry > Project Status window.
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Quantity Variance
The Quantity Variance report compares the estimated unit to date for each cost element with the actual units to date 
used. The report shows an estimated project variance for each cost code. Total projected variance amounts calculate 
automatically for all cost elements.

Select Reports > Job Cost > Job Reports > Variance Reports > Quantity Variance.
Use the lookup buttons in the From and To fields to select the print range. Select Insert >>.
Select Print.
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WIP
At month end, you may want to make sure that the WIP accounts are updated in Job Cost balance with the WIP 
accounts updated in the general ledger (GL). You can run reports that show you which Job Cost transactions have and 
have not been posted through to the GL - and which transactions have been posted in the GL, but not to Job Cost.

Using WIP Reports at Month End (page 220)
Sample Report Sequence (page 219)
Posting Setup (page 219)
Running the JC WIP Reports (page 219)

Summary (page 222)
Detail (page 222)
Exception Report - Job Cost costs not in GL (page 223)
Exception Report - GL costs not in Job Cost (page 223)

Using WIP Reports at Month End

Job Cost provides the following reports to help you reconcile Job Cost with the general ledger:

WIP report: Printed by year and period, this report shows amounts for each job, grouped by division. This is to 
give you an idea of amounts that are currently unbilled. You can print a summary or detailed version of this 
report.
Exception reports: The exception reports how which costs have been posted in the GL but have NOT been 
posted in Job Cost, and vice versa.

For example, for costs that are in Job Cost but not the GL, you may have posted to the GL, but did not post the GL batch 
yet. Conversely, for costs in the GL but not in Job Cost, you may have posted costs from any other module to those 
accounts, for example, an adjustment entry to the account not assigned to a job.

When transactions are posted that are applied to a job, the JC20001 table will be updated with the ORTRXSRC 
(originating transaction source) from the GL20000 table, and with the JRNENTRY (journal entry) number. In 
addition, transactions in the GL10001 (so all batches must be posted in GL) and GL30000 (for transactions in 
closed years) are checked.


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Sample Report Sequence

The following steps demonstrate how these reports can be used to help reconcile WIP and Progress Billings accounts as 
part of month end reconciliation.

Step 1: Run the WIP reconciliation Summary report

Run the summary version of the WIP reconciliation report to see which amounts balance; you can filter the report for 
the month you are reconciling. If you open the Summary Inquiry window to view GL activity (Inquiry > Financial > 
Summary), the Net Change for a period should match the same account's total for the same date range on the 
reconciliation report.

Step 2: Run the WIP reconciliation Detail report

If summary report totals do not balance, you can view transaction-level detail for the period. This may help identify 
discrepancies.

Step 3: Run the Exception reports

If you still cannot pinpoint the issue, these reports identify transactions that were posted to your Job WIP accounts but 
not to the GL, and vice versa. These reports check all accounts that are used in the current setup or data set as WIP or 
Progress Billing accounts, as well as AR invoices, cost tables for open and closed jobs, and the POC revenue recognition 
entry, will be checked.

The exception reports identify journal entries along with the type of transaction and the user who posted it. For 
example, the issue may be a payable that debited WIP without the job number filled in, or a journal entry that was made 
directly to the GL instead of through Job Cost. The report helps you identify the transaction and assess user training 
needs.

Step 4: Make any adjustments to GL or Job Cost accounts

Posting Setup

Before you run the WIP reconciliation reports, your posting options must be set up to create journal entries for 
transactions. You must set this up for the following product series: Inventory (with an origin of Transaction Entry) and 
Sales (with an origin of Sales Transaction Entry). These may have already been set up, but we recommend that you 
double-check the setup.

Select Microsoft Dynamics GP > Tools > Setup > Posting > Posting. The Posting Setup window opens.
In the Series drop-down menu, select Sales.
In the Origin drop-down menu, select Sales Transaction Entry.
Under Create a Journal Entry, select the Transaction radio button.
In the Series drop-down menu, select Inventory.
In the Origin drop-down menu, select Transaction Entry.
Select OK.

Running the JC WIP Reports

Select Reports > Job Cost > Job Reports > Audit Reports > Job WIP Reports. The JC WIP Reports window opens.
Enter a Start Date and End Date.
Select to run by all or individual Division, Job, and/or Cost Element.

The Job to Date or JTD line of the Job Percentage of Completion report can also be used to identify the 
balance in other accounts, such as Over Billing, Under Billing, and Progress Billing. In addition, the Month to 
Date (MTD) line shows activity for the year and period.


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Select an Account Number.
Select to run a WIP report (summary or detail) or Exception report.
Select Print.

If you are using SSRS reports, these Dexterity reports are replaced with the SSRS versions; refer to WIP Reports in Job 
Cost (page 149).

Summary

Detail
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Exception Report - Job Cost costs not in GL

Exception Report - GL costs not in Job Cost

Job Cost Edit Lists
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POC Edit List (page 222)
Payables Edit List (page 222)
Inventory Edit List (page 222)

POC Edit List
You may want to print the POC Edit List prior to closing a period in Job Cost, as well as before building a POC entry. The 
report contains cost element totals, progress billings, contract earned, billings in excess of cost plus earnings, and 
unbilled receivable amounts for all open jobs. In addition, expected contract, revised forecast, and total cost amounts 
appear. If the information on the POC Edit List is inaccurate, you may select to run the Recreate Summary utility to help 
correct this information.

Totals for jobs that are excluded from POC do not appear on this report. Unless you are using a separate division with 
separate accounts for non-POC jobs, excluding jobs from POC may cause a discrepancy between the totals on the edit 
list and the balance in your accounts.

Select Reports > Job Cost > Edit Lists > POC Edit List.
Enter the Year and use the lookup button to select a Period in the year. The Job and date fields are disabled for 
this report.
Select Print.

Payables Edit List
The Payables Edit List contains job and cost code information for an accounts payable batch. Print this report before 
posting to verify the accuracy of your transactions. If an error appears, you can correct the entries, print another edit list 
to review your corrections, and then post.

Select Reports > Job Cost > Edit Lists > Payables Edit List.
Enter a Batch Number.
Select Print.

Inventory Edit List
The Inventory Edit List contains job and cost code information for the selected inventory batch. Print this report before 
posting to verify the accuracy of your transactions. If an error appears, you can correct the entries, print another edit list 
to review your corrections, and then post.

Select Reports > Job Cost > Edit Lists > Inventory Edit List.
Enter a Batch Number.
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Select Print.

Billing Reports

Billing Report (page 225)
Retention Report (page 225)
Over (Under) Billing Report (page 226)
Unbilled Costs Report (page 226)
Transaction Detail Report (page 227)
Transaction Summary Report (page 227)
Aged Trial Balance Report (page 228)

Billing Report
The Billing report lists the net billed, total contract earned, and cash received amounts for each job, including an over- 
or under-billed amount. Company totals for all jobs appear at the bottom of the report.

Select Reports > Job Cost > Billing Reports > Billing.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.

Retention Report
The Retention report lists retention withheld, retention billed, and billable retention amounts for open jobs. Retention 
amount totals for all open jobs appear at the bottom of the report.

Select Reports > Job Cost > Billing Reports > Retention.
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Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.

Over (Under) Billing Report
The Over (Under) Billing report lists over- or under-billed amounts for all open jobs. The report also includes posted 
costs, estimated gross profit, revenues earned, and amounts billed to date for each open job.

Select Reports > Job Cost > Billing Reports > Over (Under)Billing.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.

Unbilled Costs Report
The Unbilled Costs report lists unbilled costs for a job or a range of jobs. This report can only be printed for jobs that 
have a contract type of Cost Plus and a billing type of Transaction Level or Project Trx Level.

Select Reports > Job Cost > Billing Reports > Transaction Level Reports > Unbilled Costs.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.
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Transaction Detail Report
The Transaction Detail report lists the transactions made in a range of jobs, over a range of dates. When a date range is 
selected, the report will consider the GL posting date of the transactions being billed, not the GL posting date of the 
billing invoices. If you do not select a date range, the job transactions will be listed for all dates. If you select a date 
range but do not select a range of jobs, all job transactions will be listed for that date range. This report can only be 
printed for jobs that have a contract type of Cost Plus and a billing type of Transaction Level or Project Trx Level.

Select Reports > Job Cost > Billing Reports > Transaction Level Reports > Transaction Detail.
From the Range drop-down list, select Job Number or Enter Date.
Use the From and To lookup buttons to select a range of job numbers or date range. Select Insert >>.
Select Print.

Transaction Summary Report
The Transaction Summary report lists summary information of transactions made in a range of jobs, over a range of 
dates. If you do not select a date range, the job transactions will be listed for all dates. If you select a date range but do 
not select a range of jobs, all job transactions will be listed for that date range.
This report can only be printed for jobs that have a contract type of Cost Plus and a billing type of Transaction Level or 
Project Trx Level.

Select Reports > Job Cost > Billing Reports > Transaction Level Reports > Transaction Summary.
Use the Ranges drop-down list to select a range type.
Use the From and To lookup buttons to select the print range. Select Insert >>.
If you want to further restrict the range, select the other range type and enter the range.
Select Print.
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Aged Trial Balance Report
The Aged Trial Balance report is a statement of all the open debit and credit items in a double-entry ledger to show the 
equality and maturity from an entered date. You can print an Aged Trial Balance report for each job. You must run the 
receivables aging process routine (Routines > Sales > Aging) prior to printing the report.

Select Reports > Job Cost > Billing Reports > Aged Trial Balance.
Enter a Date from which to start aging. Items dated later than the date entered here will not be included on the 
report.
If you want to print the report for a specific project manager, mark the By Manager checkbox and enter the 
manager.
Select a sorting method from the Sort drop-down list. You can sort by job number or customer ID. If you sort by 
customer ID, the report includes a Retainer column.
Select range type from the drop-down list. Use the From and To lookup buttons to select the print range. Select 
Insert >>.
Select Print.

This report will not include closed jobs. If you would like your report to include closed jobs, you can use the 
SRS Aged Trial Balance report. You must have SRS reports enabled to print the SRS Aged Trial Balance report.


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Sorted Reports
Sorted reports list job information per division, project number, or project manager. These reports include Profit and 
Loss, Job Schedule, Over (Under) Billing, Backlog, Retention, Employee Summary, Project Summary, Costs by Period, 
and Labor Summary. You can also print a Division Billing report by division.

Division Reports
Reports that are sorted per division include Profit and Loss, Job Schedule, Over (Under) Billing, Backlog, Billing, 
Retention, Employee Summary, Project Summary, Costs by Period, and Labor Summary reports.

Profit and Loss by Division Report (page 227)
Job Schedule by Division Report (page 230)
Over (Under) Billing by Division Report (page 230)
Backlog by Division Report (page 231)
Billing by Division Report (page 231)
Retention by Division Report (page 232)
Employee Summary by Division Report (page 232)
Project Summary by Division Report (page 233)
Costs by Period by Division Report (page 233)
Labor Summary by Division Report (page 234)

Profit and Loss by Division Report

The Profit and Loss by Division report lists customers, percent complete, contract earned, actual cost to date, and profit 
or loss for jobs within the selected divisions.

Select Reports > Job Cost > Sorted Reports > Division Reports > Profit and Loss.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.
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Job Schedule by Division Report

The Job Schedule by Division report lists the contract, forecasted cost, anticipated profit, and contract-to-date 
amounts for jobs within the selected divisions.

Select Reports > Job Cost > Sorted Reports > Division Reports > Job Schedule.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.

Over (Under) Billing by Division Report

The Over (Under) Billing by Division report lists posted cost, estimate profit, revenues earned, and billed-to-date 
amounts for jobs within the selected divisions.

Select Reports > Job Cost > Sorted Reports > Division Reports > Over (Under) Billing.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.
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Backlog by Division Report

The Backlog by Division report lists original contract, contract earned, and backlog amounts for jobs within the selected 
divisions.

Select Reports > Job Cost > Sorted Reports > Division Reports > Backlog.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.

Billing by Division Report

The Division Billing report lists total contract, gross billed retention, net billed, and cash received amount for jobs 
within the selected divisions.

Select Reports > Job Cost > Sorted Reports > Division Reports > Billing.
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Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.

Retention by Division Report

The Retention by Division report lists the total contract, retention withheld, retention billed, and billable retention 
amounts for jobs within the selected divisions.

Select Reports > Job Cost > > Sorted Reports > Division Reports > Retention.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.

Employee Summary by Division Report

The Employee Summary by Division report contains all hours, labor amounts, overhead amounts, and totals for each 
job number assigned to the selected division. The transaction beginning and ending dates must match the Date and To 
dates from payroll entry.

Select Reports > Job Cost > Sorted Reports > Division Reports > Employee Summary.
Select a Division.
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Enter beginning and ending dates.
Select Print.

Project Summary by Division Report

The Project Summary by Division report displays actual labor hours, labor cost, other costs, estimated labor hours, 
labor cost, and other costs for all projects assigned to the selected division.

Select Reports > Job Cost > Sorted Reports > Division Reports > Project Summary.
Select a Division.
Enter a data range.
Select Print.

Costs by Period by Division Report

The Costs by Period report lists the actual costs to date and costs per selected period for jobs within the selected 
divisions.

Select Reports > Job Cost > Sorted Reports > Division Reports > Costs by Period.
Enter a year(s) in the From and To fields. Use the lookup buttons in the Period ID From and To fields to select 
the period range.
Use the lookup buttons to select the print range. Select Insert >>.
Select Print.
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Labor Summary by Division Report

The Labor Summary by Division report contains all hours and totals for each job number assigned to a division. The 
transactions on the report are based on the general ledger posting date. This report is for open jobs only.

Select Reports > Job Cost > Sorted Reports > Division Reports > Labor Summary.
Select a Division.
Enter beginning and ending dates and select Print.

Project Manager Reports
Reports that are sorted per project manager include Profit and Loss, Job Schedule, Over (Under) Billing, Backlog, 
Billing, Retention, Employee Summary, Project Summary, Costs by Period, and Labor Summary reports.

Profit and Loss by Project Manager Report (page 235)
Job Schedule by Project Manager Report (page 235)
Over (Under) Billing by Project Manager Report (page 236)
Backlog by Project Manager Report (page 236)
Billing by Project Manager Report (page 237)
Retention by Project Manager Report (page 237)
Audit Costs by Project Manager Report (page 238)
Costs by Period by Project Manager Report (page 238)
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Profit and Loss by Project Manager Report

The Profit and Loss by Project Manager report lists customers, percent complete, contract earned, actual cost to date, 
and profit or loss for jobs assigned to the selected project managers.

Select Reports > Job Cost > Sorted Reports > Project Manager Reports > Profit and Loss.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.

Job Schedule by Project Manager Report

The Job Schedule by Project Manager report lists the contract, forecasted cost, anticipated profit, and contract-to-date 
amounts for jobs assigned to the selected project managers.

Select Reports > Job Cost > Sorted Reports > Project Manager Reports > Job Schedule.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.
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Over (Under) Billing by Project Manager Report

The Over (Under) Billing by Project Manager report lists posted costs, estimated profit, revenues earned, and billed-to-
date amounts for jobs assigned to the selected project managers.

Select Reports > Job Cost > Sorted Reports > Project Manager Reports > Over (Under) Billing.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.

Backlog by Project Manager Report

The Backlog by Project Manager report lists original contract, contract earned, and backlog amounts for jobs assigned 
to the selected project managers.

Select Reports > Job Cost > Sorted Reports > Project Manager Reports > Backlog.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.
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Billing by Project Manager Report

The Billing by Project Manager report lists total contract, gross billed retention, net billed, and cash received amount for 
jobs assigned to the selected project managers.

Select Reports > Job Cost > Sorted Reports > Project Manager Reports > PM Billing.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.

Retention by Project Manager Report

The Retention by Project Manager report lists the total contract, retention withheld, retention billed, and billable 
retention amounts for jobs assigned to the selected project managers.
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Select Reports > Job Cost > Sorted Reports > Project Manager Reports > Retention.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.

Audit Costs by Project Manager Report

The Audit Costs by Project Manager report lists transactions, documents, vendors, and employee transaction quantities 
for the jobs assigned to the selected project managers.

Select Reports > Job Cost > Sorted Reports > Project Manager Reports > Audit Costs.
Select a Project Manager.
Select a Date Range radio button, and enter the dates.
Select a Range radio button, and enter a cost element type or All. Mark the Exclude Inactive checkbox to 
exclude inactive cost codes from the report.
Select Print.

Costs by Period by Project Manager Report

The Costs by Period by Project Manager report lists the actual costs to date and costs per period for jobs assigned to the 
selected project managers.

Select Reports > Job Cost > Sorted Reports > Project Manager Reports > Costs by Period.
Enter a range of years and periods.
Select a manager range and select Insert >>.
Select Print.
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Project Number Reports
Reports that are sorted per project number include Profit and Loss, Job Schedule, Over (Under) Billing, Backlog, Billing, 
Retention, Employee Summary, Costs by Period, and Labor Summary reports.

Profit and Loss by Project Report (page 239)
Job Schedule by Project Report (page 240)
Over (Under) Billing by Project Report (page 240)
Backlog by Project Report (page 241)
Billing by Project Report (page 241)
Retention by Project Report (page 242)
Employee Summary by Project Report (page 242)
Costs by Period by Project Report (page 242)
Labor Summary by Project Report (page 243)

Profit and Loss by Project Report

The Profit and Loss by Project report lists customers, percent complete, contract earned, actual cost to date, and profit 
or loss for jobs within the selected projects.

Select Reports > Job Cost > Sorted Reports > Project Reports > Profit and Loss.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.
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Job Schedule by Project Report

The Job Schedule by Project report lists the contract, forecasted cost, anticipated profit, and contract-to-date amounts 
for jobs within the selected projects.

Select Reports > Job Cost > Sorted Reports > Project Reports > Job Schedule.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.

Over (Under) Billing by Project Report

The Over (Under) Billing by Project report lists posted costs, estimated profit, revenues earned, and billed to date 
amounts for jobs within the selected projects.

Select Reports > Job Cost > Sorted Reports > Project Reports > Over (Under) Billing.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.
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Backlog by Project Report

The Backlog by Project report lists original contract, contract earned, and backlog amounts for jobs within the selected 
projects.

Select Reports > Job Cost > Sorted Reports > Project Reports > Backlog.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.

Billing by Project Report

The Billing by Project report lists total contract, gross billed retention, net billed, and cash received amount for jobs 
within the selected projects.

Select Reports > Job Cost > Sorted Reports > Project Reports > Project Billing.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.
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Retention by Project Report

The Retention by Project report lists the total contract, retention withheld, retention billed, and billable retention 
amounts for jobs within the selected projects.

Select Reports > Job Cost > Sorted Reports > Project Reports > Retention.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.

Employee Summary by Project Report

The Employee Summary by Project report contains all hours, labor amounts, overhead amounts, and totals for each job 
number assigned to a project. The transaction beginning and ending dates must match the Date To dates from payroll 
entry.

Select Reports > Job Cost > Sorted Reports > Project Reports > Employee Summary.
Select a Project Number.
Enter beginning and ending dates.
Select Print.

Costs by Period by Project Report

The Costs by Period by Project report lists the actual costs to date and costs per selected period for jobs within the 
selected projects.

Select Reports > Job Cost > Sorted Reports > Project Reports > Costs by Period.
Enter the range of years and periods.



241

3.
4.

1.
2.
3.

•
•
•
•
•
•
•
•
•

Select the project number print range and select Insert >>.
Select Print.

Labor Summary by Project Report

The Labor Summary by Project report contains all hours and totals for each job number assigned to a project. The 
transactions on the report are based on the general ledger posting date. This report is for open jobs only.

Select Reports > Job Cost > Sorted Reports > Project Reports > Labor Summary.
Select a Project Number.
Enter beginning and ending dates and select Print.

Labor Reports

Job Labor Report (page 244)
Certified Payroll Report (page 244)
Union Report (page 243)
Rate Class Setup Report (page 244)
Rate Class Union Report (page 244)
Employee Union Report (page 247)
Monthly Union Report (page 248)
Monthly Payroll Report (page 249)
Monthly Contribution Report (page 249)
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Technician Schedule Report (page 250)

Job Labor Report
The Job Labor report contains estimated, actual, and remaining labor hours for all labor cost codes for the job, as well 
as field estimated percentage complete and the percentage of the cost code completed based on the field estimate. 
This report also projects gain or loss for each cost code, based on the field-estimated percentage complete.

Select Reports > Job Cost > Labor Reports > Job Labor.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.

Certified Payroll Report
The Certified Payroll report lists employee information, details of hours worked, hourly rate, gross earned in job, 
deductions, and net weekly pay for the selected jobs.

You must have an address ID entered in the Employee Address Maintenance window (Cards > Payroll > Employee > 
Address) for transactions to appear on the Certified Payroll report. To print a Certified Payroll report using SRS, refer to 
the TimeTrack manual. When building your payroll batches for certified payroll checks, the From and To dates of the 
Pay Period Date field in the Build Payroll Checks window (Transactions > Payroll > Build Checks) must be in a seven-day 
range. The From (beginning) date must be the beginning day of the week; the To (ending) date must be the week-
ending date from the payroll transaction. This applies to both Microsoft Dynamics GP and TimeTrack payroll 
transactions.

Select Reports > Job Cost > Labor Reports > Certified Payroll.
Enter the transaction beginning and ending dates.
Select to print the report for all transactions, one job, or a range of jobs. Enter a Job Number or Range.
Select Print.

To print accurate certified payroll reports, you must print your payroll checks using the Microsoft Dynamics GP 
Payroll module.


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Union Report
The Union report is a combination of the Union report and Union Summary report. Both reports contain weekly pay 
amounts, benefit, and deduction contributions for each employee in the union. You can also sort the employees by 
name or position and automatically calculate gross wages by transaction date or check date. A maximum total of 150 
benefits and deductions will print on the Union report. The Union Summary report lists a summary for all union 
employees.

Select Reports > Job Cost > Labor Reports > Union.
Enter the date to begin the report. If you are going to calculate gross wages based on a check date, enter the first 
day of the month in which the check was issued, rather than the first day of the month when the pay period 
began.
Select to print a Union report, Union Summary report, or both. The default is Summary, which is both reports. 
To print only the Union Summary report, mark the Summary Only checkbox. To print only the Union report, 
unmark both checkboxes.
Enter the beginning and ending dates of the pay weeks for which you want report information. 

Select to Sort the report by position or by employee last name. If you sort by position, a subtotal is given for 
each position. The report also includes a total by union. If you sort by employee last name, the report will total 
by union and not by position.
Select to Calculate Gross Wages by check date or transaction date. If you select to calculate by check date, the 
employee summary table is used to get the gross wages. Make sure that, if your pay period begins in one month 
and ends in another, the Month Begin Date is the first day of the month in which the check was issued, rather 
than the first day of the month in which the pay period began. If you select to calculate by transaction date, the 
payroll transaction history table is used to get the gross wage amount for each transaction.
Select Print.

For this report, the pay week must begin and end on the first and last days of the week as defined for 
the pay period (Transactions > Payroll > Build Checks).


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Rate Class Setup Report
The Rate Class Setup report lists all rate classes entered.

Select Reports > Job Cost > Labor Reports > Rate Class.
Enter a rate class range or select All to include all rate classes.
Enter a union code range or select All to include all union codes.
Select Print.

Rate Class Union Report
The Rate Class Union report is a combination of  the Union report and Union Summary report. Both reports contain the 
amount of hours and gross wages. The Union report is organized by union employee; the Union Summary report is 
organized by union and rate class. You can run the report for a single union code or a range of union codes.

Select Reports > Job Cost > Labor Reports > Rate Class Union.
In the Month Begin Date field, enter the beginning date for the report.
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Select to print a Union report, Union Summary report, or both. The default is Summary, which is both reports. 
To print only the Union Summary report, mark the Summary Only checkbox. To print only the Union report, 
unmark both checkboxes.
Enter the starting and ending union codes.
Enter the beginning and ending dates for each week. If you leave these fields blank, the dates will automatically 
fill in, starting from the date entered in the Month Begin Date field.
In the Options area, select either Position or Name as the sorting option for the report.
Select Print.

Employee Union Report
The Employee Union report lists all the employees who belong to a union. The report contains deduction/benefits 
amounts, hours, and pay amount. The report is organized by union, then rate class.

Select Reports > Job Cost > Labor Reports > Employee Union.
Use the Ranges drop-down list to select the range for running the report. You can specify ranges for the 
employee ID, week-ending date, and union code. 

In the From and To fields, select the beginning and ending values for your range. For the Employee ID and 
Union Code ranges, use the lookup buttons to select values. For the Week-Ending Date range, enter the 
beginning and ending transaction dates, not the week-ending dates.
Select Insert >>. You can create one range for each type of range.
Select Print.

If you don't select a range, the report will print all values for all range types.
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Monthly Union Report
The Monthly Union report contains the number of hours and amount of earnings for each union employee within a 
specified time period and union range. The report also contains hours and earnings by rate class. This report is 
organized by union code.

Select Reports > Job Cost > Labor Reports > Monthly Union.
In the Ranges field, use the drop-down list to select the range(s) for the report. You can specify ranges for the 
week-ending date and for union code.
In the From and To fields, enter the beginning and ending values for your range. For the Week-Ending Date 
range, enter the beginning and ending transaction dates, not the week-ending dates.
Select Insert >>. You can create one range for each type of range.
Select Print.
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Monthly Payroll Report
The Monthly Payroll report contains the total hours and gross earnings for union employees within a specified time 
period.

Select Reports > Job Cost > Labor Reports > Monthly Payroll.
In the From and To fields, enter the beginning and ending values for your range. Enter the beginning and ending 
transaction dates, not the week-ending dates.
Select the Insert >>. You can select one range per report.
Select Print.

Monthly Contribution Report
The Monthly Contribution report contains the benefits, deductions, hours, and gross earnings for each employee in a 
union.

Select Reports > Job Cost > Labor Reports > Monthly Contribution.
In the Ranges field, use the drop-down list to select the range(s) for the report. You can specify ranges for the 
week-ending date and for union code.
In the From and To fields, select the beginning and ending values for your range. For the Week-Ending Date 
range, enter the beginning and ending transaction dates, not the week-ending dates.
Select Insert >>. You can create one range for each type of range.
Select Print.



248

1.
2.
3.
4.
5.

Technician Schedule Report
The Technician Schedule report lists jobs and the technicians scheduled to work on the jobs. You can print the report 
for all jobs, a single job, or a range of jobs. You can also filter the report by cost code number. The Technician Schedule 
report is available if you're using the Job Scheduling feature.

Select Reports > Job Cost > Labor Reports > Technician Schedule.
Select to print the report for all jobs, a single job, or a range of jobs. Enter the Job Number or range.
Enter the date range.
Select to print the report for all cost codes or a specific cost code. Enter the Cost Code.
Select Print.
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Setup Reports
You can print reports from your Job Cost setup. These include Cost Code Master, Posting Options, Project Number, 
Overhead Detail, and Overhead Groups, and Architects reports.

Cost Code Master Setup Report (page 251)
Posting Options Report (page 252)
Project Number Setup Report (page 253)
Overhead Detail Codes Report (page 254)
Overhead Group Codes Report (page 254)
Architect Setup Report (page 255)

Cost Code Master Setup Report
The Cost Code Master Setup report contains all master cost codes, descriptions, and cost element types. Review this list 
once you set up all master cost codes to ensure your list is complete.
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Select Reports > Job Cost > Setup Reports > Cost Code Master.

Posting Options Report
The Posting Options report lists the setup options you selected in the Posting Options window. This includes your 
revenue recognition method, whether you post payroll through general ledger, and whether you want to print Certified 
Payroll reports.
Select Reports > Job Cost > Setup Reports > Posting Options.
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Project Number Setup Report
The Project Number Setup report lists all project numbers and associated jobs set up in Job Cost. Use this list as a 
reference when you set up projects.
Select Reports > Job Cost > Setup Reports > Project Number.
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Overhead Detail Codes Report
The Overhead Detail Codes report lists setup options entered for all overhead detail codes in the Overhead Detail Codes 
Setup window. Overhead detail codes define how overhead calculates based on payroll costs.
Select Reports > Job Cost > Setup Reports > Overhead Detail Codes.

Overhead Group Codes Report
The Overhead Group Codes report lists the setup options entered for tracking overhead in the Overhead Groups Setup 
window. The report also lists the overhead details assigned to the group.
Select Reports > Job Cost > Setup Reports > Overhead Groups.
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Architect Setup Report
The Architect Setup report lists all architects entered.
Select Reports > Job Cost > Setup Reports > Architects.

History Reports

Job History Report (page 255)
Job History Detail Report (page 256)
Job History Notes Report (page 257)

Job History Report
The Job History report lists committed, posted, estimated, and forecasted costs for each cost element, as well as 
estimated gross profit, change order, and other job information for closed jobs.

Select Reports > Job Cost > History Reports > Job History.
Select to print the report for all jobs, a single job, or a range of jobs. If you select the Job Number or Range radio 
button, enter the number or range.
Select Print.
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Job History Detail Report
The Job History Detail report includes estimate and actual cost code amounts for a closed job.

Select Reports > Job Cost > History Reports > Job Detail History.
Select a Job Number.
Select Print. The sorting options are disabled for this report.



255

1.
2.

3.

•
•
•
•

Job History Notes Report
The Job History Notes report lists notes from closed jobs.

Select Job Cost > Reports > History Reports > History Notes.
Select to print the report for all jobs, a single job, or a range of jobs. If you select the Job Number or Range radio 
button, enter the number or range.
Select Print.

Subcontractor Reports
Subcontractor reports relate to subcontractors used on jobs. Reports include Vendor Activity, Subcontractor Status, 
Subcontractor Detail, Subcontractor Retention, and Insurance Expired, Subcontractor Cost Codes, and Subcontractor 
Summary Status reports.

Vendor Activity Report (page 258)
Subcontractor Status Report (page 258)
Subcontractor Detail Report (page 259)
Subcontractor Retention Report (page 260)
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Insurance Expired Report (page 260)
Subcontractor Cost Codes Report (page 261)
Subcontractor Summary Status Report (page 262)
Subcontractor Claims Report (page 263)
Subcontractor Supplemental Report (page 263)

Vendor Activity Report
The Vendor Activity report contains a list of vouchers entered for a job, sorted by vendor. The report also includes total 
units purchased, the cost-per-unit, and the total cost for each vendor.

Select Reports > Job Cost > Subcontractor Reports > Vendor Activity.
Use the Ranges drop-down list to select a range type.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.

Subcontractor Status Report
The Subcontractor Status report contains the jobs, contract information, contract amounts, insurance information, and 
invoice amounts for each subcontractor.

Select Reports > Job Cost > Subcontractor Reports > Subcontractor Status.
Use the Ranges drop-down list to select a range type.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.
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Subcontractor Detail Report
The Subcontractor Detail report contains jobs, contract amount, and invoice detail for each subcontractor.

Select Reports > Job Cost > Subcontractor Reports > Subcontractor Detail.
Use the Sort By drop-down to select the sorting method. You can sort by vendor ID or job number.
Use the Ranges drop-down list to select a range type.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.
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Subcontractor Retention Report
The Subcontractor Retention report contains jobs, contract amounts, and retention information for each 
subcontractor.

Select Reports > Job Cost > Subcontractor Reports > Subcontractor Retention.
Use the Sort By drop-down to select the sorting method. You can sort by vendor ID or job number.
Use the Ranges drop-down list to select a range type.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.

Insurance Expired Report
The Insurance Expired report contains insurance and expiration date information for each vendor.

Select Reports > Job Cost > Subcontractor Reports > Insurance Expired.
Use the Ranges drop-down list to select a range type.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.
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Subcontractor Cost Codes Report
The Subcontractor Cost Codes report contains a list of cost codes assigned to each vendor. The report is sorted by job, 
then vendor.

Select Reports > Job Cost > Subcontractor Reports > Subcontractor Cost Codes.
Use the Ranges drop-down list to select a range type.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.
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Subcontractor Summary Status Report
The Subcontractor Summary Status report summarizes contract information for all jobs for which the subcontractor is 
being used.

Select Reports > Job Cost > Subcontractor Reports > Subcontractor Summary Status.
Use the Ranges drop-down list to select a range type.
Use the From and To lookup buttons to select the print range. Select Insert >>.
Select Print.
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Subcontractor Claims Report
This report displays the cost code description, total amount of the payment claim and the scheduled amount. This 
report reflects all cost codes for each job as well as the comments entered in the Reason Note field of the Contract 
Claimed Amounts window. The report creates a separate page for each job.

Subcontractor Supplemental Report
This report provides for all the required Building and Construction Industry Security of Payment (Supporting 
Statement) Regulation 2014 supporting statement information.

Service Management Dexterity Reports
Service Management is shipped with a set of Dexterity reports that can be customized with Report Writer, which ships 
with Microsoft Dynamics GP System Manager module. Some reports provide helpful information about your customers 
and their locations. Others track your service call information and monitor equipment information for each customer 
location. Other reports show salesperson commissions and maintenance contract profitability. Some standard reports 
can be used as marketing tools to offer maintenance contracts to repeat service call customers. They can also be 
helpful for maintaining your customer file information or if you want to print company information.

Reports print to the screen in full screen mode. Use the full screen button, which is located next to the Mail button in the 
upper left corner of all report windows, to toggle to partial screen view.

If you're using global filtering, you can use global filters when printing some reports. Use the drop-down list in the 
report setup window to select a branch. The report prints only the records belonging to the selected branch. If you 
select User Profile from the drop-down list, the global filter defaults based on your user profile setup. You can select the 
Branch indicator at any time to see the global filters you've chosen.

The reports are grouped into three areas: General, Service, and Maintenance. In most cases, you have the option of 
printing a report to the screen, to a printer, or to a file.

You may wish to print some of the reports when you have finished setting up Service Management. A current 
copy of each report could be kept on file in case the files containing the information become damaged.


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If SQL reporting has been set up, some of the standard Dexterity reports may have been replaced by SQL reports. 
Additional SQL reports are available to print from Report Manager or the Custom Reports list.

General Reports

Contact ID Report
You can assign contacts to locations and maintenance contracts. The Contact ID report lists the contact ID, contact 
name, address, and contact organization.

Select Reports > Service Management > General > Contacts.
Select a sorting method from the drop-down list.
Select whether to include all contacts or a range. Enter the range, if applicable.
Select whether to print a summary report, detail report, or labels.

Customer Locations Report
Since some service customers may have multiple locations, you can print the Customer Locations report to list each 
location's information. The Customer Locations report is compiled from the service call database. It lists the customer's 
address information, salesperson, labor group name, pricing matrix name, and user-defined field information for each 
location.

Select Reports > Service Management > General > Customer Locations.
Select a customer using the lookup button in any field. When searching by customer ID, customer name, or 
address 1, you must make a partial entry and then select the lookup button to begin the search. When searching 
by location phone, enter a phone number and then select the phone button to begin the search. If a match is 
found, the customer record will be retrieved.
Select Print.

Remember, you can set a default report destination in the Microsoft Dynamics GP User Preferences window 
(Microsoft Dynamics GP > Tools > Setup > User Preferences).


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Customer Report
The Customer report lists information on your service customers.

Select Reports > Service Management > General > Customer Report.
Select a sorting method from the drop-down list.
Select to print all customers or a range of customers. Enter the customer range, if applicable.
Select to print a summary report, a detail report, or labels.
Select a sorting method from the drop-down list. The last two choices in the drop-down list are user-defined 
fields.
Select Print.
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Summary (page 264)
Detail (page 265)

Summary

If you don't have information in a field you are sorting by, the record is skipped.
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Detail

Equipment at Location
The Equipment at Location report lists the equipment information at a customer location. The report compiles 
information from the equipment database.

Select Reports > Service Management > General > Equipment at Location.
Select a customer using the lookup button in any field. When searching by Customer ID, Customer 
Name, Location Name, or Address 1, you must make a partial entry in the field and then select the lookup 
button to begin the search. When searching by location phone, enter a phone number and then select the phone 
button to begin the search. If a match is found, the customer record will be retrieved.
You can limit the data in the lookup windows by selecting a branch name from the drop-down list at the top of 
the window.
Select Print.
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Invalid 
Labor 
Rate 
Groups
The 
Invalid 
Labor 
Rate 
Groups 
report 
lists 
locations 
that have 
invalid 
labor 
rates 
assigned. 
A location 
record 
may have 
an invalid 
labor rate 
group if 
the user 
has 
changed 
from 
using 
Service 
labor 
rates to 
using 
overhead 
amounts 
from Job 

Cost to determine labor rates. The report also prints after marking or unmarking the setup option to use overhead 
amounts from Job Cost.

Select Reports > Service Management > General > Invalid Labor Rates.
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Lookup Reports
Most windows in Service Management have fields with attached lookup windows. The lookup window contents can be 
printed in report format. You can select to print all reports at once or each report individually. It can be helpful to have a 
copy of the lookup window entries for your records or to note any duplications in the lists.

All Lookup Reports (page 269)
Customer Window Lookups Report (page 268)
Equipment Window Lookups Report (page 268)
Maintenance Contract Types List (page 271)
Maintenance Task Codes Report (page 273)
Maintenance Tasks by Equipment Type Report (page 274)
Service Call Window Lookups Report (page 275)
Task Code Task Lists Report (page 277)

All Lookup Reports

All lookup reports print at once. When one report window is closed, the next report opens. Select Reports > Service 
Management > General > Lookups > All.

Each report can be printed to a printer by choosing the Print button in the screen output window.
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Customer Window Lookups Report

The Customer Window Lookups report lists the lookup window items in the User-Defined 1 and User-Defined 2 lookup 
windows.
Select Reports > Service Management > General > Lookups > Customer.

Equipment Window Lookups Report

The Equipment Window Lookups report lists the contents of the Type of Equipment, Extended Warranty Type, Installed 
By, and Manufacturer lookup windows.
Select Reports > Service Management > General > Lookups > Equipment.
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Maintenance Contract Types List

Select Reports > Service Management > General > Lookups > Contract Types.
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Select Reports > Service Management > General > Lookups > Contract Types.
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Maintenance Task Codes Report

Select Reports > Service Management > General > Lookups >Task Codes.

This report can also be printed from the Task Codes Setup window. Setup > Service Management > Lookup Setup > Task 
Codes.
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Maintenance Tasks by Equipment Type Report

Select Reports > Service Management > General > Lookups > Task Codes by Equipment.
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Service Call Window Lookups Report

There are two Service Call Window Lookups reports. The first report lists the contents of the Technician, Division, 
Status, and Type of Problem lookup windows. When this window is closed, the second Service Call Window Lookups 
report opens, listing the contents of the Type of Call and User-Defined 1 lookup windows. Select Reports > Service 
Management > General > Lookups > Service Call.
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Task Code Task Lists Report

This report can be printed from the Task Codes Setup window. Setup > Service Management > Lookup Setup > Task 
Codes.

Mobile Purchase Order
This report is printed from the Mobile Purchase Order Inquiry window. Inquiry > Service Management > Mobile Purchase 
Order Inquiry.
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Printable Notes Report
You can print notes that have been added to Service Management records using the notepad button and are marked 
printable. You can print the note text, transaction number, cost code, current user, and index.

Select Reports > Service Management > General > Printable Notes.
Select a sorting method from the drop-down list.
To restrict the records that are printed, enter a Range. You can enter a range of customer IDs, current owners, or 
reminder dates.
Select Insert>> to insert the restriction in the scrolling window. You can only enter one restriction per restriction 
type.
Select Print to print the notes that fall within the restrictions you've entered.

Service Reports
Assigned Appointments Report (page 276)
Commission Report (page 279)
Completed Calls Report (page 280)
Contract Escalation Build Report (page 281)
Contract Mass Renewal Reports (page 280)
Customer Reports (page 283)
Escalation Committed Report (page 291)
Escalation Notification Report (page 292)
Guaranteed Service Call Report (page 293)
Inventory Adjustments Edit List (page 294)
Open Service Calls with Costs Report (page 295)
Profitability Report (page 296)
Service at Location Report (page 297)
Service Call Log (page 298)
Service Calls by Salesperson Report (page 299)
Technician Reports (page 300)
Unassigned Appointments Report (page 309)
Unbilled Costs Report (page 310)
Unposted Costs Report (page 311)
WIP Dexterity Reports (page 312)

Assigned Appointments Report
The Assigned Appointments report lists all appointments with a status other than Unassigned or Default. The total 
number of assigned appointments and their total hours listed at the end of the report.

Select Reports > Service Management > Service > Assigned Appointments.
Enter a Start Date and an End Date.
Select whether to include calls with an MCC call type.
Select Print.
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Commission Report
The Commission report lists all salespeople and their commissions for each service call.

Select Reports > Service Management > Service > Commissions.
Enter a Start Date and an End Date.
Select to print the report for All salespeople or an Individual salesperson. Enter a Salesperson ID, if applicable.
Select Print.
Select whether to print a standard or detailed report.
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Standard

Detailed

Completed Calls Report
The Completed Calls report lists the completed service calls by service call ID, contract type, technician, location name, 
and supervisor.

Select Reports > Service Management > Service > Completed Calls.
Enter a Start Date and an End Date.
Use the radio buttons to limit the type of calls reported.
Select Print.
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Contract Escalation Build Report
This report displays the build information for contract escalations. The contract information that is listed includes the 
Customer ID, Address ID, Master Contract, and Contract Number. Also included are indicators if the build is valid, 
forecast missing, if the contract is not 100% billed, not 100% revenue recognized, the number of open calls, if the 
contract is on hold, and the approved status. The totals at the bottom of the report indicate the number of successful 
and unsuccessful contracts in addition to a total number of contracts.
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Contract Mass Renewal Reports
These reports are printed from the Contract Mass Renew window. (Microsoft Dynamics GP > Tools > Routines > Service 
Management > Maintenance Contract > Mass Renewal)

Contract Mass Renewal Report (page 280)
Contract Renew Exception Report (page 280)

Contract Mass Renewal Report

This report displays the Customer ID, Location ID, Contract Number, Contract Type, Master Contract, and Expiration 
Date. Indicators display if the contract is set to auto-renew, on hold, canceled, is greater than 365 days, has open calls, 
not billed 100%, or not recognized 100%. At the bottom of the report, the number of successful contracts, unsuccessful 
contracts, and the total number of contracts are displayed. If there are any unsuccessful contracts, the exception report 
prints afterward with additional information.

Contract Renew Exception Report

The Contract Renew Exception Report prints if there are any contracts that could not be renewed. This report displays 
information about the contracts that were not renewed. Examples may be that the revenue and billing are not 100% 
(depending on your setup), inactive location, inactive customer, and/or a contract is on hold.
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1.
2.
3.

4.

5.

Customer Reports

Mean Time Customer Report (page 283)
Service Calls by Problem Type Report - Customer (page 284)
Cost and Revenue Maintenance Work (ATD) Report (page 285)
C&B Noncontract Work Report - Customer (page 286)
Customer Call History Report (page 287)

Summary (page 287)
Detail (page 288)

Contract Cost Breakdown Report (page 288)
Billing and Revenue Projection Report (page 289)
Mean Time Between Failures Report (page 290)

Mean Time Customer Report

The Mean Time Customer report lists the time between changes in a service appointment's status. The appointment 
statuses used are the user-defined time stamps plus the status Open. (Microsoft Dynamics GP > Tools > Setup > Service 
Management > User-Defined Label Setup > Time Stamp)

Select Reports > Service Management > Service > Customer Reports > Mean Time.
Enter a Start Date and an End Date.
Select time stamps using the drop-down lists in the Start Time Description and End Time Description fields. If 
the time stamps in the drop-down list aren't the ones you defined during setup, you may have connected the 
time stamp to an appointment status. In this case, the appointment status would override the time stamp.
Use the lookup window in the Customer Name, Location Name, and Contract Number fields to select data to 
limit your report. If you leave these fields blank, all data prints. You can select to include all service calls, only MC 
calls, or all service calls except MC calls.
Select Print.
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Service Calls by Problem Type Report - Customer

The Service Calls by Problem Type report lists service calls categorized by problem type.

Select Reports > Service Management > Service > Customer Reports > Calls by Problem.
Enter a Start Date and an End Date.
Select the All or Individual radio button. If you select Individual, use the lookup windows in the Type of 
Problem, Customer Name, Location Name, or Contract Number fields to limit the data in the report.
Select Print.
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Cost and Revenue Maintenance Work (ATD) Report

The Cost and Revenue Maintenance Work (ATD) (actual total to date) report lists the annual value, year-to-date billing, 
year-to-date revenue recognized, year-to-date total costs, and the cost/billing ratio for a maintenance contract. The 
report also lists the plan and actual billing amounts for each cost category. The report is based on the current system 
date.

Select Reports > Service Management > Service > Customer Reports > Contract Work ATD.
Use the lookup windows in the Customer Name, Location Name, and Contract Number fields to limit the 
report data. If you leave the fields blank, all data prints.
Select Print.
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C&B Noncontract Work Report - Customer

The Cost and Billing Noncontract Work report lists the cost amount, billed amount, profit, and cost/billed ratio of non-
maintenance contract work by service call at a location.

Select Reports > Service Management > Service > Customer Reports > C&B Noncontract.
Enter a Start Date and an End Date.
The Customer Cost and Billing radio button should be selected. Select to print the report for All customers or 
an Individual customer. If you select the Individual radio button, use the lookup buttons to select a customer 
and location.
Select Print.
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Customer Call History Report

The Customer Call History report lists all service calls by customer location.

Select Reports > Service Management > Service > Customer Reports > Call History.
Enter a Start Date and an End Date.
You can limit the data in your report by choosing a Customer ID and/or Location ID.
Select to print a Summary or Detail report. The detail report includes the service call ID, description, type of 
problem, date of service call, division, salesperson, purchase order, technician, type of call, call status, 
resolution ID, and hours. The summary report includes only the service call ID, call type, technician ID, call 
status, and resolution ID.
Select Print.

Summary
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Detail

Contract Cost Breakdown Report

The Contract Cost Breakdown report lists the amount posted from maintenance contract service calls on a cost 
category basis.

Select Reports > Service Management > Service > Customer Reports > PM Cost Breakdown.
Enter a Start Date and an End Date.
You can limit the report data by choosing a Customer ID and/or Location ID.
Select Print.
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Billing and Revenue Projection Report

The Billing and Revenue Projection report projects maintenance contract cost and billing amounts monthly. The report 
is listed by maintenance contract numbers within divisions. The customer ID and customer name, location ID and 
location name, start date, expiration, frequency, total amount, billed to date, revenue to date, and whether there is 
automatic billing are reported. The report also shows the billing and revenue amount per month for each contract 
within a division. If you're using global filtering, the report subtotals by division, branch, region, and affiliate.

Select Reports > Service Management > Service > Customer Reports > Contract Revenue.
Select a month from the Starting Month drop-down list and enter a year in the Year field. This is the date the 
report projects from. That is, if you enter July 2003 your report will show revenue between July 2003 and June 
2004.
You can limit the report data by choosing a Customer ID and/or Location ID.
Select Print.
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Mean Time Between Failures Report

The Mean Time Between Failures report lists the time between service call work on specific pieces of equipment. The 
report lists the customer name, location name, equipment ID, equipment type, manufacturer, installation date, MTBF 
average, and the number of calls per piece of equipment.

Select Reports > Service Management > Service > Customer Reports > Mean Time b/Failures.
Enter a Start Date and an End Date.
You can limit your search using the lookup windows in the Customer Name, Location Name, or Equipment 
ID fields or by entering a number in the Maximum Days between Failures field.
Select Print.
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Escalation Committed Report
This report prints after committing escalations for one or more maintenance contracts in the Process Contracts 
window. Included in the report is the year and month you selected from the Build Escalation window, the customer and 
location IDs, contract number, the starting contract amount, and the new contract renewal amount. The header 
displays the date and time the contracts were escalated and the footer includes a total number of contracts that were 
escalated.
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Escalation Notification Report
This report has a breakdown of the escalation amounts for each cost category for all the contracts that are to be 
escalated for a given month, as well as the estimated cost amounts. The contracts appearing on this report are based 
on the Escalation Date on the maintenance contract. (The Escalation Date is calculated as the Expiration Date minus the 
the number entered in Escalation Notification Days.)
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Guaranteed Service Call Report
The Guaranteed Service Call report includes all service calls that have a value in one or more of the Guaranteed Time/
Date fields in the Time Stamp window.

Select Reports > Service Management > Service > Guaranteed Calls.
Select to print either a Detail or Summary report.
Select the sorting method for the report from the drop-down list and select whether to include assigned 
equipment.
Use the drop-down list in the Ranges field to restrict the report.
The restrictions you select determine which fields are available. Use the Insert>> button to add the restrictions to 
the report.
Select Print.



9 https://docs.key2act.io/display/1805b07/Alternate+Windows+and+Reports+Manager
10 https://docs.key2act.io/display/1805b07/

Entering+Inventory+Transactions+in+Service+Management#EnteringInventoryTransactionsinServiceManagement-inventorytrxadjustments
11 https://docs.key2act.io/display/1805b07/Entering+Inventory+Transactions+in+Job+Cost
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Inventory Adjustments Edit List
This is an alternate report that can be printed instead of the Microsoft Dynamics GP Transaction Edit List when entering 
inventory adjustments. The alternate report includes either the service call ID and cost category or the job number and 
cost code in the Signature Information column. Access to this report is set up through the Advanced Windows and 
Reports Manager9.  For information on creating inventory adjustment transactions in Signature, see Entering Inventory 
transactions as adjustments10 or for Job Cost, see Entering Inventory Transactions in Job Cost11.

https://docs.key2act.io/display/1805b07/Alternate+Windows+and+Reports+Manager
https://docs.key2act.io/display/1805b07/Entering+Inventory+Transactions+in+Service+Management#EnteringInventoryTransactionsinServiceManagement-inventorytrxadjustments
https://docs.key2act.io/display/1805b07/Entering+Inventory+Transactions+in+Job+Cost
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Open Service Calls with Costs Report
The Open Service Calls with Costs report lists each open service call ID with the corresponding customer name and cost 
amount. An open service call with costs has unposted equipment, material, labor, subcontractor, or other added 
costs. Because the report prints all unposted service call invoice costs, it can be a helpful tool to track displaced or 
incomplete service calls. The Open Service Calls with Costs report prints if you are using the Service Invoicing module.

Select Reports > Service Management > Service > Service with Costs.
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Profitability Report
As service calls are completed and posted, you can see how profitable they are. A Profitability report can be printed 
detailing the profitability of all or specific service call types for one or all your customers. The service invoices must be 
posted for the call to be included in the report. The Profitability report displays the customer's service call information 
and lists the service call types. Each of the cost category totals is listed, in addition to the total cost, tax, billing amount, 
cost markup, and gross profit for each service call.

Select Reports > Service Management > Service > Profitability.
Enter a Start Date and an End Date.
The Profitability radio button should be selected. Select to print the report for one or all customers and for one 
or all call types. Enter the customer or call type, if necessary.
Select Print.
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Service at Location Report
The Service at Location report lists service call information for a specific customer location within a certain date range. 
The report compiles information from the service call database and includes information from the Service Call window. 
The total number of service calls at the selected customer location is listed at the end of the report.

Select Reports > Service Management > Service > Service at Location.
Select a customer using the lookup button in any field. When searching by Customer ID, Customer 
Name, Location Name, or Address 1, you must make a partial entry in the field and then select the lookup 
button to begin the search. When searching by location phone, enter a phone number and then select the phone 
button to begin the search. If a match is found, the customer record will be retrieved.
Enter a Start Date and an End Date.
Select Print.
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Service Call Log
You can view a history of your service calls.

Select Reports > Service Management > Service > Service Call Log.
Use the drop-down list in the lower left corner of the window to search for a call either by service call ID or by 
created date.
Complete either the Service Call ID or Created Date field as appropriate. Tab off the field to begin the search. 
Your search criteria takes you to the nearest match item in the scrolling data.
Select Print.
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Service Calls by Salesperson Report
The Service Calls by Salesperson report lists all service calls assigned to each salesperson. The report compiles 
information from the service call database and lists the service call ID, location name, call type, problem type, and date 
of call.

Select Reports > Service Management > Service > Service by Salesperson.
Enter a Start Date and an End Date.
Select to print a report for All salespersons or an Individual salesperson. Select a Salesperson ID, if applicable.
Mark the checkbox if you want to Exclude closed and complete calls from the report.
Select Print.
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Technician Reports

Mean Time Technician Report (page 300)
Service Order Aging Report (page 301)
Monthly Labor Plan Report (page 302)
Technician Service Calls Report (page 303)
Service Calls by Problem Type Report - Technician (page 304)
C&B Noncontract Work Report - Technician (page 305)

Summary (page 306)
Detail (page 307)

Contract Service Call Activity Report (page 307)
Service Calls by Technician Report (page 308)

Mean Time Technician Report

The Mean Time Technician report lists the time between changes in a service appointment's status. The appointment 
statuses used are the user-defined time stamps, plus the status Open.

Select Reports > Service Management > Service > Technician Reports > Mean Time.
Enter a Start Date and an End Date.
Use the drop-down lists in the Start Time Description and End Time Description fields to select time stamps. If 
the time stamps in the drop-down list aren't the ones you defined during setup, you may have connected the 
time stamp to an appointment status. In this case, the appointment status would override the time stamp.
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Use the lookup window in the Salesperson ID, Technician Team, and Technician ID fields to select data to limit 
your report. If you leave these fields blank, all data prints.
Select whether to include all service calls, only MC calls, or all service calls except MC calls.
Select Print.

Service Order Aging Report

The Service Order Aging report lists open overdue preventive maintenance service calls. The report ranks the MCC calls 
by days overdue.

Select Reports > Service Management > Service > Technician Reports > Service PM Aging.
Enter a Start Date and an End Date.
You can limit the report data using the lookups in the Salesperson ID, Technician Team, and Technician 
ID fields.
Select Print.
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Monthly Labor Plan Report

To view technicians' labor loading hours grouped by salesperson on a monthly basis, use the Monthly Labor Plan 
report. You can select to display actual hours for all technicians, or the technician assigned to a task/contract. You can 
also view total hours for the primary technician on the contract or the technician assigned to a task.

Select Reports > Service Management > Service > Technician Reports > PM Labor Load Monthly.
Use the drop-down lists in the Start Month and End Month fields to make your selections.
Select the All or Individual radio button. If you select Individual, use the lookup windows in the Salesperson 
ID, Technician Team and Technician ID fields to limit the report data.
Select Print.



301

1.
2.
3.
4.

5.

Technician Service Calls Report

The Technician Service Calls report lists a technician's service calls and appointments.

Select Reports > Service Management > Service > Technician Reports > Service Calls.
Enter a Start Date and an End Date.
Select to include Completed/Closed and MCC calls in the report by marking the checkboxes.
Select to print the report for All technicians or an Individual technician by choosing a radio button. If you select 
Individual, use the lookup buttons in the Salesperson ID, Technician Team, and Technician ID fields to limit the 
report data.
Select Print.
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Service Calls by Problem Type Report - Technician

The Service Calls by Problem Type report lists a technician's service calls categorized by problem type.

Select Reports > Service Management > Service > Technician Reports > Calls by Problem.
Enter a Start Date and an End Date.
Select the All or Individual radio button. If you select Individual, use the lookup windows in the Salesperson ID, 
Technician Team, and Technician ID fields to limit the report data.
Select Print.
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C&B Noncontract Work Report - Technician

The Cost and Billing Noncontract Work report lists the cost amount, billed amount, profit, and cost/billed ratio of 
noncontract work at a specified location.

Select Reports > Service Management > Service > Technician Reports > C&B Noncontract.
Enter a Start Date and an End Date.
The Technician Cost and Billing radio button should be selected. Select to print a summary or detail report.
Select to print the report for All salespeople or an Individual salesperson. If you select the Individual radio 
button, use the lookup button to select a salesperson. You can also filter the report by technician team and 
technician ID.
Select Print.
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Summary
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Detail

Contract Service Call Activity Report

The Contract Service Call Activity report lists the total posted costs of service calls covered by a maintenance contract. 
The service call costs are reported by cost category of each service call for the maintenance contract. The report is listed 
by location, then division, then contract number.

Select Reports > Service Management > Service > Technician Reports > Contract Activity.
Enter a Start Date and an End Date.
Use the lookup windows in the Salesperson ID, Technician Team, and Technician ID fields to limit your report 
data. If you leave the fields blank, all data prints.
Select Print.
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Service Calls by Technician Report

The Service Calls by Technician report lists all service calls assigned to a technician for a specific date range. The report 
compiles information from the service call database and includes information from the Service Call window. The total 
number of service calls and hours for the technician are listed at the end of the report.

Select Reports > Service Management >Service > Technician Reports > Service by Technician.
Enter a Start Date and an End Date.
Select to include All technicians or an Individual technician. Select a Technician ID, if applicable.
Select Print.
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Unassigned Appointments Report
The Unassigned Appointments report lists all appointments for a date range that have an Unassigned or Default status. 
The total number of unassigned appointments and their total hours are listed at the end of the report.

Select Reports > Service Management > Service > Unassigned Appointments.
Enter a Start Date and an End Date.
Select whether to include calls with an MCC call type.
Select Print.
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Unbilled Costs Report
The Unbilled Costs report lists all unbilled labor costs for unposted service calls that have a call status other than 
Complete. The report lists the service call ID, problem description, call status, technician name, location name, service 
invoice date, and hours.

Select Reports > Service Management > Service > Unbilled Costs.
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Unposted Costs Report
The Unposted Costs report lists all unposted costs. You can select to print a summary or detail report and can select 
what cost types and call types to display. The Unposted Costs report prints if you are using SOP invoicing.

Select Reports > Service Management > Service > Service with Costs.
Select a report type by choosing the Summary or Detail radio button. If you select Summary, only the cost 
totals will print. If you select Detail, each line item on a SOP document will print.
In the Include Cost Types field, mark the cost types to display.
In the Include Call Types field, mark the call types to display.
Mark the Subtotal By Division checkbox if you want division subtotals to display on the report.
Select Print.
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WIP Dexterity Reports
At month end, you may want to make sure that the WIP accounts in Service Management balance with the WIP accounts 
in the general ledger (GL). You can run reports that show you which service transactions have and have not been posted 
through to the GL - and which transactions have been posted in the GL, but not to Service Management.

WIP accounts in Signature Service Management and WIP accounts in the general ledger (GL) get "out of balance" mostly 
because of service invoices being posted with unposted costs remaining.

The costs that are committed on a purchase order do not become actual costs until they are received through a 
receivings transaction entry. You can bill a customer prior to receiving actual costs, and when the service invoice is 
posted, WIP accounts are credited and COGS accounts debited for ALL service call costs, including unreceived PO lines. 
In this case, WIP accounts are relieved based on the committed cost remaining for the unreceived PO lines.

When committed costs remain, those amounts are not tracked in the GL. By default, you will not be able to post a 
service invoice that contains committed costs. This will be controlled with options on the Invoice Options window, as 
well as other checkboxes that deal with posted costs.

About Trailing Costs (page 313)
Using WIP Reports at Month End (page 313)
Sample Report Sequence (page 313)

Step 1: Run the Reconciliation Summary Report (page 313)
Step 2: Run the Reconciliation Detail Report (page 312)
Step 3: Run the Trailing Cost and Trailing PPV Cost Reports (page 312)
Step 4: Run the Exception Reports (page 312)
Step 5: Make Any Adjustments to GL or Service Accounts (page 312)

About Updated Records (Additional Aid to Reconciliation) (page 312)
Posting Setup (page 315)
Running the WIP Reports (page 315)

WIP Report - Summary (page 316)
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WIP Report - Detail (page 316)
WIP Reconcile Report - Summary (page 317)
WIP Reconcile Report - Detail (page 318)
WIP Exception Report - Service Management Costs Not in GL (page 318)
WIP Exception Report - GL Costs Not in Service Management (page 319)
Service Invoice Trailing Costs Report - Summary (page 319)
Service Invoice Trailing Costs Report - Detail (page 320)

About Trailing Costs

Trailing costs are the costs that remain unposted after a service invoice has been posted, for a closed service call. 
Trailing costs could be partial PO shipments that were not received, a purchase price variance (PPV) that appeared on a 
receipt, or other committed costs that were not posted before a service invoice was posted.

Using WIP Reports at Month End

The following reports are included to help you reconcile WIP and Progress Billings accounts as part of the month-end 
closing process:

WIP report: Printed by year and period and shows amounts for each service call summarized by division.
Reconcile report: Prints debit/credit amounts by WIP and COGS along with the extended cost to reconcile the 
amounts posted to ensure they balance.
Exceptions reports: Shows which costs have been posted in the GL but have NOT been posted in Service 
Management, and vice versa.

For example, for costs that are in Service but not the GL, you may have posted to the GL, but did not post the GL batch 
yet. Conversely, for costs in the GL but not in Service, you may have posted costs from any other module to those 
accounts, for example, an adjustment entry to the account not assigned to a service call.

Sample Report Sequence

The following steps demonstrate how these reports can be used to help reconcile WIP and Progress Billings accounts at 
month end.

Step 1: Run the Reconciliation Summary Report (page 313)
Step 2: Run the Reconciliation Detail Report (page 312)
Step 3: Run the Trailing Cost and Trailing PPV Cost Reports (page 312)
Step 4: Run the Exception Reports (page 312)
Step 5: Make Any Adjustments to GL or Service Accounts (page 312)

Step 1: Run the Reconciliation Summary Report

Run the summary version of the Reconciliation report to see which amounts balance; you can filter the report for the 
month you are reconciling

If you open the Summary Inquiry window to view GL activity (Inquiry > Financial > Summary), the Net Change for a 
period should match the same account's Extended Amount for the same date range on the Reconciliation report.

Extended Amount = WIP Debit - WIP Credit + COGS Debit - COGS Credit
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Step 2: Run the Reconciliation Detail Report

If summary report totals do not balance, you can view transaction-level detail for the period. This may help identify 
discrepancies.

Step 3: Run the Trailing Cost and Trailing PPV Cost Reports

If you cannot identify the issue, it may be due to a trailing cost or purchase price variance (PPV). This report checks for 
trailing costs and PPV costs in any account that is set up as a Cost Account or Progress Billing account in Invoice or 
Maintenance Account Setup. Cost of sales and sales accounts are not checked.

Trailing costs may exist due to a trailing invoice, for example, a vendor invoice that is posted after a service call is 
closed. The transaction will still appear in the GL WIP accounts but will not appear in Service.

A PPV occurs when the amount that is relieved from WIP when posting a service invoice is different than the amount 
that was debited to WIP. This may occur if there is a trailing invoice; when there is no actual cost at the time of invoice 
posting, the Service WIP accounts are relieved based on committed cost remaining, and the amounts may not agree. 
The impact of a PPV does not appear on the service call but may be identified with this report.

Step 4: Run the Exception Reports

If you still cannot pinpoint the issue, these reports identify transactions that were posted to your Service WIP accounts 
but not to the GL, and vice versa. All accounts that have been set up as WIP or Cost service invoice or maintenance 
accounts, as well as any account that has been posted to for a service call, will be checked.

The report identifies journal entries along with the type of transaction and the user who posted it. For example, the 
issue may be a payable that debited WIP without the service call filled in, or a journal entry that was made directly to 
the GL instead of through Service. The report helps you identify the transaction and assess user training needs.

Step 5: Make Any Adjustments to GL or Service Accounts

You can adjust cost amounts in the Signature Transaction entry or Service Invoice windows. If you have trailing costs, 
you may select to create an administrative service call to transfer the cost into the subledger via a clearing account.

About Updated Records (Additional Aid to Reconciliation)

To help you to tie back/reconcile amounts in the general ledger with amounts in Service Management, several 
additional records/tables will be updated because of performing certain actions, such as posting a purchase order 
invoice (from the Purchasing Invoice Entry window) or posting a service invoice. These are listed below.

After posting a Purchase Order invoice that contains committed purchase order costs (costs that have been 
included on a posted service invoice as part of committed costs remaining), a new record is created in 
the SV_Invoice_Trailing_Costs table to show the trailing cost amounts. This allows you to tie these amounts back 
to the service call.
After posting a Purchase Order invoice with PPV (purchase price variance) on a closed service call, a new 
record is created in the SV_Invoice_Trailing_PPV_Costs table to show the amount of the variance (positive or 
negative) in a field called Trailing Cost.
After posting a service invoice and RM transaction the account indexes for the Invoice Account and Invoice 
Account Credit accounts will be stored in the SV000815 table.
After posting a plus button   transaction to a service invoice the account index for the WIP Credit Account 
will be stored in the SV000810 table.
After transactions are posted that apply to a service call the following fields are updated accordingly in the 
SV000810 or SV000815 tables: Divisions, Journal Entry, Referenced TRX Number, Transaction Source, Account 
Index Credit, Account Index Debit, and GL Posting Date.
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After Signature Payroll Posting, the account indexes for the OH (overhead) Account Index CR (credit) and OH 
(overhead) Account Index DR (debit) will be stored in the SV000810 table.
For maintenance contracts, after the revenue recognition process is run the account indexes used for 
progress billings and contract earnings will be stored, along with the GL Journal Number and the line sequence 
numbers created.
For maintenance contracts, after creating invoices for billing schedules we will store the RM Document 
Number to match in the SV_Contract_Billing_MSTR table or SV_Master_Contract_Billing_MSTR (for master 
contracts). In the SV_Maint_Invoice_MSTR table, the account index will be stored containing the progress billing 
amounts.

Posting Setup

Before you run the WIP reconciliation reports, your posting options must be set up to create journal entries for 
transactions. You must set this up for the following product series': Inventory (with an origin of Transaction Entry) and 
Sales (with an origin of Sales Transaction Entry). These may have already been set up, but we recommend that you 
double-check the setup.

Select Microsoft Dynamics GP > Tools > Setup > Posting > Posting. The Posting Setup window opens.
In the Series drop-down, select Sales.
In the Origin drop-down, select Sales Transaction Entry.
Under Create a Journal Entry, select the Transaction radio button.
In the Series drop-down, select Inventory.
In the Origin drop-down, select Transaction Entry.
Select OK.

Running the WIP Reports

Select Reports > Service Management > Service > WIP Reports. The Service Management WIP Reports window 
opens.
Enter a Start Date and an End Date.
Select a GL Account Number. To run for all accounts, leave this field blank.
Select to run by all or individual Division, Customer, Location and/or Contract.
Select to run a WIP report (summary or detail), Reconcile report (summary or detail), or Exception report. For the 
Exception report, you can select to run a report for Service Costs not in GL or GL Costs not in Service.
Select Print.

Dexterity report examples appear below.

WIP Report - Summary (page 316)
WIP Report - Detail (page 316)
WIP Reconcile Report - Summary (page 317)
WIP Reconcile Report - Detail (page 318)
WIP Exception Report - Service Management Costs Not in GL (page 318)
WIP Exception Report - GL Costs Not in Service Management (page 319)
Service Invoice Trailing Costs Report - Summary (page 319)
Service Invoice Trailing Costs Report - Detail (page 320)

If you are using SSRS reports, these Dexterity reports are replaced with the SSRS versions; refer to WIP SSRS 
reports (page 98) for examples of the SSRS WIP reports.


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WIP Report - Summary

WIP Report - Detail
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WIP Reconcile Report - Summary
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WIP Reconcile Report - Detail

WIP Exception Report - Service Management Costs Not in GL
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WIP Exception Report - GL Costs Not in Service Management

Service Invoice Trailing Costs Report - Summary
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Service Invoice Trailing Costs Report - Detail

Maintenance Reports
Additional maintenance reports can be accessed by choosing the Print button in the Maintenance Contract window.

Contract Base Profile Report
The Contract Base Profile report lists the billing and labor status of all your maintenance contracts by contract type.

Select Reports > Service Management > Maintenance > Contract Base Profile.
Use the lookup window to select a contract type. If you leave the Contract Type field blank, all contract types 
print.
Select Print.
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Gross Margin to Date Report
The Gross Margin to Date report lists, by maintenance contract, the year, closed date, contract earned, cost all, and 
gross margin of your maintenance contracts.

Select Reports > Service Management > Maintenance > Gross Margin to Date.
In the Gross Margin to Date window, use the lookup window in the Contract Number field to select a contract 
number.
Select Print.
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Labor Load Schedule Report
This report is used to view technicians' total available monthly labor hours. The available hours are grouped by MCC, 
billable, burden, and MC hours.

Select Reports > Service Management > Maintenance > Labor Load Schedule.
Select the All or Individual technician radio button. If you chose Individual Technician, select a technician.
The first time during a session you select Print, you will receive a message asking if you want to run the utility 
that matches technicians by skill level to maintenance tasks. Select Yes. A progress window appears.



12 https://docs.key2act.io/pages/viewpage.action?pageId=101320329
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Maintenance Contract Reconciliation Reports
The Contract Reconciliation Reports show BEFORE and AFTER totals and changed fields are indicated with an asterisk in 
front of each total.  The reports are available for each Reconcile process: Billing, Cost, and Revenue. The reports display 
automatically after the Reconcile process if there were any changes made. For information on the Reconcile process, 
see Reconciling Cost, Billing, and/or Revenue12 in the Signature User Guide.

Contract Reconciliation Billing Report (page 321)
Contract Reconciliation Cost Report (page 321)
Contract Reconciliation Revenue Report (page 322)

Contract Reconciliation Billing Report

Contract Reconciliation Cost Report

https://docs.key2act.io/pages/viewpage.action?pageId=101320329


322

Contract Reconciliation Revenue Report



323

1.
2.
3.

4.

•
•
•
•

Master Contract Reports
The Master Contract List contains all master contracts and their assigned maintenance contracts, as well as the 
information from the Master Contract window.

The Master Contract Financial report lists all master contracts, contract amounts, total cost, contract earned, gross 
profit, revenue recognized, and amount billed for each contract on a year-to-date and total-to-date basis.

Select Reports > Service Management > Maintenance > Master Contract.
Select to print the Master Contract List or the Master Contract Financial report from the Report drop-down list.
From the Print drop-down list, select to print the report for all customers, a customer range, or a branch range. 
Enter the range information, if applicable.
Select Print

Master Contract List (page 323)
Master Contract Financial (page 324)
Contract Process Report (page 324)
Master Contract Process Exception (page 327)

Master Contract List

You can also print the Master Contract List for a specific customer by choosing File > Print in the Master 
Contract window.


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Master Contract Financial

Contract Process Report
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Master Contract Process Exception

Monthly Labor Plan Report
The Monthly Labor Plan report lists the scheduled MCC labor hours for each technician monthly. The report also lists 
the actual hours per service call completed by the technician.

Select Reports >Service Management > Maintenance > Labor Load Monthly.
Select the All or Individual Technician radio button. If you chose Individual Technician, select a technician.
Make a selection from the Month field drop-down list.
The first time you select Print during a session, you will receive a message asking if you want to run the utility 
that matches technicians by skill level to maintenance tasks. Select Yes. A progress window appears.
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Overdue PM Report
The Overdue PM report lists maintenance contract service work that is not complete. That is, all overdue MCC service 
calls with an Open call status are in the report.

Select Reports > Service Management > Maintenance > Overdue Preventive Maintenance. The Overdue PM Report 
window opens, displaying maintenance service calls that are overdue.
To change the number of records in the report or to age the Overdue PM Report window, make a new entry in 
the Number of Days Overdue field and tab off.
The system generates a report based on the Date field in the Service Call window. If the service call date is more 
than the number of days overdue, the service call appears in the scrolling window. You can double-click a call in 
the scrolling window to open the Service Call window.
Select Print.

You can view overdue preventive maintenance service calls by choosing the Overdue indicator in the Service Manager 
window or the Location window.

Technician Load Summary Report
This report is a summary of technicians' monthly MCC workload.

Select Reports > Service Management > Maintenance > Technician Load Summary.
Select the All or Individual Technician radio button. If you select Individual Technician, select a technician.

Remember, if you roll all your calls forward and don't exclude MCC calls, the Overdue indicator won't appear 
because the date of the MCC calls changes when calls roll forward.


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The first time during a session you select Print, you will receive a message asking if you want to run the utility 
that matches technicians by skill level to maintenance tasks. Select Yes.

Workorder Register Report
The Workorder Register report lists technicians' open MCC service calls. There are fields on the form for technicians to 
check when the calls are completed and for the technician's signature.

Select Reports > Service Management > Maintenance > Workorder Register.
Enter a Start Date and an End Date.
The Technician ID field defaults as All. If you want to select an individual technician, use the lookup window in 
the Technician ID field to select a technician.
Select the All or Individual Contract radio button. If you select Individual Contract, use the lookups in 
the Customer ID, Address ID, and Contract Number fields to make your selections.
Select Print.

Inactive Task Code or Task List Warnings
The Inactive Task Code or Task List Warnings report can be manually printed from the Contract Quote and Maintenance 
Contract window. The report will automatically generate when an inactive task code and/or task list exists on a contract 
is generated from the contract quote and/or a contract is renewed. This report displays the inactive tasks and/or 
inactive task lists that are associated with the quote or contract. The information included in the report is the customer 
number, customer name, address code, location name, contract/quote number, equipment ID, equipment type, task 
list ID, task code, and the task code description. 
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Using SmartList Objects
SmartList Builder objects are available for Equipment Management, Job Cost, and Service Management. These objects 
include Go To items for several windows. Some Go To items appear for multiple objects.

SmartList Designer objects are available for Job Cost and Service Management. For information on using SmartList 
Designer, see the Microsoft Dynamics GP Systems User Guide.

Importing SmartList Objects
SmartList Builder (page 330)
SmartList Designer (page 331)

SmartList Builder
You must own SmartList Builder to use Signature SmartList Builder objects.
The following must be set up in Equipment Management prior to importing SmartList Builder objects:

Equipment attributes
Equipment status
Equipment user-defined prompts
Model user-defined prompts

You must be logged in as "sa" to import objects.

Select Microsoft Dynamics GP >Tools > SmartList Builder > Import. Select the folder icon and navigate to the 
Signature SmartList Builder Objects folder in your Microsoft Dynamics GP directory.
Select the appropriate XML file and select Open. Then select Import. When the import finishes, a message 
appears indicating the import process has completed. Select OK.

If changes are made to any of these items after importing SmartList Builder objects, you must re-import for 
those changes to be detected and appear on the Equipment and Equipment Model SmartLists.


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Repeat the steps to import additional XML files, as needed.

SmartList Designer
If you do not own SmartList Builder, use SmartList Designer to create SmartLists by importing the Signature SmartList 
Objects.

Select Microsoft Dynamics GP > SmartList. Select Export/Import and then Import.
Select Add and then navigate to <GP Install folder>\Signature\SmartList Designer Objects. If you have purchased 
SmartList Builder, you will want to import the objects for SmartList Builder. See the previous section for 
information on importing SmartList Builder objects.
Select the appropriate XML file(s) and select Open. Then select Import. When the import finishes, a message 
appears indicating the import process has completed. Select OK.
Repeat the steps to import additional XML files, as needed.
Close the SmartList window and then re-open to complete the import process.

Accessing SmartList Objects
You access SmartList objects in the SmartList window. Each object name begins with the word Signature, followed by 
the descriptive name; for example, Signature Service Calls.

Select SmartList.
Scroll down to the objects that begin with Signature. Select an object to display the records for that object. 
Records appear in the right pane of the window.
To select a Go To item, select a record for that object, and select the Go To... button. Select an item from the Go 
To menu. You can also double-click a record to display the default Go To item, which is the first item in the Go To 
menu.

For information on using the SmartList window, see the Microsoft Dynamics GP documentation.

Modifying SmartList Builder Objects
Any modifications that you make to one of the imported SmartList templates will be lost if you re-import SmartList 
Builder objects. Before you modify a template, we recommend duplicating the SmartList and making changes to the 
copy.

Select Microsoft Dynamics GP > Tools > SmartList Builder > SmartList Builder.
Use the lookup button to select the SmartList ID of the object you would like to duplicate. The Equipment 
Management SmartList Builder objects that you imported are identified with _S_EMS_{_}.
Select Options > Duplicate....
Select SmartList as the New List Type. You can also duplicate the template into Excel Report Builder; see 
Creating a SmartList Object Excel Report (page 332) for details.
Enter a New List ID and New List Name, and select Duplicate.

If double-clicking a record does not display a window, select SmartList > Options to open the Options window. 
In the Category drop-down list, select the object that is currently highlighted in the SmartList window, then 
select OK. In the SmartList window, select the Refresh button, then double-click a record. The window for the 
default Go To item should appear. Double-clicking will now work for all objects.


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The new SmartList opens and can be edited in the SmartList Builder window. We recommend modifying this 
copy, as any changes that you make to the original template will be lost if you need to re-import SmartList 
Builder objects.

Refer to the SmartList Builder (with Excel Report Builder) user documentation for information on editing SmartList 
Builder objects.

Creating a SmartList Object Excel Report
You can create Excel Reports from the SmartList objects that you imported.

Select Microsoft Dynamics GP > Tools > SmartList Builder > SmartList Builder.
Use the lookup button to select the SmartList ID of the object you would like to duplicate. The Signature 
SmartList Builder objects that you imported are identified with S_ for Service Management or Job Cost and 
EMS_ for Equipment Management.
Select Options > Duplicate....
Select Excel Report as the New List Type.
Enter a New List ID and New List Name for the Excel Report, and select Duplicate.
The new report opens in Excel Report Builder, where you can modify the Excel Report. Refer to the SmartList 
Builder (with Excel Report Builder) user documentation for more details.

If you use Microsoft Dynamics GP SmartList Builder to create your own SmartLists and Microsoft Excel reports, you can 
use the following SmartList Builder objects as templates for creating SmartLists in Equipment Management:

Cost Categories
Equipment
Equipment Models
Meter Readings
Rental Agreement Lines
Rental Invoice Lines
Scheduled Maintenance

These templates are contained in an XML file that can be imported into SmartList Builder. After importing SmartList 
Builder objects, the templates can be used in SmartList or edited in SmartList Builder or Excel Report Builder.

Preparing Go To Items for Use in the SmartList Window
Select Microsoft Dynamics GP > Tools > SmartList Builder > SmartList Builder. Select the lookup button in the 
SmartList ID field and complete the following steps for each Signature object displayed in the list:
Highlight the Signature object in the list and click Select.
Select the Go To... button. All available Go To locations display. Here you can Add, Edit, or Remove Go To items. 
When you are finished, Select OK.
In the SmartList Builder window, select Save. When the information has saved, the window will clear.
When you have completed these steps for each object in the list, close the SmartList Builder window. Open the 
SmartList window under Microsoft Dynamics GP > SmartList. The following message will appear: SmartList 
Builder has detected changes to be made. Do you want to make these changes now? Select Yes. The update will 
take a few moments.

When the update completes, the SmartList window will open. You are now ready to use the Signature SmartLists and 
Go To items.
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Signature Objects and Go To Items Reference
The following Signature objects and Go To items are available for use in SmartList.

Service Management (page 331)
Job Cost (page 331)
Equipment Manager (page 334)

Service Management

Object Go To items

Signature Service Calls Service Call, Service Manager, Customer, Location, 
Contracts

Signature Service Customer Locations Service Manager, Service Call History, Equipment 
Summary, Customer, Location

Signature Service Equipment Equipment, Contract, Service Manager, Customer, 
Location

Signature Service Invoice History Invoice, Service Call, Service Manager, Customer, 
Location

Signature Service Invoice Open Invoice, Service Call, Service Manager, Customer, 
Location

Signature Service Maintenance Contracts Contract, Contract Coverage, Revenue/Costs, Service 
Manager, Customer, Location

Job Cost

Object Go To items

Signature Job Billings Invoice Zoom, Job Status, Billed Position, Billing Inquiry

Signature Job Cost Codes Cost Code, Cost Code Setup, Cost Code Transactions, 
Cost Code Summary, Job Status, Job Maintenance

Signature Job Subcontractors Vendor Status, Job Status, Job Maintenance, Billed 
Position, Master Vendor Dates, Master Subcontractor, 
Subcontractor Status



332

Object Go To items

Signature Job Transactions Job Cost Transaction Zoom, Cost Code Summary, Job 
Status, Job Maintenance

Signature Jobs Job Status, Job Change Orders, Billed Position, Billing 
Inquiry, Project Status, Job Maintenance

Equipment Manager

Object Go To items

Cost Categories Equipment Hierarchy, Equipment Manager

Equipment Address Maintenance, Customer Maintenance, 
Equipment Hierarchy, Equipment Manager, Model 
Maintenance

Equipment Models Equipment Model

Meter Readings Equipment Hierarchy, Equipment Manager, Op Log 
Maintenance, Service Call

Rental Agreement Lines Address Maintenance, Customer Maintenance, 
Equipment Hierarchy, Equipment Manager, Item 
Maintenance, Job Status, Model Maintenance

Rental Invoice Lines Address Maintenance, Agreement Entry, Customer 
Maintenance, Equipment Hierarchy, Equipment 
Manager, Invoice Entry, Item Maintenance, Job Status, 
Model Maintenance

Scheduled Maintenance Equipment Hierarchy, Equipment Manager, Scheduled 
Maintenance, Service Call
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Contact Information
Support and Sales

Support Phone: 262-317-3800
Email: support@Key2Act.com13 
Hours: Normal support hours are 7:00 a.m. to 6:00 p.m. Central Time. After-
hours and weekend support is available for an additional charge. Please 
contact Key2Act Support for additional information. 

Key2Act will be closed in observance of the following holidays: New Year's 
Day, Memorial Day, Independence Day, Labor Day, Thanksgiving Day, Day 
after Thanksgiving, and Christmas Day.

Support Plans We're committed to providing the service you need to solve your problems 
and help your team maximize productivity.

We offer several Signature Enhancement and Support Plans to meet your 
needs and Extended Support Plans for retired product versions available 
at http://www.key2act.com/customer-portal/help.

Sales Phone: 262-317-3700  
Fax: 262-317-3701

Key2Act Headquarters

Address: 
Key2Act
1970 S. Calhoun Rd.
New Berlin, WI 53151-1187 

Phone: 262-821-4100 or 866-Key2Act (866-539-2228)
Email: info@Key2Act.com14

Website: www.Key2Act.com15 
Office hours: Monday through Friday from 8 a.m. to 5 p.m. Central Time.
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