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Introduction

Introduction

Signature MobileTech lets technicians who use mobile devices share and receive information to and from a host
system — in this case, the Signature modules and Microsoft Dynamics GP.

Technicians can receive appointments that are created in the Signature modules, together with appointment details
such as estimated hours, description, location, and service call history. Technicians then can update appointments
with expense and resolution details.

The information in this guide is intended for administrators and others in your organization who install and set up
MobileTech. It also provides information about processing entries and activities in Microsoft Dynamics GP and the
Signature modules that are entered and synchronized, or synced, by field technicians.

Note: Any references to MobileTech assume that you are installing or have installed the latest version of the
components that are available for MobileTech.

For information for technicians, see the Help in MobileTech Client.

Compatible operating systems

Refer to the operating systems document found with the MobileTech guides on the Product Download page on
Signature Resources (http://www.key2act.com/customer-portal/downloads) for a list of supported operating systems.
We recommend that you perform the appropriate testing prior to any major purchasing decisions, including the
procurement of devices.

KEY2ACT offers compatibility testing if you are interested in making sure that your device and operating system are
compatible with MobileTech. Contact KEY2ACT Support to obtain this service.

Prerequisite applications

If you do not already have these .NET applications installed on your computer, they will be installed when you install
MobileTech.

Application Version
MobileTech Sync Server .NET 4.5.2 Full Framework
MobileTech Administration .NET 4.5.2 Full Framework
MobileTech Client .NET 4.5.2 Client Framework
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Other system requirements

This section outlines basic system requirements for MobileTech R6.0, although the specific system requirements for
your installation depend on which versions of Signature and Microsoft Dynamics GP you are using. The system
requirements for your version of Signature and Microsoft Dynamics GP also apply to MobileTech.

To find a complete list of system requirements across all the Signature modules, refer to the Signature System
Requirements document found on the Product Download page on Signature Resources.

http://www.key2act.com/customer-portal/downloads

Component

Requirements

SQL Server

Operating system

Microsoft SQL Server Reporting Services (SSRS)

Internet Information Services

Silverlight

Web Service server

Microsoft SQL Server 2012, 2014, or 2016

Note: Do not install MobileTech server components on
your SQL Server machine. Install MobileTech
Administration on the MobileTech web server.

Microsoft Windows Server 2008 R2 or later

Connectivity to the SSRS report server that you use
for the Signature modules and Microsoft Dynamics GP
is required

Note: Printing reports offline is not currently
supported.

I1IS7.50r8.0

Silverlight is required to run Resco Woodford and is
installed with Woodford if it is not already installed

e 2.8 gigahertz (GHz) or higher processing
speed

e 16 GB available RAM (minimum)
e Dual core CPU (minimum)

e 20 GB available hard disk space
(recommended)

e 1 gigabit per second (Gbps) connection
speed (recommended)

Note: Computers that have more than 16 GB of RAM
will require more disk space for paging, hibernation,
and dump files.
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Component Requirements

Device communication
e  Wireless (Wi-Fi)

e Cellular (WWAN)

Other resources

For more information about MobileTech and related applications, see these resources found on the Product
Download page on Signature Resources (http://www.key2act.com/customer-portal/downloads).

e Signature MobileTech R6.0 Readme
Describes the features and resolved issues in MobileTech R6.0 and lists compatible software versions.

e Signature Service Management and Signature Equipment Management guides
Describe how to set up and use Service Management and Equipment Management, and how to process
information that is sent from MobileTech to the host system.

e Signature Reports guide
Describes how to deploy reports for both Service Management and MobileTech.

e Resco Mobile CRM Woodford User Guide
Includes information about how to use Woodford to customize your application.
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Installing MobileTech

Use these instructions if you are installing and setting up MobileTech for the first time. For system requirements
information, see the Introduction on page 1.

After you install MobileTech Sync Server, MobileTech Integration Sync, and MobileTech Administration, you must set
up application options and set up and grant access to users by using MobileTech Administration.

You will then install MobileTech Client on the various devices that are used by technicians.

CAUTION: Before upgrading MobileTech, we recommend that you make a backup copy of the web.config,
MobileTechAdmin.exe.config, and XrmServer.SyncConsole.exe.config files if you have made changes to these files.
After upgrading you can reinsert your changes.

Installing and setting up MobileTech involves these steps:

e Installing MobileTech Sync Server on page 4

e Installing MobileTech Integration Sync on page 6

e  Setting up Distributed Transaction Coordinator (DTC) on page 6

e Installing MobileTech Administration on page 7

e Installing eTimeTrack Web Service on page 8

e  Setting up MobileTech on page 12

e [nstalling and using Resco Woodford on page 41

e Installing MobileTech Client on page 46

Install MobileTech Sync Server

You can install MobileTech Sync Server on any Microsoft Windows client machine. The person who installs the
application must be an administrator who has permission to use the server “sa” password.

The application provides a way to view changes for service calls and appointments from Microsoft Dynamics GP that
are waiting to be synced with MobileTech. You can set up the Integration Monitor to run at specific intervals, but you
can also run the process manually at any time.

1. Double-click Signature MobileTech Sync Server.exe. See the Readme for the version of the sync server
to install.

2. Onthe Welcome to the Signature MobileTech Sync Server Setup Wizard page, choose Next.

3. Onthe End-User License Agreement page, read and accept the terms of the license agreement and choose
Next. The Sync Server Setup page is displayed.

4. Enter this information to indicate where the sync server should be installed.

e Sync Server Site Name
Enter the name of the sync server site or accept the default name.

e Website Port
Enter the number of the website port or accept the default port number of 8080.
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5.

6.

10.

11.

12.

13.

14.

15.

16.

Choose Next. The SMTP Server Setup page is displayed.
Enter information in the following fields. This information is encrypted in the web.config file.

e SMTP Host Server
Enter the name of the SMTP server that email messages to client devices are transmitted from.

e SMTP Port
Enter the port number for the SMTP host server or accept the default port number.

e User Name
Enter the email address of the person who sends report email notifications.

e Password and Confirm Password
Enter and confirm the password that is required to send report email notifications.

e Error Report Recipient
Enter the email address where error reports are sent.

Choose Next. The Configuration Database Setup page is displayed.

Enter this information, which is required to create a configuration database.

e SQL Instance
Enter the SQL Server name and instance where the Microsoft Dynamics GP database is installed.

e SA Password
Enter the password for the “sa” user.

Choose Next. The Create MobileTech SQL Account page is displayed.

Enter information in these fields.

e MobileTech User
Displays mobiletech, which you cannot change.

e Password
If a SQL Server account exists for the mobiletech user, enter the mobiletech account password so
it can be validated. If a SQL Server account does not exist, you are prompted to confirm the
password.
Choose Next. The Select Installation Folder page is displayed.

Choose Browse to select the location where MobileTech Sync Server will be installed, or accept the default
location.

Choose Next. The Ready to Install page is displayed.
Choose Install. The Installing Signature MobileTech Sync Server page is displayed.

When the installation is complete, the Completing the Signature MobileTech Sync Server Setup Wizard
page is displayed.

Choose Finish.
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Install MobileTech Integration Sync

MobileTech Integration Sync applies the settings you enter to the automated sync process. The integration sync
process automatically updates the middle-tier database with changes that are made in Microsoft Dynamics GP.

You can change the frequency of the updates later. For more information, see Monitor processes and tasks by using
Integration Monitor on page 60.

An icon for MobileTech Integration Sync is added to your desktop. You can choose the icon at any time after you set
up MobileTech if you want to manually run the sync process.

1.

10.

11.

12.

13.

Double-click Signature MobileTech Integration Sync.exe. See the Readme for the version of the
integration sync to install.

On the Welcome to the Signature MobileTech Integration Sync Setup Wizard page, choose Next.

On the End-User License Agreement page, read and accept the terms of the license agreement and choose
Next. The SQL Server Set Up page is displayed.

Enter the SQL Server name and instance where the Microsoft Dynamics GP database is installed, and the
system administrator (sa) password.

Choose Next. The MobileTech User Details page is displayed.

The mobiletech user name is displayed. If a SQL Server account exists, enter the administrator password so
it can be validated. If a SQL Server account does not exist, you are prompted to confirm the password.

Choose Next. The Set Up Sync Settings page is displayed.

Enter information in these fields.

e Sync Server URL
The server name and the port where the sync server was installed. The default port is 8080.

e Task Frequency
Enter a number, in minutes, to indicate how frequently the integration sync process updates the
middle-tier database with changes that were made in Microsoft Dynamics GP.
Choose Next. The Select Installation Folder page is displayed.

Enter the location where MobileTech Integration Sync will be installed, or accept the default location.
Choose Next.

On the Ready to Install page, choose Install. The Installing Signature MobileTech Integration Sync page is
displayed.

When the installation is complete, the Completing the Signature MobileTech Integration Sync Setup Wizard
page is displayed.

Choose Finish.

Set up Distributed Transaction Coordinator (DTC)

Use the Local DTC Properties window to set up the properties for Microsoft Distributed Transaction Coordinator
(DTC) on these computers:

The server where SQL Server is running for MobileTech
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The computer where MobileTech Sync Server is installed

The computer where MobileTech Sync Integration is installed

This helps make sure that transactions between the host computer and client devices are successfully completed and

synced.

1.

From the Start menu, choose Administrative Tools > Component Services. The Component Services
window is displayed.

Double-click the Computers folder, double-click My Computer, and then double-click Distributed
Transaction Coordinator.

Right-click Local DTC and choose Properties. The Local DTC Properties window is displayed. Choose the
Security tab.

Under Security Settings, mark these check boxes:
e Network DTC Access
e Allow Remote Clients

e Allow Remote Administration

Under Transaction Manager Communication, mark the Allow Inbound and Allow Outbound check
boxes, and then select No Authentication Required.

The DTC logon account is displayed in the Account field. Accept the default account location, or choose
Browse to select a different location.

For more information about the options in this window, choose the setting these properties link at the
bottom of the window.

Choose OK.
In the Component Services window, in the left pane, choose Services.

In the Services list, double-click Distributed Transaction Coordinator. The Distributed Transaction
Coordinator Properties (Local Computer) window is displayed.

10. On the General tab, verify that the Startup type field is set to Automatic or Automatic (Delayed Start).

11. Choose OK.

Install MobileTech Administration

Double-click Signature MobileTech Admin.exe. See the Readme for the version of MobileTech
Administration to install.

On the Welcome to the Signature MobileTech Admin Setup Wizard page, choose Next.

On the End-User License Agreement page, read and accept the terms of the license agreement and choose
Next. The SQL Server Settings page is displayed.

Enter information in these fields.

e Dynamics GP System Database
Enter the name of the database where Microsoft Dynamics GP is stored.
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10.

11.

12.

13.

14.

15.

e SQL Server
Enter the name of the SQL server for MobileTech.

e SA Password
Enter the SQL Server system administrator (sa) password.

Choose Next. The MobileTech User Details page is displayed.

The mobiletech user name is displayed by default. If a SQL Server account exists, enter the administrator
password so it can be validated. If a SQL Server account does not exist, you are prompted to confirm the
password.

Choose Next. The Sync Server Details & Registration Web Details page is displayed.

Enter the URL for the sync server. By default, the port number is 8080.

Mark the check box if the Signature Registration web service is installed on a secure website (https://
instead of http://). This allows the registration web service to be consumed over Secure Sockets Layer
(SSL).

Choose Next. The Select Installation folder page is displayed.

Choose Browse to select the location where MobileTech Administration should be installed, or accept the
default location.

Choose Next. The Ready to Install page is displayed.
Choose Install. The status bar shows the progress of the Signature MobileTech Admin Setup Wizard.

When the installation is complete, the Completing the Signature MobileTech Admin Setup Wizard page is
displayed. Choose Finish.

Complete the following setup tasks, depending on whether you have a previous version of MobileTech
installed:

e If you are installing MobileTech for the first time, go to Set up MobileTech on page 12.

e If you previously installed an earlier version of MobileTech and you are now installing MobileTech
R6.0, you will be prompted to update the middle-tier database, and you must run the Create
Database Objects tool for each company immediately after you install MobileTech Administration.
To manually create database objects, In MobileTech Administration, go to Tools > Create
MobileTech Objects, and then choose Process.

Install eTimeTrack Web Service

The eTimeTrack Web Service application is included with the installation package for MobileTech.

Note: In the current release, extended pricing is not supported for expense and travel transactions through Time

Entry.
1. Double-click eTimeTrackWebServiceSetup.exe.
2. Onthe Welcome to the Signature eTimeTrack Web Service Setup Wizard page, choose Next.
3. Onthe End-User License Agreement page, read and accept the terms of the license agreement, and then
choose Next. The Select Installation Folder page is displayed.
4. Accept the default installation location, or choose Browse to select the location where the eTimeTrack Web

Service should be installed.
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10.

11.

12.

13.

Choose Next. The SQL Database page is displayed.

Enter the SQL server and instance for the eTimeTrack Web Service (server namelinstance).

Note: The default user name is displayed and you cannot change it.

Enter a password for the user and choose Next. The Web Service User Configuration page is displayed.

Note: The default user name is displayed and you cannot change it.

Enter a password for the user.

In the Database field, enter the database name for your company. If you are installing MobileTech on
multiple databases, enter each database name, separated by commas.

Choose Next. The Ready to Install page is displayed.
Choose Install. The status bar shows the progress of the Signature eTimeTrack Web Service Setup Wizard.

When the installation is complete, the Completing the Signature eTimeTrack Web Service Setup Wizard
page is displayed. Choose Finish.

Continue with the information in Set up MobileTech on page 12.
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Upgrading MobileTech

Upgrading MobileTech involves these steps:

e Install MobileTech Sync Server on page 4

e Install MobileTech Integration Sync on page 6

e Install MobileTech Administration on page 7

e Set up MobileTech on page 12

e [nstalling and using Resco Woodford on page 41

e Install MobileTech Client on page 46

After the upgrade is complete, you can use MobileTech Administration to select application options and set up and
grant access to users.

CAUTION: Before upgrading MobileTech, we recommend that you make a backup copy of the web.config,
MobileTechAdmin.exe.config, and XrmServer.SyncConsole.exe.config files if you have made changes to these files.
After upgrading you can reinsert your changes.

Updates on iOS devices

If your technicians use iOS devices, the technicians will sometimes be notified about MobileTech app updates for
their devices. Do not install the client updates on those devices unless you will also be updating the
MobileTech Sync Server and MobileTech Administration applications to the compatible versions that are
listed in the Readme. We recommend that you clearly communicate this information to your technicians.

We also recommend that you turn off automatic downloads of updates on iOS devices. To do this, go to Settings >
iTunes & App Store. In the Automatic Downloads section, make sure the Updates option is turned off (the toggle
switch should appear gray, not green). Repeat this task on each iOS device.

You can view which version of MobileTech is installed on each device. For more information, see View user device
information and sync activity on page 60.

Upgrading to MobileTech R6.0

Regardless of which version you are upgrading from, be sure to install the components for the most recent version.
You do not need to uninstall or rename the current MobileTech R6.0 files.

Note: If you have made changes to views or stored procedures in previous versions of MobileTech, those changes
will be overwritten during the upgrade. Make sure all work is synced with the host system before you upgrade a
device.

If you are upgrading from an R3.0 or R3.1 version of MobileTech, we recommend that you remove the client shortcut
from the devices. The R6.0 installation process creates a new shortcut instead of overwriting the R3.1 or R3.0
shortcut.

When you upgrade to the most recent release of MobileTech, you must upgrade these applications before you
upgrade MobileTech Client:
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e MobileTech Sync Server
e  MobileTech Integration Sync

e MobileTech Administration

CAUTION: Before upgrading MobileTech, we recommend that you make a backup copy of the web.config,
MobileTechAdmin.exe.config, and XrmServer.SyncConsole.exe.config files if you have made changes to these files.
After upgrading you can reinsert your changes.

You will be prompted to install database objects the first time you log on to MobileTech Administration. You must do
this for each company. If you are not prompted to install database objects, go to Tools > Create MobileTech Objects
and choose Process.

You then set up MobileTech and install MobileTech Client on client devices.

Note: In MobileTech, there is one middle-tier database for each Microsoft Dynamics GP company. The naming
convention for the database name is companyname_RESCOXRM. The configuration database is called
RESCOXRM_CONFIG.

After you install MobileTech Sync Server, MobileTech Integration Sync, and MobileTech Administration, continue with
the steps in Set up MobileTech on page 12.
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Setting up MobileTech

MobileTech is configured by using MobileTech Administration. This application lets you set up users and customize
setup options per your organization’s business rules and procedures.

You need to set up MobileTech for each company by completing the procedures that follow.

Note: Any reference to MobileTech assumes that you are installing or have installed the latest version of the
components that are available for MobileTech.

Set up password complexity and lockout policy

Setting up password complexity

You can set up minimum complexity requirements for MobileTech passwords, such as requiring digits, upper case
letters, special characters, and password length in the Signature MobileTech Web Sync Server web.config and
MobileTechAdmin.exe.config files using a regex (regular expression) check.

<add key=""PasswordPolicyStrengthRegex" value="" />

Note: User password strength regex check (empty allows any password). This value defaults empty.

Sample:
The settings in the sample below are explained. You are not limited to these settings.

add key="PasswordPolicyStrengthRegex" value="~(?=.*[0-9]) (?=.*[A-
Z]) (?=_*[1@#$&amp;*]) -{8,}$"

e (?=7[0-9))
Indicates at least one digit.

o (=4AZ])
Indicates at least one upper case letter.

o (?=r[l@#$&amp;*])
Indicates at least one special character.

e {8}

Indicates a minimum of 8 characters in length

Setting up the password policy lockout

Set up your password lockout policy to indicate a lockout mode (Lockout or Disable), after x failed login attempts, as
well as how many minutes a user's account is locked. These set up options are in the Signature MobileTech Web
Sync Server web.config file. The Password Policy Lockout Attempts setting will also need to be set in the
MobileTechAdmin.exe.config file.

Note: If you choose to not set up a password lockout policy, set PasswordPol icyLockoutAttempts to either 0 or
" as this allows an infinite nhumber of invalid login attempts.

e Password Policy Lockout Mode
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<add key="PasswordPolicylLockoutMode' value="Lockout" />

This setting has two possible values — Lockout and Disable. This setting works in conjunction with the
PasswordLockoutAttempts setting. The default value is Lockout.

e Lockout
When the setting is set to Lockout and the Lockout Attempts value is hit, the account will be locked
out until the PasswordLockoutDuration value has been reached. This value is in minutes. The
system administrator can unlock the user in the user profile.

e Disabled
When the setting is set to Disable and the Lockout Attempts value is hit, the system administrator
will need to enable the user in the user profile.

e Password Policy Lockout Attempts

<add key="PasswordPolicyLockoutAttempts" value="3" />

Sets the number of invalid logon attempts that are allowed before an account is locked out. The default
value is 3.

Note: The Password Lockout Attempts setting needs to be set up in both the Signature MobileTech
Web Sync Server web.config and MobileTechAdmin.exe.config files.

e Password Policy Lockout Duration

<add key=""PasswordPolicylLockoutDuration” value="60" />

Sets the length of time (minutes) the account is locked. The default value is 60. This setting is used in
conjunction with the Lockout mode.

Log on to MobileTech Administration

The user who logs on to MobileTech Administration must be a member of the DYNGRP SQL Server role for each
company database and for the DYNAMICS database. To install database objects or create the middle-tier database,
you must log on with the SQL Server “sa” account.

When you create a middle-tier database in MobileTech R6.0, a daily cleanup job is automatically set up for the
database. For more information about this job or how to specify when it runs, see Create a cleanup job for the middle-
tier database on page 15.

Any time you log on to MobileTech Administration and the version number of MobileTech Administration is higher
than the last time you logged on for a company, the page to install database objects opens. You must install
database objects for each company.

If you are not prompted to install database objects, go to Tools > Create MobileTech Objects, and then choose
Process.

1. From the Start menu, open MobileTech Admin. The MobileTech Administration Login page is displayed.

2. Enter information in these fields to connect to the MobileTech database.

e Server Name
Enter the SQL Server name and instance where the Signature modules are installed.

Example: serveninstance
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e Authentication
Choose the authentication mode. You must have a valid SQL Server logon set up.

e Windows Authentication
Use your Windows user credentials to log on.

e  SQL Server Authentication
Use your SQL Server credentials to log on.

e Login
Enter the name for the system administrator (sa).

e Password
Enter the password for the system administrator.

Choose Connect.

If multiple companies are installed, the MobileTech Administration Login page is displayed again. In the
Company field, select a company and choose Connect. The active company is displayed at the bottom left
of the MobileTech Administration page.

If you need to update the organization database, you will be prompted to do so.

Enter the email address and password for the administrator, and then choose Update.

If you need to install database objects, you will be prompted to do so. If you are not prompted to install
database objects after you log on, choose Tools > Create MobileTech Objects.

You must install database objects for each company.
Choose Process. When the process is complete, choose Next.

See these procedures to continue setting up MobileTech for that company:

e Create a cleanup job for the middle-tier database on page 15

e Setup anew useron page 15

e  Set up options for MobileTech on page 20

e Set up TimeTrack batch options on page 35

e  Set up report and email options on page 35

e Set up file extension options for attachments on page 37

e  Set up customer options for field invoicing and field payments on page 38

e Load data on page 39

e  Set up additional companies on page 40

To switch companies, choose File > Change Company. Select a company, and then choose OK.
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Change a Resco administrator password

If you or another administrator forgets an account password, you cannot retrieve the existing password, but you can
change it.

Note: This option is available only for users who belong to the SysAdmin role in SQL Server. These users can be
Windows or SQL users.

You can change the password for only one MobileTech administrator at a time.

1. In MobileTech Administration, choose Tools > Change Resco Administrator Password. The page displays a
list of all the system users in the configuration database.

2. Select the administrator whose password you want to change. The Databases for Account area displays a
list of all the company databases where the password will be changed.

3. Enter and confirm the new password.

4. Choose Change Password. The password will be changed for all the company databases that were listed in
the Databases for Account area.

Create a cleanup job for the middle-tier database

Occasionally, when a service call is created in the host system but completed on a mobile device, records that are
related to that service call do not get removed from the middle-tier database when the service call is completed.

To make sure these records are cleared out of the middle-tier database, you should set up the daily cleanup job. This
job looks in the middle-tier database for records related to service calls that were closed or completed more than 14
days ago, and for task attachments that have no parent service call. Those records are removed from the middle-tier
database during the next integration sync.

Important note: If more than 450 service calls are completed per day, we recommend that you work with KEY2ACT
Support.

This job is automatically set up when you create a new middle-tier database in Signature MobileTech R6.0. However,
if you are upgrading to Signature MobileTech R6.0 from a release prior to MobileTech R4.0 SP1, you need to
manually create this cleanup job in MobileTech Administration.

When you create the cleanup job, it is automatically set up to run every four hours each day. To change the
frequency or specify the time, change the schedule for the SQL Server Agent job. For more information, see the
Microsoft SQL Server documentation.

1. In MobileTech Administration, choose Tools > Create Middle Tier Database Clean Up Job. The Create
Cleanup Job page is displayed.

Note: You must be a member of the SQL Server SysAdmin role to open this page.

2. Choose Close after the cleanup job is created.

Set up a new user

Use this information to help you set up new users individually or to import multiple users:

e Add a MobileTech user on page 16
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e Import multiple MobileTech users on page 17

You can add or import only the number of users you purchased licenses for.

Add a MobileTech user

When you are setting up MobileTech after installing or upgrading, you will add users and then continue with the setup
steps, including those described in Load data on page 39.

However, when you add users later — such as when new technicians join your organization — you can refresh the
lookups rather than syncing them, to improve performance during the load data process.

Note: Use the filter options to narrow the user display list. You can filter by user, technician ID, or login account.
Enter a partial or whole entry and then choose the Filter icon. To clear the filter, choose the Clear Filter icon.

Add a user before you load data and sync lookups

1. In MobileTech Administration, choose Users, and then choose Add User. The user fields are displayed on
the page. Enter information in these fields.

First Name
Enter the first name of the user.

Last Name
Enter the last name of the user.

Email Address
Enter an email address for the user. The email address becomes the user name for the technician
when the technician signs in to a client device.

This is also the email address where the Call Summary, Employee Timesheet, Job Appointment
Summary, and Job Safety Audit reports are sent.

Password and Confirm Password
Enter and confirm a password that lets the user sign in to MobileTech.

Technician ID
Select the identifier for the technician whom you are adding as a user.

Employee ID
After you set up and save user information, the employee ID that is set up in Microsoft Dynamics
GP for the user is displayed as an ID for the employee.

Locked/Disabled check boxes

If you are have set up password complexity and a lock out policy, you can unmark the appropriate
check box if the user is locked out or has disabled their account due to invalid login attempts.

See Set up password complexity and lockout policy on page 12 for more information.

Roles

Select the role of the MobileTech user. By default, a client user is assigned to the MobileTech role.
To assign a user to the system administrator role in MobileTech Client, mark System
Administrator.

See Using Role Maintenance on page 17 for information on creating roles.

2. Choose Save. The user is added to the list of users in the column on the left.
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Add a user after you have loaded data and synced lookups

1.

In MobileTech Administration, choose Users, and then choose Add User. The user fields are displayed on
the page.

Enter information in the fields, as described in Add a user before you load data and sync lookups on page
16.

Choose Save. The user is added to the list of users in the column on the left.
Choose Tools > Refresh Lookups.

Mark the Employee check box and the check boxes for all its child entities, such as Pay Code, Work Crew,
and so on.

Note: When you mark a lookup, other associated lookups might be marked if there are dependencies
between the lookups. For example, if you mark the check box for a child lookup, the parent lookup
automatically is marked because that must be refreshed, too.

Choose Refresh.
Choose Load Data.
Mark the check boxes for the technician to load data for.

Enter the date range to include when you load and sync data, and leave the Sync Lookups check box
unmarked.

10. Choose Import, and then choose Close.

Import multiple MobileTech users

You can import multiple user records from Microsoft Dynamics GP instead of adding individual users.

All users who are set up as technicians in Service Management are listed. You can select only the number of
technicians you purchased licenses for.

1.

In MobileTech Administration, choose Users, and then choose Import. The Bulk User Load page is
displayed.

Mark the check boxes for the technicians whose records you want to import. These users will be assigned to
the role of Mobile Tech.

If a technician does not have an email address and password assigned, enter that information in the
appropriate columns. The email address for each technician must be unique.

Each technician’s email address also is used to send and receive reports that are associated with technician
activities.

Choose Update. The technicians are added to the list of users in the column on the left.

Using Role Maintenance

The Role Maintenance window is used to add or delete user-created roles. You can also add technicians to the roles
in this window. The default roles of System Administrator and MobileTech are created during the installation of
MobileTech and cannot be deleted.
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Note: Using Woodford, you can customize the application to user roles. For specific information about how to use
Woodford to customize your application, see the Resco Mobile CRM Woodford User Guide.

Adding a new role
1. In MobileTech Administration, choose Role Maintenance.
2. Choose Add Role to create a new role.
3. Enter a Role Name and choose Add.

4. Choose OK.

Deleting a role
1. In MobileTech Administration, choose Role Maintenance.
2. Choose the role in the Role Name list.
3. Choose Delete Role.

4. Choose Yes in the confirmation window.

Deleting multiple roles
1. In MobileTech Administration, choose Role Maintenance.
2. Choose Add Role.
3. Mark the check boxes next to the roles to be deleted.
4. Choose Delete Selected Roles.

5. Choose Yes in the confirmation window.

Adding one or more technicians to a role
1. In MobileTech Administration, choose Role Maintenance.
2. Choose the role you are assigning technicians to in the Role Name list.
3. Choose Add Technicians.

4. Use the filter options to narrow the technician disy list. You can filter by name or technician ID. Enter a

partial or whole entry and then choose the Filter icon. To clear the filter, choose the Clear Filter

icon.
5. Mark the check box next to the technician(s) to add to the role.

6. Choose Add.
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Removing one or more technicians from a role
1. In MobileTech Administration, choose Role Maintenance.
2. Choose the role you are removing the technician from in the Role Name list.
3. Mark the check box(es) next to one or more technicians.
4. Choose Remove Technicians.

5. Choose Yes in the confirmation window.

Note: Technicians may also be added to or removed from roles in the User window by marking/unmarking the check
box next to the role name and then saving the User record.

Verify attachment setup

In the host system, the Signature Document Attachments Setup window is used to set up the file locations where
reports are copied when they are generated and attached to service calls. For information about how to set up
service call task attachments and physically stored document attachments in Service Management, see Signature
Help or the Service Management User Guide.

Note: The reports can be reprinted in Service Management by opening the service call attachments. We recommend
that users reprint the reports from the attachments rather than regenerating the reports, because regenerated reports
might differ from the original versions and will not include signatures.

For information about how to set up attachments to be sent to technicians, see Set up attachments to be sent to
technicians on page 48.
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Setting up MobileTech options

Specify setup options

Use this information to choose settings that control how MobileTech is used. Settings that are not available are read-

only.

In MobileTech Administration, choose Setup Options. The setup options page is displayed.

Select a setting to view its description at the bottom of the page, or refer to the tables that follow for information about
how to configure the settings for your organization.

MobileTech Global Settings

DataSource
The SQL Server name and instance that was specified during logon. This value cannot be changed.

Username
The user who logged on to MobileTech Administration to communicate with the SQL Server database. This
value cannot be changed.

TimeTrackProxyUrl
The URL of the default TimeTrack Web Service. This value is configured during setup and should not be
changed unless the TimeTrack Web Service is moved to a new server.

LogVerbose
Determines whether all possible events are logged to the event log. The default value is False.

If True, all possible events are logged to the event log, and the event log fills much more quickly. You might
want to set this to True only for troubleshooting purposes.

LogSql
Determines whether all T-SQL statements are logged to the event log. The default value is False.

MobileTech Company Specific Settings

AdminEmailAddress
The administrative email account where log files and error logs are sent.

HistoryCount
The number of historical equipment and service records to display on the client device when the technician
requests service history. The default value is 3.

IncludeMCCWithHistory
Determines whether maintenance computer-generated calls (MCC) are included when service and
equipment history is requested. The default value is True.

CurrencyDecimalPlaces
The number of decimal places that are used to process currency amounts on the device. This value comes
from Microsoft Dynamics GP and cannot be changed.
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e CreateNewCallForAnyCustomer
Determines whether technicians can create a service call for any customer in the system. The default value
is False.

The following settings for global filtering and creating a call for any customer determine permissions for
technicians. For more information about global filtering, see “Using global filters” in the Service Management
manual.

Note: Global filtering is set up in Service Management. Go to Microsoft Dynamics GP > Tools > Setup >
Service Management > Module Setup > Service Options. In the Service Options window, mark Use
Global Record Identification Filters.

e Global filtering is marked and CreateNewCallForAnyCustomer = True
Technicians can create calls for any customers and locations in their assigned branches (home and
away), and for any exception-branch customers and locations that are assigned to calls and
appointments.

e Global filtering is marked and CreateNewCallForAnyCustomer = False
Technicians can create calls only for customers and locations that are assigned to their calls and
appointments.

e Global filtering is not marked and CreateNewCallForAnyCustomer = True
Technicians can create calls for any customers and locations in the system.

e Global filtering is not marked and CreateNewCallForAnyCustomer = False
Technicians can create calls only for customers and locations that are assigned to their calls and
appointments.

Report Settings

e ReportEmailMode
Determines how to handle automated emails of reports and other documents, such as invoices. Reports are
always sent to the email account that is specified for a technician when the technician is added to
MobileTech (MobileTech Administration > Users).

Note: Each technician’s email address is also their logon account, and that is the email address that is
used to send reports to the technician.

e Do not send report emails
The report is sent only to the specified email account for the technician. The technician can then
decide whether to forward the report to others, and to whom. This is the default value and should
be used if reports should never be sent directly to a customer or another third-party contact.

e Signature Contact Management
Send an email to the technician, and to the contact or contact list that is set up in Contact
Management and that is associated with the location of the service call.

e GP Internet Addresses
Send an email to the technician who is set up in the Internet Information window in Microsoft
Dynamics GP (Microsoft Dynamics GP > Tools > Setup > Company > Internet Information)
and who is associated with the location of the service call. Only one contact is allowed for this
value.

e Selected or entered by technician
The technician can select one or more email addresses to send reports or other documents, such
as invoices, to appropriate personnel in the organization. The technician can also enter email
addresses for new contacts and customers to send documents to them. This value applies only to
external reports and documents, such as field invoices and the Call Summary report.
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e ReportEmailSMTPServer
The name of the machine where the email server resides.

e ReportEmailSMTPServerPort
The port that is used by the email server. The default port number is 25, but you can change it for your
system.

e ReportEmailSMTPEnableSSL
Determines whether SSL is used by the email server. The default value is False.

e ReportExecutionUrl
The URL for the Report Execution web service. This URL is used by the system to communicate with the
SSRS report server to generate the Call Summary report.

Note: To locate the URL, open Reporting Services Configuration Manager, and then open the Web
Service URL section. Use the value from the URLSs field, followed by /ReportExecution2005.asmx.

Example: http://{servername}/ReportServer/ReportExecution2005.asmx

e UseSMTPAuthentication
Determines whether a user name and password are required for sending email. The default value is True.

e SMTPUsername
The user name that is used to send report email naotifications. This is available — and required — if
UseSMTPAuthentication = True.

e SMTPPassword
The password that is used to send report email notifications. This is available — and required — if
UseSMTPAuthentication = True.

e ReportPreviewMaxRetryAttempts
The number of times that the client attempts to retrieve the preview of a field invoice after it is requested.
The default number of attempts is 30.

This setting applies to field invoicing and is available only if Field Invoicing and Field Payments is registered,
and UseFieldinvoicing = True in the Field Invoicing and Field Payments Settings area.

e ReportPreviewRetryInterval
The number of seconds between when the client tries to retrieve the preview of a field invoice until the
maximum number of attempts has been met or the preview invoice is generated. The default number of
seconds is 30.

This setting applies to field invoicing and is available only if Field Invoicing and Field Payments is registered,
and UseFieldlnvoicing = True in the Field Invoicing and Field Payments Settings area.

Mobile Device Global Settings

e AutoStatusUpdate
The default status for appointments that are received by the device. The default value is blank, which means
no status is assigned to the appointments

If a status is selected for both this setting and JobSafetyStartStatus in Job Safety Tasks on page 26, we
recommend that you do not use the same status for both.

Note: AutoStatusUpdate and TimeLogStatusUpdate in Time Log Settings on page 24 cannot have the
same value.
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DefaultWeekday
The default week-ending day for time entries, which is based on the TimeTrack settings in the Microsoft
Dynamics GP database. This value cannot be changed.

UseAdditionalWork
Determines whether technicians can enter additional work on a service call. The default value is True.

If False, technicians cannot enter new additional work in the Additional Work pane.

UseBarcoding
Determines whether the organization uses barcoding functionality in MobileTech. If True, barcoding is used.

If False, barcoding is not used. The default value is False.

UseServiceCallUserDefine2
Indicates whether the Service Call User Defined 2 field is a validated lookup, based on the Service
Management settings in Microsoft Dynamics GP. This value cannot be changed.

UseWorkCrewJobCost

Determines whether technicians can enter billed labor, travel, and expense transactions for a Job Cost work
crew that includes any Microsoft Dynamics GP user who has valid hourly or business expense type pay
codes. The default value is True.

UseWorkCrewService
Determines whether technicians can enter labor, travel, or expense transactions for service work crews or
individual work crew members when a service appointment is completed. The default value is False.

UseTechnicianHelper
Determines whether technicians can enter labor and expense transactions for another technician. The
default value is False.

If True, technicians also can change the technician on the transaction.
UseChangeOrder
Determines whether technicians can enter and review change orders that affect job costs. The default value

is True.

CustomerNotesReadOnly
Determines whether technicians can edit customer notes. The default value is True.

LocationNotesReadOnly
Determines whether technicians can edit location notes. The default value is True.

EquipmentNotesReadOnly
Determines whether technicians can edit equipment notes. The default value is True.

ServiceCallNotesReadOnly
Determines whether technicians can edit service call notes. The default value is True.

AppointmentNotesReadOnly
Determines whether technicians can edit appointment notes. The default value is True.

ContractNotesReadOnly
Determines whether technicians can edit contract notes. The default value is True.

DefaultNewNotesAsInternal
Determines whether the default setting for new notes that are created by technicians is Internal, which
means the notes are not displayed on the Call Summary report. The default value is False.

Technicians can change this setting per note when they create notes.
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Time

UseAppointmentNotesSummary

Determines whether note links are displayed at the bottom of the Appointment pane when technicians view
the details for a service call appointment. If True, the links are displayed, so technicians can easily view the
notes from one location. The default value is False.

UseEventBasedSync

Determines whether event-based syncing is used on all devices. If True, event-based syncing is used to
sync to the host system after a service call is created, an appointment is created or completed, a timesheet
report is requested, or a payment has been applied to a field invoice. If False, event-based syncing is not
used. The default value is True.

If Sync Login is marked on the Setup page on the device, the Sync page will be displayed and the user
must choose Sync. For more information, see “Event-based syncing” in the MobileTech Help.

Log Settings

UseTimelLog

Determines whether technicians can clock in and out from the client device and have billable labor hours
calculated automatically by the system. Unbillable hours for technicians also are calculated by the system.
Users also can see which appointments they are timed in to, and the Time In and Time Out values are
displayed in the Appointment Summary Preview and Job Summary Preview panes and on the Call
Summary and Appointment Summary reports. The default value is False.

If False, the next four settings are not available.

TimeLogLockTimelnTimeOut

Determines whether the Time In and Time Out fields on the client device are locked. The default value is
True.

If True, hours go directly to appointment history. If False, technicians can manually adjust the time.

You can change this value only if UseTimeLog = True.

TimeLogLockLaborTime
Determines whether the Labor Time field on the client device is locked. The default value is True.

If False, technicians can manually adjust the labor hours that are calculated based on their time in and time
out.

You can change this value only if UseTimeLog = True.
TimeLogAllowTimeOverlap
Determines whether technicians can time in to multiple appointments at the same time. The default value is

False, so time-in and time-out entries cannot overlap.

You can change this value only if UseTimeLog = True.

Note: If you are upgrading from an earlier version of MobileTech, this setting may have been set to
True and could not be changed. If so, the setting remains set to True after the upgrade, but you can
change the value.

TimeLogRoundinglInterval
The interval (in minutes) that labor time is rounded to when technicians time in and out. The default value is
15, which means the technician’s labor hours are rounded to the nearest 15 minutes.

You can change this value only if UseTimeLog = True.
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e TimelLogStatusUpdate
Choose the appointment status to default for appointments when the technicians time in. If the status is
manually updated in the appointment to the specified status, the technician will be automatically timed in.
The default value is empty (disabled).

Note: TimeLogStatusUpdate and AutoStatusUpdate in Mobile Device Global Settings on page 22
cannot have the same value.

Field Invoicing and Field Payments Settings

When you use field invoicing and field payments, you can invoice customers in the field as soon as an appointment is
completed, and collect payment for those invoices right away. Invoices are calculated similarly to how they are
calculated in Service Management.

You can enable this feature by customer, so that some customers can be invoiced in the field and invoices for other
customers are generated in the host system.

When technicians select to complete an appointment, they can choose to preview the field invoice before the service
call appointment is completed and the field invoice is created.

During the service call appointment completion process, a field invoice is created and the technician can accept
payment, depending on whether field payments are enabled. Both full and partial payments can be made.

This information applies when you use field invoicing and field payments:

e Field invoicing can be used only with service invoicing. Sales Order Processing (SOP) invoicing is not
supported.

e Payment term discounts are not supported.

e In the Tax Detail Maintenance window in Microsoft Dynamics GP, the Based On field for the tax detail must
be set to Percent of Sale/Purchase. The other options are not supported with field invoicing. Also, the
Round field must be set to Up to the Next Currency Decimal Digit.

e You must use a tax schedule from the master tax schedule, which is tied to a customer’s service location.
You cannot use tax schedules for individual cost categories.

e If you use SOP for inventory, the billing amount for items comes from the Item Price List Maintenance
window. If you do not use SOP for inventory, the billing amount comes from the Service Management pricing
matrix.

e All payment types are accepted, including cash, check, and credit card. However, a customer can use each
payment type only once per payment. For example, customers can pay using both a credit card and a
check, but not two credit cards. This is consistent with how the On Account window works in Service
Management.

These settings only apply if Field Invoicing and Field Payments is registered.

e UseFieldIlnvoicing
Determines whether the organization allows invoicing by technicians in the field. The default value is False.
If True, invoices are generated automatically when appointments for a service call are completed, if the
customer is set up to receive field invoices.

If False, the remaining settings in this section are not available.

e FieldlnvoicingTaxMode
Determines whether taxes for the organization are calculated for field invoices based on the tax schedule
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that is set up for a customer location, or if taxes are not calculated for field invoices. The default value is Do
not tax.

e Do not tax
Taxes are not calculated for field invoices. We recommend that you select this option if taxes are
built into your pricing.

e Calculate taxes using Dynamics tax information
Taxes are calculated based on the master tax schedule ID that is set up for the customer location.
For more information, see the Help for the Customer Maintenance window in Microsoft Dynamics
GP Receivables Management.

You can change this value only if UseFieldInvoicing = True.

e UseFieldlnvoicePreview
Determines whether technicians can preview field invoices before they are generated. The default value is
False.

You can change this value only if UseFieldInvoicing = True.

e PreviewlnvoiceNumber
The invoice number to use when a preview invoice is generated.

You can enter up to seven alphabetic, numeric, or special characters for the preview number. The invoice
number is the same for all preview invoices that are generated on all mobile devices and is added as a
prefix to the technician’s name on the preview invoice. The default value is PREVIEW.
You can change this value only if UseFieldInvoicePreview = True.

e UseFieldinvoiceSignature
Determines whether the customer signature that is collected when a service call appointment is completed
should be printed on the field invoice. The default value is False.
You can change this value only if UseFieldInvoicing = True.

e UseFieldPayments
Determines whether technicians can collect payments in the field and then send payment transactions to

Microsoft Dynamics GP. The default value is False.

You can change this value only if UseFieldInvoicing = True.

Job Safety Tasks

These settings apply only to service appointments. For information about how to set up Job Safety Audit (JSA)
information in the host system, see Set up job safety audit (JSA) information on page 51.

e UseJobSafetyTasks
Determines whether the JSA process is used. The default value is False.

If False, the remaining settings in this section are not available.

Note: If you change this setting to True, the JSA process is used only for appointments that are created
or edited in Service Management — and then synced — after the setting is changed. Other existing
appointments are not impacted.

e JobSafetyTaskListType
The JSA task list type. This value is required to use JSA and to make JSA tasks available to technicians.
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You can change this value only if UseJobSafetyTasks = True.

e JobSafetyStartStatus
The appointment status that is used to start the JSA process. When a technician selects this appointment
status, the Job Safety tab opens automatically so the technician can complete JSA tasks.

If a status is selected for both this setting and AutoStatusUpdate in the Mobile Device Global Settings
section, we recommend that you do not use the same status for both.

You can change this value only if UseJobSafetyTasks = True.

e JobSafetyUnsafeStatus
The appointment status that is used to indicate that work conditions are unsafe.

You might want to create a status specifically for this purpose, such as UNSAFE. You can create this status
in the Appointment Status Setup window in Service Management.

You can change this value only if UseJobSafetyTasks = True.

e JobSafetyValidationLevel
The level of requirement for completing the Job Safety Task report before starting work on appointment
tasks. The default value is REQUIRED.

e REQUIRED
The report must be completed to complete an appointment.

e OPTIONAL
The report does not have to be completed to complete an appointment.

You can change this value only if UseJobSafetyTasks = True.

Equipment Settings

e AllowModifyEquipmentRecord
Determines whether technicians can change an equipment record from the client device. The default value
is True.

Note: This setting does not prevent technicians from creating new equipment records.

e AllowModifyNewEquipmentld
Determines whether technicians can enter the equipment ID when they create an equipment record. The
default value is False.

If False, the equipment ID is system generated.

e UseRefrigerantTracking
Determines whether the Refrigerant Tracking tab is available when viewing equipment on a service call.
The default value is False.

If Refrigerant Tracking is not registered, this value cannot be changed.

e SyncAllEquipmentRecords
Determines whether all equipment records that technicians have access to are synced to the client devices.

If True, results are determined by the settings for global filtering in Service Management and the
CreateNewCallForAnyCustomer value in MobileTech Administration. The default value is False.
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Note: If you change this value from False to True, you need to load data, and make sure Sync
Lookups is marked before you choose Import. For more information, see Load data on page 39.

Global filtering is set up in Service Management. Go to Microsoft Dynamics GP > Tools > Setup > Service
Management > Module Setup > Service Options. In the Service Options window, mark Use Global Record
Identification Filters.
e Global filtering is marked and CreateNewCallForAnyCustomer = True
Every piece of equipment for locations in a technician’s branch, along with any exception-branch
customers and locations that are assigned to calls and appointments, is synced.

e Global filtering is not marked and CreateNewCallForAnyCustomer = True
All equipment records are synced, regardless of whether the equipment is assigned to a call.

e Global filtering is not marked and CreateNewCallForAnyCustomer = False
Only equipment records for locations that have assigned calls are synced.

e AssignedEquipmentValidationLevel
The level of requirement for equipment to be assigned during the appointment completion process. The
default value is Optional.
e OPTIONAL - Appointments can be completed regardless if equipment has been assigned or not.

e  WARNING — A warning is displayed if equipment has not been assigned to the appointment.

e REQUIRED - An appointment cannot be completed until equipment has been assigned.

Task Settings

Note: Beginning with Signature 2018 and MobileTech 6.0, if a task response is marked as required in Service
Management, the task cannot be completed until the response is entered.

e DefaultTaskStatus
The default task status when a task is received on a mobile device. The default setting is based on the task
status that is set up in Service Management.

This value does not apply to the tasks that are displayed when you view tasks by selecting the All Open
Tasks (hierarchy) view in the Tasks pane.

This value cannot be changed.

e DefaultTaskCompletionStatus
The default status that is used when completing a task on the client device.

e TaskValidationLevel
The level of requirement for completing tasks before completing an appointment. The default value is
WARNING.

e OPTIONAL - Appointments can be completed regardless of the status of the appointment tasks.

e WARNING — A warning is displayed if appointment tasks are set to the default task status that is
specified in the DefaultTaskStatus setting.

e REQUIRED - An appointment cannot be completed until all tasks have a status other than the
default task status, as defined in the DefaultTaskStatus setting.

e HideTaskEstimateHours
Determines whether estimated hours for a task are hidden on the client device.
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If True, estimated hours are hidden (they are not displayed on the client device). The default value is False.

e ShowTasksForAppointments
Determines whether tasks that are associated with an appointment are shown with the Appointment pane
when a service call appointment is completed. The default value is False.

e UseTaskMaterials
Determines whether task materials (replacement parts) are displayed for tasks and task hierarchies for
service calls. The default value is False.

Purchase Order Settings
These settings apply only if you use purchase orders.

e UsePurchaseOrder
Determines whether the Purchase Orders tab on mobile devices is active. Technicians can use that tab to
enter purchase orders. The default value is True.

e PurchaseOrderValidationLevel
The level of requirement for entering purchase orders before completing an appointment. The default value
is OPTIONAL.

e OPTIONAL - Technicians do not need to enter purchase orders before completing appointments
and are not prompted to enter them.

e WARNING - Technicians are prompted, but not required, to enter purchase orders before
completing appointments.

e REQUIRED - Technicians must enter at least one purchase order before completing appointments.

e AutoGeneratePurchaseOrderNumbers
Determines whether purchase order numbers are generated automatically.

If True, purchase order numbers are generated automatically and cannot be changed by technicians. If
False, technicians can enter purchase order numbers.

To use a unique prefix to make it easier to identify in the host system purchase orders that were entered by
technicians, select False. Then, for the DefaultPONumberPrefix setting, enter a prefix to display on
purchase orders that are created by technicians.

The default value is True.

e DefaultPONumberPrefix
Enter a unique purchase order number prefix to display on purchase orders that are created by technicians.

You can change this value and generate special prefixes only if AutoGeneratePurchaseOrderNumbers =
False.

e DefaultPOltemNumberPrefix
Enter a default prefix to display when technicians enter a non-inventory item on a purchase order line.

e DefaultSite
The default inventory site to use when technicians create purchase orders. If a technician is assigned to this
site in Service Management, the site is displayed by default in the Site field in the PO Lines pane. If a
technician is not assigned to this site in Service Management, the Site field is blank.
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DefaultUnitOfMeasure
The default inventory unit of measure to use when technicians create purchase orders.

UnknownVendorld
The default vendor ID to use when a vendor name is not displayed in the lookup window.

Technicians can select the Unknown Vendor option on devices when they purchase an item from a new
vendor who is not set up in Service Management.

UsePurchaseOrderReceipt
Determines whether technicians can view and receive against drop-ship purchase orders that are entered in
Microsoft Dynamics GP. The default value is False.

Resolution Settings

These settings apply only to service appointments.

UseResolution
Determines whether the Resolution tab is displayed when an appointment is being completed. The default
value is True and cannot be changed.

ResolutionValidationLevel
The level of required information that must be entered on the Resolution tab when completing an
appointment. The default value is OPTIONAL.

e OPTIONAL — Technicians do not need to complete the information on the tab to complete the
appointment.

e WARNING — A warning is displayed to indicate that information on the tab is not complete.
e REQUIRED - Technicians must complete the information on the tab to complete the appointment.

UseAppointmentResolutionNote

Determines whether the Appointment Summary or Call Summary report is generated when resolution notes
are entered for an appointment or service call.

If True, and resolution notes are entered for appointments, the Appointment Summary report is generated. If
False, and resolution notes are entered for service calls, the Call Summary report is generated. The default
value is False.

ResolutionNoteValidationLevel
The level of required information that must be entered for a Resolution Note is created. The default value is
Optional.

e OPTIONAL - Technicians do not need to complete the information on the tab to complete the
appointment.

o  WARNING — A warning is displayed to indicate that information on the tab is not complete.

e REQUIRED - Technicians must complete the information on the tab to complete the appointment.

Labor Settings

UseLabor
Determines whether Labor is an entry type option in Time Entry when an appointment is being completed.
The default value is True.
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If False, the remaining settings in this section are not available.
LaborValidationLevel
The level of information that is required for labor when completing an appointment. The default value is
OPTIONAL.
e OPTIONAL - Technicians do not need to complete labor information to complete appointments.
e  WARNING — A warning is displayed to indicate that labor information is not complete.
e REQUIRED - Technicians must complete labor information to complete appointments.

You can change this value only if UseLabor = True.

DefaultCostCodelLabor
The default cost code that is displayed on the device for labor.

You can change this value only if UseLabor = True.

DefaultBilledHourlyPayCode

The default pay code that is displayed on the device for billed hourly labor. Technicians can set up or
change any pay code on an individual device.

You can change this value only if UseLabor = True.

DefaultUnbilledHourlyPayCode

The default pay code that is displayed on the device for hourly labor that is not billed. Technicians can set up
or change any pay code on an individual device.

You can change this value only if UseLabor = True.

ShowTechnicianTotalLaborHours

Determines if the technician's hours display in the Time Entries and Appointment Entry headers. The default

value is set to False.

e Time Entry header - Displays the current week or previous week total hours, depending on the
drop-down selection.

e Appointment Entry header - Displays the total appointment hours.

Travel Settings

Note: In the current release, extended pricing is not supported for travel and expense transactions through Time

Entry.

UseTravel
Determines whether Travel is an entry type option in Time Entry when an appointment is being completed.
The default value is True.

If False, the remaining settings in this section are not available.

TravelValidationLevel

The level of information that is required for travel when completing an appointment. The default value is
OPTIONAL.

e OPTIONAL
Technicians do not have to complete travel information to complete appointments.
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o  WARNING
A message is displayed to indicate that travel information is not complete.

e REQUIRED
Technicians must complete travel information to complete appointments.

You can change this value only if UseTravel = True.

DefaultBilledTravelPayCode
The default pay code that is displayed on the device for billed travel. Technicians can set up or change any
pay code on an individual device.

You can change this value only if UseTravel = True.

DefaultUnbilledTravelPayCode

The default pay code that is displayed on the device for unbilled travel. Technicians can set up or change
any pay code on an individual device.

You can change this value only if UseTravel = True.

Expense Settings

Note: In the current release, extended pricing is not supported for expense and travel transactions through Time

Entry.

UseExpense

Determines whether Expense is an entry type option in Time Entry when an appointment is being
completed. The default value is True.

If False, the remaining settings in this section are not available.

ExpenseValidationLevel
The level of information that is required for expenses when completing an appointment. The default value is
OPTIONAL.
e OPTIONAL - Technicians do not have to complete expense information to complete appointments.
o WARNING — A message is displayed to indicate that expense information is not complete.
e REQUIRED - Technicians must complete expense information to complete appointments.

You can change this value only if UseExpense = True.

DefaultCostCodeExpense
The default cost code that is displayed on the device for expenses.

You can change this value only if UseExpense = True.
DefaultBilledExpensePayCode
The default pay code that is displayed on the device for billed expenses. Technicians can set up or change

any pay code on an individual device.

You can change this value only if UseExpense = True.

DefaultUnbilledExpensePayCode
The default pay code that is displayed on the device for unbilled expenses. Technicians can set up or
change any pay code on an individual device.
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You can change this value only if UseExpense = True.

Inventory Settings

Uselnventory

Determines whether the Inventory tab is displayed when an appointment is being completed. The default
value is True.

If False, the remaining settings in this section are not available.

UseNoninventoryltems
Determines whether non-inventory parts can be entered on the device. The default setting is True.

You can change this value only if Uselnventory = True.

Note: If you use non-inventory items as task materials and UseTaskMaterials = True, you should set
this option to True.

InventoryValidationLevel
The level of information that is required on the Inventory tab when an appointment is being completed. The
default setting is OPTIONAL.

e OPTIONAL - Technicians do not have to complete the information on the tab to complete the
appointment.

e  WARNING — A message is displayed to indicate that information on the tab is not complete.

e REQUIRED - Technicians must complete the information on the tab to complete the appointment.

You can change this value only if Uselnventory = True.

ShowlnventoryCost
Determines whether the Inventory Cost field is displayed on the tab. The default value is True.

You can change this value only if Uselnventory = True.

ShowlnventoryPrice
Determines whether the Inventory Price field is displayed on the tab. The default value is True.

You can change this value only if Uselnventory = True.
ShowlnventorySiteQtyAvailable
Determines whether Inventory Site Quantity based on the technician's sites in Technician Setup. The default

value is False.

Additional setup requires you to choose the Load Data tab, select your technicians, mark Sync Lookups,
and then choose Import.

The calculation used is Quantity on Hand - Quantity Allocated per item in Microsoft Dynamics GP - Quantity
in the MobileTech Inventory holding table (WS20002).

Signature Settings

These settings apply only to service appointments.
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UseSignature
Determines whether the Signature tab is displayed when an appointment is being completed. The default
value is True.

Validation levels
The level of information required when an appointment is being completed. These options are available
when UseSignature is set to True.

e CustomerSignatureValidationLevel
The level of information that is required to capture the customer name and signature when an
appointment is being completed. The default value is OPTIONAL.

e OPTIONAL
A customer name and signature is not required to complete an appointment.

o WARNING
A message is displayed to indicate that a customer name signature has not been
captured.

e REQUIRED

A customer nhame and signature is required to complete an appointment.

e TechnicianSignatureValidationLevel
The level of information that is required to capture the technician name and signature when
completing an appointment. The default value is OPTIONAL.

e OPTIONAL
A technician name and signature is not required to complete an appointment.

e WARNING
A message is displayed to indicate that a technician name and signature has not been
captured.

e REQUIRED

A technician name and signature is required to complete an appointment.

2SEE Settings

XOi (formerly XOEye) equips field technicians with wearable technology systems, or the free Vision Telepresence
Client app for Android and iOS devices, that capture and share information. The technician can capture an image
and/or video that is uploaded to the XOi server. After uploading in the client, the unique hyperlink is copied to the
Resolution Note. After synchronizing, back office users can view the attachment to the service call. Anyone with the
unique hyperlink can view and/or download the images or video. The activities on the XOi server are tagged with the
call ID, appointment number, location name, and XOi user ID. The hyperlink is available for 30 days.

UseXOEye
Determines if the XOi APl is enabled. The default value is False.

UseXOEyeWorkflow
Determines if XOi Workflow is enabled. The default value is False.

XOEyeClient ID
Defaults to MobileTech. Display only.

XOEyeLoginURL
Defaults to the XOi login URL. Display only.
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e XOEyeVisionURL
Defaults to the XQi Vision endpoint. Display only.

e XOEyePartnerID
Enter your XOi Partner ID that has been provided to you from XOi.

Set up TimeTrack batch options

You can specify a custom batch name for TimeTrack transactions that are entered from a mobile client device.

Note: In the current release, extended pricing is not supported for expense and travel transactions through Time
Entry.

When technicians complete a call that contains labor, a batch is created in TimeTrack. Users can commit and post
these batches as they would any other TimeTrack batches.

1. In MobileTech Administration, choose Setup Options, and then choose Options > TimeTrack Batch Options.
The TimeTrack Batch Options page is displayed.

2. Enter a custom batch name, or choose to base the name on the technician ID, branch name, technician
team, or service area.

3. You can optionally choose to include the Time Track week-ending date or the transaction date in the batch
name.

Note: Because either of these options contain eight characters and the batch name can be only 15
characters long, if you mark this check box, the name you specified in step 2 is truncated to seven
characters, if necessary.

4. Choose Save.

Set up report and email options

You can specify options to send MobileTech reports via email.

1. In MobileTech Administration, choose Setup Options, and then choose Options > Report Options. The
Report and Email Options page is displayed.

2. You can set up the following information for sending reports and other documents, such as invoices, to a
customer.

e Report Source
The name of the report. Available reports are:

e Call Summary

e Field Invoice

Note: The Field Invoice report is available only if Field Invoicing and Field Payments
is registered, and UseFieldlnvoicing = True in the setup options.

e Job Safety Audit

e Employee Time Sheet
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e Appointment Summary

e Inspection Report

Note: The Inspection Report is available only if VEI is registered.

e Job Appointment Summary

Appointment Type
Indicates whether all appointments or only service appointments are displayed on the report.

Call Type
The default call type filter for the report. -Blank- displays all call types.

Note: For inspection reports, verify that the correct call type is set up for inbound and outbound
calls.

Division
The default division filter for the report. -Blank- displays all divisions.

Email Technician
Mark the check box if you want the technician to receive the report via email.

Report Type
Indicates a SQL Server Reporting Services (SSRS) report.

Report Format
The output format of the report:

e PDF - Acrobat file

e EXCEL - Microsoft Excel file

e MHTML — Web archive file

e IMAGE - Tagged Image File Format (TIFF) file

Report Path Name

Use SQL Server to determine the path where the report is deployed. The path is most likely either
/Company Name/WennSoft Service/Call Summary or /Company Name/Signature Service/Call
Summary, depending on whether you upgraded to MobileTech R6.0 from a previous version or
installed it for the first time.

Contact Role Type
Specifies which contacts receive automatic emails if you selected Signature Contact
Management for the ReportEmailMode setting in the setup options.

Enter a contact role type to send emails only to contacts of a certain type. If you enter %, emails
will be sent to all contact types.

Email From Address

The email address that reports or other documents, such as invoices, are sent from. If you use a
generic company email address, such as MobileTech@ YourCompany.com, you can prevent the
technician from having to forward a report email to a customer contact, so the customer will not
have the technician’s email address.

Email Subject
The subject of the email message when the report is sent.
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e Email Body
The body text of the email message when the report is sent.

3. Choose Save.

Optional: Add call, appointment, and location information
to email subject lines and attachment names

You can set up MobileTech to automatically include the service call ID and appointment number in the email subject
line and the name of the PDF attachment when Call Summary, Appointment Summary, or Field Invoice reports are
sent via email.

1. In MobileTech Administration, choose Setup Options, and then choose Options > Report Options. The
Report and Email Options page is displayed. Scroll to the Email Subject column.

2. Inthe Email Subject column, to include the following automatically.

e Service Call ID and Appointment Number
Enter a space and then type ({0}).

e Service Call ID, Appointment Number, and Location
Enter a space and then type ({0} : {1}).

3. Choose the Save icon and close the page.

Set up file extension options for attachments

You can specify the types of file extensions for attachments that can be sent to devices from the host system.

1. In MobileTech Administration, choose Setup Options, and then choose Options > Attachment Extensions.
The Attachment Extensions Setup page displays a list of default extensions.

2. To add an extension type, choose the Add icon. In the Extension column, enter the type of extension for
the attachment.

3. To delete an extension type, select an extension type and choose the Delete icon. You can also choose the
Refresh icon to update the list.

4. Choose the Save icon to save the changes.

Optional: Specify which report attachments to sync to
devices

By default, the following report attachments are not synced from the middle-tier database to the devices:
e  Appointment Summary report

e  Call Summary report
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Job Appointment Summary report

JSA report

You can change the attachment sync filter in Woodford if you want these report attachments to be synced to the

devices.

For more information about logging on to Woodford, see Install and activate Woodford on page 41.

1.

In MobileTech Administration, choose Tools > Launch Woodford. The Dynamics CRM Login Dialog window
is displayed.

Enter the URL, user name, and password to log on to Woodford.

The URL must include the server name and port where MobileTech is installed, and the name of the
company database (in lowercase letters).

Example: http://servername:8080/companydatabase

Choose OK.

In the Woodford workspace, double-click your mobile project.

In the navigation pane, choose Note, and then choose Sync Filter on the toolbar.

The Edit Filter window is displayed. This window lists the conditions for the reports that are not currently
synced to the devices.

Remove the condition for the report attachments that you want to sync to the devices.

For example, if you want Call Summary reports to be synced to the devices, choose the drop-down arrow for
the Name — Does Not Contain — Call Summary Report condition, and then choose Delete from the menu
that appears.

When you have finished editing the sync filter, choose Save & Close on the toolbar.

Choose Publish All on the toolbar.

Set up customer options for field invoicing and field
payments

If your organization uses field invoicing, you can allow and restrict which customers the technicians can generate field
invoices for in MobileTech. For example, you might let technicians generate invoices for residential customers, but
not for commercial customers.

You can restrict or allow access to individual customers or to all customers.

Field invoicing is available only if Field Invoicing and Field Payments is registered, and UseFieldlnvoicing = True in
the setup options.

1.

In MobileTech Administration, choose Setup Options, and then choose Options > Customer Options. The
Customer Setup page is displayed.

This page displays a list of customers who are set up in the Customer Maintenance window in Microsoft
Dynamics GP, and who have this information set up:

e Service area
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e  Primary and secondary technician
e Labor rate group

e  Price matrix

2. Make sure the Disable Field Invoicing check box is not marked for the customers for whom technicians
can generate field invoices. If that check box is marked for a customer, a technician cannot create a field
invoice for that customer.

You can complete these actions by using the icons on the page:

e Navigation buttons
Go to a record that is not highlighted. For example, you can go to the first, next, or previous
customer record, or the last record in the list.

e Refreshicon
Apply changes that were made since the last time you saved changes on the page.

e Select All Toggle icon
Mark or unmark the Disable Field Invoicing check box for all the customers in the list.

3. Choose the Save icon to save the changes.
Load data

You must load data into the organizational database for each technician you select. Any data that is associated with
open calls and appointments for each technician, and for the specified date range, is included.

Each time you load data, lookups are processed first, followed by all items that are available to sync in the
WSMobileTechSync table are processed first. The progress information for the process is displayed as Integration
Synchronization.

1.

2.

In MobileTech Administration, choose Load Data.

Mark the check boxes for the technicians to load data for, or choose Select All to mark all the technicians in
the list.

Enter the date range to include when you load and sync data.

Note: We recommend that you limit the date range so only current and relevant data is included and
historical data for transactions is not included. For performance reasons, the maximum date range is
two months.

Mark the Sync Lookups check box.

Note: If there is not any data to sync in certain lookup tables, this check box is marked and cannot be
unmarked.

You do not need to mark this check box if you are adding subsequent users after you have already
loaded data and synced lookups. For more information, see Add a MobileTech user on page 16.

Choose Import. The processing time is determined by the number of technicians, the amount of data to
import, and the date range that you entered.

Choose Close.

39



Setting up MobileTech options

Set up additional companies

You must set up each company that is in the Microsoft Dynamics GP database.
1. In MobileTech Administration, choose File > Change Company. The Change Company page is displayed.
2. Select a company and choose OK.

3. See Set up MobileTech on page 12 to continue with the procedures to set up each company.

Optional: Increase the maximum size of the MobileTech
event log

When transaction information is transmitted between devices and the host system, any events that occur are
recorded in the MobileTech event log in Windows Event Viewer.

This log can fill up quickly, so you might want to increase the maximum size of the event log so you do not lose log
history.

The default maximum size of the event log is 4,096 KB. Depending on the amount of history you want to keep, you
might want to double (8,192 KB), triple (12,288 KB), or quadruple (16,384 KB) the maximum size of the event log.

1. Choose Start > Administrative Tools > Event Viewer. The Event Viewer window is displayed.
2. Inthe navigation pane, expand Applications and Services Logs.

3. Right-click the MobileTech log and choose Properties. The Log Properties — MobileTech window is
displayed.

4. Inthe Maximum log size (KB) field, enter a new maximum file size, such as 8192, 12288, or 16384.

5. Choose OK.
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Installing and using Resco Woodford

Woodford is a tool that lets you customize and configure MobileTech for your business purposes.

Important: You must install and activate Woodford, regardless of whether you will customize MobileTech.

These are some of the customizations you can make:

Design and add new views or change existing views.
Change field labels, entities, and alerts, and hide fields on pages.

Manage security and view information about devices that sync with the MobileTech web service, such as the
operating system, version, current user, and sync dates.

Specify global sync settings for all technicians (On Load, On Change, and On Save).

Install and activate Woodford

We recommend that when you launch Woodford, you log on by using the system administrator credentials you used
when you installed MobileTech Administration.

1.

In MobileTech Administration, choose Tools > Launch Woodford. The Dynamics CRM Login Dialog window
is displayed.

Enter the URL, user name, and password to log on to Woodford.

The URL must include the server name and port where MobileTech is installed, and the name of the
company database (in lowercase letters).

Example: http://servername:8080/companydatabase
Choose OK.

The Registered User window might be displayed. If it is, enter your contact information in the window and
choose Register.

If the "New update is available" message is displayed, choose Later.

Important: Do not install a new version of Woodford until you are instructed to do so by KEY2ACT.
Woodford is a third-party product and you must use a version of Woodford that is compatible with
MobileTech R6.0.

Choose Import and browse to the location where the MobileTech.woodford file was saved when you
installed MobileTech Administration.

For most users, the location of the Woodford file is C:\Program Files (x86)\Signature MobileTech
Admin\Woodford.

The Add Mobile Project window is displayed.

In the Type and Template fields, accept the default entries.

In the Name field, enter MobileTech.

Mark the MobileTech check box for the role.
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9. Choose OK.
The exclamation point next to the mobile project indicates that the project has not been published.
10. Double-click the MobileTech mobile project and choose Publish All.

11. Sync your device. The "Application was updated" message is displayed to indicate that a Woodford project
is active.

12. Unmark the option to be notified when Woodford updates are available. In Woodford, choose Settings and
unmark the Check for updates on startup check box.

13. Save the changes.

For information about how to use Woodford to customize your application, see the Resco Mobile CRM Woodford
User Guide.

Important information for upgrade customers who already
use Woodford

If you are using a previous version of MobileTech and you already have Woodford installed, review this information
carefully before you install the latest compatible version of Woodford.

Do not install a version of Woodford that is newer than v8.3.2

Do not install a newer version of Woodford until you are instructed to do so by KEY2ACT. Woodford is a third-party
product and you must use a version of Woodford that is compatible with MobileTech R6.0.

When you launch Woodford, if the "New update is available" message is displayed, choose Later.

After you install and activate Woodford, we recommend that you set up Woodford so you are not prompted to install a
newer version when it is released by Resco. In Woodford, choose Settings and unmark the Check for updates on
startup check box.

Import a new project file

Follow these steps to import the new Woodford project file.

1. Back up and rename the Woodford project
Back up the Woodford project and rename it (for example, OLD_MobileTech.woodford).

2. Deactivate the old Woodford project
Select the project file that you renamed in the previous step and choose Deactivate.

3. Load the new Woodford project file
Changes have been made to the application that require a new MobileTech.woodford project file be used.

4. Reapply customizations after you install
If you have already made customizations to MobileTech by using Woodford, you must reapply those
customizations each time you upgrade MobileTech and the corresponding Woodford project.
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5. Publish the new project file
Double-click the new MobileTech.woodford project file and choose Publish All.

Modifying entities by using Woodford

Modifying entities by using Woodford

This information is intended to provide insight into areas that cannot be modified by using Woodford. It also includes
recommendations about which entities you should not change.

Tabs that you cannot modify

You cannot use Woodford to modify the Resolution tab and the Summary tab for appointments in MobileTech.

Entities that you should not change sync filters for

To help make sure that all records sync accurately, we recommend that you do not change sync filters for the
following entities. Changing these filters could result in unexpected behavior and sync issues:

e  Appointments

e Appointment status time stamps

e Change orders and change order details

e  Consumed inventory

e Contracts

e Customers

e  Equipment and contract equipment

e Locations, sublocations, and location contacts
e Jobs and job cost codes

e Job safety tasks

e  Meter readings

e Purchase orders and purchase order details

e  Purchase order receipts and purchase order receipt details
e Refrigerant tracking

e  Service calls
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e Tasks and subtasks

e Time logs

Enabling flexible forms

The flexible form is a way for users get a perfect overview of any record at a glance. Instead of users choosing
various tabs to the view information, you can put the record’s fields, associated views and other items into one
screen.

Note: The Appointment, Appointment Completion, Customer, and Location entities have been tested to work with
flexible forms. While other forms can be modified to use with flexible forms, doing so is at your own risk.

To enable flexible forms
1. In MobileTech Administration, choose Tools, and then choose Launch Woodford.
2. Choose the MobileTech project and then choose Edit from the menu bar.
3. Inthe navigation bar, choose Configuration.

4. In the Mobile CRM Configuration section, complete the following:

e Flexible Forms
Enable Flexible Forms by setting this to True.

e Flexible Forms use Vertical List
We recommend you leave this option set to True. If set to False, the forms scroll horizontally on

larger devices.

Note: Smaller devices like smart phones display the information in a single vertical scroll
window. Larger devices may display up to three columns of information, depending on the size
of the device. Additionally, when scrolling on an Android or iOS device, a hover menu bar
displays that a user can tap to navigate quickly to a section.

Note: The barcode icon is not available when a list is displayed in a completion form if Flexible Forms is set to True in
Woodford. The barcode icon is available in full panel mode, which you can access by double-tapping the section
header.

To customize forms

For information about how to customize the Appointment, Appointment Completion, Customer, and Location forms
and their associated tabs, see the Flexible Forms section in the Resco Mobile CRM Woodford User Guide.

Avoid making these changes

This information is intended to provide insight into areas that cannot be modified by using Woodford. It also includes
recommendations about which entities you should not change.
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Tabs that you cannot modify

You cannot use Woodford to modify the Resolution tab and the Summary tab for appointments in MobileTech.

Entities that you should not change sync filters for

To help make sure that all records sync accurately, we recommend that you do not change sync filters for the
following entities. Changing these filters could result in unexpected behavior and sync issues:

Appointments

Appointment status time stamps
Change orders and change order details
Consumed inventory

Contracts

Customers

Equipment and contract equipment
Locations, sublocations, and location contacts
Jobs and job cost codes

Job safety tasks

Meter readings

Purchase orders and purchase order details

Purchase order receipts and purchase order receipt details

Refrigerant tracking
Service calls
Tasks and subtasks

Time logs
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Installing MobileTech Client

Use these instructions to install MobileTech Client. For information about how to use MobileTech Client after it is
installed, see the Help in MobileTech.

1.

Double-click the install file. For example, for Windows devices, this is Signature MobileTech Client.exe.
See the Readme for the version of MobileTech Client to install.

On the Welcome to the Signature MobileTech Client Setup Wizard page, choose Next.

On the End-User License Agreement page, read and accept the license agreement, and then choose Next.
The Select Installation Folder page is displayed.

Choose Browse to select the location where MobileTech Client should be installed, or accept the default
location.

Choose Next. The Ready to Install page is displayed.

Choose Install to start the installation. The Installing Signature MobileTech Client page will display the
progress of the installation.

When the installation is complete, the Completing the Signature MobileTech Client Setup Wizard page is
displayed. Choose Finish.
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Setting up MobileTech on a client device

Information about how technicians can set up and use MobileTech on a client device is described in the Help on the
device.

From the MobileTech home page, choose Help and choose Signature MobileTech to see a list of topics. See
“MobileTech setup on a mobile device” for setup information and “Synchronization” for information about how to sync
with the host system.

e Technician information to sign in to or sync a mobile device
To sign in to a device or to sync a device with the host system, a technician must enter the URL of
MobileTech Integration Sync Server and a user name.
The URL must include the server name, website port number, and company database name.

Example: http://servername:8080/companydatabase

e Technician user names are their email addresses
A technician’s MobileTech user name is the email address that is set up in MobileTech Administration. See

Add a MobileTech user on page 16.

Technicians must use their email addresses to sign in to a client device.
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Setting up information in Microsoft Dynamics GP

This section helps administrators set up various types of information in the host system that technicians can access
as they enter information and complete tasks using mobile devices.

Set up TimeTrack to maintain history

You must set up TimeTrack to maintain history so TimeTrack transactions appear correctly on the Call Summary
report, especially after the TimeTrack batches are committed.

1. In Microsoft Dynamics GP, choose Microsoft Dynamics GP > Tools > Setup > TimeTrack > Setup Options.
The TimeTrack Setup Options window is displayed.

2. Inthe Miscellaneous Items section, mark Maintain History.

3. Choose Save.

Set up TimeTrack for unbilled transactions

If technicians will enter unbilled TimeTrack transactions in MobileTech, you must set up the host system to handle
those transactions properly.

1. In Microsoft Dynamics GP, choose Microsoft Dynamics GP > Tools > Setup > TimeTrack > Setup Options.
The TimeTrack Setup Options window is displayed.

2. Inthe Create a GL Journal Entry For section, mark Unbilled Transactions.
3. Choose Save.

4. Set up unbilled asset accounts. For information, see the TimeTrack documentation.

Set up attachments to be sent to technicians

Before you can send document attachments to technicians, you need to select and set up the actual files to attach
and send.

For more information about document management, see the Service Management documentation.
1. In Microsoft Dynamics GP, open a service call.

2. Choose the attachment (paperclip) icon next to the Service Call ID field. The Document List window is
displayed.

3. Choose Add. The Document Maintenance window is displayed.
4. Select a format and a file.

5. Choose the Copy To Database option.

Important: Attachments will not be sent to the device if you do not choose this option.
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6. Specify any additional information and choose Save.

Give technicians access to inventory items

To track inventory items that a technician uses on a service call, make sure the technicians have access to the
appropriate inventory sites.

1. In Microsoft Dynamics GP, choose Microsoft Dynamics GP > Tools > Setup > Service Management >
Lookup Setup > Technicians > Technicians. The Technician Setup window is displayed.

2. Select the technician ID.

3. Choose Inventory Sites. The Technician Inventory Site Setup window is displayed.

4. Mark the Assigned check box for the inventory sites that are associated with the technician.
5. Choose OK, and then choose Save in the Technician Setup window.

6. Repeat steps 2 through 5 for each technician.

7. Open MobileTech Administration and choose Load Data.

8. Select a technician and a date range.

9. Make sure the Sync Lookups check box is marked.

10. Choose Import.

Set up billable and unbillable pay codes

You can specify which pay codes are billable, unbillable, or both, and then send those pay codes to devices for
technicians to use for time, expense, and travel entries.

1. In Microsoft Dynamics GP, choose Inquiry > Service Management >Mobile Pay Code Setup. The
MobileTech Pay Code Setup window is displayed.

2. Choose whether each pay code is billable, unbillable, or both. The default value is Both for all pay codes.

3. Choose OK.

Set up resolution note snippets

You can set up resolution note snippets in Service Management to help you track work that is completed by
technicians. These snippets provide a uniform method for technicians to report how they resolve issues and complete
appointments. Technicians can include these snippets in the Resolution Note field in MobileTech.

1. In Microsoft Dynamics GP, choose Microsoft Dynamics GP > Tools > Setup > Service Management >
Lookup Setup > Service > Resolution Note Snippets. The Resolution Note Snippets window is displayed.

2. Enter aresolution ID and a description of up to 255 characters.

3. Choose Save.
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Assign items to vendors and create records for unknown
vendors

If a technician purchased items from a vendor who is not already entered in the system, complete these steps.

You also need to complete step 2 if both the item and vendor already exist in the system, but the item is not assigned
to the vendor from whom it was purchased.

1. In Microsoft Dynamics GP, choose Cards > Purchasing > Vendor. In the Vendor Maintenance window,
create a record for the vendor.

2. In Microsoft Dynamics GP, choose Cards > Inventory > Vendors. In the Item Vendors Maintenance window,
assign the item that was purchased to the vendor record that you just created.

Give technicians access to vendors

By default, vendors in Microsoft Dynamics GP are visible to technicians, who can select a vendor while creating a
purchase order. You can designate which vendors the technicians can select if you do not want all vendors to be
displayed in lookup lists.

1. In Microsoft Dynamics GP, choose Inquiry > Service Management > Mobile Vendor Setup. The Mobile
Vendor Setup window is displayed.

2. Unmark the check box next to vendors if you do not want the vendors to be displayed in lookup lists in
MobileTech.

3. Choose OK.

Verify mobile vendor setup for drop-ship purchase orders

You can receive committed and partial drop-ship purchase orders for job appointments and service calls from mobile
vendors. Drop-ship purchase orders are saved and committed in Microsoft Dynamics GP (Transactions > Purchasing
> Purchase Order Entry).

Mobile vendors must be set up in Service Management (Inquiry > Service Management > Mobile Vendor Setup). For
more information, see Give technicians access to vendors on page 50.

Freight and miscellaneous charges that are entered for purchase orders in Microsoft Dynamics GP are not synced to
the device. However, technicians can enter the amounts from the invoices when they receive shipments in the field.

Set up and use work crews for appointments

You can create work crew who work together at job or service appointments. For example, a team that installs
heating systems or does survey work could be a work crew.

You must set up work crews in TimeTrack, and then the activities of the crews can be tracked in MobileTech.

Depending on how your system is set up, at least one of these options in MobileTech Administration must be set to
True:

o UseWorkCrewJobCost

50



Setting up information in Microsoft Dynamics GP

e UseWorkCrewService

A technician who enters time for an appointment must be assigned to the work crew that is completing the work for
the appointment.

Set up work crews

1. In Microsoft Dynamics GP, choose Microsoft Dynamics GP > Tools > Setup > TimeTrack > Work Crews.
The Work Crew Setup window is displayed.

2. Enter a work crew name and description.
3. Mark the Enabled check box.

4. Choose Save, and then continue to set up work crews as needed.

Assign employees to work crews

You must set up employees as TimeTrack users in the Signature Registered Users Setup window (Microsoft
Dynamics GP > Tools > Setup > TimeTrack > Registered Users) before you can assign individuals to work crews.

After employees are set up as TimeTrack users, use the Work Crew Employee Setup window to assign individuals to
work crews.

1. In Microsoft Dynamics GP, choose Microsoft Dynamics GP > Tools > Setup > TimeTrack > Work Crew
Employees. The Work Crew Employee Setup window is displayed.

2. Select a work crew.
3. Inthe Signature Registered Employees grid, select an employee and choose Insert to add the employee

to the work crew. To remove a crew a member, select the employee in the Crew Members grid and choose
Remove.

Note: If an employee who was a member of a work crew has an Inactive status, choose Synchronize in the Work
Crew Employee Setup window. The employee is removed from the work crew.

Set up job safety audit (JSA) information

Use this information to set up JSA task lists and task codes in Microsoft Dynamics GP. For more information, see the
Service Management documentation.

For information about the JSA setup options in MobileTech Administration, see Job Safety Tasks on page 26.

Create an unsafe work environment indicator

If technicians determine there are safety issues that could prevent them from performing work, those technicians can
alert the office that the site is unsafe and provide a record in the host system.

To allow this, create an appointment status for unsafe work environments. For example, if you create an appointment
status of Unsafe, the technician could change the appointment status to Unsafe and send the appointment back to
the host system. The appointment would be removed from the technician’s device after syncing.
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1. In Microsoft Dynamics GP, choose Microsoft Dynamics GP > Tools > Setup > Service Management >
Lookup Setup > Service > Appointment Status. The Appointment Status Setup window is displayed.

2. Enter a name for the appointment status.

3. Complete the remaining fields, as necessary, and choose Save.

Create the JSA task list type

When you create a task list type of JSA, you indicate that the tasks are safety tasks that are handled differently than
other task types. All job safety task lists must have a task list type of JSA.

1. In Microsoft Dynamics GP, choose Microsoft Dynamics GP > Tools > Setup > Service Management >
Lookup Setup > Tasks > Task List Types. The Task List Type Setup window is displayed.

2. Enter JSA and choose Save.

Create task codes for JSA tasks

You must create task codes that will be assigned to JSA task lists. The task codes define the specific conditions that
a technician must validate before starting work on a service call.

For information about recommended naming conventions, see Naming conventions for JSA task list IDs and task
codes on page 54.

1. In Microsoft Dynamics GP, choose Microsoft Dynamics GP > Tools > Setup > Service Management >
Lookup Setup > Tasks > Task Codes. The Task Code Setup window is displayed.

2. Enter a task code and description.

3. You can also set up responses for each task. For information, see Set up responses for JSA tasks on page
52.

4. Complete the remaining fields, as necessary, and then choose Save. Repeat these steps for each task code
that you need to set up.

Note: Skill levels have no effect on JSA task codes.

Set up responses for JSA tasks

When you create task codes, you can also set up responses so technicians can respond to the tasks in the task list.
A task response can be marked as Required so that a technician has to complete that task response before exiting
the form.

You can use List, Yes/No, or Text response types.

1. In Microsoft Dynamics GP, choose Microsoft Dynamics GP > Tools > Setup > Service Management >
Lookup Setup > Tasks > Task Codes. The Task Code Setup window is displayed.

2. Enter or select a task code.
3. Choose the Responses button. The Task Responses Setup window is displayed.

4. Select a response type:
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e Yes/No
Provides the user with a drop-down list of Yes and No in the service call.

A Yes/No response type can be marked as a Skipped response. If a response selected is No, any
children beneath the skipped parent whether required or not, will be skipped and marked as
Completed.

e List
Provides the user with a drop-down list of user-defined responses in the service call.

e Text
Provides the user the ability to enter a text response. Text responses are stored in the database,
but are not displayed on the JSA report.

Note: This option can only be used once per task code and only as the last non-None row. All
further rows will be set to None.

5. Enter a label for the response field. This typically is the condition that must be validated or the question that
must be answered, such as Is there a sign-in and sign-out procedure?

6. If you selected the List response type, choose the Responses ID link. The Task Responses List Setup
window is displayed.

a. Enter or select a responses list ID.
b. Enter Yes and No as the values that will appear in the list.
Depending on your organization’s policies, you can enter just Yes and No, or you can enter a

longer value by typing Yes or No, a space, a hyphen, another space, and then the description.
Example: Yes — Sign in and out using the appropriate procedure.

Note: Only values that include more than three characters are displayed in the Risk control measures
section of the JSA report. Values of Yes and No will not be displayed.

For more information about setting up responses, see “Setting up task responses” in the Service
Management documentation.

6. Complete the remaining fields, as necessary, and then choose Save. Choose Save again in the Task Code
Setup window.

Create JSA task lists and add task codes

For each category of safety tasks, you must specify an integer as the task list ID. For example, if the category is
Electrical, the ID could be 1 and have a description of Electrical.

Task list IDs must be numeric. For information about recommended naming conventions, see Naming conventions for
JSA task list IDs and task codes on page 54.

All job safety task lists must have task list type of JSA.

1. In Microsoft Dynamics GP, choose Microsoft Dynamics GP > Tools > Setup > Service Management >
Lookup Setup > Tasks > Task Lists. The Task List Maintenance window is displayed.

2. Enter atask list ID and description.

53



Setting up information in Microsoft Dynamics GP

Note: Task lists for personal protective equipment must have an ID of 99. In addition,
JobSafetyTaskListType must be set to JSA in the Job Safety Tasks area of the setup options.
Otherwise, values will not be displayed in the Personal Protective Equipment section of the JSA report.

3. Select JSA as the task list type.

4. Complete the remaining fields, as necessary, and then choose Tasks. The Task List Detail window is
displayed.

5. Select the task codes to include in the list and choose Insert to add them to the task list. For more
information about using the fields in this window, see “Creating a task list” in the Service Management
documentation.

6. Choose OK, and then choose Save in the Task List Maintenance window.

Naming conventions for JSA task list IDs and task codes

When you set up JSA information, you will create task codes, and then assign those task codes to the JSA task lists
that you create.

Task list IDs must be numeric, and we recommend that you use a naming convention that groups together the task
codes that will be assigned to each JSA task list. This lets technicians navigate through categorized lists of tasks in
the appointment details, so they can respond to the tasks without having to open and save each task individually.

For example, suppose you plan to create task lists for servicing electrical, elevator, and HVAC systems. You might
categorize them in this way.

Task List ID Description
1 ELECTRICAL TASKS

Task code Description

1.1 Are you working near energized power?
1.2 Can electrical work be done with the power off?
1.3 Does Iive power work involve removal, replacement, etc.?

Task List ID Description
2 ELEVATOR TASKS

Task code Description

21 Are you working in a confined space?
2.2 Is there a safe emergency escape route from the work area?
2.3 I lighting in the work area adequate?

Task List ID Description

HVAC TASKS

Task code Description

31 Are you working in a noisy environment?

32 Are you using a ladder or stepladder?

33 Are you working above & feet in height?

3.4 Are you working within 3 feet of a roof edge?
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Set up sublocations for barcoding

The barcode functionality is available for equipment, sublocations, and inventory. The supported barcodes are those
in the ZBar library including: EAN-13/UPC-A, UPC-E, EAN-8, Code 128, Code 39, Interleaved 2 of 5, and QR Code.

The barcode feature allows the field technician to:

Scan a barcode from a piece of equipment or a sublocation with the MobileTech device for easy navigation
and accessibility to the assigned tasks.

Scan a piece of equipment to add it to an existing service call or to add it to a new service call.
Scan and record a barcode for a new piece of equipment at a customer site.

Scan a barcode for an existing piece of equipment, if a barcode doesn’t already exist, to update the
equipment record with the barcode scanned.

Automate the entry of an inventory part number during the appointment completion process.

To set up sublocations for barcoding

Before technicians can scan a sublocation barcode from the Service Calls or Appointments lists, you must select
sublocation validation in Service Management and set UseBarcoding to True in MobileTech Administration.

1.

In Microsoft Dynamics GP, choose Microsoft Dynamics GP > Tools > Setup > Service Management >
Module Setup > Service Options. The Service Options window is displayed.

In the Premier Options section, mark Use Validation for Sublocations, and then choose OK. This makes
the Sublocations button available in the Location window.

In Microsoft Dynamics GP, choose Cards > Sales > Customer. Enter or select a customer. Choose the
Location button, enter or select a location, and then choose the Sublocations button. The Sublocation
Maintenance window is displayed.

If a barcode is associated with the sublocation, add a sublocation barcode.

Save the changes.

In MobileTech Administration, choose Setup Options. Under Mobile Device Global Settings, make sure
UseBarcoding = True.
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Information processing in Microsoft Dynamics
GP

This section provides information about how host system users process information that was entered in MobileTech.

Process purchase orders in Service Management and
Purchasing

A purchase order that is entered in MobileTech by a technician must be reviewed, committed, and processed in
Service Management and Microsoft Dynamics GP Purchasing before costs that are associated with the purchase
order can be processed in the system.

Note: To allow technicians to quickly work and provide information to customers in the field, purchase orders for
service invoices and field invoices do not include taxes unless the invoices have been received in the Purchasing
module of Microsoft Dynamics GP.

Process purchase orders that were entered by technicians

After a purchase order has been synced with the host system, you can view and process the purchase order in
Service Management.

Costs that are associated with a purchase order are displayed in Service Management as committed costs on the
service invoice.

1. To view and process purchase orders that were sent from MobileTech, in Microsoft Dynamics GP, choose
Inquiry > Service Management > Mobile Purchase Order Inquiry. The Mobile Purchase Order window is
displayed.

2. You can choose Print to print the Mobile Purchase Order report, which displays information about the
purchase orders that need to be processed.

3. Select the transactions from MobileTech to process and choose Process.

4. Choose Redisplay to update the list of purchase orders that were submitted by technicians.

Post purchase orders in Microsoft Dynamics GP

1. To post purchase order transactions in Microsoft Dynamics GP that originated from MobileTech, in Microsoft
Dynamics GP, choose Transactions > Purchasing > Purchase Order Entry. The Purchase Order Entry
window is displayed.

2. Inthe PO Number field, select a purchase order.

3. View and change other information as needed. For example, you can add freight, tax, and miscellaneous
amounts to the purchase order.

Note: A purchases tax schedule for a company must be set up in the Company Setup window
(Microsoft Dynamics GP > Tools > Setup > Company > Company) before you can process taxes for
purchase order receipts.
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4. Choose Commit. Purchase orders that are committed are available in MobileTech so that technicians can
enter purchase order receipts for inventory items.

Process additional work requests for a technician

When additional work requests arrive from a technician, process those requests by using the Mobile Additional Work
window in Service Management.

1. In Microsoft Dynamics GP, choose Inquiry > Service Management > Mobile Additional Work Inquiry. The
Mobile Additional Work window is displayed.

2. Mark the check box next to an additional work record and use the following buttons for the additional work
requests. You can also choose Mark All or Unmark All to include or exclude all requests.

Process

When you finish reviewing a request, choose Process. The user who processed the request is
listed in the Followed Up By field in the Mobile Additional Work window that is opened from the
Service Call window.

Redisplay
Refresh the window if other work requests have been created since you opened the window. The
window is refreshed every time you open it.

Print
Print the selected work requests. To print all work requests, choose Mark All to select all the
requests.

Delete
Delete the selected work request. When you delete a request, no record of it remains in the
system. You can print a list before deleting, if necessary.

3. If atechnician has added an attachment to an additional work item in MobileTech, the icon changes from a
paperclip to a paperclip attached to paper. Once the additional work request is handled the attachment
remains with the additional work record.

To view the attachment, focus on the additional work row and then choose the additional work icon to open
the Document List window. This window displays the following information from the additional work item:

Service Call
Appointment
Additional Work Date

Additional Work Time

Choose the attachment listed in the scrolling window and then choose to Edit or Display. You can also add a
file to this additional work record by choosing Add.

Process inventory and non-inventory item transactions

Use the Mobile Inventory window to process inventory transactions that are entered by technicians.
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Note: If you use Sales Order Processing (SOP) invoicing, an item number cannot exist as both an inventory item and
a non-inventory item. If an item in the Mobile Inventory window has the same item number as an inventory item, but it
was sent from MobileTech as a non-inventory item, the location code will be blank and the item will not process
successfully. You will receive an error saying that the item number/location code does not exist in Inventory. You
must delete the line from the Mobile Inventory window and process the item correctly in SOP for the service call.

1. In Microsoft Dynamics GP, choose Inquiry > Service Management > Mobile Inventory Inquiry. The Mobile
Inventory window is displayed.

The items and part numbers that were entered by technicians for service calls are displayed. To delete a
record, select the item or part and choose Delete.

2. Choose Process to process the transactions.

Note: You cannot process individual lines or items. All transactions that are displayed are processed at the same
time.

Transactions that are processed successfully no longer appear in the window. Transactions that are not processed
successfully are displayed on the Mobile Inventory report. To print the report, choose Print.

Process field invoices and payments

Invoices and payments that are generated from MobileTech are processed and posted in Microsoft Dynamics GP and
in Service Management using the same tasks and procedures for invoices that are created in Service Management.

If your organization uses Field Invoicing and Field Payments, when technicians create an invoice on a device after
they complete appointments for a service call, the technicians can preview and verify the information on their devices,
generate a field invoice, and then sync it to the host system. If they are authorized to do so, technicians can also
collect payment for the invoice.

Note: If a technician’s time card in TimeTrack has been committed by a back-office user (such as someone in the
Payroll department), and this occurred before the service call was completed and the field invoice was generated,
that labor expense will not be displayed on the field invoice.

The labor expense will be displayed if the time card has not been committed, or if it has been committed and the
expense transaction has been posted.

After invoices or payments are received in the host system, the invoice is attached to the service call. The
Receivables Management batch and the transactions are automatically created. This batch has a prefix of
FLDINVC<current system date> and can be posted just like any other batch.

Field invoicing is available only if Field Invoicing and Field Payments is registered, and UseFieldlnvoicing = True in
the setup options in MobileTech Administration. Field payments are available only if Field Invoicing and Field
Payments is registered, and if both UseFieldInvoicing and UseFieldPayments = True in the setup options.

Note: MobileTech is not integrated with a credit card vendor. If you want technicians to be able to accept credit card
payments from customers, you must set up credit card information for your company in the Credit Card Setup window
in Microsoft Dynamics GP (Microsoft Dynamics GP > Tools > Setup > Company > Credit Cards). For more
information, see the Microsoft Dynamics GP Help.

For information about how to create field invoices and collect payments on a device, see “Working with field invoices
and customer payments” in the MobileTech Help. For information about how to process invoices and payments in the
host system, see the Service Management documentation.
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Field invoice restrictions in Service Management
Field invoices created in MobileTech have the following restrictions in Service Management:

e Regardless of unposted costs setup options in Invoice Setup, if a field invoice is created in MobileTech, all
unposted costs associated with the MobileTech invoice must be posted before the invoice, or the batch
containing the invoice, can be posted.

e Field invoices cannot be:

e Deleted or voided.

e  Edited, including from the Receivables Management batch.

e Adjustments such as credit memos, amount changes that constitute adjusting entries, etc., must be made
manually using separate transactions.

e Costs associated with a field invoice:
e Cannot be deleted.

e Should not be edited. Regardless of a cost edit, billing amounts will not be updated.

Note: Editing costs associated with a field invoice may result in inaccurate accounting entries.

e The service call ID cannot be changed or removed from any unposted cost transaction that has an
associated field invoice number.
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Completing administrative tasks and
procedures

This section provides information about tasks and procedures that administrators might occasionally have to
complete in MobileTech Administration.

Refresh specific lookups

You can sync individual lookups in MobileTech to refresh a subset of lookups without loading all data.
1. In MobileTech Administration, choose Tools > Refresh Lookups.

2. Mark the check box next to the lookups that you want to refresh.

Note: When you mark a lookup, other associated lookups might be marked, as well, if there are
dependencies between the lookups. For example, if you mark the check box for a child lookup, the
parent lookup automatically is marked because that must be refreshed, too.

3. Choose Refresh.

Monitor processes and tasks by using Integration Monitor

MobileTech Integration Sync monitors changes in the middle-tier database that are made in Microsoft Dynamics GP.

When you installed the integration sync, you entered a task frequency. This is how frequently the integration sync
process runs to update changes that are made in Microsoft Dynamics GP.

To view changes that are waiting to go into the middle-tier database, in MobileTech Administration, choose
Integration Monitor.

View user device information and sync activity

You can use MobileTech Administration to view information about the devices that technicians are using, and the
sync activity on those devices.

1. In MobileTech Administration, choose Users.

2. Inthe Synced Devices area, you can see a list of synced devices. For each device, you can see which
version of MobileTech is installed, when it was last synced to the host system, the security policy for the
device, and the operating system that is installed on the device.

Using Report Maintenance

Use Report Maintenance to determine why a report has a status of FAILED in the middle-tier report table. Note that
the report also must have a related appointment in the middle-tier appointment table to display in this window. After
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fixing the error(s), you can choose Process to attempt to re-process the report. Time-out errors can be fixed by simply
processing the report again in this window.

Note: This is not a reprint feature.

To use Report Maintenance:
1. In MobileTech Admin, choose Report Maintenance.
2. Reports with a status of FAILED in the middle-tier display in the window.

3. Optional: The reports that display can be filtered by choosing a column name from the Column drop-down.
Enter a partial or whole word and then choose Search.

4. The scrolling window displays the following information:
e  Service Call ID/Job Number
e  Appointment
e Technician
e Customer
e Location
e Report Type
e Created On date/time

e  Error Message

Note: To view the entire error message, you may need to use the scroll bar at the bottom of
the window to scroll to the right. You may need to resize the column to view the entire
message.

5. Optional: Choose a column heading to sort the displayed information.

6. Review the error message. You may need to use the horizontal scroll bar and/or resize the column to view
the entire message.

e If the report has a time out error, continue with step 6.

e For all other errors, you must fix the error(s) and then return to this window.

7. Mark the report(s) to process, either individually or choose the check box to the left of the Service Call/Job
column to select all.

8. Choose Process.

If the report fails again, it will be displayed in the Report Maintenance window, otherwise the report will be
attached to the appropriate Signature window.
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Contact information

Support and sales

Support

Phone: 262-317-3800
Email: support@KEY2ACT.COM

Hours

Normal support hours are 7:00 a.m. to 6:00 p.m. Central Time. After-hours and weekend support is available for an
additional charge. Please contact KEY2ACT Support for additional information.

KEY2ACT will be closed in observance of the following holidays: New Year’s Day, Memorial Day, Independence Day,
Labor Day, Thanksgiving Day, Day after Thanksgiving, and Christmas Day.

Support Plans

We're committed to providing the service you need to solve your problems and help your team maximize productivity.

We offer several Signature Enhancement and Support Plans to meet your needs and Extended Support Plans for
retired product versions available at http://www.key2act.com/customer-portal/help.

Sales

Phone: 262-317-3700
Fax: 262-317-3701

KEY2ACT headquarters

Address:

KEY2ACT

1970 S. Calhoun Rd.

New Berlin, W1 53151-1187

Phone: 262-821-4100 or 866-KEY2ACT (866-539-
2228)

Website: www.KEY2ACT.COM

Email: info@KEY2ACT.COM

Office hours: Monday through Friday from 8 a.m. to 5 p.m. Central Time.
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