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Introduction
Signature MobileTech provides your field resources with the information they need to perform their job. MobileTech 
enables technicians who use Windows laptops, or Android and iOS mobile devices to view, capture and share work-
related information to and from Signature.

Technicians can receive appointments that are created in the Signature modules, together with appointment details 
such as estimated hours, description, location, and service call history. Technicians then can update appointments with 
expense and resolution details.

The information in this guide is intended for administrators and others in your organization who install and set up 
MobileTech. It also provides information about processing entries and activities in Microsoft Dynamics GP and the 
Signature modules that are entered and synchronized, or synced, by field technicians.

For information for technicians, see the Help in MobileTech Client.

Compatible Operating Systems
Refer MobileTech Readme or to the operating systems document found with the MobileTech guidelines on the Product 
Download page on Signature Resources (https://www.wennsoft.com/wsportal/product-downloads) for a list of 
supported operating systems. We recommend that you perform the appropriate testing prior to any major purchasing 
decisions, including the procurement of devices.

WennSoft offers compatibility testing if you are interested in making sure that your device and operating system are 
compatible with MobileTech. Contact WennSoft Support to obtain this service.

Prerequisite Applications
If you do not already have these .NET applications installed on your computer, they will be installed when you install 
MobileTech.

Application Version

MobileTech Sync Server .NET 4.5.2 Full Framework

MobileTech Administration .NET 4.5.2 Full Framework

MobileTech Client .NET 4.5.2 Client Framework

Any references to MobileTech assume that you are installing or have installed the latest version of the 
components that are available for MobileTech.



https://www.wennsoft.com/wsportal/product-downloads
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Other System Requirements
This section outlines basic system requirements for MobileTech 8.0, although the specific system requirements for your 
installation depend on which versions of Signature and Microsoft Dynamics GP you are using. The system requirements 
for your version of Signature and Microsoft Dynamics GP also apply to MobileTech. 

To find a complete list of system requirements across all the Signature modules, refer to the System Requirements12.

This table lists the tested and supported compatible versions for MobileTech 8.0 SP 2.

Software or device Compatible versions

Operating systems  Android 8.0 (Oreo), 9.0 (Pie), 10.0, 11.0*
iOS 12, 13, 14, 15
Windows 10

Signature version number Signature 18.03b05
Signature 2018 R4 18.00b04g421
Signature 2018 R3 18.00b03g310
Signature 2016 R3 SP 2 16.00b03g321

Obtain a Google Maps API Key
If you will be using the Mapping feature on a Windows computer, you will need to obtain a Google Maps API key at 
https://cloud.google.com/maps-platform/pricing/. (Select Dynamic Maps and then select Maps JavaScript API.)

Other Resources
For more information about MobileTech and related applications, see these resources.

Signature MobileTech 8.0 Readme3

Describes the features and resolved issues in MobileTech and lists compatible software versions.
Signature Service Management and Signature Equipment Management guides
Describe how to set up and use Service Management and Equipment Management, and how to process 
information that is sent from MobileTech to the host system.
Signature Reports guide: Describes how to deploy reports for both Service Management and MobileTech.
Resco Mobile CRM Woodford User Guide: Includes information about how to use Woodford to customize your 
application.

IMPORTANT

*For Android 11 users only: The MobileTech 
Sync Server needs to be on an "https" 
server.



https://wennsoft.atlassian.net/wiki/spaces/1803b05/pages/7700556/System+Requirements
https://wennsoft.atlassian.net/wiki/spaces/1803b05/pages/7700556/System+Requirements
https://wennsoft.atlassian.net/wiki/spaces/MT80/pages/6620015/MobileTech+8.0+Readme
https://wennsoft.atlassian.net/wiki/spaces/1803b05/pages/7700556/System+Requirements
https://cloud.google.com/maps-platform/pricing/
https://wennsoft.atlassian.net/wiki/spaces/MT80/pages/6620015/MobileTech+8.0+Readme


Introduction

3

Control Definitions
The chart below displays the control source for each entity item per MobileTech version. The cells are highlighted in 
green to identify there is a control change from the previous version.

MobileTech 7.0 MobileTech 7.5 MobileTech 8.0

Entity Name Item 100%
Resco

100%
HTML

Both 100%
Resco

100%
HTML

Both 100%
Resco

100%
HTML

Both

Additional 
Work

Form X X X

List X X X

Appointment Form X X X

List X X X

Appointment 
Completion

Resolution X X X

Summary X X X

Appointment 
Status

List X X X

Attachment Form X X X

List X X X

Call 
Resolution

Form X X X

List X X X

Call Type Form X X X

List X X X

Change Order Form X X X
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MobileTech 7.0 MobileTech 7.5 MobileTech 8.0

List X X X

Change Order 
Detail

Form X X X

List X X X

Consumed 
Inventory

Form X X X

List X X X

Contract Form X X X

Contract 
Equipment

List X X X

Cost Code List X X X

Customer Form X X X

List X X X

Employee Form X X X

List X X X

Equipment Form X X X

List X X X

Extended 
Warranty 
Type

List X X X

Invoice List X X X

Job Cost 
Code

List X X X
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MobileTech 7.0 MobileTech 7.5 MobileTech 8.0

Job Safety 
Task

Form X X X

List X X X

Labor 
Expense

Form X X X

List X X1 X X

Location Form X X X

List X X X

Location 
Contact

Form X X X

List X X X

Manufacturer Form X X X

List X X X

Meter 
Reading

Form X X X

List X X X

Note Form X X X

List X X X

Pay Code List X X X

Payment Form X X X

Summary X X X

Purchase 
Order Detail

Form X X X

List X X X
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MobileTech 7.0 MobileTech 7.5 MobileTech 8.0

Purchase 
Order Receipt

Form X X X

List X X X

Purchase 
Order Receipt 
Detail

Form X X X2

List X X X2

Problem Type List X X X

Refrigerant 
Code

List X X X

Refrigerant 
Leak 
Sublocation

List X X X

Refrigerant 
Tracking

Form X X X

List X X X

Refrigerant 
Type

List X X X

Report List X X X

Resolution 
Snippet

List X X X

Service Call 
(New)

Form X X X

Service Call Form X X X

List X X X

Service Call 
History

Form X X X3

List X X X3



Introduction

7

1.

2.

MobileTech 7.0 MobileTech 7.5 MobileTech 8.0

Site Inventory List X X X

Sublocation List X X X

Sub Task Form X X X4

List X X X 4

Task Form X X X 4

List X X X 4

Task Material List X X X 4

Task 
Response

List X X X 4

Task 
Response List 
Value

List X X X 4

Timelog Form X X X

Timesheet 
Report 
Request

Signature X X X

User Define 1 List X X X

User Define 2 List X X X

Work Crew List X X X

Work Crew 
Employee

List X X X

The Labor Expense list on the home screen was updated to 100% HTML, whereas the list on the Appointment 
Completion form remains 100% Resco. 
The Purchase Order Receipt Detail form and list were combined into one form. For a visual example, see PO 
Receipt Changes (page 11).
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3.

4.

The Service Call History form and list were combined into one form. For a visual example, see Call History 
Changes (page 12).
All Task items were combined into one form. For a visual example, see Task Changes (page 13). 
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Training Resources
For Resco training information, see the following Resco resources:

Javascript Bridge Reference4

Resco Academy5

Resco Developers YouTube Channel6

Common Offline HTML File Layout

1 Initial Settings

2 Create Items (toolbars, forms lists, etc) *if 100% offline html

3 Event Handlers

4 Load Options

5 Load Data

6 Toolbar Functions

7 Form or List Item Function 

8 Form or List Executions

https://www.resco.net/javascript-bridge-reference/
https://www.resco.net/academy/
https://www.youtube.com/user/RescoDevelopers
https://www.resco.net/javascript-bridge-reference/
https://www.resco.net/academy/
https://www.youtube.com/user/RescoDevelopers
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PO Receipt Changes
The Purchase Order Receipt Detail form and list were combined into one form. 

MobileTech 7.5

MobileTech 8.0 (and later)
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Call History Changes
The Service Call History form and list were combined into one form. 

MobileTech 7.5

MobileTech 8.0 (and later)
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Task Changes
All Tasks items were combined into one form. 

MobileTech 7.5

MobileTech 8.0 (and later)

Installing or Upgrading MobileTech
Use these instructions when installing or upgrading MobileTech. For system requirements information, see the Other 
System Requirements (page 2).

After you installing the MobileTech components, you will need to set up MobileTech Administration including 
application options and set up and grant access to users.
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You will then install MobileTech Client on the various devices that are used by technicians.

See also:

Install MobileTech Server (page 14)
Upgrade MobileTech Server (page 16)
Install the MobileTech Client (page 19)
Install eTimeTrack Web Service (page 20)
Install the Quadra Field Quoting Integration (optional) (page 20)

Install MobileTech Server
If you are upgrading MobileTech, see Upgrade MobileTech Server (page 16). 

Step 1: Install MobileTech Server (page 14)
Step 2: Install MobileTech Client (page 16)
Step 3: Install eTimeTrack Web Service (page 16)
Step 4: Set up MobileTech Admin (page 16)
Step 5: Import the MobileTech project (page 16)
Step 6: Complete additional setup (page 16)
Step 7: Deploy SSRS Reports (page 16)

Step 1: Install MobileTech Server
You can install MobileTech Server on any Microsoft Windows Server environment. See the Signature System 
Requirements for specific versions. The person who installs the application must be an administrator who has 
permission to use the server "sa" password. 

MobileTech Server installs the following:

MobileTech Admin 
MobileTech is configured by using MobileTech Administration. This application lets you set up users and 
customize setup options per your organization's business rules and procedures.
MobileTech Integration Sync 
MobileTech Integration Sync applies the settings you enter to the automated sync process. The integration sync 
process automatically updates the middle-tier database with changes that are made in Signature and Microsoft 
Dynamics GP. You can change the frequency of the updates later. For more information, see Monitor Processes 
and Tasks by Using Integration Monitor (page 83). An icon for MobileTech Integration Sync is added to your 
desktop. You can choose the icon at any time after you set up MobileTech if you want to manually run the sync 
process.
Resco Cloud 
Resco Cloud a cross-platform mobile solution with  advanced configuration capabilities . Resco Cloud includes 
the Offline HTML version of Woodford, which is a tool that lets you customize and configure MobileTech for your 
business purposes. You will need to  importing the MobileTech Woodford project (page 52) . We refer to this as 
Woodford in the rest of our documentation.

Before upgrading MobileTech, we recommend that you make a backup copy of the web.config, 
MobileTechAdmin.exe.config, and XrmServer.SyncConsole.exe.config files if you have made changes to 
these files. After upgrading you can reinsert your changes.


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17.
18.
19.

20.

To install the MobileTech Server:

Right-click on the Signature MobileTech Server x-x-xx.exe file.
Click Run as administrator.
If the User Account Control window displays, select Yes to continue with the installation.
The Welcome to the Prerequisites Setup Wizard displays if any prerequisite files need to be installed or updated. 
Mark the checkbox next to the required file(s) to be installed and select Next. The external setup window for each 
file opens. You may need to move the MobileTech Server Setup window to see the other setup windows. 
Complete the file installation(s). After you have installed the prerequisite files, return to the MobileTech Server 
Setup window and select Next.
In the Welcome window, click Next.
On the End-User License Agreement page, read and accept the terms of the license agreement and choose Next. 
On the SQL Server Settings window, enter the following information:

Dynamics GP System Database 
Enter the name of the database where Microsoft Dynamics GP is stored. Dynamics defaults into this field 
but you can change this if your database name is different.
SQL Server 
Enter the SQL Server name and instance where the Microsoft Dynamics GP database is installed.
SA Password 
Enter the SQL system administrator password.

Select Next. The ODBC runs a connection test.
On the MobileTech User Details window:

MobileTech User
Displays mobiletech, which you cannot change.
Password
If a SQL Server account exists for the mobiletech user, enter the mobiletech account password so it can be 
validated. If a SQL Server account does not exist, you are prompted to confirm the password.

Select Next.
On the Sync Server Details and Registration Web Service Details window, enter the Sync Server Details:

Sync Server URL
Enter the Sync Server URL address.  http://servername:8888
MobileTech Admin User (Email)
This is the email address that you will use to log into Woodford.

Mark the checkbox if the Signature Registration web service is installed on a secure website (https:// instead of 
http://). This allows the registration web service to be consumed over Secure Sockets Layer (SSL).
Click Next.
On the Email and Scheduled Task Details window, enter the following:

Error Report Email Address
Enter the email address where error reports are sent.
Scheduled Task  Frequency 
Enter a number, in minutes, to indicate how frequently the integration sync process updates the middle-
tier database with changes that were made in Microsoft Dynamics GP. This defaults to 15 minutes.

Select Next.
On the Select Installation Folder window,  select Browse to choose the location where MobileTech Server will be 
installed, or accept the default location C:\Program Files (x86)\Signature\MobileTech\.
Select Next.
On the Installing Signature MobileTech Server page, select Install.
The Administrator: Windows PowerShell command window opens to run a Resco script.

Press any key to close the command window.

This script may take approximately 5 minutes to run. When everything is done installing, you will see 
"Press any key to continue..." as the final line.


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21. On the Signature MobileTech Server Setup window select Finish.

Step 2: Install MobileTech Client
To install the MobileTech Client on a computer, see Install the MobileTech Client (page 19).

Step 3: Install eTimeTrack Web Service
To install eTimeTrack Web Service, see Install eTimeTrack Web Service (page 20).

Step 4: Set up MobileTech Admin
After completing the installation steps, you will need to review the Setting up MobileTech (page 21) section. You then set 
up MobileTech and install MobileTech Client on client devices from their respective app store. You must do this for each 
company. If you are not prompted to install database objects, go to Tools > Create MobileTech Objects and 
choose Process.

See Set up MobileTech Administration (page 24).

Step 5: Import the MobileTech project
See Import the MobileTech Woodford Project (page 52).

Step 6: Complete additional setup
Review the Setting up MobileTech (page 21) section. 

Step 7: Deploy SSRS Reports
See the Signature Reports Guide for information on deploying a report.

Upgrade MobileTech Server
Regardless of which version you are upgrading from, be sure to install the components for the most recent 
version. After you install MobileTech Server, you must set up application options and set up and grant access to users 
by using MobileTech Administration. You will then install MobileTech Client on the various devices that are used by 
technicians.

Upgrading MobileTech involves making a backup config files (optional), uninstalling your current MobileTech, and then 
installing the latest version of MobileTech Server and Client. 

After the upgrade is complete, you can use MobileTech Administration to select application options and set up and 
grant access to users.

In MobileTech, there is one middle-tier database for each Microsoft Dynamics GP company. The naming 
convention for the database name is companyname_RESCOXRM. The configuration database is called 
RESCOXRM_CONFIG.


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Step 1: Making backups of .config files (page 17)
Step 2: Uninstall your current MobileTech installations (page 17)
Step 3: Install MobileTech Server (page 17)
Step 4: Install MobileTech Client (page 19)
Step 5: Set up MobileTech Admin (page 19)
Step 6: Import the MobileTech Woodford project (page 19)
Step 7: Deploy Any Updated SSRS Reports (page 19)

Step 1: Making backups of .config files
Before upgrading MobileTech, we recommend that you make a backup copy of the 
web.config, MobileTechAdmin.exe.config, and XrmServer.SyncConsole.exe.config files if you have made changes 
to these files. After upgrading you can reinsert your changes.

Step 2: Uninstall your current MobileTech installations
Prior to upgrading to MobileTech 7.5, you will need to uninstall MobileTech from your Windows server/workstations:

Signature MobileTech Integration Sync
Signature MobileTech Sync Server
Signature MobileTech Admin
Signature MobileTech Client

Step 3: Install MobileTech Server
You can install MobileTech Server on any Microsoft Windows Server environment. See the Signature System 
Requirements for specific versions. The person who installs the application must be an administrator who has 
permission to use the server "sa" password. 

MobileTech Server installs the following:

MobileTech Admin 
MobileTech is configured by using MobileTech Administration. This application lets you set up users and 
customize setup options per your organization's business rules and procedures.
MobileTech Integration Sync 
MobileTech Integration Sync applies the settings you enter to the automated sync process. The integration sync 
process automatically updates the middle-tier database with changes that are made in Signature and Microsoft 
Dynamics GP. You can change the frequency of the updates later. For more information, see Monitor Processes 

Important upgrade information
Do not install a version of Woodford that is newer than 12.X.
Do not install a newer version of Woodford until you are instructed to do so by WennSoft. Woodford is a third-
party product and you must use a version of Woodford that is compatible with the version of MobileTech you 
are using.
When you launch Woodford, if the "New update is available" message displays, choose Later.
After you install and activate Woodford, we recommend that you set up Woodford so you are not prompted to 
install a newer version when it is released by Resco. In Woodford, choose Settings and unmark the Check for 
updates on startup checkbox.
Review the steps below carefully before you install the latest compatible version of Woodford.


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and Tasks by Using Integration Monitor (page 83). An icon for MobileTech Integration Sync is added to your 
desktop. You can choose the icon at any time after you set up MobileTech if you want to manually run the sync 
process.
Resco Cloud 
Resco Cloud a cross-platform mobile solution with  advanced configuration capabilities . Resco Cloud includes 
the Offline HTML version of Woodford, which is a tool that lets you customize and configure MobileTech for your 
business purposes. You will need to  importing the MobileTech Woodford project (page 52) . We refer to this as 
Woodford in the rest of our documentation.

To install the MobileTech Server:

Right-click on the Signature MobileTech Server x-x-xx.exe file.
Click Run as administrator.
If the User Account Control window displays, select Yes to continue with the installation.
The Welcome to the Prerequisites Setup Wizard displays if any prerequisite files need to be installed or updated. 
Mark the checkbox next to the required file(s) to be installed and select Next. The external setup window for each 
file opens. You may need to move the MobileTech Server Setup window to see the other setup windows. 
Complete the file installation(s). After you have installed the prerequisite files, return to the MobileTech Server 
Setup window and select Next.
In the Welcome window, click Next.
On the End-User License Agreement page, read and accept the terms of the license agreement and choose Next. 
On the SQL Server Settings window, enter the following information:

Dynamics GP System Database 
Enter the name of the database where Microsoft Dynamics GP is stored. Dynamics defaults into this field 
but you can change this if your database name is different.
SQL Server 
Enter the SQL Server name and instance where the Microsoft Dynamics GP database is installed.
SA Password 
Enter the SQL system administrator password.

Select Next. The ODBC runs a connection test.
On the MobileTech User Details window:

MobileTech User
Displays mobiletech, which you cannot change.
Password
If a SQL Server account exists for the mobiletech user, enter the mobiletech account password so it can be 
validated. If a SQL Server account does not exist, you are prompted to confirm the password.

Select Next.
On the Sync Server Details and Registration Web Service Details window, enter the Sync Server Details:

Sync Server URL
Enter the Sync Server URL address.  http://servername:8888
MobileTech Admin User (Email)
This is the email address that you will use to log into Woodford.

Mark the checkbox if the Signature Registration web service is installed on a secure website (https:// instead of 
http://). This allows the registration web service to be consumed over Secure Sockets Layer (SSL).
Click Next.
On the Email and Scheduled Task Details window, enter the following:

Error Report Email Address
Enter the email address where error reports are sent.
Scheduled Task  Frequency 
Enter a number, in minutes, to indicate how frequently the integration sync process updates the middle-
tier database with changes that were made in Microsoft Dynamics GP. This defaults to 15 minutes.

Select Next.
On the Select Installation Folder window,  select Browse to choose the location where MobileTech Server will be 
installed, or accept the default location C:\Program Files (x86)\Signature\MobileTech\.
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Select Next.
On the Installing Signature MobileTech Server page, select Install.
The Administrator: Windows PowerShell command window opens to run a Resco script.

Press any key to close the command window.
On the Signature MobileTech Server Setup window select Finish.

Step 4: Install MobileTech Client
To install the MobileTech Client on a computer, see Install the MobileTech Client (page 19).

Step 5: Set up MobileTech Admin
After completing the installation steps, you will need to review the Setting up MobileTech (page 21) section. You then set 
up MobileTech and install MobileTech Client on client devices from their respective app store.

The first time you log into MobileTech Admin after upgrading, you will be prompted to upgrade the Resco middle-tier 
databases. After this has completed, you will be prompted to install database objects. You must do this for each 
company. If you are not prompted to install database objects, go to Tools > Create MobileTech Objects and 
choose Process.

See Set up MobileTech Administration (page 24).

Step 6: Import the MobileTech Woodford project
See Import the MobileTech Woodford Project (page 52).

Step 7: Deploy Any Updated SSRS Reports
If the MobileTech Readme indicates any SSRS Reports have been updated, you will need to deploy these reports. See 
the Signature Reports Guide for information on deploying a report.

Install the MobileTech Client
After installing and setting up MobileTech Admin, you will want to test your settings in the Mobile CRM app (MobileTech 
Client). If you will be installing the Mobile CRM app to a Windows Server, you will need to download and install the 
Resco Mobile CRM Windows (desktop)7 Client from the Resco Downloads web page. For all other operating systems, you 
can download from the following app stores: Apple App Store, Google Play, and Windows Store.

To download the Mobile CRM app to a Windows Server:

This script may take approximately 5 minutes to run. When everything is done installing, you will see 
"Press any key to continue..." as the final line.



In MobileTech, there is one middle-tier database for each Microsoft Dynamics GP company. The naming 
convention for the database name is companyname_RESCOXRM. The configuration database is called 
RESCOXRM_CONFIG.



https://www.resco.net/downloads/MobileCRM-Tablet.msi
https://www.resco.net/downloads/MobileCRM-Tablet.msi
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Go to https://www.resco.net/support/downloads/.
Download the Windows (desktop)8 Mobile CRM app.
Double-click the MobileCRM-Tablet.msi file.
Complete the setup wizard.

Install eTimeTrack Web Service
The eTimeTrack Web Service application is included with the installation package for MobileTech.

Double-click eTimeTrackWebServiceSetup.exe.
On the Welcome to the Signature eTimeTrack Web Service Setup Wizard page, choose Next.
On the End-User License Agreement page, read and accept the terms of the license agreement, and then choose 
Next. The Select Installation Folder page is displayed.
Accept the default installation location, or choose Browse to select the location where the eTimeTrack Web 
Service should be installed.
Choose Next. The SQL Database page is displayed.
Enter the SQL server and instance for the eTimeTrack Web Service (server name\instance). 

Enter a password for the user and choose Next. The Web Service User Configuration page is displayed. 

Enter a password for the user.
In the Database field, enter the database name for your company. If you are installing MobileTech on multiple 
databases, enter each database name, separated by commas.
Choose Next. The Ready to Install page is displayed.
Choose Install. The status bar shows the progress of the Signature eTimeTrack Web Service Setup Wizard.
When the installation is complete, the Completing the Signature eTimeTrack Web Service Setup Wizard page is 
displayed. Choose Finish.
Continue with the information in Setting up MobileTech (page 21).

Install the Quadra Field Quoting Integration (optional)
The MobileTech/Quadra integration allows field technicians to generate Quadra recommendations directly from the 
MobileTech appointment completion process.  Technicians can then view that recommendation from within ERTH’s 
Quadra mobile application and turn that into field quotes and future service call work in Signature/MobileTech. For 
more information about Quadra Field Quoting application, see https://www.erthcorp.com/quadra-field-quoting-new/.

Use the steps below to install the Quadra Field Quoting integration with MobileTech. 

In the current release, extended pricing is not supported for expense and travel transactions through Time 
Entry.



The default user name is displayed and you cannot change it.

The default user name is displayed and you cannot change it.

https://www.resco.net/downloads/MobileCRM-Tablet.msi
https://www.resco.net/support/downloads/
https://www.resco.net/downloads/MobileCRM-Tablet.msi
https://www.erthcorp.com/quadra-field-quoting-new/
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Running the configuration script
Locate the Create Quadra Objects.sql file found at C:\Program Files 
(x86)\Signature\MobileTech\Admin\Scripts\Integrations.
Open Microsoft SQL Server Management Studio (SSMS).
In Microsoft SSMS, open the Create Quadra Options.sql script file and complete the following steps:

Replace the {company-db} text with your company database name such as TWO. e.g. USE [{company-
db}] --> USE [TWO].
Replace the {orgname} text (3 occurrences) with the actual company database name. e.g. {orgname}
_RESCOXRM --> two_RESCOXRM.
Replace the {quadra-db} text (2 occurrences) with the actual Quadra database name. e.g. {quadra-
db}..mfq_recommendationTemplates --> QUADRA..mfq_recommendationTemplates.
Set the @QuadraAPIKey variable that was issued by ERTH.

Execute the Create Quadra Options.sql script.

Setting up MobileTech
MobileTech is configured by using MobileTech Administration. This application lets you set up users and customize 
setup options per your organization's business rules and procedures.

You need to set up MobileTech for each company by completing the procedures that follow.

If you previously installed an earlier version of MobileTech and you are now installing MobileTech 8.0, you will be 
prompted to update the middle-tier database, and you must run the Create Database Objects tool for each company 
immediately after you install MobileTech Administration. To manually create database objects, In MobileTech 
Administration, go to Tools > Create MobileTech Objects, and then choose Process.

Set up Distributed Transaction Coordinator (DTC) (page 21)
Set up Password Complexity and Lockout Policy (page 22)
Increase the Maximum Size of the MobileTech Event Log (optional) (page 24)
Set up MobileTech Administration (page 24)
Import the MobileTech Woodford Project (page 52)
Set up Woodford (page 54)
Set up MobileTech on a Client Device (page 59)
Set up Information in Microsoft Dynamics GP (page 66)
XOi Deep Linking Setup (page 74)

Set up Distributed Transaction Coordinator (DTC)
Use the Local DTC Properties window to set up the properties for Microsoft Distributed Transaction Coordinator (DTC) 
on these computers:

The server where SQL Server is running for MobileTech.
The computer where MobileTech Server is installed.

Any reference to MobileTech assumes that you are installing or have installed the latest version of the 
components that are available for MobileTech.


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This helps make sure that transactions between the host computer and client devices are successfully completed and 
synced.

From the Start menu, choose Administrative Tools > Component Services. The Component Services window is 
displayed.
Double-click the Computers folder, double-click My Computer, and then double-click Distributed Transaction 
Coordinator.
Right-click Local DTC and choose Properties. The Local DTC Properties window is displayed. 
Choose the Security tab.
Under Security Settings, mark:

Network DTC Access
Allow Remote Clients
Allow Remote Administration

Under Transaction Manager Communication, mark:
Allow Inbound
Allow Outbound
No Authentication Required

The DTC logon account is displayed in the Account field. Accept the default account location, or choose Browse
to select a different location. For more information about the options in this window, choose the Learn more 
about setting these properties link at the bottom of the window.
Choose OK.
In the Component Services window, in the left pane, choose Services.
In the Services list, double-click Distributed Transaction Coordinator. The Distributed Transaction Coordinator 
Properties (Local Computer) window is displayed.
On the General tab, verify that the Startup type field is set to Automatic or Automatic (Delayed Start).
Choose OK.

Set up Password Complexity and Lockout Policy
Setting up password complexity (page 22)
Setting up the password lockout policy (page 23)

Setting up password complexity
You can set up minimum complexity requirements for MobileTech passwords, such as requiring digits, upper case 
letters, special characters, and password length in the C:\Program Files 
(x86)\Signature\MobileTech\RescoCloud\Web.config and C:\Program Files 
(x86)\Signature\MobileTech\Admin\MobileTechAdmin.exe.config files using a regex (regular expression) check. 

<add key="PasswordPolicyStrengthRegex" value="" />

Example:

The settings in the sample below are explained. You are not limited to these settings.

IMPORTANT: Inbound DTC must be enabled in the Windows Firewall (and not blocked by any other internal 
firewall appliances) on both the server where SQL Server is running for MobileTech and the computer where 
MobileTech Server is installed.



User password strength regex check (empty allows any password). This value defaults empty.
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add key="PasswordPolicyStrengthRegex" value="^(?=.[0-9])(?=.[A-Z])(?=.[!@#$&]).

{8,}$"

(?=.[0-9]){*} Indicates at least one digit.

(?=.[A-Z])* Indicates at least one upper case letter.

(?=.[!@#$&]) Indicates at least one special character.

{8,} Indicates a minimum of 8 characters in length

Setting up the password lockout policy
Set up your password lockout policy to indicate a lockout mode (Lockout or Disable), after x failed login attempts, as 
well as how many minutes a user's account is locked. These setup options are in the Web.config file. The Password 
Policy Lockout Attempts setting will also need to be set in the MobileTechAdmin.exe.config file.

Password Policy Lockout Mode
This setting has two possible values – Lockout and Disable. This setting works in conjunction with the 
PasswordLockoutAttempts setting. The default value is Lockout.
<add key="PasswordPolicyLockoutMode" value="Lockout" />

Lockout
When the setting is set to Lockout and the Lockout Attempts value is hit, the account will be locked out 
until the PasswordLockoutDuration value has been reached. This value is in minutes. The system 
administrator can unlock the user in the user profile.
Disabled
When the setting is set to Disable and the Lockout Attempts value is hit, the system administrator will 
need to enable the user in the user profile.

Password Policy Lockout Attempts
Sets the number of invalid logon attempts that are allowed before an account is locked out. The default value is 
3. 
<add key="PasswordPolicyLockoutAttempts" value="3" />

Password Policy Lockout Duration - Sets the length of time (minutes) the account is locked. The default value 
is 10 minutes. This setting is used in conjunction with the Lockout mode.
<add key="PasswordPolicyLockoutDuration" value="10" />

If you choose to not set up a password lockout policy, set PasswordPolicyLockoutAttempts to either 0 or "" 
as this allows an infinite number of invalid login attempts.



The Password Lockout Attempts setting needs to be set up in both the Web.config and 
MobileTechAdmin.exe.config files.


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Increase the Maximum Size of the MobileTech Event Log (optional)
When transaction information is transmitted between devices and the host system, any events that occur are recorded 
in the MobileTech event log in Windows Event Viewer. This log can fill up quickly, so you might want to increase the 
maximum size of the event log so you do not lose log history.

The default maximum size of the event log is 4,096 KB. Depending on the amount of history you want to keep, you might 
want to double (8,192 KB), triple (12,288 KB), or quadruple (16,384 KB) the maximum size of the event log.

Choose Start > Administrative Tools > Event Viewer. The Event Viewer window is displayed.
In the navigation pane, expand Applications and Services Logs.
Right-click the MobileTech log and choose Properties. The Log Properties – MobileTech window is displayed.
In the Maximum log size (KB) field, enter a new maximum file size, such as 8192, 12288, or 16384.
Choose OK.

Set up MobileTech Administration
The user who logs on to MobileTech Administration must be a member of the DYNGRP SQL Server role for each 
company database and for the DYNAMICS (your database may have a different name) database. To install database 
objects or create the middle-tier database, you must log on with the SQL Server "sa" account.

When you create a middle-tier database in MobileTech, a daily cleanup job is automatically set up for the database. For 
more information about this job or how to specify when it runs, see Create a cleanup job for the middle-tier 
database (page 26). 

Continue setting up MobileTech with the following steps:

Menu Navigation Overview (page 24)
Launching MobileTech Admin (page 25)
Create a cleanup job for the middle-tier database (page 26)
Set Up MobileTech Options (page 27)
Set up Additional Options (page 45)
Set Up New Users (page 49)
User Role Maintenance (page 51)
Switching Companies (page 52)
Set Up Additional Companies (page 52)

Menu Navigation Overview

File
Registered Products
Displays the registered MobileTech products and the user count.
Change Company (page 52)
Select to switch to another company.
About
Displays the current installed version of Signature and MobileTech Admin. You can also access online help and 
view the registered products.
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View
Users (page 49)
Select to set up new users and view/edit existing users.
Setup Options (page 27)
Select to choose settings that control how MobileTech is used.

Tools
Create MobileTech Options (page 27)
Any time you log on to MobileTech Administration and the version number of MobileTech Administration is 
higher than the last time you logged on for a company, the page to install database objects opens. You must 
install database objects for each company. If you are not prompted to install database objects, you can do so by 
going to Tools > Create MobileTech Objects.
Update Middle Tier
Select to update the Middle Tier. When updating MobileTech Admin, you are prompted to update the Resco 
middle tier, however you can also do so manually. 
Create Middle Tier Clean Up Job (page 26)
Occasionally, when a service call is created in the host system but completed on a mobile device, records that 
are related to that service call do not get removed from the middle-tier database when the service call is 
completed. To make sure these records are cleared out of the middle-tier database, you should set up the daily 
cleanup job.
Load Data (page 50)
You must load data into the organizational database for each technician you select. Any data that is associated 
with open calls and appointments for each technician, and for the specified date range, is included.
Refresh Lookups (page 83)
Select this option to sync individual lookups in MobileTech to refresh a subset of lookups without loading all 
data.
Change Resco Administrator Password (page 83)
If you or another administrator forgets an account password, you cannot retrieve the existing password, but you 
can change it.
Launch Resco Cloud Dashboard (page 82)
Select to launch the Resco Cloud Dashboard in your default browser.
Launch Woodford (page 24)
Select to launch Woodford in your default browser. See Set up Woodford (page 54) for more information.
Install Resco Mobile CRM Client (page 19)
Select to launch Resco's Mobile CRM Client download page in your default browser.

Launching MobileTech Admin
From the Start menu, open MobileTech Admin. 
On the MobileTech Administration Login page, enter information in these fields to connect to the MobileTech 
database.

Server Name
Enter the SQL Server name and instance where the Signature modules are installed. Example: 
server\instance.
Authentication
Choose the authentication mode. You must have a valid SQL Server logon set up.

Windows Authentication
Use your Windows user credentials to log on.
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SQL Server Authentication
Use your SQL Server credentials to log on.

Login
Enter the name for the system administrator (sa).
Password
Enter the password for the system administrator.

Choose Connect.
If multiple companies are installed, the MobileTech Administration Login page is displayed again. In 
the Company field, select a company and choose Connect. The active company is displayed at the bottom left of 
the MobileTech Administration page.
Enter the email address, password, and the other information for the administrator, and then choose Create/
Update.
The following options may need to be updated, which you will be prompted for:

Organization database
Resco middle-tier database(s)
Database objects

Choose Process. 
Continue setting up MobileTech.

Create a cleanup job for the middle-tier database
Occasionally, when a service call is created in the host system but completed on a mobile device, records that are 
related to that service call do not get removed from the middle-tier database when the service call is completed.

To make sure these records are cleared out of the middle-tier database, you should set up the daily cleanup job. This 
job looks in the middle-tier database for records related to service calls that were closed or completed more than 14 
days ago, and for task attachments that have no parent service call. Those records are removed from the middle-tier 
database during the next integration sync.

This job is automatically set up when you create a new middle-tier database in Signature MobileTech R7.0. However, if 
you are upgrading to Signature MobileTech R7.5 from a release prior to MobileTech R4.0 SP1, you need to manually 
create this cleanup job in MobileTech Administration. When you create the cleanup job, it is automatically set up to run 
every four hours each day. To change the frequency or specify the time, change the schedule for the SQL Server Agent 
job. For more information, see the Microsoft SQL Server documentation.

To create a cleanup job for the middle-tier database:

In MobileTech Administration, choose Tools > Create Middle Tier Database Clean Up Job. The Create Cleanup Job 
page is displayed. 

Choose Close after the cleanup job is created.

If you are not prompted to install database objects after you log on, choose Tools > Create 
MobileTech Objects. You must install database objects for each company. For more information, 
see Set Up MobileTech Options (page 27).



If more than 450 service calls are completed per day, we recommend that you work with WennSoft Support.

You must be a member of the SQL Server SysAdmin role to open this page.
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Set Up MobileTech Options
Any time you log on to MobileTech Administration and the version number of MobileTech Administration is higher than 
the last time you logged on for a company, the page to install database objects opens. You must install database 
objects for each company. Use this information to choose settings that control how MobileTech is used. Settings that 
are not available are read-only.

In MobileTech Administration, choose Setup Options.
On the Setup Options window, select a setting to view its description at the bottom of the page, or refer to the 
tables that follow for information about how to configure the settings for your organization. 

MobileTech Global Settings (page 27)
MobileTech Company-Specific Settings (page 28)
Report Settings (page 29)
Mobile Device Global Settings (page 30)
Time Log Settings (page 33)
Field Invoicing and Field Payment Settings (page 34)
Job Safety Tasks (page 35)
Equipment Settings (page 36)
Task Settings (page 37)
Purchase Order Settings (page 38)
Resolution Settings (page 39)
Labor Settings (page 40)
Travel Settings (page 41)
Expense Settings (page 41)
Inventory Settings (page 42)
Signature Settings (page 43)
XOi Integration (page 44)

MobileTech Global Settings

Setting Description

DataSource The SQL Server name and instance that was specified during logon. This value 
cannot be changed.

Username The user who logged on to MobileTech Administration to communicate with the 
SQL Server database. This value cannot be changed.

TimeTrackProxyUrl The URL of the default TimeTrack Web Service. This value is configured during 
setup and should not be changed unless the TimeTrack Web Service is moved to 
a new server.

LogVerbose Determines whether all possible events are logged to the event log. The default 
value is False.If True, all possible events are logged to the event log, and the 
event log fills much more quickly. You might want to set this to True only for 
troubleshooting purposes.
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Setting Description

LogSql Determines whether all T-SQL statements are logged to the event log. The 
default value is False.

MobileTech Company-Specific Settings

Setting Description

AdminEmailAddress The administrative email account where log files and error logs are sent. This 
email address was entered during the installation of MobileTech Server.

HistoryCount The number of historical equipment and service records to display on the client 
device when the technician requests service history. The default value is 3.

IncludeMCCWithHistory Determines whether maintenance computer-generated calls (MCC) are included 
when service and equipment history is requested. The default value is True.

CurrencyDecimalPlaces The number of decimal places that are used to process currency amounts on the 
device. This value comes from Microsoft Dynamics GP and cannot be changed.
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Report Settings

Setting Description

ReportEmailMode Determines how to handle automated emails of reports and other documents, 
such as invoices. Reports are always sent to the email account that is specified 
for a technician when the technician is added to MobileTech (MobileTech 
Administration > Users). 

Do not send report emails - The report is sent only to the specified 
email account for the technician. The technician can then decide 
whether to forward the report to others, and to whom. This is the 
default value and should be used if reports should never be sent 
directly to a customer or another third-party contact.
Signature Contact Management - Send an email to the technician, 
and to the contact or contact list that is set up in Contact 
Management and that is associated with the location of the service 
call.
GP Internet Addresses - Send an email to the technician who is set 
up in the Internet Information window in Microsoft Dynamics 
GP (Microsoft Dynamics GP > Tools > Setup > Company > Internet 
Information) and who is associated with the location of the service 
call. Only one contact is allowed for this value.
Selected or entered by technician - The technician can select one or 
more email addresses to send reports or other documents, such as 
invoices, to appropriate personnel in the organization. The 
technician can also enter email addresses for new contacts and 
customers to send documents to them. This value applies only to 
external reports and documents, such as field invoices and the Call 
Summary report.

ReportEmailSMTPServer The name of the machine where the email server resides.

ReportEmailSMTPServerPort The port that is used by the email server. The default port number is 25, but you 
can change it for your system.

ReportEmailSMTPEnableSSL Determines whether SSL is used by the email server. The default value is False.

Each technician's email address is also their logon account, and that is 
the email address that is used to send reports to the technician.



The Select or entered by technician option allows 
technicians the ability to add a contact on-the-fly.


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Setting Description

ReportExecutionUrl The URL for the Report Execution web service. This URL is used by the system to 
communicate with the SSRS report server to generate the Call Summary report. 

UseSMTPAuthentication Determines whether a user name and password are required for sending email. 
The default value is True.

SMTPUsername The user name that is used to send report email notifications. This is available – 
and required – if UseSMTPAuthentication = True.

SMTPPassword The password that is used to send report email notifications. This is available – 
and required – if UseSMTPAuthentication = True.

ReportPreviewMaxRetryAttem
pts

The number of times that the client attempts to retrieve the preview of a field 
invoice after it is requested. The default number of attempts is 30.This setting 
applies to field invoicing and is available only if Field Invoicing and Field 
Payments is registered, and UseFieldInvoicing = True in the Field Invoicing and 
Field Payments Settings area.

ReportPreviewRetryInterval The number of seconds between when the client tries to retrieve the preview of 
a field invoice until the maximum number of attempts has been met or the 
preview invoice is generated. The default number of seconds is 30.This setting 
applies to field invoicing and is available only if Field Invoicing and Field 
Payments is registered, and UseFieldInvoicing = True in the Field Invoicing and 
Field Payments Settings area.

Mobile Device Global Settings

Setting Description

AutoStatusUpdate The default status for appointments that are received by the device. The default 
value is blank, which means no status is assigned to the appointments. If a 
status is selected for both this setting and JobSafetyStartStatus in Job Safety 
Tasks (page 35), we recommend that you do not use the same status for both. 

To locate the URL, open Reporting Services Configuration Manager, 
and then open the Web Service URL section. Use the value from 
the URLs field, followed by /ReportExecution2005.asmx. Example: 
http://\{servername}/ReportServer/ReportExecution2005.asmx



AutoStatusUpdate and TimeLogStatusUpdate in Time Log 
Settings (page 33) cannot have the same value.


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Setting Description

DefaultWeekday The default week-ending day for time entries, which is based on the TimeTrack 
settings in the Microsoft Dynamics GP database. This value cannot be changed.

UseAdditionalWork Determines whether technicians can enter additional work on a service call. The 
default value is True. If False, technicians cannot enter new additional work in 
the Additional Work pane.

UseBarcoding Determines whether the organization uses barcoding functionality in 
MobileTech. If True, barcoding is used. If False, barcoding is not used. The 
default value is False.

UseServerMode Determines whether technicians can utilize SERVER MODE with all Offline HTML 
pages. Server Mode allows users to access customer, location, and equipment 
data via the Middle Tier database (utilizing mobile data). If False, users will only 
access customer data on their devices, not from the Middle Tier. The default 
value is True.

See Set the Fetch Limit (page 57) for information on setting the number 
of Customer Location (customers and locations) or Equipment records that the 
SERVER MODE fetches at a time in the New Service Call window in the 
MobileTech Client.

UseServiceCallUserDefine2 Indicates whether the Service Call User Defined 2 field is a validated lookup, 
based on the Service Management settings in Microsoft Dynamics GP. This value 
cannot be changed.

UseWorkCrewJobCost Determines whether technicians can enter billed labor, travel, and expense 
transactions for a Job Cost work crew that includes any Microsoft Dynamics GP 
user who has valid hourly or business expense type pay codes. The default value 
is True.

UseWorkCrewService Determines whether technicians can enter labor, travel, or expense transactions 
for service work crews or individual work crew members when a service 
appointment is completed. The default value is False.

UseTechnicianHelper Determines whether technicians can enter labor and expense transactions for 
another technician. The default value is False. If True, technicians also can 
change the technician on the transaction.

UseChangeOrder Determines whether technicians can enter and review change orders that affect 
job costs. The default value is True.

CustomerNotesReadOnly Determines whether technicians can edit customer notes. The default value 
is True.
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LocationNotesReadOnly Determines whether technicians can edit location notes. The default value 
is True.

EquipmentNotesReadOnly Determines whether technicians can edit equipment notes. The default value 
is True.

ServiceCallNotesReadOnly Determines whether technicians can edit service call notes. The default value 
is True.

AppointmentNotesReadOnly Determines whether technicians can edit appointment notes. The default value 
is True.

ContractNotesReadOnly Determines whether technicians can edit contract notes. The default value 
is True.

DefaultNewNotesAsInternal Determines whether the default setting for new notes that are created by 
technicians is Internal, which means the notes are not displayed on the Call 
Summary report. The default value is False. Technicians can change this setting 
per note when they create notes.

UseAppointmentNotesSumma
ry

Determines whether note links are displayed at the bottom of 
the Appointment pane when technicians view the details for a service call 
appointment. If True, the links are displayed, so technicians can easily view the 
notes from one location. The default value is False.

UseEventBasedSync Determines whether event-based syncing is used on all devices. If True, event-
based syncing is used to sync to the host system after a service call is created, an 
appointment is created or completed, a timesheet report is requested, or a 
payment has been applied to a field invoice. If False, event-based syncing is not 
used. The default value is True.If Sync Login is marked on the Setup page on the 
device, the Sync page will be displayed and the user must choose Sync. For 
more information, see "Event-based syncing" in the MobileTech Help.

UseMobileAuditBackgroundSy
nc

Used to control the ability to auto-upload mobileaudit records to the host. This 
is used with Woodford's Auditing feature to track technician GPS coordinates 
based on creating or updating specific entities such as Appointment, TimeLog, 
or TimeEntry.  The default value is False. See Enable Mobile Auditing (page 56) for 
setting up Woodford's Auditing feature.

OnSiteStatusUpdate Used when UseMobileAuditBackgroundSync=True to determine what status will 
be used to automatically send the technician's GPS coordinates to the host.  No 
synchronization is required, but an internet connection must be available. See 
Enable Mobile Auditing (page 56) for more information.
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Time Log Settings

Setting Description

UseTimeLog Determines whether technicians can clock in and out from the client device and 
have billable labor hours calculated automatically by the system. Unbillable 
hours for technicians also are calculated by the system. Users also can see which 
appointments they are timed in to, and the Time In and Time Out values are 
displayed in the Appointment Summary Preview and Job Summary Preview 
panes and on the Call Summary and Appointment Summary reports. The default 
value is False. If False, the next four settings are not available.

TimeLogLockTimeInTimeOut Determines whether the Time In and Time Out fields on the client device are 
locked. The default value is True.If True, hours go directly to appointment 
history. If False, technicians can manually adjust the time.You can change this 
value only if UseTimeLog = True.

TimeLogLockLaborTime Determines whether the Labor Time field on the client device is locked. The 
default value is True.If False, technicians can manually adjust the labor hours 
that are calculated based on their time in and time out.You can change this 
value only if UseTimeLog = True.

TimeLogAllowTimeOverlap Determines whether technicians can time in to multiple appointments at the 
same time. The default value is False, so time-in and time-out entries cannot 
overlap.You can change this value only if UseTimeLog = True. 

TimeLogRoundingInterval The interval (in minutes) that labor time is rounded to when technicians time in 
and out. The default value is 15, which means the technician's labor hours are 
rounded to the nearest 15 minutes. Enter a value of 1-60 minutes. You can 
change this value only if UseTimeLog = True.

TimeLogStatusUpdate Choose the appointment status to default for appointments when the 
technicians time in. If the status is manually updated in the appointment to the 
specified status, the technician will be automatically timed in. The default value 
is empty (disabled). 

If you are upgrading from an earlier version of MobileTech, this setting 
may have been set to True and could not be changed. If so, the setting 
remains set to True after the upgrade, but you can change the value.



If you enter 0, this may cause the calculations to not work as expected.

TimeLogStatusUpdate and AutoStatusUpdate in Mobile Device Global 
Settings (page 30)  cannot have the same value.


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Field Invoicing and Field Payment Settings
When you use field invoicing and field payments, you can invoice customers in the field as soon as an appointment is 
completed, and collect payment for those invoices right away. Invoices are calculated similarly to how they are 
calculated in Service Management. You can enable this feature by customer, so that some customers can be invoiced in 
the field and invoices for other customers are generated in the host system. When technicians select to complete an 
appointment, they can choose to preview the field invoice before the service call appointment is completed and the 
field invoice is created. During the service call appointment completion process, a field invoice is created and the 
technician can accept payment, depending on whether field payments are enabled. Both full and partial payments can 
be made.

This information applies when you use field invoicing and field payments:

Field invoicing can be used only with service invoicing. Sales Order Processing (SOP) invoicing is not supported.
Payment term discounts are not supported.
In the Tax Detail Maintenance window in Microsoft Dynamics GP, the Based On field for the tax detail must be 
set to Percent of Sale/Purchase. The other options are not supported with field invoicing. Also, the Round field 
must be set to Up to the Next Currency Decimal Digit.
You must use a tax schedule from the master tax schedule, which is tied to a customer's service location. You 
cannot use tax schedules for individual cost categories.
If you use SOP for inventory, the billing amount for items comes from the Item Price List Maintenance window. If 
you do not use SOP for inventory, the billing amount comes from the Service Management pricing matrix.
All payment types are accepted, including cash, check, and credit card. However, a customer can use each 
payment type only once per payment. For example, customers can pay using both a credit card and a check, but 
not two credit cards. This is consistent with how the On Account window works in Service Management.

These settings only apply if Field Invoicing and Field Payments is registered.

Setting Description

UseFieldInvoicing Determines whether the organization allows invoicing by technicians in the field. 
The default value is False.

If True, invoices are generated automatically when appointments for a service 
call are completed, if the customer is set up to receive field invoices.

If False, the remaining settings in this section are not available.

FieldInvoicingTaxMode Determines whether taxes for the organization are calculated for field invoices 
based on the tax schedule that is set up for a customer location, or if taxes are 
not calculated for field invoices. The default value is Do not tax.

Do not tax
Taxes are not calculated for field invoices. We recommend that 
you select this option if taxes are built into your pricing.
Calculate taxes using Dynamics tax information
Taxes are calculated based on the master tax schedule ID that is 
set up for the customer location. For more information, see the 
Help for the Customer Maintenance window in Microsoft 
Dynamics GP Receivables Management.
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Setting Description

UseFieldInvoicePreview Determines whether technicians can preview field invoices before they are 
generated. The default value is False.

If True and UseFieldInvoiceSignature = True. The technician is prompted to 
either use the Summary Signature or to capture a signature for the Field Invoice 
Report. 

If False and UseFieldInvoiceSignature = True, the Summary signature is used for 
the Field Invoice Report, without prompting the technician to obtain the invoice 
signature.

PreviewInvoiceNumber The invoice number to use when a preview invoice is generated.You can enter up 
to seven alphabetic, numeric, or special characters for the preview number. The 
invoice number is the same for all preview invoices that are generated on all 
mobile devices and is added as a prefix to the technician's name on the preview 
invoice. The default value is PREVIEW.

UseFieldInvoiceSignature Determines whether the customer signature that is collected when a service call 
appointment is completed should be printed on the field invoice. The default 
value is False.

If True, depending on the UseFieldInvoicePreview setting, the Field Invoice 
Report may use the Summary Signature or the technician may be prompted to 
collect a new signature for the Field Invoice Report. A customer signature 
captured from the Report tab is only attached to the Field Invoice Report. The 
signature validation for the Field Invoice Report uses the Signature Settings 
CustomerSignatureValidationLevel option in MobileTech Admin's Setup 
Options. See Signature Settings (page 43).

UseFieldPayments Determines whether technicians can collect payments in the field and then send 
payment transactions to Microsoft Dynamics GP. The default value is False.

Job Safety Tasks
These settings apply only to service appointments. For information about how to set up Job Safety Audit (JSA) 
information in the host system, see Set up job safety audit (JSA) information (page 70).

Setting Description

UseJobSafetyTasks Determines whether the JSA process is used. The default value is False. If False, 
the remaining settings in this section are not available. 

If you change this setting to True, the JSA process is used only for 
appointments that are created or edited in Service Management – and 
then synced – after the setting is changed. Other existing appointments 
are not impacted.


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Setting Description

JobSafetyTaskListType The JSA task list type. This value is required to use JSA and to make JSA tasks 
available to technicians.

JobSafetyStartStatus The appointment status that is used to start the JSA process. When a technician 
selects this appointment status, the Job Safety tab opens automatically so the 
technician can complete JSA tasks.If a status is selected for both this setting 
and AutoStatusUpdate in the Mobile Device Global Settings section, we 
recommend that you do not use the same status for both.

JobSafetyUnsafeStatus The appointment status that is used to indicate that work conditions are 
unsafe.You might want to create a status specifically for this purpose, such as 
UNSAFE. You can create this status in the Appointment Status Setup window in 
Service Management.

JobSafetyValidationLevel The level of requirement for completing the Job Safety Task report before 
starting work on appointment tasks. The default value is REQUIRED.

REQUIRED - The report must be completed to complete an 
appointment.
OPTIONAL - The report does not have to be completed to 
complete an appointment.

Equipment Settings

Setting Description

AllowModifyEquipmentRecord Determines whether technicians can change an equipment record from the 
client device. The default value is True.

AllowModifyNewEquipmentId Determines whether technicians can enter the equipment ID when they create 
an equipment record. The default value is False. If False, the equipment ID is 
system generated.

UseRefrigerantTracking Determines whether the Refrigerant Tracking tab is available when viewing 
equipment on a service call. The default value is False. If Refrigerant Tracking is 
not registered, this value cannot be changed.

This setting does not prevent technicians from creating new equipment 
records.


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Setting Description

AssignedEquipmentValidation
Level

The level of requirement for equipment to be assigned during the appointment 
completion process. The default value is Optional.

OPTIONAL – Appointments can be completed regardless if equipment 
has been assigned or not.
WARNING – A warning is displayed if equipment has not been assigned to 
the appointment.
REQUIRED – An appointment cannot be completed until equipment has 
been assigned.

Task Settings

Setting Description

DefaultTaskStatus The default task status when a task is received on a mobile device. The default 
setting is based on the task status that is set up in Service Management. This 
value does not apply to the tasks that are displayed when you view tasks by 
selecting the All Open Tasks (hierarchy) view in the Tasks pane. This value 
cannot be changed.

DefaultTaskCompletionStatus The default status that is used when completing a task on the client device.

TaskValidationLevel The level of requirement for completing tasks before completing an 
appointment. The default value is WARNING.

OPTIONAL – Appointments can be completed regardless of the status of the 
appointment tasks.
WARNING – A warning is displayed if appointment tasks are set to the 
default task status that is specified in the DefaultTaskStatus setting.
REQUIRED – An appointment cannot be completed until all tasks have a 
status other than the default task status, as defined in 
the DefaultTaskStatus setting.

•

•

If a task response is marked as required in Service Management, the task cannot be completed until the 
response is entered.
A service call can remain open with Task Completion set to Required if a second appointment is created 
for the service call prior to attempting to complete the first appointment.



Regardless of the TaskValidationLevel, a value must be entered for all 
required task responses.


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Setting Description

HideTaskEstimateHours Determines whether estimated hours for a task are hidden on the client device. 
If True, estimated hours are hidden (they are not displayed on the client device). 
The default value is False.

ShowTasksForAppointments Determines whether tasks that are associated with an appointment are shown 
with the Appointment pane when a service call appointment is completed. The 
default value is False.

UseTaskMaterials Determines whether task materials (replacement parts) are displayed for tasks 
and task hierarchies for service calls. The default value is False.

Purchase Order Settings
These settings apply only if you use purchase orders.

Setting Description

UsePurchaseOrder Determines whether the Purchase Orders tab on mobile devices is active. 
Technicians can use that tab to enter purchase orders. The default value is True.

PurchaseOrderValidationLevel The level of requirement for entering purchase orders before completing an 
appointment. The default value is OPTIONAL.

OPTIONAL – Technicians do not need to enter purchase orders before 
completing appointments and are not prompted to enter them.
WARNING – Technicians are prompted, but not required, to enter 
purchase orders before completing appointments.
REQUIRED – Technicians must enter at least one purchase order before 
completing appointments.

AutoGeneratePurchaseOrderN
umbers

Determines whether purchase order numbers are generated automatically. 
If True, purchase order numbers are generated automatically and cannot be 
changed by technicians. If False, technicians can enter purchase order numbers. 
To use a unique prefix to make it easier to identify in the host system purchase 
orders that were entered by technicians, select False. Then, for 
the DefaultPONumberPrefix setting, enter a prefix to display on purchase 
orders that are created by technicians. The default value is True.

DefaultPONumberPrefix Enter a unique purchase order number prefix to display on purchase orders that 
are created by technicians. You can change this value and generate special 
prefixes only if AutoGeneratePurchaseOrderNumbers = False.

DefaultPOItemNumberPrefix Enter a default prefix to display when technicians enter a non-inventory item on 
a purchase order line.
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Setting Description

DefaultSite The default inventory site to use when technicians create purchase orders. If a 
technician is assigned to this site in Service Management, the site is displayed by 
default in the Site field in the PO Lines pane. If a technician is not assigned to 
this site in Service Management, the Site field is blank.

DefaultUnitOfMeasure The default inventory unit of measure to use when technicians create purchase 
orders.

UnknownVendorId The default vendor ID to use when a vendor name is not displayed in the lookup 
window. Technicians can select the Unknown Vendor option on devices when 
they purchase an item from a new vendor who is not set up in Service 
Management.

UsePurchaseOrderReceipt Determines whether technicians can view and receive against COMMITTED drop-
ship purchase orders that are entered in Microsoft Dynamics GP. The default 
value is False.

Resolution Settings
These settings apply only to service appointments.

Setting Description

UseResolution Determines whether the Resolution tab is displayed when an appointment is 
being completed. The default value is True and cannot be changed.

ResolutionValidationLevel The level of required information that must be entered on the Resolution tab 
when completing an appointment. The default value is OPTIONAL.

OPTIONAL – Technicians do not need to complete the information on the 
tab to complete the appointment.
WARNING – A warning is displayed to indicate that information on the 
tab is not complete.
REQUIRED – Technicians must complete the information on the tab to 
complete the appointment.

ResolutionNoteValidationLeve
l

The level of required information that must be entered for a Resolution Note is 
created. The default value is Optional.

OPTIONAL – Technicians do not need to complete the information on the 
tab to complete the appointment.
WARNING – A warning is displayed to indicate that information on the 
tab is not complete.
REQUIRED – Technicians must complete the information on the tab to 
complete the appointment.
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Setting Description

UseAppointmentResolutionNo
te

Determines whether the Appointment Summary or Call Summary report is 
generated when resolution notes are entered for an appointment or service call. 
If True, and resolution notes are entered for appointments, the Appointment 
Summary report is generated. If False, and resolution notes are entered for 
service calls, the Call Summary report is generated. The default value is False.

Labor Settings

Setting Description

UseLabor Determines whether Labor is an entry type option in Time Entry when an 
appointment is being completed. The default value is True.

If False, the remaining settings in this section are not available.

LaborValidationLevel The level of information that is required for labor when completing an 
appointment. The default value is OPTIONAL.

OPTIONAL – Technicians do not need to complete labor information to 
complete appointments.
WARNING – A warning is displayed to indicate that labor information is 
not complete.
REQUIRED – Technicians must complete labor information to complete 
appointments.

DefaultCostCodeLabor The default cost code that is displayed on the device for labor.

DefaultBilledHourlyPayCode The default pay code that is displayed on the device for billed hourly labor. 
Technicians can set up or change any pay code on an individual device.

DefaultUnbilledHourlyPayCod
e

The default pay code that is displayed on the device for hourly labor that is not 
billed. Technicians can set up or change any pay code on an individual device.

ShowTechnicianTotalLaborHo
urs

Determines if the technician's hours display in the Time Entries and 
Appointment Entry headers. The default value is set to False.

Time Entry header - Displays the current week or previous week 
total hours, depending on the drop-down selection.
Appointment Entry header - Displays the total appointment 
hours.
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Travel Settings

Setting Description

UseTravel Determines whether Travel is an entry type option in Time Entry when an 
appointment is being completed. The default value is True.

If False, the remaining settings in this section are not available.

TravelValidationLevel The level of information that is required for travel when completing an 
appointment. The default value is OPTIONAL.

OPTIONAL - Technicians do not have to complete travel information to 
complete appointments.
WARNING - A message is displayed to indicate that travel information is 
not complete.
REQUIRED - Technicians must complete travel information to complete 
appointments.

DefaultBilledTravelPayCode The default pay code that is displayed on the device for billed travel. Technicians 
can set up or change any pay code on an individual device.

DefaultUnbilledTravelPayCod
e

The default pay code that is displayed on the device for unbilled travel. 
Technicians can set up or change any pay code on an individual device.

Expense Settings

Setting Description

UseExpense Determines whether Expense is an entry type option in Time Entry when an 
appointment is being completed. The default value is True. If False, the 
remaining settings in this section are not available.

In the current release, extended pricing is not supported for travel and expense transactions through Time 
Entry.



In the current release, extended pricing is not supported for expense and travel transactions through Time 
Entry.


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Setting Description

ExpenseValidationLevel The level of information that is required for expenses when completing an 
appointment. The default value is OPTIONAL.

OPTIONAL – Technicians do not have to complete expense 
information to complete appointments.
WARNING – A message is displayed to indicate that expense 
information is not complete.
REQUIRED – Technicians must complete expense information to 
complete appointments.

You can change this value only if UseExpense = True.

DefaultCostCodeExpense The default cost code that is displayed on the device for expenses. You can 
change this value only if UseExpense = True.

DefaultBilledExpensePayCode The default pay code that is displayed on the device for billed expenses. 
Technicians can set up or change any pay code on an individual device.

You can change this value only if UseExpense = True.

DefaultUnbilledExpensePayCo
de

The default pay code that is displayed on the device for unbilled expenses. 
Technicians can set up or change any pay code on an individual device.

You can change this value only if UseExpense = True.

Inventory Settings

Setting Description

UseInventory Determines whether the Inventory tab is displayed when an appointment is 
being completed. The default value is True.

If False, the remaining settings in this section are not available.

UseNonInventoryItems Determines whether non-inventory parts can be entered on the device. The 
default setting is True.

If you use non-inventory items as task materials 
and UseTaskMaterials = True, you should set this option to True.





Setting up MobileTech

43

•

•

•

•

•

•

Setting Description

InventoryValidationLevel The level of information that is required on the Inventory tab when an 
appointment is being completed. The default setting is OPTIONAL.

OPTIONAL – Technicians do not have to complete the information on the 
tab to complete the appointment.
WARNING – A message is displayed to indicate that information on the 
tab is not complete.
REQUIRED – Technicians must complete the information on the tab to 
complete the appointment.

ShowInventoryCost Determines whether the Inventory Cost field is displayed on the tab. The 
default value is True.

ShowInventoryPrice Determines whether the Inventory Price field is displayed on the tab. The 
default value is True.

ShowInventorySiteQtyAvailab
le

Determines whether Inventory Site Quantity based on the technician's sites in 
Technician Setup. The default value is False.Additional setup requires you to 
choose the Load Data tab, select your technicians, mark Sync Lookups, and 
then choose Import. The calculation used is Quantity on Hand - Quantity 
Allocated per item in Microsoft Dynamics GP - Quantity in the MobileTech Inventory 
holding table (WS20002).

Signature Settings
These settings apply only to service appointments.

Setting Description

UseTechnicianSignature Determines whether the Signature tab is displayed when an appointment is 
being completed. The default value is True.

TechnicianSignatureValidatio
nLevel

The level of information that is required to capture the technician name and 
signature when completing an appointment. The default value is OPTIONAL.

OPTIONAL - A technician name and signature is not required to complete 
an appointment.
WARNING - A message is displayed to indicate that a technician name 
and signature has not been captured.
REQUIRED - A technician name and signature is required to complete an 
appointment.

The Signature tab displays if at least one Signature option is marked True.
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Setting Description

UseCustomerSignature Determines whether the Signature tab is displayed when an appointment is 
being completed. The default value is True.

CustomerSignatureValidation
Level

The level of information that is required to capture the customer name and 
signature when an appointment is being completed. The default value 
is OPTIONAL.

OPTIONAL - A customer name and signature is not required to complete 
an appointment.
WARNING - A message is displayed to indicate that a customer name 
signature has not been captured. 
REQUIRED - A customer name and signature is required to complete an 
appointment.

XOi Integration
XOi equips field technicians with wearable technology systems, or the Vision Telepresence Client app for Android and 
iOS devices, that capture and share information. The XOi Integration section only displays if you have a valid SEE 
registration.

Setting Description

UseXOiWorkflow Determines if XOi Workflow is enabled. The default value is False. If set to True, 
a SEE Workflow option is added to the service appointment Completion window. 
Users select an Open XOi Vision hyperlink to open a browser to the XOi Vision 
web page where they log in and complete the XOi Workflow.

The technician can capture an image and/or video that is uploaded to the XOi 
server. After returning to MobileTech and confirming the Workflow has been 
completed, the unique hyperlink is copied to the Resolution Note. After 
synchronizing, back office users can view the attachment to the service call. 
Anyone with the unique hyperlink can view and/or download the images or 
video. The activities on the XOi server are tagged with the call ID, appointment 
number, location name, and XOi user ID. 

Only one UseXOi option can be set to true. An error message displays if you attempt to set both options to 
True.


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Setting Description

UseXOiDeepLinking Determines if XOi Deep Linking is enabled. The default value is False. If set to 
True, an XOi Workflow option and an XOi Site History option are added to the 
appointment Resolution tab and the appointment form. When a technician 
selects the XOi Workflow's Open XOi Vision link, the XOi Vision app opens. The 
technician returns to MobileTech from within Vision. For more information on 
XOi deep linking, see XOi Deep Linking Setup (page 74).

The technician is able to access the Vision app from within MobileTech to access 
the XOi Workflow and view site history.

XOiClient ID Defaults to MobileTech. Display only.

XOiLoginURL Defaults to the XOi login URL. Display only.

XOiVisionURL Defaults to the XOi Vision endpoint. Display only.

XOiPartnerID Enter your XOi Partner ID that has been provided to you from XOi.

Set up Additional Options
These options are available from the MobileTech Setup Options > Options page.

Set up attachment extensions (page 45)
Set up customer options for field invoicing and field payments (page 45)
Set up report and email options (page 46)
Set up TimeTrack batch options (page 48)

Set up attachment extensions
You can specify the types of file extensions for attachments that can be sent to devices from the host system.

In MobileTech Administration, choose Setup Options, and then choose Options > Attachment Extensions. The 
Attachment Extensions Setup page displays a list of default extensions.
To add an extension type, choose the Add icon. In the Extension column, enter the type of extension for the 
attachment.
To delete an extension type, select an extension type and choose the Delete icon. You can also choose the 
Refresh icon to update the list.
Choose the Save icon to save the changes.

Set up customer options for field invoicing and field payments
If your organization uses field invoicing, you can allow and restrict which customers the technicians can generate field 
invoices for in MobileTech. For example, you might let technicians generate invoices for residential customers, but not 
for commercial customers. You can restrict or allow access to individual customers or to all customers. Field invoicing is 
available only if Field Invoicing and Field Payments is registered, and UseFieldInvoicing = True in the setup options.
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In MobileTech Administration, choose Setup Options, and then choose Options > Customer Options. The 
Customer Setup page is displayed.This page displays a list of customers who are set up in the Customer 
Maintenance window in Microsoft Dynamics GP, and who have this information set up:

Service area
Primary and secondary technician
Labor rate group
Price matrix

Make sure the Disable Field Invoicing checkbox is not marked for the customers for whom technicians can 
generate field invoices. If that checkbox is marked for a customer, a technician cannot create a field invoice for 
that customer. You can complete these actions by using the icons on the page:

Navigation buttons - Go to a record that is not highlighted. For example, you can go to the first, next, or 
previous customer record, or the last record in the list.
Refresh icon - Apply changes that were made since the last time you saved changes on the page.
Select All Toggle icon - Mark or unmark the Disable Field Invoicing checkbox for all the customers in 
the list.

Choose the Save icon to save the changes.

Set up report and email options
You can specify options to send MobileTech reports via email.

In MobileTech Administration, choose Setup Options, and then choose Options > Report Options. The Report and 
Email Options page is displayed.
You can set up the following information for sending reports and other documents, such as invoices, to a 
customer.

Report Source
The name of the report. Available reports are:

Call Summary
Field Invoice 

Job Safety Audit
Employee Time Sheet 

Appointment Summary
Inspection Report 

The Field Invoice report is available only if Field Invoicing and Field Payments is 
registered, and UseFieldInvoicing = True in the setup options.



•

•

When the Email Technician option is marked, the Employee Time Sheet is emailed to the 
technician logged into the device:

After a job appointment is completed and synced, if the appointment has at least 
one time entry. The Time Sheet will be for the current week and include all Job 
Cost transactions for the employees assigned to the time entries for the job 
appointment.
When the report is requested from the Time Entries list. The current list view 
determines which week the Time Sheet will be for, and it will include all 
transaction types (Job Cost, Service, and Unbilled). The employees included in 
the report will be determined by the user’s selection (run the report for all or 
select which employees to include).


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3.

1.

Job Appointment Summary
Appointment Type
Indicates whether all appointments or only service appointments are displayed on the report.
Call Type
The default call type filter for the report.  Blank displays all call types. 

Division
The default division filter for the report. Blank displays all divisions.
Email Technician - Mark the checkbox if you want the technician to receive the report via email.
Report Type
Indicates a SQL Server Reporting Services (SSRS) report.
Report Format
The output format of the report:

PDF – Acrobat file
EXCEL – Microsoft Excel file
MHTML – Web archive file
IMAGE – Tagged Image File Format (TIFF) file

Report Path Name
Use SQL Server to determine the path where the report is deployed. The path is most likely either /
Company Name/WennSoft Service/Call Summary or /Company Name/Signature Service/Call Summary, 
depending on whether you upgraded to MobileTech from a previous version or installed it for the first 
time.
Contact Role Type
Specifies which contacts receive automatic emails if you selected Signature Contact Management for 
the ReportEmailMode setting in the setup options. Enter a contact role type to send emails only to 
contacts of a certain type. If you enter %, emails will be sent to all contact types. 

Email From Address
The email address that reports or other documents, such as invoices, are sent from. If you use a generic 
company email address, such as  MobileTech@YourCompany.com , you can prevent the technician 
from having to forward a report email to a customer contact, so the customer will not have the 
technician's email address.
Email Subject
The subject of the email message when the report is sent.
Email Body
The body text of the email message when the report is sent.

Choose Save.

Optional: Add call, appointment, and location information to email subject lines and attachment names

You can set up MobileTech to automatically include the service call ID and appointment number in the email subject 
line and the name of the PDF attachment when Call Summary, Appointment Summary, or Field Invoice reports are sent 
via email.

In MobileTech Administration, choose Setup Options, and then choose Options > Report Options. The Report and 
Email Options page is displayed. Scroll to the Email Subject column.

The Inspection Report is available only if VEI is registered.

For inspection reports, verify that the correct call type is set up for inbound and outbound calls.

Only one Contact Role Type may be entered.
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In the Email Subject column, to include the following automatically.
Service Call ID and Appointment Number - Enter a space and then type ({0}) .

Service Call ID, Appointment Number, and Location - Enter a space and then type ({0} : {1}) .
Choose the Save icon and close the page.

Optional: Specify which report attachments sync to devices

By default, the following report attachments are not synced from the middle-tier database to the devices:

Appointment Summary report
Call Summary report
Job Appointment Summary report
JSA report

You can change the attachment sync filter in Woodford if you want these report attachments to be synced to the 
devices. 

In MobileTech Administration, choose Tools > Launch Woodford. The Dynamics CRM Login Dialog window is 
displayed.
Enter the URL, user name, and password to log on to Woodford. The URL must include the server name and port 
where MobileTech is installed, and the name of the company database (in lowercase letters). Example: 
http://servername:8080/companydatabase.

Choose OK.
In the Woodford workspace, double-click your mobile project.
In the navigation pane, choose Note, and then choose Sync Filter on the toolbar. The Edit Filter window is 
displayed. This window lists the conditions for the reports that are not currently synced to the devices.
Remove the condition for the report attachments that you want to sync to the devices. For example, if you want 
Call Summary reports to be synced to the devices, choose the drop-down arrow for the Name – Does Not 
Contain – Call Summary Report condition, and then choose Delete from the menu that appears.
When you have finished editing the sync filter, choose Save & Close on the toolbar.
Choose Publish All on the toolbar.

Set up TimeTrack batch options
You can specify a custom batch name for TimeTrack transactions that are entered from a mobile client device.

When technicians complete a call that contains labor, a batch is created in TimeTrack. Users can commit and post these 
batches as they would any other TimeTrack batches.

In MobileTech Administration, choose Setup Options, and then choose Options > TimeTrack Batch Options. The 
TimeTrack Batch Options page is displayed.
Enter a custom batch name, or choose to base the name on the technician ID, branch name, technician team, or 
service area.
You can optionally choose to include the Time Track week-ending date or the transaction date in the batch 
name. 

In the current release, extended pricing is not supported for expense and travel transactions through Time 
Entry.


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Choose Save.

Set Up New Users
Use this information to help you set up new users individually or to import multiple users:

Add a MobileTech user (page 49)
Import multiple MobileTech users (page 50)
Load Data (page 50)

Add a MobileTech user
When you are setting up MobileTech after installing or upgrading, you will add users and then continue with the setup 
steps, including those described in Load Data (page 50).
However, when you add users later – such as when new technicians join your organization – you can refresh the lookups 
rather than syncing them, to improve performance during the load data process.

Add a user before you load data and sync lookups

In MobileTech Administration, choose Users, and then choose Add User. The user fields are displayed on the 
page. Enter information in these fields.

First Name: Enter the first name of the user.
Last Name: Enter the last name of the user.
Email Address: Enter an email address for the user. The email address becomes the user name for the 
technician when the technician signs in to a client device.This is also the email address where the Call 
Summary, Employee Timesheet, Job Appointment Summary, and Job Safety Audit reports are sent.
Password and Confirm Password: Enter and confirm a password that lets the user sign in to MobileTech.
Technician ID: Select the identifier for the technician whom you are adding as a user.
Employee ID: After you set up and save user information, the employee ID that is set up in Microsoft 
Dynamics GP for the user is displayed as an ID for the employee.
Locked/Disabled checkboxes: If you are have set up password complexity and a lock out policy, you can 
unmark the appropriate checkbox if the user is locked out or has disabled their account due to invalid 
login attempts. See Set up Password Complexity and Lockout Policy (page 22) for more information.
Roles: Select the role of the MobileTech user. By default, a client user is assigned to the MobileTech role. 
To assign a user to the system administrator role in MobileTech Client, mark System 
Administrator.See User Role Maintenance (page 51) for information on creating roles.

Choose Save. The user is added to the list of users in the column on the left.

Because either of these options contain eight characters and the batch name can be only 15 characters 
long, if you mark this checkbox, the name you specified in step 2 is truncated to seven characters, if 
necessary.



You cannot exceed the number of active MobileTech technicians that you are licensed for.

Use the filter options to narrow the user display list. You can filter by user, technician ID, or login account. 
Enter a partial or whole entry and then choose the Filter  icon. To clear the filter, choose the Clear Filter 

 icon.


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Add a user after you have loaded data and synced lookups

In MobileTech Administration, choose Users, and then choose Add User. The user fields are displayed on the 
page.
Enter information in the fields, as described above in Add a user before you load data and sync lookups.
Choose Save. The user is added to the list of users in the column on the left.
Choose Tools > Refresh Lookups.
Mark the Employee checkbox and the checkboxes for all its child entities, such as Pay Code, Work Crew, and so 
on. 

Choose Refresh.
Choose Load Data.
Mark the checkboxes for the technician to load data for.
Enter the date range to include when you load and sync data, and leave the Sync Lookups checkbox unmarked.
Choose Import, and then choose Close.

Import multiple MobileTech users
You can import multiple user records from Microsoft Dynamics GP instead of adding individual users.
All users who are set up as technicians in Service Management are listed. You can select only the number of technicians 
you purchased licenses for.

In MobileTech Administration, choose Users, and then choose Import. The Bulk User Load page is displayed.
Mark the checkboxes for the technicians whose records you want to import. These users will be assigned to the 
role of Mobile Tech.
If a technician does not have an email address and password assigned, enter that information in the appropriate 
columns. The email address for each technician must be unique.Each technician's email address also is used to 
send and receive reports that are associated with technician activities.
Choose Update. The technicians are added to the list of users in the column on the left.

Load Data
You must load data into the organizational database for each technician you select. Any data that is associated with 
open calls and appointments for each technician, and for the specified date range, is included.

Each time you load data, lookups are processed first, followed by all items that are available to sync in the 
WSMobileTechSync table are processed first. The progress information for the process is displayed as Integration 
Synchronization.

In MobileTech Administration, choose Load Data.
Mark the checkboxes for the technicians to load data for, or choose Select All to mark all the technicians in the 
list.
Enter the date range to include when you load and sync data. 

When you mark a lookup, other associated lookups might be marked if there are dependencies 
between the lookups. For example, if you mark the checkbox for a child lookup, the parent lookup 
automatically is marked because that must be refreshed, too.



We recommend that you limit the date range so only current and relevant data is included and 
historical data for transactions is not included. For performance reasons, the maximum date range is 
two months.


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Mark the Sync Lookups checkbox. 

Choose Import. The processing time is determined by the number of technicians, the amount of data to import, 
and the date range that you entered.
Choose Close.

User Role Maintenance
The Role Maintenance window is used to add or delete user-created roles. You can also add technicians to the roles in 
this window. The default roles of System Administrator and MobileTech are created during the installation of 
MobileTech and cannot be deleted.

Adding a new role (page 51)
Adding one or more technicians to a role (page 51)
Removing one or more technicians from a role (page 51)
Deleting a role (page 52)
Deleting multiple roles (page 52)

Adding a new role
In MobileTech Administration, choose Role Maintenance.
Choose Add Role to create a new role.
Enter a Role Name and choose Add.
Choose OK.

Adding one or more technicians to a role
In MobileTech Administration, choose Role Maintenance.
Choose the role you are assigning technicians to in the Role Name list.
Choose Add Technicians.
Use the filter options to narrow the technician display list. You can filter by name or technician ID. Enter a partial 

or whole entry and then choose the Filter  icon. To clear the filter, choose the Clear Filter  icon.
Mark the checkbox next to the technician(s) to add to the role.
Choose Add.

Removing one or more technicians from a role
In MobileTech Administration, choose Role Maintenance.
Choose the role you are removing the technician from in the Role Name list.
Mark the checkbox(es) next to one or more technicians.
Choose Remove Technicians.

If there is no data to sync in certain lookup tables, this checkbox is marked and cannot be unmarked. 
You do not need to mark this checkbox if you are adding subsequent users after you have already 
loaded data and synced lookups. For more information, see Add a MobileTech user (page 49).



Using Woodford, you can customize the application to user roles. For specific information about how to use 
Woodford to customize your application, see the Resco Mobile CRM Woodford User Guide.


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Choose Yes in the confirmation window.

Deleting a role
In MobileTech Administration, choose Role Maintenance.
Choose the role in the Role Name list.
Choose Delete Role.
Choose Yes in the confirmation window.

Deleting multiple roles
In MobileTech Administration, choose Role Maintenance.
Choose Add Role.
Mark the checkboxes next to the roles to be deleted.
Choose Delete Selected Roles.
Choose Yes in the confirmation window.

Switching Companies
To switch companies, choose File > Change Company. Select a company, and then choose OK.

Set Up Additional Companies
You must set up each company that is in the Microsoft Dynamics GP database.

In MobileTech Administration, choose File > Change Company. The Change Company page is displayed.
Select a company and choose OK.
See Setting up MobileTech (page 21) to continue with the procedures to set up each company.

Import the MobileTech Woodford Project
Resco's Woodford component is a tool that lets you customize and configure MobileTech for your business purposes. 

Technicians may also be added to or removed from roles in the User window by marking/unmarking the 
checkbox next to the role name and then saving the User record.



•

•

Important information for upgrade customers who already use Woodford
Do not install a version of Resco Cloud that is newer than v12.x.x.xxxx. Do not install a newer 
version of Woodford until you are instructed to do so by WennSoft. Woodford is a third-party product 
and you must use a version of Woodford that is compatible with the version of MobileTech you are 
using.
When you launch Woodford, if the "New update is available" message is displayed, choose Later.
After you install and activate Woodford, we recommend that you set up Woodford so you are not 
prompted to install a newer version when it is released by Resco. In Woodford, choose Settings and 
unmark the Check for updates on startup checkbox.


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To import the MobileTech Woodford project:

We recommend that when you launch Woodford, you log on by using the system administrator credentials you used 
when you installed MobileTech Administration.

In MobileTech Administration, choose Tools > Launch Woodford. 
Enter the user name, and password to log on to Woodford. 
Choose OK. 
The Registered User window may display. If it does, enter your contact information in the window and 
choose Register.
If the "New update is available" message is displayed, choose Later. 
If you have an existing MobileTech project, you must deactivate the project before importing the new/updated 
project. Select the project and then select Deactivate from the top navigation. 

Choose Import and browse to the location where the MobileTech.woodford file was saved when you installed 
MobileTech Administration. For most users, the location of the Woodford file is C:\Program Files 
(x86)\Signature\MobileTech\Admin\Woodford. 
In the Add Mobile Project window, select MobileTech x-xx-xxx.woodford and then choose Open. 

In the Import Project window, complete the following fields as needed:
Type
Accept Standard User.
Name
Accept MobileTech x-x-xx.
Priority
Accept the default "0", however if you have more than one project for the same security role, the one with 
a higher priority is used.
Custom Version Identifier (Optional)
Leave blank or enter any descriptive text. This information displays in the Project Version column in the 
App Projects grid. You can edit the project properties to update this field if needed.
Roles
Mark MobileTech. 

Choose Save. 

An exclamation point   icon displays next to the mobile project to indicate the project has not been 
published.
Double-click the MobileTech mobile project.

• Your existing MobileTech project must be deactivated before you import a new or updated 
project. If you are importing an updated project with the same name, you will need to rename the 
deactivated project using Properties from the top navigation before importing. Then choose Create 
New in the window that displays.

•

•

If you have already made customizations to MobileTech by using Woodford, you must reapply 
those customizations each time you upgrade MobileTech and the corresponding Woodford 
project. 
Re-enable any options that were enabled in Woodford. For example, if you are using Mobile 
Auditing (page 56) (UseMobileAuditBackgroundSync=True), please be sure to re-enable the 
Woodford Auditing settings after importing a new Woodford projects.



If you are re-importing the same project version and are prompted to overwrite the existing deactivated 
project, choose Cancel and then rename the existing deactivated project using Properties in the top 
navigation. Then import the project and choose Create New in the window that displays and continue 
with the instructions below.


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In the Navigation bar at the top, verify that the Publish Version displays 12.0 (default value). To avoid sync 
issues, do not change this field. 
Choose Publish All.
In the Select Projects window, verify that MobileTech is marked and then select OK.
Unmark the option to be notified when Woodford updates are available. In Woodford, choose Settings and 
unmark the Check for updates on startup checkbox.,
Click Save.

See Set up Woodford (page 54) for information on customizing and configuring entities. For information about how to use 
Woodford to further customize your application, see the Resco Mobile CRM Woodford User Guide9.

Sync the technician devices
Sync the technician devices using MobileTech Client. The "Application was updated" message is displayed on the 
device to indicate that a Woodford project is active.

Set up Woodford
Enable Flexible Forms (page 55)
Enable Mobile Auditing (page 56)
Set the Fetch Limit (page 57)
Set up the Sync Date filters (page 57)
Enter the Google Maps API key (page 58)
Enabling Sync Dashboard (page 58)
Enabling the Automatic Timesheet Generation after Job Appointment Completion (page 59)

•
•

Avoid making these changes with Woodford
This information is intended to provide insight into areas that cannot be modified by using Woodford. It also 
includes recommendations about which entities you should not change.

Tabs that you cannot modify
You cannot use Woodford to modify the Resolution tab and the Summary tab for appointments in 
MobileTech.

Background Download Configuration setting
The Background Download option must remain at its default False setting. This setting is found in the 
Woodford project in Settings > Configuration > Offline Data Sync - Background Sync > Background Download.
These are the known issues if this setting is changed:

Background Download interferes with the MobileTech AutoStatusUpdate feature.
The first list that is opened from the Home screen is cached and you cannot close it or refresh it.  This 
can cause stale data to remain on the list.


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Enable Flexible Forms
The Flexible Form is a way for users get a perfect overview of any record at a glance. Instead of users choosing various 
tabs to the view information, you can put the record's fields, associated views and other items into one screen.

Enabling Flexible Forms
In MobileTech Administration, choose Tools, and then choose Launch Woodford.
Choose the MobileTech project and then choose Edit from the menu bar.
In the left navigation bar, under Settings, select Configuration.
On the UI tab, in the Forms section, complete the following:

Flexible Forms: Enable Flexible Forms by setting this to True.
Flexible Forms List Scrolling: We recommend set this option to True to use vertical scrolling. If set to 
False, the forms scroll horizontally on larger devices.

In the left navigation bar under Design, select Theme.
In the far right section, to the right of TAB, select the ellipsis   icon to display more options.
Choose Selected Foreground.
In the Tab Selected Foreground window, in the Hex # field enter 000000 (zeros) to change the color to black. 
(Leave #FF in the first section of the Hex field.)
Select OK.
Select Foreground.
In the Tab Foreground window, In the Hex # field enter 000000 (zeros) to change the color to black. (Leave #FF in 
the first section of the Hex field.)
Select OK.
Publish the Woodford project.

•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Entities that you should not change Sync Filters for
To help make sure that all records sync accurately, we recommend that you do not change sync filters for the 
following entities. Changing these filters could result in unexpected behavior and sync issues.

Appointment Status Time Stamp
Change Order
Change order detail
Consumed inventory
Contract
Equipment
Contract equipment
Purchase Order
Purchase Order Detail
Purchase Order Receipt
Purchase Order Receipt Detail
Refrigerant Tracking
Tasks
Subtasks
Time log

The Appointment, Appointment Completion, Customer, and Location entities have been tested to work with 
Flexible Forms. While other forms can be modified to use with Flexible Forms, doing so is at your own risk.


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Customizing Forms
For information about how to customize the Appointment, Appointment Completion, Customer, and Location forms 
and their associated tabs, see the Flexible Forms section in the Resco Mobile CRM Woodford User Guide.

Enable Mobile Auditing
Use Woodford's Mobile Audit feature to update the Technician Vehicle table (SV00113). The location information 
updates automatically based on time/distance plus you can choose to have the location updated when the technician 
updates appointments, creates a labor transaction, and/or times in/out of appointments.

The location data is updated when the device is synchronized to the host. We recommend that you use event-based 
synchronization so that the technician location coordinates are sent when completing (and syncing) their 
appointments. This will also enable other applications such as Schedule to view the most up-to-date information about 
the technician's location. For more information about synchronizing, see Setting up Host Syncing (page 63).

In MobileTech Administration, go to Tools > Launch Woodford.
Open the active Mobile Project.
Navigate to the Auditing tab on the left panel.
Under Auditing Settings, mark the following checkboxes:

Enable
Include GPS position
Track GPS position changes: We recommend that you use the default values for Delay (600 seconds) and 
Distance (500 meters) as reducing these values may affect the device battery performance. 

The settings above are enough to track the technician's location in the Technician Vehicle table (SV00113), but if 
you also want to track entity-specific changes (Create and/or Update), you can mark the following options under 
Enable auditing for the following entities and operations:

Appointment: If you want to know where the technician was when recording his/her appointment data.
Time Entry: If you want to know where the technician was when recording labor transactions.
Time Log: If you want to know where the technician is timing in or timing out of appointments. 

•

•

Smaller devices like smart phones display the information in a single vertical scroll window. Larger 
devices may display up to three columns of information, depending on the size of the device. 
Additionally, when scrolling on an Android or iOS device, a hover menu bar displays that a user can tap 
to navigate quickly to a section.
The barcode icon is not available when a list is displayed in a completion form if Flexible Forms is set to 
True in Woodford. The barcode icon is available in full panel mode, which you can access by double-
tapping the section header.



Choose Yes when prompted with "Track GPS position is obsolete function replaced by Location 
Tracking. Are you sure to turn it on?"



•

You will also need to set up the following options in MobileTech Admin. See Mobile Device 
Global Settings (page 30) in Set up MobileTech Options.

UseMobileAuditBackgroundSync: Used to control the ability to auto-upload 
mobileaudit records to the host. This is used with Woodford's Auditing feature to track 
technician GPS coordinates based on creating or updating specific entities such as 
Appointment, TimeLog, or TimeEntry. Set this option to True.


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Choose Save.
Publish the project.

Set the Fetch Limit
The Fetch Limit is the number of Customer Location (customers and locations) or Equipment records that the SERVER 
MODE fetches at a time in the New Service Call window in the MobileTech Client. The Fetch Limit defaults to 100. A 
Customer Location/Equipment search field displays at the top of the New Service Call window if the number of 
customers, locations, and equipment records are equal to or greater than the fetchLimit value.

In MobileTech Administration, go to Tools > Launch Woodford.
Open the active Mobile Project.
Navigate to the Offline HTML tab on the left panel.
Double-click entity to open. 
Double-click servicecall to open.
Select servicecall-form_new.html and then choose Edit.
Scroll down to INITIAL SETTINGS.
Update the var fetchLimit value. The default is 100.
Select Save to close the Edit window.
Select Save to save the project.
Publish the project.
Technicians will need to synchronize to update the MobileTech Client.

Set up the Sync Date filters
Beginning with MobileTech 7.5, the Start Sync Date filters are now set up in Woodford and are a global setting. Prior to 
MobileTech 7.5 this was a device setting in the MobileTech Client app. If you need to have different sync rules 
for different technicians, you will have to clone the Woodford project and use different Roles to identify those different 
sync rules. For more information, see Sync Filter - Resco's Wiki10.

The default setting is +/- 1 month. If you need to adjust the Sync Filter range, you will need to update each of the 
following entities in Woodford:

Appointment
Customer
Job Safety Task
Job Safety Task Response
Service Call
Subtask
Task
Task Response

To set up the Sync Date filters:

• OnSiteStatusUpdate: Used when UseMobileAuditBackgroundSync=True to determine 
what status will be used to automatically send the technician's GPS coordinates to the 
host.  No synchronization is required, but an internet connection must be available.

UseServerMode must be set to TRUE in MobileTech Admin Mobile Device Global Settings (page 30). This setting 
defaults to TRUE.


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In MobileTech Administration, choose Tools, and then choose Launch Woodford.
Choose the MobileTech project and then choose Edit from the menu bar.
In the navigation bar, select an entity from the left navigation. 

Click Sync Filter in the top navigation.
In the Edit Filter window, to the right of each Start Date:

Enter a new value for Last X Months.
Enter a new value for Next X Months.

Select Save.
Complete the same steps for the other entities, making sure to enter the same values as the first entity.
Save the project.
Publish the project.

Enter the Google Maps API key
If you will be using the Mapping feature on a Windows computer, you will need to obtain a Google Maps API key 
at https://cloud.google.com/maps-platform/pricing/. (You will need an API key that includes Maps and Routes. You do 
not need Places.)

In MobileTech Administration, choose Tools, and then choose Launch Woodford.
Choose the MobileTech project and then choose Edit from the menu bar.
In the navigation bar, choose Configuration.
Scroll down to the Integrations - Google section.
Enter the key in the Google API Key field.
Mark the Lock checkbox.
Select Save in the top navigation.
Publish the MobileTech project.

Enabling Sync Dashboard
Sync Dashboard is a comprehensive monitoring tool that gives you a 360º overview of sync details including what are 
the sync errors, how many users have sync errors, how long each sync takes, the average sync length, how many 
records are synced, and more. This also includes a Sync conflict resolution feature. This is a separate tool and needs to 
have Auditing and Log synchronization event enabled in the MobileTech Woodford project. For an in-depth overview, 
see your Woodford documentation and/or this blog post: https://blog.resco.net/2019/02/21/sync-dashboard/.

To enable Sync Dashboard:

Launch Woodford and open the mobile project.
Navigate to the Auditing panel on the left menu.
Mark Enabled and Log synchronization event. From this point on, all client sync logs will display in the Sync 
Dashboard.
Publish the Woodford project.
Syncing a device to log sync activity.
Open a browser and enter your MobileTech server name.
On the Resco Cloud Apps & Tools window, select Sync Dashboard.

Make sure to click on the entity name to display the Entity view. If you click the icon to the left of the 
entity name, the Mobile Views, Forms and Charts view displays. The Sync Filter button only displays 
on the Entity view.


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Enabling the Automatic Timesheet Generation after Job Appointment Completion
In Woodford, select the MobileTech project and then select Edit from the menu bar.
From the left navigation, select Offline HTML.
Double-click Entity to open.
Double-click Appointment to open.
Select appointment-form_complete-job.html and then select Edit from the menu bar.
Scroll down to FORM EXECUTIONS.
Locate //,generateTimesheetReport(appointment) //Uncomment line to turn on automatic generation of 
timesheets.
Remove the preceding //, and succeeding //Uncomment line to turn on automatic generation of 
timesheets so that the line only displays the following.
generateTimesheetReport(appointment)
Select Save.
Select Save from the menu bar.
Publish the project.

Set up MobileTech on a Client Device
The following topics are also available in the MobileTech Client Help the device.

First Time Logging into Mobile CRM (page 65)
MobileTech Client Setup on a Mobile Device (page 59)
Setting up Host Syncing (page 63)

MobileTech Client Setup on a Mobile Device

Working with MobileTech Setup Options (page 59)
Viewing Options (page 59)
Setting up Time Entry Default Pay Codes (page 60)

Working with Resco Setup Options (page 60)
Accounts (page 60)
Network (page 60)
Appearance (page 61)
PIM (page 62)
Advanced (page 62)

Working with MobileTech Setup Options

To access the MobileTech Setup Options, choose Setup  and then choose MobileTech.

Viewing Options

The Options section displays your Technician ID, Employee ID, Employee Name, and the MobileTech Woodford version. 
All device settings are set up by your administrator in the Woodford project.
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Setting up Time Entry Default Pay Codes

To save time when you create unbilled and billable time, expense, and travel entries, you can set up default pay codes. 
You can select a different pay code, if necessary, when you complete an entry on your mobile device. Pay codes are set 
and assigned to individual technicians in Service Management.

If you don't set up pay codes, the pay codes from the labor, travel, and expense settings in the MobileTech setup are 
used. If no pay codes are set up there, default pay codes aren't displayed.

Choose Setup   . 
Choose MobileTech.
On the Setup page, choose Time Entry.
Select the Default Unbilled pay codes to use for unbilled hourly, expense, and travel entries when you create 
timesheet entries.
Select the Default Billiable pay codes to use for billable hourly, expense, and travel entries when you create time 
entries for appointments.
Choose the Save   icon.

Working with Resco Setup Options
The following setup options are from Resco. Some of the setup options below are not supported by MobileTech and 
changing these options may affect how the MobileTech works on your device.

Choose Setup  .
Choose Resco.
Update the settings below:

Accounts

CRM Displays your technician email address.

Network

Online Mode Displays the Online Mode as set up by your adminstrator.

Auto Sync Displays the Auto Sync setting as set up by your administrator.

Sync Login Choose On to require that you log on to MobileTech before you sync your mobile 
device. Choose Off if you want to be able to sync your mobile device without 
logging on to MobileTech.

Save Password Choose On to save your logon password for the device that you're using. If this 
option is on, you don't have to enter your password each time you log on to 
MobileTech. If you choose Off, you must enter a password on the device when 
you start MobileTech.
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Use Fingerprint
(Android/iOS only)

Turn on to use your fingerprint, Touch ID, and/or Face ID to log into MobileTech. 
We recommend to leave this turned Off if you share a device.

Appearance

Language Not supported by MobileTech. By default it is set to Automatic to use the 
language of your device.

New Form UI Not supported by MobileTech.

Max Image Size iOS Only - Choose the maximum image size. Default / 640 x 480 / 1024 x 768 / 
1600 x 1200 / 2048 x 1536 / 2592 x 1936

List Buttons Not supported by MobileTech.

Map Choose On to make the Map button available.

Dashboard Not supported by MobileTech.

Change List Not supported by MobileTech.

Design Dashboards Not supported by MobileTech.

Private Charts Not supported by MobileTech.

AutoFormGrid Not supported by MobileTech.

Full Screen
(Windows only)

This Windows-only option displays the full screen setting as set up by your 
adminstrator.

On 
If you are using a Windows device, this option displays MobileTech 
in full-screen view. The title bar, including the icons for 
minimizing, maximizing, and closing the app, won't be displayed.
Off 
The title bar and the icons for minimizing, maximizing, and closing 
the app display.

Locations on maps are displayed only if coordinates for locations are 
entered in Service Management. Contact your system administrator 
about making changes to the Service Management SV00200 table.


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Ask Before Exit
(Windows only)

If you're using a Windows device, choose On if you want to be prompted for a 
confirmation before closing MobileTech.

PIM

Call Via Not supported by MobileTech.

Send Invites Not supported by MobileTech.

Use Reminders Not supported by MobileTech.

Send Email Via Not supported by MobileTech.

HTML Emails Not supported by MobileTech.

Signature Not supported by MobileTech.

Exchange Folder Not supported by MobileTech.

Show Images Not supported by MobileTech.

Mark Email Read Not supported by MobileTech.

Advanced

Home Realm Not supported by MobileTech.

ADSF Username Not supported by MobileTech.

UseSystemOAuth Not supported by MobileTech.

Web Service Must be XRM. Other selections are not supported by MobileTech.

Delete Data Use this option to clear the local database. After you've entered information by 
using your mobile device and synced data, you can delete data, which lets you 
manage your device memory and optimize performance by removing old files.
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Max Attachment Size
(Windows and iOS only)

If you're using a Windows or iOS device, select the file size of attachments, such 
as photos. If you're viewing an image that exceeds this size, it's resized to the 
maximum image size for viewing purposes, and then returned to its original size. 
If you take a photo with your device, this is the maximum size of the photo.

Display Density
(Android only)

If you're using an Android device, use this field to change the size of the content 
on the screen. You can use this setting to display more or less content, 
depending on the size of the screen and your preference.

Max Attachment Size The maximum size of any file that can be attached to records. This setting can't 
be changed on the device. This is a Woodford setting.

Max Sync Records The maximum number of records that can be synced to the mobile device for one 
entity. The default maximum is 100,000 records at one time, but you can 
decrease that number.

Diag. Sync Log Use this option to log details for synchronizations.

Entity Not supported by MobileTech.

AppFolder Not supported by MobileTech.

Client Certificate Not supported by MobileTech.

Pinned Certificate Not supported by MobileTech.

Choose the Save   icon.

Setting up Host Syncing

Synchronizing, or syncing, with the host system lets you update the information on your mobile device with any 
changes that might have been made in Microsoft Dynamics GP. Syncing also updates the host system with changes that 
you make on your mobile device, such as changes to the statuses of calls and appointments, or new notes and 
attachments.

Syncing can be set up based on events and you can manually sync your mobile device at any time. If you cannot click on 
a setup field on your device, you must contact your administrator to unlock the field.

IMPORTANT: While Resco offers an automatic sync option, we advise against using it as it has caused issues 
with MobileTech functionality.


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Event-based syncing
If MobileTech is set up to use event-based syncing, event-based syncing is used to synchronize your device to the host 
system in these situations:

You choose Save after creating a service call.
You choose Save after creating an appointment.
You choose Complete Appointment after completing a service call appointment.
You request a timesheet report.

Display the Sync page to prompt you to synchronize

After you create a service call, create or complete an appointment, or request a timesheet report, the Sync page is 
displayed. You must choose Sync to sync to the host system.

Field Setting

UseEventBasedSync in the Admin Setup Options True

Sync Login on the device On

Automatically synchronize your device to the host system

After you create a service call, create or complete an appointment, or request a timesheet report, your device is 
automatically synced to the host system.

Field Setting

UseEventBasedSync in the Admin Setup Options True

Sync Login on the device Off

If MobileTech is not set up to use event-based syncing, no event-based syncing occurs. The device will sync depending 
on your settings in the Sync Login or Auto Sync fields on the Setup page, or when you manually sync the device. See 
"Automatic syncing" and "Manual syncing" in this topic for more information.

Manual syncing

To log on or to sync the host and your mobile device, follow these steps.

Choose the Sync icon.
Enter the following information. If you've previously used MobileTech on this client device, most or all of this 
information is shown as default entries.

To manually sync with the host system from the Sync page, the Sync Login option must be marked on the 
Options tab on the Setup page.


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Field Description

Url Enter the URL of the MobileTech Integration Sync Server. The URL must 
include the server name, website port number, and company database 
name.

Example: http://servername:8888/companydatabase

            

User Name Enter your user name. This is the email address that was set up for you by 
an administrator in MobileTech Administration to use when you log on to a 
client device.

Password Enter the password that is associated with your user name.

Save Password Mark this option if you want the application to remember your password 
after you exit and start MobileTech again. Don't save your password if 
you're using a shared client device. If you don't save your password, it is 
saved only during this session. You won't have to re-enter your password 
the next time you sync during this session.

Choose the Sync icon. If you encounter any issues while you're syncing, you can review and resolve by 
choosing Sync Errors. For more information, see Resolving sync issues1112.

First Time Logging into Mobile CRM
The first time that a user logs into Resco's Mobile CRM, device users should make the following selections:

Launch the Mobile CRM app.
On the Meet Resco Mobile CRM screen, tap Skip Tour. 
On the Welcome to Resco Mobile CRM screen, select Internal User.
On the Sync screen, select Standard User next to User Mode.
Enter the following: 

URL
Enter the URL of MobileTech Integration Sync Server. The URL must include the server name, website 
port number, and company database name. Example: https://mobiletech.company.com/
companydatabase. 

Username
A technician's MobileTech username is the email address that is set up in MobileTech Administration. 
See Add a MobileTech user (page 49). 

The internal address will be http://servername:8888/companydatabase. Your IT manager will 
need to update the firewall rules to map the external SSL traffic to the internal MobileTech port 
of 8888.



https://wennsoft.atlassian.net/wiki/spaces/mt75/pages/6815936/Resolving+sync+issues
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Password
A technician's password is set up in MobileTech Administration. See Add a MobileTech user (page 49).

To save the password, set the Save Password toggle to On.

Set up Information in Microsoft Dynamics GP
This section helps administrators set up various types of information in the host system that technicians can access as 
they enter information and complete tasks using mobile devices.

Set up TimeTrack (page 66)
Maintaining history (page 66)
Entering unbilled transactions (page 66)
Setting up manager approval (page 67)
Verify technician and manager setup in Signature Registered Users Setup (page 67)

Set up attachments to be sent to technicians (page 67)
Give technicians access to inventory items (page 67)
Set up billable and unbillable pay codes (page 68)
Set up resolution note snippets (page 68)
Assign items to vendors and create records for unknown vendors (page 68)
Give technicians access to vendors (page 68)
Verify mobile vendor setup for drop-ship purchase orders (page 69)
Verify Signature Document Attachments setup (page 69)
Set up and use work crews for appointments (page 69)

Set up work crews (page 69)
Assign employees to work crews (page 70)

Set up job safety audit (JSA) information (page 70)
Create an unsafe work environment indicator (page 70)
Create the JSA task list type (page 70)
Create task codes for JSA tasks (page 70)
Set up responses for JSA tasks (page 71)
Create JSA task lists and add task codes (page 72)

Naming conventions for JSA task list IDs and task codes (page 72)
Set up sublocations for barcoding (page 73)

Set up TimeTrack

Maintaining history
You must set up TimeTrack to maintain history so TimeTrack transactions appear correctly on the Call Summary report, 
especially after the TimeTrack batches are committed.

In Microsoft Dynamics GP, choose Microsoft Dynamics GP > Tools > Setup > TimeTrack > Setup Options. The 
TimeTrack Setup Options window is displayed.
In the Miscellaneous Items section, mark Maintain History.
Choose Save.

Entering unbilled transactions
If technicians will enter unbilled TimeTrack transactions in MobileTech, you must set up the host system to handle 
those transactions properly.
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In Microsoft Dynamics GP, choose Microsoft Dynamics GP > Tools > Setup > TimeTrack > Setup Options. The 
TimeTrack Setup Options window is displayed.
In the Create a GL Journal Entry For section, mark Unbilled Transactions.
Choose Save.
Set up unbilled asset accounts. For information, see the TimeTrack documentation.

Setting up manager approval
In the TimeTrack User Guide, see Setting up the manager approval feature for more information regarding setting up the 
manager.

If technicians submit timesheets that need manager approval, you will need to set up the following in the TimeTrack 
Setup Options window:

Verify technician and manager setup in Signature Registered Users Setup
In order for the technician's manager to be notified by email, you will need to verify that the manager's email address is 
set up in TimeTrack's Registered Users Setup window. In the TimeTrack User Guide, see Signature registered users and 
Setting up the manager approval feature for detailed information.

Set up attachments to be sent to technicians
Before you can send document attachments to technicians, you need to select and set up the actual files to attach and 
send. For more information about document management, see the Service Management documentation.

In Microsoft Dynamics GP, open a service call.
Choose the attachment (paperclip) icon next to the Service Call ID field. The Document List window is 
displayed.
Choose Add. The Document Maintenance window is displayed.
Select a format and a file.
Choose the Copy To Database option. Copy to Database must be selected in order to send attachments to 
devices. Attachments will not be sent to the device if you do not choose this option.
Specify any additional information and choose Save.

Give technicians access to inventory items
To track inventory items that a technician uses on a service call, make sure the technicians have access to the 
appropriate inventory sites.

In Microsoft Dynamics GP, choose Microsoft Dynamics GP > Tools > Setup > Service Management > Lookup Setup > 
Technicians > Technicians. The Technician Setup window is displayed.
Select the technician ID.
Choose Inventory Sites. The Technician Inventory Site Setup window is displayed.
Mark the Assigned checkbox for the inventory sites that are associated with the technician.
Choose OK, and then choose Save in the Technician Setup window.
Repeat steps 2 through 5 for each technician.

In the TimeTrack Setup Options Email Notification section, the option to Notify Manager when Employee has 
Updated Rejected Trx is not honored in MobileTech. If marked, the manager will not receive email 
notifications. The manager will receive a notification when the technician resubmits the timesheet if Notify 
Manager when Employee Submits Time Card for Approval is marked.


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Open MobileTech Administration and choose Load Data.
Select a technician and a date range.
Make sure the Sync Lookups checkbox is marked.
Choose Import.

Set up billable and unbillable pay codes
You can specify which pay codes are billable, unbillable, or both, and then send those pay codes to devices for 
technicians to use for time, expense, and travel entries.

In Microsoft Dynamics GP, choose Inquiry > Service Management >Mobile Pay Code Setup. The MobileTech Pay 
Code Setup window is displayed.
Choose whether each pay code is billable, unbillable, or both. The default value is Both for all pay codes.
Choose OK.

Set up resolution note snippets
You can set up resolution note snippets in Service Management to help you track work that is completed by technicians. 
These snippets provide a uniform method for technicians to report how they resolve issues and complete 
appointments. Technicians can include these snippets in the Resolution Note field in MobileTech.

In Microsoft Dynamics GP, choose Microsoft Dynamics GP > Tools > Setup > Service Management > Lookup Setup > 
Service > Resolution Note Snippets. The Resolution Note Snippets window is displayed.
Enter a resolution ID and a description of up to 255 characters.
Choose Save.

Assign items to vendors and create records for unknown vendors
If a technician purchased items from a vendor who is not already entered in the system, complete these steps.

You also need to complete step 2 if both the item and vendor already exist in the system, but the item is not assigned to 
the vendor from whom it was purchased.

In Microsoft Dynamics GP, choose Cards > Purchasing > Vendor. In the Vendor Maintenance window, create a 
record for the vendor.
In Microsoft Dynamics GP, choose Cards > Inventory > Vendors. In the Item Vendors Maintenance window, assign 
the item that was purchased to the vendor record that you just created.

Give technicians access to vendors
By default, vendors in Microsoft Dynamics GP are visible to technicians, who can select a vendor while creating a 
purchase order. You can designate which vendors the technicians can select if you do not want all vendors to be 
displayed in lookup lists.

In Microsoft Dynamics GP, choose Inquiry > Service Management > Mobile Vendor Setup. The Mobile Vendor Setup 
window is displayed.
Unmark the checkbox next to vendors if you do not want the vendors to be displayed in lookup lists in 
MobileTech.
Choose OK.
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Verify mobile vendor setup for drop-ship purchase orders
You can receive committed and partial drop-ship purchase orders for job appointments and service calls from 
mobile vendors. Drop-ship purchase orders are saved and committed in Microsoft Dynamics GP (Transactions > 
Purchasing > Purchase Order Entry). 
Mobile vendors must be set up in Service Management (Inquiry > Service Management > Mobile Vendor Setup). For 
more information, see Give technicians access to vendors13. 
Freight and miscellaneous charges that are entered for purchase orders in Microsoft Dynamics GP are not synced 
to the device. However, technicians can enter the amounts from the invoices when they receive shipments in the 
field.

Verify Signature Document Attachments setup
In the host system, the Signature Document Attachments Setup window is used to set up the file locations where 
reports are copied when they are generated and attached to service calls. For information about how to set up service 
call task attachments and physically stored document attachments in Service Management, see Signature Help or the 
Service Management User Guide.

The reports can be reprinted in Service Management by opening the service call attachments. We recommend that 
users reprint the reports from the attachments rather than regenerating the reports, because regenerated reports 
might differ from the original versions and will not include signatures.

For information about how to set up attachments to be sent to technicians, see Set up attachments to be sent to 
technicians (page 67).

Set up and use work crews for appointments
You can create work crew who work together at job or service appointments. For example, a team that installs heating 
systems or does survey work could be a work crew. You must set up work crews in TimeTrack, and then the activities of 
the crews can be tracked in MobileTech. Depending on how your system is set up, at least one of these options in 
MobileTech Administration must be set to True:

UseWorkCrewJobCost
UseWorkCrewService

A technician who enters time for an appointment must be assigned to the work crew that is completing the work for the 
appointment.

Set up work crews
In Microsoft Dynamics GP, choose Microsoft Dynamics GP > Tools > Setup > TimeTrack > Work Crews. The Work 
Crew Setup window is displayed.
Enter a work crew name and description.
Mark the Enabled checkbox.
Choose Save, and then continue to set up work crews as needed.

https://wennsoft.atlassian.net/wiki/pages/resumedraft.action?draftId=6620038#SetupInformationinMicrosoftDynamicsGP-give-techs-access-to-vendors
https://wennsoft.atlassian.net/wiki/pages/resumedraft.action?draftId=6620038#SetupInformationinMicrosoftDynamicsGP-give-techs-access-to-vendors
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Assign employees to work crews
You must set up employees as TimeTrack users in the Signature Registered Users Setup window (Microsoft Dynamics GP 
> Tools > Setup > TimeTrack > Registered Users) before you can assign individuals to work crews. After employees are set 
up as TimeTrack users, use the Work Crew Employee Setup window to assign individuals to work crews.

In Microsoft Dynamics GP, choose Microsoft Dynamics GP > Tools > Setup > TimeTrack > Work Crew Employees. The 
Work Crew Employee Setup window is displayed.
Select a work crew.
In the Signature Registered Employees grid, select an employee and choose Insert to add the employee to the 
work crew. To remove a crew a member, select the employee in the Crew Members grid and choose Remove.

Set up job safety audit (JSA) information
Use this information to set up JSA task lists and task codes in Microsoft Dynamics GP. For more information, see the 
Service Management documentation.

For information about the JSA setup options in MobileTech Administration, see Job Safety Tasks (page 35).

Create an unsafe work environment indicator
If technicians determine there are safety issues that could prevent them from performing work, those technicians can 
alert the office that the site is unsafe and provide a record in the host system. 

To allow this, create an appointment status for unsafe work environments. For example, if you create an appointment 
status of UNSAFE, the technician could change the appointment status to UNSAFE and send the appointment back to 
the host system. The appointment would be removed from the technician's device after syncing.

In Microsoft Dynamics GP, choose Microsoft Dynamics GP > Tools > Setup > Service Management > Lookup Setup > 
Service > Appointment Status. The Appointment Status Setup window is displayed.
Enter a name for the appointment status.
Complete the remaining fields, as necessary, and choose Save.

Create the JSA task list type
When you create a task list type of JSA, you indicate that the tasks are safety tasks that are handled differently than 
other task types. All job safety task lists must have a task list type of JSA.

In Microsoft Dynamics GP, choose Microsoft Dynamics GP > Tools > Setup > Service Management > Lookup Setup > 
Tasks > Task List Types. The Task List Type Setup window is displayed.
Enter JSA and choose Save.

Create task codes for JSA tasks
You must create task codes that will be assigned to JSA task lists. The task codes define the specific conditions that a 
technician must validate before starting work on a service call.

If an employee who was a member of a work crew has an Inactive status, choose Synchronize in the Work Crew 
Employee Setup window. The employee is removed from the work crew.


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For information about recommended naming conventions, see Naming conventions for JSA task list IDs and task 
codes14.

In Microsoft Dynamics GP, choose Microsoft Dynamics GP > Tools > Setup > Service Management > Lookup Setup > 
Tasks > Task Codes. The Task Code Setup window is displayed.
Enter a task code and description.
You can also set up responses for each task. For information, see Set up responses for JSA tasks15.
Complete the remaining fields, as necessary, and then choose Save. Repeat these steps for each task code that 
you need to set up.

Set up responses for JSA tasks
When you create task codes, you can also set up responses so technicians can respond to the tasks in the task list.
You can use either List or Text response types.

In Microsoft Dynamics GP, choose Microsoft Dynamics GP > Tools > Setup > Service Management > Lookup Setup > 
Tasks > Task Codes. The Task Code Setup window is displayed.
Enter or select a task code.
Choose the Responses button. The Task Responses Setup window is displayed.
Select a response type: 

List: Provides the user with a drop-down list of user-defined responses in the service call.
Text: Provides the user the ability to enter a text response. Text responses are stored in the database, but 
are not displayed on the JSA report.

Enter a label for the response field. This typically is the condition that must be validated or the question that 
must be answered, such as Is there a sign-in and sign-out procedure?
If you selected the List response type, choose the Responses ID link. The Task Responses List Setup window is 
displayed.

Enter or select a responses list ID.
Enter Yes and No as the values that will appear in the list. Depending on your organization's policies, you 
can enter just Yes and No, or you can enter a longer value by typing Yes or No, a space, a hyphen, another 
space, and then the description. Example: Yes – Sign in and out using the appropriate procedure.

 For more information about setting up responses, see "Setting up task responses" in the Service Management 
documentation.
Complete the remaining fields, as necessary, and then choose Save. Choose Save again in the Task Code Setup 
window.

Skill levels have no effect on JSA task codes.

The Text option can only be used once per task code and only as the last non-None row. All 
further rows will be set to None.



Only values that include more than three characters are displayed in the Risk control measures section 
of the JSA report. Values of Yes and No will not be displayed.


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Create JSA task lists and add task codes
For each category of safety tasks, you must specify an integer as the task list ID. For example, if the category 
is Electrical, the ID could be 1 and have a description of Electrical.
Task list IDs must be numeric. For information about recommended naming conventions, see Naming conventions for 
JSA task list IDs and task codes16.
All job safety task lists must have task list type of JSA.

In Microsoft Dynamics GP, choose Microsoft Dynamics GP > Tools > Setup > Service Management > Lookup Setup > 
Tasks > Task Lists. The Task List Maintenance window is displayed.
Enter a task list ID and description. 

Select JSA as the task list type.
Complete the remaining fields, as necessary, and then choose Tasks. The Task List Detail window is displayed.
Select the task codes to include in the list and choose Insert to add them to the task list. For more information 
about using the fields in this window, see "Creating a task list" in the Service Management documentation.
Choose OK, and then choose Save in the Task List Maintenance window.

Naming conventions for JSA task list IDs and task codes

When you set up JSA information, you will create task codes, and then assign those task codes to the JSA task lists that 
you create.

Task list IDs must be numeric, and we recommend that you use a naming convention that groups together the task 
codes that will be assigned to each JSA task list. This lets technicians navigate through categorized lists of tasks in the 
appointment details, so they can respond to the tasks without having to open and save each task individually.

For example, suppose you plan to create task lists for servicing electrical, elevator, and HVAC systems. You might 
categorize them in this way.

Task List ID Description

1 ELECTRICAL TASKS

Task Code Description

1.1 Are you working near energized power?

1.2 Can electrical work be done with the power off?

1.3 Does live power work involve removal, replacement, etc.?

Task lists for personal protective equipment must have an ID of 99. In 
addition, JobSafetyTaskListType must be set to JSA in the Job Safety Tasks area of the setup options. 
Otherwise, values will not be displayed in the Personal Protective Equipment section of the JSA report.



https://wennsoft.atlassian.net/wiki/pages/resumedraft.action?draftId=6620038#SetupInformationinMicrosoftDynamicsGP-naming-conventions
https://wennsoft.atlassian.net/wiki/pages/resumedraft.action?draftId=6620038#SetupInformationinMicrosoftDynamicsGP-naming-conventions
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Task List ID Description

2 ELEVATOR TASKS

Task Code Description

2.1 Are you working in a confined space?

2.2 Is there a safe emergency escape route from the work area?

2.3 Is lighting in the work area adequate?

Task List ID Description

3 HVAC TASKS

Task Code Description

3.1 Are you in a noisy environment?

3.2 Are you using a ladder or stepladder?

3.3 Are you working above 6 feet in height?

3.4 Are you within 3 feet of a roof edge?

Set up sublocations for barcoding
The barcode functionality is available for equipment, sublocations, and inventory. The supported barcodes are those in 
the ZBar library including: EAN-13/UPC-A, UPC-E, EAN-8, Code 128, Code 39, Interleaved 2 of 5, and QR Code. 
The barcode feature allows the field technician to:

Scan a barcode from a piece of equipment or a sublocation with the MobileTech device for easy navigation and 
accessibility to the assigned tasks.
Scan a piece of equipment to add it to an existing service call or to add it to a new service call.
Scan and record a barcode for a new piece of equipment at a customer site.
Scan a barcode for an existing piece of equipment, if a barcode doesn't already exist, to update the equipment 
record with the barcode scanned.
Automate the entry of an inventory part number during the appointment completion process.

Before technicians can scan a sublocation barcode from the Service Calls or Appointments lists, you must select 
sublocation validation in Service Management and set UseBarcoding to True in MobileTech Administration.

In Microsoft Dynamics GP, choose Microsoft Dynamics GP > Tools > Setup > Service Management > Module Setup > 
Service Options. The Service Options window is displayed.
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In the Premier Options section, mark Use Validation for Sublocations, and then choose OK. This makes 
the Sublocations button available in the Location window.
In Microsoft Dynamics GP, choose Cards > Sales > Customer. Enter or select a customer. Choose 
the Location button, enter or select a location, and then choose the Sublocations button. The Sublocation 
Maintenance window is displayed.
If a barcode is associated with the sublocation, add a sublocation barcode.
Save the changes.
In MobileTech Administration, choose Setup Options. Under Mobile Device Global Settings, make 
sure UseBarcoding = True.

XOi Deep Linking Setup
XOi Deep Linking allows users to click a link in MobileTech to open XOi's Vision app. Within the Vision app, users click a 
Return button to go back to MobileTech.

XOi Integration Setup in Schedule (page 74)
Overview (page 75)

XOi Integration Setup in Schedule
The XOi Integration Setup in Schedule is used by XOi Technologies to access a specific API that is used by XOi for the 
Deep Linking workflow feature. This information must be provided to XOi. (A Schedule Administrator can print the 
contents of this window from a browser.) The XOi Integration Setup section is conditionally enabled if the See feature is 
registered for MobileTech, otherwise this tab is hidden. After setting up the integration, two XOi user roles are created 
and are hidden from the User Roles window. The XOi user is hidden from the User Detail window.

XOi Deep Linking is:

Compatible with MobileTech v8 and higher.
Available for supported versions of Signature 2016 and Signature 2018.
Enabled in Schedule 4.5 and higher.

To set up the XOi Integration in Schedule:

In Schedule, select the menu icon and then select Administration.
Select the Integrations tab.
Under Account Detail:

User Name
Displays the user name for the XOi integration.
Password
Enter the XOi password.
Confirm Password
Enter your XOi password again. If you've mistyped the password, an error message displays that the 
passwords don't match.

Under Integration Details, complete the following fields:
API URL
Displays the Schedule API URL. 

IMPORTANT

XOi Deep Linking must be first be enabled in MobileTech Admin. See XOi Integration (page 44) in the MobileTech 
8.0 Installation & Administration Guide for more information.


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Signature Version
Displays the current Signature major version.

In the Active Dynamics Companies section, all active companies' details (Company Name and Company ID) 
are shown as more than one company may need to be set up with XOi Technologies.

Overview
With XOi Deep Linking turned on and XOi integration set up in Schedule, this is what you can expect to happen with 
Schedule service appointments. In XOi's Vision app, a job is the same as a service appointment in MobileTech.

A new service call with an appointment is created in Schedule, Signature, or MobileTech. The appointment is 
assigned to a technician and scheduled.

XOi polls for new appointments that are scheduled and assigned or completed for technicians whose email 
addresses are also valid XOi Vision email addresses. 
In XOi Vision, the job is created automatically based on the service appointment in Service Management. 
The Schedule API creates several read-only notes that are attached to the service appointment. 

XOi Site History
This internal note contains the hyperlink to the Job Activity in the Vision app. This note is required to 
display the XOi Site History field on the service appointment.
XOi Workflow 
This internal note contains the hyperlink to the job. This note is required to display the XOi Workflow field 
on the service appointment.
XOi Resolution 
This note contains the URL to view any related photos and/or videos on the Vision website and is 
included on the Call (or Appointment) Summary report.
XOi Transcript 
This note contains Vision's video transcription.

Using MobileTech
Completing Administrative Tasks and Procedures (page 82)
Information processing in Microsoft Dynamics GP (page 76)

The Active Dynamics Companies list includes all active Dynamics companies that may or may not have 
Signature and/or Schedule installed.



If the service appointment is created in MobileTech, the technician will need to sync their device to 
send the appointment to the back office. The XOi integration will run and the notes will be added to the 
appointment in the back office and will be available when the technician syncs again, however it could 
take a while for the XOi Vision notes to be created (based on the XOi polling cycle, syncing of data, etc.).



This note is generated after the Vision platform processes the audio, which may be hours after 
the appointment is completed, so the XOi Video Transcription note will not be included on the 
Appointment Summary report. There may be up to three XOi Transcript notes, named XOi 
Transcript, XOi Transcript 2, and XOi Transcript 3.


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Information processing in Microsoft Dynamics GP
This section provides information about how host system users process information that was entered in MobileTech.

Approving/Rejecting Timesheets (page 76)
Process Additional Work Requests for a Technician (page 76)
Process Contact Management (page 77)
Process Drop Ship Purchase Order Receipts (page 78)
Process Field Invoices and Payments (page 80)
Process Inventory and Non-Inventory Item Transactions (page 81)
Process Purchase Orders in Service Management and Purchasing (page 81)

Approving/Rejecting Timesheets
For information on how manager's approve timesheet transactions, in the TimeTrack User Guide see Approving or 
rejecting TimeTrack transactions.

Process Additional Work Requests for a Technician
When additional work requests arrive from a technician, process those requests by using the Mobile Additional Work 
window in Service Management.

In Microsoft Dynamics GP, choose Inquiry > Service Management > Mobile Additional Work Inquiry. The Mobile 
Additional Work window is displayed.
Mark the checkbox next to an additional work record and use the following buttons for the additional work 
requests. You can also choose Mark All or Unmark All to include or exclude all requests.

Process: When you finish reviewing a request, choose Process. The user who processed the request is 
listed in the Followed Up By field in the Mobile Additional Work window that is opened from the Service 
Call window.
Redisplay: Refresh the window if other work requests have been created since you opened the window. 
The window is refreshed every time you open it.
Print: Print the selected work requests. To print all work requests, choose Mark All to select all the 
requests.
Delete: Delete the selected work request. When you delete a request, no record of it remains in the 
system. You can print a list before deleting, if necessary.

If a technician has added an attachment to an additional work item in MobileTech, the icon changes from a 
paperclip to a paperclip attached to paper. Once the additional work request is handled the attachment remains 
with the additional work record. To view the attachment, focus on the additional work row and then choose the 
additional work icon to open the Document List window. This window displays the following information from 
the additional work item:  

Service Call
Appointment
Additional Work Date
Additional Work Time

Choose the attachment listed in the scrolling window and then choose to Edit or Display. You can also add a file to this 
additional work record by choosing Add.
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Process Contact Management
Location Contacts that are entered in MobileTech by a technician must be reviewed and processed before the contacts 
are added and/or updated in Signature. Processing these contacts will add a master Local contact and assigns the 
contact to the location.

Technicians can add the following Contact information for a customer in MobileTech:

Contact Name (required)
Email Address (required)
Phone Number
Phone Type
Role - Technicians can choose an existing role or add on-the-fly. See below for information on how to add the 
role type to Signature.

Processing the contacts
If an existing contact is edited in MobileTech, you may see more than one row in the Mobile Contacts window. For 
example, if a contact has three telephone numbers associated and the contact's role has been updated, you will see 
three rows of contact information to be updated; one row for each phone number. This is because MobileTech sees this 
information joined into a single entity and Signature Service Management sees this as multiple entities. 

In Microsoft Dynamics GP, choose Inquiry > Service Management > Mobile Contacts.
The Mobile Contacts window displays contacts added in MobileTech.
Review the following information:

Customer 
Location (required)
Contact Name (required)
Phone Number
Phone Type
Email Address
Role - If the technician created a new role for the contact, an error message "This is not a valid Contact 
Role Type." displays in the Error Message field. To clear the message, do one of the following options, 
followed by choosing the Redisplay button:

Clear the role field by highlighting the field contents and pressing Delete on your keyboard.
Edit the role name in the field to match an existing role.
Add the new role by marking the Contact checkbox and then selecting the Role zoom to open the 
Role Type Setup window. The message "This role type does not exist. Do you want to add it?" 
displays. Mark Yes , enter a description, and then choose Save . Close the Role Type Setup 
window. 
Choose an existing Role Type by marking the Contact checkbox and then selecting the Role Type 
lookup to open the Role Type Lookup window. Select the Role Type and then choose Select. 

Created User - Technician who added the contact.
Contact ID
Phone ID
Error Message

In the Mobile Contacts window, you can process the contacts individually by marking the contact checkbox and 
then choosing Process or you can choose the Mark All button and then choose Process to add all the contacts. 
Contacts will no longer display in the Mobile Contacts window once they are added to Signature.



Using MobileTech

78

•
•
•
•
•
•
•

•
•

1.

2.

3.

4.

5.

Buttons on this window

Mark All - Marks all Contact checkboxes.
Unmark All - Unmarks all Contact checkboxes.
Process - Adds the marked contacts.
Redisplay - Refreshes the display.
Delete - Deletes marked contacts.
Cancel - Cancels the process.
Go To - Choose this and then select Contact Management to open the Contact Setup window. (This window 
opens empty, no data automatically fills in this window.)

Process Drop Ship Purchase Order Receipts
A drop-ship purchase order assigned to a job or service call in the back office. This creates a committed cost on the job 
or service call. A technician is able to receive all or part of this drop-ship purchase order when completing the job or 
service appointment. Note that the technician will need to sync the device after the drop-ship purchase order has been 
created. After the technician receives the drop-ship purchase order and syncs the device, the drop-ship purchase order 
receipt is sent back to the server. To process the receipt, the purchasing batch MOBILEYYMMDD (year, month, day) will 
need to be posted from the Purchasing Batch Entry window.

Receive items in MobileTech from a Drop-Ship Purchase Order (page 78)
Processing the Drop-Ship Purchase Order Receipt (page 79)

Receive items in MobileTech from a Drop-Ship Purchase Order
After drop-ship purchase orders are committed for a job or service call, you can use the PO Receipts pane to receive 
items from purchase orders. You can also receive partial shipments.

Choose Appointments  . Select an appointment and choose Complete.

Choose the PO Receipts   tab to display the receipts that are processed and assigned to the appointment. 
(Processed receipts are not editable.)
To view all receipts available for the service call or job, but not assigned to the appointment or processed, 
choose the Refresh icon in the top right corner. These receipts will be available on your device until you sync the 
device.
Select an unprocessed purchase order receipt to open the PO Receipt pane. (An unprocessed receipt displays as 
Processed: No.)
Enter information in these fields, as necessary.

Field Description

PO Number The purchase order number for the job appointment. You can't change this value.

Vendor The vendor that is associated with the appointment and purchase order. You can't 
change this value.

Processed Displays Yes or No to indicate if you received items that are listed on the purchase 
order receipt.
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Field Description

Service Call The appointment number associated with the purchase order. You can't change this 
value.

Transaction Date* The date when the purchase order items were received. The current date is displayed 
by default, but you can change it.

Freight Amount You can optionally enter the freight charges for items on the purchase order from the 
invoice.  

Misc Amount You can optionally enter the miscellaneous charges for items on the purchase order 
from the invoice.

Vendor Doc#* Enter a number or identifier for the vendor document. For example, you could enter 
the number of the packing slip or other information that might be included with the 
shipment.

*Required field
Choose the Receipt Detail bar to display the PO Receipts line detail list, where the line items are displayed for 
the purchase order receipt.

To receive all items for all line items, choose Receive All to mark the Received checkbox for each line.
To receive items for only one line, select the line and toggle Received to Yes.

If the quantity of items that was delivered differs from the quantity that was originally on the purchase order, 
you can change the value in the Quantity field to reflect the number of items that were delivered. The number of 
delivered items can be less, the same, or more than is indicated on the purchase order. 

Choose the Save   icon.
On the next device sync, the receipt is sent to the back office.

Processing the Drop-Ship Purchase Order Receipt
Once the device syncs, the receipt is sent back to the server. The back office can now post the batch from the 
Purchasing Batch Entry window. For more information on posting the batch, see Using Microsoft Dynamics GP Purchase 
Order Processing in the Service Management and Job Cost User Guides.

In Microsoft Dynamics GP, go to Transactions > Purchasing > Purchasing Batches.
In the Purchasing Batch Entry window, use the Batch ID lookup to select the drop-ship purchase receipt in the 
MOBILEYYMMDD batch.
To print the Edit List, select Print from the menu bar. 
To post the batch, select Post from the menu bar.

After the purchase order receipt is synced, you can't change the quantity. To process the remainder of 
the items, you must again choose the PO Receipt tab and choose the sync icon to view the 
purchase order and receive the remainder of the order.


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Process Field Invoices and Payments
Invoices and payments that are generated from MobileTech are processed and posted in Microsoft Dynamics GP and in 
Service Management using the same tasks and procedures for invoices that are created in Service Management.

If you have set up Third Party Billing in Service Management, the field invoice respects the Bill to information provided 
in the Service Call. For more information about setting up Third Party Billing, see "Using Third Party Billing" in Service 
Management help.

If your organization uses Field Invoicing and Field Payments, when technicians create an invoice on a device after they 
complete appointments for a service call, the technicians can preview and verify the information on their devices, 
generate a field invoice, and then sync it to the host system. If they are authorized to do so, technicians can also collect 
payment for the invoice.

After invoices or payments are received in the host system, the invoice is attached to the service call. The Receivables 
Management batch and the transactions are automatically created. This batch has a prefix of FLDINVC<current system 
date> and can be posted just like any other batch.

Field invoicing is available only if Field Invoicing and Field Payments is registered, and UseFieldInvoicing = True in the 
setup options in MobileTech Administration. Field payments are available only if Field Invoicing and Field Payments is 
registered, and if both UseFieldInvoicing and UseFieldPayments = True in the setup options.

For information about how to create field invoices and collect payments on a device, see Field Invoices and Customer 
Payments17 in the MobileTech Help. For information about how to process invoices and payments in the host system, 
see the Service Management documentation.

If a technician's time card in TimeTrack has been committed by a back-office user (such as someone in the 
Payroll department), and this occurred before the service call was completed and the field invoice was 
generated, that labor expense will not be displayed on the field invoice.The labor expense will be displayed if 
the time card has not been committed, or if it has been committed and the expense transaction has been 
posted.



MobileTech is not integrated with a credit card vendor. If you want technicians to be able to accept credit card 
payments from customers, you must set up credit card information for your company in the Credit Card Setup 
window in Microsoft Dynamics GP (Microsoft Dynamics GP > Tools > Setup > Company > Credit Cards). For more 
information, see the Microsoft Dynamics GP Help.



•

•
•
•

Field invoice restrictions
Field invoices created in MobileTech have the following restrictions in Service Management:

Regardless of the Invoicing with Cost Options in Invoice Options (Setup > Service Management > Invoice 
Setup > Invoice Options), if a field invoice is created in MobileTech, all unposted costs associated with 
the MobileTech invoice must be posted before the invoice, or the batch containing the invoice, can be 
posted.
Field invoices cannot be:

Deleted or voided.
Edited, including from the Receivables Management batch.



https://wennsoft.atlassian.net/wiki/spaces/MT80/pages/6619960/Field+Invoices+and+Customer+Payments
https://wennsoft.atlassian.net/wiki/spaces/MT80/pages/6619960/Field+Invoices+and+Customer+Payments
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Process Inventory and Non-Inventory Item Transactions
Use the Mobile Inventory window to process inventory transactions that are entered by technicians.

In Microsoft Dynamics GP, choose Inquiry > Service Management > Mobile Inventory Inquiry. The Mobile Inventory 
window is displayed.The items and part numbers that were entered by technicians for service calls are 
displayed. To delete a record, select the item or part and choose Delete.
Choose Process to process the transactions.

Transactions that are processed successfully no longer appear in the window. Transactions that are not processed 
successfully are displayed on the Mobile Inventory report. To print the report, choose Print.

Process Purchase Orders in Service Management and Purchasing
A purchase order that is entered in MobileTech by a technician must be reviewed, committed, and processed in Service 
Management and Microsoft Dynamics GP Purchasing before costs that are associated with the purchase order can be 
processed in the system.

Process purchase orders that were entered by technicians (page 82)
Post purchase orders in Microsoft Dynamics GP (page 82)

•

•
•
•

•

Adjustments such as credit memos, amount changes that constitute adjusting entries, etc., must be 
made manually using separate transactions.
Costs associated with a field invoice:

Cannot be deleted.
Should not be edited. Regardless of a cost edit, billing amounts will not be updated.

The service call ID cannot be changed or removed from any unposted cost transaction that has an 
associated field invoice number.

Editing costs associated with a field invoice may result in inaccurate accounting 
entries.



If you use Sales Order Processing (SOP) invoicing, an item number cannot exist as both an inventory item and 
a non-inventory item. If an item in the Mobile Inventory window has the same item number as an inventory 
item, but it was sent from MobileTech as a non-inventory item, the location code will be blank and the item 
will not process successfully. You will receive an error saying that the item number/location code does not 
exist in Inventory. You must delete the line from the Mobile Inventory window and process the item correctly in 
SOP for the service call.



You cannot process individual lines or items. All transactions that are displayed are processed at the same 
time.



To allow technicians to quickly work and provide information to customers in the field, purchase orders for 
service invoices and field invoices do not include taxes unless the invoices have been received in the 
Purchasing module of Microsoft Dynamics GP.


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Process purchase orders that were entered by technicians
After a purchase order has been synced with the host system, you can view and process the purchase order in Service 
Management.

Costs that are associated with a purchase order are displayed in Service Management as committed costs on the service 
invoice.

To view and process purchase orders that were sent from MobileTech, in Microsoft Dynamics GP, choose Inquiry 
> Service Management > Mobile Purchase Order Inquiry. The Mobile Purchase Order window is displayed.
You can choose Print to print the Mobile Purchase Order report, which displays information about the purchase 
orders that need to be processed.
Select the transactions from MobileTech to process and choose Process.
Choose Redisplay to update the list of purchase orders that were submitted by technicians.

Post purchase orders in Microsoft Dynamics GP
To post purchase order transactions in Microsoft Dynamics GP that originated from MobileTech, in Microsoft 
Dynamics GP, choose Transactions > Purchasing > Purchase Order Entry. The Purchase Order Entry window is 
displayed.
In the PO Number field, select a purchase order.
View and change other information as needed. For example, you can add freight, tax, and miscellaneous 
amounts to the purchase order. 

Choose Commit. Purchase orders that are committed are available in MobileTech so that technicians can enter 
purchase order receipts for inventory items.

Completing Administrative Tasks and Procedures
This section provides information about tasks and procedures that administrators might occasionally have to complete 
in MobileTech Administration.

Access Resco Cloud Dashboard (page 82)
Change a Resco Administrator Password (page 83)
Monitor Processes and Tasks by Using Integration Monitor (page 83)
Refresh Specific Lookups (page 83)
Using Report Maintenance (page 84)
View User Device Information and Sync Activity (page 84)

Access Resco Cloud Dashboard
The Resco Cloud Dashboard is the landing page when you log into your company on Resco Cloud. Access the Resco 
Cloud Dashboard in MobileTech Admin by going to Tools > Launch Resco Cloud Dashboard. For more information about 
the Resco Cloud Dashboard, go to https://docs.resco.net/wiki/Resco_Cloud.

A purchases tax schedule for a company must be set up in the Company Setup window (Microsoft 
Dynamics GP > Tools > Setup > Company > Company) before you can process taxes for purchase order 
receipts.



https://docs.resco.net/wiki/Resco_Cloud


Using MobileTech

83

•

•

•

1.

2.

3.
4.

1.
2.

3.

On the Resco Cloud Dashboard, you have access to:

Woodford
Woodford is a browser-based configuration tool for managing MobileTech. It allows you to manage connected 
mobile devices and to customize versions of MobileTech dedicated to a particular set of users. See Set Up 
Woodford (page 54) for MobileTech-specific information.
Admin Console
Admin Console is a server administration center used to configure and manage your Resco Cloud server. 
Sync Dashboard
The Sync Dashboard provides visibility into synchronization performance by identifying sync errors, sync 
duration, and metrics like average sync time.

Change a Resco Administrator Password
If you or another administrator forgets an account password, you cannot retrieve the existing password, but you can 
change it.

In MobileTech Administration, choose Tools > Change Resco Administrator Password. The page displays a list of 
all the system users in the configuration database.
Select the administrator whose password you want to change. The Databases for Account area displays a list of 
all the company databases where the password will be changed.
Enter and confirm the new password.
Choose Change Password. The password will be changed for all the company databases that were listed in the 
Databases for Account area.

Monitor Processes and Tasks by Using Integration Monitor
MobileTech Integration Sync monitors changes in the middle-tier database that are made in Microsoft Dynamics GP.

When you installed the integration sync, you entered a task frequency. This is how frequently the integration sync 
process runs to update changes that are made in Microsoft Dynamics GP.

To view changes that are waiting to go into the middle-tier database, in MobileTech Administration, choose Integration 
Monitor.

Refresh Specific Lookups
You can sync individual lookups in MobileTech to refresh a subset of lookups without loading all data.

In MobileTech Administration, choose Tools > Refresh Lookups.
Mark the checkbox next to the lookups that you want to refresh. 

Choose Refresh.

This option is available only for users who belong to the SysAdmin role in SQL Server. These users can be 
Windows or SQL users.You can change the password for only one MobileTech administrator at a time.



When you mark a lookup, other associated lookups might be marked, as well, if there are dependencies 
between the lookups. For example, if you mark the checkbox for a child lookup, the parent lookup 
automatically is marked because that must be refreshed, too.


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Using Report Maintenance
Use Report Maintenance to determine why a report has a status of FAILED in the middle-tier report table. Note that the 
report also must have a related appointment in the middle-tier appointment table to display in this window. After fixing 
the error(s), you can choose Process to attempt to re-process the report. Time-out errors can be fixed by simply 
processing the report again in this window.

To use Report Maintenance:

In MobileTech Admin, choose Report Maintenance.
Reports with a status of FAILED in the middle-tier display in the window.
Optional: The reports that display can be filtered by choosing a column name from the Column drop-down. 
Enter a partial or whole word and then choose Search.
The scrolling window displays the following information:

Service Call ID/Job Number
Appointment
Technician
Customer
Location
Report Type
Created On date/time
Error Message 

Optional: Choose a column heading to sort the displayed information.
Review the error message. You may need to use the horizontal scroll bar and/or resize the column to view the 
entire message.

If the report has a time out error, continue with step 6.
For all other errors, you must fix the error(s) and then return to this window.

Mark the report(s) to process, either individually or choose the checkbox to the left of the Service Call/Job 
column to select all.
Choose Process. If the report fails again, it will be displayed in the Report Maintenance window, otherwise the 
report will be attached to the appropriate Signature window.

View User Device Information and Sync Activity
You can use MobileTech Administration to view information about the devices that technicians are using, and the sync 
activity on those devices.

In MobileTech Administration, choose Users.
In the Synced Devices area, you can see a list of synced devices. For each device, you can see which version of 
Mobile CRM is installed, when it was last synced to the host system, the security policy for the device, and the 
operating system that is installed on the device.

This is not a reprint feature. 

To view the entire error message, you may need to use the scroll bar at the bottom of the 
window to scroll to the right. You may need to resize the column to view the entire message.


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Sync Error Troubleshooting
These are some of the common Labor Sync Error messages that your technicians may receive when syncing their 
devices. Use the table below to troubleshoot and fix these errors.

Error Message Description Fix

A valid labor rate does not 
exist for this position/pay 
code or department/
position/pay code 
combination.

This error displays when the labor rate group 
combination assigned to the Customer is not set up with 
the pay code the technician was using.   Labor Rate 
Groups must be configured with the proper combination 
of position, department, and pay code in order for Labor 
to be transacted successfully.   If the technician uses one 
of these pay codes that has not been configured 
correctly they may see this particular error message 
preventing them from syncing.

Adding the appropriate 
Labor Rate Group 
combination will resolve 
this sync error.

The service call entered is 
either missing or closed. 
Enter another service call 
ID.

This error displays when there is stale data on the 
device.   If a technician is getting this error, the back 
office has likely deleted or closed the service call that 
the technician is trying to enter labor towards.

A DELETE DATA from the 
device should clear this 
old data from the device 
and resolve this sync 
error.

This batch is marked to be 
committed and cannot be 
edited.

This error displays when the batch is marked for 
processing Payroll Posting.

The TimeTrack or Payroll 
batch will need to be 
unmarked in order for the 
technician to be able to 
sync successfully.

The fiscal period for this 
date is not part of a fiscal 
year. Enter a new date.

This error is due to the technician entering a Labor 
transaction that has a “week-ending” day in a fiscal year 
that is not currently open.   This is a common error that 
occurs for technicians in the last week of the year that is 
due to the upcoming Fiscal Year not being open yet.

To check if the current or next fiscal year is open, go to 
Microsoft Dynamics GP > Tools > Setup > Company > 
Fiscal Periods to open the Fiscal Period Setup window.

Opening the Fiscal Period 
will allow the Technicians 
to sync this Labor 
successfully.

This cost code does not 
exist. Enter another code.

This error is stating the Cost Code used in the 
transaction does not exist or does not match the system 
data.   This could translate to data mismatches or stale 
middle-tier data.

Adding, updating, or re-
Loading (Load Data) the 
Cost Code data for the 
transaction will resolve 
this issue.
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Error Message Description Fix

Unknown error number 
XXXXX.

This particular error is due to the system ERROR tables 
(SVERRORS, WSERRORS, JCERRORS) being empty in the 
company database. TimeTrack requires these tables to 
be populated.  This can sometimes happen after a 
Signature upgrade where the Signature Utilities 
program was not launched as an Administrator.  

Re-populating these 
tables should resolve this 
issue and Technicians can 
resync to push the 
transactions through to 
the host system.
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Contact Information
Support & Sales

Support Phone: 262-317-3800
Email: support@wennsoft.com
Hours: Normal support hours are 7:00 a.m. to 6:00 p.m. Central Time. After-hours and weekend support is available for 
an additional charge. Please contact WennSoft Support for more information.

WennSoft will be closed in observance of the following holidays: New Year's Day, Presidents' Day, Memorial Day, 
Juneteenth, Independence Day, Labor Day, Veterans' Day, Thanksgiving Day, the Day after Thanksgiving, Christmas 
Day, and the Day after Christmas.

Support Plans 
We're committed to providing the service you need to solve your problems and help your team maximize productivity.

We offer several Signature Enhancement and Support Plans to meet your needs and Extended Support Plans for retired 
product versions available at https://www.wennsoft.com/wsportal.

Sales 
Phone: 262-317-3700 
Fax: 262-317-3701

Address
WennSoft Headquarters
1970 S. Calhoun Rd.
New Berlin, WI 53151-1187

Phone: 262-821-4100 or 866-539-2228
Email: info@wennsoft.com
Website: www.wennsoft.com 
Office hours: Monday through Friday from 8 a.m. to 5 p.m. Central Time.

https://www.wennsoft.com/wsportal.
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