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TimeTrack Introduction

Signature TimeTrack streamlines labor, expense, and travel cost tracking within Signature Service Management, Job
Cost, and Equipment Management.

TimeTrack:

« Allows you to monitor and analyze costs to help you make accurate and timely business decisions. TimeTrack
works like an electronic time card. Employees can charge time and expenses to jobs and service calls on a daily
basis. Non billable time, or time not assigned with a job or service call, can also be entered. Employees can also
charge time to fixed assets.

« Allows supervisors and managers to quickly review time cards and simultaneously post transactions to billing
and payroll. This results in a faster billing cycle, better cash flow, and quicker management reporting cycles.

« Includes flexible labor cost methods and labor classifications to accommodate government, construction, and
other complex project tracking and billing requirements. Certified payroll reporting and union reporting are
available within Job Cost.

«+ Provides useful cost-tracking features, including the ability to enter cost transactions for Service Management
and Job Cost in one window.

« Allows you to tab through required fields to enter time card data. This feature makes it easier and faster to enter
data when many time card entries are required.

If you will be printing the Microsoft Dynamics Worker's Compensation Summary report (Reports > Payroll > Period-

End) and you are using Rate Classes in Job Cost, you will need to up the Job Cost Rate Class amount so that it takes into
account the pay factor for the pay codes set up in Microsoft Dynamics GP. For example, if you are creating an overtime
rate class and in Microsoft Dynamics GP you've created a standard pay code that is $10/hr and then create an Overtime
pay code that has a pay factor of 1.5 and is based on the standard pay code, you will need to enter $15 for the Overtime
rate class.

Posting Flow Documents

Posting flow documents are available to aid your understanding of system procedures, table relationships, and data
flow. These documents can be found in Posting Flow Documents & Table Changes®.

Optional features

This documentation describes all the features you can purchase with TimeTrack. Optional features are noted in the
description. To view the features that you have purchased and registered, choose Help > About Signature, then choose
Modules. To purchase the optional features below, contact WennSoft Sales.

« Export Interface
« Import with Validation
«+ Salaried Time Entry

Buttons, Symbols, and Indicators

« Symbols and Buttons (page 2)
« Indicators (page 5)

1 https://wennsoft.atlassian.net/wiki/spaces/Signature2018R4/pages/7328584
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Symbols and Buttons

The following symbols and buttons are used in windows throughout Service Management, Job Cost, TimeTrack, and
Equipment Management.

Symbol/Button Description

- Account analysis button
’-&'j‘h Use the account analysis button to check or change the analysis codes to which

the posting amount is to be allocated. The account analysis button is available
when an amount is to be posted to a ledger account that has been set up for MDA.

Appointment history button

The appointment history button in the Service Call Appointments window opens
the Appointment History window, listing all changes that were made to the
appointment. The button will be present if the Keep Appointment History
checkbox was marked in the Service Options window.

Arrow buttons
Use the arrow buttons to rearrange items in a scrolling window.

(][+]
pong

Attached image button

Use the attached image button to attach documents to a record. If a record has
attached documents, the button shows a paper clip attached to a piece of paper.
If the record does not have attached documents, the button shows a paper clip.
Document examples include purchase orders, diagrams, or job change orders.
Bitmap file format (.BMP) is required unless you have purchased the Advanced
Document Management feature. This feature allows numerous file formats
(e.g.,.DOC, .XLS, .TIF) to be attached.

==

Best technician button

Choosing the best technician button selects the next available, qualified
technician for a service call. This allows you to schedule a technician for a service
call as soon as possible.

4 4 b » Browse buttons
Browse buttons help you scan information, such as customer records and
location records. You'll be able to browse through records using the sorting
method selected for that window. This feature helps you locate records quickly.

ﬂ Camera button
Use the camera button to view images attached to an equipment record.



Symbol/Button Description

R

Equpment Cate
Equpment Type I IP

8

Ellipsis button

If the Project Manager's Advisor feature is registered, the ellipsis button is
available in certain windows. Use the button to open the Project Job Summary
window.

Eraser button
Use the eraser button to remove items from a list.

Expansion button
When you choose an expansion button, the detail for the selected field is
displayed.

Folder button
Use the folder button to browse to find a file.

Go button

The Go button is used to quickly locate items in a scrolling window. To use the Go
button, enter a partial entry in the field and choose the green arrow. The scrolling
window will be positioned on the first occurrence of your entry.

Go to button
Use the Go To button to open the Go To menu, which lists windows you can open.

The items on the Go To menu in the Equipment Manager window are user-
definable.

Item information button
Displays additional information about the selected item.

Link (zoom)
Alink appears as an underlined prompt for a field. Choose the link to open a
window containing additional information for this item.

Link button

Use the link button to link a branch in Equipment Management to a branch in
Service Management. Choosing this button in the Equipment Manager window
will populate the customer, address ID, and equipment ID fields to the branch in
the Service Management. If the branch is not linked, the Link button displays with
ared slash.



Symbol/Button Description

r Lookup button

l A lookup button indicates a lookup window is available. When you choose a
lookup button, a list of lookup items displays in a window. Using lookup windows
helps you to quickly enter and validate information.

New call button
F"E Use the new call button to create a new service call in Service Management.

Next available button

The next available button is used to calculate the technician's next available time
slot for performing an appointment. The button is disabled if you have more than
one appointment on the call or if the service call date and appointment date
don't match.

Notepad button

The notepad button makes it possible to attach important information directly to
a window or record so it's easily accessible. An attached note is easily recognized
because lines of text appear to fill the button. If a note isn't attached to a window
or a field, the notepad button will not have lines.

7} |

Organization structure button

Use the organizational structure button to assign a piece of equipment to an
organizational structure, such as company branch or division. Organizational
structures must have been set up on your system.

i

Password padlock button
Use the password padlock button to assign or change a password for a protected
item such as a budget.

Phone button

Use the phone button to search for a customer by phone number. You must first
enter a phone number and then select the phone button. If a match is found, the
customer record is retrieved.

£

Print button
Use the print button to print information displayed in the window.

I

Print button
If the Project Manager's Advisor feature is registered, the print button is available
in certain windows. Use the button to choose a report to print.

I



Symbol/Button Description

H | Query button
_EE Use the query button to establish temporary filter preferences for items viewed in
e a window. Once the window is closed, the temporary filter preferences are
cleared.
L Redisplay button
4 Use the Redisplay button to refresh a window after you've entered changes.

Show/hide detail buttons

Fat

; Fat Use the show/hide detail buttons to view additional information for items listed

] in a scrolling window.

| ¥

| = |
Technician schedules button
The technician schedules button opens the Technician Schedules window, which
is used to determine technicians' availability.
Tree view button

-E The tree view button opens a tree view window. Tree view windows display
directories, subdirectories, and items using folders. A "+" symbol next to a folder
indicates the folder contains subdirectories or items. Subdirectories and items
are indented under a directory.
Indicators

Visual indicators are linked to the customer ID and location. Not all indicators may be visible because they are
dependent upon your system's initial setup.

Indicator Description

* Contract indicator
. A Contract indicator displays when contracts exist for the selected location. To view
the contracts, choose the Contract button at the top of the window to open the
Maintenance Contract window or use the lookup in the Contract Number field to
select a contract.

52 Expired Contract indicator
Eg* An Expired Contract indicator displays when an expired contract exists for the
selected location. Zoom on the indicator to open the Maintenance Contract window.



Indicator Description

AP Canceled Contract Indicator
% A Canceled Contract indicator displays when a canceled contract exists for the
selected location. Zoom on the indicator to open the Maintenance Contract window.

I Closed Contract Indicator
A Closed Contract indicator displays when a closed contract exists for the selected
location. Zoom on the indicator to open the Maintenance Contract History window.

k Master Contract indicator
A Master Contract indicator displays if a master contract exists for the customer
location. Zoom on the indicator to open the Master Contract window.

Global filtering indicator
6 If you are using global filtering, a Branch indicator appears in the Service Manager
window. Use the looking glass pointer that appears over the indicator to open the
Global Filter View window. This displays the global filtering information for the
selected customer's location. The branch name, affiliate, region, and branch are
displayed. Global Filtering is an optional module that must be purchased separately.
Contact WennSoft Sales for more information.

Branch

g Stop-and-go light indicator
The Stop-and-Go Light indicator displays the account status of the selected customer.
Surmmany The three lights of the Stop-and-Go Light are driven by Microsoft Dynamics GP
accounts receivables aging. If the customer's account status is within the time range
of the first field, then the light is green. If the customer's account status is within the
second time range, the light is yellow. If the account status is within the third or
higher time range, or if the customer is on hold or inactive, the light is red. You can
also define an additional procedure to turn the Stop-and-Go Light red.

[ History indicator
‘5 The History indicator displays if current or historical service calls exist for this
History customer. Zoom on the indicator to open the Service Call Lookup by Customer
window.

= Quote indicator
| ! The Quote indicator displays if a maintenance quote exists. Zoom on the indicator to
open the Contract Quote window.

Overdue indicator
! The Overdue indicator displays if there are overdue scheduled preventive
maintenance service calls for the selected customer location. Zoom on the indicator
to open the Overdue PM window where you can view a list of the preventive
maintenance service calls that are overdue. Selecting an overdue service call opens
the Service Call window.

Overdue



Indicator Description

The Service Level Agreement indicator displays if the contract number for the selected
customer's location has a service level assigned to it and therefore a guaranteed
response time needs to be met.

@ Service level agreement indicator

SLA

A Warranty indicator appears in several windows if equipment associated with a
service call or maintenance call is covered by a warranty. You associate equipment
with a service call in the Service Call or Service Call Tasks window. You associate
equipment with a maintenance contract in the Contract Coverage Maintenance
window. The indicator appears in the Service Call, Service Invoice, Maintenance
Costs, and Adjustments to Costs windows. If the date in the Warranty Expires or
Extended Warranty Expires field in the Equipment window is greater than the date
the service call was opened, the indicator appears.

% Warranty indicator

W arranty

Has-components indicator
The Has-Components indicator displays in the Equipment window for master

equipment records.
Has Comp

Component indicator
% The Component indicator displays in the Equipment window when the equipment
record is a component record.

I:UITIP

Item indicator
- The Item indicator displays in the Equipment window when the equipment record
doesn't belong to a group.

ltem
Group indicator
ﬁl The Group indicator displays in the Equipment window when the equipment record
a belongs to a group and the item is the lead item in the group.
oLp
Group item indicator
@ The Group Item indicator displays in the Equipment window when the equipment
T record belongs to a group and the item isn't a lead item in the group.
Project contract status indicator
ﬂ Choosing the Project Contract Status indicator in the Project Status window opens

the Project Contract Status window for the given project. Current contract, pending,
and expected contract amounts are shown.



Indicator Description

Project billed position indicator

@ Choosing the Project Billed Position indicator in the Project Status window opens the
Project Billed Position window for the given project. Contract earned, over (under)
billing, and cash over (shortage) amounts are shown.

: Stop-and-go light indicator
g The Stop-and-Go Light indicator displays in the Subcontractor Status window and the
: Master Subcontractors Maintenance window. If the subcontractor to which a job is
g assigned is marked on hold in the Subcontractor Maintenance window, the light is
red. If the subcontractor is not on hold, the light is green.

Setting up TimeTrack

Before using TimeTrack, you must enter registration keys, choose module setup options, set up fixed assets, and select
offset accounts.

Viewing TimeTrack Application and User Activity Information

The About Signature window lists the versions of Dexterity, Microsoft Dynamics GP, and Signature that you are using.
You can also view the number of Signature users registered for your company and the number of users currently in the
system.

« View application information (page 8)
+ View registered modules (page 8)
« View installation history (page 9)
« View user activity information (page 9)

View application information
Choose Help > About Signature.

View registered modules

Choose the Modules button in the About Signature window to open the Signature Modules window. This window
displays all Signature modules and whether the site is registered to use those modules.

& faSignature product is not registered, the word DEMO appears next to the product name, along with an
expiration date. Refer to the Installation, Upgrade, and New Features manual for information on registering
Signature products.

You can print the information listed in the Signature Modules window by choosing the Print button. The
Registration report prints.



View installation history

1.

Choose the History button in the About Signature window to open the Signature Installation History window.
This window displays the version of Signature products you are running, any service packs or maintenance
releases that have been installed, as well as other relevant information. The window initially displays
information for the current workstation and server. You can make another selection from the Display drop-down
list to view other information. You can rearrange the columns by dragging and dropping the column header.
Changes to the columns will be saved for each user. Selections in the drop-down list include:

+ Current Workstation and Server

« Current Workstation Only

+ All Workstations and Server

« All Workstations Only

« Server Only
To print the Installation History report, choose the printer button. The report contains the information listed in
the Installation History window.

View user activity information

Choose Microsoft Dynamics GP > Tools > Setup > Module Name > Module User Activity.

The User Activity window shows which users are currently using the module, which company they're working in, and
the date and time they started working in that company. It's important to monitor user activity if you've reached the
maximum number of users allowed in the system or if you need exclusive access to the system before performing a file
maintenance procedure. You can click Redisplay to update the window with any users that have logged in since you
initially opened the window. You can delete a user by selecting the user ID and choosing Delete.

Setting Up Signature Registered Users

1.

o

Use the Signature Registered Users Setup window to enable the ability to enter time for your employees in
TimeTrack.
Choose Microsoft Dynamics GP > Tools > Setup > TimeTrack > Registered Users. You can sort employee names by
last name, employee ID, or by active users of TimeTrack or Remote Time Entry (Excel TimeTrack Client)
employees.
Choose Synchronize to synchronize Microsoft Dynamics GP employee records (Cards > Payroll > Employee) with
Signature employee records. If you manually update the Manager ID field in the Signature Registered Users
window, synchronizing will not overwrite this and the employee record will not be changed.
The following fields are populated with information from the Microsoft Dynamics GP employee records:
« Email Address field with the email address in the Internet Addresses lookup from the Employee window.
« Manager ID field with the Supervisor ID entered in the Employee window.

& See Setting up the Manager Approval Feature (page 41) for more information on the Manager
ID, E-mail Address, and Power User fields.

Mark the TimeTrack checkbox to enable time entry in TimeTrack and/or Clock for employees. If an employee
does not have this checkbox marked, time cannot be entered using TimeTrack and/or Clock for that employee.
Mark the Remote Time Entry checkbox if the employee will have time entered from Excel TimeTrack Client.
The User ID field is no longer used.

Choose Save.



Signature Employee Lookup in TimeTrack

The lookup window in the Employee ID field in the Time Card Entry window is now populated based on the Signature
Registered Users Setup window, not on Microsoft Dynamics GP employee records.

Choosing Setup Options

Before using TimeTrack, you must choose setup options for entering and processing TimeTrack data. After you choose
setup options, you can choose File > Print to print the TimeTrack Setup List. Choose Microsoft Dynamics GP > Tools >
Setup > TimeTrack > Setup Options.

Sections in this window:

Third Party (page 10)
Default from Previous Transaction (page 10)
Week-Ending Date Defaults (page 11)
Create a GL Journal Entry for (page 11)
Miscellaneous Items (page 11)
« Creating the vendor IDs in the Vendor Maintenance window (page 12)
« Creating the vendor IDs in the Employee Maintenance Codes window (page 12)

Third Party

In the Third Party section, you can choose options for integrating with third party payroll systems.

Integrate to Canadian Payroll

Mark this checkbox to allow your TimeTrack data to integrate with Microsoft Dynamics GP Canadian Payroll
module by writing directly to Canadian Payroll tables, provided the program is installed.

Integrate to Fixed Asset Management

Mark this checkbox to integrate with the Microsoft Dynamics GP Fixed Asset Management module, provided both
Fixed Asset Management and Job Cost are installed. If the Fixed Asset Management module is not installed, this
checkbox will be disabled. A fixed asset is a piece of equipment or material to which charges are made on a job,
per the time used. After you save the Setup Options window, you must then set up your fixed asset options. See
Setting up shift codes for shift premiums (page 13) for details.

Integrate to Equipment Management Workorders

Marking this checkbox adds WO-EQS to the TRX Type lookup window in the Time Card Entry window. This allows
TimeTrack to integrate with Equipment Management by creating workorder labor transactions, provided
Equipment Management is installed. If Equipment Management is not installed, this checkbox will be disabled.
Marking this checkbox enables the Create U.S. Payroll Transactions for Workorders checkbox.

Create a Text File for Export

Marking this checkbox allows you to create comma-delimited text files for export to ADP Payroll or Microsoft
Dynamics GP Canadian Payroll. If you are integrating with Microsoft Dynamics GP Canadian Payroll, we suggest
you use this feature as a backup in case problems occur during the TimeTrack commit process. When this
checkbox is marked, the File Format drop-down list is enabled. Select a file format from the drop-down list. See

Exporting TimeTrack data to a third-party payroll module (page 38) for more information.

Default from Previous Transaction

In the Default from Previous Transaction section, choose items to default from previous transactions.
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You can automatically have information from the previous transaction entered in new transactions by marking any of
the following checkboxes:

« Job Number/Service Call ID/WO Number
« Day of Week

+ SMS Cost Code

« JC Cost Code

o AssetID

+ GL Account checkboxes.

Week-Ending Date Defaults

In the Week-Ending Date Defaults section, choose week-ending dates.

« Default Week-Ending Day
Enter the day you want as the default week-ending day. Week-ending dates displayed in the Time Card Entry
window will end on that day of the week. If you select a default day, you must enter a week-ending date
corresponding to that day of the week. If you do not select a default, the Week Ending field will be blank in the
Time Card Entry window. You may then put in any date that falls within an open fiscal year. The next transaction
will default to the date you enter.

+ Default Date From
Choose to display the default week-ending date from the previous week, the current week, or the batch. This
option is enabled after a default week-ending day is entered. For example, if Previous Week is selected and if
today is the default end of the week, it will appear in the Week Ending field in the Time Card Entry window. If
today is not the end of the week, the previous week-ending date will display. You can then browse in one-week
increments. If you choose Batch, each Time Card Entry transaction assigned to a batch is assigned the same
week-ending date as the batch. You cannot change the date on the transaction.

Create a GL Journal Entry for

+ Unbilled Transactions
Mark this checkbox to create general ledger entries for unbilled transactions. After the Setup Options window is
saved, you must then set up your unbilled asset account by selecting credit GL accounts by department. See
Setting up Unbilled Offset Accounts (page 16) for details. If the Integrate to Fixed Asset Management checkbox is
also not marked, the GL Account field in the Time Card Entry window will be hidden.

& GL accounts for service calls are set up in Service Management by selecting Microsoft Dynamics GP > Tools >
Setup > Service Management >Invoice Setup > Accounts and choosing the Costing (Manual) button. See the
Setting up invoice accounts section in the Service Management User Manual.

Miscellaneous Items

+ Create Expense/Travel Transactions
Mark this checkbox if you want to enter expense and travel transactions in the Time Card Entry window. You can
choose to reimburse expenses through Payroll or through Accounts Payable.
« If reimbursing expenses through Payroll, the transaction will be part of the payroll batch created when
the transactions are committed in TimeTrack.
« If reimbursing expenses through Accounts Payable, the transaction will be part of an AP batch. In
addition, you must also set up a vendor ID for the employee, and assign that vendor ID to the employee in
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Employee Maintenance Codes. The vendor IDs can be created in the Vendor Maintenance window or in
Employee Maintenance Codes window.

®

Creating the vendor IDs in the Vendor Maintenance window

i. Setup the employees as vendors in the Vendor Maintenance window (Cards > Purchasing
> endor). For example, the employee, ALAN FLINT, you could have a vendor record
called ALANFLINT.

ii. Assign the vendor for that employee in the Employee Maintenance Codes window
(Microsoft Dynamics GP > Tools > Setup > Job Cost > Payroll Setup > Employee Codes).

Creating the vendor IDs in the Employee Maintenance Codes window

i. Open the Employee Maintenance Codes window (Microsoft Dynamics GP > Tools > Setup >
Job Cost > Payroll Setup > Employee Codes) and select an employee.
ii. Enter a new Vendor ID for this employee and tab off the field or choose Save.
iii. When you are prompted to add this vendor record, choose Add.
iv. Enter the name of the Employee and any other relevant information in Vendor
Maintenance. Save and close.

& Remember that whatever appears in the Check Name field is how the name will
appear on the checks.

v. Save the Employee Maintenance Codes window.

Create U.S. Payroll Transactions for Workorders

Mark this checkbox if you are using Microsoft Dynamics GP Payroll and want to automatically create U.S.
Payroll transactions for workorders upon committing. This option is enabled if the Integrate to
Equipment Management Workorders checkbox is marked.

Calculate Overhead for Unbilled Transactions

Mark this checkbox if you want the costs for unbilled transactions entered in TimeTrack to include
overhead in the total cost amount. This option is enabled if the Create a Journal Entry for Unbilled
Transactions checkbox is marked. Unbilled labor transactions entered in TimeTrack use the overhead
group code from Job Cost to calculate overhead amounts. See Setting up overhead detail codes and
Setting up overhead group codes in the Job Cost User Manual. If the Integrate to Canadian Payroll
checkbox is marked, only the dollar amount for overhead is sent to the general ledger. When the option is
not marked, the overhead amount and wage amount are sent to the general ledger account.

Total Cost Display Excludes Overhead

Mark this checkbox to exclude overhead from the total cost in the Time Card Entry window and on the
edit list reports.

Total Cost Display is Hidden

Mark this checkbox to display zero in the Total Cost field in the Time Card Entry window. Marking this
checkbox also hides the Cost column in the list view section of the Time Card Entry window.
Subsequent Transactions Begin at Employee ID Field

Mark this checkbox to automatically begin on an Employee ID field for transaction windows. This allows
for convenient selection of a new employee. This works only for entering multiple transactions in the
same session, without closing the Time Card Entry window.

Do Not Refresh List View Window after Save

When using the Premier version of TimeTrack or in situations where there is a large amount of data being
entered, refreshing the list view section after a save may be time consuming. Mark this checkbox to
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eliminate the automatic refresh in the Time Card Entry window, although the hours will still update. You
can also manually refresh the window by choosing the Redisplay button.

« Do Not Save List View Column Settings
Mark this checkbox to use the default system settings every time the Time Card Entry window is opened.
If you do not mark this checkbox, any changes to the window properties (column order, column size, and
sort order) will be saved when you exit the window.

« Maintain History
Mark this checkbox if you want to maintain a history of committed TimeTrack transactions. See Using
TimeTrack history (page 31) for more information.

« Use Average Salary Labor Rate
Mark this checkbox if you want to enter salary labor transactions.

+ Restrict employee access in eTimeTrack for current user
This checkbox is no longer used. eTimeTrack has been deprecated with the Signature 2018 R3 release.

+ Require Batch Approval
Mark this checkbox if you want to require approval for a TimeTrack batch to be committed. If you mark
the checkbox, enter a password for approving batches in the Password field. This password will always
display when the Setup Options window is opened. If you do not want all users to see the password, you
could restrict access to the Setup Options window using Microsoft Dynamics GP window-level security.

« Default Transaction Type
Use the lookup to select the default transaction type for the Time Card Entry window. If you do not
choose a default, the Job Cost type will default the first time the window is opened. Each subsequent
transaction defaults to the transaction type of the previous transaction. The WO-EQS transaction type is
used for Equipment Management workorder transactions.

+ Require Manager Approval
This option enables the manager approval feature, which requires that time cards be approved before
they can be committed. Refer to Manager Approval of Time Card Transactions (page 41) for more
information about setting up and using this feature.

« The E-mail Notification checkboxes are enabled when the manager approval feature is turned on.

Setting up Shift Codes for Shift Premiums

You can set up shift premiums, which allows you to add an amount to an hourly wage for when employees are working
a swing or graveyard shift. Shift codes are set up in Microsoft Dynamics GP.
When you enter payroll transactions, you must select a shift code.

1. Choose Microsoft Dynamics GP > Tools > Setup > Payroll > Shift Code. The Shift Code Setup window opens.
2. Enter the name of your Shift Code and a Description.

3. Select either a flat Amount or a Percent, then enter the appropriate value.

4, Save the shift code, and repeat the steps above to create more shift codes if necessary.

About shift premiums

This feature is an extension of the Microsoft Dynamics GP feature that allows you to add an additional pay amount to an
hourly wage, as incentive for employees to work outside the regular day shift, such as second shift or third (graveyard)
shift. When entering a payroll transaction, the shift premium will default automatically based on the shift code that is
assigned to the employee's pay code. Depending on what application you are using to enter labor transactions, the shift
code can be edited per transaction.

You can edit the shift code for these applications:

« Time Card Entry window (TimeTrack)
« Signature Payroll Transaction Entry window
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You cannot edit the shift code for these applications:

« Group Time Card Entry (TimeTrack)

+ Excel TimeTrack Client

« MobileTech (The remote technician cannot edit the shift code; however, someone in the office can edit the shift
code via the Time Card Entry window in TimeTrack.)

Setting up Fixed Assets

To integrate TimeTrack with the Microsoft Dynamics GP Fixed Asset Management module, you must have Job Cost and
the Microsoft Dynamics GP Fixed Asset Management module installed and registered. Additionally, the Integrate to
Fixed Asset Management checkbox must be marked on the TimeTrack Setup Options window.

Setting up fixed assets involves the following:

« Step 2: Select fixed asset option (page 14)
« Step 3: Set up cost recovery rate (page 15)

Step 1: Link asset to a job in Job Cost

You must link a fixed asset to a job in Job Cost using the Job User-Defined window. The asset ID links the TimeTrack
transaction to the job and the cost code defined for the job.

Refer to the Job Cost User Manual for complete instructions on setting up a job.

1. Choose Cards > Job Cost > Job.

Select a Job Number. This could be a job you created specifically for fixed assets.

Choose User-Defined. The Job User-Defined window opens.

Select an Asset ID.

Make additional changes, if necessary, and choose Save.

Complete the Job Maintenance window, and choose Save.

To add cost codes to the asset job, choose the Cost Codes button in the Job Maintenance window. The Job Cost

Codes Setup window opens. All cost codes used as fixed asset transaction offsets must be set up on this window.
8. Toadd an existing cost code to the asset, use the Add Cost Codes button to select a cost code. Complete the

remaining fields.

9. To add a new cost code to the asset, complete the window to create the new cost code.

10. Choose Save.

No o hswN

Step 2: Select fixed asset option

On the Fixed Asset Options window, you choose whether to use a default cost code or a default GL offset account as the
fixed asset transaction offset. After you choose one of the options, you must enter the default cost code or the default
GL offset account. You must select an option for each division. You cannot save a fixed asset transaction if the division
of the asset job is not set up in this window.

1. Choose Microsoft Dynamics GP > Tools > Setup > TimeTrack >Fixed Asset Setup.
2. Enter the division you will charge the fixed asset transaction offset to.
3. Choose an option.
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& Tousean asset in TimeTrack, the asset's suffix ID must be set to "1" in the Fixed Asset Management
module. Use the lookup in the Asset ID field on the Asset General Information window (Cards > Fixed
Assets > General) to display the asset ID and suffix ID.

« Option 1 - Use the default cost code as the fixed asset transaction offset
Choose this option if you want to use a default cost code as the fixed asset transaction offset. If the job
number entered in TimeTrack contains a division set up as with Option2, the credit goes to the GL
account assigned to that division, not to the asset job default cost code. If the job number entered in
TimeTrack contains a division set up as Option 1, the credit is charged to the offset account for the
division of the asset job number. When you enter an Asset-JC transaction in the Time Card Entry window,
the debit will be charged to the job number selected in the Time Card Entry window. The credit will be
charged to the offset account for the division of the asset job number. When you enter a Fixed Asset-
General Ledger (FA-GL) transaction in the Time Card Entry window, the debit will be charged to the GL
account selected in that window. The credit will be charged to the offset account for the division of the
asset job number.

& fyou are entering FA-GL transactions, you must select Option 1. If you are entering Asset-JC
transactions, you can choose either option.

« Option 2 - Use a default GL offset account as the fixed asset transaction offset

Choose this option if you want to use a default GL offset account as the fixed asset transaction offset. The
Default GL Offset Account setup in the Fixed Asset Options window is the account that will receive the
credit, and NO asset job will be credited. When you enter an Asset-JC transaction in the Time Card Entry
window, the debit will be charged to the job number selected in that window. If the job number entered
in TimeTrack contains a division set up as Option 2, the credit goes to the Default GL Offset Account
assigned to that division in the Fixed Asset Options window. The credit DOES NOT go to the asset job
default cost code (see Optionl). If you want the credit to be captured on the asset job, both the division
of the asset job and the job number (debit job) entered in TimeTrack must have its division set as Option
1in the Fixed Asset Options window

4. Enter a default cost code or a default GL offset account. If you selected Option 1, enter the cost code to credit

fixed asset charges. If you selected Option 2, enter the GL offset account to credit the fixed asset charges.
5. Choose Save.
6. To print all selections by division, choose Print.

Step 3: Set up cost recovery rate

The cost recovery rate is the hourly rate charged to the job for use of an asset. The recovery rate is used to calculate the
cost for a fixed asset transaction in the Time Card Entry window.

Choose Microsoft Dynamics GP > Tools > Setup > TimeTrack > Fixed Asset Cost Recovery Rate.

Enter the Asset ID.

In the Cost Recovery Rate field, enter a dollar amount to apply to each unit for the use of an asset.
Choose Save.

To print a list of all assets that have cost recovery rates assigned, choose File > Print.

o

Entering Time Card Batches

You can set up batches in the Time Card Batch Entry window that can be used in TimeTrack and Microsoft Dynamics GP
Payroll.

1. Choose Transactions > TimeTrack > Time Card Batch Entry.
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Enter a Batch ID for a single-use batch.

Enter a Comment to describe the batch.

4. Enter a Week Ending Date. This field is enabled if you set up a default week-ending day in Setup Options, and
marked the option to default the week-ending date from the batch.

w

& Time card entry transactions that are assigned to this batch on the Time Card Entry window will be
assigned this week-ending date. If you change the week-ending date of the batch, the date rolls down
to all transactions in the batch. Once the batch is approved for committing, you cannot edit the batch
week-ending date.

5. Choose Save.

Setting up Unbilled Offset Accounts

If you mark the Create a GL Journal Entry for Unbilled Transactions checkbox in the Setup Options window, you can
create general ledger entries for unbilled transactions.

1. Choose Microsoft Dynamics GP > Tools > Setup > TimeTrack > Unbilled GL Offset.
2. Enter the Department to apply the unbilled GL entries to.

3. Enter the GL Offset Account to charge the credit.

4. Choose Save.

Using TimeTrack

With TimeTrack, users can enter labor hours, expenses, and travel costs for Service Management, Job Cost, and
Unbilled transactions. TimeTrack transactions appear on the Service Invoice window after the batch is committed or in
the Job Status window after the transactions are posted. TimeTrack is compatible with the Microsoft Dynamics GP
Fixed Asset Management module, allowing you to charge fixed asset costs to jobs or cost codes. You have the option of
having the fixed asset offset for TimeTrack transactions post to a default cost code or a default general ledger offset
account. The TimeTrack import feature allows a field person to send a tab-delimited text file to the office via e-mail and
have that information automatically entered into the system.

About Negative Payroll Transactions

TimeTrack allows the entry and processing of negative time transactions in some instances. This provides a Signature
user with the ability to perform corrective transactions to update Service Management, Equipment Management, and
Job Cost.

If you are using Microsoft Dynamics GP Payroll, these corrective transactions will transfer into the GP Payroll posting
process via payroll integration. However, Microsoft Dynamics GP Payroll does not recommend or support negative
payroll transactions.

Per tests performed by Signature, negative transactions will post properly through Dynamics GP Payroll, if the sum of
the tax transaction results in a positive or net neutral (zero) tax transaction for each tax code used in the payroll
transaction. In this case, GP Payroll will calculate the correct Federal, State and Local tax liability. The exception to this
posting result is found primarily with local tax calculations. When a user generates a corrective transaction to change
the local tax code assignment, the net tax transaction set does not result in a positive or net neutral local tax
transaction for each of the local tax codes; therefore, negative local tax calculations are not properly reversed and
should not be attempted. The same would be true if the State or Federal tax codes were changed.
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Microsoft's instruction for correcting any payroll error is to void the erroneous payroll check and re-issue the check
once the data has been corrected.

& Signature is not authorized to modify the Microsoft Dynamics GP Payroll source code. Until Microsoft provides
a method for accurately posting corrective payroll transactions, Signature must follow the directives outlined
by Microsoft. Any attempt to circumvent the established procedure outlined above is not supported by
Signature.

If you are using US Payroll, and the Use COGS Distribution for Invoices and Allow posting invoices with negative/
committed costs options are marked in Invoice Options, voiding a check after the job or service call invoice is posted
creates a negative transaction to reverse the costs and billable amount of the payroll transactions. If the service call or
jobis closed, it will be reopened to allow you to post this transaction.

About Using the Service Call Lookup Window

When you are entering a transaction that is associated with a service call on the Time Card Entry window, you can filter
the Service Call Lookup window to display all service calls or only those service calls that you have an appointment for.
This is useful if you do not want to scroll through a long list of service calls to find the one you are working on. By
default, only your service calls will display.

You can toggle between your service calls and all service calls as necessary.

Entering Labor Transactions

The Time Card Entry window allows you to record labor costs for service calls, jobs, Equipment Management
workorders, and unbilled or general ledger transactions.

You must have Equipment Management registered if you want to integrate with TimeTrack. Before you enter workorder
transactions, make sure you have the Integrate to Equipment Management Workorders checkbox marked on the
Setup Options window (Microsoft Dynamics GP > Tools > Setup >TimeTrack > Setup Options). The enabled fields on the
Time Card Entry window are determined by setup options. See Choosing Setup Options (page 10).

1. Choose Transactions > Time Track > Time Card Entry.
2. Complete the following fields, as necessary.
« BatchID
After entering a batch ID, you can view which employees and week-ending dates are included in the
batch by choosing the expansion button. Double-clicking an employee name on the Expanded Batch
Lookup window populates the employee ID and week-ending date.
« Employee ID
Select the employee that you are creating the transaction for.
+ Week Ending
This date populates based on setup options. You can edit the date. If a default week-ending day was set
up on the Setup Options window, you will receive a warning message for entering a new date that does
not fall on the week-ending day.

& fyou are using Certified Payroll reports, the week-ending date should fall on a Saturday.
+ Certified Payroll

This checkbox will be marked when you select a job, if the transaction type is Job Cost and the job is a
certified payroll job.
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Transaction Number

The transaction number is assigned when the transaction is saved, or when you attach a note to the
transaction using the notepad button. See Entering notes (page 24). The number is taken from the
Computer Check field on the Payroll Setup Options window (Setup > Payroll > Payroll > Options).

TRX Type

The transaction type defaults based on setup. Depending on the transaction type, certain Time Card
Entry fields will become disabled. If you choose a transaction type of WO-EQS, the Cost Type field will
default to Labor. WO-EQS transactions work only with the Labor cost type.

& Toautomatically enter the type, you can enter the first letter and tab off the field.

Cost Type

To create a labor transaction, use the drop-down menu to choose a cost type of Labor.

Job Number / Service Call ID / Workorder Number

For Job Cost transactions, the Job Number field is enabled. For Service transactions, the Service Call ID
field is enabled. For WO-EQS transactions, the Workorder Number field is enabled. For Unbilled
transactions, this field is disabled.

Day of Week

Enter or use the lookup button to choose the day of the week. You can also type a partial entry or type the
number of the day (1 = Monday, etc.) and tab off the field to automatically enter the date.

Cost Code

For Job Cost and Service transactions, enter a cost code. Only cost codes relating to labor display. For
Job Cost transactions, cost codes with a cost element type of Labor. For Service transactions, cost codes
6 - 10. For WO-EQS transactions, enter a task ID. If you have the same cost code assigned to different cost
element types, use the lookup to ensure you select the correct cost code. You can also enter a new cost
code.

Equipment ID

For Job Cost or Unbilled transactions, this field is disabled. For WO-EQS transactions, the equipment
defaults from the workorder number. For Service transactions, enter the equipment serviced on the call.
Use the expansion button to open the Contract Task Completed window, where you can mark a task
complete and enter a completion date. The user date defaults. The task is marked complete in the
Service Call Tasks window and the Maintenance Tasks window. If you choose Mark All or mark the task as
complete and tab off the field, the task will be automatically saved.

AssetID

The Asset ID field is disabled for Service, Job Cost, Unbilled, and WO-EQS transactions.

Pay Code

Enter a pay code. For Service or Job Cost transactions, the employee must have a pay code, position, and
department belonging to a labor rate group established. See Creating labor rate groups in the Service
Management and Job Cost user manuals. If you want to edit payroll information for the employee, you
can open the Edit Payroll Fields window using the Pay Code expansion button, Options > Edit Payroll
Fields, or Ctrl+F. These changes only apply to this transaction and do not change the employee defaults.
All fields on this window default from Job Cost and Microsoft Dynamics GP setup, except for Days Worked
and Weeks Worked. The Rate Class field pertains to Job Cost transaction types only. You can enter days
worked and weeks worked data, which is used for calculating benefits in Microsoft Dynamics GP Payroll.
Hours

Enter the number of labor hours. If the transaction type is Job Cost and the job is a certified payroll job,
after entering hours, the Time Sheet Certified window opens where you can distribute the payroll hours
among different days. If the pay rate for an employee is zero, the Edit Pay Rate window will open
automatically after tabbing off the Hours field.

Transaction Description

Enter a transaction description using up to 30 characters. Do not use quotation marks or commas in the
description.
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+ Pay Rate
This field displays if the Edit Financial Fields and Display Pay Rate on Trx checkboxes are marked in
Payroll Setup Options (Microsoft Dynamics GP > Tools > Setup > Payroll > Payroll > Options button). To
override a pay rate, open the Edit Pay Rate window using the expansion button, Ctrl-E, or Options > Edit
Pay Rate. This window allows you to change the pay rate for only this transaction, for prevailing wage
type jobs. If the pay rate for an employee is zero, the Edit Pay Rate window will open automatically after
tabbing off the Hours field.

& Zero cost labor transactions will be saved and committed in TimeTrack and sent to Payroll. Zero
cost labor transactions can be entered for any transaction type. A zero balance journal entry will
be created in General Ledger. Zero balance journal entries must be deleted manually.

+ Shift Code
If you are using shift premiums, select a shift code.
« Shift Premium
Shift premiums can be used for Job Cost, Service, and Unbilled labor transactions. Flat dollar amount is
calculated per hour. Percent is calculated based on the gross pay rate. Decimal places for shift premiums
are determined by the Decimal Places for Pay Rate field on the Payroll Setup Options window (Microsoft
Dynamics GP > Tools > Setup > Payroll > Payroll > Options button).
« Total Cost
The total cost calculates automatically, depending on the transaction type. For Job Cost transactions,
the hourly pay rate multiplied by hours plus overhead. For Service transactions, the hourly pay rate
multiplied by hours plus overhead and extended costs. For Unbilled transactions, the hourly rate
multiplied by hours plus overhead. For WO-EQS transactions, the hourly rate multiplied by hours. If you
marked the Total Cost Display Excludes Overhead checkbox in Setup Options, the total will not include
overhead for the Job Cost and Service transaction types. If you marked the Total Cost Display Is Hidden
checkbox in Setup Options, the Total Cost field and Cost column on the list view window will be hidden.
* Hours
Only labor hours appear in the Hours column.
+ GL Account
For Unbilled transactions, if the Create a GL Journal Entry for Unbilled Transactions checkbox is
marked in Setup Options, enter a GL account. For WO-EQS transactions, the GL account number comes
from the task ID. This field is hidden if the Integrate to Fixed Asset Management and Create a GL
Journal Entry for Unbilled Transactions checkboxes are not marked in Setup Options.
3. Choose Save. Saving clears the transaction information, places the data in the list view window, and updates the
Hours column.
4. Choose File > Print to print the Employee Weekly Time Edit List, based on the batch number, employee ID, and
week-ending date. Transactions are separated by pay code. The total labor hours by day are at the bottom of the
page. These hours do not include fixed asset or expense/travel transactions.

5. Commit the transactions. See Committing time card transactions (page 30).

Entering Salary Labor Transactions

You can enter time for salaried employees. The system calculates an average hourly rate by dividing an employee's
weekly salary by the number of hours worked. Salary amounts can be entered for Job Cost, Service Management,
Equipment Management, and Unbilled transactions.

To use this feature, mark the Use Average Salary Labor Rate checkbox in the Setup Options window (Microsoft
Dynamics GP > Tools > Setup > TimeTrack > Setup Options).

1. Choose Transactions > TimeTrack > Time Card Entry.
2. Complete the Time Card Entry window. See Entering Labor Transactions (page 17). Use a salary Pay Code, or a pay
code based on a salary pay code. Commission pay codes should not be used.
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3. Save the transaction.

4. Use the Calculate Average Rate button to calculate the rate for this transaction. Pay rates are automatically
calculated when committing the batch or printing the Employee Weekly Time Edit List or Time Sheet Edit List.
Pay rates appear as zero until they are calculated.

5. Double-click a transaction from the scrolling window to view the pay rate and total cost. The Pay Rate field will
be visible if the Edit Financial Fields and Display Pay Rate on Trx checkboxes are marked in Payroll Setup
Options (Microsoft Dynamics GP > Tools > Setup > Payroll > Payroll > Options button).

Due to rounding, the Pay Rate field for salary transactions displays five decimal places when the Use Average
Salary Labor Rate checkbox is marked in Setup Options. If you are not using this feature, the number of decimal
places is determined in Payroll Setup Options.

Since salary transactions can be in any pay period, all pay periods can be used when calculating an average
hourly pay rate. To calculate the hourly pay rate, the calculated amount is divided by the number of hours
worked in a week, including sick, vacation, and holiday time. For each pay period, the weekly pay amount is
calculated as follows:
+ Weekly
Pay amount
+ Biweekly
Pay amount /2
« Semimonthly
(Pay amount * 24) / 52
« Monthly
(Pay amount * 12) / 52
« Quarterly
(Pay amount * 4) / 52
« Semiannually
(Pay amount * 2) / 52
« Annually
Pay amount /52
« Daily
Pay amount * 5
The calculation includes all the employee's salary transactions and transactions with pay codes based on salary
with the same week-ending date. All salary transactions with the same week-ending date for an employee must
be entered in the same batch.

Rate classes will not affect the pay rate of salary transactions when the Calculate Average Salary Labor
Rate checkbox is marked in Setup Options.

If you have a batch of transactions that all have a salary pay code, you may end up with a Payroll batch of zero
transactions after committing the batch, even though there are transactions in the batch.

6. If you want overhead amounts calculated in Service Management, build the checks for this batch as usual.
Otherwise, do not mark a batch with zero transactions.

7. If you want to post the transactions to Job Cost, you must mark the Payroll Post to Job Cost Only checkbox in
Posting Options before posting the batch. If this option is not marked, you cannot select the batch in the Job
Cost Payroll Post window. Unmark the Payroll Post to Job Cost Only option after posting the batch. When
committing and exporting batches, transactions with a salary pay code are only sent to U.S. Payroll, Canadian
Payroll, or ADP if they have a pay type of vacation or sick. Be sure to base your vacation, sick, or holiday pay
codes on the salary pay code, with the same pay rate. If you need a salary-based pay code to have a different pay
rate, the hours for the salary-based pay code must be entered in Payroll. For example, salaried employees may
get paid an overtime rate 1.5 multiplied by their salary rate.

8. Similarly, if you want to post the transactions to Service Management, you must mark the Payroll Post to Service
Only checkbox in Invoice Options before posting the batch.
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9. Choose File > Print to print the Employee Weekly Time Edit List, based on the batch number, employee ID, and
week-ending date. Transactions are separated by pay code. The total labor hours by day are at the bottom of the
page. These hours do not include fixed asset or expense/travel transactions.

10. Commit the transactions. See Committing Time Card Transactions (page 29).

& Zero cost labor transactions will be saved and committed in TimeTrack and sent to Payroll. Zero cost labor
transactions can be entered for any transaction type. A zero balance journal entry will be created in General
Ledger. Zero balance journal entries must be deleted manually.

Entering Expense and Travel Transactions

Expenses incurred for a job or a service call can be entered in the Time Card Entry window at the same time work hours
are entered. You can track expenses directly related to a job or service call. In addition, expenses for Unbilled
transactions can be entered. The expenses can be travel or non-travel.

& fyou are integrating with Canadian Payroll, expense reimbursements have to go through Accounts Payable.

« Transactions for reimbursed expenses (page 21)
« Transactions for non-reimbursed expenses (page 21)
+ Before entering expense and travel transactions (page 22)
+ Step 1: Select expense transaction options (page 22)
« Step 2: Define pay codes for expense transactions (page 22)
+ Step 3: Assign expense pay codes to employee records (page 22)
+ Entering expense and travel transactions (page 22)

Transactions for reimbursed expenses
When an employee enters and saves a reimbursable expense in the TimeTrack window, three things happen:

+ A payroll transaction is created in Microsoft Dynamics GP.
+ The cost is charged to the appropriate business expense accounts for Job Cost or Service Management.
+ Forservice transactions, an entry can be made to a general ledger account.

When a payroll check is generated for the employee, the dollar amount of the expense is added to the employee's
paycheck. This means that only one check is generated that includes regular pay and expenses.

Transactions for non-reimbursed expenses

Non-reimbursed expenses can only be used with Service labor transactions. For an expense that is not reimbursed, a
payroll transaction is not created. An example of a non-reimbursable expense would be travel costs for an employee
using a company-owned vehicle.

If a Service Management transaction for travel expenses is created, and the total cost is zero, a payroll transaction is not
created. In this case, the pay code and pay rate are used to allocate the expense to an appropriate account in Microsoft
Dynamics GP. An entry is made to the general ledger batch. The name of the entry is "SM," plus the name of the payroll
batch. Since the expense is not related to payroll, a payroll transaction is not created.

For example, the costs for a company-owned vehicle used by an employee can be tracked by defining a pay code with a
pay rate of zero and associating the pay code with an appropriate expense account. The employee enters the total
number of miles accumulated for business travel in the Time Card Entry window. Since the pay rate for the pay code is
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set to zero, the total cost calculated is zero, and a payroll transaction is not created. A general ledger transaction is
created for the cost based on the amount in the Cost Rate field in the Travel Charges window (Microsoft Dynamics GP >
Tools > Setup > Service Management > Invoice Setup > Travel Charges).

Before entering expense and travel transactions

Step 1: Select expense transaction options

1. Choose Microsoft Dynamics GP > Tools > Setup > TimeTrack > Setup Options.
2. Markthe Create Expense/Travel Transactions checkbox.

Step 2: Define pay codes for expense transactions

Pay codes used for expense transactions entered in TimeTrack must be defined with a pay type of Business Expense.
Follow the standard procedures for entering a new pay code.

1. Choose Microsoft Dynamics GP > Tools > Setup > Payroll > Pay Code.

Enter a Pay Code and Description.

Select Business Expense from the Pay Type drop-down menu.

Enter a Pay Rate.

Select the frequency for paying the expense in the Pay Period drop-down menu.

If the expense is not subject to taxes, clear the checkboxes in the Subject to Taxes section.

o0k wn

Step 3: Assign expense pay codes to employee records
Only the expense codes assigned to an employee record are available in the TimeTrack Time Card Entry window.

1. Choose Cards > Payroll > Pay Code.

Use the Employee ID lookup to select an employee.

Use Pay Code lookup to select an expense pay code.

Choose to use the default information from the company pay code record.
Choose Save.

ol wn

Entering expense and travel transactions

1. Choose Transactions > TimeTrack > Time Card Entry. The fields available in the Time Card Entry window depend
on setup options. See Choosing Setup Options (page 10).

2. Enter a Batch ID. After entering a batch ID, you can view which employees and week-ending dates are included

in the batch by choosing the expansion button in the Batch ID field. Double-clicking an employee name from the

list in the Expanded Batch Lookup window enters the employee ID and week-ending date in the Time Card Entry

window.

If the Employee ID field is blank, enter an employee ID.

4. The week-ending date appears in the Week Ending field based on setup options. You can edit the date.

w

& The transaction number is assigned when the transaction is saved or when you attach a note to the
transaction using the notepad button. See Entering notes (page 24). The number is taken from the
Computer Check field in the Payroll Setup Options window (Setup > Payroll > Payroll > Options).

5. Select a transaction type. Choose a cost type of travel or expense. The transaction type and cost type selected
determine the fields that are available to complete a transaction.
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10.

11.
12.
13.

14.

15.

16.

17.

& The unitvalue used for travel costs associated with a service call or a job number is based on the value
entered in the Travel Units field in the Service Management Travel Charges window (Microsoft Dynamics
GP > Tools > Setup > Service Management > Invoice Setup > Travel Charges). If nothing is entered in the
field, the system default value, miles, is used. This will affect the column heading in the edit list reports.

Choose the job number or service call ID. The Job Number field is enabled when the transaction type is Job Cost.
The Service Call ID field is enabled when the transaction type is Service.

Enter the day of the week. Use the lookup button to choose the day of the week. You can also type a partial entry
or type the number of the day (1 = Monday, etc.) and tab off the field to automatically enter the date.

Enter a cost code. Only cost codes relating to expenses will display. That is, SMS cost codes 1, 2, 4, or 5 for non-
travel expenses and SMS cost code 5 for other expenses, and cost codes with a cost element of something other
than labor for Job Cost expenses will appear.

If cost code 5 is selected, the sub cost code field is enabled and Travel will default. You can use the lookup to
choose a different sub cost code.

Enter equipment ID. If the transaction type is Service, enter the piece of equipment serviced on the service call.
Use the expansion button attached to the field to mark an MCC call task complete. The transaction date is
entered as the task's completion date. The task is marked complete in the Service Call Tasks window and the
Maintenance Tasks window.

Enter a pay code. The pay code must have a pay type of business expense.

Enter the number of units for expense cost types or miles for travel cost types.

For expense cost types, tab to the field next to the Units field and enter an amount. The rate defaults from setup.
The expansion button attached to the Amount field is disabled when entering expense and travel transactions
for certified payroll jobs.

Enter a transaction description using up to 30 characters. Do not use quotation marks or commas in the
description. The Pay Rate field will be visible if the Edit Financial Fields checkbox and Display Pay Rate on TRX
checkbox are marked in the Payroll Setup Options window (Setup > Payroll > Payroll > Options). The total cost
calculates automatically, depending on the transaction type. If you marked the Total Cost Display Is Hidden
checkbox in the Setup Options window, the Total Cost field and the Cost column in the list view window will be
hidden.

Choose Save. A transaction number is assigned to the entry and a line item is displayed in the transaction list
when the transaction is saved. The information included will vary for each transaction type.

Choose File > Print to print the Employee Weekly Time Edit List, based on the batch number, employee ID, and
week-ending date. Transactions are separated by pay code. The total labor hours by day are at the bottom of the
page. These hours do not include fixed asset or expense/travel transactions.

Commit the transactions. See Committing Time Card Transactions (page 29).

Entering Transactions Using Sales Order Processing Invoicing

Labor, expense, and travel transactions can be created in TimeTrack and used with Sales Order Processing (SOP)
invoicing in Service Management. Transactions entered in TimeTrack are automatically put on hold in SOP until the
TimeTrack batch is committed. You must be set up to use SOP invoicing in Service Management. See Choosing Service
Options and the "SOP Invoicing" chapter in the Service Management User Manual.

1.

2.

Enter a labor, expense, or travel transaction as usual. See Entering Labor Transactions (page 17) and Entering
Expense and Travel Transactions (page 21). After the transaction is entered, the primary document in SOP is
placed on a process hold. The TimeTrack transactions are added to the primary SOP document after the batch is
committed. The Process Hold ID is TimeTrack. The hold is released after all TimeTrack transactions associated
with the document are committed.

Commit the batch as usual. See Committing Time Card Transactions (page 29).
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Entering Notes

You can add notes to Job Cost, Service Management, Unbilled, workorder, and fixed asset transactions by choosing the
notepad button in the Time Card Entry window. The Maintain History checkbox in the Setup Options window (Microsoft
Dynamics GP > Tools > Setup > TimeTrack > Setup Options) must be marked to enter notes for fixed asset transactions.

« Entering a note (page 24)
« Printing a note (page 24)
+ Viewing a note (page 24)

Entering a note

1. Choose Transactions > TimeTrack > Time Card Entry.

Select an existing transaction or enter a new one.

3. Choose the notepad button to the right of the Transaction Number field. Enter the note in the Notes window and
choose Attach. The notepad button in the Time Card Entry window changes color and is filled with lines,
indicating that a note is attached to the transaction.

N

Printing a note

You can print a note or set of notes. The report must be produced before the batch is committed. Once the batch is
committed, the notes are saved with the transactions and can only be viewed from the Time Card History window.

1. Choose Reports > TimeTrack > Printable Notes.

2. Use the Product drop-down menu to select a product.

3. Choose a range type from the Ranges drop-down menu. You can print notes by job number/service ID, author,
or modification date (the date(s) within which printable notes were modified). Use the lookups in the From and
To fields to specify a range. You can enter author and modified date ranges regardless of the product selected
using the lookups in the From and To fields.

4. Choose Insert >>.

5. Choose Print.

Viewing a note

Notes attached to Unbilled, Job Cost, and Service Management transactions can be viewed from the Microsoft
Dynamics GP Payroll Transaction Entry window. Depending on setup, notes attached to Equipment Management
transactions are saved as Unbilled transactions. Notes attached to fixed asset transactions are viewed from the Time
Card History window. Job Cost notes can also be viewed in Job Cost from the Payroll Entry Zoom window. Service
Management notes can also be viewed in Service Management from the Adjustment to Costs window.

« Commit the batch. Notes must be committed to be viewed in Microsoft Dynamics GP, Job Cost, and Service
Management. Once committed, the notes can only be viewed from the Time Card History window. See

Committing Time Card Transactions (page 29).

« Open the Payroll Transaction Entry window by choosing Transactions > Payroll > Transaction Entry.
« Choose the notepad button to view/edit the note in Microsoft Dynamics GP or zoom on the Product field to view/
edit the note in Job Cost or Service Management.

& You canview and edit the note from Microsoft Dynamics GP, Job Cost, or Service Management. Changes made
to the note from Microsoft Dynamics GP are not reflected in Job Cost or Service Management and vice versa.
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Entering Fixed Asset Transactions

You can use the FA-GL transaction type to create general ledger entries or use the Asset-JC transaction type to create
cost code and general ledger entries.

» Entering FA-GL transactions (page 25)
« Entering Asset-JC transactions (page 25)

Entering FA-GL transactions

The FA-GL transaction type allows you to create a general ledger entry for a fixed asset transaction. In other words, you
will be able to charge fixed asset costs to a general ledger account instead of a specific job. The number of hours for FA-
GL transactions will not be added to the total hours and daily hour amounts in the Time Card Entry window. The
negative number of hours will be sent to the fixed asset job and cost code. TimeTrack FA-GL transactions create job
transaction entries that credit the fixed asset job number, default cost code, and general ledger account assigned to the
cost code. With this option, TimeTrack verifies that the job and default cost code exist for the fixed asset when entering
an FA-GL transaction. To create FA-GL transactions, you must check Option 1 in the Fixed Asset Options window.

See Setting up Fixed Assets (page 14) for details.

1. Choose Transactions > Time Track > Time Card Entry.

2. Enter a Batch ID. After choosing a batch ID, you can view which employees and week-ending dates are included
in the batch by choosing the expansion button in the Batch ID field. Double-clicking an employee name from the
list in the Expanded Batch Lookup window enters the employee ID and week-ending date in the Time Card Entry
window.

3. Ifthe Employee ID field is blank, enter an employee ID.

4. The week-ending date appears in the Week Ending field based on setup options. You can edit the date.

& The transaction number is assigned when the transaction is saved or when you attach a note to the
transaction using the notepad button. See Entering notes (page 24). The number is taken from the
Computer Check field in the Payroll Setup Options window (Setup > Payroll > Payroll > Options).

Enter FA-GL in the TRX type field.

Enter a day of the week.

Enter asset ID. The asset ID must be set up as a job of the same name in Job Cost.

Enter the number of hours the asset was used.

Enter a general ledger account for the debit portion of the transaction.

10. View the total cost. The total cost calculates automatically as is calculated by multiplying the hours by the cost
recovery rate. The total cost will be used as the debit amount charged to the selected general ledger account.
See Set up cost recovery rate (page 15) for details. The Pay Rate field will always display $0.00.

11. Choose Save.

12. Commit the transactions. See Committing Time Card Transactions (page 29).

© e~ U

Entering Asset-JC transactions

The Asset-JC transaction type allows you to charge fixed asset costs to a default cost code or to a general ledger
account you designate. The number of hours for Asset-JC transactions will not be added to the total hours and daily
hour amounts in the Time Card Entry window. The negative number of hours will be sent to the fixed asset job and cost
code. Asset-JC transactions create job transaction entries that credit the fixed asset job number, default cost code, and
general ledger account assigned to the cost code. With this option, TimeTrack verifies that the job and default cost code
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exist for the fixed asset when entering an Asset-JC transaction. To create Asset-JC transactions, you can use either
Option 1 or Option 2 in the Fixed Asset Options window. See Setting up Fixed Assets (page 14) for details.

1. Choose Transactions > Time Track > Time Card Entry.
2. Enter abatch ID, employee ID, and week-ending date.

& Thetransaction number is assigned when the transaction is saved or when you attach a note to the
transaction using the notepad button. See Entering notes (page 24). The number is taken from the
Computer Check field in the Payroll Setup Options window (Setup > Payroll > Payroll > Options).

w

Enter Asset-JC in the TRX type field.

4. Enter ajob number, day of week, and JC cost code number. For Asset-JC transactions, all cost codes except
labor will display.

5. Enter an asset ID. This cannot be the same as the job number. The system will verify that a cost recovery rate has
been established for the asset. If you selected Option 1 in the Fixed Asset Options window, the division must
correspond to that of the asset job number. If you selected Option 2, the division must correspond to that of the
Job Cost job number.

6. Enter the number of hours the asset was used.

7. View the total cost. The total cost calculates automatically and is calculated by multiplying the hours by the cost
recovery rate. The total cost will be used as the debit amount charged to the selected general ledger account.
See Set up cost recovery rate (page 15) for details. The Pay Rate field will always display $0.00.

8. Choose Save.

9. Commit the transactions. See Committing Time Card Transactions (page 29).

Entering Group Time Card Transactions

The Group Time Card Entry window provides a quick, easy way to create multiple time card transactions in a short
amount of time. In addition you can attach fixed assets to labor transactions, matching employees and/or fixed assets
to ajob and cost code.

In the Group Time Card Entry window, you can:

« Attach fixed assets to labor transactions, and create transactions for those assets. You simply select from a list of
applicable fixed assets, and the system automatically creates the fixed asset transactions for you.

« Create multiple transactions for a group of employees that have similar time card information. This is handy
when you have multiple employees working on the same job, and for which time card information would be
mostly similar for each employee (for example, job number, hours, pay code and so on).

« About time card entry workflow (page 26)

+ Before you begin (page 27)

«+ Creating group labor transactions (page 27)

+ Adding fixed asset transactions to labor transactions (page 28)
« Editing group transactions (page 28)

« Filtering your view of transactions (page 29)

About time card entry workflow

Even though the Group Time Card Entry window can save you valuable time, you may still choose to create your labor
transactions in the Time Card Entry window, but attach fixed assets to those transactions using the Group Time Card
Entry window. All you would do is open the payroll batch in the Group Time Card Entry window, and attach fixed assets
to those labor transactions. The Group Time Card Entry window is handy because you enter one time card transaction
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yourself, select the other employees, and the system automatically creates the remaining transactions, and adds them
to the payroll batch.

Before you begin

Before creating group fixed asset transactions, you must have fixed asset jobs set up in the Job Cost system. See Setting
up Fixed Assets (page 14) for information on setting up fixed assets for jobs.

Creating group labor transactions
There are two ways to create labor transactions in the Group Time Card Entry window.

+ Individually, as you would using the Time Card Entry window
+ As a group by entering one transaction manually, then selecting multiple employees for which time sheet
information might be similar (for example, the same job on the same day with the same pay code).

In either case, you need to enter at least ONE labor transaction manually.

1. Choose Transactions > TimeTrack > Group Time Card Entry. The Group Time Card Entry window opens.

2. Make sure the Group Type is set to Labor.

3. Select a batch.

4. Select a Week Ending Date and TRX Type. The fields in the Transaction Filters section of the Group Time Card
Entry window are used to filter your view once transactions are created. See Filtering your view of
transactions (page 29) for more information.

5. Fill the following fields:

« Employee ID
The employee for which this transaction will be created.
+ Job Number
The job on which this employee was working.
+ Cost Code
The cost code associated with this job and transaction.
« Day of the Week
The day of the week the work was performed.
+ Code
The pay code associated with this employee, and to be used for this transaction.
+ Hours
The number of hours worked for the selected day.
« The Group TRX # and TRX # fields are filled automatically by the system.

6. Press Tab to save this transaction and move to a new line. Notice that the TRX # field fills in with a number. At
this point, you can continue to create individual labor transactions, or use the Select Employees button to
automatically create transactions for multiple employees at once, using the same criteria from the first
transactions (i.e. same job, cost code, pay code, and so on). The remaining steps below pertain to group entry.

7. Click anywhere within the transaction on which you will base other employee's transactions, then click Select
Employees. The Employee Transactions window opens.

8. Available employees appear in the top half of the window. To select an employee, click on the employee in the
list, then click Insert>>. The selected employee moves to the bottom half of the window.

9. When finished, click Add Batch. This adds time card transactions to the payroll batch, which display in the Group
Time Card Entry window. If needed, you can delete the batch using the Delete Batch button at the top of the
Group Time Card Entry window. You can edit transactions by clicking inside the box and making your changes.
Changes are automatically saved when you tab off the row.
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& You cannot delete individual transactions from this window. You must do so using the Time Card Entry
window.

Adding fixed asset transactions to labor transactions

Once you have created labor transactions, you can select the fixed assets that apply to those transactions (and jobs),
and create transactions for those assets.

& Make sure the Integrate to Fixed Asset Management checkbox is marked in the TimeTrack Setup Options
window (Microsoft Dynamics GP > Tools> Setup > TimeTrack).

1. Inthe Group Time Card Entry window, change the Group Type to Fixed Asset.

2. Select a Batch Number, Week Ending Date, and Employee ID. (If you had entered labor transactions, but did
not close the window, the Week Ending Date and Batch Number. Simply select an Employee ID.) The labor
transactions for that employee display.

3. Select the labor transaction for which you want to create fixed asset transactions. To do this, click anywhere
inside the row that contains that transaction.

4. Click Select Assets. The Fixed Asset Transactions window opens.

5. Select a Cost Code Number.

6. Available job assets appear in the top half of the window. (Only assets that are attached to jobs appear.) To
select an asset, click on the asset in the list, then click Insert >>. The selected asset moves to the bottom half of
the window.

7. When finished, click Add Batch. This adds time card transactions to the payroll batch, which display in the Group
Time Card Entry window. The transactions are automatically saved to the batch. The fixed asset transaction
shares the same Group TRX # as the corresponding labor transaction, but also have their own individual TRX #.

8. To enter fixed asset transactions for additional employees, use the arrows in the Employee ID field to select the
next employee, or use the lookup button.

Editing group transactions

You can edit labor and fixed asset transactions from the Group Time Card Entry window. Click inside any of the boxes
and make your changes. In addition, when you edit a labor transaction, you have the option of rolling down those
changes to the corresponding fixed asset transactions, and to other labor transactions.

For example, if you mistakenly entered the wrong cost code for several labor transactions, you would manually change
the first transaction, then choose to have the system automatically change (roll down) the remaining transactions.
Fields changed that roll down to fixed asset transactions include:

« Job Number
« Day of Week
« Hours

Fields changed that roll down to other labor transactions include:

« Cost Code
« Pay Code

When you edit one of these fields, when you tab off the line, the system asks you if you want to roll down the changes to
the other transactions.

& You can also edit individual labor transactions using the Time Card Entry window.
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Filtering your view of transactions

If you have more than one screen full of transactions, you can filter which transactions display by selecting values for
one or more of the following:

« TRXType

« Job Number
« Day of Week
« Employee ID

Placing a Batch in Single-User Edit Mode

You can place a TimeTrack batch into single-user edit mode. The user who places the batch in single-user edit mode is
the only one who can view or edit the batch while it's in the edit mode.

& You cannot mark a batch for single-user edit and mark it to commit at the same time.

To mark a batch for single-user edit

1. Choose Transactions > TimeTrack > Time Card Commit.
2. Mark the Single-User Edit checkbox. The user ID of the person marking the batch for edit displays in the Marked
By field. That user is the only person who can view or edit the batch.

& The Mark All and Unmark All buttons are used for committing batches. Batches that are marked for single-user
edit are not affected.

When a user selects a batch in the Time Card Entry window or the Time Card Batch Entry window, if the batch is marked
as single-user edit by a different user, a message will appear indicating this, and the batch cannot be edited. If the user
selecting the batch is the person who marked the batch as single-user edit, the batch can be edited.

Committing Time Card Transactions

The commit process sends time card transactions to Service Management, Job Cost, Equipment Management, and
Microsoft Dynamics GP Payroll. The transactions will appear as actual costs against the service call, job, or workorder.
In Job Cost, costs will appear as actual costs, but only after a payroll post has been performed.

All transactions, except for fixed asset transactions, are saved to Microsoft Dynamics GP payroll files and can be posted
through the build checks process. This includes unbilled transactions. Fixed asset transactions can be batch posted or
series posted.

+ Approving a batch for committing (page 29)
« Committing time card transactions (page 30)

Approving a batch for committing
If you chose the option to require approval for batches to be committed, you must approve the batches.

1. Choose Transactions > TimeTrack > Time Card Batch Entry.
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2. Enterthe batch ID of the batch you want to approve. If you want to view the transactions before approving this

batch, use the printer button to print an edit list.

Mark the Approved checkbox.

4. Enterthe password for batch approval. After entering the correct password, the User ID and Approval Date fields
are populated with the current user and the system date.

5. Choose Save.

w

Committing time card transactions

1. Choose Transactions > TimeTrack > Time Card Commit.

2. Mark the Mark to Commit checkbox for each batch to be committed. If batch approval is required and a batch is
not approved, you are not able to mark the batch to commit. If you choose Mark All, only approved batches will
be marked.

3. Choose Edit List to print the Time Sheet Edit List. Approved transactions are verified after choosing Edit List.
Correct any errors and rerun the edit list. The Asset-JC and FA-GL transactions are grouped under a blank pay
code. The report will show the pay rate and labor amount only if the payroll option Display Pay Rate on TRX is
marked. The labor amount will display with or without overhead based on TimeTrack setup.

4. Choose the Commit button to commit the transactions in Microsoft Dynamics GP Payroll. You cannot commit
batches marked by other users. Committed transactions will appear on the Time Sheet Committed report.

If you marked the checkbox Create a Text File for Export and chose a file format of ADP in the Setup Options
window, the Commit button will be disabled and the Export button will be enabled. The commit process is
performed as part of the TimeTrack Export wizard. See Exporting TimeTrack data to a third-party payroll
module (page 38).

If you are using the batch week-ending date as the default week-ending date, transactions will not be committed
if the batch week-ending date is missing, the batch week-ending date does not match the transaction week-
ending date, or the batch week-ending date is not on the default week-ending day specified in the Setup Options
window.

If you are using SOP invoicing for Service Management, certain parts of SOP transactions are verified only when
committing the batch. Therefore, you may encounter additional errors when committing. If errors are found, a
message appears asking if you want to print the edit list to view the errors.

& The edit list that prints from the commit process error message will show SOP errors that occurred
when committing TimeTrack transactions to Service Management, but the edit list that prints from the
Edit List button in the Time Card Commit window will not show these errors.

After correcting the errors, recommit the batch without running the edit list. Running the edit list before
recommitting would cause the original errors to appear on the list even though they may have been corrected.

& Before you edit transactions that contain errors, you must unmark the Mark to Commit checkbox for
that batch in the Time Card Commit window.

If you marked the Integrate to Canadian Payroll option in the Setup Options window, you will be prompted to
save the committed transactions to a Canadian Payroll batch number. If you marked the Create a Text File for
Export checkbox in the Setup Options window, you will be prompted to choose a file to save the transaction to.
We recommend you use this feature as a backup if you are integrating with Canadian Payroll. You also can save
this text file to your Microsoft Dynamics GP directory. You can import this file into applications other than
Microsoft Dynamics GP.

30



5.

+ If a Job Cost transaction
When you commit a batch, the Job Cost transaction information goes directly to Microsoft Dynamics GP
Payroll and to Job Cost.
+ If an unbilled transaction
If you marked the Unbilled Transactions checkbox in the Setup Options window, when you commit a
batch, the unbilled information goes to Microsoft Dynamics GP Payroll and a batch is created in Microsoft
Dynamics GP with a prefix of UN. If the setup item was not marked, the transaction will only go to
Microsoft Dynamics GP Payroll.
« If a fixed asset transaction
When you commit a batch, a batch containing the FA-GL and Asset-JC transactions is created in Microsoft
Dynamics GP General Ledger with a prefix of FA.
« If an Equipment Management workorder transaction
When you commit a batch, a batch containing the workorder transactions is created in Microsoft
Dynamics GP General Ledger with a prefix of WO. If you marked the Create U.S. Payroll Transactions for
Workorders checkbox in the TimeTrack Setup Options window, a U.S payroll transaction is also created.
Post the committed general ledger batches. After a time card entry batch is committed, you can post the FA, UN,
and WO batches in the Batch Entry window (Transactions > Financial > Batches) or in the Master Posting window
(Routines > Master Posting). Once you post FA batches, the transactions appear in the Job Status window. Payroll
batches must be posted. See Entering payroll transactions in the Job Cost User Guide.

Editing Labor Transactions from Microsoft Dynamics GP

After the TimeTrack payroll batch is committed, you can partially edit labor transactions entered in TimeTrack from the
Microsoft Dynamics GP Payroll Transaction Entry window by zooming on the Product field. You cannot view or edit
TimeTrack transactions with Unbilled as the transaction type or expense or travel as the cost type from Microsoft
Dynamics GP.

1.
2.
3.

Choose Transactions > Payroll > Transaction Entry.

Choose the show/hide details button to see the details for a selected transaction.

Zoom on the Product field to open the Service Payroll Entry window or the Job Cost Payroll Entry window,
where you can edit certain fields for labor transactions. You cannot zoom on the Product field for Unbilled
transaction types or expense or travel cost types. When using SOP invoicing in Service Management, all
TimeTrack transactions with a transaction type of Service appear in Microsoft Dynamics GP as Unbilled.

Do not edit TimeTrack expense transactions in the Payroll Transaction Entry window. Data corruption may
occur. If the transaction must be changed, delete it and re-enter it in TimeTrack.

Using TimeTrack History

You can view the history of committed TimeTrack payroll transactions. This is helpful for reviewing the work performed
by an employee on a job or service call. You can view committed transactions in the Time Card History window and by
printing TimeTrack history reports.

« Setting up TimeTrack history (page 32)
« Viewing the time card history window (page 32)
+ Using TimeTrack history reports (page 32)

«+ Transaction history report (page 32)
« History notes (page 33)

31



Setting up TimeTrack history
To maintain TimeTrack history, you must mark the appropriate setup option.

1. Choose Microsoft Dynamics GP > Tools > Setup > TimeTrack > Setup Options.
2. Inthe Miscellaneous Items section, mark the Maintain History checkbox.
3. Choose Save.

Viewing the time card history window
The Time Card History window is a view-only version of the Time Card Entry window.

1. Choose Inquiry > TimeTrack > History.

2. Enter abatch ID. Only batches that include committed transactions are available. You can use the expansion
button in the Batch ID field to select an employee and week-ending date associated with this batch.

3. Ifthe Employee ID field is blank, enter an employee ID. Only employees associated with the selected batch are
available. You can use the expansion button in the Employee ID field to select a week-ending date associated
with this employee and batch.

4. The week-ending date appears in the Week Ending field based on setup options. You can edit this field. The
transactions for the selected batch appear at the bottom of the window.

5. Toview information for an individual transaction, double-click a transaction. The information appears in the
upper portion of the window.

6. To print an Employee Weekly Time Edit List, click the printer button. This list contains information for all
transactions displayed in the Time Card History window.

7. Choose OK to close the window. You can access the following history windows from the Time Card History
window:

+ View Payroll Fields window
To open the View Payroll Fields window, click the expansion button in the Pay Codes field.
« Time Sheet Certified History window
If a transaction is associated with a certified payroll job (as indicated by a marked Certified Payroll
checkbox), click the expansion button in the Hours field to open the Time Sheet Certified History window.
+ Notes History window
If a note is attached to a transaction (as indicated by a yellow notepad button), click the notepad button
in the Transaction Number field to open the Notes History window.

Using TimeTrack history reports

TimeTrack history reports contain committed transaction information and provide the ability to print history notes for
committed transactions.

Transaction history report

The Transaction History report contains a list of committed labor and/or expense transactions. For each transaction,
the report contains the employee name, transaction number, job number/service call, cost code, pay code, hours, and
total amount.

1. Choose Reports > TimeTrack > Transaction History.

2. Choose a product from the Product drop-down list. The default is ALL.

3. Choose whether to include labor transactions, expense transactions, or both in the report. The default is both.

4. Choose arange type from the Ranges drop-down list. You can print transactions by employee ID, job number/
service ID, or week-ending date. Use the lookups in the From and To fields to specify a range. If you are using
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Equipment Management with TimeTrack and you selected WO-EQS as the product type, choose Job Number/
Service Call ID as the range, then select the workorders in the From and To fields.

5. Choose Insert >>.

6. Choose Print.

History notes
History notes are notes from committed transactions.

1. Choose Reports > TimeTrack > History Notes.

2. Choose a product from the Product drop-down list. The default is ALL.

3. Choose arange type from the Ranges drop-down list. You can print notes by job number/service ID, author, or
modified date. Use the lookups in the From and To fields to specify a range.

4. Choose Insert >>.

5. Choose Print.

Using the TimeTrack Import Feature

By using the TimeTrack Import feature, field personnel can send data to the office via e-mail and have that information
automatically entered into the system. Labor, expense, travel, and fixed asset transaction data can be imported.

You can generate the Account Index List. The report provides a list of general ledger accounts and an index number.
This makes it possible to look up an index number and use it in the import file to link an unbilled or FA-GL transaction to
the general ledger account to be charged.

If Open Database Connectivity (ODBC) is used to import data directly to the WSWHSE table, a text note can be entered
for a transaction. Two fields, Warehouse Note String and Warehouse Note String2, are used to enter a note. Each field
holds a maximum of 255 characters.

+ Setting up the time sheet import file (page 33)
» Before importing a time sheet file (page 36)
«+ Step 1: Choose TimeTrack options (page 36)
+ Step 2: Create a batch file in Microsoft Dynamics GP (page 36)
« Step 3: Choose payroll options in Microsoft Dynamics GP (page 36)
+ Importing a time sheet file (page 37)
« Importing hours for certified payroll jobs (page 37)
« Creating an account index list (page 38)

Setting up the time sheet import file

If you are not using ODBC to import data directly to the WSWHSE table, the import file must be created as a tab-
delimited text file. Following is the order required for data entered in the import file. Each record in the file must be
entered in the order listed.

The tab-delimited text file containing the following fields, including blank fields, must be entered in the order listed, for
the system to populate the WSWHSE table and make that data available to TimeTrack.

& Afield must be created for each item listed here. If a field is not used, create a column for it in the time sheet
import file and leave it empty. The empty column will be skipped when the file is imported into TimeTrack.
Additionally, the import text file should not include the field names. The file should contain just the data to be
imported.
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Field

Batch ID

Week Ending Date

Employee ID

Signature Transaction Type

Signature Cost Type

Signature Job Number / Service Call
ID/ WO Number

Day of the Week

Signature Cost Code

Description

Avalue is not required for this field. A batch ID can be
entered in the Import Time Sheet window. However,
whenever a batch ID is found in the import file, it is used.
The ID entered in the import file overrides an ID entered
in the Import Time Sheet window. The Batch ID is limited
to 15 characters, alphanumeric characters only.

& Ifabatch IDis not entered, you must include
two tab characters that precede the Week
Ending Date field.

Format must be MM/DD/YY or MMDDYY. A week-ending
date can also be entered in the Import Time Sheet
window. A date must be entered in the import file or the
Import Time Sheet window. However, whenever a week-
ending date is found in the import file, that date is used.
The date entered in the import file overrides a date
entered in the Import Time Sheet window.

From Microsoft Dynamics GP employee setup.

Job Cost, Service, Unbilled, Asset-JC, FA-GL, or WO-EQS.
The first letter of each transaction type can be used.

In the tab-delimited text file, use:

1 for labor

2 for expense

3 for travel

4 for fixed asset

If the Signature Cost Type field is empty, the system
enters a value of:

4 if the transaction type is asset-JC or FA-GL.

1if the transaction type is Job Cost, Service, Unbilled, or
WO-EQS.

First letter(s) or integer abbreviation.

For labor cost types, codes 6 - 10 are valid.
For expense cost types, codes 1,2, 4, and 5 are valid.
For travel cost types, code 5 is valid.
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Field Description

9 Equipment ID

10 Cost Code Number - CC Phase Each segment of the cost code must be in a separate
field. Insert an empty space for unused segments. A
maximum of four segments are allowed.

11 Cost Code Number - CC_Step Each segment of the cost code must be in a separate
field. Insert an empty space for unused segments. A
maximum of four segments are allowed.

12 Cost Code Number - CC_Detail Each segment of the cost code must be in a separate
field. Insert an empty space for unused segments. A
maximum of four segments are allowed.

13 Cost Code Number - Component Each segment of the cost code must be in a separate
field. Insert an empty space for unused segments. A
maximum of four segments are allowed.

14 Cost Element For labor transactions, must be 1.
For expense, travel, or fixed asset transactions, codes 2 -
9 are valid.

15 Pay Rate Amount / Hour Pay Rate Amount / Hour (optional)
Pay Rate Amount/ Unit (optional)
In TimeTrack, the value defaults from the pay code if the
field is empty.

16 UPR Trx Code (Pay Code) Use a business expense pay type for expense or travel
transactions.
Do not use a pay code for asset-JC or FA-GL transactions.

17 Trx Hours / Units Trx Hours/Units (Actual Units multiplied by 100)
or Trx Qty Trx Qty for expense or travel - Do not multiply the units
by 100.

18 Account Index For unbilled and FA-GL transactions only. To use with
unbilled transactions, the Create a Journal Entry for
Unbilled Transactions option must be selected in the
Setup Options window. To use with FA-GL transactions,
the option, Integrate to Fixed Asset Management, must
be selected in the Setup Options window. See Creating
an account index list (page 38).
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Field Description

19 Asset ID Enter a value for asset-JC or FA-GL transactions only.
Leave the field empty for other transactions.

20 Transaction Description Use up to 30 characters for a description. Leave the field
empty for asset-JC or FA-GL transactions.

21 Department

22 Task ID For WO-EQS transactions only. If a task ID is not entered,
a tab character must follow the Transaction Description
field.

23 Union Code

Before importing a time sheet file

Perform the following setup procedures before importing a timesheet file.

Step 1: Choose TimeTrack options

1. Choose Microsoft Dynamics GP > Tools > Setup > TimeTrack > Setup Options.
2. Select the following options:
« Under Third Party, mark the Integrate to Fixed Asset Management checkbox if you want to import fixed
asset transactions.
« Under Create a GL Journal Entry For, mark the Unbilled Transactions checkbox if you want to create a
journal entry for unbilled transactions.
« Under Miscellaneous Items, mark the Create Expense/Travel Transactions checkbox. Fields for importing
expense and travel data will be available in TimeTrack.

Step 2: Create a batch file in Microsoft Dynamics GP

Choose Transactions > Payroll > Batches. If a batch is not created, TimeTrack creates a single-use batch file. In the batch
comment area the message, Created from TimeTrack import, is displayed.

Step 3: Choose payroll options in Microsoft Dynamics GP

1. Choose Setup > Payroll > Payroll > Options.

2. Under the Options section, mark the Edit Financial Fields checkbox and the Display Pay Rate on Trx checkbox.
When these options are marked, a pay rate amount can be imported. If the options are not marked, the value for
the pay code is used as the default value.
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Importing a time sheet file

Once you have received and saved an appropriately formatted text file containing TimeTrack data from the field, you
can import that data into your system through the TimeTrack Import window.

1.

10.

11.
12.

13.

14.

Choose Microsoft Dynamics GP > Tools > Integrate > TimeTrack > Import.

2. Enter a path to the text file or select the folder button to locate the path.
3.
4. Inthe Import Time Sheet window, if you are not using ODBC to import data directly to the WSWHSE table, select

Choose Next > to open the Import Time Sheet window.

Update Warehouse. The file is imported into a TimeTrack data table. If you are using ODBC to import data
directly to the WSWHSE table, skip this step.

Choose a Batch ID to use if the batch ID is not imported with the time sheet file. If you are using the Default Date
From Batch option, the following is true:

The Default Week Ending Date field will be locked. If a week-ending date is not imported with the time sheet file,
the date will be that of the batch entered in the Import Time Sheet window.

If the batch entered does not have a week-ending date, the transactions in the batch will not be imported.

If the week-ending date of the batch entered does not fall on the default week-ending day specified in the Setup
Options window, the transactions in the batch will not be imported.

If the week-ending date of the transaction in the import file is different than the batch week-ending date, the
batch date will be used for the transaction.

& You cannotimport transactions into a batch that has been approved for committing or has been
marked as single-user edit.

Choose the Default Week Ending Date to use when date is not imported with the time sheet file. The date will
default based on setup options for the week-ending date.

Select Build Time Sheets. The transactions are created in TimeTrack from the time sheet import file data.

If errors are found, choose the Print Audit button to generate an Exceptions report and view the error
descriptions. For example, if there are 10 transactions, six without errors and four with errors, the six that are
fine will be imported; the remaining four will appear on the Exceptions report. Let's say that, out of the four
transactions with errors, two contain valid data in the import file, but additional changes need to be made on
the system (for example, a job or cost code needs to be activated) - and the remaining two contain errors in the
import file. After you fix all the errors (both within the system and in the import file), you must re-import the time
sheet (before re-building) because changes have been made to the import file. In addition, before you re-build
the time sheets, you must remove the transactions from the import file that have already been built successfully
(in our example above, the six transactions). Otherwise, you will get duplicate transactions. An alternative is to
remove all the TimeTrack transactions from the import file by deleting the batch.

& The TimeTrack transactions will not display in the Payroll Batch Entry window.

After the transactions have been removed, choose Build Time Sheets again to create the transactions in
TimeTrack.

Commit the transactions. See Committing Time Card Transactions (page 29).

Importing hours for certified payroll jobs

If 40 hours are imported for a certified payroll job, TimeTrack distributes eight hours to each day of that week, Monday
through Friday. If less than 40 hours are imported, the hours will not be distributed to multiple days. You must
distribute the hours to multiple days using the Time Card Entry window. You cannot import more than 40 hours per
transaction.
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Creating an account index list

To determine the index number to enter in the time sheet import file for a transaction that is charged to a general
ledger account, generate the Account Index List.

1. Choose Reports > TimeTrack > Account Index List.
2. Select a destination for the report and choose OK in the Report Destination window. The length of the report
depends on the number of accounts set up in Microsoft Dynamics GP.

Exporting TimeTrack Data to a Third-Party Payroll Module

You can export TimeTrack data to a third-party payroll module. To set up the export file, you map TimeTrack fields to
third-party payroll module fields. You also specify a file name and location for the export file.
Currently, you can export TimeTrack data for the ADP PC/Payroll module.

Setting up and using the TimeTrack export feature involves the following:

« Step 1: Enable the export feature (page 38)
« Step 2: Set up the export file (page 38)

« Fields required by ADP Payroll (page 39)
« Step 3: Create an export file (page 39)

Step 1: Enable the export feature
To enable the export feature, you must mark the setup option and select the file format to be used for the export file.

1. Choose Microsoft Dynamics GP > Tools > Setup > Time Track > Setup Options.

2. Inthe Third Party section, mark the Create a Text File for Export checkbox. The File Format drop-down is
enabled.

3. Inthe File Format drop-down list, select ADP as the file format.

4. Choose Save.

Step 2: Set up the export file

To set up the export file, you map TimeTrack fields to third-party payroll module fields. You also specify a file name and
location for the export file. The export file must contain a .CSV (comma-separated values) extension.

1. Choose Microsoft Dynamics GP > Tools > Setup > Time Track > Export File Setup.

2. Enter a company code.

3. Inthe Default Pathname for Export File field, enter a location followed by a file name for your export file. Click
the yellow folder button to search for a location. The recommended location for ADP files is: C:
\ADP\PCPW\ADPDATA\<filename>

& When you click the yellow folder button, the Default Path for Export File window opens. If you select a
location from this window, you must also type the file name in the same window. If you include the file
extension in the file name, you must type it manually. The value (.CSV) in the File type field does not
carry over into the Default Path for Export File field in the Export File Setup window.

The Export File Setup window fills in with the available fields.
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« Each row represents a single field of data that can be exported. The most commonly-used (and
required) fields are already selected, as indicated by the checkboxes in the Include column. To
view additional rows, use the scroll bar on the right side of the window.

+ The Column Name column references a corresponding column in the Signature holding table
(Thisis an internal table that stores information to be included in the export file). The Field Name
column contains the ADP fields.

& Some of the default fields are required by the third-party payroll module. See Fields required by ADP
Payroll below for a list of fields required by the third-party payroll module to which you are exporting.

4. Toinclude a field in the export file, mark the Include checkbox for that field. Fields required by the third-party
payroll module are selected by default.

5. Use the Mapped Field lookup button to select a TimeTrack field to map to the corresponding ADP field.

6. The SQL Statement column contains code that is automatically generated when you map a TimeTrack field in
the Mapped Field column. You can customize the mapping of the fields by editing these statements and/or SQL
stored procedures.

& To edit SQL statements or stored procedures, you should be familiar with Microsoft SQL Server. For
help, contact WennSoft Support.

7. When you're finished with the Export File Setup window, click OK.
8. To print the Export File Setup List for the selected company only, click the printer button. To print the Export File
Setup List for all companies, click the Clear button to clear the window, then click the printer button.

Fields required by ADP Payroll
The following payroll fields are required by ADP Payroll module:

« CoCode
« BatchID
o File#

See the ADP PC/Payroll user manual for more information on ADP requirements.

Step 3: Create an export file

You create an export file using the TimeTrack Export Wizard. You can also choose to commit the TimeTrack batch as
part of the export process. This is analogous to clicking the Commit button in the Time Card Commit window.

1. Choose Transactions > TimeTrack > Time Card Commit.
2. Select a batch. You can create an export file for multiple batches.
3. Choose Edit List to view the transactions before exporting. Transactions are verified after choosing Edit List.

& ferrors appear in the edit list, do not continue with creating the export file. After correcting the errors,
you can continue with the export process.

Choose Export to display the Welcome to the TimeTrack Export Wizard window.

Choose Next to display the Company Code and File Pathname window.

In the Company Code field, use the lookup button to select a company code.

The file and location default from the Export File Setup window. You can change the file and location of the
export file. To change the location, use the folder button in the File Pathname field to search for a location.

8. Enter the Period End Date for each technician record. If there are multiple daily hours logged for the week, all
hours for a technician appear under one record with this end date.

No ok
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9. Choose Next. After a few moments, the Report Destination window appears. Select a destination for the report.
We recommend that you mark the Screen checkbox to view the report on screen. The TimeTrack Export Wizard
creates an Export report that shows the batch ID(s) and other information relating to the batch(es).

10. When you finish viewing the report, close the report window. The Time Track Export Wizard continues and the
Create export text file window appears.

11. Choose Next to create the export file. When the export is finished, the Commit selected batch window appears:

12. Choose Commit to commit the batch. When finished, the Report Destination window appears. The TimeTrack
Export Wizard creates the TimeTrack Commit report.

& fyou choose Cancel or Back instead of Commit, the information in the export file is deleted. To create a
new file, you must start the TimeTrack Export Wizard from the beginning.

13. When the commit process is finished, choose Finish.

& For SOP invoicing for Service Management users, if errors were found during the commit process, you must fix

the errors and re-create the export file. See Correcting Commit Errors and Re-Creating the Export File (page 40)

for more information.

Correcting Commit Errors and Re-Creating the Export File

If errors were found during the commit portion of creating the export file, you must fix the errors, re-create the export
file, and copy and paste the corrected transactions into the original export file.

When you re-create the export file, valid transactions previously included in the original export file will not be re-created
in the export file. Therefore, do not delete the original export file.

& This section applies primarily to users of SOP invoicing for Service Management, since errors are not reported
until after the commit process and cannot be fixed until after the export and commit processes have finished.

1. Fix the transactions that contain errors.
2. Re-create the export file using a different file name than the original export file, and recommit the batch.

See Create an export file (page 39).

3. Open both export files. These files should contain a .CSV extension, and appear in the folder you designated in
the File Pathname field in the Company Code and File Pathname window of the TimeTrack Export Wizard. The
default folder is C:\ADP\PCPW\ADPDATA.

4. Inthe re-created export file, copy a fixed transaction, highlight the corresponding transaction in the original file,
then paste the new transaction into the original export file. Repeat this step for each transaction that was re-
created in the export file.

a « To copy an entire row in Excel, click the first column of the transaction, hold down the Shift key,
then click the last column of the transaction.

« Make sure you do not overwrite valid transactions that appear in the original export file.

5. Save the original export file

Rebuilding the Payroll Keys Master Table

The Payroll Keys Master table tracks all payroll transaction numbers. If this table becomes corrupt or incomplete, you
can rebuild it to prevent duplicate transaction numbers. Existing data isn't deleted by using this utility.
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& Verify no other users are logged in to TimeTrack before performing this utility.

1. Choose Microsoft Dynamics GP > Tools > Utilities > TimeTrack > Rebuild.

2. Mark the products you want to rebuild the Payroll Keys Master table for.

3. Choose Rebuild. The following message appears: It is recommended that you back up your data before running
this utility. Do you want to continue?

4. If you have backed up your data, choose Continue. If not, back up your data, then proceed.

Using the Transaction Transfer Utility

You can use this utility to transfer employee TimeTrack transactions to a different batch.

1. Go to Microsoft Dynamics GP > Tools > Utilities > TimeTrack > Transaction Transfer.

Choose the source Batch ID.

Choose the blue arrow button to choose the Employee ID whose transaction(s) need to be transferred.

Choose the Destination Batch ID and enter the Week Ending Date.

Choose Redisplay to populate the Source scrolling window with the transactions for the employee selected.
Mark checkbox(es) next to the transactions to transfer and then choose Insert >>to move the transactions to the
Destination scrolling window.

If you need to move transactions from the Destination scrolling window back to the Source scrolling window,
mark the appropriate checkbox(es) and then choose Remove >>.

7. Choose Process to complete the transfer.

ou s wN

Manager Approval of Time Card Transactions

The manager approval feature allows managers or supervisors to approve employees' time card transactions before
committing those transactions. If manager approval is required, TimeTrack transactions will not be committed until
they have been approved.

You can set up e-mail notifications that will let the manager know when a time card is ready for approval and let the
employee know when a manager approves or rejects a transaction. If a transaction is rejected, the manager can also
receive an e-mail notification when the employee corrects and saves the transaction.

The manager approval feature also allows managers to print a report that lists employees who have not entered all
their time for the week.

Setting up the Manager Approval Feature
To enable manager approval and e-mail notifications, you must perform the following setup steps.

«+ Step 1: Setting up database mail (page 42)
+ Step 2: Enabling manager approval and e-mail notifications (page 42)
« Step 3: Verify that e-mail addresses and managers are set up (page 43)
« Setting up e-mail addresses in Microsoft Dynamics GP (page 43)
+ Setting up e-mail addresses in TimeTrack (page 43)
+ Specify a manager for each employee (page 43)
+ Giving managers permission to approve other managers' timecards (page 44)
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Step 1: Setting up database mail

TimeTrack e-mail notifications require SQL Server Database Mail to be set up. Database Mail allows you to set up an
account that uses an SMTP server and e-mail address to automatically send e-mails. The account is assigned to a
profile, and the default Database Mail profile can be used to send manager approval request notifications from
TimeTrack.

If you already have a profile and account set up, make sure the profile you want to use for TimeTrack notifications is set
as the default profile. If you need to create a new profile, complete the steps below. Refer to the Microsoft SQL Server
help for further details on account and parameter setup.

The following instructions are for Database Mail setup on SQL Server 2008 R2. Setup steps may vary for different SQL
Server versions.

1.

orwWN

10.

11.

Open SQL Server Management Studio.

In the Object Explorer sidebar, expand Management.

Right-click Database Mail, and select Configure Database Mail.

On the first screen of the Database Mail Configuration Wizard, choose Next >.

Mark the Set up Database Mail... radio button, and choose Next >.

On the New Profile page, enter a Profile Name and Description. Use the Add... button to add an SMTP account
to this profile.

On the Add Account to Profile window, use the drop-down menu to select an existing account, or use the New
Account... button to set up a new account. Once you have selected an account, choose OK to close this window
and add the account to the profile.

When you are finished setting up the profile, choose Next >.

On the Manage Profile Security page, mark the Public checkbox next to the profile. Set this profile as the default
by selecting Yes from the Default Profile drop-down menu. Choose Next >.

On the Configure System Parameters page, specify the options that you want to use for Database Mail. Choose
Next >.

When you are done setting up the profile, choose Finish. Additionally, if you are using Microsoft Office x64 as the
default mail client, the server type must be set to Exchange on the System Preferences window (Microsoft
Dynamics GP > Tools > Setup > System > System Preferences).

Step 2: Enabling manager approval and e-mail notifications

Complete the following steps to enable the manager approval feature and customize the e-mail notifications that you
want to use.

1.
2.

Choose Microsoft Dynamics GP > Tools > Setup > TimeTrack > Setup Options.

Mark the Require Manager Approval checkbox to require that time cards be approved before they can be
committed.

Mark the E-Mail Notification checkbox to enable e-mail notifications. This checkbox is enabled only when the
Require Manager Approval setting is turned on.

& Email notifications only work if you are using TimeTrack for manager approval. If you will be using
Clock for time entry and approval, these settings will not apply. Most notifications work with
MobileTech time entry submissions, unless noted otherwise.

Mark the additional checkboxes as necessary to customize e-mail notification options.

+ Notify Manager when Employee Submits Time Card for Approval
Mark this checkbox to send a notification to the employee's manager when a time card is submitted for
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approval. The employee will not need to notify the manager personally when the time card is ready for
approval.

+ Notify Employee when Time Card is Rejected by Manager
Mark this checkbox to send a notification to the employee when a time card is rejected. The manager will
not need to notify the employee personally when a time card is rejected.

+ Notify Manager when Employee has Updated Rejected Trx
Mark this checkbox to send a notification to the manager when an employee updates a rejected
transaction. The employee will not have to re-submit the time card after it is updated.

& This option only works when transactions are updated in TimeTrack. If a technician updates a
rejected time entry in MobileTech, an email notification is not sent to the manager - however the
manager will receive an email when the time entry is resubmitted if Notify Manager when
Employee Submits Time Card for Approval is marked.

+ Notify Employee when Manager Prints the Time Card Entries Exception Report
Mark this checkbox to send a notification to the employee when the exception report is printed by the
manager. This report is printed when an employee lists fewer than 40 hours of time for the week.
Employees on this list will receive a notification.
5. Choose Save.

Step 3: Verify that e-mail addresses and managers are set up

Before e-mail notifications can be sent to employees and managers during the time card approval process, e-mail
addresses must be set up for all registered TimeTrack users.
You must also specify the manager of each employee on the Signature Registered Users Setup window. See Signature

registered users (page 9) for more information.

Setting up e-mail addresses in Microsoft Dynamics GP

E-mail address entered on the Employee Maintenance window in Microsoft Dynamics GP will automatically populate on
the Signature Registered Users Setup window.

1. Choose Cards > Payroll > Employee. The Employee Maintenance window opens.

2. Choose the employee and select the Internet Addresses button located next to the Address ID field. The Internet
Information window opens.

In the E-mail field, verify or enter an e-mail address.

4. Choose Save, then Save again in the Employee Maintenance window.

w

Setting up e-mail addresses in TimeTrack

If e-mail addresses were set up on the Employment Maintenance window in Microsoft Dynamics GP, they will populate
on the Signature Registered Users Setup window in Time Track. Otherwise, you can enter them manually.

1. Choose Microsoft Dynamics GP > Tools > Setup > TimeTrack > Registered Users. The Signature Registered Users
Setup window opens.

2. Inthe E-Mail Address field, enter the employee's e-mail address.

3. Choose Save. The window closes.

Specify a manager for each employee

You must specify a manager for each employee to use the manager approval feature.
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1. Choose Microsoft Dynamics GP > Tools > Setup > TimeTrack > Registered Users. The Signature Registered Users
Setup window opens.

2. Foreach TimeTrack user, use the lookup to select a Manager ID.
3. Choose Save.

Giving managers permission to approve other managers' timecards

To give managers the ability to approve other managers' timesheets, you must set up the approving manager as a
power user.

& The power user classification applies ONLY to TimeTrack, and not to any other Signature products.

1. Choose Microsoft Dynamics GP > Tools > Setup > TimeTrack > Registered Users. The Signature Registered Users
Setup window opens.

2. Locate the user and mark the Power User checkbox.

Repeat this step for every manager authorized to approve employee timecard transactions.

4. Choose Save.

w

Using the Manager Approval Feature

The manager approval feature allows for the following:

« Users can submit time card transactions for manager approval
« Managers can approve or reject time card transactions

Additionally, e-mail notifications will be sent based on the setup options specified.

+ Submitting for approval (page 44)
+ Examining an e-mail notification in your e-mail program (page 45)
« E-mail subject line (page 45)
+ E-mail body (page 45)
+ Approving or rejecting TimeTrack transactions (page 45)
+ Checking which employees have not entered all their time (page 45)
+ Time Sheet Edit List report (page 46)

Submitting for approval

If e-mail notifications are enabled in TimeTrack for manager approval, and the Submit for Approval feature is set up,
you can automatically send your manager an e-mail to let him or her know when all your transactions for the week have
been entered and are ready for approval.

1. Choose Transactions > TimeTrack > Time Card Entry.

2. Onthe Time Card entry window, enter transactions as you normally would.

3. When you are done entering all your transactions for the week, and you are ready for your time card to be
approved, select the Submit for Approval button.

You will receive an error message if there is any missing information, or if a row is still in edit mode. If the submission is
successful, you will receive a notification telling you the time card has been submitted. An e-mail will be sent to your
manager, and you will receive a copy. Depending on the other TimeTrack setup options that are marked, you may
receive a notification if your time card is rejected or an exception report is printed.
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Examining an e-mail notification in your e-mail program

Regardless of the e-mail program your company uses, the content of TimeTrack e-mail notifications will be uniform,
depending on the reason the e-mail was sent.

E-mail subject line
The Subject line contains one of the following subjects, depending on the type of notification.

« For rejected transactions, the following text appears: Rejected Time Card Entries
» For approved transactions, the following text appears: Approved Time Card Entries
« If any transactions in a batch were rejected and you committed the batch, the following text appears: HOLD

E-mail body
The body of the e-mail contains a general format, depending on the type of notification.

« For approvals, the following text appears: <Manager ID> has approved the following transactions: <transaction
number>.

« Forrejections, the following text appears: <Manager ID> has rejected the following transactions: <transaction
number> Manager's Comment: <comment>.

Approving or rejecting TimeTrack transactions

As a manager, you can approve or reject time card transactions when the Manager Approval feature is enabled.

Checking which employees have not entered all their time

Before you approve or reject time card transactions, you can print a report that lists the employees who have not
entered all their time for the week.

1. Choose Transactions > TimeTrack > Time Card Approval. The Time Card Approval window opens.

2. Onthe Time Card Approval window, select the printer button at the top right portion of the window.

3. Select the print destination. When you click OK; if your system is set up for automatic e-mail notification, you will
receive the following message: Do you want to send a notification to all employees in the list?

4. Choose Yes or No. The Time Card Entries Exception List report displays.

The Manager ID populates automatically based on the active user.

6. Enter a Batch ID, Week Ending Date, and Employee ID. Only employees assigned to you (the manager or
supervisor) are available for approval.

7. Double-click a transaction to select for review.

8. Do one of the following:

« To approve a transaction, click the Approve radio button. An Approved status indicator appears in the
Approved column.

« To reject a transaction, click the Reject radio button to send it back to the employee for corrections. A
Rejected status indicator appears in the Approved column, and the Manager's Comments field is
enabled. Enter a reason for rejecting the transaction.

» To approve all transactions, make sure at least one transaction is selected, and click the Approve All
button at the top of the window.

@
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If you attempt to commit a TimeTrack batch that contains unapproved transactions for an employee, the following
message will appear while in the Time Card Commit window:
There are unapproved/rejections in batch <batch ID>. Not all transactions will be committed. Do you want to continue?

Time Sheet Edit List report

For transactions that have not been approved, the following message will appear on the Time Sheet Edit List report:
This transaction has not been approved and will not be committed.

Document Attachments for TimeTrack

If you are using the Advanced Document Management module in Service Management or Job Cost, you can use
document attachments in TimeTrack as well. Documents can be attached to time card entries, which is useful if you
have an expense report that you want to submit with your time card entry at the end of the week. Files are attached on
the Time Card Entry window, and those attachments can be viewed on the Time Card Entry, Time Card Approval, and
TimeTrack History windows.

When a record does not have documents attached, a paper clip icon displays. When documents are attached, the icon
shows a paper clip attached to a piece of paper.

Transactions with attachments cannot be mass approved. During the bulk approval process, transactions with
attachments will be rejected to be approved individually. After the time card entry is approved, attachments can no
longer be added or edited for the approved entry.

Using the Document Attachments Feature

+ Adding a new attachment (page 46)
« Time card approval (page 47)

+ Deleting an attachment (page 47)

+ Deleting a transaction (page 47)

Adding a new attachment
Complete the following steps to add a document attachment to a Time Card entry.

1. Choose Transactions > TimeTrack > Time Card Entry. The Time Card Entry window opens.

2. Double-click an existing entry from the scrolling window, or create a new time card entry. To create a new entry,
select a Batch ID, Employee ID, Week Ending Date, and Job Number/Service Call ID, if applicable.

3. Toadd an attachment to the entry, select the paper clip icon next to the Transaction Number field. The

Document List window opens. This window displays the attachments for this transaction.

Choose Add, and the Document Maintenance window opens.

Enter the Format of the attachment, as well as a Description and Date.

6. If you are attaching a file that is located online, mark the Internet/Extranet Address checkbox. When this
checkbox is marked, the Select File button is disabled. Enter the URL of the attachment in the grey text field next
to the button. The attachment will be opened from the URL. Skip to step 9.

7. If you are attaching a file from your computer, use the Select File button to browse for the file that you want to
attach.

8. Select the radio button that indicates the type of document attachment you want to create.

o~
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10.

11.

+ Copy File
This method will copy the file to the attachments folder on the shared server under \timetrack. The copy
will be opened from this location on the shared server. The file name of the attachment will be
automatically generated with the appropriate format extension. The file name will appear in the non-
editable Document ID field.
«+ Attach File
This method will attach the file from any location. The path to the file is saved, and the file will open from
that location. This method uses less hard disk space, but the attachment cannot be opened if the file is
ever moved.
« Copy to Database
This method will copy the file to the Microsoft SQL Server database. The copy will be opened from the
database. This method offers a more secure connection to attachments and makes the documents easier
to manage.
Choose Save. The attachment is saved to the transaction and displays on the Document List window. From the
Document List window, you can Add a new attachment, or Edit or Display an existing attachment.
Exit the Document List window to return to the Time Card Entry window. The attachments button next to the
Transaction Number field indicates that there is an attachment.

& fyou decide to Clear the window before your time card entry is saved, the attachment will also be
cleared. If the attachment was copied to the shared server or database, it will be deleted.

Finish all necessary fields to complete the time card entry, and Save the transaction when you are done.

Time card attachment(s) can be viewed from the Time Card Entry, Time Card Approval, and TimeTrack History
windows.

Time card approval

After a manager approves your time card transaction in Time Card Approval, you can no longer add a new attachment
or edit an existing attachment. You can view the attachments associated with the time card transaction. If a manager
rejects your time entry in Time Card Approval, you can continue to edit document attachments.

Deleting an attachment

Attachments can be deleted from a time card transaction. If the attachment was copied to the shared server or
database, it will be deleted from that location after the attachment is deleted in TimeTrack.

1.
2.
3.

Choose Transactions > TimeTrack > Time Card Entry. The Time Card Entry window opens.

Select the Batch ID and Employee ID, and double-click an existing transaction entry from the scrolling window.
Select the paper clip icon next to the Transaction Number field. The Document List window opens. This window
displays the attachments for this transaction.

Select an attachment, then choose Edit. The Document Maintenance window opens.

Choose Delete. The attachment is deleted from the time card transaction. If the attachment was copied to the
shared server or database using the Copy File or Copy to Database methods, the file will be deleted from that
location as well.

Deleting a transaction

If a transaction that has an attachment is deleted, and the attachment was copied to the shared server or database, the
attachment will be deleted from that location after the transaction is deleted in TimeTrack.

1.

Choose Transactions > TimeTrack > Time Card Entry. The Time Card Entry window opens.
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2. Select the Batch ID and Employee ID, and, if necessary, double-click to select an existing entry from the
scrolling window.
3. Choose Delete. You are prompted to delete the entire week or a single transaction.
+ Single TRX
The transaction and any attachments associated with the transaction are deleted.
« Entire Week
All transactions and attachments for the entire week are deleted.
4. When asked to confirm your choice, choose Delete.

The specified transaction or week is deleted, along with any attachments. If an attachment was copied to the shared
server or database using the Copy File or Copy to Database methods, the file will be deleted from that location as well.

Setting up the Document Attachments Feature

Setup of this feature involves creating an attachments folder and mapping the attachments folder to the server. If you
have previously used the Advanced Document Management module in Service Management or Job Cost, the
attachments folder may already be mapped to the server. If so, you only need to perform Step 2 below.

« Step 1: Create a folder for document attachments (page 48)
« Step 2: Create a subfolder for TimeTrack attachments (page 48)
« Step 3: Map the attachments folder to the server (page 48)

« Step 4: Map the temporary folder location (page 49)
« Step 5: Update the next document number (optional) (page 49

+ Creating the pathname to the document-viewing application (page 49)

Step 1: Create a folder for document attachments

& Before performing this procedure, verify no one is logged in to Microsoft Dynamics GP.
Complete this step to create a folder that will hold your attachments. The attachments folder must be created on the
shared server so everyone can access the attachments.

1. Browse to the directory where Dynamics is installed, for example, C:\Program Files (x86)\Microsoft
Dynamics\GP2010.
2. Inthis location, create a folder called docs.

The document attachments folder now exists on the shared server.

Step 2: Create a subfolder for TimeTrack attachments
TimeTrack attachments must be saved in a subfolder of the attachments folder on the shared server.

1. Browse to the attachments folder, for example, C:\Program Files (x86)\Microsoft Dynamics\GP2010\docs.
2. Inthis location, create a folder called timetrack.

The TimeTrack document attachments subfolder now exists on the shared folder.

Step 3: Map the attachments folder to the server

Add the following line to the DEX.INI file on each client workstation:
WS_DocRoot=H:\GP\docs\ (must end in backslash)
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« where H is a shared mapped drive
« where GP is the name of the Microsoft Dynamics GP folder on the shared SQL server
+ where docs is the document attachments folder in the Microsoft Dynamics GP folder

Step 4: Map the temporary folder location

You must specify a temporary folder to be used when viewing attachments that were copied to the database.
Add the following line to the DEX.INI file on each client workstation:

WS_TempDir=C:\temp\ (must end in backslash)

« where Cis the local drive
« where temp is the name of the folder that will hold the attachments

Step 5: Update the next document number (optional)

If you have multiple companies that are using document attachments, the "Copy File" method saves attachments for all
companies to the same shared location. You will receive an error when saving an attachment if the next document
number that defaults has already been used by another company.

You can set the next document number to be different for each company by updating the WSDOCS field in the WSSEQ
table. The maximum document attachment number is 2,147,843,648; determine how you want to divide this number
based on the number of companies you have.

For example, if you have three companies, you may choose to start Company A with the next number of 1, but perform
the following two SQL actions to update the next number for the other two companies:

Company B: UPDATE WSSEQ SET WSDOCS = 715947882

Company C: UPDATE WSSEQ SET WSDOCS = 1431895766

Creating the pathname to the document-viewing application

If a file extension association was established in Windows Explorer, the system uses that association when viewing
document files. You must create a pathname to the document-viewing application only if a file extension association
does not exist in Explorer, or if you want the ability to override the association established in Explorer.

To create the pathname to the document-viewing application:

1. Choose Microsoft Dynamics GP > Tools > Setup > Service Management > Module Setup > Document Viewers.

2. Enter athree-character document type in the Type field.

3. Inthe View Path field, enter the location of the application's executable file. This must be entered in the
following format: :c:directory/XXXXX.exe

4. Choose Save.
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Contact Information

Contact Information

Support & Sales

Support Phone: 262-317-3800

Email: support@wennsoft.com

Hours: Normal support hours are 7:00 a.m. to 6:00 p.m. Central Time. After-hours and weekend support is available for
an additional charge. Please contact WennSoft Support for more information.

WennSoft will be closed in observance of the following holidays: New Year's Day, Presidents' Day, Memorial Day,
Juneteenth, Independence Day, Labor Day, Veterans' Day, Thanksgiving Day, the Day after Thanksgiving, Christmas
Day, and the Day after Christmas.

Support Plans
We're committed to providing the service you need to solve your problems and help your team maximize productivity.

We offer several Signature Enhancement and Support Plans to meet your needs and Extended Support Plans for retired

product versions available at https://www.wennsoft.com/wsportal.

Sales
Phone: 262-317-3700
Fax: 262-317-3701

Address

WennSoft Headquarters
1970 S. Calhoun Rd.

New Berlin, WI 53151-1187

Phone: 262-821-4100 or 866-539-2228

Email: info@wennsoft.com

Website: www.wennsoft.com

Office hours: Monday through Friday from 8 a.m. to 5 p.m. Central Time.



https://www.wennsoft.com/wsportal.
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