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Job Cost Introduction
Signature Job Cost adds important job costing features to the Microsoft Dynamics GP application. Job Cost allows you 
to analyze job-related costs, billings, and profits, helping you make accurate and timely business decisions.

The ability to make informed, fast business decisions is one of the most significant benefits of a computerized 
accounting system, and Job Cost leads the way in facilitating those decisions.

Posting Flow Documents
Posting flow documents are available to aid your understanding of system procedures, table relationships, and data 
flow. These documents can be found in Posting Flow Documents1. 

Signature Action Lists for JC
Lists provide quick access to records and information, helping to reduce the amount of time that it takes to complete 
some of your daily tasks within Signature. You can use lists to perform actions on multiple records at once.

Accessing Signature lists (page 1)
Performing an action on a list item (page 2)

Service Management (page 3)
Job Cost (page 3)

Accessing Signature lists
Lists are displayed in the content pane of the Microsoft Dynamics GP application window. In the navigation pane, you 
will find a button for each Microsoft Dynamics GP series and each Signature module.
Use the following navigation pane buttons to access Signature lists:

Signature Service
Signature Job Cost
Signature Equipment

The content pane will display the area page for the product you have chosen. On the area page, you will find quick links 
to all the product's operations, which you can also access from the menu toolbar.

The navigation pane will display a list of all the lists that are available for the selected product. The following lists are 
available for each Microsoft Dynamics GP series and Signature module:

Important: If you intend to use Job Appointments and you also use TimeZone views in Service Management, 
your users must use the Alternate Customer Maintenance window to set up GP Customers and Addresses/
Locations.  Failure to use the Alternate Customer Maintenance window will result in job appointments not 
being properly displayed in Schedule.



https://docs.key2act.io/display/1803b05/Posting+Flow+Documents
https://docs.key2act.io/display/1803b05/Posting+Flow+Documents
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Series/Module Lists

Financial Accounts, Account Transactions, Checkbooks, General Ledger Batches, 
Report list, and Assets

Sales Customers, Prospects, Salespeople, All Sales Transactions, Receivables 
Transactions, Sales Order Transactions, Invoicing Transactions, 
Receivables Batches, and Report list

Purchasing Vendors, All Purchasing Transactions, Payables Transactions, Purchase 
Order Transactions, Payables Batches, and Report list

Administration All Reports list, My Reports list, System Report list, Company Report list, 
Custom Report list, and SmartList Favorites

Inventory Items, Bill of Materials, Item Transactions, Report list, and In-Transit 
Transfers

HR & Payroll Employees, Applicants, Attendance Transactions, and Report list

Manufacturing Bills of Materials, Picking Documents, Job Costing, Routings, and 
Manufacturing Orders

Project Projects, Timesheet Transactions, Billing Transactions, PA purchase 
order transactions, and Report list

Field Service Service Call Transactions, Contract Transactions, RMA Transactions, 
RTV Transactions, Depot Transactions, In-Transit Transfers, Equipment, 
and Report list

Signature Service Service Locations

Signature Job Cost Jobs

Signature Equipment Equipment, Report list

Performing an action on a list item
Each list displays an action pane that contains action buttons. With these buttons, you can add new records to the list 
or perform actions on the records that you choose in the list. You can also open windows that allow you to view record 
details.
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Service Management
Open the Service Management area page by choosing the Signature Service navigation pane button.
From the navigation pane, choose Service Locations to display the Service Locations list in the content pane.
From here, a record displays for each location. You can sort the list of records by any column that displays, 
including Customer ID, Branch, and zip code. Right-click the column toolbar to show, hide, or re-order the 
columns that you want to display. You can also apply filters to the list to customize the records that display.
By choosing records from the list and using the action buttons, you can:

Look up service calls in history
Modify existing maintenance contracts
Create new service calls, contract quotes, and maintenance contracts

Job Cost
Open the Job Cost area page by choosing the Signature Job Cost navigation pane button.
From the navigation pane, choose Jobs to display the Jobs list in the content pane.
A list of job records displays. By choosing job records from the list and using the action buttons, you can:

Edit jobs
Create new jobs
Close jobs

Signature Home Pages for JC
Home pages provide quick access to information and frequently-used windows and reports within Signature products. 
Signature home pages are customizable by user and integrated with Microsoft Dynamics GP home pages. Home pages 
were introduced in Microsoft Dynamics GP version 9.0. Home pages are not limited to accessing Signature windows and 
reports; you can also create links to Microsoft Dynamics GP windows, external programs, and web pages.

Access to Signature windows and reports from a home page is based on your access to Signature menu items, as 
defined in your Job Cost, Service Management, and Equipment Management user profiles. For example, in Job Cost, if 
you have been granted access to the Job Maintenance window previously, you will have the same access from a "quick 
link" on your personalized Signature home page. For Service Management users, global filtering - if set up - will apply to 
Signature home pages.

Home Page Areas
To control the content that displays on your home page, choose the Customize this page... link in the upper right of your 
screen. The Customize Home Page window opens. Mark the checkbox next to each area that you want to appear on 
your home page. You can use the expansion buttons to further customize the content or close this window and refer to 
the following steps for each area.

Business Analyzer

Signature Home Pages do not contain "user roles," as in Microsoft Dynamics GP home pages. Therefore, when 
you open your home page for the first time, the default display will be determined by your Microsoft Dynamics 
GP user role.


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The Business Analyzer (formerly called Metrics) displays graphical representations of data within your system. 
Signature provides five graphical reports for Job Cost, six graphical reports for Service Management, and six graphical 
reports for Equipment. See the full list along with descriptions at the end of this section.

Before you can view the Signature graphical reports on your home page, you must update each report's parameter to 
the specific user login name. This must be done for each user who needs to view the graphical report.

To update a graphic report's parameters:

Go to the Report Server (http://yourcomputername/Reports_yourservername).
From the Report Server, choose yoursystemDB> yourcompanyDB > Signature Job Cost or Signature Service.
Open the Charts and KPIs folder.

In the Charts And KPIs window, hover your mouse over the report name and choose the drop-down arrow that 
displays.
Choose Manage.
From the navigation pane, choose Parameters.
On the UserID line, choose Override Default and then enter your login name.
Choose Apply.

Adding graphical reports on your home page

For information on how to add a graphical report to Business Analyzer, see the Microsoft Dynamics GP documentation.

Viewing graphical reports on your home page

To display a Signature graphical report on your home page, choose the right or left arrow that appears at the bottom of 
the Business Analyzer tile. Every time you choose the right arrow, the next graphical report in the list displays on your 
home page.

The following Signature graphical reports are available, organized by product:

Service Management 
Following is a list of graphical report names and an accompanying description.

12-MTH Analysis of Contract Costs and Revenue by Contract Type
Provides a side-by-side comparison of year-to-date costs and year-to-date revenue for contracts in the last 12 
months.
Analysis of Costs vs. Billed By Cost Type
Provides a side-by-side comparison of year-to-date costs vs. year-to-date billed for contracts, starting with the 
current user date and organized by call type.This graphical report does not include taxes in billed amounts.
MTD Appointments Completed by Technician
Shows the top 12 most month-to-date appointments completed by technician ID.
MTD Billing by Technician
Shows the top 10 most labor billed by technician ID.

Service Management graphical reports contain a SMS prefix. Job Cost graphical reports contain a JC prefix. 
Equipment Management graphical reports contain an EMS prefix.



The order of adding a graphical report to Business Analyzer in Microsoft GP Dynamics and updating the report 
parameters in Report Manager is not important, however the graphical report will not display any data until 
the parameters have been updated.


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Overdue PM Appointments by Contract Type
Shows the top 12 number of contract service calls for which there are overdue appointments, organized by 
contract type.
Six Month Analysis of Service Billed and Unbilled Dollars
Shows the billed and unbilled amounts for the last six months, starting with the current user date. This graphical 
report does not include taxes in billed amounts.

Job Cost

Top 10 Jobs Anticipated Loss
Shows the top 10 jobs based on anticipated loss.

Top 10 Jobs Over/Under Billed
Shows the top 10 most under-billed jobs displayed in ascending order.
Top 10 Jobs Anticipated Profit
Shows the top 10 jobs based on anticipated profit.
Top 5 Jobs Earned vs. Billed
Provides a side-by-side comparison between the amount earned and the amount billed for contracts.
Top 5 Jobs Based on Contract Earned
Shows the top 5 jobs based on highest contract earned.

Equipment Management

Top 12 Branch Division Totals
Shows the top 12 total number of equipment per branch, by division.
Top 12 Branch Totals
Shows the top 12 total number of equipment per branch.
Top 12 Division Totals
Shows the top 12 total number of equipment per division.
Top 12 Model Rental Totals
Provides a side-by-side comparison between the number of equipment On Rent vs. the number of equipment 
Available.
Top 12 Model Totals
Shows the top 12 total number of equipment per model.
Top 12 Status Totals
Shows the top 12 total number of equipment per equipment status.

Quick Links
You can add quick links for most Signature windows/features. These links represent the many toolbar items. You can 
add quick links to windows, navigation lists, web pages, external programs, and files.
For more information, see the Microsoft Dynamics GP documentation.

Shortcuts
Shortcuts are displayed in the upper part of the navigation pane when your Home Page is displayed. If the navigation 
pane is not visible, choose the Layout menu and choose Navigation Pane. Choose the Home navigation pane button to 
display your shortcuts and your home page.

Use shortcuts to quickly open frequently used windows and resources within Microsoft Dynamics GP. For example, if 
you regularly access a small subset of windows in your daily tasks, you can create shortcuts to those windows and store 
them in one folder. You can do the same with windows that you use less frequently, such as those used for month-end 
closing procedures.
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The default set of shortcuts contain a Startup folder. Shortcuts that you move into this folder will start automatically 
when you log in to a company in Microsoft Dynamics GP.
Shortcuts also may include a User Classes folder. The User Classes folder is created for you by the system administrator 
and contains shortcuts to specific tasks and windows. The system administrator can modify and delete a User Classes 
folder or any other shortcuts within the folder.

Keyboard shortcuts

You can apply a series of keystrokes to activate a shortcut (or any other command) using the keyboard. Any keyboard 
commands already in use will not be available to use for custom keyboard shortcuts.
For more information on shortcuts and keyboard shortcuts, see the Microsoft Dynamics GP documentation.

To do
This area contains reminders and tasks that pertain to information that needs to be addressed or actions to be 
performed.
For more information, see the Microsoft Dynamics GP documentation.

Symbols, Buttons, and Indicators for JC
Symbols and Buttons (page 6)
Indicators (page 10)

Symbols and Buttons
The following symbols and buttons are used in windows throughout Service Management, Job Cost, TimeTrack, and 
Equipment Management.

Symbol/Button Description

Account analysis button
Use the account analysis button to check or change the analysis codes to which 
the posting amount is to be allocated. The account analysis button is available 
when an amount is to be posted to a ledger account that has been set up for MDA.

Appointment history button
The appointment history button in the Service Call Appointments window opens 
the Appointment History window, listing all changes that were made to the 
appointment. The button will be present if the Keep Appointment History 
checkbox was marked in the Service Options window.

 

Arrow buttons
Use the arrow buttons to rearrange items in a scrolling window.
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Symbol/Button Description

Attached image button

Use the attached image button to attach documents to a record. If a record has 
attached documents, the button shows a paper clip attached to a piece of paper. 
If the record does not have attached documents, the button shows a paper clip. 
Document examples include purchase orders, diagrams, or job change orders. 
Bitmap file format (.BMP) is required unless you have purchased the Advanced 
Document Management feature. This feature allows numerous file formats 
(e.g., .DOC, .XLS, .TIF) to be attached.

Best technician button
Choosing the best technician button selects the next available, qualified 
technician for a service call. This allows you to schedule a technician for a service 
call as soon as possible.

Browse buttons
Browse buttons help you scan information, such as customer records and 
location records. You'll be able to browse through records using the sorting 
method selected for that window. This feature helps you locate records quickly.

Camera button
Use the camera button to view images attached to an equipment record.

Ellipsis button
If the Project Manager's Advisor feature is registered, the ellipsis button is 
available in certain windows. Use the button to open the Project Job Summary 
window.

Eraser button
Use the eraser button to remove items from a list.

Expansion button
When you choose an expansion button, the detail for the selected field is 
displayed.

Folder button
Use the folder button to browse to find a file.

Go button
The Go button is used to quickly locate items in a scrolling window. To use the Go
button, enter a partial entry in the field and choose the green arrow. The scrolling 
window will be positioned on the first occurrence of your entry.
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Symbol/Button Description

Go to button
Use the Go To button to open the Go To menu, which lists windows you can open. 
The items on the Go To menu in the Equipment Manager window are user-
definable.

Item information button
Displays additional information about the selected item.

Link (zoom)
A link appears as an underlined prompt for a field. Choose the link to open a 
window containing additional information for this item.

   

Link button
Use the link button to link a branch in Equipment Management to a branch in 
Service Management. Choosing this button in the Equipment Manager window 
will populate the customer, address ID, and equipment ID fields to the branch in 
the Service Management. If the branch is not linked, the Link button displays with 
a red slash.

Lookup button
A lookup button indicates a lookup window is available. When you choose a 
lookup button, a list of lookup items displays in a window. Using lookup windows 
helps you to quickly enter and validate information.

 

New call button
Use the new call button to create a new service call in Service Management.

Next available button
The next available button is used to calculate the technician's next available time 
slot for performing an appointment. The button is disabled if you have more than 
one appointment on the call or if the service call date and appointment date 
don't match.

Notepad button
The notepad button makes it possible to attach important information directly to 
a window or record so it's easily accessible. An attached note is easily recognized 
because lines of text appear to fill the button. If a note isn't attached to a window 
or a field, the notepad button will not have lines.

Organization structure button
Use the organizational structure button to assign a piece of equipment to an 
organizational structure, such as company branch or division. Organizational 
structures must have been set up on your system.
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Symbol/Button Description

Password padlock button
Use the password padlock button to assign or change a password for a protected 
item such as a budget.

Phone button
Use the phone button to search for a customer by phone number. You must first 
enter a phone number and then select the phone button. If a match is found, the 
customer record is retrieved.

Print button
Use the print button to print information displayed in the window.

Print button
If the Project Manager's Advisor feature is registered, the print button is available 
in certain windows. Use the button to choose a report to print.

Query button
Use the query button to establish temporary filter preferences for items viewed in 
a window. Once the window is closed, the temporary filter preferences are 
cleared.

Redisplay button
Use the Redisplay button to refresh a window after you've entered changes.

Show/hide detail buttons
Use the show/hide detail buttons to view additional information for items listed 
in a scrolling window.

Technician schedules button
The technician schedules button opens the Technician Schedules window, which 
is used to determine technicians' availability.

Tree view button
The tree view button opens a tree view window. Tree view windows display 
directories, subdirectories, and items using folders. A "+" symbol next to a folder 
indicates the folder contains subdirectories or items. Subdirectories and items 
are indented under a directory.
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Indicators
Visual indicators are linked to the customer ID and location. Not all indicators may be visible because they are 
dependent upon your system's initial setup.

Indicator Description

Contract indicator
A Contract indicator displays when contracts exist for the selected location. To view 
the contracts, choose the Contract button at the top of the window to open the 
Maintenance Contract window or use the lookup in the Contract Number field to 
select a contract.

Expired Contract indicator
An Expired Contract indicator displays when an expired contract exists for the 
selected location. Zoom on the indicator to open the Maintenance Contract window.

Canceled Contract Indicator
A Canceled Contract indicator displays when a canceled contract exists for the 
selected location. Zoom on the indicator to open the Maintenance Contract window.

Closed Contract Indicator
A Closed Contract indicator displays when a closed contract exists for the selected 
location. Zoom on the indicator to open the Maintenance Contract History window.

Master Contract indicator
A Master Contract indicator displays if a master contract exists for the customer 
location. Zoom on the indicator to open the Master Contract window.

Global filtering indicator
If you are using global filtering, a Branch indicator appears in the Service Manager 
window. Use the looking glass pointer that appears over the indicator to open the 
Global Filter View window. This displays the global filtering information for the 
selected customer's location. The branch name, affiliate, region, and branch are 
displayed. Global Filtering is an optional module that must be purchased separately. 
Contact WennSoft Sales for more information.

Stop-and-go light indicator
The Stop-and-Go Light indicator displays the account status of the selected customer. 
The three lights of the Stop-and-Go Light are driven by Microsoft Dynamics GP 
accounts receivables aging. If the customer's account status is within the time range 
of the first field, then the light is green. If the customer's account status is within the 
second time range, the light is yellow. If the account status is within the third or 
higher time range, or if the customer is on hold or inactive, the light is red. You can 
also define an additional procedure to turn the Stop-and-Go Light red.
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Indicator Description

History indicator
The History indicator displays if current or historical service calls exist for this 
customer. Zoom on the indicator to open the Service Call Lookup by Customer 
window.

Quote indicator
The Quote indicator displays if a maintenance quote exists. Zoom on the indicator to 
open the Contract Quote window.

Overdue indicator
The Overdue indicator displays if there are overdue scheduled preventive 
maintenance service calls for the selected customer location. Zoom on the indicator 
to open the Overdue PM window where you can view a list of the preventive 
maintenance service calls that are overdue. Selecting an overdue service call opens 
the Service Call window.

Service level agreement indicator
The Service Level Agreement indicator displays if the contract number for the selected 
customer's location has a service level assigned to it and therefore a guaranteed 
response time needs to be met.

Warranty indicator
A Warranty indicator appears in several windows if equipment associated with a 
service call or maintenance call is covered by a warranty. You associate equipment 
with a service call in the Service Call or Service Call Tasks window. You associate 
equipment with a maintenance contract in the Contract Coverage Maintenance 
window. The indicator appears in the Service Call, Service Invoice, Maintenance 
Costs, and Adjustments to Costs windows. If the date in the Warranty Expires or 
Extended Warranty Expires field in the Equipment window is greater than the date 
the service call was opened, the indicator appears.

Has-components indicator
The Has-Components indicator displays in the Equipment window for master 
equipment records.

Component indicator
The Component indicator displays in the Equipment window when the equipment 
record is a component record.
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Indicator Description

Item indicator
The Item indicator displays in the Equipment window when the equipment record 
doesn't belong to a group.

Group indicator
The Group indicator displays in the Equipment window when the equipment record 
belongs to a group and the item is the lead item in the group.

Group item indicator
The Group Item indicator displays in the Equipment window when the equipment 
record belongs to a group and the item isn't a lead item in the group.

Project contract status indicator
Choosing the Project Contract Status indicator in the Project Status window opens 
the Project Contract Status window for the given project. Current contract, pending, 
and expected contract amounts are shown.

Project billed position indicator
Choosing the Project Billed Position indicator in the Project Status window opens the 
Project Billed Position window for the given project. Contract earned, over (under) 
billing, and cash over (shortage) amounts are shown.

Stop-and-go light indicator
The Stop-and-Go Light indicator displays in the Subcontractor Status window and the 
Master Subcontractors Maintenance window. If the subcontractor to which a job is 
assigned is marked on hold in the Subcontractor Maintenance window, the light is 
red. If the subcontractor is not on hold, the light is green.

Batch Naming Conventions for JC
The following batch names are used in Signature. 

Service Management (page 13)
Job Cost (page 13)
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Service Management

Description Batch Name Example

Manual reopen of service call. user+MNLREOPEN LESSOMNLREOPEN

Manual close of service call. user+MNLClose LESSOMNLCLOSE

Job Cost

Description Batch Name Example

Changing profit types on a Job cost code. PRFTCHG+user PRFTCHGLESSO

Running Revenue Recognition for Percentage of 
Completion (POC)

POC+user+batch date POCLESSO05052027

Running Revenue Recognition for Revenue Performance 
Obligations (RPO)

RPO+user+batch date RPOLESSO05052027

Job Cost Setup
To use Job Cost, you must perform setup procedures. Typically, you complete the setup procedures once. How you use 
Job Cost depends on how your accounting system is set up, as well as how Microsoft Dynamics GP modules such as 
Receivables Management, Payables Management, and Payroll are set up. In some cases, you can use default entries 
from Microsoft Dynamics GP modules when you set up information in Job Cost.

In Job Cost, you must set up the following:

Core system
Cost codes
Accounts
Security
Payroll
User-defined fields

You must complete all setup procedures before using Job Cost.

You can also set up your system to access Signature windows using SmartList objects. See Using SmartList 
Objects for Signature Job Cost Products (page 77) for more information.





14

•
•
•

Prior to setting up Job Cost, document your Job Cost accounting processes with the assistance of your accounting 
professional. If you have not discussed the setup process with your accountant, we recommend you do so before 
continuing.

Signature Job Cost Setup Checklists
Setup checklists provide a way to make setting up your applications easier and more efficient. Setup tasks are arranged 
in the order in which they should be performed. Instead of traversing through the menus, you can perform setup tasks 
in one easy location. In addition, you can track the status of each setup task by marking it as In Progress, Complete, or 
Not Used. Whenever you make changes to a setup window, the system will prompt you to update that status.

Access to Signature setup windows is based on your access to Signature menu items, as defined in your Job Cost, 
Service Management, and Equipment Management user profiles.

Accessing the Setup Checklist window (page 14)
Getting help with setup tasks (page 14)
Completing a setup task (page 15)

Accessing the Setup Checklist window
Choose Microsoft Dynamics GP > Tools > Setup > Setup Checklist.
This window is populated with Microsoft Dynamics GP and Signature setup tasks. The Signature modules that integrate 
with GP include Job Cost, TimeTrack, Service Management, and Equipment Management.

Getting help with setup tasks
Signature setup checklists include window-level help. This help displays in the Setup Guide window, which appears to 
the right of the Setup Checklist window. When you click on a setup checklist task, the Setup Guide window changes to 
display information for that task.

Some setup tasks that require "sa" security privileges cannot be performed using the Setup Checklist window; 
instead, users must perform these tasks using the menu paths.



•

•

Overhead Groups and Detail Codes Setup
Setting up overhead groups and overhead detail codes is not included as part of the Setup Checklist. For these 
setup tasks, use the following menu paths:

For Service Management, mark the Use Overhead Amounts from Job Cost checkbox in the Service 
Options window, then choose Microsoft Dynamics GP > Tools > Setup > Job Cost > Payroll Setup > 
Overhead Groups (for overhead groups) and Microsoft Dynamics GP > Tools > Setup > Job Cost > Payroll 
Setup > Overhead Detail Codes (for overhead detail codes).
For Job Cost, choose Microsoft Dynamics GP > Tools > Setup > Job Cost > Payroll Setup > Overhead 
Groups (for overhead groups) and Microsoft Dynamics GP > Tools > Setup > Job Cost > Payroll Setup > 
Overhead Detail Codes (for overhead detail codes).


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Completing a setup task
Choose the plus sign in front of a product to reveal its setup categories. You can also highlight the product and 
use the right or left arrow keys on your keyboard to expand or collapse the tree view. You can also choose to 

expand   or contract   all nodes.
Choose the plus sign in front of the setup category to show the setup tasks. As illustrated below, individual setup 
tasks do not have a plus sign in front of them:
Double-click a task to open the setup window for that task.
Complete the setup window. Refer to the Setup Guide on the right side of the screen for help, or the appropriate 
user manual for that Signature product.
Save your changes. The Setup Checklist Status window displays: You can keep the status as In Progress or 
change it to Complete or Not Used. The setup checklists are very flexible; if you mark a setup task as Complete, 
you can still open that setup window later and make changes if you need to. When a change has been made to a 
setup window, it is notated in the Setup Checklist, a   indicates that the setup task is marked as Complete. If a 
setup task is marked as Not Used, it would be notated with   . Tasks that are In Progress are identified with 
 .

For additional information on the Setup Checklist window, refer to your Microsoft Dynamics GP documentation.

Setting up the Core Job Cost System
Setting up the core Job Cost system involves the following to be set up in the order listed.

Setting up Job Cost Security (page 15)
Viewing Application and User Activity Information in Job Cost (page 19)
Determining the Revenue Recognition Method (page 20)
Setting up Fiscal Periods (page 21)
Choosing Posting Options (page 23)
Additional Job Close Setup (page 26)
Project Percentage of Completion Revenue Recognition (page 27)
Setting up Document Numbers (page 29)
Setting up Projects (page 30)
Setting up Master Tax Schedules (page 31)
Choosing Job Cost Setup Options (page 31)
Setting up Job Types (page 33)
Setting up Architects (page 33)

Setting up Job Cost Security
Job Cost uses the Microsoft Dynamics GP security functions for window- and report-level access. In addition to 
Microsoft Dynamics GP security, Job Cost provides password protection for certain functions based on a security level 
that is granted to each user. The purpose of Job Cost security is the ability to change passwords for specific functions 
based on security level.

Important: If you intend to use Job Appointments and you also use TimeZone views in Service Management, 
your users must use the Signature Alternate Dynamics versions of the Customer Maintenance, Customer 
Address Maintenance, and Customer Class setup windows. These windows contain information that is 
specifically used by Signature during the appointment scheduling process.


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Setting up security in Job Cost involves the following:

Step 1: Enter a System Password (page 16)
Step 2: Select Functions to Password Protect (page 16)

Description of Password Functions (page 16)
Job Status (page 16)
Job Maintenance (page 16)
Billing (page 17)
Change Orders (page 17)
Miscellaneous (page 17)

Step 3: Create Security Levels (page 17)
Step 4: Set up Password Profile (page 18)
Step 5: Create a User Profile (page 18)

Step 1: Enter a System Password
You can either accept the default password or enter a new password to access Job Cost security functions.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Security Setup > System Password.
Enter the default system password of "access" and select OK.
Enter a new system password.
Select Save.

Step 2: Select Functions to Password Protect
Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Security Setup >Password Setup.
Enter the system password and select OK. 

Use the drop-down list in the Password Setup window to view only those items in a specific functional area, such 
as Job Status or Job Maintenance.
Select the functions that require password protection.
Select OK to close the window.

Description of Password Functions

The following lists each item by functional area and provides explanations of what happens when the item is marked as 
requiring a password. Functions that cannot be changed are marked as "permanent" in the descriptions.

Job Status

Revise Estimate Cost
Allows estimate cost revisions in the Job Status window.
Revise Forecast Cost
Allows forecasted cost revisions in the Job Status window.

Job Maintenance

View Job Maintenance
Allows opening of the Job Maintenance window.

Some functions are marked by default and cannot be changed.
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Edit Job Cost Code Profit Type & Amt
Allows changes to the profit type and amount in the Job Cost Codes Setup window. (permanent)
Edit Original Contract
Allows changes to the original contract amount in the Job Maintenance window.
Change Contract Type
Allows changes to the contract type in the Job Maintenance window. (permanent)
Add Job Cost Codes
Allows saving new cost codes to a job.

Billing

Create Job Invoice
Allows entry of billing amounts in the Job Invoice Entry window.
Override Billing Amount
Allows billing in excess of the contract amount. (permanent)

Change Orders

View Change Orders
Allows change order additions in the Job Status window.
Edit Change Order Profit Type & Amt
Allows changes to the change order profit type and amount in the Change Order Cost Codes Setup window. 
(permanent)
Edit Change Order Amt
Allows changes to the change order amount in the Change Order Cost Codes Setup window. (permanent)
Post Change Orders
Allows posting change orders in the Job Status window.
Revise Change Order Estimate Cost
Allows changes to posted change order estimates.

Miscellaneous

Print Reports
Allows access to Job Cost Reports menu.
Access Utilities
Allows opening Job Cost utilities.
Job Cost Routines
Allows access to Job Cost routines.
Access Setup Options Menu
Allows access to Job Cost Setup menu.

Step 3: Create Security Levels
You can set up different security levels to assign to individuals. For example, an "administrative clerk" level might have 
access only to data entry windows or functions, but a "supervisor" level might have access to every window and 
function.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Security Setup > Security Levels.
Enter the system password and select OK.
Enter a Security Level and Description.
Select Save.
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Step 4: Set up Password Profile
For each security level, you can define a password profile for individual functions. You can accept the default password 
for all functions, enter individual passwords for the functions, or enter a password for an individual functional area.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Security Setup > Password Profile.
Enter the system password and select OK.
Enter an existing Security Level.
Select a functional area from the Password Function Group drop-down list.
You can change all the passwords for an entire functional area or for individual functions.

For functional area: Enter the new password in the Default Password field and select Apply All. All the 
passwords for that group change in the Password column.
For individual functions: Enter the new password in the Password column for an individual function. 

Close the Password Profile Setup window for the changes to take effect.

Step 5: Create a User Profile
The User Profile Setup window is used to assign each user ID to a security level. You can set up a one-to-one relationship 
between the Microsoft Dynamics GP user ID and the Job Cost employee ID.
Depending on the restriction chosen, the user can view payroll information for all employees, only those for which the 
employee is assigned as project manager, or for no employees.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Security Setup >User Profile.
Enter the system password and select OK.
Complete the following fields, as necessary.
User ID
Select Add Users and select from the list of Microsoft Dynamics GP user IDs assigned to your company.

Security Level
Assign a security level to this user.
Employee ID
Select the employee you are creating the ID for. 

Division
If you have the Project Manager's Advisor feature registered, you can enter a division. The View Divisions 
field becomes enabled after choosing a division.
Open Payroll Entry Zoom, View Job Status, View Job History, View Divisions
You must have the Project Manager's Advisor feature registered to enable the View Job Status, View Job 
History, and View Divisions fields.

All
The user can view job details for all employees.
Assigned Jobs
The user can only view job details of jobs that the user is assigned to as project manager. If the 
Project Level feature is registered, the project managers will be limited to viewing their own 
projects.
None
The user cannot view job details.

All passwords must be UPPERCASE.

If you are using the Project Manager's Advisor (PMA) feature, we recommend that you enter an 
employee ID for security purposes.


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Select Save.

Viewing Application and User Activity Information in Job Cost
The About Signature window lists the versions of Dexterity, Microsoft Dynamics GP, and Signature that you are using. 
You can also view the number of Signature users registered for your company and the number of users currently in the 
system.

View application information (page 19)
View registered modules (page 19)
View installation history (page 19)
View user activity information (page 20)

View application information
Choose Help > About Signature.

View registered modules
Choose the Modules button in the About Signature window to open the Signature Modules window. This window 
displays all Signature modules and whether the site is registered to use those modules. 

View installation history
Choose the History button in the About Signature window to open the Signature Installation History window. 
This window displays the version of Signature products you are running, any service packs or maintenance 
releases that have been installed, as well as other relevant information. The window initially displays 
information for the current workstation and server. You can make another selection from the Display drop-down 
list to view other information. You can rearrange the columns by dragging and dropping the column header. 
Changes to the columns will be saved for each user. Selections in the drop-down list include:

Current Workstation and Server
Current Workstation Only
All Workstations and Server
All Workstations Only
Server Only

To print the Installation History report, choose the printer button. The report contains the information listed in 
the Installation History window.

Users who have a user profile set up in Service Management should have access to the following alternate 
Microsoft Dynamics GP windows: Customer Address Maintenance, Customer Class Setup, and Customer 
Maintenance. Users who only have a user profile set up in Job Cost should not have access to these alternate 
windows.



If a Signature product is not registered, the word DEMO appears next to the product name, along with an 
expiration date. Refer to the Installation, Upgrade, and New Features manual for information on registering 
Signature products.
You can print the information listed in the Signature Modules window by choosing the Print button. The 
Registration report prints.


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View user activity information
Choose Microsoft Dynamics GP > Tools > Setup > Module Name > Module User Activity.

The User Activity window shows which users are currently using the module, which company they're working in, and 
the date and time they started working in that company. It's important to monitor user activity if you've reached the 
maximum number of users allowed in the system or if you need exclusive access to the system before performing a file 
maintenance procedure. You can click Redisplay to update the window with any users that have logged in since you 
initially opened the window. You can delete a user by selecting the user ID and choosing Delete.

Determining the Revenue Recognition Method
One of the first steps in setting up your Job Cost system is choosing posting options. The posting option is dependent 
on your revenue recognition method. Your accountant can advise you on the method most appropriate for your 
business. Under the revenue recognition principle, revenues should be earned and realized before they are recognized. 
Posting then transfers the journal entries to the appropriate accounts in the general ledger.

The revenue recognition methods include:

Revenue Performance Obligations (page 20)
Percentage of Completion (page 20)
Completed Contract (page 21)
Immediate Recognition (page 21)

Revenue Performance Obligations
The Revenue Performance Obligation revenue recognition method is used by companies that either enter into contracts 
with customers to transfer goods or services or enters into contract for the transfer of nonfinancial assets unless those 
contracts are within the scope of other standards (for example: leases and insurance contracts).  Update (ASU) 
2014-09, Revenue from Contracts with Customers (Topic 606) http://www.fasb.org2.

Each job can have one or more revenue codes assigned, depending on contract type.  Original Transaction Price + 
Change Order Transaction Price Amount = Expected Transaction Price Amount. The total transaction price amounts for a 
job cannot exceed the Expected Contract Amount.

Percentage of Completion
The Percentage of Completion revenue recognition method records a job's revenue and expenses in each period, based 
on the actual percentage of the job completed during the period. Typically, all costs incurred for the period post to a 
general ledger work-in-process (WIP) account as a debit. A monthly journal entry is created to recognize revenue and 
the cost of sales using the following equation:

[Actual Cost (or Labor Hours) / Forecasted Cost (or Labor Hours)] x Contract Amount = Revenue Earned

As part of the month-end process, the following general ledger account adjustments are made to record revenue and 
expenses on your monthly profit-and-loss statement:

Credit each WIP account (balance sheet)
Credit the job revenue account (profit and loss)
Debit the cost of jobs account (profit and loss)
Debit the progress billings account (balance sheet)

http://www.fasb.org/
http://www.fasb.org/
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Debit to unbilled receivables or credit to billings in excess (balance sheet)

To use the Percentage of Completion revenue recognition method, mark the Revenue Recognition Method checkbox on 
the Posting Options window. The Closing Jobs Journal Entry checkbox on the Posting Options window will be marked 
automatically.

Completed Contract
With the Completed Contract revenue recognition method, the cost and revenue on a job are recorded only when the 
job is completed and closed. This can occur at any time during the fiscal year.
When the job is complete, the costs and revenues are removed from balance sheet accounts and transferred to profit-
and-loss statement accounts such as cost of jobs and job revenue. To accurately adjust the general ledger when you 
close the job, Job Cost creates the following entries:
For expenses not yet posted to profit and loss accounts:

Credits each WIP account (balance sheet)
Debits the cost of jobs account (profit and loss)

For revenues not yet posted to profit and loss accounts:

Debit the progress billings account (balance sheet)
Credit the job revenue account (profit and loss)

To use the Completed Contract revenue recognition method, mark the Closing Jobs Journal Entry checkbox on the 
Posting Options window.

Immediate Recognition
With the Immediate Recognition method, you can record revenue when an invoice is created by using Job Cost's invoice 
accounts as revenue accounts. If you select this method, cost of sales is recognized as cost transactions are posted. 
Typically, no WIP accounts are used, and the cost code method of posting is used. 

To use the immediate recognition method to recognize revenue, do not mark the Revenue Recognition 
Method checkbox or the Closing Jobs Journal Entry checkbox in the Posting Options window.

Setting up Fiscal Periods
Fiscal periods are divisions of the fiscal year that define when transaction information is summarized, and financial 
statements are prepared. Although fiscal periods are typically monthly, quarterly, or semi-annually, you can create a 
maximum of 54 open fiscal periods for each year. When you no longer want information posted to a period, you can 
close the period. If you wish to save time setting up the same fiscal periods in both Job Cost and Microsoft Dynamics GP, 
you also have the option of automatically calculating Job Cost Fiscal periods when you create fiscal periods in Microsoft 
Dynamics GP.

Creating fiscal periods (page 21)
Creating Microsoft Dynamics GP and Job Cost fiscal periods (page 22)
Editing an existing fiscal year (page 22)

Creating fiscal periods
Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Job Cost Setup > Fiscal Periods. The first time you open 
the Job Cost Fiscal Periods Setup window, if fiscal periods are set up in Microsoft Dynamics GP, they will 
automatically be created in Job Cost. Select OK to save changes. No further editing is required.
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Use the Year drop-down list to select a year to set up or enter a new year. 

The First Day, Last Day, and Number of Periods fields default based on existing fiscal periods. You can enter 
different values.
Select Calculate.
You can change the name of the periods. For example, if you use four fiscal periods, you could enter Quarter 1 for 
Period 1. To change the name of a period, double-click the period under the Period Name column and type the 
new name. You can also edit the Date fields.
To print the Fiscal Periods Setup report, select File > Print or select the printer button.
Select OK.

Creating Microsoft Dynamics GP and Job Cost fiscal periods
You can automatically create Job Cost fiscal periods when you set up fiscal periods in Microsoft Dynamics GP. In 
addition, re-calculating the periods of an existing GP fiscal year also re-calculates existing Job Cost fiscal periods.

Select Microsoft Dynamics GP > Tools > Setup > Company > Fiscal Periods.
Enter the new fiscal Year and dates for the First Day and Last Day of the year.
Enter the Number of Periods that you want in the new fiscal year and select Calculate.
When the fiscal periods populate in the scrolling window, make any necessary changes. Refer to the Microsoft 
Dynamics GP documentation for more information about GP fiscal period setup.
When you are finished setting up the GP fiscal year, select OK. A Job Cost fiscal year is automatically created with 
fiscal periods based on the same setup options. To view or edit the Job Cost fiscal year, select Microsoft 
Dynamics GP > Tools > Setup > Job Cost > Job Cost Setup > Fiscal Periods.

Editing an existing fiscal year
The changes that you make in GP fiscal period setup will affect Job Cost only if the fiscal year that you are editing does 
not contain any closed Job Cost fiscal periods. If, for example, you want to change the length of GP period 4, but Job 
Cost period 4 is already closed, this change cannot roll down to Job Cost and will be made in GP only. This is true 
whenever the Job Cost fiscal year contains closed periods, regardless of which periods are closed and which you are 
editing.

Select Microsoft Dynamics GP > Tools > Setup > Company > Fiscal Periods.
Select an existing Year from the drop-down menu.
You can re-calculate fiscal periods by editing the First Day, Last Day, and/or Number of Periods in the fiscal 
year and choosing Calculate.
Edit the fiscal periods in the scrolling window, as necessary. Refer to the Microsoft Dynamics GP documentation 
for more information about GP fiscal period setup.
When you are finished, select OK. The changes that you made to the GP fiscal year will be reflected in the Job 
Cost fiscal year as well.

The Historical Year checkbox indicates if the selected year has been closed (Microsoft Dynamics GP > 
Tools > Setup > Company > Fiscal Periods).



If you are editing an existing fiscal year and a closed Job Cost period is detected within that year, the changes 
you make to the GP fiscal year will affect GP only and will not roll down to Job Cost.


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Choosing Posting Options
Since journal entries are transferred to the appropriate accounts in the general ledger during posting, Job Cost contains 
multiple posting options that allow you to specify the source of your posting accounts. You can also specify how you 
will post your payroll and options for closing jobs. To print the JC Posting Options report, select File > Print or select the 
printer button.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Job Cost Setup > Posting Options.
Complete the Cost Code Debit Posting Accounts section by choosing the type of posting account. This allows you 
to specify where to define general ledger posting accounts for Job Cost transactions.

Select Cost Codes if:
You want to assign a posting account for each cost code when you create a new job.
You are using the immediate revenue recognition method and you want the ability to assign any 
general ledger account as the default debit posting account for any cost code assigned to a job.
You do not post cost transactions to WIP accounts. With this option, you must assign a posting 
account to each Job Cost code.
You assign a general ledger posting account while setting up cost codes in the Master Cost Codes 
Setup window. That account is added to the cost code record when you add cost codes to jobs in 
the Job Cost Codes Setup window. You can change the general ledger account number assigned 
to the code at that time.
You want unlimited posting accounts, one for each cost code.

Select Division if you are using the percentage-of-completion or completed contract revenue recognition 
method to post costs to WIP accounts. You can use this option for up to nine general ledger posting 
accounts, one for each cost element. Choosing this option requires you to assign default cost element 
posting accounts for each division. Transactions posted to all cost codes for the same cost element in a 
division update the same general ledger account. 

Select one of the following Revenue Recognition Methods:
None
Percentage of Completion

POC Calculation Method 
You can use either labor hours or costs as the method of POC calculation. The percentage 
complete for a job is calculated as either Actual Labor Units divided by (Revised) Forecasted Labor 
Units or Actual Costs divided by Forecasted Costs. This is a global option; your selection applies to 
all jobs in the system. If you change this option, you must run the Recreate Job Master Summary 
utility for ALL jobs to recreate all months using the new POC calculation method. You may want to 
use the labor hours method if you find POC to be misleading when calculated based on cost, 
reflecting the cost of equipment or materials that are sitting in a warehouse rather than the cost 
of actual work that has been completed for the job.
Use Job and Project Loss Recognition
For more information on loss recognition and this setup option, see Loss Recognition (page 110).

Revenue Performance Obligations 

If you are using the immediate revenue recognition method, you can use either the Cost 
Codes option or the Division option.



CAUTION:  DO NOT change the Revenue Recognition Method in Posting Options from RPO 
to POC if you have any active RPO jobs. If the Revenue Recognition Method is changed from 
RPO to POC, all RPO jobs will be missing from future POC processes.  You will not have the 
ability to run the RPO process to recognize the missing revenue because the RPO fields will no 
longer be available.


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Post Through the GL 
Mark this checkbox if you want to post the transaction through the General Ledger. If you are using the 
Percentage of Completion or Revenue Performance Obligations method, a general ledger journal entry is 
created each period to recognize revenue and cost of sales. If you do not mark the Post Through the 
GL checkbox, you need to manually post the transaction stored in a general ledger batch at the end of each 
month. However, manual posting allows you to print an edit list and review the accounts that update before 
posting in the general ledger. 

Sales/Revenue Accounts for SOP Billing From 
If you are using the Sales Order Processing (SOP) module to bill jobs, select the accounts to be updated for 
billing SOP transactions. Choices include Job Cost and SOP. If you are using the revenue recognition percentage-
of-completion posting method, the Job Cost radio button is selected automatically and cannot be changed.

Job Cost 
If you select Job Cost, the accounts set up in the Invoice Accounts Setup window (Microsoft Dynamics GP > 
Tools > Setup > Job Cost > Account Setup > Invoice Accounts) will be used.
SOP 
If you select SOP, either the item or customer accounts will be used, as set in the Sales Order Processing 
Setup window (Microsoft Dynamics GP > Tools > Setup > Sales > Sales Order Processing).

In the Payroll section, select from the following options:
Certified Payroll 
Mark this checkbox if you create certified payroll reports. If you use Microsoft Dynamics GP Payroll to 
print your company's payroll checks on a weekly basis and have certified payroll jobs, mark the Certified 
Payroll checkbox. 

Rate Class 
Mark this checkbox if you want to assign wage rates, benefits, and deductions to union employees, by 
category, using rate classes. See Setting up Rate Classes for Union Payroll (page 55). 

Payroll Post Through the GL 
Mark this checkbox to post Job Cost payroll batches through the General Ledger. Leave this option 
unmarked to post payroll batches manually in the General Ledger. A General Ledger journal entry is 
created automatically each time you post job transactions through Microsoft Dynamics GP Payroll to Job 
Cost.
Payroll Post to Job Cost Only 
Mark this checkbox if you do not use Microsoft Dynamics GP Payroll and you want to post Job Cost 
payroll transactions to Job Cost only. This option allows you to post payroll transactions without 
building checks first and deletes your payroll batch after posting. If you mark this option, you also need 
to mark Payroll Post to Service Only. Microsoft Dynamics GP > Tools > Setup > Service Management > 
Invoice Setup > Invoice Options.

This option overrides your GP Posting Setup option to allow batch posting only. If you post through the 
GL, transactions can be posted even without the Allow Transaction Posting GP option marked.



If you do not use Microsoft Dynamics GP Payroll or do not have certified payroll jobs, leave this 
option unmarked. This option requires additional processing time during posting.



If you are ONLY using Rate Class to determine the pay rate amount for your payroll transaction, 
and Union reporting is NOT a requirement, we have added a new option to improve the process 
performance of running payroll.  By adding this line to the Dex.ini file, benefit and deduction 
records will not be gathered in our tables:    DisableRateClassBenefitsAndDeductions=TRUE DO 
NOT USE this option with the Rate class Prevailing Wage or Highest Wage options.


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Payroll Post Transaction Summary 
Mark this checkbox to create a General Ledger journal entry that totals all payroll transactions for each 
division. This option is useful if the same employee works on multiple jobs. If you do not mark this 
checkbox, a journal entry is created for each transaction.
Payroll Overhead Detail Distribution (optional):
Mark this checkbox if you wish to set up unique overhead offset accounts for each individual overhead 
detail code. An account must be assigned for each division and overhead detail code through the Payroll 
and Overhead Offset Accounts Setup window (Microsoft Dynamics GP > Tools > Setup > Job Cost > Account 
Setup > Payroll Offset Accounts).

In the (optional) Estimate Cost section, mark the Estimate Cost by Period checkbox if you would like to 
estimate your costs by fiscal period. Marking this checkbox disables the Estimate Units and Estimate Amount/
Unit fields on the Job Cost Codes Setup window and enables the "+/-" button on the Job Cost Codes Setup 
window. See Revising estimated costs (page 96) for information on entering estimates. 

In the Close Jobs section, select from the following:
Closing Jobs Journal Entry
Mark this checkbox to automatically create a closing jobs journal entry in the general ledger when you 
close a job. This entry credits the WIP accounts and debits the cost of sales for each cost element. The 
final revenue earned (the total contract amount) becomes a credit to your contract earned closed jobs 
account and a debit to your progress billings account. The journal entry moves these totals from the 
balance sheet to the profit-and-loss statement. 

Allow Job to Close if Committed Costs
Mark this checkbox to close jobs with committed costs.
Post Through the GL
Mark this checkbox to post transactions through the General Ledger. 

Allow Job to Close if Net Billed not equal to Expected Contract
Mark this checkbox if you want the ability to close a job when the billed amount does not equal the 
contracted amount.
Allow Job to Close if Total Invoiced not equal to Cash Received
Mark this checkbox if you want the ability to close a job when the total invoiced amount does not equal 
the cashed received.
Only Allow Inactive Jobs to be Closed
Mark this checkbox if you do not want users to be able to close active jobs. When this option is marked, 
opening the Close Jobs window will not temporarily inactivate active jobs. Be aware that in a multi-user 
scenario, a job may be reactivated by one user while another user is attempting to close it.

If you mark this checkbox, a GL batch will still be created when you post the Job Cost payroll 
transaction. If you do not want to update the general ledger, you should delete this batch.



Do not change the Estimate Cost by Period option after creating jobs.

If you use the completed contract revenue recognition method, you must mark the Closing Jobs 
Journal Entry checkbox. This option is marked automatically if you are using the percentage-of-
completion revenue recognition method.



Beginning with Signature 2018 R4, the Post Through the GL option only applies to the legacy Job 
Close window. If you are using the new Job Close window, you will need to manually post the 
batch.


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(Optional) To access the additional Job Close Setup window, select Additional from the top navigation and then 
select Job Close Setup. Use the Job Close Setup window to disable filters, indicate the columns that display 
related to jobs and projects, and to enable users to save a job close schedule. See Additional Job Close 
Setup (page 26) for more information. 

Select Save.

Additional Job Close Setup
Use the Job Close Setup window to disable filters, indicate the columns that display related to jobs and projects, and to 
enable users to save a job close schedule. 

Go to Microsoft Dynamics GP > Tools > Setup > Job Cost > Job Cost Setup > Posting Options.
In the Posting Options window, select Additional and then select Job Close Setup.
The Report Folder and Reports fields default to display folder and report names. You would only need to edit 
these fields if you have a custom report that may or may not reside in a different folder. 
In the Disable Filters section, mark the filters that you do not want to show in the Close Jobs window. All four 
options display unless marked to disable. Note that you are required to have at least one filter displayed in the 
Close Job window.

All Jobs
Project
Customer
Division

In the Enable Job Columns section, mark any additional job-related columns to display in the Available Jobs 
scrolling window. These default to none marked.

Job Name
Manager ID
Job Address
Contract Type
Billing Type

In the Enable Project Columns section, mark any additional project-related columns to display in the Available 
Jobs scrolling window. These default to none marked.

Project Name/Description
Architect ID
Project Set-up Date
Project Closed Date

In the Close Job UI Processing Threshold section, mark the number of minutes the job close SQL process may 
need. The default value is 2 minutes. We recommend that you only change this value if the process times out.
Mark Enable Save Schedule to display the Save Schedule button in the Job Close window. This defaults to not 
marked. Saving a job close schedule allows users to save the entire list of jobs for the User ID and Posting Date 
for processing later. Any jobs that were marked prior to saving will still be marked when the saved schedule is 
opened again.

Select Save.

This window is only accessible for users who fall under the security task K2AA_JOBCLOSESET. This 
security task is automatically assigned to the WSJC POWERUSER* role.



Only one schedule per user can be saved at one time.
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Project Percentage of Completion Revenue Recognition
If you are using the Project Level feature, you can now use the project's percentage of completion (POC) to recognize 
revenue. Previously, percentage of completion could only be used at the job level to recognize revenue.

A project's POC is determined by the Project Total Cost divided by the Project Forecast Cost, where these values are 
calculated as the sum of the total and forecast costs for all jobs assigned to the project. All jobs, including those that are 
inactive, are included in the project POC calculation. You cannot have any jobs excluded from POC when POC is 
recognized at the project level.

The project's percentage of completion will be applied as the POC for each job that is assigned to the project. This is the 
POC that will be used to calculate the contract earned amount for each job, as well as the entire project.

Example

Project A has three jobs:

Job Job Expected Contract Job Total Cost Job Forecast Cost

2776 2,000,000 1,500,000 1,500,000

2777 5,000,000 2,600,000 3,000,000

2778 3,000,000 1,500,000 2,500,000

The job amounts are added to determine the project amounts:

Project ProjectExpected Contract ProjectTotal Cost ProjectForecast Cost

Project A 10,000,000 5,600,000 7,000,000

Project POC (Project Total Cost / Project Forecast Cost) = 80% (5,600,000 / 7,000,000)
Project Contract Earned (Project POC x Project Expected Contract) = 8,000,000 (80% x 10,000,000)
Job Contract Earned (Project POC x Job Expected Contract) =

2776 1,600,000 (80% x 2,000,000)

2777 4,000,000 (80% x 5,000,000)

2778 2,400,000 (80% x 3,000,000)

Requirements (page 28)
Setting up a project to use project-level POC (page 28)

POC Method indicators (page 28)
On job windows (page 28)
On project windows (page 28)
On reports (page 29)

Project POC Breakdown (page 29)
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From the Billed Position window (page 29)
From the Project Billed Position window (page 29)

Requirements
To use Project Level POC, in addition to having the Project Level feature registered, you must have the following options 
selected in the Posting Options window (Microsoft Dynamics GP > Tools > Setup > Job Cost > Job Cost Setup > Posting 
Options):

Cost Code Debit Posting Accounts set to Division posting
Percentage-of-Completion marked as the Revenue Recognition Method
POC Calculation Method set to Posted Costs

If you meet these requirements, you can use the project-level POC method for recognizing revenue.

You can change the POC method on a project only if the project type is Project Standard Billing and no invoices 
have been created for the project.
You can change the contract type on a job that has been invoiced and included in a POC journal entry only if the 
billing type for the job and the project is Standard.

Setting up a project to use project-level POC
Complete the following steps to use percentage of completion at the project level. You cannot change the POC method 
for any project that has invoices saved or posted.

Select Cards > Job Cost > Project to open the Project Maintenance window.
Select a Project Number.
In the POC Method field, select Project Level.
Select Save.

POC Method indicators

On job windows

When project-level POC is being used, the POC Method field will appear on multiple job and project windows to indicate 
that POC is being recognized at the Project Level.

This read-only field appears on the Job Maintenance, Job Status, and Job Billed Position windows for jobs that are 
using project-level POC.

When POC is recognized at the job level, this field will be hidden from the job windows.

On project windows

When project-level POC is being used, the POC Method field appears on the Project Maintenance, Project Status, and 
Project Billed Position windows for projects that are using project-level POC. 

This field is read-only on the Project Status and Project Billed Position windows.

When upgrading, the POC Method for existing jobs and projects defaults to Job Level.



29

1.
2.
3.
4.

1.
2.

3.
4.

1.
2.
3.

4.
5.

On reports

When project-level POC is being used, the Job Report indicates the POC Method as Project Level.

All project and job reports display contract and billing amounts based on the project POC when the POC method is set 
to Project Level.

Project POC Breakdown

The new Project POC Breakdown window allows you to view a breakdown of expected contract, contract earned, 
billing, and over/(under) billing amounts when you are using project-level POC. You can open this window from either 
the Billed Position window or the Project Billed Position window.

From the Billed Position window

Opening the Project POC Breakdown window from a job's Billed Position window allows you to view POC, contract, and 
billing amounts for the job.

Select Cards > Job Cost > Job.
On the Job Maintenance window, select a job and use the expansion button to open the Job Status window.
Use the Billed Position button to open the Billed Position window.
Use the Project POC Breakdown button to open the Project POC Breakdown window. This button is hidden if the 
job is not using project-level POC.

This window displays information only for the current job, using the Project % Completion as the POC.

From the Project Billed Position window

Opening the Project POC Breakdown window from the Project Billed Position window allows you to view contract and 
billing amounts for the project by job.

Select Cards > Job Cost > Project.
On the Project Maintenance window, select a project and use the expansion button to open the Project Status 
window.
Use the Project Billed Position indicator to open the Project Billed Position window.
Zoom on the Project Contract Earned field to open the Project POC Breakdown window.

Setting up Document Numbers
Document numbers reference the various types of documents associated with Job Cost such as invoices, change 
orders, and purchase orders. These numbers appear in transaction entry windows and on Job Cost posting reports as 
part of the audit trail. You can use the document number to trace a posted transaction to its origin.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Job Cost Setup > Number Options.
For each document type, accept the default description.
Enter the Next Number to use when you create a new document. You can override this number when you enter 
transactions.
To print the Number Options report, select File > Print or select the printer button.
Select Save.
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Setting up Projects
Projects are used to group and track related jobs. You can assign multiple jobs to a project and print reports by project 
number. The diagram below illustrates a sample project.

Select Cards > Job Cost > Project to open the Project Maintenance window.
Complete the following fields, as necessary.

Project Number, Description
You must enter a number and description for the project.
Manager
Use the lookup to select a project manager.
Customer Number, Address
Select the project customer and address.
Bill To Customer, Bill To Address
This field defaults from the Customer Number and Address fields. You can select a different Bill To 
Customer for third party billing. If you select a different customer, the Bill To address defaults from the 
Customer Maintenance window, however you can select a different address.
Tax Schedule
This defaults from the project customer. You can use the lookup to select a different tax schedule.
Project Type
Select one of the following. Once a project has been saved or has posted jobs, you cannot change the 
project type.

Project Standard Billing
Project Bill Code
You can use this project type ONLY if all jobs assigned to the project have a billing type of Project 
Bill Code.
Cost Plus Billing
Use this project type for Time and Materials (T&M) projects.
Project Allocated Revenue
Use this project type for a Fixed Contract project.

Architect ID
Select an architect ID if you want to assign an architect to the project.
Calculate Sales Tax on Billing Amount
If you are using a Retention Percent, mark this checkbox to calculate the sales tax on the Billing Amount. 
If unmarked, the sales tax is based on the subtotal amount (Billing Amount - Retention Amount). There 
are currently five states (WA, NV, TX, OH & DE) that require that sales taxes on the Job Cost invoices be 
calculated based on the gross receipts (sales amount not reduced by retention).  The Calculate Sales Tax 

Projects are used primarily with project-level billing. If you do not use project-level billing, you do not have to 
set up projects. See also Setting up Project-Level Billing (page 209).


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on Billing Amount checkbox displays on the Project Invoice Entry window as well, with the checkbox 
defaulting based on the Project from the Project Maintenance window. Users can mark/unmark the 
checkbox in the Project Invoice Entry window. Taxes are recalculated when the checkbox is marked/
unmarked. 
Total to Allocate (read-only)
This field displays the project's contract amount, or the sum of the contract amounts for all jobs assigned 
to this project. If you are using the Project Allocated Revenue billing type, this field indicates the total 
amount that will be allocated by bill code.
Total Reimbursable (read-only)
This field displays the total billable amount generated by any reimbursable jobs assigned to this project. 
If there are no reimbursable jobs assigned to the project, this amount is zero.

Enter additional project information as necessary.
To print the Project Number Setup report, select File > Print or select the printer button.
Select Save.

Setting up Master Tax Schedules
You can create master tax schedules to determine how taxes will be calculated on your job when billing customers. 
Master tax schedules allow you to exclude billing for specific cost elements from the sales tax calculation. You can also 
have specific cost elements taxed with different tax schedule IDs.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Job Cost Setup > Master Tax Schedules.
Complete the following fields, as necessary.

Master Tax Schedule ID
Use the lookup to select an existing ID.
Tax Schedule ID
Select a tax schedule for each cost element. The Master Tax Schedule ID defaults but can be edited.
Exclude From Tax Calculation
If billing taxes on certain cost elements is not required, mark this checkbox. For each cost element, you 
must either select a tax schedule or mark it as exempt.

To print the Master Tax Schedule List report, select File > Print or select the printer button.
Select Save.

Choosing Job Cost Setup Options
You can determine how Job Cost operates by choosing setup options.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Job Cost Setup > Setup Options.
Complete the following fields, as necessary.

Change division after costs are posted to a job
Mark this checkbox if you plan to change divisions after posting costs. You can only do this if you are not 
using the percentage-of-completion revenue recognition method. To change the division, you must set 
up more than one division. See Setting up divisions (page 39).
Auto adjust forecasted only when posted is greater than forecasted
This option is used when choosing the Adjust Forecasts button in the Job Status window. You can adjust 
forecasted costs/labor to equal posted costs/labor (depending on whether you are calculating 
percentage of completion based on costs or labor hours). Mark this checkbox if you want forecasted units 
to be revised only for cost codes where the posted units are greater than the forecasted units. If this 
checkbox is not marked, forecasts are revised for every cost code where the posted cost/labor does not 
equal forecasted costs/labor. Forecasted costs/labor hours for jobs are displayed in the Job Status 
window (Inquiry > Job Cost > Job Status).
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Allow forecasted cost to be less than posted cost for a job
Mark this checkbox if you want to allow forecasted costs to be less than actual costs on a job. You cannot 
mark this checkbox if you are using the percentage-of-completion revenue recognition method. 
See Choosing Posting Options (page 23).
Use department for profit type 9 service labor rate groups
Mark this checkbox if you want to use labor rate groups that are based on department. If you are using 
labor rate groups based on position, leave this checkbox unmarked. See Creating labor rate groups 
(optional) (page 75) for more information on labor rates.
Profit Amount Decimal Places
To change the number of decimal places allowed for entering profit amounts, select a number from the 
drop-down list. The default is 2, which is the minimum number of decimal places. You cannot decrease 
this number once you have saved a new number.
Suppress PO Line Item Tax Update to Job Cost and Service Management
Mark this checkbox to suppress the inclusion of tax on purchase order line items as part of the line item 
cost updated to Job Cost and Service Management. This checkbox affects both Job Cost and Service 
Management. This option will automatically be marked and disabled if the Enable GST for Australia/New 
Zealand and Enable Tax Date checkboxes are marked in the Microsoft Dynamics GP Company Setup 
Options window. To open the Company Setup Options window, select the Options button in the 
Company Setup window (Microsoft Dynamics GP > Tools > Setup > Company > Company).
Suppress Contract Payment tax update to Job Cost and Service Management
This affects tax updates to posted costs on jobs. If marked, taxes will not show as posted costs on jobs. If 
unmarked, posted costs will include taxes.
Display fully invoiced bill codes during job invoice entry
Mark this checkbox to display fully invoiced bill codes during job invoice entry. When you enter job 
invoices, the system will ask if you want to display fully invoiced bill codes in the Schedule Invoice 
window.
Display Preference
Mark the appropriate radio button to display the markup or margin percent in the Job Status window. 
Markup percent calculates a job's profit amount as a percentage of forecasted costs. Margin percent 
calculates profit as a percentage of the expected contract amount. The display preference selected also 
affects the following windows and reports:

Job Status by Period window
Job Status History window
Project Status window
Project Manager Summary window
Job Status report
Job Schedule report
Forecasted Costs by Period report
Project Status report
Job Reference report
Job Schedule by Division report
Job Schedule by Project report
Posted Costs by Period report
Job Status History report
Setup Options report

Default from Last PO Line Entered
When adding a line item to a purchase order in the alternate Purchase Order Entry and alternate 
Purchasing Item Detail Entry windows, you can have the job number and cost code default from the last 
line item entered. Mark the Job Number checkbox if you want the job number from the last line item 
entered to default into the Job No/Service Call field. If you mark the Job Number checkbox, you can also 
mark the Cost Code checkbox if you want the cost code from the last line item entered to default into the 
Cost Code field.
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Reporting
You can select to print reports as they are normally printed, or as SQL reports. To deploy SQL reports, you 
must select Run Wizard to run the Signature SQL Reporting Wizard. Refer to the Reports manual for 
additional steps required to set up SQL reports.

Select Save.

Setting up Job Types
The Job Type field is an informational field in the Job User-Defined window. You can define a list of job types that can 
be accessed from the Job Type lookup window.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Job Cost Setup > Job Type.
In the Job Type Setup window, enter a Job Type.
Select Save.

Setting up Architects
If you use American Institute of Architects (AIA) billing, you must set up the architects used on jobs.

Select Cards > Job Cost > Architect.
Enter an Architect ID and the architect's full Name.
Enter address information.
Select Save.

You can assign architects to jobs in the Job Maintenance window. See Job maintenance (page 88).

Setting up Cost Codes for Job Cost
Cost codes are used to define and categorize the costs of a job. Cost codes serve as the building blocks of job costing 
and allow you to define the source of posting accounts and the revenue recognition method used. Cost recognition in 
Job Cost consists of the cost code format or structure, cost code segments, cost codes, and cost code elements. In 
addition, you need to specify profit types (for Cost Plus contract and Cost Plus NTE contract jobs) and production 
measures that you can assign to cost codes.

Setting up cost codes involves the following, in the order displayed:

Dividing a job into segments (page 34)
Setting up cost element names (page 34)
Renaming cost code segments (page 35)
Setting up the cost code format (page 36)
Defining production measures (page 36)
Saving predefined profit types (page 37)

Description of profit types (page 37)
Setting up master cost codes (page 38)

If you want to print the Setup Options report using the printer button, make sure to save the window first.

Once you assign a job type to a job and save it, you cannot delete the job type unless you remove it from all 
jobs.


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Dividing a job into segments
Large projects, activities, and organizations are often divided into smaller parts to facilitate their management. The 
following diagram shows how a job can be broken into cost elements and cost code segments (phases, steps, details, 
and components).

Setting up cost element names
Cost elements are categories of costs on a typical job and are used to group similar costs or cost codes. Labor, Material, 
Equipment, Subcontractor, and Other serve as default cost elements. Four user-defined cost elements are also 
available.

You can accept the default cost element names or rename them. You cannot rename the Labor cost element because it 
is the only cost element used with payroll transactions. You should establish your cost elements before renaming your 
cost code segments

Below is a list of the default cost elements
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Cost 
element

Description

1 - Labor You can post transactions that include the Labor cost element to Job Cost payroll or Microsoft 
Dynamics GP Payroll. You can also post labor costs with job transaction entries.

2 - 
Material

If you're using Inventory Control, you can post transactions that include the Material cost element to 
Job Cost and Inventory Control. You can also post material costs with job transaction entries or 
accounts payable transactions.

3 - 
Equipmen
t

If you're using Payables Management, you can enter equipment costs on a voucher and post to the 
payables record for the vendor from which you rented the equipment. You can also post equipment 
costs with job transaction entries or inventory transactions.

4 - 
Subcontr
actor

If you're using Payables Management, you can post Transactions that include the Subcontractor cost 
element to Payables Management. You can also post subcontractor costs with job transaction entries 
or inventory transactions.

5 - Other This cost element is used to track miscellaneous costs that do not fall into one of the four default cost 
elements. Examples are manually calculated overhead amounts and freight. You can also post Other 
cost elements with job transaction entries, accounts payable, or inventory transactions.

6 to 9 
-User-
defined

You can create up to four user-defined cost elements and define revenue and expense posting 
accounts. You can also post user-defined costs with job transaction entries, accounts payable, or 
inventory transactions.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Cost Code Setup > Cost Elements.
You can change the names of the default and user-defined cost element descriptions. 

To print the Cost Element Setup List report, select File > Print or select the printer button.
Select Save.

Renaming cost code segments
A segment represents a unique category of information, such as a business location, department, or account type. 
Default names for cost code segments are provided in the Cost Codes Segment Setup window. You can either save the 
default names or rename the segments to suit your needs.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Cost Code Setup > Cost Code Segments.
You can enter a new name for each cost code segment. For example, if you create cost codes and use the second 
segment to differentiate the cost codes by warehouse location, enter "location" instead of "phase."
Select Save.

If you plan to modify any Job Cost reports using Report Writer, you must use the default name in the 
Internal Name column.



If you rename a cost code segment, you must do so before setting up your cost code format.
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To print the Cost Code Segments List report, reopen the Cost Code Segment Setup window, and select File > 
Print or select the printer button.

Setting up the cost code format
The cost code format can contain one to four segments. Each segment can contain up to five alphanumeric characters. 
Each segment of a cost code represents a unique phase, step, detail, or component level of a job.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Cost Code Setup > Cost Code Format.
In the Number of Segments field, enter the number of segments for your cost codes. This is determined by how 
you plan to break down your jobs. You can enter up to four segments and can enter a maximum of five 
alphanumeric characters for each segment. Do not leave blank characters in segments. 

Select Save.

If you want to change the cost code format after saving, you must contact WennSoft Support. We do not recommend or 
support changing the cost code format after costs post in Job Cost.

Defining production measures
Production measures are used to track the number of units estimated or produced for a selected cost code. Typical 
measures are Hours and Each.

A quantity-per-unit is calculated automatically for each cost code in the Job Cost Code Setup window. You can also 
compare actual production quantities for cost codes to estimated production quantities to help identify problems with 
a job.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Cost Code Setup > Measures.
Enter a Measure Code and Description.
Select Save.
To print the Production Measure Codes report, select File > Print or select the printer button.

If you rename a segment, you must do so before setting up your cost code format.

You must enter at least one segment consisting of at least one character. You can use additional steps, 
details, and components. We do not recommend or support changing the format after you post costs.



If you need to use large segment lengths in your company, you may need to change your Microsoft Dynamics 
GP user preferences to allow scrolling arrows in your cost code fields. To change preferences, select Microsoft 
Dynamics GP > Tools > Setup > User Preferences. In the User Preferences window, mark the Horizontal Scroll 
Arrows checkbox.



You must set up production measures before you add cost codes to your jobs. This is necessary for assigning 
production and estimate measures to the cost codes. You can set up additional production measures in the 
Job Cost Codes Setup window.


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Saving predefined profit types
Profit types define billing amount calculations for cost codes. When you assign a profit type to a cost code, billing 
amounts on all posted job transactions for this cost code use the calculation method associated with the assigned 
profit type. If you select Cost Plus or Cost Plus NTE as a job's contract type, billing amounts calculate automatically as 
costs are posted to the job. These amounts are based on the profit types on the Profit Type Setup window.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Cost Code Setup > Profit Types.
Select Save. 

To print the Profit Type Setup List report, reopen the Profit Type Setup window, and select File > Print or select 
the printer button.

Description of profit types
1 - Non-billable
Billing amount = 0.00 
Use this profit type when the cost amounts posted to the cost code for the job should not be billed to the 
customer, or if you want to track costs but not bill for costs.
2 - None
Billing amount = cost amount 
Use this profit type when the cost amount charged to the cost code for the job will become the billable amount. 
This is the default profit type for all cost codes on Fixed Amount contract jobs.
3 - Percent margin
Billing amount = cost / (1 - percent margin) 
Use this profit type when the billing amount is based on a desired profit margin for the cost code. This margin is 
assigned as the profit amount for the cost code. For example, if a unit's actual cost is $100, and you select a 
percent margin of 24 percent, the billing amount is $131.58. (The calculation is: 100 / (1 - 0.24) = 131.58).
4 - Percent of cost
Billing amount = cost + (cost x percent of cost) 
Use this profit type when the markup amount is calculated as a percentage of the actual cost for the cost code 
assigned to the job. This markup percent is assigned as the profit amount to the cost code. For example, if the 
actual cost for the cost code is $100, and you select a percent of cost of 10 percent, the billing amount is $110.
5 - Per unit amount
Billing amount = cost + (number of units x profit per unit) 
Use this profit type when the profit amount is calculated as a dollar amount per unit for the cost code. For 
example, if the cost of each unit is $10, and 10 units are used with a profit amount of $5 per unit, the billing 
amount is $150. (Cost is 10 x $10 = $100 and billing amount is $100 + ($10 x $5) = $150.)
6 - Total dollar amount
Billing amount = cost + profit amount
Use this profit type when the profit amount for the cost code equals a total dollar amount, regardless of the cost 
or number of units used. For example, enter a profit amount of $100 for the cost code. The amount billed for the 
cost code is cost plus $100.
7 - Flat rate per cost code
Use this profit type when the billing amount for the cost code equals a total dollar amount, regardless of the cost 
or number of units used. The total amount billed for the cost code is entered as the profit amount for the cost 
code. For example, enter $10 as the total amount billed for the cost code. If your cost is $7, your profit is $3. If 
your cost is $8.50, your profit is $1.50.

You must open and save the Profit Type Setup window, even though you cannot change the defaults.
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8 - Flat rate per unit
Use this profit type when the cost code is billed as a flat amount per unit regardless of the cost of the unit. The 
amount billed per unit for the cost code is entered as the profit amount for the cost code. For example, if you 
enter a billable amount of $25 for a labor cost code, you bill $25 per unit. If your cost per unit is $10, your profit 
per unit is $15. If your cost per unit is $22.50, your profit per unit is $2.50.
9 - Service labor rate group
If you are also using Service Management, use this profit type to bill job customers for labor-only cost codes and 
establish billing amounts for labor transactions. Labor rates can be set up to reflect different rates for different 
pay codes. You can create labor rates by position or by department. This profit type is unavailable if you do not 
have the Service Management Labor Rates module. Contact WennSoft Sales if you would like to purchase this 
module.

Setting up master cost codes
Since the jobs a company performs are usually similar, many of the details of the job structure (including some cost 
codes) will be common to many jobs. Master cost codes are commonly used codes that can be easily assigned to jobs 
without reentering information.

When designing cost codes, keep in mind that the system sorts characters from left to right, with numbers taking 
priority over letters.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Cost Code Setup > Master Cost Codes.
Complete the following fields, as necessary.

Cost Element Type
The default is 1 for Labor.
Cost Code, Description
Enter a new cost code and description.
Profit Type ID, Profit Amount
Enter the profit type ID and profit amount. If you only use the cost code on Cost Plus contract jobs, assign 
a profit type ID. The profit type for all cost codes assigned to Fixed Amount contract jobs automatically 
defaults to None and cannot be changed. If all jobs have the same profit amount for this cost code, you 
can set a percentage or currency profit amount.
Service Labor Rate Group
Enter a service labor rate group. This field is enabled only if the profit type is 9 - Service Labor Rate Group. 
See Creating labor rate groups (optional) (page 75).
Estimate Units, Estimate Amount/Unit, Estimate Amount, Estimate Measure, Estimate Measure 
Name
Enter estimate information. Generally, the estimate unit and estimate amount/unit are assigned at the 
job level. The Estimate Amount field fills in automatically. When you enter an estimate measure, the 
Estimate Measure Name field will complete.
Production Est. Qty, Production Qty/Unit, Production Measure, Production Measure Name
Enter production information. If all your jobs use the same production measures for this cost code, enter 
the production quantity needed to complete a typical job. The production quantity per unit is calculated 
automatically based on the Estimate Units field. Enter a production measure. The Production Measure 
Name field will complete.
Transaction Type
Enter the transaction type. Accept All as the default or select from the drop-down list. Choices include 
ALL, Inventory Item, Vendor ID, and Purchase Order. If you select Inventory Item, an Item Number field 
appears, allowing you to enter an inventory item. If you select Vendor ID, you can enter a vendor as a 
subcontractor. See Adding subcontractors to a job record. If you select Purchase Order, a PO Number 
field appears. Enter a purchase order number.
Workers Comp
Use the lookup button to select a workers' compensation code.
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Account Number
If you selected the Cost Code option in posting options setup, select a general ledger posting account to 
post transaction costs assigned to this cost code. When you assign a general ledger account to a cost 
code in the Master Cost Code Setup window, the designation remains in effect when you add the cost 
code to a job in the Job Cost Codes Setup window. If you selected the Division posting option, you will 
not be able to select an account in the Master Cost Codes Setup window. Instead, when you use the Job 
Cost Code window, a default account will appear, taken from your division account setup.

Select Save.
To print the Cost Code Master Setup report, select File > Print or select the printer button.

Setting up Accounts for Job Cost
Setting up posting account information determines how Job Cost transactions post within Microsoft Dynamics GP 
General Ledger.

Setting up accounts involves the following, set up in the order displayed:

Setting up divisions (page 39)
Setting up division accounts (page 39)
Setting up payroll and overhead offset accounts (page 40)
Setting up revenue accounts (page 46)
Setting up invoice accounts (page 48)
Assigning default master cost codes (page 49)
Setting up overhead accounts (optional) (page 50)

Setting up divisions
You can set up divisions to group jobs for reporting and accounting purposes. You can also attribute all job-related 
revenue and expenses to general ledger accounts set up for the division.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Account Setup > Divisions.
Enter a Division name. If you do not plan to use company divisions, select All.
Select Save.
To print the Division Setup list, select File > Print or select the printer button.

Setting up division accounts
You must define a posting account for each cost element. If your company uses multiple divisions, you must assign a 
default set of cost element posting accounts for each division.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Account Setup > Division Accounts.
Select a Division. You must set up accounts for all divisions.
Enter account numbers. You must enter a general ledger account for all cost elements, even if you do not plan to 
use them. If you are adding a new account, a message appears asking if you want to add this account. If you 
select Yes, another message appears asking what type of account you want to add. Select Posting, complete the 
Account Maintenance window, and select Save.
Select Save. 
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To print the Division Accounts report, select Print. You can also print the Detail Codes List report to verify the 
debit general ledger posting accounts for a job's cost codes. See the Job Cost Dexterity Detail codes list report in 
the Reports manual or help file. Go to Help > Signature Manuals or Help > Signature Help.

Copying division accounts
You can copy an existing division and its accounts to save time.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Account Setup > Divisions.
Enter a Division to copy.
Select Copy.
Enter the name of the new division in the Copy Division window.
Select Copy. The division is created, and the accounts are copied to the division. The new accounts are reflected 
in the following windows:

Division Accounts Setup
Payroll and Overhead Offset Account Setup
Revenue Recognition Account Setup
Invoice Accounts Setup
Default Cost Codes

Setting up payroll and overhead offset accounts
You can set up offset accounts to overhead and payroll for jobs to the employee's payroll department, which may or 
may not be the employee's home department. This allows more granularity and detail when employees perform work 
under a different payroll department. Many companies set up payroll so that all employee wages and overhead burdens 
such as benefits, taxes, and tool costs charge to the Payroll departments such as electrical or excavation and these 
departments have managers that carry P&L responsibility. Jobs and service calls are assigned to divisions and may use 
resources from multiple departments.

As costs hit jobs, an offset account is credited, and a Cost of Goods Sold Account is debited so financial reporting can be 
done by division. Often, though, this offset is only at a company level instead of a Payroll department level, so 
department profitability can skew as a result.

You can assign accounts at the department level, and further down at the pay code, overhead code, or cost element 
level. This is accomplished in one window: Payroll and Overhead Accounts Setup.

Example scenario: If a member of the Electrical department, in the Residential division, works on a Job in the Commercial 
division for 30 of 40 hours in a week, the costs of the member's benefits and tools costs for all 40 hours go to the Electrical 
department but 30 hours' worth of revenue is generated in the Commercial division. As a result, the division has profit, even 
with the Cost of Goods Sold amounts that it carries, and the Electrical department does not. If this happens often, financial 
reports can start to indicate that the Electrical department and even the Residential division is not contributing to 
profitability.

If you change accounts, the new account number takes effect for all new transactions posted to this 
division and cost element. Any unposted transactions saved to a batch before you changed the division 
account will post with the account number at the time of data entry.



You must have marked the Payroll Overhead Detail Distribution checkbox during posting setup to copy 
overhead accounts. See Choosing Posting Options (page 23).


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You can access the Payroll and Overhead Offset Accounts Setup in the following ways:

From the main menu, select Microsoft Dynamics GP > Tools > Setup > Job Cost > Account Setup > Payroll Offset 
Accounts.
In Service Management, from the Invoice Accounts window (Microsoft Dynamics GP > Tools > Service Management 
> Invoice Setup > Invoice Accounts > Payroll Offset button).
In Service Management, from the Maintenance Accounts window (Microsoft Dynamics GP > Tools > Service 
Management > Maintenance Setup > Accounts > Payroll Offset button).

About the window hierarchy
This window is organized in a hierarchical tree. There are main branches and sub-branches, like main folders and sub-
folders in a Windows Explorer environment.

Origins represent the product areas: Job Cost, Service Invoice, and Service Maintenance.

Account Types represent the types of offset charges for which accounts will be assigned. These include Gross Pay 
Offset, Overhead Offset, Travel Offset, and Expense Offset

The highest level of the tree is Division; the next highest is Department. The next level depends on the origin/account 
type combination.

Each level contains a Default and All branch. Default is used when you want to assign a default account for that 
department, pay code, and so on, one is not needed at a lower level, such as per pay code, overhead code, or cost 
element. All is used when you know that there will be no specific accounts, and one account will suffice. Even the 
lowest levels within a hierarchy (Pay Code, Overhead Code, or Cost Element) have Default and All.

The ONLY required default account for the entire tree is the All - Default: REQUIRED account. You must assign a 
REQUIRED account for each origin/account type combination. However, this account would only be used if you did not 
have accounts assigned anywhere in the individual Division tree levels.

At a minimum, you MUST assign an All - Default: REQUIRED account for each origin/account type 
combination in the account tree. However, this account would only be used if you did not have accounts 
assigned anywhere in the individual Division tree levels.


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The hierarchy for each origin/account is illustrated below.
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Preparing to set up accounts
The Payroll And Overhead Offset Accounts Setup window provides a lot of flexibility in setting up accounts. Before you 
begin assigning accounts, jot down how general or specific you want charges, expenses, and so on to be charged to 
what accounts, for which departments. Perhaps you could print the origin/account type diagrams above, and mark 
which levels for which you will assign accounts. If necessary, organize and enter your accounts in a spreadsheet, and 
use that as your source when you enter them into the system.
Setup requirements for account types
Please review the following setup requirements for setting up offset accounts.

Overhead Offset
You can enter accounts for individual overhead detail codes (Job Cost) only if the Payroll Overhead Detail 
Distribution checkbox in the Posting Options window is marked. You can still assign a default account that 
would be used for all overhead codes.
Travel Offset Accounts and Expense Offset Accounts
You can enter accounts for travel and expenses only if Signature TimeTrack is registered and the Create 
Expense/Travel Transactions option is set. This applies to all origins.

Printing the account setup list

To keep better track of which accounts were assigned, we recommend you periodically print the Signature Payroll and 
Offset Accounts list. In the Payroll and Overhead Offset Accounts window, select the printer button that appears at the 
bottom left of the window. Complete the Report Destination window to print the report.

Assigning accounts
You must set up at least a required default account for each origin/account type combination.

In the Payroll and Overhead Offset Accounts window, select the Origin and Account Type.

If a setup option has been unmarked (for example, Create Expense/Travel Transactions in the TimeTrack Setup 
Options window) after an account was assigned in this tree that required the setting of that option, the 
account designation will still print in this report; however, the account cannot be posted to.


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Locate the Division for which you want to assign accounts. Use the tree view to navigate as far down the tree as 
you desire, until you hit the level at which you want to assign an account. To save time, you can navigate the tree 
using arrow keys. When you get to a level/node for which you can assign accounts, the account field at the 
bottom of the window is enabled. Some origin/account type trees do not go as deep as others. For example, for 
the travel offset account type, you can specify accounts at the Pay Code level. For the expense account type, you 
can assign accounts one level deeper, at the Cost Element level.
You can select an account in one of two ways:

Double-click on the node to which you are assigning the account (ex. Pay Code). The Accounts window 
opens. Select an account, then click Select. The account displays in the account number in the account 
field. The account is saved automatically. - OR -
Highlight the node in the tree, then enter the account manually in the account field at the bottom of the 
window. When finished, select the Save button. (You only need to select Save when you enter accounts 
manually.) 

Select OK to disregard the error and keep the window open. You will get this message until you enter the 
required account that the system is looking for.
Select Ignore to close the window.

Creating new accounts

Although you will probably not have to very often, you can create new accounts from the Payroll And Overhead Offset 
Accounts Setup window, that will be assigned to whatever node is selected.

Highlight the node in the tree, then enter the account manually in the account field at the bottom of the window.
In the account field, type a new account, then Tab. Select Add when prompted to create the account.
Select the type of account you want to create (Posting, Fixed, or Variable). The Account Maintenance window 
opens.
Complete the fields on the Account Maintenance window, including a Description. When finished, select Save.

How the system determines which account to use
When an offset account is needed in a posting window or elsewhere, the system looks at the Payroll and Overhead 
Offset Accounts Setup window, in the following order, starting from the lowest (more specific) level to the highest (more 
general).

(Specific) Pay Code, Overhead Code, or Cost Element
Pay Code - Default for Overhead Code or Cost Element - Default
Department - All Departments or Pay Code - All Pay Codes (for Job Cost travel and expense offset accounts only)
Department - Default
Division - All Divisions: Department (specific)
Division - All Divisions: Department - All Departments - Pay Code
All - Default: REQUIRED

Reviewing accounts after posting
In this section, we will look at a sample General Ledger after payroll has been posted, in this case, through the Signature 
Transaction Entry window. Included is where from within the Payroll and Overhead Offset Accounts Setup window the 
accounts were grabbed.

Assign more accounts; remember to assign at least an All - Default: REQUIRED account for each 
origin/account type combination. If you close the window without having assigned Default 
accounts, a missing required account number message will display.


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After running Signature Payroll Post, the posting journal report contains account information, including GL accounts 
and amounts. Below is a table of the accounts and windows/areas within Signature Job Cost from which the accounts 
were taken.

Area from Payroll and Overhead 
Offset Accounts Setup window

Account Description Debit Credit

Division Account Setup - 
COMMERCIAL Division - Labor 
Cost element

000-1410-02 WIP-Labor-Jobs-
COMMERCIAL

$2100.00 $0.00

Payroll and Overhead Offset 
Account Setup - Gross Pay Offset 
Credit Account - HOUR pay code

000-5100-00 Salaries and Wages 0.00 1070.00

Payroll and Overhead Offset 
Account Setup - Overhead Offset 
Credit Account - HOUR pay code

000-4801-00 Overhead Offset Job 
Cost Labor

0.00 1036.00

Payroll and Overhead Offset 
Account Setup - Travel Offset 
Credit Account - TRAVEL pay code

000-4800-00 Overhead 0.00 3.80

Totals $2100.00 $2100.00

Setting up revenue accounts
You must designate the posting accounts that update when you create a percentage-of-completion journal entry or 
closing jobs journal entry for each division.
Even if you do not use the percentage-of-completion revenue recognition method, you must complete the revenue 
recognition account setup to specify payroll and payroll overhead offset accounts.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Account Setup > Revenue Accounts.
Select a division from the drop-down list, then select a Source Document.
Select accounts for the following categories. You must assign an account number to each revenue recognition 
account.

Progress Billings
Customer billings post to this general ledger account, which debits during the creation of revenue 
recognition entries for customer billings and should be the same account entered in the Invoice Account 
Setup window for each division.
WIP accounts
Enter WIP accounts for each cost element. These nine accounts will be the credit accounts in the 
percentage-of-completion journal entry for the various cost elements. If you are using percentage-of-
completion or completed contract revenue recognition, these accounts should be the same as those 
entered in the Division Accounts Setup window.
Billings in Excess of Cost + Earnings
The posting account to which amounts post for jobs with amounts billed greater than revenue earned on 
the job (in excess of cost plus earnings).
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Unbilled Receivable
The posting account to which amounts post for jobs with amounts billed less than the revenue earned on 
a job (unbilled receivables).
Prior Year Retained Earnings Offset
Enter the prior year retained earnings offset. This account is not used at the present time, but you must 
still enter an account for each division.

Select Save.
To print the Job Cost Revenue Accounts report, select Print. This report contains all the accounts you designate 
for revenue recognition.

Assigning revenue and expense accounts
You must assign revenue and expense accounts that will be used as offset posting accounts for the WIP accounts 
selected in the Revenue Recognition Account Setup window.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Account Setup > Revenue Accounts. The Revenue 
Recognition Account Setup window opens.
Select the Revenue and Exp Accounts button.
Select accounts for the following categories:

Contract Earned
The contract earned account, which is the posting account to which revenue amounts for open jobs post 
when the percentage-of-completion journal entry is created. Typically, this is a sales-open jobs account.
EXP accounts
Enter expense accounts (EXP) that are debit offsets to the accounts entered in the WIP fields in the 
Revenue Recognition Account Setup window during the percentage-of-completion journal entry.

Select Save.

Setting up accounts for closing jobs
If you use the percentage-of-completion revenue recognition method and post costs to WIP balance sheet accounts 
rather than expense accounts, the totals will be moved from the balance sheet to the profit-and-loss statement when 
you close the job. The accounts you set up in this section are updated with those totals when the job closes.

Enter a close jobs account for each editable field that is updated when you complete the job closing process. You must 
enter accounts for all items in the Close Jobs Account Setup window.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Setup > Account Setup > Revenue Accounts.
Select the Close Jobs Accounts button. The progress billings account and WIP accounts you entered in the 
Revenue Recognition Accounts Setup window automatically appear as defaults in the Close Jobs Account Setup 
window. You cannot change those accounts.
In the Contract Earned Closed Jobs field, enter the contract earned closed jobs account. Closed job revenues 
post to this account as the offset to progress billings accounts.
Enter expense accounts. The accounts entered will be debit offsets to the accounts entered in the WIP fields in 
the Revenue Recognition Account Setup window during the close job journal entry.
Select Save.
To print the Closed Jobs Accounts report, select Print.

We recommend that you use the same accounts for closing jobs as you do for revenue recognition.
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Setting up invoice accounts
You must specify general ledger posting accounts, which are updated when you post job-related invoices. You can 
select to use a single sales general ledger account when posting Job Cost invoices (required for percentage-of-
completion and completed contract revenue recognition methods) or assign a sales account to each cost element billed 
on an invoice. Assigning a sales account to each cost element allows you to track invoiced amounts by cost element in 
the general ledger.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Account Setup > Invoice Accounts.
Select a division from the drop-down list. 

Select an invoice posting option and the appropriate general ledger posting accounts based on the invoice 
posting option you selected:

Option 1 - Single sales account Option 2 - Sales account for each 
cost element/code

Select this option if... You use the percentage-of-
completion or completed contract 
revenue recognition method. 
The single sales account method 
designates that one general ledger 
account updates when you post Job 
Cost invoices to the selected division.

When an invoice is posted with this 
option, the typical general ledger 
entry debits an accounts receivable 
account and credits a progress 
billings account.

You want to update designated sales 
posting accounts assigned to each cost 
element when you post Job Cost 
invoices to the selected division.

Typically, you use this method to 
recognize revenue when issuing 
invoices. This option allows you to 
compare amounts billed for each cost 
element. For example, if you want to 
know the total amount of labor sales, 
all labor sales amounts are posted to 
one general ledger account. Each sale 
from a cost element posts to its 
specific account.

The invoice posting accounts are updated when you post invoices for a job assigned to this division. 
You must enter accounts for each division.



You cannot select option 2 if 
you are using the percentage-
of-completion revenue 
recognition method.


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Option 1 - Single sales account Option 2 - Sales account for each 
cost element/code

Sales account to use 
when posting Job Cost 
invoices

Progress Billings 
Enter the general ledger account 
credited when invoices are posted for 
jobs. This is for percentage-of-
completion or closed jobs journal 
entries. This account is the offset to 
the progress billings account and 
should be the same as the account 
entered in the Division Accounts 
Setup window (Microsoft Dynamics GP 
> Tools > Setup > Job Cost > Account 
Setup > Division Accounts).

You can enter one sales account if you 
recognize revenue when invoices post 
and you want all sales amounts 
posted to the same general ledger 
account.

Cost Element Sales Accounts 
Enter a sales account for each cost 
element. These accounts are updated 
for each cost element affected by an 
invoice:

Labor
Materials/Equip
User-Defined 2
Subcontractors
Travel
Startup
Other
User-Defined 7
User-Defined 8

Enter receivables and commission accounts:
Accounts receivable
The general ledger account debited when you post accounts receivable amounts for Job Cost invoices.
Retention accounts receivable
The general ledger account debited when you post retention accounts receivable amounts for Job Cost 
invoices.
Commissions payable
The general ledger account credited when you post commissions payable amounts for Job Cost invoices. 
Your setup selections in Receivables Management determine commission amounts.
Commissions expense
The general ledger account debited when you post commissions expense amounts for Job Cost invoices.

Mark the Use a sales account for each bill code checkbox if you want to use a sales account for each bill code at 
the job level and during job invoice entry. You cannot use this option if there are unposted invoices.
Select Save.
To print the Invoice Accounts report, select Print.

Assigning default master cost codes
If you use Payables Management with Job Cost, you can assign master cost codes that appear as defaults for specific 
distribution types when you enter Job Cost accounts payable transactions. These distribution types include trade 
discounts, freight, miscellaneous, tax amounts, and depreciation.
When you assign a master cost code as the default for a payables distribution type, costs automatically distribute to the 
cost code during transaction entry after you select a job number, provided the master cost code exists for the job. The 
costs then post to the general ledger account assigned to the Job Cost code.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Account Setup > Default Cost Codes.
Select a division from the drop-down list.
Mark the appropriate distribution types checkboxes. As you mark the checkboxes, the Cost Code Number field 
becomes enabled. You do not need to use all distribution types. By assigning a cost code number in the 
Depreciation field, the Fixed Assets Management depreciation expense account is credited, and the Job Cost 
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general ledger account is debited upon posting. The asset must be set up as a job with the asset ID being the job 
number. The asset ID must also have a suffix of 1. The Depreciation field is enabled only if the Fixed Assets 
Management module is installed.
Assign a Cost Code Number and general ledger account to each distribution type.
Select Save.
To print the Default Cost Codes report, select Print.

Setting up overhead accounts (optional)
If you selected the Payroll Overhead Detail Distribution option when you set up posting options (Microsoft Dynamics GP 
> Tools > Setup > Job Cost > Job Cost Setup > Posting Options), you must set up overhead accounts. An overhead detail 
account must be assigned for each division and each overhead detail code. Based on this setup, the posting process 
calculates each individual overhead detail cost amount and distributes that cost to a separate general ledger account.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Account Setup > Overhead Accounts.
Enter a Division.
Enter the Overhead Detail Code and Overhead Detail Account.
Select Save.
To print the Overhead Detail Accounts report, select File > Print or select the printer button.

Setting up Payroll for Job Cost
Set up Job Cost payroll in the following order:

Setting up Overhead Detail Codes (page 52)
Setting up Overhead Group Codes (page 53)
Setting up Federal Classification Codes (page 53)
Setting up Union Categories (page 54)
Setting up Union Codes (page 54)
Setting up Employee Codes (page 55)
Setting up Rate Classes for Union Payroll (page 55)
Prevailing Wage and Fringe Rate Calculation (page 62)

Overview of overhead codes
Overhead is the indirect, job-related cost your company incurs in the process of doing business. Examples of overhead 
costs are workmen's compensation and benefits earned by hourly employees. Overhead may also include items such as 
administrative salaries, rent expense, and other indirect expenses incurred in a job.

Job Cost allows you to recognize the overhead cost of labor by creating overhead detail codes and assigning those 
codes to overhead groups. The overhead groups are associated with position/department codes, which are associated 
with employees. The employee and job are entered in the payroll transaction. After a transaction is posted, the 
overhead is applied to the job.
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Overhead detail codes
Overhead detail codes define how overhead amounts are calculated based on payroll costs. You can recognize indirect 
labor costs, not typically set up as cost codes on an hourly or piecework basis, as overhead. These costs are added to 
posted amounts for the detail and are not identified separately on customer invoices.

For example, assume you employ a technician, JBLACK, who works 10 hours at $10 per hour. If you set up a fixed cost 
overhead detail code of $5 per hour to account for benefits and a fixed cost overhead detail of 20 percent for general 
overhead, JBLACK's job wage calculation is:

10 hours @ $10 per hours $100.00

Overhead detail-benefits $50.00 ($5 x 10 hours)

Overhead detail-general $20.00 ($100 x 20%)

Job Wages $170.00

In this example, you would enter two overhead detail codes: one for benefits and one for general. You could use the 
abbreviation code BEN for the description "Benefit" and use $5 for the fixed portion. You could also use the code GEN 
for the description "General Overhead" and 20 percent as the portion.

The payroll transaction posts in Job Cost and then in the general ledger, provided the accounts are the default general 
ledger accounts, as a debit to WIP-Labor, a credit to the Wages Payable account of $100, and a credit to the Overhead 
Offset account of $70. The Wages Payable and Overhead Offset posting accounts default by division from the Revenue 
and Exp Account Setup window.

The methods for calculating overhead are flexible. You can allocate overhead on a cost-per-unit basis to a labor cost 
code or as a percentage of cost, or a combination of both.

Overhead group codes
Overhead group codes organize overhead detail codes logically per departments, positions, and pay codes. For 
example, assume you set up detail codes for hourly workmen's compensation overhead and hourly driving time to a 
site. You combine these details under a group code named Hour and specify that the code applies to technicians 
assigned to the installation department.

The following illustration shows how overhead details can be grouped:

You must set up detail codes for overhead in Job Cost regardless if you apply overhead to your jobs. To do so, 
create an overhead detail code for zero percent or zero dollars per unit.


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Each detail code represents an indirect cost. You could enter the percentage of wages incurred on each of the details 
and use the appropriate amounts to calculate and track overhead costs on Job Cost payroll transactions assigned to 
the installation group code.
Grouping detail codes allows you to use both percentages and fixed amounts when calculating specific overhead 
amounts.

To post payroll transactions, you must set up at least one overhead group. Even if your company does not assign 
overhead costs to jobs, you must create an overhead detail code for zero percent or zero dollars per unit. You then 
assign the code to overhead group codes for each job department/position combination. See Setting up Overhead 
Group Codes (page 53).

Setting up Overhead Detail Codes

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Payroll Setup > Overhead Detail Codes.

Complete the following fields, as necessary.
Overhead Code, Description: Enter an abbreviated name and a description for the overhead 
classification.
Allocation Method
Assign one of the following methods of calculating overhead for the detail code:

Fixed portion
Allows you to allocate overhead on a cost per unit basis for payroll transactions. For example, if 
you want to apply hourly overhead to account for the cost of employees driving to and from a job 
site, you could add $1.50 per hour (the unit of measure) with an overhead detail code to cover the 
cost.
Percent portion
Allows you to allocate overhead on a percentage basis for payroll transactions. For example, you 
can set up an overhead detail code for the cost of taxes incurred on an employee's pay rate that 
adds 16 percent of the payroll wages.

You must set up detail codes for overhead in Job Cost regardless if you apply overhead to your jobs. To do so, 
create an overhead detail code for zero percent or zero dollars per unit.



If you have unposted payroll transactions (for either Microsoft Dynamics GP Payroll or TimeTrack), do 
not change overhead detail codes (or create new codes and assign them to affected overhead 
accounts) until all unposted transactions are posted. Otherwise, posting these transactions could 
result in unbalanced general ledger entries. Contact WennSoft Support for assistance.


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Fixed Portion, Percent Portion
Enter the fixed portion or percent portion amount. The field that is enabled depends on the allocation 
method you chose.

Select Save.
To print only the overhead detail codes using the Overhead Detail Codes report, select File > Print or select the 
printer button. To print all detail codes (including overhead), select Reports > Job Cost > Job Reports > Detail 
Codes List.

Setting up Overhead Group Codes
If you use the Microsoft Dynamics GP Payroll module, Job Cost uses the departments, pay codes, and positions entered 
in that module for the overhead group codes. If you do not use Microsoft Dynamics GP Payroll, you must enter 
employee master records, department, position records, and pay codes if you want to recognize overhead.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Payroll Setup > Overhead Groups.
Enter an Overhead Group name and Description. Use the Tab key to move from the name to the description.
Enter a Department, Position, and Pay Code. You can use the word All in each of these fields.
Enter a Detail Code and select Save.
To print the Overhead Group Codes report, select File > Print or select the printer button.

Facilitating setup by using All
Since the number of combinations of department, position, and pay code for a given overhead group code can become 
quite large, you can facilitate the setup by entering the word All in any of those fields. For example, if all departments, 
all positions, and all pay codes have a general overhead detail code, All could be used with each of those items.

If a specific combination of department, position, and pay code has a unique detail code, that combination will be used 
along with any All combinations for the overhead group that match the same criteria. For example, if the administration 
department, CEO position, and salary pay code combination had a special bonus overhead detail code, and the All 
departments, CEO position, and All pay codes combination also had a bonus overhead detail code, both detail codes 
would be used.

Setting up Federal Classification Codes
Federal classification codes are assigned to employees in the Employee Maintenance window or to transactions during 
Job Cost payroll entry.

If you use Microsoft Dynamics GP Payroll to print payroll checks, these classifications appear on certified payroll reports 
printed from Job Cost (Reports > Job Cost > Labor Reports > Certified Payroll).

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Payroll Setup > Federal Classification Codes.
Enter a Fed Class Code and Description.
Select Save.
To print the Federal Classification Codes report, select File > Print or select the printer button.

You must set up group codes for overhead in Job Cost regardless if you apply overhead to your jobs. To do so, 
create an overhead detail code for zero percent or zero dollars per unit. Assign this overhead detail code to the 
All overhead group code for job department, position, and pay code.


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Setting up Union Categories
If you employ union members, you can enter benefit and deduction categories to be included on your Job Cost Union 
report. Benefit and deduction categories are assigned payroll benefits and/or deductions. These are calculated during 
payroll processing and printed on the Job Cost Union report.

Once union categories are created, you assign the categories to a union code using the Benefits and Deductions buttons 
in the Union Code Setup window.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Payroll Setup > Union Categories.
Enter a Union Category.
Mark the appropriate checkbox to determine which window the union categories will be displayed in:

Display in union benefit window
Union categories will appear in the Union Benefits Setup window.
Display in union deduction window
Union categories will appear in the Union Deductions Setup window.

Select Save.
To print the Union Categories List report, select File > Print or select the printer button.

Setting up Union Codes
You can set up union codes that identify the unions your company is required to report to. Once unions are created, you 
can assign benefits, pay codes, and deductions.

Step 1: Create a union code.
Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Payroll Setup > Union Codes.
Enter the union code, description, and address information. The Benefits, Hours, and Deductions buttons 
become enabled.
Select Save. 

To print the Union Code List report, select File > Print or select the printer button. The report includes a union 
employee's earned wages, benefit, and deduction amounts for a specified period of time. 

Step 2: Assign union benefits
Select the Benefits button in the Union Code Setup window. You can assign the benefits provided by a union to 
the union codes. Example benefits include 401K and life insurance.
Select a benefit category from the Benefit Category drop-down list. This list contains the benefit categories 
defined in the Union Category Setup window.

A maximum total of 150 benefits and deductions print on the Union report.

Deduction and benefit codes must be set up in the Microsoft Dynamics GP Payroll module.

You must pay employees weekly and use the Microsoft Dynamics GP Payroll module to print Job Cost 
Union reports. Also, the date used for building checks must be the same as the beginning and ending 
dates on your payroll transactions.


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Select a Benefit Code in the list and then select Insert >>. The benefit code appears in the Union Benefits list.
Select Save.
To print the Unions Benefits/Deductions List report, select File > Print or select the printer button.

Step 3: Assign pay codes
Select the Hours button in the Union Code Setup window. You can assign pay codes set up in Microsoft Dynamics 
GP Payroll to a union pay type for the union code. Example pay codes include hourly and overtime.
Select a pay type from the Union Pay Type drop-down list.
Select a Pay Code in the list, then select Insert >>. The pay code appears in the Union Codes list.
Select Save.
To print the Unions Benefits/Deductions List report, select File > Print or select the printer button.

Step 4: Assign union deductions
Select the Deductions button in the Union Code Setup window. You can assign deductions associated with a 
union to the union codes.
Select a deduction from the Deduction Category drop-down list.
Select a Deduction Code in the list and then select Insert >>. The deduction code appears in the Union 
Deductions list.
Select Save.
To print the Unions Benefits/Deductions List report, select File > Print or select the printer button.

Setting up Employee Codes
You can set up a relationship of employees to their union code and/or federal classification in the Employee 
Maintenance Codes window.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Payroll Setup > Employee Codes.
Enter an Employee ID. The Name defaults.
Enter a Rate Class. See Setting up Rate Classes for Union Payroll (page 55).
Enter a Union Code.
Enter a Federal Classification.
Select Save.
To print the Employee Maintenance report, select File > Print or select the printer button.

Setting up Rate Classes for Union Payroll
Rate classes allow you to assign wage rates, benefits, and deductions to union employees by category. Within a 
particular rate class/union, you can create multiple rate classes based on different combinations of positions, pay 
codes, and deduction/benefit categories.

Multiple unions for one rate class
You can have multiple unions for the same rate class. This is useful if you have employees from multiple trades 
employed on the job or an employee who works for another union local (besides his home local) for a short 
amount of time. Conversely, you can also have one union be part of multiple rate classes.
Multiple calculation methods for benefits and deductions
You can calculate benefits or deductions based on % of Net Wages, % of Gross Wages, % of Deduction, and % of 
Earnings Wages, just as you can in Microsoft Dynamics GP. In addition, the system allows fixed Microsoft 
Dynamics GP benefits and deductions to be calculated, even if they are not set up as being part of a rate class, 
for example, if an employee has garnishments set up in GP.
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Prevailing wage and benefit determination
You can implement prevailing wage and fringe rates into your payroll calculations, based on the information 
from the government-supplied Davis-Bacon Act (DBA) wage determination sheet. This information is based on 
the union, county, and occupational (fed class) code and includes standard and overtime rates for wage and 
fringe benefits.

The rate class feature allows employees to use the same "base" pay codes and benefit codes, relying on the system to 
substitute the appropriate pay rate or benefit/deduction calculation depending on several factors such as varying union 
local guidelines, job location (for example, Milwaukee vs. Chicago), or even the type of job (for example, heavy 
commercial vs. light commercial).

An example would be when an employee receives a completely different compensation package for a period of time, 
such as when a journeyman is the most senior person on a job site and thus qualifies for the Foreman wage and benefit 
package for that period of time.
The rate class calculates rates based on a matrix of job positions (classification), pay codes, and union codes; each of 
which can be changed on a line by line basis on the timesheet.

In a union environment, companies are faced with complex methods to determine the rate of pay for an employee. In 
addition to specific wage rates based on the worker’s experience level and classification within a union, the location of 
the work and the employee’s relationship with the company can become a factor. See Over-Scale Pay Rate Support for 
Unions (page 59) for more information.

Before you begin
Before you use rate classes, make sure the following have been set up:

Employee pay codes, deductions, and benefits
Union categories and union codes

If the deductions and benefits are not set up for an employee, they will not be included in the paychecks.

To set up pay codes, select Microsoft Dynamics GP > Tools > Setup > Payroll > Pay Code.
To set up deductions, select Microsoft Dynamics GP > Tools > Setup > Payroll > Deductions.
To set up benefits, select Microsoft Dynamics GP > Tools > Setup > Payroll > Benefits.

Setting up rate classes
Setting up rate classes involves the following:

Step 1: Enable the rate class feature
You enable the rate class feature in the Posting Options window.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Job Cost Setup > Posting Options.
In the Payroll section, mark the Rate Class checkbox.
Select Save.

Before you install the latest Microsoft Dynamics GP service pack relating to payroll issues, and before you use 
rate classes, contact WennSoft Support.



Once you decide to use rate classes, make sure you set up all pay codes as part of a rate class. Otherwise, 
checks will be calculated based on Microsoft Dynamics GP Payroll instead of rate classes.


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Step 2: Set up rate class codes

This is where you enter your rate class codes, enable prevailing wage and fringe rate calculation feature (which 
includes use highest wage rate), or only the use highest wage rate (excluding prevailing calculation).

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Payroll Setup > Rate Class.
Enter a Rate Class code name. Give some thought as to how you want to categorize/name your rate classes. For 
example, if you are setting up your rate classes to reflect the type of job, for example, heavy commercial vs. light 
commercial, indicate that in the rate class name.
Complete the remaining fields, as necessary.

Rate Class
Enter the name of your rate class, being as descriptive as possible.
Description
It might be a good idea to include the names of the unions assigned to this rate class, in this description.
Use Prevailing Wage and Fringe (Davis Bacon)
If your organization pays its employees' wages and fringes based on the government-supplied wage 
determination sheet, mark this checkbox so that you can set up rate classes to automatically calculate 
those rates and fringes. If this checkbox is marked, the second is automatically marked. When you mark 
this checkbox, the Use Highest Wage Rate checkbox is marked automatically, as the prevailing feature 
must first determine the highest wage rate for an employee.
Use Highest Wage Rate
If your organization pays its employees the highest rate no matter what, mark this checkbox, and leave 
the other checkbox unmarked. The system determines the highest rate from the following: 1) employee 
2) rate class 3) job rate class and 4) transaction (if different).

Select Save.

Copying rate classes

You can copy an existing rate class to save time. When you copy a rate class, all position/pay code/deduction-benefit 
category combinations are copied also.

Only rate classes that contain valid pay codes and deductions/benefits will be copied.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Payroll Setup > Rate Class.
Select a Rate Class and select Copy.
Select Copy to the message asking if you want to copy the rate class.
Enter a New Rate Class, Rate Class Description, and New Union Code.
Select Copy.

Step 3: Set up rate class detail

You can set up multiple rate classes for multiple position/pay code/deduction-benefit category combinations. You can 
enter special rates for benefits and deductions using either a fixed dollar amount or percentage of gross wages. These 
amounts override any rates set up in the Employee Deduction Maintenance window (for deductions) and the Employee 
Benefit Maintenance window (for benefits).

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Payroll Setup > Rate Class.
Select a Rate Class code.
Fill the remaining fields, as necessary.

You can set up multiple rate classes for the same union.



58

•

•

•

•

•

•

•
•
•
•

•

•

4.

5.

1.
2.
3.

Federal Classification Code
The federal classification code is an assigned code for this type of work. This field acts as a filtering field, 
which allows you to view the rate classes for just one particular federal classification code.
Union Code
Enter a union code to be associated with this rate class.
Payroll Record Type
Select from Pay Codes, Deductions, and Benefits.
Position
The job position associated with this union/rate class.
Deduction/Benefit Code
If the Payroll Record Type is Deductions or Benefits, select a Deduction/benefit code from the lookup.
Calculation Method
Select from the following:

Percent of Gross Wages: e.g. 401K matching based on employee contribution
Percent of Net Wages: e.g. Vacation pay or employee garnishments
Amount Per Unit: e.g. Pension, Health, and Welfare
Percent of Earnings Wages: e.g. Over-scale pay rates

Pay Code
The pay code associated with this rate class, for example, hourly, salary, overtime, double-time, and so 
on.
Dollar Amount/Percentage
For pay rate or deduction/benefit, enter a dollar amount if the calculation method is Amount per Unit, or 
a percentage if the method involves a percentage, for example, % of gross wages. 

When finished, select Save. Your new rate class will appear in the scrolling window in the lower portion of the 
window. Proceed with adding other unions to the current rate class - OR - create additional rate classes.
To print the Rate Class report, select the printer button. This report contains a list of all rate classes and their 
associated unions. If a rate class is selected when you select the printer button that the rate class and union 
code will default as the selection criteria in the Rate Class Report window. To edit a rate class, double-click a 
record and edit the fields. If you change the Position, Pay Code, or Deduction/Category field, a new record will be 
created. The record you first selected is not overridden. The first record is overridden only if you change the 
amount or percentage in the Calculation Type field.

Step 4: Assign rate classes to union employees

You can assign a rate class to each union employee. Each employee can be assigned to only one rate class.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Payroll Setup > Employee Codes.
Enter an Employee ID.
Enter a Rate Class. The Union Code field automatically defaults to the union code associated with that rate 
class.

If you will be printing the Microsoft Dynamics Worker's Compensation Summary report (Reports 
> Payroll > Period-End), you will need to up the Job Cost Rate Class amount so that it takes into 
account the pay factor for the pay codes set up in Microsoft Dynamics GP. For example, if you 
are creating an overtime rate class and in Microsoft Dynamics GP you've created a standard pay 
code that is $10/hr and then create an Overtime pay code that has a pay factor of 1.5 and is 
based on the standard pay code, you will need to enter $15 for the Overtime rate class.



You cannot delete a rate class if it is assigned to an employee, a job, an uncommitted TimeTrack transaction, 
or an uncommitted Microsoft Dynamics GP Payroll transaction. You can delete an entire rate class (and all its 
records) if a rate class is selected and none of the individual records are selected.


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Enter a Federal Classification Code.
Select Save. You can also assign a rate class to an employee in the following ways:

Assign a rate class to a job that an employee is associated with. This overrides the rate class in the 
Employee Maintenance Codes window. See Assign rate classes to jobs (below).
Assign the rate class to payroll transactions. The rate class is assigned to the employee for that 
transaction only, and overrides the rate class assigned in the Job Maintenance and Employee 
Maintenance Codes windows.

Step 5: Assign rate classes to jobs

You can assign one rate class for each job. The rate class entered in the Job Maintenance window overrides the rate 
class in the Employee Maintenance Codes window.

Select Cards > Job Cost > Job.
Complete the Job Maintenance window, assigning a rate class to the job. See Creating a Job Record (page 88). 
Select Save.

For information on processing payroll with rate classes, see Processing Payroll with Union Rate Classes (optional) (page 
138). This section also contains examples of the many uses of the rate class feature.

Over-Scale Pay Rate Support for Unions
In a union environment, companies are faced with complex methods to determine the rate of pay for an employee. In 
addition to specific wage rates based on the worker's experience level and classification within a union, the location of 
the work and the employee's relationship with the company can become a factor. There are cases where the locality 
should dictate the rate for an employee, where the scale rate in the home union should dictate the rate, and cases 
where the employee is paid a rate above both of these. This features helps the scenario where the worker gets paid the 
highest rate. For example, the employee's home union might be Milwaukee, but could work temporarily on a job in 
Appleton. The Milwaukee union's pay rate is higher than Appleton's, hence, for incentive or other reasons, the 
Milwaukee union might agree to pay the employee their higher home rate. If your company supports similar over-scale 
scenarios, follow the steps below to implement this feature into your payroll system. This feature supports payroll 
transactions created in Payroll Transaction Entry in Microsoft Dynamics GP and in Time Track.

How it works (page 59)
Setup requirements (page 60)
Transaction entry (page 60)
Union Reports (page 60)
Example (page 60)

Pay rates (page 60)
Transaction (page 60)

How it works

Once set up, the system will use the higher pay rate from one of the following:

Rate class for employee's union
Rate class assigned to the job
Employee personal rate (pay code)

The highest pay rate feature applies only to pay rates, NOT to benefits and deductions.
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Setup requirements

To set the system to use the highest pay rate, you must mark the checkbox Use higher pay rate, for ALL rate class 
groups, in the Rate Class Setup window.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Payroll Setup > Rate Class. The Rate Class Setup window 
opens.
Select a rate class.
Mark this checkbox: Use higher pay rate.
Select Save. Proceed to mark this checkbox for all rate classes.

Transaction entry

When you create a payroll transaction with these rate classes, the higher rate will be filled into the respective Pay Rate 
fields. If you are using Signature TimeTrack, if the rate class and union differ between the employer's home union and 
the union he/she happens to be working on currently, you must change the union code on the transaction to a union 
code that is assigned to the job rate class (in the Edit Payroll Fields window). If the two venues are part of the same 
union, then the only thing that might change is the pay rate.

After entering payroll transactions, commit and/or post as you normally would.

Union Reports

On union reports, the union code that will display is the union that the employee worked with while on the job. On the 
Employee Union report, you will see the employee's home union and the union from the job.

Example

Employee works on a job for a different union local, and has been approved to get paid the higher rate, which happens 
to be his home union local. This example uses TimeTrack for payroll transactions.

Employee, WILLIE GREEN, is working on a job for the Sheet Metal Local Appleton union. His home union is Milwaukee, 
and he is performing the same duties in Appleton as does in his home union. In spirit of reciprocity, the Appleton local 
has agreed to pay Willie his home rate, which is the higher rate of the two unions.

For purposes of this example, we will assume that the Use higher pay rate checkbox has been marked for all rate 
classes in the Job Cost system. This example uses TimeTrack.

Pay rates

Our fictitious system is set up with the following pay rates:

Job pay rate (from a rate class assigned to job): $23.45/hour
Home union pay rate (from a rate class assigned to employee): $26.75
Pay code pay rate: $20.00

Transaction

We will create TimeTrack transaction for WILLIE GREEN and show that the system will use the highest pay rate of the 
three:
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The Pay Rate filled correctly with $26.75.

In the Edit Payroll Fields window (expansion button in Pay Code field), the Rate Class fills from the job, and the Union 
from employee. Because the rate class and union code for Willie's union differ from the Milwaukee union, we must 
change the union.
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After changing the union, the Window looks like this:

 

If you create more transactions for this job, and the unions differ, you must change the Union field in the Edit Payroll 
Fields for every transaction.

Prevailing Wage and Fringe Rate Calculation
You can implement prevailing wage and fringe rates into your payroll calculations, based on the information from the 
government-supplied Davis-Bacon Act (DBA) wage determination sheet. This information is based on the union, county 
and occupational code (fed class code) and includes standard, and overtime rates for wage and fringe benefits. You 
might have several different classes of workers on the same Davis-Bacon job (pipefitters, boilermakers, and so on). Each 
class of employee must be paid their appropriate determination. The actual wages plus employer-funded fringe 
benefits must equal or exceed the prevailing wage plus the prevailing fringe benefit amount equal or greater than the 
prevailing wage plus the fringe benefit amount - on an hourly basis (union or non-union) - as the base rate.

If an employee is due a cash fringe amount, which is paid in cash instead of contributing to the fringe benefit fund, the 
system calculates that amount and adds it to the employee's total hourly wage.

This feature accommodates several prevailing wage and benefit scenarios, including the following:

Prevailing wage is higher than employee standard wage.
Employee standard wage is higher than prevailing wage.
Prevailing fringe is higher than employee standard fringe.
Employee standard fringe is higher than prevailing fringe.
Prevailing wage is higher than employee standard wage but employee standard fringe is higher than prevailing 
fringe.
Prevailing fringe is higher than employee standard fringe but employee standard wage is higher than prevailing 
wage.

About prevailing feature and rate classes (page 63)
Calculation flow: Pay rate with cash fringe (page 63)

Example scenarios - prevailing wage and benefits (page 65)

An excess in either component (wage or fringe) can offset a shortfall in the other component under the Davis-
Bacon Act.


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EXAMPLE 1: Prevailing wage and fringe are greater than employee standard wage and fringe (page 
65)
EXAMPLE 2: Prevailing wage is greater than employee standard wage; employee fringe is greater 
than prevailing fringe, by a greater difference than the wage difference (page 65)
EXAMPLE 3: Employee wage is greater than prevailing wage; prevailing fringe is greater than 
employee standard fringe (page 65)
EXAMPLE 4: Employee standard wage and fringe are higher than prevailing wage and fringe, 
respectively (page 66)
EXAMPLE 5: Employee standard wage is lower than prevailing wage, but the employee fringe is 
higher than the prevailing fringe (page 66)

Setup (page 67)
Prevailing Wage and Fringe Rate Maintenance window (page 67)
Employee Fringe Maintenance window (page 68)

About prevailing feature and rate classes
If you also set up pay rates that are higher than DBA prevailing wage rates within a federal class code, but separated by 
position code, you can still use the rate class feature to set up rates by position, and the prevailing feature to set up the 
prevailing wage. The system simply takes the higher pay rate. Either way, rate classes are required to take advantage of 
the prevailing wage and fringe features, whether union or non-union.

Calculation flow: Pay rate with cash fringe
The following diagram shows how the system calculates the pay rate involving prevailing wage and fringe amounts. Pay 
rate includes any cash fringe that may be due to the employee.
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Example scenarios - prevailing wage and benefits

This section contains example scenarios to illustrate how prevailing wage and fringe benefits are calculated, including 
cash fringe, if applicable.
The Employee Standard rate in the examples below is the highest rate, taken from one of the following:

Employee (Employee Pay Code Maintenance window)
Employee rate class (Employee Maintenance Codes window)
Job rate class (Job Maintenance window)

EXAMPLE 1: Prevailing wage and fringe are greater than employee standard wage and fringe

In this example, the prevailing wage and fringe rates are higher than the bricklayer's standard wage and fringe. The 
bricklayer will get the prevailing wage of 32.71, plus the difference between the prevailing fringe and his/her standard 
fringe, making a cash fringe of 9.54.

Wage Fringe Cash fringe Total package

Prevailing 32.71 14.54 47.25

Employee Standard 28.50 5.00 33.50

Result: 32.71 5.00 9.54 47.25

Cash fringe = (prevailing wage - employee fringe)

EXAMPLE 2: Prevailing wage is greater than employee standard wage; employee fringe is greater than prevailing 
fringe, by a greater difference than the wage difference

In this example, the prevailing wage for bricklayers is greater than the employee's standard rate for bricklayers. 
However, the employee's fringe benefits are higher than prevailing. Because the difference in fringe is greater than the 
difference in wage (in the example below, $5.21 - $4.21 = $1.00), the employee does not get the prevailing wage, there is 
no cash fringe, and the wage rate is reduced from $32.71 to $31.71. The total package for the employee is $38.25, which 
is equal to the prevailing total package.

Wage Fringe Cash fringe Total package

Prevailing 32.71 4.54 37.25

Employee Standard 28.50 9.75 38.25

Result: 28.50 9.75 none 38.25

EXAMPLE 3: Employee wage is greater than prevailing wage; prevailing fringe is greater than employee standard 
fringe

In this example, the prevailing wage for bricklayers is $25.75 per hour but your company has Bricklayer 1 and Bricklayer 
2, where Bricklayer 1 makes 25.50 per hour and Bricklayer 2 makes 28.00 per hour. (You can set up the different rates 
using a combination of the prevailing feature with the rate class feature to set up the three rates). In our example, 
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Bricklayer 2 is used, and since the employee rate is higher than the rate class rate, $28.00 will be used. The prevailing 
fringe rate is greater than the employee fringe. In this example, the difference in the wages ($2.25) is subtracted from 
the greater difference in fringe ($3.00), giving us a cash fringe of $0.75.

Wage Fringe Cash fringe Total package

Prevailing 25.75 8.00 33.75

Employee Standard 28.00 5.00 33.00

Result: 28.00 5.00 0.75 33.75

Cash fringe = (prevailing fringe - employee fringe)- (employee wage - prevailing wage)

EXAMPLE 4: Employee standard wage and fringe are higher than prevailing wage and fringe, respectively

In this example, the bricklayer's standard wage and fringe are higher than the prevailing wage and fringe, respectively. 
Therefore, the total package for the employee is higher than the prevailing package, and no adjustments are necessary.

Wage Fringe Cash fringe Total package

Prevailing 25.75 5.00 30.75

Employee Standard 28.75 8.00 36.75

Result: 28.75 8.00 none 36.75

EXAMPLE 5: Employee standard wage is lower than prevailing wage, but the employee fringe is higher than the 
prevailing fringe

In this example, the prevailing wage is $1.00 higher than the employee standard wage, and the employee fringe is $1.00 
higher than the prevailing fringe. Therefore, the employee will not get the prevailing wage of $34.00 but instead, the 
standard rate of $33.00 (34-1). There is no cash fringe and the total package is $39.00.

Wage Fringe Cash fringe Total package

Prevailing 34.00 5.00 39.00

Employee Standard 33.00 6.00 39.00

Result: 33.00 6.00 (none) 39.00
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Setup
Setting up the prevailing wage and benefits feature involves the following windows: Employee Fringe Maintenance, 
Prevailing Wage and Fringe Rate, Rate Class Codes, and Rate Class Detail. Information on the rate class windows 
appears in the Job Cost User Manual. Make sure to set up rate class codes and detail prior to setting up prevailing wage 
and fringe rates.

Prevailing Wage and Fringe Rate Maintenance window

This window is used to enter wage rate and fringe rate information from the government-supplied wage determination 
sheet. Information is based on the union, county and Standard Occupational Code (Fed Class Code). Fringe rate is an 
hourly accumulation of all the fringe benefits paid to a typical employee in a classification (union or non-
union). Microsoft Dynamics GP > Tools > Setup > Job Cost > Payroll Setup > Prevailing Wage and Fringe Rate.

Rate Class
Select the rate class for which you will be entering wage and fringe rates.
Union Code
This can be any union; it does not have to be assigned to the selected rate class in the Rate Class Detail window. 
This field is NOT required for non-union contractors.
Start Date
Enter a starting date for entering wage and fringe rates in this window. The default is the user date.
Filter Date
Use this field to filter the wage/fringe rate entries that appear in the window. Wage/fringe rate entries appear 
only if this Filter Date falls within the start and end dates of the entry. If there are multiple entries (rows) for the 
same federal classification, but with different start dates, only the most recent entry will appear, assuming the 
Filter Date falls within the date range of the entry.
Federal Classification
Sometimes referred to as the Standard Occupational Code.
Rates (straight time, overtime, and double time)
Enter the wage rate for straight time, as supplied on the wage determination sheet. The overtime and double 
time are calculated automatically; you can change these amounts, if necessary.
Fringes (straight time, overtime, and double time)
Enter the fringe rates for straight time, overtime, and double time - as supplied on the wage determination 
sheet. This will be an accumulated amount of several benefit categories. The default for overtime and double 
time is the same as straight time, however, you can override these defaults.
Start Date
The date that the wages for this federal classification code takes effect for this employee.
End Date
The system automatically fills in an end date as soon as you create a subsequent entry for the same federal 
classification code with a different start date (you cannot enter a date manually). For example, if wages for a fed 
code go into effect on 1/10/2010, but will increase on 6/1/2010, as soon as you enter the wage line for 6/1/2010, 
the End Date for the previous entry will be set to a day before, in this case, 5/30/2010.

Entries are saved as soon as you enter data into a field. To delete a row of data, right-click and select Delete 
Row. Also, if the Filter Date does not fall completely within the start and end date of the new entry, the entry 
will disappear from view as soon as you tab to the next line. The line is saved, but won't appear until you 
change the Filter Date.


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Employee Fringe Maintenance window

This window is used to enter and manage fringe benefits paid to each employee, including a start (effective) date. The 
standard benefits entered in this window are compared to prevailing fringe benefits, based on the information from the 
government-supplied Davis-Bacon Act (DBA) wage determination sheet. Microsoft Dynamics GP > Tools > Setup > Job 
Cost > Payroll Setup> Employee Fringe

Employee ID
This employee must be set up in the Employee Maintenance Code window in Job Cost.
Name
Fills automatically based on employee ID.
Start Date
Enter a starting date for entering fringe benefits. If no date is entered, today's date is used.
Filter Date
Use this field to filter the fringe rates that appear in the window. Fringe benefits appear only if this Filter Date 
falls within the start and end dates of the benefit.
Benefit
You can select existing benefits, one by one, using the lookup (same lookup accessed through the Payroll 
module) - OR - you can create one benefit that is an accumulation of the individual benefits for this employee. 
You can give your own name to this new benefit; it does not have to be an existing benefit name. If you select 
benefits individually, the system will add up the total automatically. If you already know the total benefit 
amount for this employee, you can create one new benefit name and enter the total in one line.
Start Date
The date that the benefit takes effect for this employee.
End Date
The system automatically fills in an end date as soon as you create a subsequent entry for the same benefit code 
with a different start date (you cannot enter a date manually). For example, if benefit code H&W goes into effect 
on 1/10/2010, and will increase on 6/1/2010, as soon as you enter the benefit line for 6/1/2010, the End Date for 
the previous entry will be set to a day before, in this case, 5/30/2010.
Fringe (straight time, over time, and double time)
Enter the fringe rates for straight time, overtime, and double time - as supplied on the wage determination 
sheet. This can be an accumulated amount of several benefit categories (see Benefit above).

Labeling Job Cost User-Defined Fields
You can label numerous user-defined fields in many Job Cost windows. You can save the defaults or change the names, 
as necessary. If you make changes, select File > Print to print a report before saving. This provides you a copy of the 
original settings.

Job Maintenance user-defined fields (page 69)
Change Orders user-defined fields (page 69)
Change Order Status user-defined fields (page 69)

If you want the correct prevailing wage amount to default into Time Card Entry, you must set up at least one 
default benefit in this window, even if the fringe amount is zero.



Entries are saved as soon as you enter data into a field. To delete a row of data, right-click in the row and select 
Delete Row. Also, if the Filter Date does not fall completely within the start and end date of the new entry, the 
entry will disappear from view as soon as you tab to the next line. The line is saved, but won't appear until you 
change the Filter Date.


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Invoice Styles user-defined fields (page 69)
Subcontractor/Vendor user-defined fields (page 70)
Standard Purchase Order user-defined fields (page 70)
Job User-Defined user-defined fields (page 70)

Job Maintenance user-defined fields
Select Microsoft Dynamics GP > Tools > Setup > Job Cost > User-Defined Label Setup > Job Maintenance. The 
default user-defined fields in the Job Maintenance window appear.
Change the names and select Save.

Change Orders user-defined fields
Select Microsoft Dynamics GP > Tools > Setup > Job Cost > User-Defined Label Setup > Change Order Entry. The 
default user-defined fields in the Change Orders window appear.
Change the names and select Save.

Change Order Status user-defined fields
Select Microsoft Dynamics GP > Tools > Setup > Job Cost > User-Defined Label Setup > Change Order Status. The 
default user-defined descriptions in the Change Order window appear. These descriptions will appear in the 
Status drop-down list in the Change Orders window.
Change the names. If you modify change order reports using Report Writer, the internal name is used, not the 
new description you assign in this window.
Select Save.

Invoice Styles user-defined fields
Job Cost provides nine document styles for printing customer invoices. You can change the default invoice names. For 
example, if you use the Text Invoice style for downpayment invoices, you could name the style "Downpayments."

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > User-Defined Label Setup > Invoice Styles. The default 
invoice names appear. The internal name for each style appears in the right column. If you modify reports using 
Report Writer, you must use the internal name, not the new description you assign in this window. 

Accept the defaults or enter a new description for each invoice style. When you print a Job Cost invoice, the 
names you enter appear on the Invoice Reports drop-down menu.
Select Save. 

You must open the Invoice Style Setup window and save the displayed information, even if you do not 
plan to change default invoice names.



If you select to modify any of the invoices in Report Writer, you must modify each invoice three times: 
unposted invoices, posted invoices, and history. If you need assistance, call WennSoft Support.


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Subcontractor/Vendor user-defined fields
Select Microsoft Dynamics GP > Tools > Setup > Job Cost > User-Defined Label Setup > Vendors. The default user-
defined fields in the Subcontractors Maintenance window appear.
Change the names and select Save.

Standard Purchase Order user-defined fields
Select Microsoft Dynamics GP > Tools > Setup > Job Cost > User-Defined Label Setup > PO Standard Text to open the 
Standard Text Entry window.
Enter a PO text ID and enter the text to display on the purchase order. You can define multiple purchase order 
standard text entries.
Select Save.

Job User-Defined user-defined fields 
Select Microsoft Dynamics GP > Tools > Setup > Job Cost > User-Defined Label Setup > Job User-Defined.
Label the third and fourth fields in the upper portion. The fields have attached lookup windows that open the 
Microsoft Dynamics GP Employee lookup list. You could label these fields to display an additional project 
manager, engineer, or other employee title.
Label the remaining fields. The format of the fields is as follows:

16 text fields
Two currency fields
Two date fields
Two checkbox fields
Ten active user-defined fields. Active user-defined fields are customizable user-defined fields. They can 
be defined to return various forms of data in read-only format. Unlike other user-defined fields, users 
don't enter data in active user-defined fields. You can select which active user-defined fields are visible by 
marking the Visible checkbox next to each field. Contact WennSoft Sales for assistance with 
programming the active user-defined fields.

Select Save.

Setting up and Using Document Management in Job Cost
The Document Management feature allows users to attach bitmap (.BMP) files to records. The bitmap images can be 
saved with the record and viewed by choosing the attached image button. If the record does not have documents 
attached, the button shows a paper clip. When documents are attached, the button shows a paper clip attached to a 
piece of paper.

With the Advanced Document Management feature, you can attach numerous file formats 
(e.g., .DOC, .BMP, .XLS, .TIF, .WAV). See Advanced document management feature.

The following table lists all Service Management windows and fields with attached image buttons.
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Service Management Job Cost

Window Field(s) Window Field(s)

Customer Customer ID Job Maintenance Job Number
Project Number

Location Customer 
Address ID

Job Status Job

Maintenance Contract Customer 
Location 
Contract Number

Project Status Project Number

Equipment Location 
Equipment ID 
Equipment Type 
Model Number 
Sublocation ID

Subcontractors 
Maintenance

Job
Job Vendor

Service Call Customer 
Location 
Service Call ID

Subcontractor Dates Items

Equipment Type Setup Equipment Type 
Equipment Model 
Number

Job History Job

Contract Quote Customer 
Location 
Quote Number

Job Cost Codes Setup Job
Cost Code

Service Call Quote Service Call ID Cost Codes Details Job
Cost Code

Master Contract Customer Change Orders Job
Change Order

Maintenance Contract 
History

Customer 
Location 
Contract Number

Change Order Zoom Job
Change Order
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Service Management Job Cost

Window Field(s) Window Field(s)

Change Order Cost Code 
Setup

Job
Change Order
Cost Code

Forecast Cost Revision Entry Transaction Number

Setting up document management
Setting up document management involves creating an attachments folder and mapping the attachments folder to the 
server. For information on setting up physically stored Service Management attachments, see Setting up physically 
stored document attachments (page 74).

Step 1: Create an attachments folder
Complete the following steps to create a folder to hold your attachments.

Create a \docs folder under the \Microsoft Dynamics GP folder on the shared server. 

Create the following folders under \docs:

Service Management Job Cost

\customer
\location
\equip
\contract
\calls
\subloc
\equtype
\model
\quote

\job
\project
\changed
\subctr

Step 2: Map the attachments folder to the server
Add the following line to the DEX.INI file on each client workstation:

Before performing this procedure, make sure no one is logged into Microsoft Dynamics GP or Service 
Management or Job Cost.



The attachments folder must be created on the shared Microsoft Dynamics GP server so everyone can 
access the attachments.





3 https://docs.key2act.io/display/1803b05/Advanced+Document+Management+Module
4 https://docs.key2act.io/display/1803b05/Advanced+Document+Management+Module
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WS_DocRoot=H:\GP\docs\ (must end in backslash)
H is a shared mapped drive
GP is the name of the Microsoft Dynamics GP folder on the shared SQL server
docs is a folder in the Microsoft Dynamics GP folder

Step 3: Map the temporary folder location
You must specify a temporary folder to be used when viewing attachments that were copied to the database. Add the 
following line to the DEX.INI file on each client workstation.
Note: This temporary folder is emptied when you log out of the system. Do not use the folder for data storage.

WS_TempDir=C:\temp\ (must end in backslash)
C is the local drive
temp is the name of the folder that will hold the attachments

Using document management

Attaching a document
Choose the attached image button in any field. The Document List window opens.
Choose Add to open the Document Maintenance window.
The Document ID, Customer, and Type fields default from the previous window.
Enter a Description for the file. The description will display in the Document List window. The system date 
displays in the Date field.
The Format field is greyed out as only .bmp files can be attached. With the Advanced Document Management 
feature, you can attach numerous file formats (e.g., .DOC, .BMP, .XLS, .TIF, .WAV). See Advanced Document 
Management Module34.
In the Source Document section:

Internet/Extranet Access 
Allows you to enter a URL of a file that is located online.
Select File
Select this button to located the file you want to attach.
Choose a radio button to determine how the attachment is handled:

Copy File
Saves the file to the directory specified in your pathname setup. The file name is automatically 
generated by Service Management and appears in the non-editable Document ID field in the 
upper portion of the window. The complete filename will contain the appropriate format 
extension.
Attach File
Saves the path to the file. You will use less hard disk space by attaching the file, but risk losing the 
path if the file is ever moved.
Copy to Database
Copying the file to a Microsoft SQL database offers a more secure connection to the documents 
and makes the documents easier to manage. 

https://docs.key2act.io/display/1803b05/Advanced+Document+Management+Module
https://docs.key2act.io/display/1803b05/Advanced+Document+Management+Module
https://docs.key2act.io/display/1803b05/Advanced+Document+Management+Module
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Send Notification
Currently not in use.

Choose Save.
Close the Document Maintenance window to return to the Document List window. Your attachment appears in 
the scrolling window.

Viewing an attached document
Choose the attached image button to open the Document List window.
Select the document in the scrolling window and choose Display to view the attachment.

Editing an attached document
Choose the attached image button to open the Document List window.
Select the document in the scrolling window and choose Display.
Edit the document.
Save the document with a new name by choosing _File > Save As >_ \[new document name\].
Re-attach the document.

Deleting an attached document
Choose the attached image button to open the Document List window.
Select the document in the scrolling window and choose Edit.
In the Document Maintenance window, choose Delete.

Setting up physically stored document attachments
The ability to physically store attachments in a user-defined location has been added to Service Management for a 
select number of attachments. In Service Management, attachments are added by choosing the paper clip icon. This 
method of attaching documents is the same method that was introduced in Microsoft Dynamics GP 2013. MobileTech 
reports are added automatically when generated.

To set up the additional Document Attachment Management Setup window:

Go to Microsoft Dynamics GP > Tools > Setup > Company > Document Attachment Setup.
Mark Allow Document Attachments.
Choose Additional, and then choose:

Service Management Attachments
Enter the file locations the attachments should be saved to for each of the attachment areas.
Equipment Management Attachments
Enter the file locations the attachments should be saved to for each of the attachment areas.

Choose OK.

Copy to Database is the only option available if you are attaching a file when using the 
Web Client. You are also only able to view an attached file if it has been saved to the 
Microsoft SQL database.



For document attachments to be written to a physical file location, WRITE permission must be given to the 
folder(s) where the attachments will be copied to for all users who will be attaching files.


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Creating Labor Rate Groups for Job Cost (optional)
If you are also using Service Management, you can use labor rate groups to bill job customers. Labor rates are billed 
using a special profit type for labor-only cost codes, and are used to establish a billing amount for labor transactions. 
Labor rates can be set up to reflect different billing rates for different pay codes, such as regular time, overtime, or other 
premium rates. Billing rates also reflect different skill levels.

Cost codes with labor rates are created during setup and assigned to payroll transactions by employee. You can create 
labor rates by pay code and position or by pay code, position, and department.

If you have Service Management, you can use labor rates with Microsoft Dynamics GP Payroll, Signature TimeTrack, and 
Signature Job Cost transactions. Jobs must have a contract type of Cost Plus or Cost Plus NTE to use labor rates.

Creating labor rates by pay code and position (page 75)
Creating labor rates by pay code, position, and department (page 76)

Creating labor rates by pay code and position
You create labor rate groups by pay code and position using the Labor Rates window.

Step 1: Save the profit type setup window
You must save the Profit Type Setup window to enable the profit type: 9 - Service Labor Rate Group.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Cost Code Setup > Profit Types.
Select Save.

Step 2: Create labor rates.
Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Cost Code Setup > Labor Rates.
Complete the following fields, as necessary.

Labor Rate Group Name
Enter a labor rate group name.
Position
Use the lookup window. You can use the ALL value to represent all positions.
Pay Code
Pay codes are used to distinguish between labor rates with the same labor group name and position. 
Each labor rate group may have multiple billing amounts for a combination of positions and pay codes. 
For example, a Preferred labor group may have an overtime rate and a regular time rate for technicians, 
supervisors, and helpers. You can use the ALL value to represent all pay codes.
Description
Enter a description. For example, Supervisor - Regular or Supervisor - Overtime would differentiate one 
pay code from another.
Billing Amount
When you enter the payroll transaction, the billing amount will be calculated as the amount entered in 
this field multiplied by the quantity entered in the payroll transaction.
Fixed OH per Hour, OH Percentage
These fields do not apply to Job Cost transactions; they only apply to Service Management. Therefore, 
values entered in these fields will be ignored. Overhead will be calculated using the overhead detail 
codes set up in Job Cost for the position/pay code combination.

Select Save.
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You can delete a labor rate group record by double-clicking a record and choosing Delete twice. You can delete a labor 
rate group only after each record within that group is deleted. After each record is deleted, select Delete again to delete 
the labor rate group.

Step 3: Assign labor rates to cost codes.
You assign labor rate groups to cost codes in the Master Cost Codes Setup window. Only cost codes with a profit type of 
9 can be assigned labor rate groups.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Cost Code Setup > Master Cost Codes.
Select a Cost Code.
In the Profit Type ID field, select 9 - Service Labor Rate Group.
Enter a Labor Rate Group.
Select Save.

Step 4: Assign cost codes to jobs
Cost codes that have a profit type of 9 must be assigned to the appropriate jobs. These jobs must have a contract type 
of Cost Plus or Cost Plus NTE. See Adding Cost Codes to a Job (page 93) for information on assigning cost codes to jobs.

Creating labor rates by pay code, position, and department

Step 1: Save the profit type setup window
You must save the Profit Type Setup window to enable the new profit type: 9 - Service Labor Rate Group.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Cost Code Setup > Profit Types.
Select Save.

Step 2: Select setup options
To use labor rate groups that are based on the department, you must mark the Use department for profit type 9 
service labor rate groups checkbox in the Setup Options window.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Job Cost Setup > Setup Options.
Mark the Use department for profit type 9 service labor rate groups checkbox. 

Select Save.

Step 3: Create labor rates.
Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Cost Code Setup > Labor Rates.
Enter the Labor Rate Group Name.
Enter an Overhead Group. See Setting up Overhead Group Codes (page 53).

We recommend that you do not unmark the checkbox after it has been marked, especially after 
transactions have been posted with the checkbox marked. If you unmark the checkbox, you must set 
up your labor rates again.


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Select the Default button. This will populate the scrolling window with individual records associated with the 
overhead group.
To add a description and billing amount for a record, double-click a row in the scrolling window. The Billing 
Amount field shows the rate charged for a labor group name, specific position, specific department, and 
corresponding pay code. Leave the field blank to create a zero-dollar billing amount.
Save the new labor rate group by choosing Save. You can delete a labor rate group record by double-clicking a 
record and choosing Delete twice. You can delete an entire labor rate group only after each record is deleted. 
After each record is deleted, select Delete again to delete the labor rate group.

Step 4: Assign labor rates to cost codes
You can assign labor rate groups to cost codes in the Master Cost Codes Setup window. Only cost codes with a profit 
type of 9 can be assigned labor rates. See Setting up master cost codes (page 38) for more information.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Cost Code Setup > Master Cost Codes.
Select a Cost Code.
In the Profit Type ID field, select 9 - Service Labor Rate Group.
Enter a Labor Rate Group.
Select Save.

Step 5: Assign cost codes to jobs
Cost codes that have a profit type of 9 must be assigned to the appropriate jobs. These jobs must have a contract type 
of Cost Plus or Cost Plus NTE. See Adding Cost Codes to a Job (page 93) for information on assigning cost codes to jobs.

Using SmartList Objects for Signature Job Cost Products

Using SmartList objects for Signature products
SmartList Builder objects are available for Equipment Management, Job Cost, and Service Management. These objects 
include Go To items for several windows. Some Go To items appear for multiple objects.
SmartList Designer objects are available for Job Cost and Service Management. For information on using SmartList 
Designer, see the Microsoft Dynamics GP 2016 Systems User Guide.

Importing SmartList objects

SmartList Builder
You must own SmartList Builder to use Signature SmartList Builder objects.
You must be logged in as "sa" to import objects.

Select Microsoft Dynamics GP >Tools > SmartList Builder > Import. Select the folder icon and navigate to the 
Signature SmartList Builder Objects folder in your Microsoft Dynamics GP directory.
Select the appropriate XML file and select Open. Then select Import. When the import finishes, a message 
appears indicating the import process has completed. Select OK.
Repeat the steps import additional XML files, as needed.
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SmartList Designer
If you do not own SmartList Builder, use SmartList Designer to create SmartLists by importing the Signature SmartList 
Objects.

Select Microsoft Dynamics GP > SmartList. Select Export/Import and then Import.
Select Add and then navigate to <GP Install folder>\Signature\SmartList Designer Objects. If you have purchased 
SmartList Builder, you will want to import the objects for SmartList Builder. See the previous section for 
information on importing SmartList Builder objects.
Select the appropriate XML file(s) and select Open. Then select Import. When the import finishes, a message 
appears indicating the import process has completed. Select OK.
Repeat the steps to import additional XML files, as needed.
Close the SmartList window and then re-open to complete the import process.

Accessing SmartList objects
You access SmartList objects in the SmartList window. Each object name begins with the word Signature, followed by 
the descriptive name; for example, Signature Service Calls.

Select SmartList.
Scroll down to the objects that begin with Signature. Select an object to display the records for that object. 
Records appear in the right pane of the window.
To select a Go To item, select a record for that object, and select the Go To... button. Select an item from the Go 
To menu. You can also double-click a record to display the default Go To item, which is the first item in the Go To 
menu.

For information on using the SmartList window, see the Microsoft Dynamics GP documentation.

Modifying SmartList Builder objects
Any modifications that you make to one of the imported SmartList templates will be lost if you re-import SmartList 
Builder objects. Before you modify a template, we recommend duplicating the SmartList and making changes to the 
copy.

Select Microsoft Dynamics GP > Tools > SmartList Builder > SmartList Builder.
Use the lookup button to select the SmartList ID of the object you would like to duplicate. The Equipment 
Management SmartList Builder objects that you imported are identified with _S_EMS_{_}.
Select Options > Duplicate....
Select SmartList as the New List Type. You can also duplicate the template into Excel Report Builder; see 
Creating a SmartList Object Excel Report5 for details.
Enter a New List ID and New List Name, and select Duplicate.
The new SmartList opens and can be edited in the SmartList Builder window. We recommend modifying this 
copy, as any changes that you make to the original template will be lost if you need to re-import SmartList 
Builder objects.

If double-clicking a record does not display a window, select SmartList > Options to open the Options window. 
In the Category drop-down list, select the object that is currently highlighted in the SmartList window, then 
select OK. In the SmartList window, select the Refresh button, then double-click a record. The window for the 
default Go To item should appear. Double-clicking will now work for all objects.



https://docs.key2act.io/display/Signature2018R4/Creating+a+SmartList+Object+Excel+Report
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Refer to the SmartList Builder (with Excel Report Builder) user documentation for information on editing SmartList 
Builder objects.

Creating a SmartList Object Excel Report
You can create Excel Reports from the SmartList objects that you imported.

Select Microsoft Dynamics GP > Tools > SmartList Builder > SmartList Builder.
Use the lookup button to select the SmartList ID of the object you would like to duplicate. The Signature 
SmartList Builder objects that you imported are identified with S_ for Service Management or Job Cost and 
EMS_ for Equipment Management.
Select Options > Duplicate....
Select Excel Report as the New List Type.
Enter a New List ID and New List Name for the Excel Report, and select Duplicate.
The new report opens in Excel Report Builder, where you can modify the Excel Report. Refer to the SmartList 
Builder (with Excel Report Builder) user documentation for more details.

Preparing Go To items for use in the SmartList window
Select Microsoft Dynamics GP > Tools > SmartList Builder > SmartList Builder. Select the lookup button in the 
SmartList ID field and complete the following steps for each Signature object displayed in the list:
Highlight the Signature object in the list and click Select.
Select the Go To... button. All available Go To locations display. Here you can Add, Edit, or Remove Go To items. 
When you are finished, Select OK.
In the SmartList Builder window, select Save. When the information has saved, the window will clear.
When you have completed these steps for each object in the list, close the SmartList Builder window. Open the 
SmartList window under Microsoft Dynamics GP > SmartList. The following message will appear: SmartList 
Builder has detected changes to be made. Do you want to make these changes now? Select Yes. The update will 
take a few moments.

When the update completes, the SmartList window will open. You are now ready to use the Signature SmartLists and 
Go To items.

Signature Objects and Go To items reference
The following Signature objects and Go To items are available for use in SmartList.

Service Management

Object Go To items

Signature Service Calls Service Call, Service Manager, Customer, Location, Contracts

Signature Service Customer Locations Service Manager, Service Call History, Equipment Summary, 
Customer, Location

Signature Service Equipment Equipment, Contract, Service Manager, Customer, Location
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Object Go To items

Signature Service Invoice History Invoice, Service Call, Service Manager, Customer, Location

Signature Service Invoice Open Invoice, Service Call, Service Manager, Customer, Location

Signature Service Maintenance Contracts Contract, Contract Coverage, Revenue/Costs, Service 
Manager, Customer, Location

Job Cost

Object Go To items

Signature Job Billings Invoice Zoom, Job Status, Billed Position, Billing Inquiry

Signature Job Cost Codes Cost Code, Cost Code Setup, Cost Code Transactions, Cost Code 
Summary, Job Status, Job Maintenance

Signature Job Subcontractors Vendor Status, Job Status, Job Maintenance, Billed Position, 
Master Vendor Dates, Master Subcontractor, Subcontractor Status

Signature Job Transactions Job Cost Transaction Zoom, Cost Code Summary, Job Status, Job 
Maintenance

Signature Jobs Job Status, Job Change Orders, Billed Position, Billing Inquiry, 
Project Status, Job Maintenance

Advanced Document Management Module for Job Cost
The optional Advanced Document Management module allows users to attach files of various formats including four-
character file extensions (e.g., .DOC, .BMP, .XLS, .TIF, .WAV) to Service Management Job Cost records. In addition, you 
can link to Microsoft Office SharePoint documents. Users do this by copying and pasting the link to a SharePoint 
document within the attachment. Attachments can be saved with the record and viewed using the attached image icon. 
If a record does not have documents attached, the icon displays a paperclip. When documents are attached, the icon 
displays a paperclip attached to a piece of paper.

The Advanced Document Management module is optional. For more information, contact WennSoft Sales.

Setting up Advanced Document Management (page 82)
Create an attachments folder (page 82)
Map the attachments folder to the server (page 83)
Map the temporary folder location (page 83)
Update the next document number (optional) (page 83)
Create the pathname to the document-viewing application (page 83)
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Using Advanced Document Management (page 84)
Attaching a document (page 84)
Viewing an attached document (page 84)
Editing an attached document (page 84)
Deleting an attached document (page 85)

The following tables list all windows and fields with attached image buttons.

Service Management Job Cost

Window Field(s) Window Field(s)

Customer Customer ID Job Maintenance Job Number
Project Number

Location Customer 
Address ID

Job Status Job

Maintenance Contract Customer 
Location 
Contract Number

Project Status Project Number

Equipment Location 
Equipment ID 
Equipment Type 
Model Number 
Sublocation ID

Subcontractors 
Maintenance

Job
Job Vendor

Service Call Customer 
Location 
Service Call ID

Subcontractor Dates Items

Equipment Type Setup Equipment Type 
Equipment Model 
Number

Job History Job

Contract Quote Customer 
Location 
Quote Number

Job Cost Codes Setup Job
Cost Code

Service Call Quote Service Call ID Cost Codes Details Job
Cost Code

Master Contract Customer Change Orders Job
Change Order
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Service Management Job Cost

Window Field(s) Window Field(s)

Maintenance Contract 
History

Customer 
Location 
Contract Number

Change Order Zoom Job
Change Order

Change Order Cost Code 
Setup

Job
Change Order
Cost Code

Forecast Cost Revision Entry Transaction Number

Setting up Advanced Document Management
Setting up the Advanced Document Management module involves creating an attachments folder and mapping the 
attachments folder to the server.

Create an attachments folder
Complete the following steps to create a folder to hold your attachments.

Create a \docs folder under the \Microsoft Dynamics GP folder on the shared server. The attachments folder must 
be created on the shared server so everyone can access the attachments.
Create the following folders under \docs:

Service Management Job Cost

\customer
\location
\equip
\contract
\calls
\subloc
\equtype
\model
\quote

\job
\project
\changeOd
\subctr
\costcode
\forecast

Before performing this procedure, make sure no one is logged into Microsoft Dynamics GP or Service 
Management or Job Cost.





83

•
•
•

•
•

1.
2.
3.

4.

Map the attachments folder to the server
Add the following line to the DEX.INI file on each client workstation:
WS_DocRoot=H:\GP\docs\  (must end in backslash)

where H is a shared mapped drive
where GP is the name of the Microsoft Dynamics GP folder on the shared SQL server
where docs is a folder in the Microsoft Dynamics GP folder

Map the temporary folder location
You must specify a temporary folder to be used when viewing attachments that were copied to the database.

Add the following line to the DEX.INI file on each client workstation:

WS_TempDir=C:\temp\  (must end in backslash)

where C is the local drive
where temp is the name of the folder that will hold the attachments

Update the next document number (optional)
If you have multiple companies that are using document attachments, the "Copy File" method saves attachments for all 
companies to the same shared location. You will receive an error when saving an attachment if the next document 
number that defaults has already been used by another company.

You can set the next document number to be different for each company by updating the WSDOCS field in the WSSEQ 
table. The maximum document attachment number is 2,147,843,648; determine how you want to divide this number 
based on the number of companies you have.

For example, if you have three companies, you may select to start Company A with the next number of 1, but perform the 
following two SQL actions to update the next number for the other two companies: Company B: UPDATE WSSEQ SET 
WSDOCS = 715947882 Company C: UPDATE WSSEQ SET WSDOCS = 1431895766

Create the pathname to the document-viewing application
If a file extension association was established in Windows Explorer, the system uses that association when viewing 
document files. You must create a pathname to the document-viewing application only if a file extension association 
does not exist in Explorer, or if you want the ability to override the association in Explorer.

To create the pathname to the document-viewing application:

Select Microsoft Dynamics GP > Tools > Setup > Service Management > Module Setup > Document Viewers.
Enter a three or four-character document type in the Type field.
In the View Path field, enter the location of the application's executable file. This must be entered in the 
following format: :c:directory/XXXX.exe
Select Save.
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Using Advanced Document Management

Attaching a document
Select the attached image button in any field. The Document List window opens.
Select Add to open the Document Maintenance window.
The Document ID, Customer, Type fields default from the previous window.
Select the format in the Format field if you want to use a file extension association that was set up in the 
Document Viewers window. If the Format field is blank, the system uses the file extension association 
established in Windows Explorer.
Enter a Description for the file. The description will display in the Document List window. 
The system date defaults in the Date field.
In the Source Document section:

Internet/Extranet Access 
Allows you to enter a URL of a file that is located online.
Select File
Select this button to located the file you want to attach.
Select a radio button to determine how the attachment is handled:

Copy File
Saves the file to the directory specified in your pathname setup. The file name is automatically 
generated by Service Management and appears in the non-editable Document ID field in the 
upper portion of the window. The complete filename will contain the appropriate format 
extension.
Attach File
Saves the path to the file. You will use less hard disk space by attaching the file, but risk losing the 
path if the file is ever moved.
Copy to Database
Copying the file to a Microsoft SQL database offers a more secure connection to the documents 
and makes the documents easier to manage. 

Send Notification
Currently not in use.

Select Save.
Close the Document Maintenance window to return to the Document List window. Your attachment appears in 
the scrolling window.

Viewing an attached document
Select the attached image button to open the Document List window.
Select the document in the scrolling window and select Display to view the attachment.

Editing an attached document
Select the attached image button to open the Document List window.

Copy to Database is the only option available if you are attaching a file when using the 
Web Client. You are also only able to view an attached file if it has been saved to the 
Microsoft SQL database.


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Select the document in the scrolling window and select Display.
Edit the document.
Save the document with a new name by choosing _File > Save As >_ \[new document name\].
Re-attach the document.

Deleting an attached document
Select the attached image button to open the Document List window.
Select the document in the scrolling window and select Edit.
In the Document Maintenance window, select Delete.

Job Estimates
If you are using third-party cost estimating software, you can import the estimate information for use in Job Cost. 
Contact WennSoft Sales for information on importing estimates.

Importing estimates
Importing estimates involves the following:

Step 1: Create the import file (page 85)
Step 2: Import the estimates into Job Cost (page 87)
Step 3: Review the imported information in Job Cost (page 87)

Step 1: Create the import file
You can either generate the import text file using third-party software, or you can create it yourself using a text editor 
such as Notepad or Microsoft Excel. The import file must contain a .TXT extension. An import file contains three main 
records: comment, header, and category. Each instance of a record appears as a separate line in the import file.

Sample estimate import file

A description of each record follows:

Comment records
Comment records contain general comments or a description of the import file.

Comment records can appear anywhere in the import file. You can have as many comments as necessary.
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The first character in a comment record must be a semicolon. A sample comment record 
follows: ;Estimate to Job Cost Transfer File

Header record
A header record contains basic information about the job, such as job name and job number.

A header record is required.
The first character or field must be an asterisk. The second must be the job number. A third field 
(optional) is job name.
Data in a field must be enclosed with double quotes. If the field is a numeric or a date, no quotes are 
required.
Each field must be separated by a comma. Two consecutive commas indicate a null (empty) field.
A sample header record follow: "*","IMP001A","Imported Job">

Category records
Category records contain the estimate information that will be imported into Job Cost for each cost code, along 
with other job information.

A category record is required and consists of 12 fields. The first field in a category record is the letter C. 
The first eight fields are required.
If a field contains data, the data must be enclosed with double quotes. If the field is a numeric or a date, 
no quotes are required.
Each field must be separated by a comma. Two consecutive commas indicate a null (empty) field. A 
sample category record follows: "C","1001"," ","EQU",10031996,10.00,900.00

A description of the format for each category field appears in the following:

Field Number Description Required?

1 The letter C (quotes needed) Yes

2 Cost code format without dashes (quotes needed) 
Cost codes must exist as master cost codes in the 
Master Cost Codes Setup window.

Yes

3 Null — 17 spaces 
The description from the Master Cost Codes Setup 
window automatically defaults in the Job Cost 
Codes Setup window during the import. You do not 
have to include it in your import file.

Yes

4 One of the following cost code elements (quotes 
needed): 
LAB, MAT, EQU, SUB, OTH, UD1, UD2, UD3, UD4

Yes

5 Date (no quotes needed) Yes

6 Number of units (no quotes needed) Yes

7 Null (no quotes needed) Yes
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Field Number Description Required?

8 Amount per unit (no quotes needed) Yes

9 Null (no quotes needed) No

10 Null (no quotes needed) No

11 Null (no quotes needed) No

12 Null (no quotes needed) No

Step 2: Import the estimates into Job Cost
During the import process, you will create a new job using the job number specified in the import file.

Select Microsoft Dynamics GP > Tools > Integrate > Job Cost > Estimates.
Select the folder button to locate and select the text file for import and select Next >.
Enter the job record information in the Estimate Import window. See Creating a Job Record (page 88) for more 
information. The Job Number and Description fields come from the import file. The Contract Type is 
automatically set to Fixed Amount and the Billing Type is set to Standard. You can change these defaults.
Select Next> to open the Estimate Warehouse window. The Estimate Warehouse window summarizes the cost 
codes added to the job, including the estimated cost for each code.
Review the Estimate Warehouse window to ensure the cost codes are valid. A Valid label indicates that the cost 
code exists and will import successfully. If all cost codes are valid, proceed to the next step. An Invalid label 
indicates that the cost code does not exist in Job Cost as a master cost code. If at least one cost code is invalid, 
select Cancel to cancel the import and start over. Before you restart the import, add the appropriate cost code(s) 
to the Master Cost Codes Setup window (Microsoft Dynamics GP > Tools > Setup > Job Cost > Cost Code Setup > 
Master Cost Codes).
When all cost codes are valid, select Finish in the Estimate Warehouse window. If the import was successful, a 
message appears telling you that the import was successful, and asking you if you want to import another 
estimate file.
To finish importing files, select No. To continue importing more files, select Yes. The Import Estimates window 
reappears.

Step 3: Review the imported information in Job Cost
To make sure the information that was imported into Job Cost is satisfactory, review the appropriate fields in the Job 
Cost Codes Setup window.

Select Cards > Job Cost > Job.
Select a job, then select the Cost Codes button.
Use the browse buttons to display the costs codes that were included in the import file.
The cost code from the import file defaults in the Cost Code field.
The estimate defaults in the Estimate Amount field and is calculated as number of units (quantity) x amount per 
unit. If any estimate numbers are incorrect, check the import file to make sure the proper field was filled in. Just 
because a cost code was imported successfully doesn't mean the numbers are correct in the Job Cost Code 
Setup window. For example, if you leave field number 6 (amount per unit) blank for a cost code in the import file, 
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the import process will complete successfully, but will enter a default value of 1 in the Estimate Units field in the 
Job Cost Codes Setup window.

Job Maintenance
Use the Job Maintenance window to enter job, customer, contract, billing, and tax information. You also can enter 
information needed to track many of the details associated with a job, including cost codes, subcontractors and 
vendors, revenue codes, and bill codes.

The Subcontractor and Advanced Subcontractor features are optional. Contact WennSoft Sales for more information. 
See Subcontractor feature (page 184) and Advanced subcontractor feature (page 189).

Creating a Job Record
Job records serve as the foundation for Job Cost. You can create records for jobs to track costs, bill clients, and receive 
payments. You can edit jobs, view an existing record, or search for the record by job name or by job number.

Your billing type, which is dependent on contract type, determines the type of job invoices that can be printed. Further, 
certain billing types require that you create bill codes. For more information, see Relationship Between Billing Type, 
Contract Type, and Invoice Type (page 93).

Select Cards > Job Cost > Job.
Complete the following fields, as necessary.

Job Number, Description 
Enter a job number and description.
Project Number 
Projects are used to group related jobs. You can also use project numbers as a sorting option in lookup 
windows and for grouping similar jobs on reports. You can print reports organized by project. This field is 
required if you are using project-level billing.
Division 
You must assign jobs to a division account, even if you don't use the Division posting option (Microsoft 
Dynamics GP > Tools > Setup > Job Cost > Job Cost Setup > Posting Options). If you use the Division posting 
option, all revenue and expense accounts for this job post to the general ledger accounts associated with 
this division. 
You can change the division for a job, though you will receive a warning if you have any transactions 
posted for that job.
Estimator 
Enter the employee ID of the person estimating the project or job.
Project Manager 
Enter the project manager on the job.
Customer, Job Address 
Select the job customer and job address.
Bill To Customer, Bill To Address 
These fields default to the Customer and Job Address. If you are using 3rd party billing, you can select the 
billing customer and location where the bills associated with this job will be sent. The Bill To Address 
defaults to the Customer Maintenance Bill To address.
Contract Number 
This field is informational only.
Contract Type 
Select one of the following from the Contract Type drop-down menu:
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Fixed Amount 
This is a firm bid or guaranteed price for an entire job. The fixed price is the total amount the 
customer will be billed for the original job contract. Choosing this type enables the Functional 
Contract Amount field. Enter the fixed price. You will not be able to edit this amount for an 
existing job record unless you have been granted permission in Job Cost Security Setup.
Cost Plus 
Calculates the contract billing amount per the actual posted cost plus profit defined by the 
assigned cost codes. Cost Plus does not contain a maximum contract amount. Choosing this type 
enables the Current Contract Amount field, which is calculated automatically.
Cost Plus NTE (Not to Exceed) 
Similar to Cost Plus, except that it cannot exceed the maximum contract amount. The contract 
billing amount for the job is less than or equal to the maximum contract amount. We recommend 
using Cost Plus NTE for Cost Plus contract type jobs. Cost Plus NTE allows you to bill more than 
the calculated cost plus profit. Cost Plus contract type jobs do not allow you to bill more than the 
calculated cost plus profit for a specific cost code. Choosing this type enables the Contract 
Maximum field. Enter the maximum contract amount. You can use the Contract Maximum 
expansion button to open the Job Contract Maximum Amount window, showing the change 
orders and change order maximum amounts for Cost Plus NTE contract types.

Billing Type 

In the Billing Type field, select one of the following billing types from the drop-down list:
Standard (default) 
Select Standard if you print simple invoices such as a one-line-item description with a single 
billing amount not applied to individual cost codes. Also, select Standard if you print invoices in 
another application and use Job Cost only to enter invoice information.
User-Defined 
Select User-Defined to define your own bill codes for the selected job and to enter a total billable 
amount for each bill code. User-Defined cannot be used with Cost Plus or Cost Plus NTE contract 
type jobs. When you select User-Defined, the Architect ID field becomes enabled.
Cost Code 
Select Cost Code to automatically duplicate all cost code numbers assigned to the job as potential 
bill codes. When you select Cost Code, the Bill Codes button and Architect ID field are enabled. If 
you selected either Cost Plus or Cost Plus NTE as the contract type, you can select the Cost Code 
billing type to create your bill codes. The billable amount is automatically calculated based on 
posted transactions and the profit type assigned to each cost code.
Transaction Level 
Select Transaction Level to have transaction-level detail print on customer invoices. This billing 
type is for Cost Plus contracts only. Line item descriptions on active customer invoices depend on 
the transaction type, per the following:

If transaction type is: Line item description comes from:

Accounts Payable Description field in the Payable Transaction Entry 
window

You cannot change the billing type for a job after invoices have been created for the job. If you 
are setting up an AIA job and need to print the Application for Payment Schedule report during 
invoice entry, you must use the User-Defined or Cost Code billing type.


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If transaction type is: Line item description comes from:

Inventory Item Description field in the Item Transaction window

SOP Description field in the Item Maintenance window for 
inventory items 
Item Description field in the Sales Transaction Entry 
window for non-inventory items

POP Description field in the Item Maintenance window for 
inventory items 
Vendor Description field in the Purchase Order Entry 
window for non-inventory items

Payroll Cost Code Description field in the Payroll Transaction 
Entry window

Job Cost Reference field in the Job Transaction Entry window

Project Billing 
Select Project Billing when billing for all jobs in the project. To use Project Billing, the project 
number must be entered in the Job Maintenance window.
SOP 
Select SOP when billing for jobs using the Sales Order Processing module. This billing type is for 
Fixed Amount contract types only.
Project Bill Code 
Select Project Bill Code for jobs assigned to a project bill code project. The project number 
entered in the Job Maintenance window must be designated as a project bill code project in the 
Project Maintenance window.
User-Defined 1 & 2
Enter user-defined information.
Tax Exempt Number, Tax Schedule 
Enter tax information. If a tax schedule is assigned to the job customer in Receivables 
Management, that schedule defaults.
Retention Percent 
Enter a retention percentage to be automatically calculated and withheld from invoices.  This field 
is disabled if you are using the following Billing Types: Project Standard Billing, SOP, Project Bill 
Code, Project Trx Level, and Project Allocated Revenue.
Calculate Sales Tax on Billing Amount
If you are using a Retention Percent, mark this checkbox to calculate the sales tax on the Billing 
Amount. If unmarked, the sales tax is based on the subtotal amount (Billing Amount - Retention 
Amount). If you change the Retention Percent to 0, the Calculate Sales Tax on Billing Amount 
checkbox is cleared and disabled. There are currently five states (WA, NV, TX, OH & DE) that 
require that sales taxes on the Job Cost invoices be calculated based on the gross receipts (sales 
amount not reduced by retention).  The Calculate Sales Tax on Billing Amount checkbox displays 
on the Job Invoice Entry window as well, with the checkbox defaulting based on the Job from the 
Job Maintenance window. Users can mark/unmark the checkbox in the Job Invoice Entry window. 
Taxes are recalculated when the checkbox is marked/unmarked. This checkbox is disabled for 
these Billing Types: SOP, Project Bill Code, Project Trx Level, Project Allocated Revenue. 
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Overhead Amount 
Overhead fields are information only. In job payroll transactions, overhead amounts for labor are 
calculated based on the group code, using a flat rate per hour or a percentage of the total labor 
cost.
Currency ID 
Displays the currency ID for the billing customer. This field is only enabled if you are using 
multicurrency and using the Canadian currency ID, the contract type is fixed, and the billing type 
is user-defined.
Architect ID 
Use the lookup to select an architect if there is one assigned to this job. This field is enabled only if 
the billing type is Cost Code or User Defined.
Overhead Labor %, Overhead User-Defined % 
Overhead fields are informational only.
State 
This information should reflect the job location, not where your business is incorporated or where 
the employer lives. This code comes from the State field on job payroll transactions entered using 
the Microsoft Dynamics GP Payroll Transaction Entry window or the TimeTrack Time Card Entry 
window. In job payroll, the state assigned to the job overrides the state assigned to the employee 
(Cards > Payroll > Employee). If the State field is blank for a job, the payroll transaction uses the 
state code assigned to the employee record in Microsoft Dynamics GP Payroll setup.
SUTA State 
This information should reflect the job location, not where your business is incorporated or where 
the employer lives. This code comes from the SUTA State field on job payroll transactions entered 
using the Microsoft Dynamics GP Payroll Transaction Entry window or the TimeTrack Time Card 
Entry window. In job payroll, the SUTA state assigned to the job overrides the SUTA state assigned 
to the employee (Cards > Payroll > Employee). If the SUTA State field is blank for a job, the payroll 
transaction uses the SUTA state code assigned to the employee record in Microsoft Dynamics GP 
Payroll setup.
Local Tax 
This information should reflect the job location, not where your business is incorporated or where 
the employer lives. Use the lookup to select a local tax code. The lookup window contains local 
tax codes defined in the Microsoft Dynamics GP Payroll module. The local tax code entered here 
overrides the corresponding tax code assigned to the employee in Microsoft Dynamics GP Payroll.
Rate Class 
Enter a rate class. See Setting up Rate Classes for Union Payroll (page 55).
Scheduled Start Date, Scheduled Completion Date 
Enter the job's start date and completion date, respectively.
Est. % Complete to Date 
Enter the job's estimated percentage of completion. Project managers may use this field to 
measure job performance by comparing the actual percent complete on a cost basis to the 
manager's estimated percent complete. The actual percentage complete displays, calculated 
automatically by comparing the job's total posted costs to total forecasted costs.
Calc. % Complete to Date 
Filled in automatically based on the percentage of the forecasted costs or labor that has been 
posted. For example, if you are calculating POC based on costs and the posted costs are $60 and 
the forecasted costs are $100, the number in this field would be 60. Posted units and forecasted 
units are displayed in the Job Status window (Inquiry > Job Cost > Job Status).
Job Created Date 
Displays the date that the job was created.

Mark any appropriate checkbox(es):
Inactive 
Mark this checkbox if you want to prevent the posting of transactions to this job. Inactive jobs are 
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included in the percentage-of-completion journal entry. If the job cannot be inactivated, and you have 
SSRS installed, you will be prompted to print the Job Closing Preparation report (page 92). 

Exclude from:
RPO 
Mark this checkbox if you are using the Revenue Performance Obligations (RPO) method to 
recognize revenue to exclude jobs from the RPO calculation. See Working with Job Revenue 
Performance Obligations (page 96) for more information.
POC 
Mark this checkbox if you are using the Percentage-of-Completion revenue recognition method, 
and you are creating a fixed asset, warranty, or template job that you do not want included in the 
POC calculation. Once costs or billings are posted to the job, you cannot change this option. We 
strongly recommend using a separate division for jobs that are excluded from POC. Refer 
to Excluding a Job from POC or RPO Calculation (page 106) before marking this checkbox.

Include in Loss Recognition 
Mark this checkbox to include the job in the loss recognition journal entry for the current period. This 
checkbox is visible if the Use Job and Project Loss Recognition posting option is marked. For more 
information, see Loss Recognition (page 110).
Certified Payroll 
Mark this checkbox if the job involves certified payroll. See Certified Payroll6 for more information.
Reimbursable 
Mark if this job is reimbursable.

Select Print to print the following reports:
JC Job Report 
This report displays the job information entered in the Job Maintenance window.
Job Closing Preparation Report 
This SSRS report lists all reasons why a job cannot be closed.  This report does not include Contract 
Agreements. This report option is displayed if SSRS is installed.

Entering Job User-Defined Information
Select Cards > Job Cost > Job.
Select a Job Number, then select the User-Defined button.
Enter a Job Type, P.O. Number, and Asset ID for the job. The P.O. Number entered in the Job User-Defined 
window will be the default entry in the PO Number field of the Job Invoice Entry window for that job.
Complete the user-defined fields for the job.
Select Save. 

Select the printer button to print the Job User-Defined report, listing all the information from the Job User-
Defined window.

Appointments cannot add or update appointments if the job is marked as inactive.

If you select the Clear button in the Job User-Defined window, only the changes you've made since the 
window was last saved will be cleared.



https://docs.key2act.io/display/Signature2018R4/Certified+Payroll
https://docs.key2act.io/display/Signature2018R4/Certified+Payroll
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Relationship Between Billing Type, Contract Type, and Invoice Type
Your billing type, which is dependent on contract type, determines the type of job invoices that can be printed. Further, 
certain billing types require that you create bill codes.

Billing Type Contract Type Job Invoice Type Bill Codes Required

Standard All types Standard Types* No

User-Defined Fixed Contract AIA Billing 
Detailed Billing 
Standard Types**

Yes

Cost Code All types AIA Billing 
Detailed Billing 
Standard Types**

Yes

Transaction Level Cost Plus Transaction Level 
Trx Level by Labor 
Standard Types**

No

Project Billing All types Project Level No

SOP Fixed Contract Microsoft Dynamics GP invoice 
types are used***

No

Project Bill Code All types Project Level Yes

*Standard job invoice types include the following types of reports: Graphic Invoice, Text Invoice, Cost Elements, 
Graphics Inv 2, Text Inv 2, and Tax Detail Inv.

**If you print a standard job invoice type for a job with a Cost Code, User-Defined, or Transaction Level billing type, the 
invoice will contain a dollar amount, but will not contain detailed information. To provide your customer with a 
detailed invoice, you should use the appropriate invoice type.

***The SOP billing type is used to bill jobs using Sales Order Processing; therefore, invoices are created in Microsoft 
Dynamics GP.

Adding Cost Codes to a Job
Cost codes define the cost category and cost amount for a job. You add cost codes in the Job Cost Codes Setup 
window. You can break a job into phases, steps, details, and even sub details. A step can be broken into categories or 
cost elements such as labor, material, equipment, subcontractors, and miscellaneous costs.

When using the Copy button in the Job Maintenance window to copy a job record, user-defined field 
information will not be copied to the new job.


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In the example above, the General Conditions phase relates to the initial acquisition of land for a home or commercial 
building job. The phase is broken into the cost of land, cleanup, architectural fees, etc. Job detail is tracked for two of 
the steps. Each phase, step, detail, and sub detail of a job can be assigned an alphanumeric code or cost code for 
tracking purposes.

Select Cards > Job Cost > Job.
Select a Job, then select the Cost Codes button.
Use the lookup to select a Cost Element Type. Entering a cost element type causes the lookup window for the 
Cost Code field to include only codes for that cost element. The default is 1 for Labor.
Use the Add Cost Codes button to enter an existing master cost code or enter a new cost code and description. 

Enter the Profit Type ID and Profit Amount. These fields will be disabled if the contract type is Fixed Amount. 
The profit amount can be a flat dollar amount or percentage. Choices depend on the contract type of the job. 
The default is 2 - None. Profit type 9 is available when the cost element type is Labor. See Description of profit 
types (page 37).

If the contract type is: Profit type choices are:

Fixed Amount 2 - None

The lookup for the Cost Code field applies only to cost codes that have already been added to this job. 
It is not a lookup for the Master Cost Codes Setup window. The Posted To checkbox is marked if 
transactions have been posted for the cost code and job. The Added by CO checkbox is marked if the 
cost code was added through a change order.


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If the contract type is: Profit type choices are:

Cost Plus or Cost Plus NTE 1- Non-Billable 
2 - None 
3 - Percent Margin 
4 - Percent of Cost 
5 - Per Unit Amount 
6 - Total Dollar Amount 
7 - Flat Rate per Cost Code 
8 - Flat Rate per Unit 
9 - Service Labor Rate Group

Complete the remaining fields, as necessary.
Service Labor Rate Group
This field is enabled only if the profit type is 9 - Service Labor Rate Group. See Creating labor rate groups 
(optional) (page 75).
Account Number
If you're using the Division posting option, an account number automatically appears. If you're using the 
Cost Codes posting option, you must enter an account number.
Project Manager
The name of the project manager comes from the Employee Maintenance window.
Estimate Units
If you are using the Estimate Cost by Period posting option, this field is disabled.
Estimate Amount / Unit
Enter the estimate amount per unit of measure. If you are using the Estimate Cost by Period posting 
option, this field is disabled.
Estimate Amount
This amount calculates based on what you entered in the Estimate Units and Estimate Amount/Unit 
fields. If you are using the Estimate Cost by Period posting option, you must select the "+/-" button to 
enter an estimate. See Revising estimated costs (page 96).
Estimate Measure
Use the lookup to select an estimate measure type, for example, EA (each) and HR (hours).
Estimate Measure Name
After completing the estimate measure field, the Estimate Measure Name populates from the description 
in the Measure Setup window. This field cannot be changed.
Track Production Qty.
Mark this checkbox to enable the Production Est Quantity and Production Measure fields.
Production Est Qty., Production Measure
Enter production information. These fields are used to track the amount of work and material used for 
this cost code.
Production Qty. / Unit, Production Measure Name
These fields are system-generated, based on the production information you entered above.
Start Date, Completion Date
Enter a start date and completion date.
Workers Comp.
Use the lookup to select a workers' compensation code.
Revenue Code
Displays the revenue code the cost code is assigned to. For more information, see Assigning Cost Codes 
to Revenue Codes (page 100).
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Transaction Type
This field is enabled only for cost elements other than Labor. Select a transaction type from the drop-
down list; choices include ALL, Inventory Item, Vendor ID, and Purchase Order.

If you select Vendor ID, you can enter a vendor to link the Cost Code to a subcontractor. See 
Adding subcontractors to a job record (page 185).
If you select Inventory Item, an Item Number field appears, allowing you to enter an inventory 
item. If you select Purchase Order, a PO Number field appears, allowing you to enter a purchase 
order number. These two fields are informational only and do not affect the job.

Inactive
Mark this checkbox to inactivate the cost code. Inactivating a cost code prevents additional costs from 
being posted. This is useful when the phase of a job that is associated with the cost code is finished. You 
cannot enter the following transactions for an inactive cost code: inventory, sales order processing, 
purchase order processing, payables, Microsoft Dynamics GP Payroll, Job Cost (except production and 
unit adjustment), and TimeTrack. You can post a receivings transaction only if the cost code was marked 
as inactive after the purchase order transaction was posted and before the receivings transaction is 
posted. You can also enter production unit transactions and job transaction unit adjustments for inactive 
cost codes.

Select Save.
To print the Job Cost Codes setup list, select File > Print or select the printer button.

Revising Estimated Costs
You can enter estimate cost revisions and cost estimates based on fiscal periods for cost codes on a job. If a change 
order has been created for the cost code, you cannot edit the cost code estimate. You can revise estimated costs in flat 
dollar amounts or in units. If you import estimates from an integrated software application or enter them in the Job 
Cost Code Setup window, you may need to revise the estimates. Revising an estimate on a cost code overrides the 
original estimate assigned to the cost code unless you are using the Estimate Cost by Period posting option.

Select Cards > Job Cost > Job.
Select a Job, then select the Cost Codes button.
Select the +/- button in the Estimate Amount field.
Enter the Cost Code.
Enter the number of Units and an Amount/Unit. If you entered a single Unit ("1"), the Amount/Unit is a flat 
dollar amount that will default in the Amount field. If you entered multiple units, the total estimated cost code 
amount calculates automatically as the Amount.
Enter a Description.
Select Post. The estimate information displays in the scrolling field. The Transaction Total field appears if you 
have the Estimate Cost by Period checkbox marked in the Posting Options window.
To print the Estimate Revision List report, select File > Print. Close the Estimate Cost Revision Entry window.
Select Save. The Job Cost Codes Setup window reappears. After you post an estimate revision, the amount 
appears in the Estimate Amount field in the Job Cost Codes Setup window. You can zoom on this amount to 
display the Cost Code Estimate Zoom window, which summarizes the estimate information entered.

Working with Job Revenue Performance Obligations
The Revenue Performance Obligation (RPO) revenue recognition method is used by companies that either enter into 
contracts with customers to transfer goods or services or enters into contract for the transfer of nonfinancial assets 
unless those contracts are within the scope of other standards (for example: leases and insurance contracts). Revenue 

When you enter an estimate revision and are using the Estimate Cost by Period posting option, make sure the 
posting date falls within the period you want the transaction to affect.


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codes are assigned at the job level. Under the new Accounting Standards Update (ASU) 2014-09, Revenue from Contracts 
with Customers (Topic 606). For more information, see http://www.fasb.org. In our Help files and Job Cost user guide, 
the acronym RPO refers to revenue codes on jobs.

Setting up and using revenue codes (page 97)
Viewing Revenue Code inquiry windows (page 97)
Closing & Routines (page 97)
New or updated reports (page 97)

Dexterity Reports (page 97)
SSRS Reports (page 98)

Setting up and using revenue codes
Complete the Posting Options setup (page 23).
Create a job record (page 88).
Add the cost codes to the job (page 93).
Create revenue codes (page 98).
Assign cost codes to revenue codes (page 100).
Editing Revenue Performance Obligations (page 167)
New rules for creating change orders (page 177)
Adding Change Order Revenue Codes (page 179)
Mass Updating Revenue Code Percentages (page 165)

Viewing Revenue Code inquiry windows
Viewing Revenue Code Status (page 172)
Viewing Billed Position (page 172)
Viewing Revenue Recognition Summary (page 172)
Viewing revenue code history (page 239)

Closing & Routines
Closing a Job (page 222)
Closing a Period or Month (page 235)
Creating Job Revenue Journal Entries (page 163)

New or updated reports
These are either new or existing reports that base the Contract Earned and Over/(Under Billed) calculations on the 
revenue code revisions for the selected period. The new calculations are used if the Revenue Recognition method is set 
to Revenue Performance Obligations in Posting Setup. See Choosing Posting Options (page 23) for more information.

Dexterity Reports
Revenue Edit List - new report that is similar to the JC POC Edit List

For revenue to be recognized on a Performance Obligation Contract, the Original Transaction Price on the Job 
Revenue Codes window must be populated the same month.



http://www.fasb.org
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Revenue Entry List - new report that is similar to the JC POC Entry List
JC Backlog
JC Backlog by Division
JC Backlog Sort By
JC Fiscal Period Costs by Division
JC Fiscal Period Costs by PM
JC Fiscal Period Costs by Project
JC Job Billing
JC Job Billing Division
JC Job Billing PM
JC Job Billing Project
JC Job Schedule by Division
JC Job Schedule Sort By
JC Over/Under Billings
JC Over/Under Billings by Division
JC Over/Under Billings Sort By
JC Profit and Loss
JC Profit and Loss by Division
JC Profit and Loss by PM
JC Profit and Loss by Project
JC Profit and Loss Summary by PM
JC Profit and Loss Summary by Project
JC Profit and Loss Summary by Division
JC Job Status
Job Schedule
JC P & L Sort By
JC Contracts Closed (Current Year - Contracts Closed) 

SSRS Reports
Job RPO Profit and Loss7

Creating Revenue Codes
The Revenue Code Setup window is similar to the Bill Code window functions. Revenue codes are assigned at the job 
level. As you create new Revenue Codes for jobs, you can see the total amount of the revenue codes compared to the 
job's Expected Contract amount so that you know the contract amount yet to be distributed to Revenue Codes. You can 
create one revenue code for each job or you can have multiple revenue codes on the same job.

The Total Revenue code transaction price amounts for a job cannot exceed the job's Expected Contract amount.
To track costs only, you can create a $0.00 revenue code. An example would be warranty costs. The costs from 
the cost codes assigned to that revenue code will be included in the revenue GL entry after the revenue code has 
been marked 100% complete.
A job cannot be closed if there are cost codes on the job that have yet to be assigned to a revenue code.

Updated JC Contract Closed which is will now be getting amounts from JC30001. This report will no 
longer use the global script above modified to calculate Contract Earned. The Contract Earned field in 
this report will now look at Billed Amount TTD in JC30001 to report Contract Earned.



https://docs.key2act.io/display/Signature2018R4/Job+RPO+Profit+and+Loss
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For revenue to be recognized on a Performance Obligation Contract, the Original Transaction Price on the Job 
Revenue Codes window must be populated the same month.

Creating a revenue code
On the Job Maintenance window, select Revenue Code. 

Complete the following fields, as needed:
Job
Displays the job information.
Included on CO
Mark to include the Revenue Code on the change order.
Revenue Code
Enter the Revenue Code. This field has a string length of 26. You can also add a note to this revenue code.
Description
Enter a description for the Revenue Code.
Revenue Type
Select the Revenue Type.

Point in Time
Revenue can only be recognized once (100% complete).
Over Time
Revenue can be recognized incrementally over a period of time.

Scheduled Start/Completion Date
Enter or select the Scheduled Start and Completion Dates.
Actual Start/Completion Date
Enter the Actual Start and Completion dates.
Original Transaction Price
Enter the original transaction price. 

Fixed Amount jobs
The Original Transaction Price is entered when the Revenue Code is created. Once saved, the 
amount cannot be edited unless you enter the password used to edit a job's contract amount. A 
Fixed Amount job can have multiple Revenue Codes assigned.
Cost Plus jobs
This field is not editable. The Original Transaction Price amount increases as costs and/or units 
are posted to the cost codes assigned to the Revenue Code based on the Profit Types and Profit 
Amounts on the cost codes. A Cost Plus job can only have one Revenue Code assigned. The cost 
codes on the job are auto-assigned to the one Revenue Code.
Cost Plus NTE jobs
This field is not editable. The Original Transaction Price amount increases as costs and/or units 
are posted to the cost codes assigned to the Revenue Code based on the Profit Types and Profit 
Amounts on the cost codes. The Expected Contract amounts do not exceed the NTE amount. A 
Cost Plus NTE job can only have one Revenue Code assigned. The cost codes on the job are auto-
assigned to the one Revenue Code.

Change Order Transaction Price
This amount displays from the Change Order.

The Revenue Code button is disabled if you chose POC Revenue Recognition in Posting Options (page 
23) window.



For revenue to be recognized on a Performance Obligation Contract, the Original Transaction 
Price on the Job Revenue Codes window must be populated the same month.


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Expected Transaction Price
Displays the total of the Original Transaction Price + Change Order Transaction Price. 

Deleting a Revenue Code
A revenue code can be deleted unless revenue is recognized for that Revenue Code or the code exists on a posted 
change order. Deleting a revenue code removes the link to any assigned cost codes. Those cost costs would need to be 
assigned to a different revenue code.

Assigning Cost Codes to Revenue Codes
The Revenue Cost Codes Assignment window is opened from the Job Revenue Codes window by choosing the Assign 
Cost Codes button.
Cards > Job > Revenue Codes button > Assign Cost Codes button

Assigning a cost code or multiple cost codes to a revenue code
Select the cost code in the Unassigned Cost Code section. You can select more than one unassigned cost code by 
using your mouse and using either the CTRL key (to multi-select) or the SHIFT key (to select a range).
Select the right arrow between the two sections to the Assigned Cost Codes section.

Unassigning a cost code or multiple cost codes from a revenue code
Select the cost code(s) in the Assigned Cost Codes section.
Select the left arrow between the sections to move the codes to the Unassigned section.

Conditions for adding/removing cost codes

On Fixed Contract jobs, you cannot add or remove cost codes to a revenue code that is associated with a Cost Plus 
Change Order. Those cost codes must be added in the Change Order Cost Codes window. See Adding Change Order 
Revenue Codes (page 179) for more information.

Adding Subcontractors and/or Vendors to a Job
You can enter information for a job regarding your vendors and subcontractors. The vendor record must exist in 
Microsoft Dynamics GP before it can be added to a Job Cost record. The Subcontractor and Advanced Subcontractor 
features provide additional subcontractor functionality. See Using the subcontractor feature (page 185) or Using the 
advanced subcontractor feature (page 192).

Select Cards > Job Cost > Job.
Select a job, then select the Subs/Vendors button. 

The Expected Transaction Price amount must total the Expected Contract amount for the job.

The Subcontractors Maintenance window contains additional fields for the Subcontractor and 
Advanced Subcontractor features. See Setting up the Subcontractor Feature (page 184) and Setting up 
the Advanced Subcontractor Feature (page 191).


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Complete the following fields, as necessary.
Vendor ID, Job Vendor, Address
Enter the vendor ID or select the Add Vendors button to select a Microsoft Dynamics GP vendor. The Job 
Vendor and Address fields default from the vendor record.
Vendor Contract Type
Use the drop-down list to select a type. Choices include NTE, Lump Sum, and Unit Price. This field is 
informational only.
Contract Date
The current system date defaults and can be changed.
Purchase Order #
Enter a purchase order number.
Retention %
This amount defaults from the Job Maintenance record and can be changed. You can select the 
expansion button to open the Retention window, which allows you to specify the maximum retention 
amount to be withheld for the subcontractor on the selected job.
Mod Rate
Enter the modification rate of the contractor. This field is informational only.
User-Defined
These fields are informational only.
Bonded and Lien Waiver on File
Mark these checkboxes.
Submit Date, Resubmit Date, Approved Date, Disapproved Date
Enter dates for submission, resubmission, approval, and/or disapproval.
Original Contract Amt.
Enter the original contract amount.
Change Orders
If change orders were posted for the cost code that is associated with the current subcontractor on the 
current job, the change order amount defaults.
Amended Contract Amt.
This field is calculated automatically as the sum of the original contract amount plus change order 
amounts.

Select Save.
To print the Subcontractor Status report, select File > Print or select the printer button.

Entering subcontractor contact names
You can enter contact names for your subcontractors/vendors.

Select Cards > Job Cost > Job.
Select a job, then select the Subs/Vendors button.
Select a vendor, then select the Contacts button.
Enter a contact name, phone number, fax number, and comments.
Select OK.

Adding Bill Codes to a Job
Bill codes are alphanumeric codes that you can create to track items billed for your job. Bill codes are often related to, 
or are the same as, your cost codes. Bill codes are used with Cost Code and User-Defined billing types. You can print 
required AIA job cost invoices using bill codes detail for your customers.
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The billing type you assign to a job affects how bill codes are created and what the billable amount is.

If you select the Cost Code billing type, the bill codes are automatically duplicated from all cost codes assigned 
to the job. The billable amounts for each bill code are calculated automatically based on the profit type and 
amount for the cost codes and posted costs if you are using the Cost Plus and Cost Plus NTE contract types. You 
must enter the billable amounts for Fixed Contract types.
If you select the User-Defined billing type, you can enter user-definable bill codes to break down the labor and 
material detail on customer invoices. When you bill a customer, you can enter specific amounts for each of the 
codes you defined. This provides the customer with a detailed accounting of items being billed.

Adding a bill code to a job
Select Cards > Job Cost > Job.
Select a job, then select the Bill Codes button.
Complete the following fields, as necessary.

Bill Code Number
If the contract type is Cost Plus and the billing type is Cost Code, use the Job Bill Codes Lookup 
window to select a bill code.
If the contract type is Fixed Amount and the billing type is User-Defined, enter a unique bill code 
number.

Description
Enter a description that you want to print on the invoice. If the billing type is Cost Code, the description 
for the cost code with the same number appears and should not be changed.
Cost Element
Use the lookup to assign a cost element to the bill code. Enter the cost element that applies to the type of 
bill code you set up. For example, if you set up a bill code for detailing labor costs, select the labor cost 
element. If the billing type is Cost Code, the cost element for the corresponding cost code appears in the 
Cost Element field and cannot be changed.
Total Billable Amount
Enter the total amount you wish to bill for the bill code over the life of the job. This is required for User-
Defined billing types.

If the billing type is Cost Code and the contract type is Cost Plus or Cost Plus NTE, this amount 
calculates automatically.
If the contract type is Fixed and the contract type is Cost Plus or Cost Plus NTE, you must enter an 
amount.

Amount per Invoice, Difference, Bill %
This will be the bill amount that defaults on invoices.

If the billing type is User-Defined, the amount you enter appears as the default bill amount 
whenever you create invoices for this bill code. You can edit this amount during invoice entry. For 
example, if the total billable amount for the bill code is $3,000, and you want to invoice the bill 
code in three progress billings of $1,000 each, you enter $1,000 as the amount per invoice for the 
bill code. That amount appears each time you enter this bill code on the Job Cost invoice.
If the billing type is Cost Code and the contract type is Fixed Amount, you can enter a billable 
amount. Once you enter the billable amount, the formula displayed at the bottom of the window 
calculates to show any remaining billable amounts that should be assigned to bill codes. This 
amount appears in the Difference field.

When a total billable amount and amount per invoice are entered, the Bill % field is calculated automatically as 
the percentage of the total billable amount that is billed per invoice. The bottom of the Job Bill Codes window 

Before setting up bill codes, think about how you want the detail to appear on customer invoices.
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contains the expected contract amount, the amount of the contract applied to bill codes, and the difference 
between the contract amount and applied amount.
Select Save.
To print the Job Bill Codes report, select File > Print or select the printer button.

Copying Job Records
You can copy an existing job to save time. Use this feature to create a prototype or template job. Information from the 
existing (or template) job, including cost code, revenue codes, and estimate amounts, copies to the new job record.

Select Cards > Job Cost > Job.
Select a Job to copy and select Copy.
Select Copy to the message asking if you want to copy the job.
Enter a new Job Number, Job Create Date, and Description.
Select Copy. The new job record displays in the Job Maintenance window.
Select Save.

Scheduling Job Appointments
If you're using the optional Job Scheduling feature, you can schedule technicians for Job Cost jobs using the 
Appointments window (for a single appointment at a time) or from the Service Management Appointment Wizard (for 
multiple appointments at once). In either case, technicians must be set up in Service Management before they can be 
scheduled on jobs.

Scheduling one appointment at a time (page 103)
Creating a job appointment resolution note (page 104)

Scheduling a group of appointments (page 105)

Scheduling one appointment at a time
Select Cards > Job Cost > Job.
Select a Job.
Select the Appointments button. The Appointments window opens.

If you want to use a sales account for each bill code at the job level and during job invoice entry, you can mark 
the checkbox Use a sales account for each bill code in the Invoice Accounts Setup window. See Job Cost 
Setup (page 13) for more information.



•

•
•
•

•

Because estimates vary greatly from job to job, we recommend leaving the estimate fields empty for 
template jobs. Once the record is duplicated, you can enter new estimate amounts for the new job's 
cost codes.
Posted costs and committed costs are changed to $0.00.
 Information from the Job User-Defined window will not be copied to the new job.
If you are using the Percentage-of-Completion (POC) revenue recognition method, you may want to 
exclude template jobs from the POC calculation so that they do not appear on the POC entry or edit list. 
See Excluding a job from POC (page 106).
If you are using the Revenue Performance Obligation (RPO) revenue recognition method, revenue/cost 
codes added from a change order are not copied.


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Complete the following fields, as necessary.
Appointment Description
Enter a description that conveys the purpose or other details of the appointment.
Note
Select the note icon to attach a note to the job appointment. See Creating a job appointment note (page 
104) for more information.
Technician ID
Select the technician assigned to this appointment. You can use the technician schedules button to view 
technicians' availability or use the best technician button next to the Technician ID field if you want the 
system to select the next available, qualified technician for an appointment. This feature is optional.
Date
The date that the appointment is scheduled to be performed.
Estimated Hours
Enter an estimate for completing the appointment. The number of hours cannot exceed 24. If you want 
the system to figure out the technician's next available time slot for the appointment, select the next 
available button, next to the Date field. This feature is optional.
Starting Time
Enter the time the appointment is scheduled to be performed. The time entered determines where the 
appointment displays in the Technician Board – Daily View window. If you do not enter a starting time, 
the appointment will not display in the Technician Board – Daily View window. 

Appointment Status
Default is the default status. You can change the status as necessary. Closed is not an available 
appointment status.
Completion Date
If you change the appointment status to Complete, enter a completion date.

Select Save to add the appointment to the scrolling window.

Double-clicking an appointment in the scrolling window fills its information in the header area of the window for 
editing. An appointment can be removed by choosing it in the scrolling window and choosing Delete.

Creating a job appointment resolution note
Job appointment resolution notes can be created for any open job. A job appointment note can be viewed, edited, and 
printed from within Signature, MobileTech, and Schedule. During the job appointment completion process in 
MobileTech, a technician will be able to create a job appointment resolution note. This note will be created with 
Resolution as the note subject. The job appointment resolution note is included on the Job Completion Appointment 
Summary report which can be generated and emailed from MobileTech.   

Select Cards > Job Cost > Job.
Select a Job.
Select the Appointments button. The Appointments window opens.
Select the Notes icon to the right of the appointment field.
The header information defaults from the job appointment and includes the job number, appointment, 
technician, and customer number and name.
Additionally, the last changed date and time display at the bottom of the note window.

A 12:00 a.m. time entry is the equivalent of zero. We recommend you do not have the starting 
time or ending time set to 12:00 a.m.



The appointment can have only one resolution note per appointment and technician. If the appointment is 
reassigned to a different technician, the note will be moved to the new appointment.


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Complete the following fields:
Subject
Enter or select the note subject. The subject field is saved for future use for a job appointment note when 
you save the note. 

Author
Enter or select the author. This field defaults to the user's login.
Printable
Mark the Yes radio button if you want to be able to print the note. See Printable notes in the Dexterity 
reports section of the Signature Reports documentation for instructions on printing reminder notes.

Enter the note text.
Select Save.

Scheduling a group of appointments
Select Cards > Job Cost > Job.
Select a Job.
Select a labor cost code, then select the Activities button to open the Service Management Appointment Wizard. 
Some fields will be filled in with Job Cost information.
Complete the following fields, as necessary.

Create Appointments for
Select to create the job appointment for all technicians, a single technician, a technician team, or a 
service area. Your selection determines the fields that are enabled.
Technician ID / Team / Service Area

If you are creating an appointment for a technician, complete the Technician ID field.
If you are creating an appointment for a technician team, complete the Team field.
If you are creating an appointment for all technicians in a service area, complete the Service Area 
field.

Appointment Type
Leave this field as Job to create a job appointment. You can also create an activity appointment by 
choosing Activity from the drop-down list. Activity appointments are non-service call or non-job related 
activities such as vacation, meetings, or training.
Activity ID
This field is disabled unless you change the Appointment Type to Activity.
Job Number
The job number comes from the Job Maintenance window. You can enter a different job. You cannot 
enter closed or inactive jobs.
Cost Code
Enter a cost code for the job. The cost code must have a cost element type of Labor.
Description
Enter a description that conveys the purpose or other details of the appointment.
Start Date, End Date, Starting Time, Estimated Hours
Enter start and end dates and the start time and estimated hours. If the Appointment Wizard was 
accessed from Job Cost, the start date and end date from the job cost code will default.
Days Between Appointments
Enter the number of days between appointments.
Skip
Mark the appropriate checkboxes to skip Saturdays or Sundays.

Select Create. If a schedule conflict occurs, a message appears indicating the number of appointments that were 
left unscheduled.

Resolution notes created in MobileTech have a subject of Resolution.
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Job appointments appear on the standard Dispatch Board in Service Management. 

You can reschedule job appointments in the Service Management Reschedule Appointment Wizard window. See the 
section Rescheduling activity and job appointments in the Service Management User Manual.

Excluding a Job from POC or RPO Calculation
If you are using the Percentage-of Completion (POC) or Revenue Performance Obligation (RPO) method to recognize 
revenue, you can exclude jobs from the POC/RPO calculation. This is useful if you do not want jobs that do not generate 
revenue, for example, template, fixed asset, and warranty jobs, to appear on the POC/RPO Edit List and POC/RPO Entry 
List when building a POC entry at the end of a period.

In addition, you may select to exclude a job from POC if you are:

Building an asset for your own use, without billing an external customer for the job.
Tracking costs that stay inside the company, for example, time spent on internal training, without billing an 
external customer for the job.
Billing a customer for a job that is not substantial enough to estimate or include in the POC calculation.

You may, however, want to continue posting costs to excluded jobs when applicable; costs and billing information can 
still be updated for these jobs, and a closing jobs journal entry will still be created for a job that is excluded from POC, 
but we recommend setting up a separate division if you are posting costs for these jobs.

Setting up a non-POC division
Jobs that are excluded from POC do not appear on the POC edit list; if you do not post costs for these jobs to a separate 
division with separate accounts, the totals on the edit list will not match the WIP balances in the General Ledger. In 
addition, non-POC jobs are not included in the POC entry; when the posting journal clears WIP amounts to the income 
statement, a balance from the non-POC jobs will remain in the WIP accounts.

To avoid reconciliation confusion at month's end, if you are posting costs to jobs that are excluded from POC, we 
recommend setting up separate divisions that do not use the same and COGS accounts as regular POC jobs.

You may have template jobs that are used only to create other jobs and are excluded from POC so that they do not 
appear on the POC Entry List and POC Edit List. If you are not posting costs to these template jobs, you do not need to 
use a different division for them.

Example: A fixed asset job tracks costs for an asset but does not bring in revenue. Setting up a division that uses the same 
accounts for posting costs, recognizing revenue, and closing jobs shows that the costs posted to this and other non-POC 
jobs in the division will remain in the same accounts, as there is no revenue being recognized.

Setting up the job to exclude from POC/RPO
Once costs or billings have been posted to a job, you cannot change the option to exclude the job from POC or RPO.

Select Cards > Job Cost > Job to open the Job Maintenance window, and complete the necessary fields to create 
a new job.
Select the appropriate Division for the type of excluded job you are creating. You do not need to use a non-POC /
RPO division if you are creating a template job that will not have posted costs.
Mark the Exclude from POC/RPO  checkbox. The checkbox displays if you are using the POC or RPO revenue 
recognition method.
Select Save.

You can use the printer button to print the Job Report, which indicates if the job has been excluded from POC or RPO. 
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When creating a POC/RPO entry at the end of a fiscal period, jobs that are excluded from the POC/RPO calculation do 
not appear on the Edit List or Entry List, and they are ignored by the posting journal.

Moving Costs and Billing to a Job from a Service Call
You can move costs from a service call to a job. For example, a service call might be deemed too large and longer in 
duration, and it might be prudent to transfer the costs to and track everything as a job. Or, your service organization 
might use Service Management to provide labor resources or equipment to a job, but use Job Cost to capture budgets 
and costs, and invoice customers.

In the first scenario above, you would completely transfer costs to be maintained - and invoiced - at the job level. In the 
second scenario, you would only bill the costs to the job; the costs would remain with the service call, but are billed as 
cost plus markup to recognize revenue.

The process involves mapping of cost categories in Service Management to cost codes in Job Cost. See Transferring or 
billing costs (page 108) for more information.

In addition to the ability to transfer an entire cost category to a specific cost code, you can also map transactions within 
a cost category to more than one Job cost code. See Transaction Mapping (page 108) for information on mapping 
transactions.

During the transfer, the following occurs:

The service costs which were transferred to the job are credited against the service call via general ledger journal 
transactions that are creating during the transfer process, resulting in a net zero cost balance on the service call. 
The batch number used for the general journal transactions is established during the Transfer process.
The job is debited with the new costs, via the offsetting general journal transactions.

The batch of general journal entries is posted.
The service call is closed.

This feature also works for credit memos (negative transactions). In this case, the job would be credited and service call 
would be debited. Certified Payroll jobs cannot be transferred.

Topics:

Setup - Moving costs from service call to job (page 108)
Setting up mapping defaults for cost codes (page 108)
Setting up an intra-company account (Bill to Job only) (page 108)

Transferring Costs or Billing Amounts to a Job (page 108)
Transaction Mapping (page 108)
Viewing the results after moving costs (page 109)

This procedure requires Service Management and Job Cost, and is performed from within Service 
Management. This feature requires a Microsoft Dynamics Full User license.



If the service costs are billed to the job as opposed to transferred, the ‘cost’ applied to the job is the 
marked up billable amount of each service transaction.



With the Signature 2018 R4 release, we've removed the ability to add a job on-the-fly in the Job Transfer 
window. However, if you utilize this feature, you can turn this back on by adding 
EnableTransferToJobCreateJob=TRUE to the Dex.ini file.


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Setup - Moving costs from service call to job
There are two setup procedures with this feature, one is optional and the other is required only if you use the Bill to Job 
option (second scenario described above).

Setting up mapping defaults for cost codes
You can set up default JC cost codes to use for mapping with cost categories in Service. When you transfer costs from a 
service call to a job, these defaults will be used automatically; you can also change them at transfer time.

Choose Microsoft Dynamics GP > Tools > Setup > Job Cost > Account Setup > Service Transfer Mapping. The Map 
Service Cost Categories to JC Cost Codes window opens.
Choose a Job Cost Division.
For the appropriate cost category, choose the corresponding JC cost code.
Save your defaults.

Repeat these steps for each division, as necessary.

Setting up an intra-company account (Bill to Job only)
An intra-company account is required and will be credited to service when costs are moved from a service call to a job.

Choose Microsoft Dynamics GP > Tools > Setup > Service Management > Invoice Setup > Invoice Accounts. The 
Invoice Accounts window opens.
Select an Intracompany Sales account, then click Save and close the window.

Transferring Costs or Billing Amounts to a Job
From the Service Call window, click the Transfer to Job button. The Transfer Service Costs to Job window opens.
Select the transfer type radio button:

Transfer to Job - Transfers the cost to the job.
Bill to Job - Transfer the billing amount as cost to the job.

Enter a Batch ID.
In the Job Cost Fields section, select an existing Job Number. The job information displays in the fields in this 
section.
In the Mapping section, if Job cost codes were set up for the selected division, they will display by default. (See 
Setting up mapping defaults for cost codes (page 108) for more information.) Otherwise, use the lookup to select 
the Cost Code in Job Cost that you want to map to each Cost Category in Service Management. To transfer 
service cost category transactions to specific job cost codes, see Transaction Mapping (page 108) below.
Choose Transfer. Choose Yes to the confirmation message to begin the transfer. If you choose Clear and then 
Continue, the window will be completely cleared and any transaction mapping that you've done will be 
removed.
When finished, if successful, you will receive a Transfer successfully completed message. Choose OK. The 
General Posting Journal will be available to view or print. This report shows the GL transactions created because 
of the costs being moved. The call from which you moved costs is now marked as Closed.

Transaction Mapping
You can map separate transactions within a Service cost category to multiple job cost codes. While not all cost 
categories have to have the transactions mapped separately, if you do choose to map a category's transactions, you will 
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need to map all of the transactions within that category. A warning indicator will display on the Transfer Service 
Costs To Job window by the service cost category name if some of the transactions within that category haven't been 
mapped. You will need to map the remaining transactions before you can save the batch in the Transfer Service Costs 
To Job window.

In the Transfer Service Costs To Job window:

If you selected Transfer To Job, the receipts will display in the Unmapped Service Transactions.
If you selected Bill To Job, the purchase orders will display in the Unmapped Service Transactions.

To map cost category transactions:

From the Transfer Service Costs to Job window, click the Cost Category arrow  icon.
In the Transaction Mapping window, following information defaults from the Transfer Service Costs to Job 
window:

Service Call
Job Number
Cost Category - This defaults cost category arrow selection. You can choose a different cost category as 
needed.

Select the Cost Code Number. The lookup opens the Job Cost Codes Lookup window and displays the cost 
codes specific to the Cost Category.
The Unmapped Service Transactions section displays all unmapped service transactions that exist for the cost 
category for the service call.
You can select one or more transactions in this section. To mark more than one transaction, hold down the CTRL 
key on your keyboard and mark the specific transactions. You can also mark all by holding down the CTRL key 
and pressing the letter A.
Click Map from the menu bar, or right-click and then select Map To Job Cost Code. You can also double-click on a 
transaction to map the transaction.
As transactions are mapped, they are moved from the Unmapped Service Transactions section to the Mapped 
Service Transactions. To unmap a transaction, in the Mapped Service Transactions section you can right-click 
on a mapped transaction and choose to unmap or select the transaction and then choose Unmap from the 
toolbar or you can double-click the mapped transaction.
In the Mapped Service Transactions section, mark Show All Cost Categories to display all of the mapped 
transactions for all the Cost Categories, not just the mapped transactions for the selected Cost Category.
You do not have to map all of the transactions to the same cost code number. You can select a different cost 
code number and then continue mapping any remaining transactions.
While still in the Transaction Mapping window, you can choose a different Cost Category to set up the mapping 
for that category in the same method as described above.
When you are done mapping individual transactions, close the Transaction Mapping window to return to the 
Transfer Service Costs to Job window.

Cost Categories that have all transactions mapped will display *Mapped by Transaction instead of a 
specific cost code.
If a Cost Category has some of the transactions mapped, but not all will display an icon.
Any transactions that aren't mapped separately in the Transaction Mapping window will be mapped to 
the Cost Code displayed for the Cost Category on the Transfer Service Costs To Job window. (See 
Transferring or Billing Costs (page 108) .) 

Continue with step 6 under Transferring or Billing Costs (page 108).

Viewing the results after moving costs
When a cost transfer is complete, a General Posting Journal is available immediately for viewing and printing. In this 
section, we will illustrate what happens after move and differentiate between a full transfer and a billing transfer.
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General Posting Journal - A familiar report that shows the journal entry created for the GL transaction during the move 
costs process, along with each account that is credited/debited. Notice that, during a Transfer to, each account is 
credited and debited accordingly. In the Bill to, only the intracompany sales account is credited.

Transfer to:

Account Description Debit Credit

000-1411-05 -EQ-Commercial $106.00

000-1411-06 -Mater.-Commercial $106.00

000-1410-05 Labor User-Commercial $80.00

000-1410-02 -Labor-Jobs-Commercial $80.00

Bill To:

Account Description Debit Credit

000-1411-02 -Mat-EQ-Commercial $397.80

000-1410-02 -Mater.-Commercial $150.00

000-4100-05 Labor User-Commercial $547.80

Service Invoice Inquiry window - Access this window by opening the Service Call window and choosing 
the Invoice button.

Loss Recognition
Loss occurs when a job or project has expected costs that exceed expected revenue. If you are using the Project Level 
feature and the Percentage of Completion (POC) revenue recognition method, you can recognize loss for a job or 
project as soon as a loss is anticipated, regardless of when the costs will incur.

The Loss Recognition feature allows you to automatically or manually select jobs and projects that are in a loss position 
and create a journal entry to accrue expected costs. If you want see how billing amounts are affected by the loss, you 
can also select whether to include billings in the loss recognition journal entry.

Example (page 111)
Example continued - with billings (page 111)

Setting up loss recognition (page 112)
Choosing the Loss Recognition posting option (page 112)
Setting up loss recognition accounts (page 112)
Setting up the next document number (page 112)

Including jobs and projects in loss recognition (page 113)
Including a job in loss recognition (page 113)
Including a project in loss recognition (page 113)
Printing an edit list (page 113)
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Creating a loss recognition journal entry (page 114)
Viewing history (page 114)
Note about closed jobs and periods (page 114)

Example
A job has the following amounts:

Expected Contract Forecast Cost Posted Cost POC

$2,500 $2,000 $1,000 50%

Contract Earned (POC x Expected Contract) =$1250 (50% x $2,500)

Anticipated Margin (Expected Contract - Forecast Cost) = $500 ($2,500 - $2,000)

When an additional $1,000 in cost is anticipated, and a change order cannot be obtained, a forecast revision is posted.

Expected Contract Revised Forecast Cost Posted Cost POC

$2,500 $3,000 $1,000 33%

These extra forecast costs affect the POC and contract earned, resulting in a loss for the period.

Contract Earned (POC x Expected Contract) =$833.33 (33% x $2,500)

Margin to Date Loss (Posted Cost - Contract Earned) =$166.67 ($1000 - $833)

In addition to the loss for the current period, the job is in an overall loss position, based on the anticipated margin and 
the costs that are yet to accrue.

Anticipated Margin (Expected Contract - Revised Forecast Cost) =$500 loss ($2,500 - 3,000)

Cost to Accrue (Anticipated Margin - Margin to Date) =$333.33 ($500 - $166.67)

Example continued - with billings
If you select to include billing amounts in the loss recognition, the loss recognition journal entry will also reverse the 
under billed/costs in excess (CIE) amount or the over billed/billings in excess (BIE) amount that is caused by the loss.

In the example above, the original Over/(Under) Billed amount is calculated as follows:

Over/(Under) Billed (Contract Earned - Billed) = $83.33 under billed ($833.33 - $750)

After the loss is recognized, the Contract Earned amount is adjusted:

Adjusted Contract Earned (Anticipated Margin Loss Posted Cost) = $500 (($500) $1,000)

The Adjusted Contract Earned amount is used to calculate the new over/(under) billed amount. Even though the job 
was previously under billed, the adjusted contract earned is now less than the billed amount:

Over/(Under) Billed (Adjusted Contract Earned - Billed) = $250 over billed ($500 - $750)

The adjustments to the CIE and BIE are recorded to indicate the difference between the new amounts and the amounts 
that are currently in the POC table.
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Setting up loss recognition
To set up the loss recognition feature, you must:

Select the Loss Recognition posting option, then select if to include billings.
Set up the accounts to use for loss recognition.
Set up the next document number for the loss recognition journal entry.

Choosing the Loss Recognition posting option
You can select the option to use job and project loss recognition if you are using the Percentage of Completion as the 
revenue recognition method. See Choosing Posting Options (page 23) for information on the other posting options in this 
window.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Job Cost Setup > Posting Options.
Mark the Use Job and Project Loss Recognition checkbox.
Mark the Automatically include all jobs and projects in a loss situation checkbox if you do not want to 
manually mark jobs and projects for inclusion in the loss recognition journal entry. If you select this option, any 
job or project that qualifies will be automatically marked for inclusion when the Loss Recognition Edit List is 
printed.
If you want to include billings in the calculation for the loss recognition journal entry, mark the Include Billings 
in Loss Recognition checkbox. See the example above for more information on including billings.
Select Save.

Setting up loss recognition accounts
Complete the following steps to set up accounts for the loss recognition journal entry.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Account Setup > Revenue Accounts. The Revenue 
Recognition Account Setup window opens.
Select a Division, then use the Revenue and Exp Accounts button to open the Revenue and Exp Account Setup 
window.
Provide account numbers for the following:

Costs of Loss Recognition
The account for the cost expense (debit amount) in loss recognition journal entries.
Accrued Costs\Costs in Excess
The account for the accrued costs or Costs in Excess (credit amount) in loss recognition journal entries.
Billings in Excess
The account for the Billings In Excess (credit amount) in loss recognition journal entries.

When you are finished, select Save.

Setting up the next document number
Complete the following steps to set the next document number for the loss recognition journal entry. The system will 
automatically assign the journal entry number based on the next document number.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Job Cost Setup > Number Options to open the Doc 
Number Setup window.
Enter the Next Number for the loss recognition journal entry.
Select Save.
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Including jobs and projects in loss recognition
Once the loss recognition feature is set up, you can recognize loss for jobs or projects that are incurring loss within a 
period. Identify the jobs and projects that are in a loss position, then select to include them in loss recognition. If the 
option to automatically include jobs and projects is turned on, any jobs and projects in a loss position will be marked 
automatically when the Loss Recognition Edit List is printed.

Including a job in loss recognition
Complete the following steps to include a job in the loss recognition journal entry for the current period. If the job is 
assigned to a project that is marked for loss recognition, the job cannot be marked. An entry will be created for the 
project.

Select Cards > Job Cost > Job. The Job Maintenance window opens.
Select the job that you want to include in the journal entry.
Mark the Include in Loss Recognition checkbox to include the job in the loss recognition journal entry for the 
current period. This checkbox is disabled if the Use Job and Project Loss Recognition posting option is turned 
off.
Select Save.

Including a project in loss recognition
Complete the following steps to include a project in the loss recognition journal entry for the current period. Projects 
can only be marked for loss recognition if they use the Project POC method, and if all jobs assigned to the project are in 
the same division. There will be one loss recognition entry that includes all jobs on the project.
When you mark a project, all the project's jobs will be considered. A loss will not be recorded unless the entire project is 
expected to end with a loss.

Select Cards > Job Cost > Project to open the Project Maintenance window.
Select the project that you want to include in the journal entry.
Mark the Include in Loss Recognition checkbox to include the project in the loss recognition journal entry for 
the current period. This checkbox is disabled if the Use Job and Project Loss Recognition posting option is 
turned off.
Select Save.

Printing an edit list
The Loss Recognition Edit List allows you to view details for the jobs and projects that will be included in the loss 
recognition journal entry. Before month end, you can use this edit list to forecast the loss for the period and view the 
effect that the loss will have on the current month's Profit & Loss Statement.

If you are automatically choosing jobs and projects for loss recognition, they will be included when the edit list is 
printed.

Select Reports > Job Cost > Edit Lists > Loss Recognition Edit List.
Select the Year and Period that you are printing the report for. This report can only be printed for the current 
period.
Select Print.

The values on this report vary depending on whether billings are included in the loss recognition. If you are not 
including billings, you will see the Cost to Accrue. If you are including billings, you will see the Billed, Under Billed, 
Billings in Excess, Adjustment to Cost, Adjustment to CIE, and Adjustment to BIE amounts.
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Creating a loss recognition journal entry
After posting the POC Entry and closing the period, you can create the loss recognition journal entry. Like the POC Entry, 
the loss recognition entry will be excluded from WIP reports.

Select Transactions > Job Cost > Loss Recognition Entry to open the Build Loss Recognition Entry window opens.
The Loss Recognition Journal Entry Number defaults based on the next document number that was specified 
during setup.
Enter a Description and select the Year and Period for the loss recognition journal entry. The entry will be 
created for the jobs and projects that were marked as in a loss position for the selected period.
Select Build.
When the entry is finished building, select Post to post the journal entry. The Loss Recognition Posting Journal 
report prints when you are finished.

The Job Profit and Loss Report will also display two additional fields from the loss recognition journal entry for jobs in a 
loss position:

The Adjustment to Cost for Loss column indicates the adjustment to cost on the loss recognition journal entry.
The Actual Cost plus Loss Adjustment column indicates the total cost plus the adjustment to cost from the loss 
recognition journal entry.

Viewing history
You can print the Loss Recognition Audit Report at any time to view loss for a period. This allows you to view historical 
loss information for jobs and projects.

Select Reports > Job Cost > Job Reports > Audit Reports > Loss Recognition Audit.
Select the Year and Period that you are printing the report for.
Select Print.

Like the edit list and posting journal, the information that appears on the audit report depends on whether billing was 
included in the loss recognition journal entry.

Note about closed jobs and periods
When you open a closed job, and that job is in a loss position, the job will be included in the next loss recognition entry.

When you open a closed Job Cost fiscal period, the Loss Recognition Entry for the period is reversed, along with the POC 
Entry. When the period is closed again, the Loss Recognition journal entry must be posted again, along with the POC 
entry.

Transactions
Entering transactions is one of the more important activities you do in managing and tracking job costing. You enter 
transactions to record costs, such as charges directly associated to material or labor, and to record invoices or bills sent 
to the customer.

Some transaction data must be entered through Job Cost windows, while other data must be entered through 
Microsoft Dynamics GP windows. These require that specific Microsoft Dynamics GP modules be installed.
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Once entered, individual transactions can be posted immediately (transaction-level posting) or saved in batches for 
posting later (batch posting). If transactions are saved in batches, they do not affect any general ledger or Job Cost 
accounts until the batches are posted. This allows you to review the transactions, print edit lists, and correct errors 
prior to posting.

Entering Beginning Balances
If you start to use Job Cost in the middle of an existing job, you can enter beginning balances in the Job Transaction 
Entry window (Transactions > Job Cost > Job Transaction Entry). You can enter beginning balances any time during your 
fiscal year.

When you set up a job for the first time, you enter beginning balances for all applicable cost codes with your job 
transaction entries. Since Job Cost creates a general ledger journal entry as costs post, you should enter a debit amount 
and a credit amount to the same account. This results in having no effect on posting account balances in the general 
ledger, but it provides your job's cost codes with the beginning balances.

Entering Payables Transactions in Job Cost
When a purchase is made for a job, you need to record it as an accounts payable transaction. A typical accounts payable 
transaction might involve piping on a construction job.

Users have access to intercompany transactions and multidimensional analysis for Job Cost and Unbilled transactions. 
You must have Microsoft Dynamics GP Intercompany Processing and Multidimensional Analysis (MDA) registered to use 
the functionality.

After completing the Payables Transaction Entry window, you can distribute the payable among Service Management 
service calls, Job Cost jobs, and Microsoft Dynamics GP transactions. You must be using Service Invoicing, not SOP 
Invoicing, to create Service transactions.

The Payables Management module must have been purchased to enter payables transactions.

Entering payables transactions (page 116)
Voiding payables vouchers (page 118)

•

•

•

For purchase order, inventory, payables, and job cost transactions, the job number and cost element 
will display with the general ledger account distribution associated with the transaction wherever 
account distributions are displayed. This applies only if the journal entry for each type of transaction is 
set up to be created per transaction, and not per batch.
The general ledger account distribution for the job will not display if you change the account number 
during purchase order, receivings, or inventory transaction entry.
Though you can void, copy, or correct a General Ledger transaction that was entered in Service 
Management or Job Cost, the transaction information will not be updated in Service Management or 
Job Cost.



If you enter beginning cost balances, keep in mind that if you want to view summary amounts for previous 
periods, enter a separate transaction for each period using an applicable posting date.



To post an intercompany payables transaction to a destination company, the option in Posting Setup to Post 
Through General Ledger Files for Transactions must be marked.


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Entering payables transactions

Step 1: Complete the payables transaction entry window
Select Transactions > Purchasing > Transaction Entry.
Complete the Payables Transaction Entry window. See the Microsoft Dynamics GP Payables Management Manual
for more information.

Step 2: Distribute the payable
In the Payables Transaction Entry window, select the Distributions button to open the Payables Transaction 
Entry Distribution window. 

Complete the following fields, as necessary. An indicates that a field is required:
Company ID
If you marked the Intercompany checkbox in the Payables Transaction Entry window, you can enter a 
company ID. Changing the company ID will remove all service call information from the transaction.
Product Indicator
Enter the product to which you want to distribute the payable amount. If the Service Call or Service 
Invoice window is open, Service will automatically appear in the Product Indicator field; otherwise, 
Unbilled will appear. You cannot change the product indicator if a service call ID or job number has been 
assigned to the transaction. Fiscal periods, which must be open, are checked for both the origination and 
destination companies when you select Job Cost from the drop-down list. You can select Unbilled, Job 
Cost, or Service from the drop-down list.
Job Number / Service Call ID
Enter a job number or service call ID if different than the current service call ID. If you haven't changed 
the company ID and if the Service Call or Service Invoice window is open, the service call ID will 
automatically appear; otherwise, the field will be blank. If you use the lookup, the Service Calls Open 
window or the Job Number Lookup window lists the calls or jobs for the selected company.
Signature CC, Item Description
For Service transactions, enter a cost code in the Signature Cost Code field. Use cost category 1, 2, 4, or 5. 
You can select the expansion button to open the Service Payables window where you can edit the billing 
amount and enter other transaction information. The Item Description field defaults from the Description 
field in the Payables Transaction Entry window on new transactions. Subsequent edits to either 
description field are not shared.
JC Cost Code, Cost Element, Debit/Originating Debit, Credit/Originating Credit
For Job Cost transactions, enter cost code and cost element information. Once you enter a cost code, the 
general ledger posting account assigned to the cost code appears. The expense amount for the cost code 
in the Debit or Originating Debit field appears as the default. If you enter a return or a credit memo, the 
amount appears in the Credit or Originating Credit field. You cannot enter cost element 1, Labor. The cost 

•
•

•

Do not save the transaction before you distribute the payable to Job Cost.
For Transaction-Level billing type jobs, the information you enter in the Description field will appear on 
customer invoices.
You cannot use recurring batches with job payables transactions. Only single-use batches are allowed.



You must have a credit for the total amount of the transaction to accounts payable for the distribution 
type PAY.


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code displays automatically if you set up default Payables cost codes in Job Cost and assigned the cost 
code to the job by distribution type.
Account
Enter an account or accept the default account. The account used depends on setup. The Account field 
isn't editable if the Use Service Debit Accounts for Microsoft Dynamics GP Costs checkbox is marked in 
the Service Options window and the product indicator is Service. If Division is chosen in the Cost Code 
Debit Posting Accounts field in the Posting Options window and the product indicator is Job Cost, the 
Account field will not be editable. It is editable for Unbilled transactions. The setup options for the 
destination company will be used for intercompany transaction. See Setting up invoice accounts in the 
Service Management documentation. If this is an Unbilled or Job Cost transaction and the account has 
been set up to use MDA, you can select the account analysis button to verify the analysis codes to which 
the posting amount is to be allocated. The account analysis button will be disabled for Service 
transactions. Service Management is not compatible with Multidimensional Analysis. You will receive 
errors if you try to post Service transactions to accounts set up for MDA.
Distribution Type
Select a distribution type from the drop-down list. For non-intercompany transactions, you are not able 
to select CASH, PAY, or UNIT for a Job or Service transaction. For intercompany transactions, you can 
only select PURCH, FNCHG, FREIGHT, or MISC for Job and Service transactions. For Unbilled transactions, 
you can select PURCH, FNCHG, FREIGHT, MISC, or UNIT.
Debit / Originating Debit, Credit / Originating Credit
Enter a debit or credit amount in either the Debit or Credit fields or the Originating Debit or Originating 
Credit fields.
Distribution Reference
The distribution reference is automatically entered as: "Service" followed by the service call ID and cost 
code (e.g. Service 0408-0001 2) and "Job" followed by the job number and cost element (e.g., Job 
F&S-1001 2). It can be edited.
Quantity
Enter a quantity if other than "1" or "-1." Returns and credit memos will have a quantity of "-1."
Corresponding Company ID
Enter a corresponding company ID. This field may be disabled depending on setup. See Microsoft 
Dynamics GP documentation.

Select OK to close the window.

Step 3: Post the transactions
Select File > Print in the Payables Transaction Entry window to print the edit lists before posting to verify the 
accuracy of the transactions you enter. If you identify errors, correct the errors and post. For more information 
on posting, see the Microsoft Dynamics GP Payables Management Manual. The amounts print in the functional 
currency.
Post the Payables Management batch in the originating company. When you batch post a Payables transaction 
with intercompany transactions, a Payables general ledger batch will be created in the originating company. If 
the Payables Management batch doesn't contain intercompany transactions, the Service Invoice and Job Status 
window will be updated.
Post the Payables general ledger batch in the originating company. After posting, the Service invoice, Job Cost 
job, and Microsoft Dynamics GP Receivables Management will be updated. The intercompany offset account will 
be used as the offset for intercompany transactions. Posting the Payables general ledger batch creates an 
intercompany general ledger batch in the destination company. The batch will be named using the next 
intercompany batch number ID.
Post the intercompany general ledger batch in the destination company. The batch will contain both Service and 
Job Cost transactions.
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Step 4: Access the transactions
Once the Payables general ledger batch is posted, you can access the transactions in the destination company in 
Service Management. They appear as manually added costs, or "+" button, transactions. They're opened by zooming on 
the cost categories in the Service Invoice window. See Entering manually added transactions in the Service Management 
User Manual.

If a service call is closed in the destination company, you are still able to post intercompany transactions to the call. The 
service call will be updated with the posted transactions.

Once the Payables general ledger batch is posted, you can access the transactions in the destination company in the 
Job Status window. See Viewing Job Status Information (page 168).

Voiding payables vouchers
When you void an open Job Cost accounts payable voucher, a negative (reversing) payables distribution is created in 
the Transaction Summary window in Job Cost.

Select Transactions > Purchasing > Void Open Transactions.
Mark the transactions to void.
Select Void.

After the voucher is voided, the Void Open Payables Transactions Posting Journal is created. You can view voided 
transactions in Job Cost in the Transaction Summary window. See Viewing Posted Costs (page 168).

Using Microsoft Dynamics GP Purchase Order Processing
You can enter and edit purchase order transactions using Microsoft Dynamics GP Purchase Order Processing (POP). You 
can enter job-related information to link the purchase order to a job. You can also enter purchase order returns for 
purchase orders that contain job costs.

When entering job information on a purchase order, all cost and item information goes to the job in Job Cost rather 
than to the Inventory module. If you wish to track purchase order items through inventory, you can first create a PO 
using the Unbilled product indicator for the items, then create an adjustment entry to the job.

Creating purchase orders (page 119)
Step 1: Complete the purchase order entry window (page 119)
Step 2: Enter job-related information (page 119)
Step 3: Commit the purchase order (page 119)

Receiving purchase order items (page 120)

While intercompany transactions can be used with Job Cost subcontractors, information such as retention and 
master subcontractors will not be updated in the destination company.



Voiding historical payables transactions does not update Job Cost records.

If you need to create a return for a Subcontractor purchase order, see Entering returns on a subcontractor 
purchase order (page 122).


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Entering purchase order returns with job costs (page 120)
The purchase order return process: a quick review (page 120)
Returning a purchase order item (page 121)
Viewing job information for a PO return (page 121)
Viewing updated costs in Job Cost (page 122)

Entering returns on a subcontractor purchase order (page 122)
Step 1: Complete the transaction in Invoice Match (page 122)
Step 2: Issue a credit memo (page 122)
Step 3: Release the invoices (page 123)
Step 4: Reconcile the Subcontractor Maintenance window (page 123)

Creating purchase orders

Step 1: Complete the purchase order entry window
Select Transactions > Purchasing > Purchase Order Entry.
Complete the window. See the Microsoft Dynamics GP Purchase Order Processing Manual for more information.

Step 2: Enter job-related information
From the Product Indicator drop-down list, select Job Cost. Unbilled is for Microsoft Dynamics GP general 
ledger transactions. 

Enter a Job Number and a Cost Code.
Select the expansion button attached to the Item field to open the Purchasing Item Detail Entry window.
Use the lookup in the Text ID field to add standard text to the purchase order. You can also use the expansion 
button to enter text to the line item. While they function similarly, the Text ID field allows more space than the 
Microsoft Dynamics GP Comment ID field. The description prints on the blank paper purchase order format.

Step 3: Commit the purchase order
Select Commit to save the purchase order and update the committed costs in Job Cost. If you plan to print/email 
the purchase order, you do not need to commit. 

Select File > Print. Upon printing and/or emailing the purchase order, the costs become committed costs for the 
job. Once a purchase order is committed, taxes are included with the item's cost in the Committed Costs column 

When copying a purchase order, Service and Job Cost information will not copy. Only the Microsoft Dynamics 
GP information will copy, and the Product Indicator field will be changed to Unbilled for all line items.



If you marked the setup option to have the job number or cost code from the last line item entered as 
the default entry in the line you're entering, that information will already be entered. See Choosing 
Setup Options8.



The PO Status field shows New if the purchase order has not been printed, Open after the purchase 
order has been printed, and Modified if it has been changed after printing.



https://docs.key2act.io/display/Signature2018R4/Choosing+Setup+Options
https://docs.key2act.io/display/Signature2018R4/Choosing+Setup+Options
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in the Job Status window and in the Actual column in the Cost Codes Detail window. To view the tax portion of 
the costs, you can zoom on the appropriate cost column in the Job Status window. Landed costs are not 
included in the committed cost amount.

Receiving purchase order items
When purchase order items or their invoices are received, you can use the Receivings Transactions Entry window to 
acknowledge and post the transaction.

Select Transactions > Purchasing > Receivings Transaction Entry.
Complete the Receivings Transactions Entry window. See the Microsoft Dynamics GP Purchase Order Processing 
Manual for more information.

Costs in the Committed Costs column in the Job Status window move to the Posted Costs column after the receipt is 
posted. Landed costs are included in the posted costs.

Entering purchase order returns with job costs
You can now perform purchase order returns for purchase orders that contain Job Cost costs. This feature supports PO 
returns with and without credit, and batch and transaction-level posting. This feature will not support the processing of 
returns against inventory transactions, as those can be performed using the current alternate Inventory Transaction 
Entry window.

Additional notes about PO returns with Job Cost:

When a return is processed that contains Job Cost items, those items will be reversed on the job.
Taxes on PO returns will update per the Suppress PO line item tax update to Job Cost and Service 
Management option in setup. If this option is turned on, taxes are not included in the total costs.

The purchase order return process: a quick review
The PO return process works as follows.

Shipment only

Create and save purchase order. PO status is NEW.
Receive and post the shipment. PO status is RECEIVED.
Create purchase order return. PO status remains RECEIVED. If a replacement item will be shipped, you can edit 
the purchase order and change the status to CHANGE ORDER. Then you could add the replacement item right on 
the original purchase order.

If you are using the Microsoft Dynamics GP Multicurrency Management module, you can toggle the display 
between the originating currency listed in the Currency ID field and the functional currency by choosing the 
multicurrency button.



If you are using the shipment types, you can also enter items line-by-line, then select Transactions > Purchasing 
> Enter/Match Invoices to select the items received.



A purchase order must be committed and received before you can enter a return for that PO.
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Shipment with Invoice

Create and save purchase order. PO status is NEW.
Receive shipment/invoice. POS status is CLOSED
Create purchase order return. PO status remains CLOSED.
Post credit transaction to Payables Management. If a replacement item will be shipped, you can edit the 
purchase order and change the status to CHANGE ORDER. Then you could add the replacement item right on the 
original purchase order. When you view the PO, both line items will be CLOSED.

Returning a purchase order item
You create a PO return as you normally would except that you can now view jobs associated with the return.

Select Transactions > Purchasing > Returns Transaction Entry. The Returns Transaction Entry window opens.
Select a return type. You must select either Return or Return W/Credit. Tab through to fill the Return No.
Fill the remaining fields, as necessary. For additional information on the fields listed below, refer to the Microsoft 
Dynamics GP documentation.

Vendor Doc. No.
The number identifying the document that the vendor gave you; typically this is the invoice number or 
packing slip number from the vendor's documents. You can leave this field blank if you're entering a 
return without credit.
Date
The date the item is to be returned. The system date fills automatically.
Batch ID
The batch associated with this purchase order, if applicable.
Vendor ID and Name
The vendor associated with the item being returned.
Currency ID
The currency ID of the returned item fills automatically.
PO Number
The purchase order number to which the returned item belongs.
Vendor Item
The item being returned.
Receipt No.
The receipt number associated with this returned item.
U of M
Displays the unit of measure for the item being returned.
Quantity Returned
The quantity to return. This field fills automatically with the maximum quantity available from the 
receipt.
Unit Cost
Displays the cost of the item in the unit of measure. 

Tab to the next line. You can now view the jobs and/or service call associated with this returned item. See 
Viewing job information for a PO return (page 121) below.
Save or post the transaction. If a return transaction results in a net $0.00 cost for the PO line item and you are 
using a price matrix where the first row begins with Starting Cost of $.01 or higher (see example below), you will 
receive an error because the system will not be able to calculate the extended markup for $0.00. To avoid this 
error, you should change the starting cost in the first row of the price matrix to $0.00.

Viewing job information for a PO return
Select Extras > Additional > Signature PO Return.
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Select OK to close the window.

Viewing updated costs in Job Cost
When a PO return has been posted, the appropriate costs are updated in Job Cost, as applicable. To view updated costs 
in Job Cost because of a PO return:

Select Inquiry > Job Cost > Job Status. The Job Status window opens.
Select a job associated with the purchase order.
Zoom on a Posted Cost for that cost element. The Cost Code Summary window opens.
Zoom on the Cost Code. The Cost Code Detail window opens.
Select View Transactions. The Transaction Summary window opens. The purchase order return transaction 
contains a transaction type of POR.
Double-click the transaction to open the Returns Transaction Inquiry Zoom window. This provides additional 
details about the PO return.

Entering returns on a subcontractor purchase order
If you have a purchase order for a job and cost code for a subcontractor with retention and have received the materials 
and posted a receiving transaction, but need to create a return, the recommended way to undo a purchase order that 
was issued and received is to finish the transaction by doing an invoice match and then enter a credit memo through 
the Payables Transaction Entry window. 

While we do get requests to do a negative PO line or an “undo the receiving” type of concept, this is not the design of GP 
Returns. While legacy systems may have a negative PO line concept, GP returns is better because of its ability to handle 
inventory either being sent back or flagged as damaged as well as creating the credit. Typically the user could go to the 
Dynamics GP Returns Transaction Entry to do the return, but because this is a subcontractor cost in job cost the return 
transaction is not allowed. However, you can create the return by completing the following steps.

In the steps below, the example described consists of:

Purchase Order: $10,000
Received Amount: $4,000
Retention: 10%
Tax Exempt: Yes

Step 1: Complete the transaction in Invoice Match
In order to undo the receiving transaction, it is recommended that the user complete the transaction through the 
invoice match process like any other received PO. Transactions > Purchasing > Enter/Match Invoices.

Complete the invoice match transaction and make note of the Document number for future reference.
After completing the invoice matching, the invoice is now recognized along with the retention withheld in the 
Subcontractors Maintenance window. The transaction is through payables but will not be paid. 

Step 2: Issue a credit memo
To update the job, Subcontractors Maintenance window, and the payables transaction the recommended approach is 
to issue a credit memo through the Accounts Payables Transaction Entry window.  

Committed costs are not added back for returns.
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Open the Accounts Payable Transaction Entry window. Transactions > Purchasing > Transaction Entry
Select the Vendor.
Enter the full amount of the invoice $4,000 in the Payables Transaction Entry window.
Select the Distributions button.
In the Payables Transaction Entry Distribution window, select the Job Number and Cost Code.
Tab off the Cost Code field, to automatically insert the Retention Payable record.
Select OK.
At this point, the payable record and the general ledger transactions have all been updated properly. There are a 
couple more steps to clean up the job.  After leaving the distribution window, the Payables Transaction Entry 
window will revert to $3,600 for the payables amount because the retention amount of $400 is now calculated. 

Step 3: Release the invoices
Release the invoices from the Subcontractor Payments window by going to Transactions > Job Cost > 
Subcontractor Payments and select the Process button.  
Release the retention from the Subcontract Transactions window by going to Transactions > Job Cost > 
Subcontractor Retention and select the Process button.
At this point, the posted costs have been removed from the job.

Step 4: Reconcile the Subcontractor Maintenance window
You will need to run the Reconcile Subcontractors to update the Subcontractors Maintenance window to display the 
Retention Invoices correctly. (The credit memo retention is being added to the field rather than deducted.) The 
Retention Invoices field should be $0, instead it is showing $800.

To run the Reconcile Subcontractors utility, go to Tools > Utilities > Job Cost > Reconcile Subcontractors.
Enter the Job Number.
Select Reconcile. 

Entering Signature GL Transactions in Job Cost
You can enter GL transactions for service calls using an alternate window called Signature Transaction Entry. This 
window is based on the Microsoft Dynamics GP GL Transaction Entry window.
The general purpose of this window is similar to the Microsoft Dynamics GP Transaction Entry window: to enter 
standard and reversing transactions, to post individually entered transactions, and to void saved transactions. 
However, you can also:

Include a combination of service calls, jobs, etc. on the same transaction, and apply to one GL journal entry
Transfer costs from a service call to a job, and vice versa, or from one service call to another

This feature supports multi-currency and Inter-company transactions, but does not support the following: Recurring 
batches and Multi-Dimensional Analysis (MDA).

About intercompany transactions
Using the Signature Transaction Entry window, you can create intercompany transactions, which allows you to record 
transactions in the general ledger for one company that will create transactions in the general ledger of another 

For Service Management, these features are available only if you are using Service Invoicing, not SOP 
Invoicing.


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company.
Consider the following when creating intercompany transactions using this window:

As with other intercompany transactions, when the transaction is posted in the current company, the GL batch is 
created in the destination company must then be posted in that company.
For Service Management, you cannot create labor transactions using the Signature Transaction Entry window.
For Job Cost, you can create labor transactions but not if you are using labor rates to calculate payroll amounts.

Creating a Signature GL transaction

Choose Transactions > Financial > General.
You can also access this window from the Service Call window by choosing the Journal Entry button.
The Journal Entry field fills automatically. You can change this entry, if necessary.

Intercompany
Mark this checkbox if you need to record transactions in the general ledger for one company that will 
create transactions in the general ledger of another company. See About intercompany transactions (page 
123) for more information.
Batch ID
The batch ID for the journal entry number you entered. If the batch ID you enter does not exist, a message 
will appear asking if you want to create a new batch.
Transaction Type
A transaction is an accounting entry that changes the balance of liability, revenue, asset and/or expense 
accounts. Standard - Mark this option to enter a general transaction, and to assign debit and credit 
amounts. Reversing - Mark this option to enter a transaction for which debit and credit entries will be 
reversed as of a later date.
Transaction Date
The transaction date can be up to 365 days prior to the first day of the oldest open year and must be in an 
existing fiscal year.
Source Document
The source document is an abbreviation that tells you which type of journal or entry to examine for more 
information about a transaction.
Reference
References are required and can be any combination of alphanumeric symbols to help you identify the 
transaction.
Currency ID
The currency ID for the transaction, if you're entering a transaction in a currency other than your 
functional currency. The functional currency is the default entry when you first open the window. Choose 
the Currency ID link to view more information. If you're not using Multicurrency Management, this field 
isn't available.
Product Indicator
Indicates the product to which you want to distribute the transaction. You can choose Unbilled, Job Cost, 
or Service. (Service is disabled if using SOP invoicing.)
Job No. / Service Call ID
The job number or service call ID associated with this transaction.
JC Cost Code
This field is not in use if this is a Service transaction. If this is a Job Cost transaction, the field displays the 
cost code associated with this transaction.
CC/CE
For a Service transaction, the cost code is displayed. If this is a Job Cost transaction, the field displays the 
cost code element based on the cost code selected. You can choose the expansion button to open the 

Make sure you have security access to alternate Microsoft Dynamics GP windows for Signature.
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Signature Transaction Detail Entry window, where you can enter additional detail for this transaction. 
See Entering additional detail for a transaction (page 125) for more information.
Co. ID
Enabled only if Intercompany checkbox is marked. Choose the company for which this transaction will 
be created.

Fill the remaining fields, as necessary.
Save or post the transaction.

Entering additional detail for a transaction
You can enter additional information for a Job Cost transaction using the Signature Transaction Detail Entry window. 
For example, if a transaction is being entered for a cost code with a cost element of 1 (labor), you can enter labor 
details, for example, department, position, and labor rate group.

To open the Signature Transaction Detail Entry window, choose the expansion button next to the Cost Element 
field in the Signature Transaction Entry window. The header fields on this window fill automatically from the 
Signature Transaction Entry window. The additional fields that are enabled on this window depend on the cost 
element selected.

Job No./ Service Call ID
Cost Element
Cost Code
Description
Cost Type Description

To enter transaction details, complete the enabled fields on this window, as necessary. If you are entering 
details for a transaction with a cost element of 1 (labor), the following fields are enabled.

Employee ID
Identifies the employee, as set up in the Employee Maintenance window.
Labor Rate Group
If the product indicator is Job Cost, the labor rate group of the cost code.If the product indicator is 
Service, the labor rate group from the customer location on the service call.
Department, Position, and Pay Code
Pertains to labor rate groups set up in Service Management and Job Cost. These fields fill automatically 
when you choose an Employee ID.
Transaction Date
Fills automatically from the same field on the Signature Transaction Entry window.
Hours
Hours of labor to be billed.
Cost per Hour
Dollar amount per labor hour. Fills automatically from the employee payroll record when you choose a 
Pay Code.
Overhead Cost
The indirect, job-related cost your company incurs in the process of doing business, for example, 
workmen's compensation. This field fills automatically. For Service Management transactions, this cost is 
calculated based on the total cost (hours*cost per hour). This feature will be modified in 9.0EX MR1 to 
allow user entry directly into this field, and will remove the dependency on hours and cost per hour.
Rate per Unit
Displays only if the Display Pay Rate on Labor transactions is marked in the Invoice Options window.

If you are entering details for a transaction with any other cost element, the following fields are enabled.
Vendor
Enabled only if cost element is not labor.
Equipment ID
Enabled only if product indicator is Service and cost element is not labor.
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Item Number and Item Description
The item number and description associated with this transaction.
Unit Of Measure
The unit of measure associated with this item.
PO Number
Purchase order number, if applicable.
Quantity
The number of items.
TRX Amount (Extended Cost)
Fills automatically based on the amount entered in the Debit or Credit field in the Signature Transaction 
Entry window. 

Choose OK.

Entering Inventory Transactions in Job Cost
If inventory items are used on a job, you can enter inventory transactions with Job Cost detail. Unlike accounts payable 
transactions, you must enter a separate inventory transaction for each job you distribute amounts to. The Inventory 
module must have been purchased to enter inventory transactions. 

Step 1: Complete the item transaction entry window
Select Transactions > Inventory > Transaction Entry.
Complete the window. See the Microsoft Dynamics GP Inventory Control Manual for more information. 

In the Trx Type field, select the Job Cost radio button.
Enter a Job Number. The Inventory Transactions window opens.
Enter a Cost Code. If you enter more than one item on the transaction, you can select Apply All to apply all 
inventory items to the same cost code. 

Select OK in the Inventory Transactions window. Transaction amounts distribute automatically to the posting 
account you assign to the cost code. Offsetting posting accounts for the inventory item are assigned based on 
the Microsoft Dynamics GP posting accounts entered when the item was set up. If you are using the Cost Code 
posting option, you can change the general ledger posting accounts on an inventory transaction. Do this by 
choosing an item number in the Item Transaction Entry window, choosing Distributions, and entering the 
accounts.
In the Item Transaction Entry window, select Save.

This field is disabled for Service transactions.

You cannot use recurring batches with job inventory transactions. Only single-use batches are allowed.

To edit a transaction in the Inventory Transactions window, you must select the Cost Code field to 
select another cost code using the lookup button. If the Cost Code field is not selected, the lookup 
button will be disabled.


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Step 2: Print an edit list
We recommend that you print an Inventory Transaction Edit List before posting to verify the accuracy of the 
transactions you entered. If you identify errors, correct the errors, and post. For more information on posting, see the 
Microsoft Dynamics GP Inventory Control Manual.

To print the Inventory Edit List with Job Cost detail, select Reports > Job Cost > Edit Lists > Inventory Edit List.
Select the appropriate Batch ID.
Select Print.

Using Sales Order Processing
Job Cost integrates with Sales Order Processing (SOP). In addition to invoice costs being updated in Job Cost, you can 
use the full invoicing system of SOP, including pricing, invoice formats, and line item taxes.
When entering inventory transactions using SOP, you can select whether to bill through SOP or bill through Job Cost.

If you are using SOP to bill jobs, see Setting up SOP invoicing in Job Cost (page 127). If you are using SOP only to enter 
inventory transactions and will bill jobs through Job Cost, see Entering inventory transactions using SOP (page 127).

The Sales Order Processing module must have been purchased to enter sales order transactions.

When using SOP invoicing with Job Cost, consider the following:

You can have multiple SOP documents for a single job.
Retention will not be withheld from SOP billing-type jobs.
Repeating documents are not allowed with SOP billing-type jobs.
You cannot bill for inactive jobs using SOP invoicing. To bill for inactive jobs, you must use the Job Invoice Entry 
feature in Job Cost (Transactions >Job Cost > Job Invoice Entry).
Billing amounts from other modules, such as Payables Management and Inventory Control, do not automatically 
appear on SOP invoices, even though the costs are applied to the SOP billing-type jobs. To include billing 
amounts on SOP invoices, you can reenter these transactions as service-type inventory items through SOP with 
a $0 cost applied to the job and cost code.

Tracking warranty part transactions through SOP
You can create warranty transactions that allow you to track warranty replacement items by customer. The standard 
sales transaction can be modified automatically to use different posting accounts for warranty item reimbursements 
and replacements than are used for new sales.

For inventory transactions, the job number and cost element will display with the general ledger account 
distribution associated with the transaction wherever account distributions are displayed. This applies only if 
the journal entry for inventory transactions is set up to be created per transaction, and not per batch. You 
must also be posting inventory by batch to the general ledger and have marked the posting options to post to 
and post through the general ledger for inventory transactions.



If using SOP invoicing, we recommend that you enter all inventory and purchasing items as SOP transactions.
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About warranty accounts
You may select to use separate accounts for tracking replacement parts and reimbursements. When you have an 
invoice type defined for warranty transactions, creating a SOP document with that invoice ID automatically modifies 
the transaction window; if you select, this can include replacing the default posting accounts with designated 
"warranty" accounts.

Before completing warranty parts setup, think about the account masks that you want to overwrite the default sales, 
receivables, and COGS accounts for each line item. The main segment of each posting account is overwritten, and the 
resulting accounts are used on the transaction.

Example: 
Sales Account: 000-2110-00 
Sales Mask: 300-????-?? 
Resulting Account: 300-2110-00

If the account that would result from the mask does not already exist, the existing account will be used on the 
transaction. Before you set up account masks, make sure the resulting accounts are set up.

To determine which is the main segment in your accounts, select Microsoft Dynamics GP > Tools > Setup > Company > 
Account Format.

When you set up account masks, define only the main segment; this is the segment of the posting accounts that will be 
overwritten.

Setting up warranty parts processing through SOP
Complete the following steps to define when a SOP document will be used as a warranty transaction and how the 
standard SOP transaction will be modified.

Select Microsoft Dynamics GP > Tools > Setup > Service Management > Invoice Setup > Warranty Parts Setup.
Complete the following fields, as necessary:

Invoice ID
A SOP invoice of this type will function as a warranty transaction. You can zoom on this field if you want 
to create a new Invoice ID for this purpose. You can set up as many warranty invoice types as you like.
Tax Schedule ID
Select a tax schedule to fill onto the warranty transaction. If you leave this field blank, the tax schedule 
fills based on the customer.
Sales Mask, Receivables Mask, COGS Mask
If you want to use separate accounts to track replacement parts and reimbursements, define the main 
segments of the accounts that you want to use. These masks overwrite the main segments of the default 
posting accounts on the transaction. See About warranty accounts (page 128). If you select to leave these 
fields blank, the default accounts for either the item or the customer fill on the transaction, as defined in 
SOP setup.
Customer ID, Address
Select the customer that is assigned to the warranty and who will reimburse for the cost of the 
replacement part.
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Creating a warranty transaction
When creating an invoice in the Sales Transaction Entry window, entering the Invoice ID that is defined as a warranty 
transaction type allows you to track a warranty transaction instead of a sale.

Select Transactions > Sales > Sales Transaction Entry.
Complete any necessary fields, including the following:

Type
Select Invoice.
Type ID
Select an Invoice ID that was defined as a warranty transaction in the Warranty Parts Setup window.
Customer ID
Select the customer who is receiving the replacement item.
Customer PO Number
You can use this field to enter the warranty claim number.

After you select the type ID and customer, the following modifications occur to turn the sales transaction into a 
warranty transaction:

The tax schedule fills from the Warranty Parts setup window; if no Tax Schedule ID was assigned to the Invoice 
ID, the tax schedule defaults based on the customer.
The Salesperson and Territory that would normally default for a sale are removed when you create a warranty 
transaction. These fields will be empty if you view the sales Commission Entry window using the Commissions
button.
The transaction cannot be linked to a service call or job, and the option to do so no longer appears in the Sales 
User-Defined Fields Entry window (User-Defined button).
When you enter the Item Number of the replacement part, you may need to change the Unit Price if the amount 
that will be refunded for the item under warranty is different than its sale price. The main segments from each of 
the account masks that you defined in warranty parts setup overwrite the default posting accounts for the line 
item. If the account that is created by the mask does not exist, you receive an error message.

Use the Distributions button if you need to manually enter any accounts that do not default or view the posting 
accounts for the line item.

Setting up SOP Invoicing in Job Cost
If you are using SOP to bill jobs, you must assign the appropriate billing type and contract type to the job, and select the 
sales/revenue accounts to be used.

Step 1: Set up billing and contract types for jobs
To bill jobs using SOP, the jobs must contain a billing type of SOP and a contract type of Fixed Amount.

Enter or create a job as usual by choosing Cards > Job Cost > Job.
From the Contract Type drop-down list, select Fixed Amount.
From the Billing Type drop-down list, select SOP. 

Select Save.

You cannot change the billing type if unposted transactions exist for the job.
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Step 2: Select sales/revenue accounts
You can select whether to use Job Cost or SOP sales/revenue accounts for billing jobs.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Job Cost Setup > Posting Options.
In the Sales/Revenue Accounts for SOP Billing From section, select the accounts to be updated for billing SOP 
transactions. Choices include Job Cost and SOP. If you are using the revenue recognition percentage-of-
completion posting method, the Job Cost radio button is selected automatically and cannot be changed. If you 
select Job Cost, the accounts set up in the Invoice Accounts Setup window (Microsoft Dynamics GP > Tools > 
Setup > Job Cost > Account Setup > Invoice Accounts) will be used. If you select SOP, either the item or customer 
accounts will be used, as set in the Sales Order Processing Setup window (Microsoft Dynamics GP > Tools > Setup 
> Sales > Sales Order Processing).
Select Save.

When you're finished setting up SOP invoicing in Job Cost, you can enter and post inventory transactions using SOP.

Entering Inventory Transactions using SOP
You can enter and edit inventory transactions using SOP.

Step 1: Complete the sales transaction entry window.
Select Transactions > Sales > Sales Transaction Entry.
Enter line items, and use the expand button to enter details for each line entry.
Complete the window. See the Microsoft Dynamics GP Sales Order Processing Manual for more information. When 
a transaction is created for a quote, the transaction will have a $0 amount in Job Cost, although the information 
is saved in Microsoft Dynamics GP and is available when you transfer the quote.

Step 2: Enter job-related information.
Select User-Defined in the Sales Transaction Entry window.
Enter a Job Number and tab off the field. The job's billing type determines which window opens.

If the billing type is SOP, which indicates you are billing through SOP, the Signature SOP Transactions 
window opens.
If the billing type is not SOP, which indicates you are billing through Job Cost, the Sales Order Processing 
Transactions window opens.

Enter a Cost Code and select OK. 

•

•

•

Even though you can enter payments in the Amounts Received field of the Sales Transaction Entry 
window, those payments are not applied to the job. Therefore, we recommend that you enter 
payments using the Receivables Management.
When using SOP Billing on a job, to invoice labor, the item must have an item type of Services. Services 
item types do not pass costs to SOP Billing Jobs. These Services items will allow Labor to be invoiced 
without adding Labor costs that would be coming to the job from Time Track or GP Payroll. Item types 
are set up in the Item Maintenance window (Cards > Inventory > Item).
Though you can copy a SOP transaction that was entered in Service Management or Job Cost, the 
transaction information will not be updated in Service Management or Job Cost.


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Select OK in the Sales User-Defined Fields Entry window.
Save or post the sales order transaction.

Tracking Warranty Part Transactions through SOP
You can create warranty transactions that allow you to track warranty replacement items by customer. The standard 
sales transaction can be modified automatically to use different posting accounts for warranty item reimbursements 
and replacements that are used for new sales.

You have the options to create:

A warranty quote that can be transferred to an order warranty transaction or transferred directly to an invoice 
warranty transaction.
A warranty order that can be transferred to a warranty invoice. If you have transferred the warranty quote to a 
warranty order, you can then transfer the warranty order to a warranty invoice.
A warranty invoice (without needing to create a warranty quote or warranty order).

About warranty accounts
You may choose to use separate accounts for tracking replacement parts and reimbursements. When you have an 
invoice type defined for warranty transactions, creating an SOP document with that invoice ID automatically modifies 
the transaction window; if you choose, this can include replacing the default posting accounts with designated 
"warranty" accounts.

Before completing warranty parts setup, think about what accounts you want to overwrite the default sales, 
receivables, COGS accounts for each line item. You can choose between account masking, where the main segment of a 
posting account is overwritten; or account substitution, where an entire account is substituted for the default account.

Account masking

The main segment of each posting account is overwritten, and the resulting accounts are used on the transaction.

For SOP billing-type jobs, you cannot add a new cost code if the invoice contains an item with an item 
type of Services.


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The association between the job and the inventory transaction is broken after you save the window. If 
you want to enter multiple inventory transactions without exiting the transaction window, make sure 
you re-select a job for each transaction. This ensures the document is linked to the job as an inventory 
transaction and does not result in the creation of an accounts receivables transaction.
Once you have saved the Signature SOP Transactions or Sales Order Processing Transactions window, 
you can access the window thereafter using the expansion button attached to the Job Number field in 
the Sales User-Defined Fields Entry window.
When you save an invoice or return, the costs are increased in the Committed Costs column of the Job 
Status window (Inquiry > Job Cost > Job Status). When you post an invoice or return (if posting to Job 
Cost), the costs move from the Committed Costs column to the Posted Costs column in the Job Status 
window. Because only invoices and returns can be posted, orders and back orders must be transferred 
to an invoice before they can be posted.
If the Enable Quantity Cancelled in the Sales Order Fulfillment checkbox is marked in the Microsoft 
Dynamics GP Sales Fulfillment Order/Invoice Setup window, the committed cost on Job Cost invoices 
will be reduced.


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Example: Sales Account: 
000-2110-00
Sales Mask: 300-????-??
Resulting Account: 300-2110-00

When you set up account masks, define only the designated segment; this is the segment of the posting accounts that 
will be overwritten.

Account substitution

You can also substitute an entire account instead of a segment only. Use the Accounts button on the Warranty Parts 
Setup window to choose the default account and then choose an existing account to use as a substitute.

Related topics:

Setting up Warranty Parts Processing through SOP (page 132)
Creating a Warranty Transaction (page 134)

Setting up Warranty Parts Processing through SOP
Complete the following steps to define when a SOP document will be used as a warranty transaction and how the 
standard SOP transaction will be modified.

Step 1: Creating a warranty invoice type (page 132)
Step 2: Completing the Warranty Parts Setup window (page 133)
Step 3: Setting up a warranty order type (page 133)
Step 4: Setting up a warranty quote type (page 133)

Step 1: Creating a warranty invoice type

You must create a warranty invoice type in the Sales Fulfillment Order/Invoice Setup window.

Choose Microsoft Dynamics GP > Tools > Setup > Sales > Sales Order Processing > Sales Document Setup > 
Fulfillment Order/Invoice.
Enter an invoice type to be used for warranty transactions. You can set up as many warranty invoice types as you 
like.
Complete the remaining fields as necessary. For more information, see the Microsoft Dynamics GP Sales Order 
Processing documentation.
Choose Save.

If the account that would result from the mask does not already exist, the default account will be used on the 
transaction. Before you set up account masks, make sure the resulting accounts are set up.



The substitution accounts set up in the Accounts window are used for all warranty invoices. If you need to set 
up substitute accounts for different warranty invoices, you may want to consider using account masking.


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Step 2: Completing the Warranty Parts Setup window 

The Warranty Parts Setup window is used to define the SOP warranty transfer invoice.

Choose Microsoft Dynamics GP > Tools > Setup > Service Management > Invoice Setup > Warranty Parts Setup.
Complete the following fields, as necessary.

Invoice ID
A SOP invoice of this type will function as a warranty transaction. You can zoom on this field if you want 
to create a new Invoice ID for this purpose. You can set up as many warranty invoice types as you like.
Tax Schedule ID
Select a tax schedule to fill onto the warranty transaction. If you leave this field blank, the customer tax 
schedule is used.
Customer ID/Address
Select the customer that is assigned to the warranty and who will reimburse for the cost of the 
replacement part. For example, a corporate ID would be used if that is who would be reimbursing your 
company for a warrantied part replacement.
Sales Mask, Receivables Mask, COGS Mask
A SOP invoice of this type will function as a warranty transaction. You can zoom on this field if you want 
to create a new Invoice ID for this purpose. You can set up as many warranty invoice types as you like.

If you want to substitute account numbers for Sales, Receivables, or COGS, choose the Accounts button. The 
substitution accounts set up in the Accounts window are used for all warranty invoices.
In the Accounts window, enter or choose the original account number for Sales, Receivables, and/or Cost of 
Goods sold.
Enter or choose the corresponding account number that will be substituted.Complete the steps for the 
remaining accounts.
Choose OK to return to the Warranty Parts Setup window. If you enter both an account mask and a substitute 
account for a default account, only the substitute account will be used for the warranty invoice transfer.
Choose Save.

Step 3: Setting up a warranty order type 

If you want to transfer a warranty order to a warranty invoice, you must set up a warranty order type that specifies the 
warranty invoice the transfer will process to. To set up a warranty order type, you will need enter a warranty invoice 
type in the Use Fulfillment Invoice ID in the Sales Order Processing Setup window.

To open the Sales Order Setup window, choose Microsoft Dynamics GP > Tools > Setup > Sales > Sales Order 
Processing > Sales Document Setup > Order.
Enter an Order ID to be used for warranty transfers.
In the Use Fulfillment Order/Invoice ID, choose the warranty invoice type.
Choose Save.

Step 4: Setting up a warranty quote type 

If you want to transfer a warranty quote to either a warranty order and/or a warranty invoice, you must set up a 
warranty quote type to specify the warranty order and/or warranty invoice the transfer will process to. To set up a 
warranty quote type, you will need enter a warranty order type in the Use Fulfillment Order ID and/or warranty invoice 
type in the Use Fulfillment Invoice ID field in the Sales Quote Setup window.
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To open the Sales Quote Setup window, choose Microsoft Dynamics GP > Tools > Setup > Sales > Sales Order 
Processing > Sales Document Setup > Quote.
Enter a Quote ID to be used for warranty transfers.
Mark the Transfer Quote to Fulfillment Order/Invoice checkbox.
In the Use Fulfillment Order/Invoice ID, choose the warranty order or warranty invoice type.
Choose Save.

Creating a Warranty Transaction
To create a warranty transaction in the Sales Transaction Entry window, choose the ID that is defined as a warranty 
transaction type to track a warranty transaction.

Choose Transactions > Sales > Sales Transaction Entry.
Complete the following fields, as necessary.

Type
Choose the type of transaction you are creating: Quote, Order, or Invoice.
Type ID
Choose the warranty ID that was defined as a warranty transaction.
Customer ID
Choose the customer who is receiving the replacement item.
Customer PO Number
You can use this field to enter the warranty claim number.

After you select the Type ID and customer, the following modifications occur to process the sales transaction as 
a warranty transaction:
The customer entered in the Sales Transaction Entry window who is returning the part will display on the 
transaction, however once the warranty invoice is posted, the customer entered in the Warranty Parts Setup 
window can be billed.
The tax schedule fills from the Warranty Parts setup window; if no Tax Schedule ID was assigned to the Invoice 
ID, the tax schedule defaults based on the customer.
The Salesperson and Territory that would normally default for a sale are removed when you transfer a warranty 
quote or a warranty order to a warranty invoice. These fields will be empty if you view the Sales Commission 
Entry window using the Commissions button for the warranty invoice.
The transaction cannot be linked to a service call or job, and the option to do so no longer appears in the Sales 
User-Defined Fields Entry window (User-Defined button).
When you enter the Item Number of the replacement part, you may need to:
Change the Unit Price if the amount that will be refunded for the item under warranty is different than its sale 
price. 

Verify the quantity to transfer is correct. Click the Show/Hide button to display the Quantity to 
Order or Quantity to Invoice. The segments from each of the account masks or account substitutions that you 
defined in warranty parts setup overwrite the default posting accounts for the line item.Use 
the Distributions button if you need to manually enter any accounts or view the posting accounts for the line 
item. 

To complete the transaction entry:
Quote
Enter a batch ID, choose Action, and then choose Transfer.

If the unit price is zeroed out, the COGS and Inventory will still contain the dollar values and will post 
with the invoice.



If the account that is created by the mask does not exist, the default account will be used.
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Order
Enter a batch ID, choose Action, and then choose Transfer.
Invoice
Choose Action, and then choose Post.

Entering Payroll Transactions in Job Cost
You can enter payroll transactions in the Microsoft Dynamics GP Payroll Transaction Entry window and assign each 
transaction to a job.

The Microsoft Dynamics GP Payroll module must have been purchased to enter payroll transactions.

Entering payroll transactions involves the following:

Step 1: Complete the Payroll Transaction Entry window (page 135)
Step 2: Enter job-related information (page 135)
Step 3: Build checks (page 136)
Step 4: Post payroll transactions to Job Cost (page 136)
Step 5: Calculate and print checks. (page 138)

Step 1: Complete the Payroll Transaction Entry window
Select Transactions > Payroll > Transaction Entry. The following message displays: Did you know you can use the 
Payroll Mass Transaction Entry window instead, to enter several similar pay transactions at the same time?
Select Transaction Entry. The Payroll Transaction Entry window opens.
Complete the window. See the Microsoft Dynamics GP Payroll Manual for more information. Overtime and 
doubletime functionality has no effect on Job Cost transactions.

Step 2: Enter job-related information
To assign a transaction to a job, you must select a transaction type of Pay Code and a pay code with a pay type of 
Hourly, Overtime, Double Time, Vacation, Sick, or Holiday.

Select the show details button and complete the additional fields:
Date From, Date To
To print certified payroll reports accurately, the beginning and ending dates entered in the Build Payroll 
Checks window must match the beginning and ending dates in the Payroll Transaction Entry window for 
the transactions in the given certified payroll pay period.
Position
Enter the employee's position.
Shift
Shift premiums cannot be applied to Job Cost transactions. You can apply a shift ID to the transaction, 
but it cannot have a premium.
Product
Select Job Cost. Unbilled is for Microsoft Dynamics GP general ledger transactions.

If you marked the Payroll Post to Job Cost Only checkbox in the Posting Options window, your payroll batch 
will be deleted after posting the batch to Job Cost. Also, you can select to have Microsoft Dynamics GP Payroll 
offset your Job Cost payroll offset credit. This would be offset by the gross wage entry by department, 
position, and pay code.


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Job Number, Cost Code
If you enter a certified payroll job in the Job Number field, the Certified Payroll Entry window opens 
automatically for you to distribute the hours. Distribute the hours using a separate entry for each day of 
the week.

Zoom on the Product field to open the Job Cost Payroll Entry window. The payroll transaction is saved when you 
zoom on the Product field. In the Job Cost Payroll Entry window, you can enter a transaction description, rate 
class, union, federal class code, number of overhead units and production units, and estimated percent 
complete. 

Select Save and close the Job Cost Payroll Entry window.
To move to the next transaction, select Next in the Payroll Transaction Entry window.

Step 3: Build checks
You can build checks to pay employees for their work. Conditions that apply to building checks include:

If you marked the setup posting option Payroll Post to Job Cost Only, you do not need to build checks before 
posting the transactions to Job Cost.
If you use Microsoft Dynamics GP Payroll to print payroll checks, include the job-related batches in the build 
process before printing an edit list or posting.

Microsoft Dynamics GP uses the employee pay rate when you build checks to print and post payroll transactions to the 
Microsoft Dynamics GP Payroll module. Job Cost uses the pay rate for the employee when the transaction is entered. If 
you enter job payroll transactions daily and change an employee's pay rate in the middle of a pay period, transactions 
may post to Payroll and Job Cost at different pay rates.

Select Transactions > Payroll > Build Checks.
Complete the Build Payroll Checks window. See the Microsoft Dynamics GP Payroll Manual for information on 
completing this window.

Step 4: Post payroll transactions to Job Cost
The Job Cost posting process creates a journal entry that does the following:

Debits the general ledger account number(s) for the labor cost codes selected.
Credits the payroll and overhead offset accounts for the associated job labor and overhead costs. See Setting up 
revenue accounts (page 46).

The rate class you enter in the Rate Class field will override the rate class that is assigned to an 
employee (in the Employee Maintenance Codes window) or assigned to a job (in the Job Maintenance 
window).



Once a transaction is assigned to a job and saved, you cannot change the Product field. You must delete the 
transaction and reenter the information.



If you post payroll transactions to accounts in Job Cost, do not change employee pay rates until checks print 
and process for all transactions entered with the old pay rate.


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Select Transactions > Payroll > Signature Payroll Posting. 

Posting Date
Enter a posting date.
Display Batches
Select to display batches created by all users or by the current user only. The batches are marked in the 
Job Cost or Service column to let you know the contents of that batch. If a batch contains transactions 
attached to a job number or service call ID, the appropriate column(s) will be marked with an asterisk *.
Status
Mark the checkbox in this column to select the batches you want to post.
Post Job Cost, Post Service
Mark these checkboxes, as desired. 

Select Post.

After completing the Job Cost posting process, the batch of Job Cost payroll transactions can be included in the next 
batch of printed payroll checks.

Job Cost batches may not be available to post prior to building checks, depending upon Job Cost setup and validation 
performed in this window. However, a batch that contains both Job Cost and Service-related transactions will be 
available to a user who wants to post only the Service related contents of a batch. Unless posting to Job Cost is selected 
along with Service, all job-related transactions will remain unposted in the batch and only the Service related 
transaction will be posted and Microsoft Dynamics GP payroll transactions deleted. This allows for Job Cost and Service 
to be posted at separate times, as required by the business processes of each product.

Distribution of payroll transactions
The general ledger journal entry for each payroll transaction distributes as follows:

Debit amounts
Debit amounts distribute to the -labor or other general ledger account you defined for the cost code entered in 
the Payroll Transaction Entry window. The debit amount equals the total labor cost posted, including overhead.
Credit amounts
The payroll and overhead offset credit amounts post to the default overhead and payroll offset credit accounts 
defined in the Revenue and Exp Account Setup window, based on a job's assigned division. The following 

•
•

•

•

You cannot print or process your payroll if you do not complete the Job Cost Posting process.
See Distribution of payroll transactions below for information on how payroll transactions are 
distributed in the general ledger.
If you changed overhead detail codes (or created new codes and assigned them to affected overhead 
accounts) since the unposted transactions were entered, DO NOT proceed to post these transactions. 
Posting these transactions could result in unbalanced general ledger entries. Contact WennSoft 
Support for assistance.
(rate classes) If you are posting payroll transactions on a daily, when you calculate checks, benefits/
deductions will only be calculated for one day instead of five. Therefore, when using rate classes, you 
cannot run Job Cost Posting daily; only once a week.



You can only post the batches marked by the user that is logged in.

If you are not using Service Management or you are, and the Service Invoicing feature is not 
registered, or the Post to Service Only option is not marked in invoice options, the Post Service 
checkbox will be disabled.


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example shows a typical Job Cost payroll posting entry. Overhead calculates automatically based on the 
overhead group code you assigned to the employee's department and position. See Setting up Overhead Group 
Codes (page 53) for more information on how Job Cost automatically calculates overhead for payroll transactions.

Account Account Description Debit Credit

000-1411-00 Labor $1135.47

000-2135-00 Accrued Payroll $959.47

000-2125-00 Benefits Allowed $176.00

Step 5: Calculate and print checks.
See the Microsoft Dynamics GP Payroll Manual for more information on calculating and printing checks.

Processing Payroll with Union Rate Classes (optional)
When processing payroll with union rate classes, perform the following steps.

Set up rate classes in Job Cost. See Setting up Rate Classes for Union Payroll (page 55).
Enter payroll transactions. See Entering Payroll Transactions in Job Cost (page 135). 

When processing payroll with rate classes, consider the following:

If you are posting payroll transactions on daily, when you calculate checks, benefits/deductions will only 
be calculated for one day instead of five. Therefore, when using rate classes, you cannot run Job Cost 
Posting daily; only once a week.
Rate classes work only with the Microsoft Dynamics GP Payroll and Signature TimeTrack modules.
You can enter/change the rate class when entering payroll transactions. This change affects only that 
transaction.
When building payroll checks, make sure to include benefits and deductions in the calculations.
Rate classes work only with Job Cost labor cost elements.
When entering payroll transactions, do not enter a rate class for non-union employees.
You can assign a rate class to a labor transaction in TimeTrack. See "Entering labor transactions" in 
the TimeTrack User Manual for more information.

Example Rate Class Scenarios
This section includes example scenarios on how you can use rate class to satisfy your complex union payroll needs. The 
first example takes you through from setup to calculating payroll checks (including sample windows), and show how 
the system calculates your payroll based on the setup criteria given. The remaining examples illustrate additional 
combinations of rate classes.

Example 1: Employee works on a heavy commercial job as a temporary Foreman (page 139)
Step 1: Set up rate classes (page 139)
Step 2: Assign rate class MILW-HVYCOMM to the HVYCOMM job (page 140)
Step 3: Create payroll transactions for ALAN (page 140)
Step 4: Build checks (page 141)
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Step 5: Calculate checks (page 141)
Step 6: Post payroll transactions to Job Cost (page 141)

Example 2: Two employees work on the same job, each with his own union (one a Pipefitter, the other an 
Asbestos worker). They both work in Milwaukee on a light commercial job, and are assigned to the same rate 
class. (page 142)

Step 1: Set up rate classes (page 142)
Step 2: Assign rate class LIGHT-COMM-MILW to the LIGHT-COMM JOB (page 143)
Step 3: Create payroll transactions for ALAN and CHARLEY (page 143)
Step 4: Build checks (page 145)
Step 5: Calculate checks (page 145)
Step 6: Post payroll transactions to Job Cost (page 145)

Example 3: Employee works on two jobs in one week, at two different locations, for two different unions, two 
rate classes (page 145)

Step 1: Set up rate classes (page 146)
Step 2: Assign rate class CHIC-HVYCOMM to the HVYCOMM-CHIC job (page 147)
Step 3: Create payroll transactions for ALAN (page 147)
After creating transactions, save and commit the batch. A snapshot of part of the Signature Time Card 
Commit report appears on the next page. Step 4: Build checks (page 148)
Step 5: Calculate checks (page 148)

Example 4: Employee works on a job for a different union local, and has been approved to get paid the higher 
rate, which happens to be his home union local (page 148)

Example 1: Employee works on a heavy commercial job as a temporary Foreman 

In this example, an employee, ALAN FLINT, works on a heavy commercial job as part of union Local 7 - Pipefitters in 
Milwaukee. His job title (position) is normally Journeyman, but on this job, he is Foreman.
FLINT's normal pay rate, as set up in his employee record, is $27.00/hour. Conversely, a Foreman's general pay rate 
is $37.00/hour. But because a) ALAN is going to be a temporary Foreman on this job, and b) the pay rate increases 
to $40.00/hour for a Foreman on heavy commercial jobs, the system needs to determine ALAN's payroll at the adjusted 
rate; that rate will be set up as a rate in Rate Class setup.
ALAN's company will set up their rate class by location/job type.

Step 1: Set up rate classes 

In this step, we will set up a rate class called MILW-HVYCOMM. Sample data used is summarized below, followed by 
sample screen shots.
Microsoft Dynamics GP > Tools > Setup > Job Cost > Payroll Setup > Rate Class. The Rate Class Setup window opens.

Rate Class: MILW-HVYCOMM
Union Code: Local7
Position: Pipefitter Foreman
Deduction Code: DUES (union dues) = $0.50/unit
Benefit Code: PENS (pension) = $3.00/unit
Pay Rate: $40.00/hour
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See the sample screenshots below:

Rate Class Setup

All we had to do here is set up a rate class with the appropriate union/pay rate/etc. combination; nothing needed to be 
changed at the employee record level (then subsequently changed back again). We set up a pay rate for a Journeyman 
and Foreman, to illustrate the difference.

When ALAN goes back to being a Journeyman, his pay rate, deductions, benefits, and so on, will be calculated based on 
the conditions at that time. On his next job, he might be a Journeyman again, and his pay rate could come from his 
employee record, or if driven by the job, another rate class could be set up then.

Step 2: Assign rate class MILW-HVYCOMM to the HVYCOMM job 

In this step, we will assign the rate class MILW-HVYCOMM to a job called HVYCOMM. This will allow us to apply the 
correct payroll costs (based on rate class and union) to the job.
Cards > Job Cost > Job. The Job Maintenance window opens. Select the job. In the Rate Class field, select the MILW-
HVYCOMM rate class. Because multiple unions are assigned to this rate class, you will select the union when entering 
payroll transactions for each employee.

Step 3: Create payroll transactions for ALAN 

In this step, we will create payroll transactions for ALAN. In this example, we will create the transaction using the 
TimeTrack Time Card Entry window. When you select the job, the pay rate as specified with the MILW-HVYCOMM rate 
class will automatically fill into this window.
In addition, because ALAN is classified as a Pipefitter Journeyman, but instead is a Pipefitter Foreman on this job, you 
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must edit the Position code for each transaction (using the expansion button next to the Pay Code field to open the Edit 
Payroll Fields window).

Batch: HVY-COMM
TRX Type/Cost Type: JOB COST
Job Number: HVYCOMM
Cost Code: 00-1000-001

After creating transactions, save and commit the batch. A snapshot of part of the Signature Time Card Commit report 
displays below.

Step 4: Build checks 

Transactions > Payroll > Build Checks. Select the batch, then select Post.

Step 5: Calculate checks 

Transactions > Payroll > Calculate Checks. The Calculate Payroll Checks window opens. Select OK to begin the calculate 
process.

Step 6: Post payroll transactions to Job Cost 

In this step, we will post the payroll transactions for ALAN using the Signature Payroll Post feature.
Transactions > Payroll > Signature Payroll Posting. The Signature Payroll Post window opens. Select the appropriate 
batch.

What is posted to Job Cost?

Because we can change the Position during payroll transaction entry, we do not affect the employee record at 
all; ALAN is still classified, by default, as a Pipefitter Journeyman.


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You can view posted costs that include rate class pay rates, deductions, and so on, just as you would any payroll 
transaction,

Inquiry > Job Cost > Job Status. The Job Status window opens.
Drill down all the way to the Payroll Entry Zoom window (Drill on Posted Costs, Cost Code, Actual Cost Amount, double-
click a transaction).

Zoom on the posted costs amount until you reach the Payroll Transaction Summary window. This window shows a 
breakdown of costs posted. The window below shows a breakdown of costs for our fictitious employee ALAN.

Gross wages = $320.00 ($40 * 8)
Overhead calculation: 
Benefit - $6 * 8 hours = $48.00
Burden - $10 * 8 hours = $80.00
ETax – 15% of $320.00 = $48.00
W/C – 7% of $320.00 = $22.40
Total overhead amount: $198.40 
Total amount applied to the job: $320.00 + $198.40 = $2,592.00 ($518.40 * 5)

Example 2: Two employees work on the same job, each with his own union (one a Pipefitter, the other an 
Asbestos worker). They both work in Milwaukee on a light commercial job, and are assigned to the same rate 
class. 

In this example, our fictitious employees, ALAN FLINT and CHARLEY NICK, work on the same job in the same week. ALAN 
is back to being a Journeyman Pipefitter, and is classified as such on this job. CHARLEY is an Asbestos Journeyman 
Class II.
ALAN's pay rate is $27.00/hour.; CHARLEY's is $35.00/hour. In addition to the pay rates being different, their benefits 
and deductions also vary between the two positions.

Step 1: Set up rate classes 

In this step, we will set up a rate class called LIGHT-COMM-MILW. Sample data used is summarized below, followed by 
sample screen shots.
Microsoft Dynamics GP > Tools > Setup > Job Cost > Payroll Setup > Rate Class. The Rate Class Setup window opens.

Rate Class: LIGHT-COMM-MILW
Union Codes: Local7 and Local6
Positions: PF-TM (Pipefitter Journeyman) and IBJ3 (Asbestos Journeyman Class II)
Deduction Codes: DUES (union dues) = $0.75/unit and .0.85/unit
Benefits: PENS (pension) = 3% of gross wages for both unions.
Pay Rates: $27.00/hour and $35.00/hour
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Rate Class Setup

 

Step 2: Assign rate class LIGHT-COMM-MILW to the LIGHT-COMM JOB 

In this step, we will assign the rate class LIGHT-COMM-MILW to a job called LIGHT-COMM (for light commercial work). 
This will allow us to apply the correct payroll costs (based on rate class and union) to the job.

Cards > Job Cost > Job. The Job Maintenance window opens. Select the job. In the Rate Class field, select the LIGHT-
COMM-MILW rate class. Because multiple unions are assigned to this rate class, you will select the union when entering 
payroll transactions for each employee.

Step 3: Create payroll transactions for ALAN and CHARLEY 

In this step, we will create payroll transactions for ALAN and CHARLEY In this example, we will create the transaction 
using TimeTrack Time Card Entry window. When you select the job, the pay rate as specified with the LIGHT-COMM-
MILW rate class will automatically fill into this window. After, we will save and commit the batch.
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Step 4: Build checks 

Transactions > Payroll > Build Checks. Select the batch, then select Post.

Step 5: Calculate checks 

Transactions > Payroll > Calculate Checks. The Calculate Payroll Checks window opens. Select OK to begin the calculate 
process.

Step 6:    Post payroll transactions to Job Cost 

In this step, we will post the payroll transactions for ALAN using the Signature Payroll Post feature.

Transactions > Payroll > Signature Payroll Posting. The Signature Payroll Post window opens. Select the appropriate 
batch.

Example 3: Employee works on two jobs in one week, at two different locations, for two different unions, two 
rate classes 

In this example, our fictitious employee, ALAN FLINT works on two different jobs in the same week, for two different 
union locals. On both jobs, he is classified as a Journeyman Pipefitter.

The first job is in his home union local, Milwaukee. He will be receiving his regular pay rate of $27.00/hour. The second 
job is in Chicago, and the Pipefitters union there pays their Journeyman at $32.00 per hour; ALAN will be receiving that 
higher rate while on the Chicago job. In addition, ALAN's benefits will change with the Chicago union local, which he will 
inherit for the period within which he is on that job.
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ALAN's company must set up the rate class feature to account for that higher pay rate in Chicago. We could set up a new 
record that covers the Chicago union in the existing rate class: MILW-HVYCOMM. However, because we have organized 
rate classes by location-job type, we will set up an entirely new rate class for Chicago, as ALAN's company will be doing 
a lot of work there over the next year.

Step 1: Set up rate classes 

In this step, we will set up a rate class called CHIC-HVYCOMM. Sample data used is summarized below, followed by 
sample screen shots. In addition, this example will also use the MILW-HVYCOMM rate class that was used in Example 1.
Microsoft Dynamics GP > Tools > Setup > Job Cost > Payroll Setup > Rate Class. The Rate Class Setup window opens.

Rate Class: CHIC-HVYCOMM
Union Code: Local7
Position: Pipefitter Foreman
Deduction Code: DUES (union dues) = $0.75/unit
Benefit Code: PENS (pension) = $3.50/unit
Pay Rate: $32.00/hour
Rate Class: MILW-HVYCOMM
Union Code: Local7
Position: Pipefitter Foreman
Deduction Code: DUES (union dues) = $0.50/unit
Benefit Code: PENS (pension) = $3.00/unit
Pay Rate: $40.00/hour

Rate Class Setup

Although we decided to create an entirely new rate class name, because of the Chicago location, you can 
organize your rate class hierarchy any way you want. For example, instead of by location and type of job, we 
could have set it up only based on the type of job, for example, light vs. heavy commercial jobs, and so on.


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Step 2: Assign rate class CHIC-HVYCOMM to the HVYCOMM-CHIC job 

In this step, we will assign the rate class CHIC-HVTCOMM to a job called HVYCOMM-CHIC. This will allow us to apply the 
correct payroll costs (based on rate class and union) to the job.

Cards > Job Cost > Job. The Job Maintenance window opens. Select the job. In the Rate Class field, select the CHIC-
HVYCOMM rate class. Because multiple unions are assigned to this rate class, you will select the union when entering 
payroll transactions for each employee.

Step 3: Create payroll transactions for ALAN 

In this step, we will create payroll transactions for ALAN. In this example, we will create the transaction using TimeTrack 
Time Card Entry window. ALAN is working in Milwaukee on Monday and Tuesday, then in Chicago on Wednesday 
through Friday.

The first two transactions will use the HVYCOMM job, MILW-HVYCOMM rate class, and the Local 7 union; the last three 
transactions will use the HVYCOMM-CHIC job, CHIC-HVYCOMM rate class, and the Local 8 union. The position will 
be PF-TM (Pipefitter Journeyman) for all transactions. We must edit some fields (using the expansion button next to the 
Pay Code field to open the Edit Payroll Fields window).

A summary of the data entry values appears below:

Batch: HVY-COMM
TRX Type/Cost Type: JOB COST
Job Number: HVYCOMM
Cost Code: 00-1000-00
Rate Class: MILW-HVYCOMM
Union Code: Local7
Batch: HVY-COMM
TRX Type/Cost Type: JOB COST
Job Number: HVYCOMM-CHIC
Cost Code: 00-1000-00
Rate Class: CHIC-HVYCOMM
Union Code: Local8
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After creating transactions, save and commit the batch. A snapshot of part of the Signature Time Card Commit 
report appears on the next page.

 
Step 4: Build checks 

Transactions > Payroll > Build Checks. Select the batch, then select Post.

Step 5: Calculate checks 

Transactions > Payroll > Calculate Checks. The Calculate Payroll Checks window opens. Select OK to begin the calculate 
process.

Example 4: Employee works on a job for a different union local, and has been approved to get paid the higher 
rate, which happens to be his home union local

This example uses TimeTrack for payroll transactions.
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Employee, WILLIE GREEN, is working on a job for the Sheet Metal Local Appleton union. His home union is Milwaukee, 
and he is performing the same duties in Appleton as does in his home union. In spirit of reciprocity, the Appleton local 
has agreed to pay Willie his home rate, which is the higher rate of the two unions.

For purposes of this example, we will assume that the User higher pay rate checkbox has been marked for all rate 
classes in the Job Cost system. This example uses TimeTrack.

Pay rates: 
Our fictitious system is set up with the following pay rates:

Job pay rate (from a rate class assigned to job): $23.45/hour

Home union pay rate (from a rate class assigned to employee): $26.75

Pay code pay rate: $20.00

Transaction: 
We will create TimeTrack transaction for WILLIE GREEN and show that the system will use the highest pay rate of the 
three.

The Pay Rate filled correctly with $26.75.

In the Edit Payroll Fields window (expansion button in Pay Code field), the Rate Class fills from the job, and the Union 
from employee. Because the rate class and union code for Willie's union differ from the Milwaukee union, we must 
change the union.

 
After changing the union. the Window looks like this:

 
If you create more transactions for this job, and the unions differ, you must change the Union field in the Edit Payroll 
Fields for every transaction.
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Entering Job Transactions
When you enter a transaction in the Job Transaction Entry window, you create a general ledger entry with Job Cost 
information. You can enter job transactions for any cost element type, including labor. Job transaction entries update 
Job Cost and the general ledger when they post.

The Job Transaction Entry window serves as a viable transaction entry alternative if you do not use the Microsoft 
Dynamics GP Payables Management, Inventory, or Payroll module, as you can also enter a quantity for each line item.

Step 1: Enter transaction information
Select Transactions > Job Cost > Job Transaction Entry.
Enter a Journal Entry Number and Batch ID. 

Select a Transaction Type of Standard or Reversing.

Step 2: Enter audit trail information
Enter a Transaction Date or Reversing Date.
Enter a Source Document and Reference. For Transaction-Level billing type jobs, the information you enter in 
the Reference field will appear on customer invoices. That information should be relevant to what you want the 
customer to see on the invoice. If you do not make an entry, a line item will have a dollar amount with no 
description.

Audit trail information appears on posting journals and can be used by external auditors to verify the accuracy of your 
record-keeping processes.

Step 3: Enter job-related information
Enter a Job Number.
Enter the Cost Code that the debit or credit amount applies to. The transaction distributes automatically to the 
posting account assigned to the cost code in the Job Cost Codes Setup window.
Enter a Debit or Credit amount.
Enter Offset Account Information. If you enter credit amounts, do not enter a job number or cost code unless 
you are certain you want to credit a job and cost code for the credit amount of the transaction.
Enter a Quantity. You must enter a number other than zero.

We recommend that you do not re-number journal entries after they've been used. Also, do not enter a 
previously used journal entry number as the Journal Entry field will skip a number and insert the next 
number.



A reversing transaction automatically reverses in both Job Cost and the general ledger on the date you specify 
in the Reversing Date field.


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Step 4: Print an edit list
To print a Job Transaction Edit List with job detail before posting, select File > Print.

Step 5: Post or save the transaction
Select Save to save the transaction or Post to post the transaction.

Job Cost detail appears for each transaction posted real-time when you close the Job Transaction Entry window. 
Depending on how you set up financial series posting in Microsoft Dynamics GP, you can print a posting journal for 
batch postings.

Entering Job Transactions by Labor Rate and Employee
You enter billable transactions by labor rate and employee using the Job Transaction Entry Employee window.

Select Transactions > Job Cost > Job Transaction Entry.
Complete the Job Transaction Entry window as usual. See Example 4 (page 148) more information.
Enter a job number and cost code with a profit type of 9. The Job Transaction Entry Employee window opens 
when you select a cost code from the lookup or after you enter a cost code manually and tab off the field.
Complete the following fields, as necessary.

Employee ID
The service labor rate group is set automatically to the group assigned to the cost code in the Master Cost 
Code Setup window.
Department, Position, Pay Code
The department and position fields come from the Employee Maintenance window.
Billing Amount
This field comes from the service labor rate group.
Debit/(Credit), Quantity
Enter a Debit/(Credit) amount and Quantity. The Quantity field represents the number of hours to be 
billed.

Select OK. The debit or credit amount and quantity are copied into the Job Transaction Entry window.
Finish completing the Job Transaction Entry window.
Save or post the transaction.

To make changes to the Job Transaction Entry Employee window after the window has been saved, select the 
expansion button next to the Quantity field in the Job Transaction Entry window. Select OK to the message stating that 
you need to complete the Job Transaction Entry Employee window.

Entering Job Invoices
You can enter job invoices to bill customers in the Job Invoice Entry window. You must purchase the Microsoft 
Dynamics GP Receivables Management module to use the invoicing feature.

A user needs proper security to display Job Cost detail (job number and cost code) on the general posting 
journal for batch posting. See Setting up security (page 15).


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In the Job Invoice Entry window, you can:

Enter credit memos.
Enter a Bill To customer that is different from the Job customer.  When you update the Bill To customer, the Bill 
To address that is designated in Customer Maintenance defaults to the Bill To address field. You can change this 
address if needed.
Enter job invoices using the optional Signature Multicurrency Management feature. You can designate an 
originating currency for standard job invoices and credit memos through the Job Invoice Entry window. 
Amounts display in the functional currency and print in the originating currency. The functional currency is the 
primary currency in which a company maintains its financial records. Typically, the functional currency is the 
currency of the country where the company is located. The originating currency is the currency that a 
multicurrency transaction was conducted in. To use Signature Multicurrency Management, you must have 
purchased Microsoft Dynamics GP Multicurrency Management. Refer to the Microsoft Dynamics GP Multicurrency 
Management Manual for setup procedures. Multicurrency is not functional with the Job Cost Project Level 
feature.
Assign a sales GL account to each bill code when creating job invoices. In addition, you can include fully billed 
bill codes on an invoice. You can assign accounts at the job level and override them at job invoice entry. For 
information on setting this up, see Assigning Sales GL Accounts to Bill Codes for Job Invoices (page 156).

Entering a job invoice (page 152)
Printing batch invoices (page 155)

Assigning GL Accounts on Jobs and Job Invoices (page 155)
Assigning Sales GL Accounts to Bill Codes for Job Invoices (page 156)
Entering Scheduled Billing Information (page 157)
Entering Standard Billing Information (page 158)
Entering Transaction-Level Billing Information (page 158)
Generating Invoices for Retention (page 160)

Entering a job invoice
Select Transactions > Job Cost > Job Invoice Entry.
Complete the following fields, as necessary.

Document Type
Select a document type from the drop-down.
Document Number
Tab to this field to display the default number.
Job Number, Job Name
Enter a Job Number. The Job Name defaults from the Job Number.
Bill To Customer, Bill To Customer Name
These fields default from the selected job. You can accept the default or you can select a different 
customer. 

You must enter job invoices through Job Cost to update billed information for jobs. Do not enter job invoices 
through the Receivables Transaction Entry window.



You can save only one unposted document to a Cost Plus transaction level job.

If you select a different customer, the Bill To address that prints on the invoice is the Bill To 
address set up in Customer Maintenance.


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Job Customer ID, Job Customer Name
These fields default from the job number selection. The job name, customer ID, customer name, tax 
schedule ID, and retention percent default from this selection.
Date
The date will determine the exchange rate in multicurrency transactions. 

Batch ID
Enter a single-use Batch ID. You cannot use a recurring batch.
Tax Schedule ID, Retention Percent
These fields default from the job number selection. 

PO Number
This number is printed as the customer order number on the invoice.
Currency ID
Enter the Currency ID, which comes from the Bill To Customer ID.

If you are using the Signature Multicurrency Management feature, you can change the currency ID. 
Amounts will print in the originating currency and display in the functional currency.
If you are not using Multicurrency Management, the Currency ID field will be disabled.
Multicurrency Management is used with Standard billing type jobs and cannot be used with 
customers with balance forward accounts.

Scrolling window
Enter the invoice text in the scrolling window.
Billing Amount
This field is determined by the job's billing type.
Retention Withheld, Retention Due, Subtotal
The Retention Withheld for this invoice calculates automatically based on the retention percentage 
specified for this job in the Job Maintenance window. You can change this amount. When retention-
withheld amounts post with an invoice, the retention receivable accounts and progress billings accounts 
specified in the Invoice Accounts Setup window will debit and credit, respectively. To invoice previously 
withheld retention, see Generating Invoices for Retention (page 160). The Subtotal field is calculated 
automatically and is equal to the billing amount minus the retention amount withheld.
Calculate Sales Tax on Billing Amount
If you are using Retentions, you can mark this checkbox to calculate the sales tax on the Billing Amount. If 
unmarked, the sales tax is based on the subtotal amount (Billing Amount - Retention Amount). This 
checkbox is set up for the job in the Job Maintenance window (see Creating a Job Record (page 88) for 
more information), however you can override that for this invoice. Taxes are recalculated when the 
checkbox is marked/unmarked.
Miscellaneous
Enter Miscellaneous amounts that should be billed to the customer, but are not part of the original 
contract. For example, you can bill the customer for freight charges that are not part of the original job 
contract. Amounts entered here are not added to the gross or net billed amount for the job. When 
miscellaneous amounts post, miscellaneous posting accounts entered in the Posting Accounts Setup 
window for the Sales series are updated. If you plan to post miscellaneous invoice amounts, make sure 
all posting accounts for the Sales series are set up or you may not be able to post Job Cost invoice 
batches.

This date is editable if the Posting Date From is set to Transaction in Microsoft Dynamics GP 
Posting Date Setup.



The Tax Schedule ID is dependent on the Job Customer. If you update the Bill To customer the 
Tax Schedule ID does not change.


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Tax
Enter taxes, which calculate automatically based on the tax schedule assigned to the job and customer 
ID. Tax amounts are not added to the gross or net billed amount for the job.
Total
The Total is calculated automatically and contains the subtotal amount plus the miscellaneous and tax 
amounts.

Select Schedule to enter billing amount information. The window that opens depends on the job billing type.
If the job billing type is Standard, the Standard Invoice or Credit window opens. See Entering Standard 
Billing Information (page 158).
If the job billing type is User-Defined or Cost Code, the Schedule Invoice window opens. See Entering 
Scheduled Billing Information (page 157).
If the job billing type is Transaction-Level, the Apply Transactions window opens. See Entering 
Transaction-Level Billing Information (page 158).

Select Print and select the type of invoice to print. Certain invoices have billing type requirements. A description 
of each type of Dexterity invoice follows. If you are using SRS reports, refer to Job Cost Reports in SSRS Reports 
for more information about the SQL Job Invoice.

Text and graphic invoices
The text invoice lists bill to customer information, job customer information, invoice number, customer 
order number, customer number, net terms, billing amount, retention and tax amounts, and total due. 
The graphic invoice lists the same information in a graphical format. Text invoice 2 and graphics invoice 2 
can be customized. The invoices print in originating currency.
Cost elements invoice
The cost elements invoice is the same as the text invoice, except the billing amounts are itemized by cost 
element.
Detail billing invoice
The detail billing invoice requires a Cost Code billing type job. It is the same as the text invoice, except the 
billing amounts are itemized by bill code.
Tax detail invoice
The tax detail invoice is the same as the text invoice, except the taxable amounts are itemized at a tax 
detail code level. The invoice prints in originating currency.
A.I.A Doc G702
This menu item prints page 1 (AIA G702) and page 2 (AIA G703) of the AIA Application and Certificate for 
Payment document. For information on setting up this invoice, see Setting up and using document 
management (page 70).
Application for payment invoice
The Application for Payment invoice is the AIA G703 document. The invoice shows the job and application 
date and lists the item number, description, schedule value, percent paid, balance due, and retainage for 
each item. It also lists the amounts for previous applications for payment, material completed this 
period, stored materials, and materials completed and stored for each item. 

Transaction-level invoice
The transaction-level billing invoice requires a Transaction-Level billing type job. It is the same as the text 
invoice, except that billing amounts are itemized by transaction and labor is summarized by cost code. 
Unit charges are calculated from the posted transaction and are included in the invoice.
Transaction-level labor invoice
The transaction-level labor invoice requires a Transaction-Level billing type job. It is the same as the 
transaction-level invoice, except that billing amounts are itemized by transaction, including labor detail.

Batch post the invoice by choosing Transactions > Sales > Series Post.

If you use AIA billing, the application number must be assigned before printing to a batch. Select 
the Application for Payment printing option.


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Printing batch invoices
You can print invoices for batches using the Signature Print button in the Receivables Batch Entry window.

Select Transactions > Sales > Receivables Batches.
Complete the Receivables Batch Entry window. See the Microsoft Dynamics GP Receivables Management Manual
for information on completing this window.
Select Signature Print > JC Invoice Reports and select the type of invoice to print.

Assigning GL Accounts on Jobs and Job Invoices
You can assign GL sales accounts to bill codes at the job maintenance level and override them during job invoice entry.

Assigning GL accounts to job bill codes
Select Cards > Job Cost > Job. The Job Maintenance window opens.
Select a Job with a bill type of User Defined or Cost Code.
Select the Bill Codes button.
Use the lookup in the Account field to select a different account. The account defaults from the Invoice Accounts 
Setup window.
Select Save.

Overriding GL accounts during job invoice entry
You can override a GL account at the job invoice level for bill codes.

Select Transactions > Job Cost > Job Invoice Entry.
Enter job invoice information as you normally would.
Select Schedule. The Schedule Invoice window opens.
Complete the fields as you normally would.
Enter the Bill Code Number(s) to include on the invoice, or select Select All to include all bill codes. If you 
chose Select All, select Yes to the message Do you want to assign all bill codes to this invoice? Select Yes to the 
message Do you want to include the fully invoiced bill code numbers?
Use the lookup to select Account Numbers for each bill code for which you want to override GL accounts.
SelectSave.

Bill codes that have been fully-invoiced (posted) will appear in the Schedule Invoice window.

Viewing results using Job Status and Microsoft Dynamics GP
The account number assigned to the bill codes will appear on several Job Cost zoom windows. In addition, the 
Microsoft Dynamics GP Sales Distribution Entry window will contain one distribution line for each bill code.

Schedule Invoice Zoom window (page 156)

•

•

All Job Cost invoices must be batch posted. They should never be edited or posted from the 
Receivables Transaction Entry window.
Choosing the Commissions button opens the Commissions Entry window. This window contains default 
sales commissions from Microsoft Dynamics GP and cannot be changed in Job Cost. The salesperson 
comes from the Bill To customer.


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Schedule Invoice History window (page 156)
Receivables Distribution Inquiry Zoom window (page 156)
Sales Transaction Distribution Entry window (page 156)

Schedule Invoice Zoom window

To access this window:

Select Inquiry > Job Cost > Job Status. Enter a Job number and select the Billing button.
Zoom on a Document Number, and the Job Invoice Zoom window opens.
Select the Schedulebutton.
Select OK to close the window.

Schedule Invoice History window

To access this window:

Select Inquiry > Job Cost > Job History > Billing.
Zoom on a Document Number.
Select the Schedulebutton.
Select OK to close the window.

Receivables Distribution Inquiry Zoom window

To access this window:

Select Inquiry > Job Cost > Job Status > Billing.
Zoom on a Document Number.
Select the Distributionbutton.
Select OK to close the window.

Sales Transaction Distribution Entry window

To access this window:

Select Transactions > Sales > Transaction Entry > Distribution.

Assigning Sales GL Accounts to Bill Codes for Job Invoices
This feature allows you to assign a sales GL account to each bill code when creating job invoices. In addition, you can 
include fully billed bill codes on an invoice. You can assign accounts at the job level and override them at job invoice 
entry. This feature applies only to user-defined and cost code bill types, and does not include project-level invoices. 
Also, your system must be set up to post through the GL; you cannot use this feature if you are using the revenue 
recognition percentage of completion (POC) method.

Setup procedures
Below is a summary of steps involved in setting up your system so you can assign GL sales accounts to each bill code, 
along with a brief description. Refer to the appropriate section for step-by-step instructions.

Before you begin, make sure there are no unposted job invoices for the division to which the accounts belong.
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Step 1: Check posting options

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Job Cost Setup > Posting Options.
Make sure the Revenue Recognition Method and Closing Jobs Journal Entry checkboxes are not marked.

Step 2: Set up invoice accounts 

A new setup option on the Invoice Accounts Setup window allows you to use a sales account for each bill code at the job 
level and during job invoice entry. You cannot use this option if there are unposted invoices.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Account Setup > Invoice Accounts. The Invoice Accounts 
Setup window opens.
Mark the Use a sales account for each bill code checkbox.
Select Save.

Step 3: Set up system to display full invoiced bill codes 

You can set up the system to provide you the option to display fully-invoiced bill codes during job invoice entry.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Job Cost Setup > Setup Options.
Mark the Display fully invoiced bill coded during job invoice entry checkbox.
Select Save.

When you enter job invoices, the system will ask if you want to display fill-invoiced bill codes in the Schedule Invoice 
window.

Entering Scheduled Billing Information
The billing information for a User-Defined or Cost Code billing type job is entered in the Schedule Invoice window, 
which displays the bill code number, schedule value, previous billings amount, percent paid, current due, and current 
bill amount. It also shows the contract amount to date, the gross bill to date, and the contract remaining amounts.

Step 1: Enter application information
Select Transactions > Job Cost > Job Invoice Entry.
Complete the Job Invoice Entry window and select Schedule.
If you bill for an AIA job, enter an application number and the last day of the billing period for the invoice.

Step 2: Enter bill code information 
Enter the bill code numbers to bill on the invoice. Select Select All to select all bill codes.

The bill code description, total schedule value, and previous billings display in the scrolling window. These amounts are 
based on the information you entered in the Job Bill Codes window and for previous invoices posted using this bill 
code. See Adding Bill Codes to a Job (page 101).

Step 3: Enter billing amounts or percentages 
Enter billable amounts in one of three ways:

Percentage amount
Enter a percentage amount in the Bill % field to invoice a percentage of the code's total billable amount. The 
calculation of the current bill amount is the percentage multiplied by the total billable amount for this bill code 



158

•

•

1.

2.
3.

4.

5.
6.

1.
2.
3.

•

•

•
4.

1.

minus any previous billings. For Cost Plus and Cost Plus NTE billing type jobs, 100% appears in the Bill % field. 
The current bill amount calculates automatically as 100% multiplied by the cost plus markup amount for the 
selected bill code.
Invoice amount
Enter the current invoice amount for the bill code in the Current Bill field. The bill percentage calculates 
automatically in the Bill % field.
Billable amount
In the Current Bill field, accept the default billable amount, which comes from the bill amount entered in the Job 
Bill Codes window.

Step 4: Enter detailed AIA information
If you use AIA billing, select the Current Bill expansion button to open the Application for Payment window. The 
full amount of the invoice appears as the default in the Work in Place field. You can change this amount, dividing 
the total billable amount between the Work in Place and Stored Materials fields.
Enter the amount of the current bill to apply to Work in Place.
Enter the amount of the bill to apply to Stored Materials or items purchased for the job not delivered to the job 
site.
The Retention Withheld amount is set to the retention percentage (specified for the job in the Job Maintenance 
window) multiplied by the current bill amount for the bill code. You can change this amount.
Select Save.
In the Schedule Invoice Window, select Save.

Entering Standard Billing Information
The billing information for a Standard billing type job is entered in the Standard Invoice or Credit window, which 
displays the cost plus markup, previous billings, current due, and current bill amounts for each cost element. Amounts 
are displayed in functional currency.

Select Transactions > Job Cost > Job Invoice Entry.
Complete the Job Invoice Entry window and select Schedule.
In the Standard Invoice or Credit window, enter values in the Current Bill column. Values entered depend on the 
contract type.

If the contract type is Fixed Amount, you do not have to break down your revenue by element, unless the 
bill needs to be tracked by cost element. You can enter the total amount in any field. The values in the 
Cost + Markup column only represent the cost. You should include your markup in the Current Bill 
column.
If the contract type is Cost Plus or Cost Plus NTE, the current bill amount for each cost element displays. 
Previously billed amounts are subtracted from the cost plus markup-to-date for the job, showing a 
current amount due for each cost element. The current amount due for each cost element appears in the 
Current Bill column and can be edited. The billing amount calculates automatically based on the job's 
billing type, the profit types, the amounts defined for the job's cost codes, and the costs posted to the 
job.
If this is a credit memo, do not enter negative amounts in the Current Bill column.

Select Save.

Entering Transaction-Level Billing Information
The billing information for Transaction-Level billing type jobs is entered in the Apply Transactions window, which 
displays cost code information for posted transactions within a document date range.

Select Transactions > Job Cost > Job Invoice Entry.
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Complete the Job Invoice Entry window and select Schedule.
Enter the range of document dates to bill for your transactions. The dates are based on the transaction posting 
date in Job Cost. You can view items in previous fiscal periods by setting the date range to include those 
periods. 

Display Transactions is defaulted to show All transactions. You can select to view only Marked transactions.  
Mark the Show Credited Transactions button to display transactions with a billed invoice and credit memo 
number.
Mark individual line items to be invoiced or select Mark All. You can also unmark transactions. The Billing 
Amount field at the bottom of the window updates the total billing amount as you mark or unmark the 
transactions.
Select Save. The Job Invoice Entry window updates with the correct billing amount, tax, and invoice total.

Entering final transaction-level billing information for Cost Plus NTE contract types
The final billing information for Transaction-Level billing type jobs is entered in the Apply Transactions window, which 
displays cost code information for posted transactions within a document date range. When entering final billing 
information for a Cost Plus NTE contract type, and you want to bill up to the NTE amount, complete the following:

Select Transactions > Job Cost > Job Invoice Entry.
Complete the Job Invoice Entry window and select Schedule.
Enter the range of document dates to bill for your transactions. The dates are based on the transaction posting 
date in Job Cost. You can view items in previous fiscal periods by setting the date range to include those 
periods. 

Display Transactions is defaulted to show All transactions. You can select to view only Marked transactions.  
Mark the Show Credited Transactions button to display transactions with a billed invoice and credit memo 
number.
Select Mark All. The transaction billing amounts automatically update so that the total billing amount does not 
exceed the remainder of the NTE. The Billing Amount field at the bottom of the window updates the total billing 
amount to display the NTE amount, if the transactions displayed equal or exceed the NTE amount. For example, 
if there is a balance of $500 remaining of the NTE amount and there are three transactions with amounts of $100, 
$300, $600 displayed. Choosing Mark All updates the transaction amounts to total $500, in the order of the 
transaction posting dates. If you unmark individual transactions that have been previously-adjusted to the final 
NTE amount using Mark All, the unmarked transaction billing amount will continue to display the adjusted 
amount. To revert the amount back to the original amount, you must close the window and then open the 
window again. To reset all the marked transaction billing amounts to their original amounts, select Unmark 
All while in the current window with Document Posting date range.
Select Save. The Job Invoice Entry window updates with the correct billing amount, tax, and invoice total.

You can enter credit memos for transactions that do not have a positive balance.

To edit a transaction-level invoice, you must delete the existing invoice and re-enter your data.

You can enter credit memos for transactions that do not have a positive balance.

If you have marked individual transactions and the invoice subtotal exceeds the contract maximum on a Cost 
Plus NTE contract type, you will receive an error message. Check to see if unposted invoices exist and change 
the amounts or delete the current invoice.


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Additional information for final billing for Cost Plus NTE contract types

To edit a transaction-level invoice, you must delete the existing invoice and re-enter your data.
If you save the Apply Transactions window without selecting Mark All and re-open the window, the Document 
Posting date range will be grayed out and you can no longer select to have the transaction billing amounts 
automatically recalculated up the NTE amount. Choosing Mark All at this point will exceed the NTE amount and 
you will not be able to save the window. You must clear the window by making a change, closing the window, 
and select Delete. Then you can open the window again to proceed with entering a date range and 
choosing Mark All.
If you re-open the window after you have used Mark All to automatically update the billing amounts, and you 
want to use Unmark All to revert the amounts to their original amount, you must clear the window as described 
above.

Printing unbilled costs, transaction detail, or transaction summary reports

To print unbilled costs, transaction detail, or transaction summary reports, select one of the following:

Reports > Job Cost > Billing Reports > Transaction Level Reports > Unbilled Costs
Reports > Job Cost > Billing Reports > Transaction Level Reports > Transaction Detail
Reports > Job Cost > Billing Reports > Transaction Level Reports > Transaction Summary

Generating Invoices for Retention
Once a job is complete, you should invoice retention amounts. Retention must be completely billed before you can 
close a job.

Create the Retention report by choosing Reports > Job Cost > Billing Reports > Retention. This report lists 
retention withheld, retention billed, and billable retention amounts for open jobs.
Select Transactions > Job Cost > Job Invoice Entry.
Complete the Job Invoice Entry window as usual. See Entering Job Invoices (page 151).
Enter the amount of retention due in the Retention Due field.
Batch post the invoice by choosing Transactions > Sales > Series Post.

Entering Production Transactions
You enter job-related production quantity information using the Production Units Entry window. Job Cost uses optional 
production-based costing techniques to measure completion. Production measures are measurement types that you 
can set up for tracking the number of units produced for a selected cost code. For example, in an electrical contracting 
business, if you assign a production measure such as feet of cabling to the cost code for the apartment building's first 
floor, you can enter a production quantity for the cost code. A quantity-per-estimate unit calculates automatically. This 
amount can be computed to actual production rate to measure job performance. You can use production measures to 
determine the percentage of a cost code completed by dividing the posted production units to date by the production 
estimate quantity.

These reports can only be printed for jobs that have a contract type of Cost Plus and a billing type of 
Transaction Level or Project Trx Level.


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Step 1: Enter transaction information
Select Transactions > Job Cost > Production Unit Entry.
Complete the following fields:

Transaction Number
A transaction number identifies a group of related line items posted collectively as a single transaction. A 
transaction number can contain many line items, and a batch can contain many transaction numbers. 
You can use the transaction number on audit trail documents (posting journals and edit lists) to trace the 
history of a specific document.
Batch ID, Transaction Date
The date you enter is used to update your Job Cost records.
Job Number
Enter a job number to which unit amounts will post.

Step 2: Enter cost code and production unit information.
Cost Code
Select the cost code to which the amounts will apply. Production units post only to cost codes marked to track 
production quantities in the Job Cost Codes Setup window.
Production Units to Date
Enter a production quantity for the cost code. This field displays previous unit quantities posted to the selected 
cost code for this job.
Field %
Enter the estimated percentage completed for this cost code. For example, if the project manager for the job 
feels a cost code is 75 percent complete based on the work performed to date, enter 75% in the Field Percent 
field. 

The Cost Codes Detail window updates with this amount. You can see the estimated percentage completed 
when you drill down to the cost code from the Job Status window. The Cost Codes Detail window allows you to 
view the Field Percent field, the Actual Cost Percent (calculated as actual cost/forecasted cost for the cost code) 
field, and the Production Percent (calculated as Production Units to Date/Production Estimate Qty) field for the 
selected cost code. 

You can add this amount to reports using Report Writer. For example, you could create a report comparing the 
field percent complete with the actual percent complete (based on production units or actual cost). You can also 
create projections based on this amount.

Step 3: Print an edit list and post
To print a Production Units Edit List, select File > Print while a batch ID displays in the Production Units Entry 
window.

To post an individual production unit entry transaction, select Post in the Production Units Entry window.

You can also enter production unit transactions using the Transactions button in the Batch Entry window (Transactions 
> Job Cost > Production Unit Batches).

If you save transactions to a batch, we recommend that you print an edit list with job detail before 
posting to verify the accuracy of the transactions you entered.


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Creating Percentage-of-Completion Journal Entries
The percentage-of-completion (POC) revenue recognition method allows you to match a job's revenue and costs to the 
periods in which they incur. Job Cost recognizes the job's revenue and expenses that are based on the percentage of 
the job completed in a period by creating and posting a POC journal entry.

If you use this revenue recognition method, the general ledger posting accounts entered in the Revenue Recognition 
Account Setup and Revenue and Exp Account Setup windows update when the entry posts.

Using a typical POC revenue recognition method setup, all job costs incurred for a period post to general ledger 
accounts as debits. The POC journal entry at the end of a fiscal period credits the accounts and expenses the costs in as 
a cost of sales for jobs. The POC journal entry recognizes revenue using the following:

Actual Cost or Labor/Forecasted Cost or Labor = Percent Complete
Percent Complete x Expected Contract Amount = Revenue Earned

If you have any jobs that are excluded from POC, for example, fixed asset or warranty jobs, the POC entry ignores those 
jobs and any balance they may leave in the accounts. See Excluding a job from POC/RPO (page 106).

You must close the fiscal period prior to building and posting the POC entry for the fiscal period. For more information 
on closing periods in Job Cost, see Closing a Period or Month (page 235).

If any periods were closed and re-opened prior to building the POC entry, you may find discrepancies between the 
information that prints on your POC Edit List (before closing the period again) and the information that prints on your 
POC Entry List (after closing the period again).

Select Transactions > Job Cost > POC Entry.
The User ID defaults to the logged in user's ID.
The Date and Time fields will default to the current date/time when the build is started.
The POC Journal Number defaults in.
Complete the following fields:

Description
Enter a Description to appear on posting reports identifying the POC journal entry.
Year
The fiscal year corresponding to the year in which you post the POC entry appears as the default. You can 
change the year.
Period ID
Enter a period ID. A transaction date showing the last date of the fiscal period displays. The POC journal 
entry reverses automatically on the first day of the next fiscal period. The reversing date also displays.

Select Build to build the POC journal entry. You must build the entry before printing an edit list to verify the 
accuracy of the transactions. The Build button changes to Post.
When the build process is complete, select File > Print to print the POC Entry List. Costs, Contract Earned, and 
other totals for jobs that are excluded from POC do not appear in the division or grand totals on this report. 
Unless you are using a separate division with separate accounts for non-POC jobs, excluding jobs from POC may 
be the reason for a discrepancy between the totals on the edit list and the balance in your accounts. 
If you need to revise forecasts for some jobs after you review the edit list, select Remove to remove the build. 
Build the entry again after revising forecasts and before posting. See Using Forecasted Costs (page 169) for more 
information.
If the edit list is accurate, select Post to post the POC entry. You can print a posting journal when the posting 
completes.

If you use the POC method, you must use division posting accounts.
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If you marked the Percentage of Completion Options: Post through the GL option in the Posting Options window, the 
POC entry posts through the general ledger. If you did not mark the option, you must post the batch in the general 
ledger to update posting accounts in that module.

Creating Job Revenue Journal Entries
If you have any jobs that are excluded from RPO, for example, fixed asset or warranty jobs, the revenue entry ignores 
those jobs and any balance they may leave in the accounts. See Excluding a job from POC/RPO (page 106).

You must close the fiscal period prior to building and posting the revenue entry for the fiscal period. For more 
information on closing periods in Job Cost, see Closing a Period or Month (page 235).

If any periods were closed and re-opened prior to building the revenue entry, you may find discrepancies between the 
information that prints on your Revenue Edit List (before closing the period again) and the information that prints on 
your Revenue Entry List (after closing the period again).

Select Transactions > Job Cost > Job Revenue Entry.
Complete the following fields:

Description
Enter a Description to appear on posting reports identifying the revenue journal entry.
Year
The fiscal year corresponding to the year in which you post the revenue entry appears as the default. You 
can change the year.
Period ID
Enter a period ID. A transaction date showing the last date of the fiscal period displays. The job revenue 
journal entry reverses automatically on the first day of the next fiscal period. The reversing date also 
displays.

Select Build to build the Revenue journal entry. You must build the entry before printing an entry list to verify the 
accuracy of the transactions. The Build button changes to Post.
When the build process is complete, select File > Print to print the Revenue Entry List. Costs, Contract Earned, 
and other totals for jobs that are excluded from the revenue entry do not appear in the division or grand totals 
on this report. Unless you are using a separate division with separate accounts for non-RPO jobs, excluding jobs 
from revenue entry may be the reason for a discrepancy between the totals on the edit list and the balance in 
your accounts.
If the entry list is accurate, select Post to post the job revenue entry. You can print a posting journal when the 
posting completes. 

You must mark the Closing Jobs Journal Entry posting option (Microsoft Dynamics GP > Tools > Setup > Job Cost 
>Job Cost Setup > Posting Options) if you use the POC revenue recognition method. Closed jobs are not 
included in the POC entry. Marking the Closing Jobs Journal Entry posting option creates a journal entry 
recognizing the final revenue and costs for the job each time you close a job. For more information on closing 
jobs in Job Cost, see Closing a Job (page 222).



For revenue to be recognized on a Performance Obligation Contract, the Original Transaction Price on the Job 
Revenue Codes window must be populated the same month.



If you close the Job Revenue Entry window without posting, a message displays asking if you want to 
post or remove the build. You will need to run the Build process again if you select to remove the build.


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If you marked Post through the GL option in the Posting Options window, the job revenue entry posts through the 
general ledger. If you did not mark the option, you must post the batch in the general ledger to update posting accounts 
in that module.

Entering Job Unit Transactions
Job unit transactions are like job transactions except that the transaction's debit amount is automatically calculated 
based on the quantity and estimated amount per unit for the selected cost code.

Step 1: Complete the job unit entry window.
Select Transactions > Job Cost > Job Unit Entry.
Complete the following fields, as necessary.

Journal Entry, Batch Number
Enter Journal Entry and Batch numbers.
Transaction Date
Enter a Transaction Date.
Source Document, Reference
Enter a Source Document and Reference. For Transaction-Level billing type jobs, the information you 
enter in the Reference field will appear on customer invoices. That information should be relevant to 
what you want the customer to see on the invoice. If you do not make an entry, a line item will have a 
dollar amount with no description. Audit trail information appears on posting journals and can be used 
by external auditors to verify the accuracy of your record-keeping processes.
Job Number
Enter a Job Number.
Cost Code
Enter the Cost Code that the debit or credit amount applies to. The transaction distributes automatically 
to the posting account assigned to this cost code in the Job Cost Codes Setup window.
Quantity
You must enter a number other than zero.
Debit / Credit
Enter a Debit or Credit amount.
Account
Enter the offset account information. If you enter credit amounts, do not enter a job number or cost code 
unless you are certain you want to credit a job and cost code.

Step 2: Print an edit list
To print a Job Transaction Edit List for units with job detail before posting, select File > Print.

Step 3: Post or save the transaction.
Select Save to save the transaction or Post to post the transaction.

Job Cost detail appears for each transaction posted real-time when you close the Job Transaction Entry window. 
Depending on the Financial Series Posting Setup, you can print a posting journal for batch postings.

A user needs proper security to display Job Cost detail (job number and cost code) on the general posting 
journal for batch posting. See Setting up security (page 15).


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Entering Unit Adjustments
You can adjust the units of a cost code, and bill for them, without affecting posted costs or the general ledger.
Before you enter unit adjustments, make sure that cost codes are added to the appropriate jobs. When unit 
adjustments are posted, contract amounts are updated, depending on the following:

Contract amounts are updated if the cost code is assigned to a job that has the following: a contract type of Cost 
Plus or Cost Plus NTE in the Job Maintenance window; a profit type ID of Flat Rate per Unit in the Job Cost Codes 
Setup window; and an amount in the Profit Amount field in the Job Cost Code Setup window.
Contract amounts are not updated if the cost code is assigned to a job that has a profit type ID other than Per 
Unit Amount, Total Dollar Amount, Flat Rate per Cost Code, or Flat Rate per Unit.

Step 1: Set up unit adjustment.
The unit adjustment document type sets the document number for the unit adjustment transactions that you enter.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Job Cost Setup > Number Options.
In the Unit Adjustment field, enter a description and next number. The field is set to unit adjustment and 1.
Select Save.

Step 2: Enter a unit adjustment transaction.
Select Transactions > Job Cost > Unit Adjustment Entry.
Complete the following fields, as necessary.

Transaction Number
The next available number defaults but can be changed.
Batch Number
Enter a Batch Number.
Document Date, Transaction Description
The user date defaults as the Document Date.
Job Number, Cost Code Number
Enter a Job Number and Cost Code Number.
Actual Units, Transaction Description
Enter the Actual Units and a Transaction Description. The unit transaction's description appears in the 
Transaction Description field in the scrolling window. You can change this description. Instead of the unit 
transaction description, when printing transaction-level billing invoices, labor cost codes show the cost 
code description and non-labor cost codes show the cost code transaction description.

Save or post the transaction. The document date is used as the posting date.
To print a Unit Adjustment Entry Edit List, select File > Print when the Unit Adjustment Entry window is open.

You can also enter unit transactions using the Transactions button in the Batch Entry window (Transactions > Job Cost > 
Unit Adjustment Batches).

Mass Updating Revenue Code Percentages
The Revenue Code Percent Mass Revision Entry window lets you update multiple job revenue code % complete at one 
time. If you are using the Project Manager's Advisor module, you should only see your assigned jobs.

You must open and save this window even if you don't make changes.
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To mass update revenue codes:

In Microsoft Dynamics GP, go to Transactions > Job Cost > Revenue Code Percent Mass Revision Entry. 

Enter the Date and a Description.
Select from the following filters to limit the jobs that display, if needed. If no filters are selected, you will see all 
job revenue codes.

Job Number
Division
Revenue Type
Project Number
Project Manager
Customer Number
Show Included Only checkbox - Displays the revenue codes marked for commitment.

Select Redisplay. 

Select a job to display all revenue codes assigned to that job with their current percentage complete.
Mark the 100% checkbox to update the code to 100% complete. The revenue amount will be included in the 
Revenue GL entry that is created for the job or division during the month end process. (Or enter a percentage 
amount in the revised field.)
Select Print to review the edit list.
Select Commit to commit the changes.

Applying Credit Memos to Job Invoices
The Microsoft Dynamics GP Apply Sales Documents window is used to apply credit memos and payments to invoices. 

To access the Apply Sales Documents window, go to Transactions > Sales > Apply Sales Documents. 
Enter the Customer ID used as the Bill to Customer for the job invoices or use the Customer ID lookup to select 
the appropriate customer.
In the Type field, select Credit Memo. 
Select the Document Number you wish to apply as a credit memo using the lookup provided. When using the 
lookup, a list of Open (unapplied) Cash Documents display.
Back on the Apply Sales Documents window, the scrolling window displays the job invoices that have the same 
job ID as the selected credit memo.
Mark the checkbox(es) to the left of the job invoice(s) that are applying the credit memo to.
Select OK.

We recommend that you print the Revenue Edit List after committing the revenue code percentages update to 
verify the changes. If you do not see expenses, verify that cost codes have been assigned to revenue codes. For 
more information, see Assigning Cost Codes to Revenue Codes (page 100).



The scrolling window does not display records. Select Redisplay to fill the window.

Inactive or jobs that are excluded from RPO are not included in the displayed jobs.

If you select Clear, all changes that were entered as well as filters will be cleared.
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Job Status
The Job Status window allows you to access current and inactive job information. You can examine committed, posted, 
estimated, and forecasted costs for each job. Accounts receivable, billed position, and cash position information is also 
available. In addition, visual indicators alert project managers to potential cost overruns or overdue billings. The Job 
Status window also provides zoom capability to the cost code and detail levels of a job.

When the actual posted costs for a cost element exceed the original estimate or latest forecasted revision, a yellow 
warning icon  appears in the right margin. The warning icon alerts the project manager of a cost overrun. When the 
warning icon displays, the forecasted cost automatically adjusts to match the amount in the Posted Costs column.

Depending on your security settings for alternate windows and your user license, you can also access the following 
transaction windows:

Purchase Order Entry
Receivings Transaction Entry
Payables Transaction Entry
Payroll Transaction Entry
Inventory Transaction Entry
Sales Transaction Entry

Editing Revenue Performance Obligations
Use the Job Revenue Code Revision Entry window to revise the percent complete for the selected revenue code. This 
window displays all previously-posted revenue code revision entries for the job

To revise a revenue performance objective:

Go to Inquiry > Job Status > Revenue Code Status button > Job Revenue Code Status > Add Revision.
In the Job Revenue Revision Entry window, complete the following fields:

Date
Enter the posting date.
Revenue Code
Select the revenue code the revision is being made for.
Percentage Revision
Enter the new percentage. The last posted revision for the revision code becomes the current percentage 
complete. 

Description
Enter a reason for the revision.

Select Post.

For Point in Time revenue codes, revenue is not recognized until it is entered as 100% complete. 
At that point it will be included in the month's revenue entry. If 100% is posted in error, you can 
enter another lower percentage revision so the revenue code is not included in the month's 
revenue entry.


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Viewing Job Status Information
You can zoom on cost element amounts in each column in the Job Status window to see detailed information. 
Committed, posted, estimated, and forecasted costs information is displayed. You can also select the buttons at the 
bottom of the Job Status window to view contract status, billed position, billing, and customer status information. You 
can select the Change Orders button to create change orders. The Labor Breakdown button is enabled if Project 
Manager Advisor is registered.

Select Inquiry > Job Cost > Job Status.

The lookup button on the Job field provides the ability to filter your view of jobs by Active, Inactive or ALL.

Viewing Committed Costs
The Committed Costs column shows the total outstanding (not yet received) amounts from saved purchase orders, 
sales orders, and sales invoices. From this column, you can drill down to view a cost code breakdown in the Committed 
Costs Inquiry window and a summary of transactions in the Committed Transaction Summary window.

Step 1: View transaction summary
Select Inquiry > Job Cost > Job Status.
Select a job and zoom on a Committed Cost element.
Select a cost code and zoom on the Cost Code Number field to open the Committed Transaction Summary 
window, where you can view transaction details for the selected cost code.
To print the Committed Cost Transaction Journal report, select File > Print.

Step 2: View transaction details.
Zoom on a document number in the Committed Transaction Summary window to open an inquiry zoom 
window, showing details of the purchase order, sales order, or sales invoice document.
To print the document, select File > Print.

Viewing Posted Costs
You can view posted costs for each cost element in the Job Status window. Amounts in the Posted Costs column are 
calculated by adding all posted costs of the same cost element on the selected job. You can zoom to view a summary of 
cost codes in the Cost Codes Summary window and details on each cost code in the Cost Codes Detail window. You can 
also view the summary of transactions, monthly costs, and production unit summary. You can also access forecasted 
revisions and enter production unit information.

Select Inquiry > Job Cost > Job Status.
Select a Job and zoom on a Posted Cost Element.
In the Cost Code Summary window, double-click a Cost Code in the scrolling window.
In the Cost Codes Detail window, you can do the following:

Select View Monthly Costs to open the Job CC Monthly Costs window, showing monthly cost amounts for 
the cost code.
Select View Transactions or zoom on an amount in the Actual Costs column to open the Payroll 
Transaction Summary window for a labor cost element or the Transaction Summary window for cost 
elements other than Labor. You can zoom on items in the Transaction Summary window to view original 
transaction details.
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Select View Production Units to open the Production Units Summary window, showing transaction detail 
for the selected cost code. This window contains a list of all production unit transactions, type, posting 
date, field percentages, and production quantities.
Zoom on an Estimated Cost amount to open the Cost Code Estimate Zoom window, where you can view 
original and change order estimates. See Revising forecasted costs (page 170).
Zoom on a Forecasted Cost amount to open the Forecast Cost Revision Entry window, where you can 
revise and post the forecast cost revision entry. See Using Forecasted Costs (page 169).
Enter the field percent complete. For example, the project manager can enter a percent complete based 
on the work performed to date and job knowledge. If the actual production percent is greater than the 
estimated field percent, it may indicate a potential cost overrun. This percentage is also used in the Labor 
Breakdown window and shown on the Job Labor and Projected Variance reports.
Enter the production quantity per unit for the current period and the production best amounts. 
The Production Best field may be used by a project manager to give incentives to employees who top 
the "production best" in a given time period. If production in the current period is considerably less than 
the production best, the project manager should take notice and find reasons for the fall in production.

Select Save.

Viewing Estimated Costs
The Estimated Costs column in the Job Status window contains the original estimated cost or budget for the job, plus 
any estimated costs from posted change orders. You can revise these estimates. Maintaining a history of both estimated 
costs and historical costs allows you to measure the performance of your job estimators. It also allows you to confirm 
pricing or bidding assumptions as your company sets pricing guidelines and pursues new contracts.

Select Inquiry > Job Cost > Job Status.
Select a job and zoom on an estimated cost element.
To revise estimated costs, see Revising estimated costs (page 96).

Using Forecasted Costs
The Forecasted Costs column in the Job Status window shows the project manager's forecast of the cost at job 
completion. You can retain both the original estimated cost and a forecasted cost. You can also revise the forecasted 
costs.

When you add cost codes to a new job, the forecasted cost equals the estimated cost. You can increase the forecasted 
cost when you know there will be a cost overrun. You can also decrease the forecasted cost if the projected actual cost 
will be considerably less than the estimated cost when the job is completed.

You can revise a forecasted cost by zooming on a cost element to open the Forecast Cost Revision Entry window.

Revising forecasted costs (page 170)
Adjusting forecasts (page 170)

When you enter a forecast revision, make sure the posting date falls within the period you want the 
transaction to affect. The amounts in the Job Status by Period window and the Percentage of Completion 
(POC) will be totaled based on the posting dates. For example, when you enter a forecast revision, the default 
date in the Date field in the Forecast Cost Revision Entry window is the user date in the current period. If you 
want the revision to affect the previous period, you would have to change the date to reflect that previous 
period.


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Revising forecasted costs
You can revise forecasted costs in units, or in dollars. With units, you can manage labor on a job based on hours.

Select Inquiry > Job Cost > Job Status.
Select a job and zoom on a forecasted cost element.
The system date appears in the Date field. You can change this date.
Enter the Cost Code that applies to the revision.
Enter both the Forecasted Units and Forecasted Amount/Unit - OR - a flat dollar revision Amount. The revision 
amount will be added to the current cost element forecast. The total amount of forecasted revisions is then 
added to the cost element's estimated cost to calculate the revised forecast amount.
Enter the identifying text that describes the reason for the forecast revision. This information appears in the 
scrolling window. You can attach a detailed note using the notepad button.
Post the revision. When you post, the revision transaction displays in the scrolling window.
To print the forecast revision list, select File > Print.

Adjusting forecasts
Depending on whether you are using labor hours or costs to calculate percent complete, you can adjust forecasted 
labor hours or costs to equal actual posted labor hours or costs for each cost code. This procedure does not consider 
estimated costs.
Unless the Auto adjust forecasted only when posted is greater than forecasted checkbox is marked on the Job Cost 
Setup Options window, the forecast is revised whenever the actual units do not equal the forecast units.

Select Inquiry > Job Cost > Job Status.
Select a job and select Adjust Forecasts. A message appears asking if you are sure that you want to adjust the 
forecasts. If so, back up your system before continuing. The Adjust Forecast Costs Utility updates forecast units 
to equal posted units.
Select OK to continue, or Cancel to exit without updating the forecasts. The system creates forecasted revisions 
for each cost code, adjusting the forecast to equal actual.

Viewing Margin Percent
You can select to view markup percent or margin percent.

Markup percent and margin percent are calculated as follows:

Markup Percent = ((Expected Contract - Total Forecasted Costs) / Total Forecasted Costs) * 100
Margin Percent = ((Expected Contract - Total Forecasted Costs) / Expected Contract) * 100

To view Margin or Markup Percent:

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Job Cost Setup > Setup Options.
In the Display Preference section, select the Margin Percent radio button. 
When the Margin Percent radio button is selected, the Anticipated Margin and Margin Percent fields appear in 
the Job Status window. Anticipated Margin is calculated the same as Anticipated Markup: Expected Contract - 
Total Revised Forecast. 

The display preference selected in the Setup Options window also affects the following windows and reports:
Job Status by Period window

Security access may be restricted, and there is no way to undo the changes that are made.
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Job Status History window
Project Status window
Project Manager Summary window
Job Status report
Job Schedule report
Forecasted Costs by Period report
Project Status report
Job Reference report
Job Schedule by Division report
Job Schedule by Project report
Posted Costs by Period report
Job Status History report
Setup Options report

Viewing a Summary of Costs by Cost Code Segment
You can view a summary of costs by cost code segment including phase, step, detail, and component.

Select Inquiry > Job Cost > Job Status.
Select a job and select the tree view button in the Job field.

Each level in the tree view represents a segment in a cost code number. The first level in the tree view is 
the phase; the second level is the step; the third level is the detail; the fourth level is the component. The 
number of available segments depends on the number specified during cost code setup.
You can select the "+" button on a segment to expand the tree view.
You can zoom on the Actual Cost to Date and Committed Cost column headings for each level to view 
additional information. Zooming on the Actual Cost to Date column opens the Cost Code Summary 
window. Zooming on the Committed Costs column opens the Committed Costs Inquiry window.

Select a segment level and zoom on a column heading. The window that opens contains cost code information only for 
cost codes that contain that segment level in the tree view. For example, if you clicked on a phase level before zooming 
on the Committed Costs column, the information will appear in the Committed Costs Inquiry window only for cost 
codes associated with that phase. If you select a step level (which is one step below the phase level) before zooming, 
the information will appear only for cost codes that contain that step within that phase. The lower the tree view level, 
the more specific the cost code information will be.

The % Variance is calculated as: ((Total Estimate - Actual Cost to Date) / Total Estimate) x 100
The Cost to Complete (Overrun) column is calculated as: (Total Forecast - (Actual Cost to Date + Committed 
Cost))
The Job Total field contains the total costs for each column.

Viewing Contract Status
The Contract Status window displays contract information, including the contract type, original contract amount, user-
defined change order amounts, contract-to-date amount, in-process change orders, and the expected contract amount.

Select Inquiry > Job Cost > Job Status.
Select a job, then select Contract Status.
View the original and expected contract amounts based on posted change orders. 

The Total Forecast column contains the total estimates plus forecasted revisions. It does not include cost 
overruns, which might cause the job total for the Total Forecast column in this window to be different than the 
Forecasted Costs column in the Job Status window.


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Viewing Revenue Code Status
Select Inquiry > Job Cost > Job Status.
Select a job, then select Revenue Code Status. 

Zoom on the Contract Billed field to open the Billed Amounts window.

Viewing Billed Position
You can view the current amount earned on the contract based on the percentage-of-completion and over- and under-
billed amounts in the Billed Position window. The cash over/shortage amount indicates whether the amount of cash 
you received is greater than the posted costs for the job. If you are excluding the job from RPO, this window will not 
display any RPO calculations.

Select Inquiry > Job Cost > Job Status.
Select a job, then select Billed Position.
Zoom on the Contract Billed field to open the Billed Amounts window.
Zoom on the Revenue Recognized field to open the Revenue Recognition Summary window, which displays the 
revenue recognition details for the current job to date.

Viewing Revenue Recognition Summary
Inquiry > Job Status > Billed Position > Revenue Recognized zoom

The Revenue Recognition Summary window displays the revenue amounts recognized on revenue codes for a job. This 
window also displays the GL journal entry number, posting year and period, revenue code transaction price and the 
amount recognized for each revenue code that has revenue recognized for the job.

If the job has more than one revenue code, use the lookup button to select a revenue code to view its revenue 
summary.

Viewing Billing Transactions
You can view billing information for the selected job, including details on specific invoices, receivable transaction 
distributions, and job cash receipts in the Billing Transaction Inquiry window.

Select Inquiry > Job Cost > Job Status.
Select a job, then select Billing.
In the Billing Transaction Inquiry window, select a transaction and zoom on the Cash Received field to open the 
Job Cash Receipts window, listing the cash receipts for the selected cost code.
Select OK to close the window.
In the Billing Transaction Inquiry window, select a transaction and zoom on the Customer ID field to open the 
Receivables Transaction Inquiry - Customer window, showing details on receivables transactions, along with 
their status and amounts.
Select OK to close the window.

If you marked the job to be excluded from RPO, this button will be disabled.

Cost Plus jobs are assumed to be always 100% complete, even if the Percent Complete in the Billed Position 
window does not reflect this.


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Double-click a transaction to open the Job Invoice Zoom window. This window contains a replica of the 
transaction as originally entered and serves as an online audit trail of your transaction information. You can view 
detail information on a job's transactions, such as invoice or credit information and receivable distributions.
Select Print to print the invoice.
In the Job Invoice Zoom window, select the Schedule button. If the job has a Standard billing type, the Standard 
Invoice or Credit Zoom window opens. If the job has a User-Defined or Cost Code billing type, the Schedule 
Invoice Zoom window opens. If the job has a Transaction-Level billing type, the Transactions Inquiry window 
opens. Detailed information from the original invoice entry is displayed.
Select OK to close the window.
Select the Distribution button to open the Receivables Distributions Inquiry Zoom window, showing the general 
ledger distribution detail for the invoice.
Select OK to close the window.

Viewing Customer Status
You can view the customer accounts receivables status in the Customer Payment Summary Inquiry window. This 
window contains the customer's aging and credit information including the most recent invoice and the most recent 
payment dates and amounts.

Select Inquiry > Job Cost > Job Status.
Select a job, then select Customer Status.
Select a cost period and zoom on the Amount field to open the Receivables Transaction Inquiry - Customer 
window, which displays all accounts receivable documents for this customer including posted and unposted 
documents.
In the Receivables Transaction Inquiry - Customer window, double-click the document number and zoom on 
the Document Number field to open the Receivables Transaction Inquiry Zoom window, showing transaction 
entry information for a specific document number.
In the Receivables Transaction Inquiry Zoom window, select Distribution to open the Receivables Distributions 
Inquiry window, listing receivables accounts and debit or credit amounts.

Viewing Job Status by Period (optional)
You can view the status of a job by fiscal period. This allows you to track cost trends across multiple periods. You can 
view job status for posted costs and forecasted costs. Open and closed periods are included.

Select Inquiry > Job Cost > Job Status.
Select a job, then select Status by Period.
Costs display for each period by cost element. The most recent period appears on the far right; the oldest period 
appears on the far left. The default tab is Forecasted Costs. To view posted costs, select the Posted Costs tab.
The current year and period default. You can change the year and period using the Year and Period ID drop-
down lists. Select the year and/or period and select Redisplay. Contract and billing information appears at the 
bottom of the window.
To print a Forecasted Costs by Period or Posted Costs by Period report, select the appropriate tab and 
select Print.

If using RPO revenue recognition, the Contract Earned amount is based on the job's revenue performance 
obligations.


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Accessing Transaction Entry Windows
Users can access the following Transaction Entry windows from the Job Status window.

Purchase Order Entry
Receivings Transaction Entry
Payables Transaction Entry
Payroll Transaction Entry
Inventory Transaction Entry
Sales Transaction Entry

If the Transaction Entry window is already open and you select the appropriate button in the Job Status window, the 
currently open Transaction Entry window comes to the front.

To access transaction entry windows:

Go to Inquiry > Job Cost > Job Status and select a job.
Select one of the follow transaction entry buttons:

Purchase Order 
Select the Purchase Order button to open the Purchase Order Entry window. The Product Indicator 
defaults to Job Cost and the job number auto-populates when the window opens. Enter the appropriate 
cost codes.
PO Receive 
Select the PO Receive button to open the Receivings Transaction Entry window. Select the purchase 
order.
Payables 
Select the Payables button to open the Payables Transaction Entry window. Select Job Cost for the 
Product Indicator and the job number auto-populates.
Payrolls 
Select the Payroll button to open the Payroll Transaction Entry window. The Product defaults to Job Cost 
and the job number auto-populates when the window opens. Enter the appropriate cost code.
Inventory 
Select the Inventory button to open the Inventory Transaction Entry window. The Transaction Type 
defaults to Job Cost and the job number auto-populates when the window opens. Select the Job Number 
expansion button to open the Inventory Transactions window to enter the cost code. Select OK to return 
to the Inventory Transaction Entry window.
Sales Order 
Select the Sales Order button to open the Sales Transaction Entry window. The job customer auto-
populates when the window opens. Select Go To and the select User-Defined. In the Sales User-Defined 
Fields Entry window, the Type defaults to Job and the job number auto-populates. Select the expansion 
button next to the job number to open the Sales Order Processing Transactions window and enter the 
cost code. Select OK to return to the Sales User-Defined Fields Entry window. Select OK to return to the 

•

•

•

•

Notes:

The buttons are enabled for active jobs and if you have security access to the  Signature Alternate 
Forms for Dynamics GP. See Setting up Job Cost Security (page 15) for more information. 
Depending on how your Alternate Signature Forms are set up, you may be prompted to open the 
Equipment Management alternate form or the Signature alternate form, select Signature.
If access is set up to only the Equipment Management Alternate Forms, the appropriate buttons are 
disabled.
Access to the Transaction Entry windows respects Microsoft Dynamics GP's user licenses.


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Sales Transaction Entry window. The Sales Order button is disabled if the job has a Sales Order 
Processing (SOP) billing type. 
Journal Entry 
Select the Journal Entry button to open the Signature Transaction Entry window. Select Job Cost for the 
Product Indicator and the job number auto-populates. Enter the cost code.

Using Change Orders
If the specifications for a current job change, you can create a change order to reflect the added work, or you can edit an 
existing change order for the job in the Change Orders window. You can also alter financial or other information 
specified in the job's contract. The committed, actual, estimated, forecasted costs, and billing amounts are stored, 
allowing you to track profitability for individual change orders.

Standard Change Order Rules (page 175)
Additional information (page 175)

Creating a change order (page 176)
Editing a change order (page 176)
Revising posted change order estimated cost (page 177)

Standard Change Order Rules
You can add either Fixed Amount or Cost Plus change orders to a job with all contract types. You can add a Cost Plus 
NTE change order only to a Cost Plus NTE job.

Job Type Change Order Type

Fixed, Cost Plus Fixed, Cost Plus

Cost Plus NTE Cost Plus NTE

Additional information
Cost codes can also be applied to change orders. The type of contract for the job and the change order determines what 
type of cost code you can apply to the change order.

When you enter a change order transaction, make sure the posting date falls within the period you want the transaction 
to affect. The amounts in the Job Status by Period window and the Percentage of Completion (POC) will be totaled 
based on the posting dates.

If you are using the RPO revenue recognition method, please see Using Change Orders when using the RPO 
Revenue Recognition Method (page 177).



If jobs are grouped by project and the billing type for the project is Cost Plus 
billing, change orders cannot be created for the job.


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Creating a change order
Select Inquiry > Job Cost > Job Status.
Select a job, then select Change Orders.
In the Change Order Inquiry window, select Add Change Orders.
Complete the following fields, as necessary.

Change Order, Description
Accept the default number or enter your own change order number. Enter a description to further 
identify the change order.
Status
Select a status for the change order.
Contract Type
From the drop-down list, select the type of calculation method to use for the billable amount of the 
change order. The job contract type in the Job Status window defaults.
Change Order Amt.
If you selected the Fixed Amount contract type, enter the amount of the change order. If you selected the 
Cost Plus NTE contract type, enter the change order maximum amount. If you chose Cost Plus as the 
billing type, you will not enter a change order amount. It will be automatically calculated, based on the 
cost code's profit type and profit amount, as costs are posted to the change order cost codes.
User-Defined
Enter user-defined information.

Select Save.
Select Cost Codes to open the Change Order Cost Codes Setup window. 
Enter a Cost Element Type.
Enter a Cost Code.

If the contract type of both the job and change order is Fixed Amount, you can either enter a new cost 
code, select Add Cost Codes to add a cost code from the master cost code list, or select Use Existing Cost 
Codes to use a cost code already assigned to the job.
If the job contract type and/or change order contract type is Cost Plus or Cost Plus NTE, you can only 
enter a new cost code for the change order. The Add Cost Codes and Use Existing Cost Codes buttons will 
be disabled.

Complete the remaining fields. If you are assigning a cost code with a cost element type of subcontractors, you 
must select a transaction type of Vendor ID and assign a vendor for the change order amount to affect 
the Amended Contract Amount field in the Subcontractors Maintenance window. See Adding cost codes to a 
job9.
Select File > Print to print the Change Order Cost Codes report listing cost codes assigned to the change order.
Select Save in the Change Order Cost Codes Setup window and close the window.
In the Change Orders window, select File > Print to print the Change Order List.
Post or save the change order. Once the change order is posted to the job, the expected contract amount and 
the estimate cost will be updated in the Job Status window.

Editing a change order
You can edit posted or unposted change orders. Unposted change orders are edited and printed in the Change Orders 
window. Posted change orders are edited and printed in the Change Orders Zoom window.

Select Inquiry > Job Cost > Job Status.
Select a job, then select Change Orders.

https://docs.key2act.io/display/Signature2018R4/Adding+cost+codes+to+a+job
https://docs.key2act.io/display/Signature2018R4/Adding+cost+codes+to+a+job


177

3.

•
•

4.
•

•
5.

6.

7.
8.

1.
2.
3.
4.
5.
6.

7.
8.
9.

10.
11.

You can either select a change order and then select the Change Order Number zoom or you can double-click a 
change order.

If the change order is unposted, the Change Orders window opens.
If the change order is posted, the Change Orders Zoom window opens. The windows are the same, except 
that the Change Order, Contract Type, and Change Order Amt. fields are disabled in the Change Orders 
Zoom window.

Change the Description, Status, and user-defined items.
If the change order is unposted, you can also change the change order number and contract type. You 
can only use Cost Plus NTE if the job contract type is Cost Plus NTE.
If the contract type is Fixed Amount, you can revise the change order amount.

Select Bill Codes to add or change bill codes for the job associated with this change order. The Job Bill Codes 
window opens. The Bill Codes button is enabled only for jobs with bill types of Cost Code or User Defined.
Select Cost Codes to add a new cost code or to edit cost code data for the existing change order. The Change 
Orders Cost Codes Setup window displays. If the change order is a Fixed Amount contract type, the Profit Type 
ID and Profit Amount fields are disabled. If the change order contract type is Cost Plus or Cost Plus NTE, the Add 
Cost Codes and Use Existing Cost Codes buttons are disabled. 

Select Print to print the Change Order Audit report.
Select OK to save the change order.

Revising posted change order estimated cost
If your change order is posted, you can revise the estimated cost in the Change Order Estimate Cost Revision Entry 
window.

Select Inquiry > Job Cost > Job Status.
Select a job, then select Change Orders.
Double-click a posted change order in the scrolling window.
Select the Cost Codes button.
Enter a Cost Code.
Select the +/- button attached to the Estimate Amount field to open the Change Order Estimate Cost Revision 
Entry window.
The system date appears in the Date field. You can change this date.
Revise the estimate by entering Units, Amount/Unit, and a Description.
To post the estimate revision, select Post. The amount and description display in the lower scrolling window.
To print the Change Order Estimate Revision List, select File > Print.
Close the Change Order Estimate Cost Revision Entry window. In the Change Orders Cost Code Setup window, 
select Save. Revised amounts are displayed in the Change Orders Zoom and Job Status windows.

Using Change Orders when using the RPO Revenue Recognition Method
If the specifications for a current job change, you can create a change order to reflect the added work, or you can edit an 
existing change order for the job in the Change Orders window. You can also alter financial or other information 
specified in the job's contract. The committed, actual, estimated, forecasted costs, and billing amounts are stored, 
allowing you to track profitability for individual change orders. 

Profit type ID and profit amount are password-protected.

If you are not using the RPO Revenue Recognition Method, please see Using Change Orders (page 175).
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RPO Revenue Recognition Method Change Order Rules (page 178)
Additional information (page 178)
Creating a change order (page 178)

Adding Change Order Revenue Codes (page 179)
Change Order Cost Codes Setup (page 179)

Editing a change order (page 180)
Revising posted change order estimated cost (page 180)

RPO Revenue Recognition Method Change Order Rules
If you are using the RPO revenue recognition method, the updated change order rules were implemented in the 
Signature 2016 R3 release. The change orders that can be created are limited based on the job's contract type:

Job Type Change Order Type

Fixed Fixed, Cost Plus

Cost Plus N/A - None

Cost Plus NTE Cost Plus NTE*

*By design, a Cost Plus NTE change order increases the overall NTE amount for the job. It is not tracked as a separate NTE 
change order.

Additional information
Cost codes can also be applied to a change order. The type of contract for the job and the change order determines 
what type of cost code you can apply to the change order.

Creating a change order
Select Inquiry > Job Cost > Job Status.
Select a job, then select Change Orders.
In the Change Order Inquiry window, select Add Change Orders.
Complete the following fields, as necessary.

Change Order, Description: Accept the default number or enter your own change order number. Enter a 
description to further identify the change order.
Status: Select a status for the change order.
Contract Type: From the drop-down list, select the type of calculation method to use for the billable 
amount of the change order. The job contract type in the Job Status window defaults.
Change Order Amt.: If you selected the Fixed Amount contract type, enter the amount of the change 
order. If you selected the Cost Plus NTE contract type, enter the change order maximum amount. If you 
chose Cost Plus as the billing type, you will not enter a change order amount. It will be automatically 

When you enter a change order transaction, make sure the posting date falls within the period you want the 
transaction to affect. The amounts in the Job Status by Period window and the Percentage of Completion 
(POC) will be totaled based on the posting dates.


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calculated, based on the cost code's profit type and profit amount, as costs are posted to the change 
order cost codes.
User-Defined: Enter user-defined information.

Select Save.

Adding Change Order Revenue Codes
Select Revenue Codes to open the Change Order Revenue Codes window.
Select or enter the revenue code.

Change Order Limit Code Type

Cost Plus 1 New

Cost Plus NTE 1 Must match current job revenue code

Fixed 1 New or existing

Complete the revenue code fields if you have created a new revenue code.
Enter the Start/End dates.

Change Order Cost Codes Setup
Select Cost Codes to open the Change Order Cost Codes Setup window. 

Enter a Cost Element Type.
Enter a Cost Code.

If the contract type of both the job and change order is Fixed Amount, you can either enter a new cost 
code, select Add Cost Codes to add a cost code from the master cost code list, or select Use Existing Cost 
Codes to use a cost code already assigned to the job.
If the job contract type and/or change order contract type is Cost Plus or Cost Plus NTE, you can only 
enter a new cost code for the change order. The Add Cost Codes and Use Existing Cost Codes buttons will 
be disabled.

Complete the remaining fields. If you are assigning a cost code with a cost element type of subcontractors, you 
must select a transaction type of Vendor ID and assign a vendor for the change order amount to affect the 
Amended Contract Amount field in the Subcontractors Maintenance window. See Adding Cost Codes to a 
Job (page 93).
Select File > Print to print the Change Order Cost Codes report listing cost codes assigned to the change order.
Select Save in the Change Order Cost Codes Setup window and close the window.
In the Change Orders window, select File > Print to print the Change Order List.
Post or save the change order. Once the change order is posted to the job, the expected contract amount and 
the estimate cost will be updated in the Job Status window.

When using existing revenue codes for change orders, you can only edit the date fields.

If you are using the revenue recognition method for RPOs, this button will be disabled until you create 
and save the change order revenue code on the change order.


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Editing a change order
You can edit posted or unposted change orders. Unposted change orders are edited and printed in the Change Orders 
window. Posted change orders are edited and printed in the Change Orders Zoom window.

Select Inquiry > Job Cost > Job Status.
Select a job, then select Change Orders.
You can either select a change order and then select the Change Order Number zoom or you can double-click a 
change order.

If the change order is unposted, the Change Orders window opens.
If the change order is posted, the Change Orders Zoom window opens. The windows are the same, except 
that the Change Order, Contract Type, and Change Order Amt. fields are disabled in the Change Orders 
Zoom window.

Change the Description, Status, and user-defined items.
If the change order is unposted, you can also change the change order number and contract type. You 
can only use Cost Plus NTE if the job contract type is Cost Plus NTE.
If the contract type is Fixed Amount, you can revise the change order amount.

Select Bill Codes to add or change bill codes for the job associated with this change order. The Job Bill Codes 
window opens. The Bill Codes button is enabled only for jobs with bill types of Cost Code or User Defined.
Select Cost Codes to add a new cost code or to edit cost code data for the existing change order. The Change 
Orders Cost Codes Setup window displays. If the change order is a Fixed Amount contract type, the Profit Type 
ID and Profit Amount fields are disabled. If the change order contract type is Cost Plus or Cost Plus NTE, the Add 
Cost Codes and Use Existing Cost Codes buttons are disabled. 

Select Print to print the Change Order Audit report.
Select OK to save the change order.

Revising posted change order estimated cost
If your change order is posted, you can revise the estimated cost in the Change Order Estimate Cost Revision Entry 
window.

Select Inquiry > Job Cost > Job Status.
Select a job, then select Change Orders.
Double-click a posted change order in the scrolling window.
Select the Cost Codes button.
Enter a Cost Code.
Select the +/- button attached to the Estimate Amount field to open the Change Order Estimate Cost Revision 
Entry window.
The system date appears in the Date field. You can change this date.
Revise the estimate by entering Units, Amount/Unit, and a Description.
To post the estimate revision, select Post. The amount and description display in the lower scrolling window.
To print the Change Order Estimate Revision List, select File > Print.
Close the Change Order Estimate Cost Revision Entry window. In the Change Orders Cost Code Setup window, 
select Save. Revised amounts are displayed in the Change Orders Zoom and Job Status windows.

Profit type ID and profit amount are password-protected.
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Working with Reminder Notes
Many major windows in Job Cost have the reminder notes feature, enabling you to attach multiple free-form notes to a 
record. The reminder note is indicated by a notepad button.

You can see a list of all reminder notes for a job, select to be reminded of the note on a specific date when you start Job 
Cost, and select to make the note printable.

Each window in Job Cost has a notepad button in the button bar to attach window-level notes. These notes can be used 
to attach instructions for completing the window and are separate from the reminder service notes.

Creating a reminder note (page 181)
Viewing reminder notes (page 181)

Creating a reminder note
To create a reminder note:

Select the notepad button in any field with an attached notepad button.
Complete the following fields, as necessary.

Note Index
Enter a name for the note. Each note for a window must have a unique name.
Author
Defaults with the current user. Use the lookup to change the author if needed.
Reminder?
Mark this checkbox if you would like to receive a message, upon opening Job Cost, that a note exists 
marked for the current system date. The current date defaults in the Reminder Date field, and can be 
edited. You must mark this checkbox if you want to be able to view the note in the Reminder Notes 
window.
Printable?
Mark the Yes radio button if you want to be able to print the note. See Printable notes in the Dexterity 
reports section of the Signature Reports documentation for instructions on printing reminder notes.
Scrolling window
Enter the note in the scrolling window.

Select Save. Once a note is created, the notepad button changes to show it has information or data.

Viewing reminder notes
Select Inquiry > Job Cost > Reminder Notes.
Enter a Date or select the lookup button in the Date field to open the Query window, where you can enter a date 
range. A list of notes that had the Reminder? checkbox marked displays in the scrolling window.
Select the lookup button in the Author field to select an author.
Double-click a note in the scrolling window to open the Notes window, where you can view and edit the note.
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Multicurrency Management Feature
The optional Multicurrency Management feature allows you to designate an originating currency for standard job 
invoices through the Job Invoice Entry and Standard Invoice or Credit windows. All costs associated with jobs are 
tracked in the functional currency only.

The functional currency is the primary currency in which a company maintains its financial records. Typically, the 
functional currency is the currency of the country where the company is located. The originating currency is the 
currency in which a multicurrency transaction was conducted.

You can also print invoices that contain bill code detail in currencies other than the functional currency, for bill code 
billing type jobs. In addition, you can enter the contract amount in the originating currency directly on the job. for bill 
code jobs.

To use the multicurrency feature in Job Cost, you must have purchased Microsoft Dynamics GP Multicurrency 
Management and Signature Multicurrency Management. For more information, contact WennSoft Sales.

Refer to the Microsoft Dynamics GP Multicurrency Management manual for setup procedures. Multicurrency is not 
functional with the Job Cost Project Level feature.

Entering the Contract Amount in the Originating Currency on the Job 
(Bill Code Jobs Only)

Select Cards > Job Cost > Job. The Job Maintenance window opens.
Select a job.
Select an originating currency in the Currency ID field. Select the expansion button to open the Exchange Rate 
Entry window, which allows you to edit the exchange rate fields, if necessary. 

In the Originating Contract Amount field in the Job Maintenance window, enter the contract amount in the 
original currency.
Select Save.

Entering billable amounts for each bill code in the originating currency
Select Cards > Job Cost > Job. The Job Maintenance window opens.
Select a job.
Select Bill Codes. The Job Bill Codes window opens.
Enter the Originating Total Billable Amount and Originating Amount per Invoice.
Select Save.
Save and close the Job Maintenance window.

Entering Multicurrency Job Invoices
When entering multicurrency job invoices, you can designate an originating currency in the Job Invoice Entry window 
and print reports in the originating or functional currency. You can use the multicurrency feature only for jobs with 
standard or user defined billing. Although the originating currency is selected, the functional currency displays in the 

All exchange rate gains and losses are tracked in Microsoft Dynamics GP, not in Signature Job Cost.
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Job Invoice Entry window and the Standard Invoice or Credit window. The originating currency prints on the invoice. 
Originating amounts can be viewed in Receivables Management.

Select Transactions > Job Cost > Job Invoice Entry. 

Complete the following fields, as necessary.
Document Type, Document Number
Enter document type and document number.
Job Number
Enter a job number. You can use multicurrency if a job uses the Standard billing type. All other job types 
will be invoiced in functional currency only.
Job Number
Defaults based on the Job Number.
Customer ID
Enter a customer ID. Multicurrency invoices cannot be entered for customers with balance forward 
accounts.
Customer Name
Defaults based on the Customer ID.
Date
Enter a document date, which determines the exchange rate in multicurrency transactions.
Batch ID
Enter a single-use batch ID. Multicurrency transactions cannot be posted in a recurring batch.
PO Number
Enter a purchase order number.
Currency ID
The currency defaults from the customer ID and can be changed. If a currency has not been specified for 
the customer, the company's functional currency will default. The Job Invoice Entry window displays 
only the functional currency.

Complete the remaining fields in the window. The Commissions button is disabled when the currency ID is an 
originating currency.
Select Schedule to display the Standard Invoice or Credit window. The functional currency displays, even though 
the originating currency is selected for the job.
Edit the Current Bill column and select Save.
In the Job Invoice Entry window, select Print. The invoice will print in the originating currency.
Select Save. Only the Graphic Invoice, Text Invoice, and Tax Detail Invoice styles will print in the originating 
currency.
You can post the invoice using Microsoft Dynamics GP Sales series posting or master posting.

About creating invoices with bill code detail
When you create a job invoice for a multi-currency bill code job, the system displays the invoice amounts in the 
originating currency; previously, the functional currency would display even though the originating currency was 
selected. 

Create job invoices as you normally would, choosing the appropriate invoice format. After the invoice has been saved or 
printed, the functional currency fields on the job and bill code will be updated with the originating currency amounts. In 
addition, all drill-downs associated with posted and historical invoices will show billing amounts in the originating 
currency.

See Entering Job Invoices (page 151) for a detailed procedure.
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Changing the currency ID on job invoices
You can now change the currency ID directly on the job invoice. You can also enter retention due amounts (for 
subcontractors) in the originating currency.

Select Transactions > Job Cost > Job Invoice Entry. The Job Invoice Entry window opens.
Fill the fields as you normally would.
Change the Currency ID, if necessary.

Change orders and bill codes
You can save bill codes to a change order before posting. This allows you to assign bill codes to change orders as 
change orders are billed, using the change order exchange and not the job's exchange rate.

Subcontractor Feature
The Subcontractor feature allows Microsoft Dynamics GP vendors to be created and saved in Job Cost as 
subcontractors. The subcontractors are then assigned to existing jobs in Job Cost. Retention is withheld from 
subcontractor invoices based on how the contract was set up. The feature also offers a Pay When Paid feature. The 
Subcontractor feature does not support the Microsoft Dynamics GP Purchasing setup option to allow duplicate invoices 
per vendor.

Setting up the Subcontractor Feature
To set up the Subcontractor feature, you must set up offset accounts, subcontractor payment options, and insurance 
options.

Setting up the Subcontractor feature involves the following:

Step 1: Set up offset accounts (page 184)
Step 2: Select subcontractor options (page 185)

Step 1: Set up offset accounts
For subcontractor retention to be calculated, the payable retention offset and payable retention liability accounts must 
be assigned to each division.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Account Setup > Subcontractor Offset Accounts.
Enter a company Division.
Enter a Payable Retention Offset account number.
Enter a Payable Retention Liability account number.
Enter a Non-Inventory Offset account number. This account is used as the credit side of the transaction in GL if 
you enter a non-inventory transaction to a job appointment.
Select Save.
To print the Offset Account List, select File > Print.

This feature applies to all jobs, not just those with multi-currency.



185

1.
2.

3.

4.
5.

•
•
•
•
•
•

•
•

Step 2: Select subcontractor options
Subcontractor options designate whether to pay the subcontractor when your company is paid, and whether to be 
reminded of the subcontractor's insurance expiration.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Subcontractor Setup > Subcontractor Options.
Mark the Pay When Paid checkbox if you will pay the subcontractor when your company is paid. If you mark the 
Pay When Paid checkbox, Job Cost automatically puts the payable on hold when you enter a payable for a 
subcontractor invoice. You release the hold when you have been paid for the sub contractor's portion of the job. 

Mark the Reminder? checkbox to receive a reminder note, notifying you before the subcontractor insurance 
expires. Enter the number of days prior to expiration you want to be reminded. When you open Job Cost on the 
designated reminder day, an alert window displays, asking if you want to see the reminder notes. 

To print the Subcontractor Options Setup List, select File > Print.
Select Save.

Using the Subcontractor Feature
To use the Subcontractor feature, you must add the subcontractors or vendors to the job and assign the subcontractor 
to a cost code. When the vendor's invoice arrives for payment, you create a payables transaction entry and distribute 
the invoice to the job and cost code. If you selected the Pay When Paid setup option, the voucher is put on payment 
hold. You can release the hold on the payables transaction after you have been paid. Once the subcontractor's job is 
complete, you generate retention invoices.

Adding subcontractors to a job record (page 185)
Distributing a payable to a job and cost code (page 187)
Releasing a payables hold (page 188)
Generating retention invoices (page 188)
Viewing updated subcontractor information (page 188)
Reconciling jobs with subcontractors (page 188)

Adding subcontractors to a job record
Adding subcontractors to a job record involves the following:

Step 1: Assign a subcontractor to a job (page 186)
Step 2: Assign a subcontractor to a cost code. (page 186)

The disabled options pertain to the Advanced Subcontractor feature.

You must open Job Cost on the designated reminder date to receive a warning. If you do not open Job 
Cost on that date and open on a later date, you will not receive a warning. You can browse through 
reminder notes (Inquiry > Job Cost > Reminder Notes) to view notes you missed.



Editing Accounts Payable subcontractor retention is not supported. The Subcontractor Module is not updated 
when an Accounts Payable subcontractor transaction is edited.


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Step 1: Assign a subcontractor to a job
You can enter information to a job regarding your vendors and subcontractors in the Subcontractors Maintenance 
window. The vendor record must exist in Microsoft Dynamics GP before it can be added to a Job Cost record.

Select Cards > Job Cost > Job.
Select a job, then select Subs/Vendors.
Complete the following fields, as necessary.

Job Vendor, Address
Enter a job vendor, or select Add Vendors to select a vendor and let the Job Vendor and Address fields 
default from the vendor record.
Hold
This checkbox is used with the Advanced Subcontractor feature. For more information, see Advanced 
subcontractor feature (page 189).
Vendor Contract Type
Select a vendor contract type from the drop-down list. Choices are NTE, Lump Sum, and Unit Price.
Contract Date, Purchase Order #
Enter the Contract Date and Purchase Order Number.
Retention %
This amount defaults from the Job Maintenance record. You can select the expansion button to open the 
Retention window, which allows you to specify a maximum retention amount for the current contract. 
Enter a Maximum Percent of Contract Amount Withheld and select OK. The retention withheld percent 
will be withheld from the subcontractor's invoices until the maximum retention amount is reached. Once 
the maximum amount is withheld, no more retention will be withheld for the subcontractor on the job. 

Mod Rate
Enter the modification rate of the contractor. This field is informational only.
User-defined
Enter user-defined information. These fields are informational only.
Bonded, Lien Waiver on File, Insurance Certificate, Insurance Expr. Date
Mark these checkboxes if applicable. If the Insurance Certificate checkbox is marked, the Insurance Expr. 
Date field is enabled. Enter the date the insurance expires.
Submit Date, Resubmit Date, Approved Date, Disapproved Date
Enter the submit date, resubmit date, approved date, and disapproved date.
Original Contract Amt
Enter the original contract amount. This amount will be used to calculate the amended contract amount 
after any change orders. For information on fields automatically updated, see Viewing updated 
subcontractor information (page 188).

To print the Subcontractor Status report, select File > Print.
Select Save.

Step 2: Assign a subcontractor to a cost code.
The subcontractor must be assigned to a cost code for retention to be calculated.

Select Cards > Job Cost > Job.
Select a job, then select Cost Codes.
Select Add Cost Codes to add a cost code for the subcontractor on the selected job. You must add a cost code 
with a cost element other than Labor.

Retention will not be withheld if a job has a billing type of SOP.
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From the Transaction Type drop-down list, select Vendor ID. The Transaction Type drop-down list is only visible 
when a cost code with a cost element other than Labor is displayed.
Select a Vendor. Accounts payable or purchase order transactions posted to a subcontractor cost code will 
automatically have retention withheld, based on the retention percent assigned to the subcontractor in the 
Subcontractors Maintenance window. 

Select Save.
Close the Job Cost Codes Setup window.
Select Save in the Subcontractors Maintenance window and the Job Maintenance window.

Distributing a payable to a job and cost code
When the vendor's invoice arrives for payment, you must create a payables transaction and distribute the invoice to the 
correct job and cost code. This allows retention to be withheld.

Select Transactions > Purchasing > Transaction Entry.
Complete the Payables Transaction Entry window. See the Microsoft – Microsoft Dynamics GP Purchase Order 
Processing Manual for information on completing this window. For Credit Memos and Invoices to appear 
correctly on the SRS Subcontractor Detail Report, the following steps must be taken during Payables 
Transaction Entry:

The original PO number for a credit memo or invoice must be entered in the Payables Transaction Entry 
window.
A credit memo must be distributed and posted to the job associated with the original purchasing 
transaction (Invoice/Shipment or Invoice Match) using the original subcontractor cost code associated 
with that job.
A credit memo must be applied to the document created by the original purchasing transaction.

Select Distributions. 

From the Product Indicator drop-down list, select Job Cost.
Enter a Job Number and Cost Code for the subcontractor. The expense amount for the cost code in the Debit
field appears as the default. If you enter a return or a credit memo, the amount appears in the Credit field. The 
cost code displays automatically if you set up default payables cost codes in Job Cost and assigned the cost 
code to the job by distribution type.
Enter amounts, complete the distribution, and select OK. See Entering payables transactions (page 115) for details. 
Retention will be automatically calculated and distributed.
In the Payables Transaction Entry window, select Post.

You can assign numerous cost codes to a vendor, but only one vendor to a cost code. You can assign 
more than one vendor to a cost code using the Advanced Subcontractor feature.



Do not edit a payables transaction that contains retention.

•

•

While intercompany transactions can be used with Job Cost subcontractors, information such as 
retention will not be updated in the destination company.
Separate accounts payable debit distribution amounts are not created for retention amounts. Instead, 
the accounts payable credit account is decreased by the amount of the retention.


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Releasing a payables hold
If the Pay When Paid option is marked in the Subcontractor Setup window and a vendor's invoice has been distributed 
to a Job and a Cost Code, the transaction record is marked on payment hold. You can release the hold on the payables 
transaction after you have been paid by the customer and are ready to pay the subcontractor.

Select Transactions > Job Cost > Subcontractor Payments.
Select a Job.
In the scrolling window, select Mark All or mark individual transactions to release. To view transaction 
information, select the document number of a marked transaction and zoom on the Apply to Document field. In 
the Payables Transaction Entry Zoom window, you can select the Distributions button to view distribution 
information.
Select Process in the Subcontractors Payments window. A message appears asking if you are sure you want to 
process the payments. Select Process. The hold on the payable is released so the subcontractor can be paid with 
the next check run.

Generating retention invoices
Once the subcontractor's job is complete to everyone's satisfaction, the retention amount can be paid.

Select Transactions > Job Cost > Subcontractor Retention.
Select a Job.
In the scrolling window, mark individual retention invoices or select Mark All to create retention vouchers in 
Payables Management. To view information on a transaction, select the document number of a marked 
transaction and zoom on the Apply to Document field. In the Payables Transaction Entry Zoom window, select 
Distributions to view distribution information.
Select Process in the Subcontractors Retention window. A message appears asking if you are sure you want to 
process the retention transactions. Select Process. This creates a payables batch with the user ID as its name. A 
payable voucher is created for each marked item. You can process a portion of the retention amount in 
increments by entering an amount in the Retention % field before choosing Process; only that partial amount 
will be processed.
Post the batch in Payables Management. See the Microsoft Dynamics GP Payables Management Manual for more 
information.

Viewing updated subcontractor information
After the subcontractor's job is complete and retention invoices have been generated, the Subcontractors Maintenance 
window is updated to record the vendor and retention invoices. The Vendor Invoices field shows the total of all vendor 
invoices posted. The Retention Withheld field shows the total retention amount of all posted invoices. The Retention 
Invoices field represents the retention invoices that have been processed. The Total field shows the total vendor 
invoices.

Select Cards > Job Cost > Job.
Select a job, then select Subs/Vendors.

Reconciling jobs with subcontractors
You can run the reconcile procedure for jobs with subcontractors or vendors to verify the information in transaction 
open files. Reconciling adjusts the totals in the master files if a discrepancy exists, and identifies posted transactions 
that contain invalid data. You can reconcile for a specific job, a range of jobs, or all jobs that have subcontractors. Back 
up your Job Cost data files before running reconcile. Make sure no one is logged into Microsoft Dynamics GP when you 
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reconcile Job Cost data files. If other users are logged in, an alert message appears, and the Job Cost reconcile process 
will not run to completion.

Select Microsoft Dynamics GP > Tools > Utilities > Job Cost > Reconcile Subcontractors.
Use the lookup buttons in the From and To fields to select a range of jobs.
Select Insert >>.
Select Reconcile.
Select Yes to the message asking if you want to reconcile.

Advanced Subcontractor Feature
The optional Advanced Subcontractor feature provides additional functionality to the standard Subcontractor feature, 
which allows Microsoft Dynamics GP vendors to be created and saved in Job Cost as subcontractors.

The Advanced Subcontractor feature does not support the Microsoft Dynamics GP Purchasing setup option to allow 
duplicate invoices per vendor. The Advanced Subcontractor feature must be registered to use this feature.

The Advanced Subcontracture feature is optional. For more information, contact WennSoft Sales.

The Advanced Subcontractor feature allows you to

Use the Subcontractor Status window, which summarizes all contracts for a subcontractor. You can also 
generate a purchase order and print subcontractor reports from the window.
Automatically place payments to subcontractors on hold if contract requirements are not met.
Assign the same job cost code to multiple subcontractors.
Receive a warning when entering a payables transaction if you exceed the subcontractor contract amount.
View whether your vendors and subcontractors have been paid for a job.
Create master subcontractors. If you use the same subcontractor on several jobs, you do not have to set up the 
subcontractor each time you create a job.
Print multiple lien waivers for a single job.
Create and manage subcontractor contract agreements for multiple jobs, and track change orders and 
payments to those subcontractors.

Adding Subcontractors to a Job Record
Adding subcontractors to a job record involves the following:

Step 1: Assign a subcontractor to a job (page 189)
Step 2: Assign a subcontractor to a cost code (page 190)
Step 3: Enter required dates for the subcontractor (page 190)

Step 1: Assign a subcontractor to a job
Select Cards > Job Cost > Job.
Select a job and select Subs/Vendors.
Complete the remaining fields, as necessary.

Job Vendor, Address
Enter a job vendor or select Add Vendors to select a vendor and let the Job Vendor and Address fields 
default from the vendor record.
Vendor Contract Type
Select a vendor contract type from the drop-down list. Choices are NTE, Lump Sum, and Unit Price.
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Contract Date, Purchase Order #
Enter the contract date and purchase order number.
Retention %
This amount defaults from the Job Maintenance record. You can select the expansion button to open the 
Retention window, which allows you to specify a maximum retention amount for the current contract. 
Enter a maximum retention amount and select OK. The retention withheld percent will be withheld from 
the subcontractor's invoices until the maximum retention amount is reached. Once the maximum 
amount is withheld, no more retention will be withheld for the subcontractor on the job. 

Mod Rate
Enter the modification rate of the contractor. This field is informational only.
User-Defined
Enter user-defined information. These fields are informational only.
Submit Date, Resubmit Date, Approved Date, Disapproved Date
Enter the submit date, resubmit date, approved date, and disapproved date. See Enter required dates for 
the subcontractor (page 190) for information on using the Subcontractor Dates button.
Original Contract Amt
This amount will be used to calculate the amended contract amount after any change orders. For 
information on fields automatically updated, see Viewing Updated Subcontractor Status Window (page 
194). 

To print the Subcontractor Status report, select File > Print.
Select Save.

Step 2: Assign a subcontractor to a cost code
The subcontractor must be assigned to a cost code for retention to be calculated.

Select Cost Codes in the Subcontractors Maintenance window.
Select Add Cost Codes to add a cost code for the subcontractor on the selected job. The cost code must already 
be assigned to the job. See Adding Cost Codes to a Job (page 93). You can assign numerous cost codes to a 
subcontractor. You can also assign one cost code to multiple subcontractors. Accounts payable or purchase 
order transactions posted to a subcontractor cost code will automatically have retention withheld, based on the 
retention percent assigned to the subcontractor in the Subcontractors Maintenance window.
If you do not want to print lien waivers for this cost code, mark the Don't Print Lien Waivers checkbox.
To print a report listing all cost codes assigned to the subcontractor on the job, select File > Print in the 
Subcontractor Cost Codes window.

Step 3: Enter required dates for the subcontractor
Select Subcontractor Dates in the Subcontractors Maintenance window.
The Subcontractor Dates window lists required items. Required items are defined in the Subcontractor Master 
Documents window. See Set up master documents (page 192). Enter a date for each required item.
Once an item is received, mark the Received checkbox and enter the date received. If you have required 
documents entered in the Insurance Dates window, select the ellipsis button in the Insurance Certificate 
Required Date field to enter the received date. Likewise, select the ellipsis button in the Lien Waiver Required 
Date field to enter received dates for lien waivers. See Entering insurance dates for a master subcontractor (page 
201) and Managing Lien Waivers (page 203) for more information. 

If a required item is not submitted by the date listed, the subcontractor for the job will be marked on hold in the 

Retention will not be withheld if a job has a billing type of SOP.
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Subcontractors Maintenance window. A star indicates the item was not received by the required date. The 
subcontractor for this job will remain on hold until the item is received.
Select Save.

Setting up the Advanced Subcontractor Feature
To set up the Advanced Subcontractor feature, you must set up offset accounts, subcontractor payment and insurance 
options, and master documents.

Setting up the Advanced Subcontractor feature involves the following:

Step 1: Set up offset accounts (page 191)
Step 2: Select subcontractor options (page 191)
Step 3: Set up master documents (page 192)

Step 1: Set up offset accounts
For subcontractor retention to be calculated, the payable retention offset and payable retention liability accounts must 
be assigned to each division.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Account Setup > Subcontractor Offset Accounts.
Enter a company Division.
Enter a Payable Retention Offset account number.
Enter a Payable Retention Liability account number.
Enter a Non-Inventory Offset account number. This account is used as the credit side of the transaction in GL if 
you enter a non-inventory transaction to a job appointment.
Select Save.
To print the Offset Account List, select File > Print.

Step 2: Select subcontractor options
Subcontractor options designate whether to pay the subcontractor when your company is paid, and whether to be 
reminded of the subcontractor's insurance expiration.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost >Subcontractor Setup > Subcontractor Options.
Pay When Paid
Mark this checkbox if you will pay the subcontractor when your company is paid. Job Cost will 
automatically put the payable on hold when you enter a payable for a subcontractor invoice. You release 
the hold when you have been paid for the subcontractor's portion of the job.
Track Multiple Lien Waivers per Job/Subcontractor
Mark this checkbox to track multiple lien waivers per job. This checkbox is enabled only if the Use Master 
Subcontractors checkbox is marked. See Printing Lien Waivers (page 202).
Allow Retention Release if Subcontractor is on Hold
Mark this checkbox to allow the release of retention for subcontractors on hold.
Automatically Add Purchase Order Cost Code to Subcontractor
Mark this checkbox to automatically add cost codes to a subcontractor during purchase order entry.
Use Master Subcontractors, Track Insurance Dates in Detail (Many per Job), Always Copy Master 
Subcontractor Data
Mark this checkbox to enable the master subcontractors feature. Marking the Use Master Subcontractors 
checkbox enables the Track Insurance Dates in Detail (Many per Job) checkbox. See Using Master 
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Subcontractors (page 198). The Always Copy Master Subcontractor Data checkbox is enabled if you are 
using the CIS feature.
Reminder?
Mark this checkbox to receive a reminder note, notifying you before the subcontractor insurance expires. 
Enter the number of days prior to expiration you want to be reminded. When you open Job Cost on the 
designated reminder day, an alert window displays, asking if you want to see the reminder notes. 

Print Lien Waiver for Job When Check Payment to That Job Exceeds
To specify a minimum amount that a check must contain before a lien waiver can be printed, enter that 
amount in this field. This amount should be less than the check amount in Payables Management. If this 
amount is zero (the default), a lien waiver will print for all checks. The Construction Industry Scheme 
feature is only available for UK customers.

To print the Subcontractor Options Setup List, select File > Print.
Select Save.

Step 3: Set up master documents
If the subcontractor has not submitted required items or documents by a specific date, the Hold checkbox will be 
marked in the Subcontractors Maintenance window for the subcontractor. Additionally, if you are using the Pay-When-
Paid feature, when you try to release a payables hold and the subcontractor is marked on hold in the Subcontractors 
Maintenance window, you cannot release the payables hold. If the Pay-When-Paid feature isn't marked, payables will 
not be put on hold. Reminder notes for each item or document can be generated.

If you marked the Track Insurance Dates in Detail (Many per Job) checkbox in the Subcontractor Options window, you 
can enter labels for four types of insurance to be tracked using the Insurance Dates window. See Entering insurance 
dates for a master subcontractor (page 201).

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > User-Defined Label Setup > Subcontractor Master 
Document Types.
Select a label and enter an Item Description.
Select Save.
Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Subcontractor Setup > Subcontractor Master Documents.

Required
Mark the required items to be received from the subcontractor. If items are not received from a 
subcontractor by a specified date, the subcontractor's payments will be put on hold for that job.
Reminder?
Mark the items you want a reminder for. See Working with Reminder Notes (page 181).
Days Notice
Enter the number of days prior to the required date you want to receive a reminder.

Select Save.

Using the Advanced Subcontractor Feature
To use the Advanced Subcontractor feature, you must add the subcontractors or vendors to the job and assign the 
subcontractor to a cost code. When the vendor's invoice arrives for payment, you create a payables transaction entry 
and distribute the invoice to the job and cost code. If you selected the Pay When Paid setup option, the voucher is put 

You must open Job Cost on the designated reminder date to receive a warning. If you do not 
open Job Cost on that date and open on a later date, you will not receive a warning. You can 
browse through reminder notes (Inquiry > Job Cost > Reminder Notes) to view notes you 
missed.


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on payment hold. You can release the hold on the payables transaction after you have been paid. Once the 
subcontractor's job is complete, you generate retention invoices.

Distributing a Payable to a Job and Cost Code
When the vendor's invoice arrives for payment, you must create a payables transaction and distribute the invoice to the 
correct job and cost code. This allows retention to be withheld.

Select Transactions > Purchasing > Transaction Entry.
Complete the Payables Transaction Entry window. See the Microsoft Dynamics GP Purchase Order Processing 
Manual for more information.
Select Distributions.
From the Product Indicator drop-down list, select Job Cost.
Enter a Job Number and Cost Code for the subcontractor. The expense amount for the cost code in 
the Debit field appears as the default. If you enter a return or a credit memo, the amount appears in 
the Credit field. The cost code displays automatically if you set up default payables cost codes in Job Cost and 
assigned the cost code to the job by distribution type.
Enter amounts, complete the distribution, and select OK. See Entering payables transactions (page 115) for details. 
Retention will be automatically calculated and distributed.
In the Payables Transaction Entry window, select Post.

Releasing a Payables Hold
If the Pay When Paid setup option was marked and a vendor's invoice has been distributed to a job and a cost code, the 
transaction record is marked on payment hold. You can release the hold on the payables transaction after you have 
been paid by the customer and are ready to pay the subcontractor. If the subcontractor to which the job is assigned is 
marked on hold in the Subcontractors Maintenance window, you cannot release the payables hold.

Select Transactions > Job Cost > Subcontractor Payments.
Select a Job.
In the scrolling window, select Mark All or mark individual transactions to release. To view transaction 
information, select the document number of a marked transaction and zoom on the Apply to Document field. In 
the Payables Transaction Entry Zoom window, you can select the Distributions button to view distribution 
information.
Select Process in the Subcontractors Payments window. A message appears asking you if you are sure you want 
to process the payments. Select Process. The hold on the payable is released so the subcontractor can be paid 
with the next check run.

Editing Accounts Payable subcontractor retention is not supported. The Advanced Subcontractor Module is 
not updated when an Accounts Payable subcontractor transaction is edited.



While intercompany transactions can be used with Job Cost subcontractors, information such as retention and 
master subcontractors will not be updated in the destination company. Separate accounts payable debit 
distribution amounts are not created for retention amounts. Instead, the accounts payable credit account is 
decreased by the amount of the retention.





194

1.
2.
3.

4.

5.

1.
2.

1.
2.
3.
4.
5.

Generating Retention Invoices
Once the subcontractor's job is complete to everyone's satisfaction, the retention amount can be paid. If the 
subcontractor to which the job is assigned is marked on hold in the Subcontractors Maintenance window, then 
retention invoices will be marked on hold and cannot be processed. See Select subcontractor options (page 191).

Select Transactions > Job Cost > Subcontractor Retention.
Select a Job.
In the scrolling window, mark individual retention invoices or select Mark All to create retention vouchers in 
Payables Management. To view information on a transaction, select the document number of a marked 
transaction and zoom on the Apply to Document field. In the Payables Transaction Entry Zoom window, 
select Distributions to view distribution information.
Select Process in the Subcontractors Retention window. A message appears asking if you are sure you want to 
process the retention transactions. Select Process. This creates a payables batch with the user ID as its name. A 
payable voucher is created for each marked item.
Post the batch in Payables Management. See the Microsoft Dynamics GP Payables Management Manual for more 
information.

Viewing Updated Subcontractor Status Window
After the subcontractor's job is complete and retention invoices have been generated, the Subcontractors Maintenance 
window is updated to record the vendor and retention invoices. The Vendor Invoices field shows the total of all vendor 
invoices posted. The Retention Withheld field shows the total retention amount of all posted invoices. The Retention 
Invoices field represents the retention invoices that have been processed. The Total field shows the total vendor 
invoices.

Select Cards > Job Cost > Job.
Select a job, then select Subs/Vendors.

Reconciling Jobs with Subcontractors
You can run the reconcile procedure for jobs with subcontractors or vendors to verify the information in transaction 
open files. Reconciling adjusts the totals in the master files if a discrepancy exists, and identifies posted transactions 
that contain invalid data. You can reconcile for a specific job, a range of jobs, or all jobs that have subcontractors.

Select Microsoft Dynamics GP > Tools > Utilities > Job Cost > Reconcile Subcontractors.
Use the lookup buttons in the From and To fields to select a range of jobs.
Select Insert >>.
Select Reconcile.
Select Yes to the message asking if you want to reconcile.

Withholding Retention on Purchase Order Invoices
The Purchase Order Processing module (POP) integrates with the Advanced Subcontractor feature. The integration 
allows retention to be withheld from purchase order invoices.

Back up your Job Cost data files before running reconcile. Make sure no one is logged into Microsoft Dynamics 
GP when you reconcile Job Cost data files. If other users are logged in, an alert message appears, and the Job 
Cost reconcile process will not run to completion.


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You must complete the following procedures before using POP with the Advanced Subcontractor feature.

Assign a retention offset and retention liability account to each Job Cost division. See Set up offset 
accounts (page 191).
Add a vendor to the job and enter a retention amount. See Adding subcontractors to a job record (page 185).
Assign a subcontractor to at least one of the job's cost codes so retention can be calculated. See Adding 
subcontractors to a job record (page 185).

Step 1: Enter a purchase order
Select Transactions > Purchasing > Purchase Order Entry.
Complete the Purchase Order Entry window as usual. See the Microsoft Dynamics GP Purchase Order Processing 
Manual for more information. In addition, complete the following fields:

Vendor ID
Enter the vendor you have set up for retention.
Product Indicator
Select Job Cost from the drop-down list.
Job No.
Select a job that has the subcontractor/vendor assigned to one of the job's cost codes.
Cost Code
Enter the cost code for the job.

Step 2: View the retention percentage
Select the expansion button in the Item field in the Purchase Order Entry window to open the Purchase Order Item 
Detail Entry window. The retention percent displays in the Retention field.

Step 3: Enter a receipt
Select Transactions > Purchasing > Receivings Transaction Entry.
Complete the Receivings Transaction Entry window. See the Microsoft Dynamics GP Purchase Order Processing 
Manual for more information. If this is a shipment/invoice receipt, you can edit the retention percentage. If this is 
a shipment receipt, you cannot edit the retention percentage. The extended cost of the item multiplied by the 
retention percent determines the amount to retain from the transaction.

Step 4: Enter an invoice
You must enter an invoice for shipment receipts.

Select Transactions > Purchasing > Enter/Match Invoices.
Complete the Purchasing Invoice Entry window. See the Microsoft Dynamics GP Purchase Order Processing 
Manual for more information. You can change the retention percentage for each line item if the item is matched 
to only one shipment document. For items matched to more than one shipment document, select the expansion 
button in the Matched to Shipment field to open the Match Shipments to Invoice window.

Step 5: View the result in Job Cost
Select Cards > Job Cost > Job.
Select a job, then select Subs/Vendors. The Total field reflects the retention withheld.
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Step 6: View the result in Microsoft Dynamics GP
Select Inquiry > Purchasing > Transaction by Vendor. The payables transaction reflects the retention amount.
Select an invoice and zoom on the Document Number field. The total amount of the payable displays in the 
Payables Transaction Entry Zoom window.

Using the Subcontractor Status Window
The Subcontractor Status window summarizes all contract, retention, and invoice amounts for a subcontractor.

Select Inquiry > Job Cost > Subcontractor Status.
Use the lookup to select a Vendor ID. The following information displays for the selected subcontractor:

Total Original Contract Amount
Displays the total of the original contract amounts of open job contracts.
Total Change Orders
Displays the total of all change orders.
Total Contract Amount
Displays the total of open job contracts.
Total Vendor Invoices
Displays the total of all purchasing invoices (from Accounts Payable or Purchase Order Receivings) that 
have been processed against open jobs.
Remaining Contract Amount
Displays the total amount remaining on the contract.
Total Retention Withheld
Displays the total of all retention withheld against purchasing invoices.
Total Released Retention Invoices
Displays the total of all retention invoices generated. Invoices are generated to pay the subcontractor for 
retention withheld against purchasing invoices.

Select the Stop-and-Go Light indicator in the Subcontractor Status window to open the Subs Job Summary 
window where you can double-click a job to open the Subcontractors Maintenance window. A red light indicates 
the subcontractor is on hold for a job. A green light indicates the subcontractor is not on hold.

You can add jobs, cost codes, and required dates for the subcontractor using the Add Jobs button. See Adding 
subcontractors/vendors to a job (page 100).

You can create a purchase order for the subcontractor using the Create PO button. See Withholding Retention on 
Purchase Order Invoices (page 194).

You can select the printer button in the Vendor field to select a subcontractor report to print. See Subcontractor 
reports in the Dexterity reports section of the Signature Reports documentation for more information.

Viewing Vendor Payments
The Job Transaction Inquiry - Vendor window allows you to view whether your vendors and subcontractors have been 
paid for a job. This window displays all amounts billed from and paid to a vendor per job, including the following:

Invoices from vendors that are not subcontractors

When you create a purchase order for a subcontractor or master subcontractor, the original contract amount 
is not updated for the subcontractor. You must update the original contract amount manually in the 
Subcontractors Maintenance window.


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Invoices from transactions without a purchase order, including transactions originating from contract 
agreements and payables transactions entries
Payments applied to subcontractor retention ("retention released") invoices

In addition, the new Subcontractor Transaction Detail report shows the details of payments billed, retained, and paid to 
subcontractors. This report is not currently designed to work if you use tax on Contract Agreements.

Select Inquiry > Job Cost > Job Status, and select a job. The Job Status window displays job costs by cost code.
Use the Vendors button to open the Job Transaction Inquiry - Vendor window. This button is disabled if you do 
not have the Advanced Subcontractor feature registered.
Use the following fields to filter and sort the vendor transactions that appear in the scrolling window:

Vendor ID
The lookup shows vendors only for the selected job. All vendors that have a payables voucher associated 
with the job will display in the lookup. A vendor with no transactions may appear if that vendor is set up 
as a subcontractor for the job. If a job has no vendors or subcontractors, the lookup displays all vendors 
in the system, without any filtering.
Job
The job defaults from the Job Status window.
Sort By
You can sort transactions by Document Number, or by Date then Voucher Number.
Include History
This checkbox defaults as marked; unmark the checkbox if you do not want any historical transactions to 
appear in the scrolling window.

If no transactions appear in the scrolling window, this may be because:

The selected vendor is set up as a subcontractor on the job, but there are no transactions for the vendor.
The selected vendor has a transaction in the work table and no posted invoices.
The selected vendor has only historical transactions, and the History checkbox is not marked.

The following information displays in the scrolling window for each vendor transaction:

Type
Indicates whether the transaction is an invoice or a credit memo. 

Document Number
Shows the document number and allows you to zoom to the Payables Transaction Entry window, or If the 
transaction is a POP Shipment/Invoice, the Receiving Transaction Inquiry window opens. If the transaction is a 
POP Receivings Entry, the Purchasing Inventory Inquiry window opens.
Date
The invoice date is used when you select to sort transactions by Date (then Voucher Number).
Amount Invoiced
This is the total amount of the transaction, including retention (Invoice Gross of Retention).
Document Amount
This is the amount of the transaction, not including retention (Invoice Net of Retention). Tax is included for 
subcontractor invoices, and/or for vendors if tax was applied to the job.
Amount Remaining
This shows the invoice amount, minus any payments applied. You can zoom to the Payable Apply Zoom window 

To display purchase order payment information correctly, we recommend having just one line per PO, but if 
you have multiple lines, each line must have its own receipt and each receipt must have its own invoice.



Returns display as credit transactions. You can zoom on the Document Number to view the details of 
the return on the Returns Transaction Inquiry Zoom window.


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for payment detail. You can select a transaction and zoom on the Document Number to view the details of the 
agreement. You can also zoom on the Amount Remaining to view details of the payable applied. You can expand 
the results in the scrolling window to view the following information as well.
Voucher Number
When transactions are sorted by Date, the voucher number is also the secondary sort field.
Transaction Description
This description defaults from the invoice.
Retention Withheld
If the vendor is a subcontractor, this field displays the original amount of retention that was withheld. This 
amount does NOT decrease as retention is paid.
Retention Remaining
If the vendor is a subcontractor, this field displays the amount of retention that remains to be paid. If a 
subcontractor has been paid, the amount remaining is zero.

Select Print to print the Job Transaction Vendor - Inquiry report, which includes all the detail from the window for 
payments billed, retained and paid to subcontractors.

Using Master Subcontractors
You can set up master subcontractors as templates for vendors used on multiple jobs. If you use the same 
subcontractor on several jobs, you don't have to set up the subcontractor each time you create a job. Instead, you can 
create a master subcontractor and assign the jobs to that master subcontractor.

Subcontractor: With subcontractors, you assign a subcontractor to a job. Therefore, the relationship of the 
subcontractor and cost codes to a job is as follows:

Master subcontractor: With the master subcontractor feature, the relationship of a master subcontractor to a 
job and cost codes is as follows:

When you create a master subcontractor using the Master Subcontractors Maintenance window for a vendor that 
already exists as a subcontractor, that master subcontractor still exists as a subcontractor. The main differences are:

The master subcontractor record is the parent record of the cost code and jobs.
When you first create a master subcontractor, some information is copied to the Subcontractors Maintenance 
window and sub windows. See Create the master subcontractors. (page 199).

If a POP or PM invoice has multiple line items, when any line on the invoice is assigned to the job, the entire 
transaction amount appears on this window. However, all line items may not be related to the job. You can 
zoom on the invoice for line detail. Likewise, a credit memo displays when it was assigned to the selected job 
in the Distribution window, even if it was not applied to this job. You can zoom on the credit memo to see 
which job it was applied to.


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Using master subcontractors involves the following:

Setting up and creating master subcontractors (page 199)
Step 1: Set up the master subcontractor feature (page 199)
Step 2: Create the master subcontractors. (page 199)

Assigning a job to a master subcontractor (page 200)
Assigning a cost code to a master subcontractor (page 200)
Entering insurance dates for a master subcontractor (page 201)
Creating a purchase order for a master subcontractor (page 201)

Automatically adding cost codes to a subcontractor on a purchase order (page 201)
Specifying required documents for a master subcontractor (page 202)

Setting up and creating master subcontractors

Step 1: Set up the master subcontractor feature

To use master subcontractors, you must mark the Use Master Subcontractors checkbox in the Subcontractor Options 
window.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Subcontractor Setup > Subcontractor Options.
Mark the Use Master Subcontractors checkbox.
Mark the Track Insurance Dates in Detail (Many per Job) checkbox to enable the Insurance Dates button in the 
Subcontractor Status and Master Subcontractor Maintenance windows and the ellipsis button in the Insurance 
Certificate field in the Subcontractors Dates window. You can enter insurance company information for each 
master subcontractor, including policy numbers and effective dates. Insurance fields are user-definable. See Set 
up master documents (page 192). See Entering insurance dates for a master subcontractor (page 201) for 
information on tracking insurance information.
Select Save.

Step 2: Create the master subcontractors.

Subcontractors who work on several jobs can be set up as master subcontractors. Master subcontractors allow you to 
define your vendor-job relationship at the vendor level instead of at the job level.

Select Cards > Job Cost > Master Subcontractor.
Complete the following fields, as necessary.

Master Sub ID
Use the lookup to select a vendor.
Vendor Contract Type
Select a vendor contract type from the drop-down list. Choices are NTE, Lump Sum, and Unit Price.
Contract Date, Purchase Order #
Enter the contract date and purchase order number.
Retention %
If the master subcontractor already has a retention percentage entered for any cost codes, a message 
appears telling you that the subcontractor cost codes will be updated with the new retention amount. 
Select Continue to update the cost codes or Cancel to not update the cost codes.
Mod Rate, User-defined
These fields are informational only.
Submit Date, Resubmit Date, Approved Date, Disapproved Date
Enter the submit date, resubmit date, approved date, and/or disapproved date.

Select Save.
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The Stop-and-Go Light indicator indicates whether the subcontractor is marked on hold in the Subcontractors 
Maintenance window. A red light indicates the subcontractor is on hold for a job. A green light indicates the 
subcontractor is not on hold. The Hold checkbox in the Master Subcontractors Maintenance window isn't used.

You can also do the following from the Master Subcontractors window:

Assign a job to a master subcontractor.
Assign a cost code to a master subcontractor.
Enter insurance dates for a master subcontractor.
Create a purchase order for a master subcontractor.
Specify required documents for a master subcontractor.
Manage lien waivers for a master subcontractor.

Assigning a job to a master subcontractor
You can assign jobs to a master subcontractor using the Add Jobs button in the Master Subcontractors Maintenance 
window.

When you assign a job to a master subcontractor for the first time, information from all the fields in the Master 
Subcontractors Maintenance window is copied to the corresponding fields in the Subcontractors Maintenance window 
for that vendor. This information is copied only if a job was not previously assigned to the subcontractor in the 
Subcontractors Maintenance window.

Select Cards > Job Cost > Master Subcontractor.
Select a subcontractor, then select Add Jobs.
Select a job and complete the Subcontractors Maintenance window. See Adding subcontractors/vendors to a 
job (page 100).
Select Save.

To view a list of jobs assigned to a master subcontractor, select the Stop-and-Go Light indicator in the Master 
Subcontractors Maintenance window.

Assigning a cost code to a master subcontractor
You can assign cost codes directly to a master subcontractor. Once a job is assigned to a master subcontractor, the cost 
codes are automatically copied to the subcontractor record assigned to that job.

Select Cards > Job Cost > Master Subcontractor.
Select a subcontractor, then select the Cost Codes button.
Enter a Cost Element. The default is 2 (Materials).
Use the lookup to select a Cost Code, or select the Add Cost Codes button to select from the master cost code 
list.
If you do not want to print lien waivers for this cost code, mark the Don't Print Lien Waivers checkbox.
Select Save.

When you assign a cost code to a master subcontractor, you can view that job/subcontractor/cost code association in 
the Subcontractor Cost Codes window.

If you save the Master Subcontractors Maintenance window, then reopen the window to make changes, none 
of the changes will copy to the Subcontractors Maintenance window.


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Entering insurance dates for a master subcontractor
You can enter insurance company information for each master subcontractor, including policy numbers and effective 
dates. If a policy expires, the vendor and all jobs the vendor is assigned to are put on hold.

Select Cards > Job Cost > Master Subcontractor.
Select a subcontractor, then select Insurance Dates.
Complete the following fields:

Required
Mark the insurance policies that are required for this master subcontractor.
Starting, Ending, Received
Enter the Starting, Ending, and Received dates. The ending date will be copied to the Required Date 
column in the Subcontractor Dates window for this subcontractor. The required date in the 
Subcontractor Dates window is automatically set to be the earliest ending date of the required insurance 
types in the Insurance Dates window. This date is copied to all jobs to which the subcontractor is 
assigned. If you do not enter an ending date for an insurance type that is marked as required, the 
subcontractor will be on hold.
Required, Available
Enter coverage amounts. These fields are informational only.
Company, Policy Number
For each insurance company, enter the company name and policy number.

Select Save.

Creating a purchase order for a master subcontractor
You can create a purchase order for a master subcontractor from the Master Subcontractors Maintenance 
window.
Select Cards > Job Cost > Master Subcontractor.
Select a Subcontractor, then select Create PO.
Complete the Purchase Order Entry window. See the Microsoft Dynamics GP Purchase Order Processing 
Manual for more information. The Vendor ID fills automatically from the Master Subcontractors Maintenance 
window.
When entering a purchase order for a master subcontractor, if you select a job to which the master 
subcontractor is not assigned, a message displays telling you that the selected vendor is not a subcontractor for 
the selected job. This allows you to assign that subcontractor to that job. Select Yes to add the master 
subcontractor to the job, or No to not add. If you select Yes, the Subcontractors Maintenance window opens. 
Complete the window.

Automatically adding cost codes to a subcontractor on a purchase order

To automatically add cost codes to a subcontractor when entering a purchase order, mark the Automatically Add 
Purchase Order Cost Code to Subcontractor checkbox in the Subcontractor Options window. This applies to cost codes 
assigned to a job that are not linked to a subcontractor in the Subcontractors Maintenance window.

You can automatically add cost codes from the Purchase Order Entry window and Item Detail Entry window.

If retention needs to be withheld, make sure you enter a contract amount in the Original Contract Amt field in 
the Subcontractors Maintenance window. Otherwise, retention will not be withheld from Purchase Order 
Processing or Payables Management.


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Specifying required documents for a master subcontractor
You can specify if a document pertaining to this master subcontractor is required.

Select Cards > Job Cost > Master Subcontractor.
Select a subcontractor, then select Master Subcontractor Documents.
Mark the documents that are Required and select Save.
A message appears asking if you want to save the changes in this window only or save the changes in this 
window and roll down the changes to the subcontractor record associated with the job or jobs. 
Select Save or Rolldown.

Printing Lien Waivers
You print lien waivers for subcontractors as part of the payables check process. You can also track multiple lien waivers 
for the same job.

Setting up lien waivers.
Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Subcontractor Setup > Subcontractor Options.
Mark the Track Multiple Lien Waivers per Job/Subcontractor checkbox.
To specify a minimum amount that a check must contain before a lien waiver can be printed, enter that amount 
in the Print Lien Waiver for Job When Check Payment to That Job Exceeds field. This amount should be less 
than the check amount in Payables Management. If this amount is zero, which is the default, a lien waiver will 
print for all invoices.
Select Save.

Printing lien waivers with the checks
You can print lien waivers as part of the check posting process in Microsoft Dynamics GP. You can also restrict the 
printing of lien waiver for specific cost codes. See Assigning a cost code to a master subcontractor (page 200) for more 
information.

Process and print checks as you normally would. See the Microsoft Dynamics GP Payables Management 
Manual for more information. When the check processing is finished, the Print Lien Waivers window opens. 
There might be a slight delay before the Print Lien Waivers window opens.
Enter a starting and ending check number for checks that have just been printed.
Select Process.

If the Pay When Paid option is marked in the Subcontractor Options window, you must release the invoices for 
payment before you can print lien waivers. See Releasing a Payables Hold (page 193).



Completed lien waivers are generated only for payables documents that are fully applied. If a payable has 
been processed that is not fully applied, a blank lien waiver will appear. Also, if you post checks using series 
posting or master posting, the Print Lien Waivers window will not appear.





203

•
•
•

1.
2.
3.

•

•

•

•

4.

1.
2.
3.

4.
5.

1.
2.
3.

4.
5.
6.

Managing Lien Waivers
You can view lien waivers, mark lien waivers as received, and reprint lien waivers using the Manage Lien Waivers 
window.

Receiving lien waivers (page 203)
Viewing received lien waivers (page 203)
Reprinting lien waivers (page 203)

Receiving lien waivers
Select Cards > Job Cost > Master Subcontractor.
Select a subcontractor and select Manage Lien Waivers.
Complete the following fields:

Job Number
Select a job.
Vendor ID
This field defaults to the vendor selected in the Master Subcontractors Maintenance window or 
Subcontractors Maintenance window.
Display
Select the Unreceived radio button.
Date Received
Mark this checkbox for the lien waiver(s) you want to receive, or select Mark All.

Select Process. To unreceive lien waivers, unmark the Date Received checkbox and select Process. To unreceive 
all lien waivers, select Unmark All before Process.

Viewing received lien waivers
Select Cards > Job Cost > Master Subcontractor.
Select a Subcontractor and select Manage Lien Waivers.
Select a job in the Job Number field. The Vendor ID defaults to the vendor selected in the Master 
Subcontractors Maintenance window or Subcontractors Maintenance window.
Select the Received radio button.
To view the details of a check, mark the Date Received checkbox, then zoom on the Check Number field.

Reprinting lien waivers
Select Cards > Job Cost > Master Subcontractor.
Select a Subcontractor and select Manage Lien Waivers.
Select a job in the Job Number field. The Vendor ID defaults to the vendor selected in the Master 
Subcontractors Maintenance window or Subcontractors Maintenance window.
In the scrolling window, mark the checkbox next to the check(s) you want to reprint.
Select Reprint. The Print Lien Waivers window opens. The starting and ending check numbers default.
Select Process. The Printed field in the Manage Lien Waivers window updates with the current date for the lien 
waivers just printed.
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Transfer Utility
Subcontractor feature users can transfer their information to the Advanced Subcontractor feature using a utility. Run 
this utility if you had been using the regular subcontractor feature but now use the Advanced Subcontractor 
feature. The utility will create subcontractor cost code records in all the required places to use the Advanced 
Subcontractor feature.

Select Microsoft Dynamics GP > Tools > Utilities > Job Cost > Subcontractor Transfer.
Use the lookup buttons in the From and To fields to select a range.
Select Insert >>.
Select Transfer.
Select Yes to the message asking you to back up your Job Cost files before running the utility.

Subcontractor Contract Agreements
Subcontractor contract agreements allow you to create and manage contracts for subcontractors - for multiple jobs - 
and to track change orders and payments to those subcontractors. When you create a contract, you distribute the 
contract amount across the relevant cost codes. These cost codes must be assigned to the job.

A contract can have one of four statuses: Pending, Confirmed, Closed, and Canceled. Confirmed is the active 
status, and the only one in which you can create change orders and post payments. Pending allows you to start 
entering information prior to a contract being finalized and approved.
Retention can be applied per cost code.
A subcontractor can have multiple contracts on one job.
Unposted costs are reflected in committed costs in Job Cost
A contract can be closed, even if there is retention left to be paid.

Suppressing taxes for contract agreement AP transactions
In some non-US locales, taxes are suppressed when posting to jobs. You can suppress taxes on AP transactions created 
for contract agreements as well.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Job Cost Setup > Setup Options. The Job Cost Setup 
Options window opens.
Mark Suppress Contract Payment tax update to Job Cost and Service Management.
Select Save.

Customizing labels for contract agreement user-defined fields
Select Microsoft Dynamics GP > Tools > Setup > Job Cost > User-Defined Label Setup > Contract Agreement. The 
User Defined Contact Agreement window opens.
Enter the names for the desired fields in the left column. Select Save when finished.

Creating subcontractor contracts
When you create a contract agreement, it defaults to a Pending state. This allows you to enter information before a 
contract is finalized, at which time, you would change the contract to Confirmed.

You must have purchased the Advanced Subcontractor feature to use this function.
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Select Cards > Job Cost > Contract Agreement. The Contract Agreement window opens.
Select a Contract Vendor, and enter a Contract Number and Contract Name.
Complete the following fields; some are filled automatically by the system and cannot be edited.

Contract Status
Defaults to Pending. As soon as the Contract Agreement window is filled in and saved, you can change 
the status to Confirmed - the status used when the contract is active; payments and change orders can be 
created only if the contract is Confirmed. Canceled means the contract will no longer be active, meaning 
no further activity is allowed and the contract cannot be reversed. Closed means the contract has been 
completely fulfilled (all payments made).
Original Contract Amount
Enter the total original contract amount. Once the contract status is Confirmed, the contract amount can 
be changed only with change orders.
Change Orders
Fills automatically with the sum of all change orders applied to this contract.
Contract To Date
Fills automatically with the amount of the original contract amount plus change orders minus any 
payments made.
Tax Schedule
Enter the tax schedule to be used with this contract.
Retention %
Enter the retention percent that will be withheld from payment until services are favorably satisfied. 
When you assign cost codes to this contract, you can enter unique retention percentages for each cost 
code, if necessary.
Estimated % Complete
If you want to track estimated completion percentage, enter it here. This field is not updated by the 
system.
Scheduled Start/Completion Dates
Enter the start and completion dates of the contract agreement.
User-Defined fields
User-defined fields are used to store additional information. If your organization has defined these, 
consult with your Manager or Supervisor to determine if these are required.

Save the window. When a Confirmed contract agreement is saved, the costs become committed costs in Job 
Cost.
To distribute the contract amount to cost codes, select the Add Cost Codes button. The Available Contract Cost 
Codes window opens.
Select a Job Number. The available cost codes appear.
Select the cost codes to distribute. You can multi-select several by using CTRL-click and SHFT-Select. After 
selection, select the Select button. The window closes and the cost codes appear in the Contract Agreement 
window.

Choosing costs codes

In the Contract Cost Codes scrolling window, you can specify a Retention% and Cost Code Cost; this cost is the 
amount of the total contract amount you want to apply to this cost code.
The total of the distributed cost code amounts MUST equal the total contract amount; otherwise, you will 
receive a message and will not be able to save the contract agreement.
When finished distributed the contract amount, select Save. When you are satisfied with the information entered 
and ready to move forward with the contract agreement, change the Contract Status to Confirmed, 
then Save again. The Change Orders and Payments buttons will be enabled.
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Creating change orders for a contract agreement

Just as you can for jobs, you can create change orders for contract agreements and assign them per cost code.

Select Cards > Job Cost > Contract Agreement. The Contract Agreement window opens.
Select a contract agreement, then select the Change Orders button at the top of the window. The Contract 
Change Order Inquiry window opens. Any existing change orders are displayed in the window.
To create a change order, select Add Change Orders at the bottom right of the window. The Contract Agreement 
Change Order window opens.
Enter a Change Order Number. This number must be unique for every change order.
Enter a Change Order Amount. Retention % defaults from the Contract Agreement window.
To distribute the contract amount to cost codes, select the Add Cost Codes button. The Available Contract Cost 
Codes window opens.
Select a Job Number. The available cost codes appear. Using the lookup, you can select to display all cost codes 
or only the cost codes already assigned to the contract.
Select the cost codes to distribute. You can multi-select several by using CTRL-click and SHFT-Select. After 
selection, select the Select button. The window closes and the cost codes appear in the Contract Agreement 
Change Order window.
In the Change Order Contract Cost Codes scrolling window, you can specify a Retention% and Cost Code Cost; 
this cost is the amount of the total change order amount you want to apply to this cost code.
The total of the distributed cost code amounts MUST equal the total change order amount; otherwise, you will 
receive a message and will not be able to save the change order.
When finished distributed the change order amount, select Save. When you are satisfied with the information 
entered and ready to move forward with the change order, change the Contract Status to Confirmed, 
then Save again. When a Confirmed contract agreement change order is saved, the costs become committed 
costs in Job Cost and amounts are reflected in the Contract Agreement window.

Requesting payments for a contract agreement

You can create payment requests for subcontractor agreements from the Contract Agreement window. When a 
payment is posted, a PM transaction is created and the Contract To Date field on the Contract Agreement window is 
updated with the new amount.

For users who have Enable GST for Australia marked in Company Setup Options, additional fields and a supplementary 
window are available to meet the requirements of various Building and Construction Industry Security of Payments Act 
in Australia. These Australia-specific fields and supplementary window are discussed at the end of this section. See 
Additional information for Australian users (page 207).

Open the Contract Agreement window (Cards > Job Cost > Contract Agreement) and select an agreement.
Select the Payments button at the top of the window. The Contract Agreement Payables Entry window opens. 
Most fields are filled automatically with contract agreement information.
The Voucher Type defaults to Invoice. You can also create credit memos. Enter a Description of your payment, 
such as payment for subcontractor X.
Enter a Batch ID (if not posting right away) and Document Number.
To start applying payments to cost codes, select the Add Cost Codes button. The Available Contract Cost Codes 
window appears.
The Release Amount defaults to the entire amount for that cost code for the current contract agreement. If this 
is a partial payment, change this amount.

While a contract is Pending, you can make changes and save as many times as you like, without affecting costs 
or balances. Only after confirming a contract will costs and amounts be updated.


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When finished, you can save it to a batch to Post, or clear the Batch ID field and post immediately. As with any 
PM transaction, the following reports are available for viewing and/or printing:

Trx Entry Posting Journal
Trx Distribution Detail
Trx Distribution Summary
Trx entry Check Register
Checkbook Posting Journal

After a PM transaction has been posted, the Retention Withheld (if applicable), Cost Code Released, and Contract 
Released amounts in the Contract Agreement window are updated with the payment amount(s).

Additional information for Australian users
This section only applies to users who have Enable GST for Australia marked in the Company Setup Options window. 
The information below will only be available displayed if the Enable GST for Australia is marked. (Microsoft Dynamics 
GP > Tools > Setup > Company > Company > Options)

Claimed Amounts Recording

The Australian Building and Construction Industry Security of Payment Act 1999 is the primary legislative instrument 
regulating payment practices in the industry. The Act's objective is to promote the flow of progress payments by 
providing a statutory right under a construction contract to receive and recover payments relating to the carrying out of 
work and the supplying of related goods and services. For more information regarding this Act, visit http://
www.procurepoint.nsw.gov.au/supplying/security-payment.
The Contract Agreement Payables Entry window has been updated to meet the requirements of various Building and 
Construction Industry Security of Payments Acts in Australia. In the Contract Agreement Payables Entry window, the 
following has been added:

A Claimed Amount field has been added. This displays the total dollar amount of claims the subcontractor has 
submitted for the contract.
An expansion button has been added to Release Amount. When you select this button, the new Contract 
Claimed Amounts window will open where you can view the sub-contractor's claimed amount and the released 
amount defaults from the previous window.

Contract Claimed Amounts window

The Contract Claimed Amounts window has been added to assist with entering the approved payment and you can 
enter a reason in the comment field. In the Contract Claimed Amounts window, you can:

Edit the approved payment amount in the Release Amount field. If the amount is changed, the Release Amount 
in the Contract Agreement Payables Entry will update accordingly. 

Enter a comment in Reason Note. Select Save to close the Contract Claimed Amounts window. In the Contract 
Agreement Payables Entry window, you can either save the transaction to a batch or you can post the 
transaction.

The release amount cannot exceed the claimed amount.

When the Claimed Amount is greater than the Release Amount, the sub-contractor must resubmit a 
claim for the remaining amount. For example, a sub-contractor claims $10,000, and only $7,000 is 
approved. The $7,000 is released for the payment. The remaining unapproved $3,000 is recorded on the 
transaction and the sub-contractor must resubmit a claim for that amount.



http://www.procurepoint.nsw.gov.au/supplying/security-payment
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Viewing the inquiry windows

In addition to the existing Contract Agreement Payables Entry Zoom window, an additional zoom window has been 
created for the Contract Claimed Amounts Inquiry window.

Go to Cards > Job Cost > Contract Agreement.
Enter or select the contract vendor, then select Contract Released to zoom to the Contract Agreement 
Transaction Inquiry window.
In the Contract Agreement Transaction Inquiry window, select Document Number to zoom to Contract 
Agreement Payables Transaction Entry Zoom window.
Select the Release Amount expansion button to view the Contract Claimed Amounts inquiry window.

Viewing the Payment Schedule report

The Payment Schedule report has been created that displays the cost code description, the total amount of the 
payment claim, and the scheduled amount. This report reflects all cost codes for each job as well as the comments 
entered in the Reason Note field of the Contract Claimed Amounts window. The report creates a separate page for each 
job.

Project Level Feature
The optional Project Level feature allows you to combine multiple jobs into a project so that you can view jobs from the 
project level. This may be useful if you have multiple divisions working together to complete a single contract, but each 
division works on its own job. The Project Level feature allows for fixed (cost of construction) and time and materials 
(T&M) projects. In addition, you can set up reimbursable expense jobs to bill projects for reimbursable expenses (such as 
travel, mileage, and hotels) incurred on jobs. For more information, contact WennSoft Sales.

The Project Level feature also features project-level billing, which allows you to create a schedule for billing multiple 
jobs on a single invoice. Project-level invoices can be created with or without bill codes. Third-party billing is supported 
in project-level billing. Project-level billing creates a single Accounts Receivables transaction while distributing revenue 
to multiple jobs, divisions, or General Ledger accounts.

Using the Project Status Window
You can view project details in the Project Status window, which summarizes information for all jobs assigned to the 
project. You can view project information in the Project Status window, which summarizes cost, billing, and revenue at 
a project level. You can drill down to job-level detail, cost codes, and transaction-level detail. You can also view current 
contract amount, contract-to-date, and expected contract data, as well as billed position, contract earned, and cash 
position at a project level. Committed, posted, estimated, and forecasted costs are listed for the project cost elements, 
as are labor units and contract information. Information is also available on the contract status and billed position of 
the project. You can also view and print posted project invoices.

Select Inquiry > Job Cost > Project Status.

Creating a project 
Zoom on the Project Number field to open the Project Maintenance window where you can create a project. 
Complete the project information and select Save. See Setting up Projects (page 30) for more information.

Project Level invoicing does not support Multicurrency.
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Viewing project job status 
Select the ellipsis button in the Project Number field to open the Project Job Summary window. Zoom on a job 
to open the Job Status window. 

Viewing contract status
Select Contract Status to open the Project Contract Status window to display detailed contract information for 
the project.
Viewing billed position 
Select Billed Position to open the Project Billed Position window to display detailed billing information for the 
project.
Viewing and reprinting posted project invoices 
Select Billing to open the Project Billing Inquiry window to display the project invoices. You can reprint a posted 
invoice from this window by selecting the invoice, selecting Print, and then selecting the invoice SSRS 
report. You can zoom on the customer name and the amount remaining by selecting the invoice and then 
selecting the appropriate zoom. 

Setting up Project-Level Billing
Project-level billing allows you to bill customers by project instead of by job. Multiple jobs are billed on one project 
invoice. Each project-level billing creates one Receivables Management invoice and updates the billing information for 
all jobs billed on the invoice.

Step 1: Set up a project
See Setting up Projects (page 30).

Step 2: Assign jobs to the project
Select Cards > Job Cost > Job.
Complete the following fields:

Job Number, Description
Enter a job number and description.
Project Number
If this is a project bill code job, enter the number of a project that has the Project Bill Code checkbox 
marked in Project Maintenance.
Architect ID
If an architect ID was assigned to the project in the Project Maintenance window, that architect defaults 
to the job record.

The printer button in the Project Number field is visible only if the Project Manager's Advisor feature is 
registered. It allows printing reports by project number. See Project Manager's Advisor feature (page 
220) for details.



•
•

Notes:
If any job on the original project invoice is no longer open, a project invoice cannot be reprinted.
Project level invoices with a billing type of Project Allocated Revenue cannot be reprinted.



Project Level invoicing does not support Multicurrency.
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Billing Type
If this is a project bill code job, select Project Bill Code from the drop-down list. If this isn't a project bill 
code job, select a billing type of Project Standard Billing.

Complete the remaining fields in the Job Maintenance window as usual. See Creating a Job Record (page 88) for 
information on completing this window.
Select Save.

Creating Project Invoices
In the Project Invoice Entry window, you can create a schedule for billing multiple jobs on a single invoice. Project-level 
invoices can be created with or without bill codes. Third party billing is supported in project-level billing. Project-level 
billing creates a single Accounts Receivables transaction while distributing revenue to multiple jobs, divisions, or 
General Ledger accounts. Credit memos can also be created in this window. A posted project invoice can be reprinted 
from the Project Status window. See Using the Project Status Window (page 208) for more information.

Select Transactions > Job Cost > Project Level Billing.
Complete the following fields, as necessary.

Document Type
Select a document type.
Document Number
Enter a document number or accept the default.
Project Number / Description
To create a project bill code invoice, enter a project bill code project number. The project description 
displays.
Bill To Customer, Bill To Customer Name
These fields default from the selected job. You can accept the default or you can select a different 
customer. 

Project Customer ID, Project Customer Name
These display-only fields default from the project number selection.
Document Date
The Document Date completes defaults from the system date, however you can change this.
Batch ID
You can assign project bill code invoices and non-project bill code invoices to the same batch, but you 
can't print either type of invoice from the Receivables Batch Entry window. You must print them from the 
Project Invoice Entry window.
Tax Schedule ID
The Tax Schedule ID defaults.
PO Number
Enter a purchase order number, as needed.
Currency ID
The Currency ID defaults.
As of Date
The As Of Date defaults as the system date, however you can change this.

You cannot change a job's project number or billing type once a project-level invoice has been posted or saved 
to the job.



If you select a different customer, the Bill To address that prints on the invoice is the Bill To 
address set up in Customer Maintenance.


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Job Number
Enter a job number.
Calculate Sales Tax on Billing Amount
This checkbox is located at the bottom of the window. If you are using a Retention Percent, mark this 
checkbox to calculate the sales tax on the Billing Amount. If unmarked, the sales tax is based on the 
subtotal amount (Billing Amount - Retention Amount). There are currently five states (WA, NV, TX, OH & 
DE) that require that sales taxes on the Job Cost invoices be calculated based on the gross receipts (sales 
amount not reduced by retention).  The checkbox setting defaults from the Project Maintenance window 
but can be marked/unmarked in the Project Invoice Entry window. Taxes are recalculated when the 
checkbox is marked/unmarked. 

If this is a project bill code invoice, when you tab off the Job Number field, the Schedule Invoice window opens. 
Use this window to assign bill code amounts to be billed at the job-level.
In the Schedule Invoice window, complete the following fields:

Application Number
When you save the invoice, the application number rolls down to all jobs assigned to that project on that 
invoice.
Period To
Enter the last day of the billing period for the invoice.
Bill Code Number, Description, Account Number, Schedule Value, Previous Billings, Bill %, Current 
Due
Enter the bill code information and billing amounts or percentages.
Current Bill
Select the expansion button in the Current Bill field to open the Application For Payment window. 
Complete the window as usual. The retention amount entered in the Retention Withheld field will 
override the retention percent entered in the Job Maintenance window. 

Select Save to close the Schedule Invoice window and return to the Project Invoice Entry window.
In the Bill column, mark the job(s) to include on the invoice. You can manually mark or unmark the jobs or you 
can use the Mark All and/or Unmark All buttons in the button bar at the top of the window.
If this is a non-project bill code invoice, you can edit the Current Billing Subtotal field. The current billing 
subtotal is set based on posted costs for the job and profit types assigned to the job's cost code. 

If you edit the current billing subtotal amount in the Project Invoice Entry window, the entire amount billed will 
be applied to the Labor cost element. To edit the amount billed at a cost-element level, select the expansion 
button in the Current Billing Total field to open the Project Job Billing window. Edit the amounts billed and 
select Save. 

The Current Billing Total field is automatically calculated based on the current billing subtotal and retention 
withheld for the job. If you edit the current billing subtotal, the retention withheld and subtotal are 
automatically updated.  

In the Project Invoice Entry window, select the Print button.

When you bill for retention due on a project-level invoice, retention must be invoiced at the job 
level.



If this is a project bill code invoice, when you select the expansion button in the Current Billing 
Total field to open the Project Job Billing window, only the Retention Due field can be edited. Use this 
window to issue a retention invoice for project bill code jobs. 



For project bill code invoices, the expansion button in the Current Billing Subtotal field opens the 
Schedule Invoice window.


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If the invoice is a non-project bill code invoice, the JC Project Invoice report prints.
If the invoice is a project bill code invoice, the project-level version of the Application for Payment invoice 
prints. The report will print all bill codes with the same project number and invoice number. If the same 
bill code exists on more than one job on the project, the report will print one line item that totals all the 
same bill codes on the project. 

In the Project Invoice Entry window, select Save.

Applying Credit Memos to Project Invoices
The Microsoft Dynamics GP Apply Sales Documents window is used to apply credit memos and payments to invoices. 
 To assist you with locating unpaid project invoices that were included in the job referenced by the credit memo, we've 
added an Additional window called Signature Credit Apply.

Applying the Credit Memo to the Document Amount
To access the Apply Sales Documents window, go to Transactions > Sales > Apply Sales Documents. 
Enter the Customer ID used as the Bill to Customer for the project invoices or use the Customer ID lookup to 
select the appropriate customer.
In the Type field, select Credit Memo. 
Select the Document Number you wish to apply as a credit memo using the lookup provided. When using the 
lookup, a list of Open (unapplied) Cash Documents display.
Select the project invoice to open the Signature Credit Apply window.
In the Signature Credit Apply window, only the matching job numbers associated with the credit memo and the 
select project invoice display. 
Mark the checkbox(es) for the job numbers that the credit memo should be applied to. The maximum amount 
that can be applied is dependent on the Document Amount displayed for that job. For example, the credit memo 
amount is $1000. The Document Amount for a job is $500. $500 would be applied to the job and the Unapplied 
Amount shows the remaining $500 Unapplied Amount.
Select OK to apply the credit memo amount to the selected job number(s) and to close the Signature Credit 
Apply window. 
On the Apply Sales Document window, the Unapplied Amount displays any remaining credit memo amount. (As 
in the example above, $500 is displays in the Unapplied Amount.)
You can repeat the process to continue applying the credit memo to additional project invoices.

Applying a Specified Credit Memo Amount to a Project Invoice
In addition to the steps in the preceding section, you also have the option to apply a specific amount of the credit memo 
to a project invoice.

To access the Apply Sales Documents window, go to Transactions > Sales > Apply Sales Documents. 
Enter the Customer ID used as the Bill to Customer for the project invoices or use the Customer ID lookup to 
select the appropriate customer.
In the Type field, selct Credit Memo. 
Select the Document Number you wish to apply as payment using the lookup provided. When using the lookup, 
a list of Open (unapplied) Cash Documents display.
To the far right of the project invoice, enter the specific Apply Amount.
Mark checkbox to the left of the project invoice to open the Signature Credit Apply window.

You can also select File > Print to print the Project Invoice Edit List, which lists jobs assigned to 
this invoice.


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In the Signature Credit Apply window, only the matching job numbers associated with the credit memo and the 
select project invoice display. 
Mark the checkbox(es) for the job numbers that the credit memo should be applied to. The maximum amount 
that can be applied is dependent both the Unapplied Amount entered in the previous window and the 
Document Amount for the job. For example, if you entered $100 in the project invoice Apply Amount field in the 
previous window, the Unapplied Amount available to apply is $100. The Document Amount for a job is $100, the 
Applied Amount for the job would display $100 and the Unapplied Amount shows $0.00. The CM Unapplied 
Amount would show the total Credit Memo unapplied amount remaining. If the total Credit Memo was $1000, 
and you've applied $100, the CM Unapplied Amount displays $900 remaining unapplied.
Select OK to apply the credit memo amount to the selected job number(s) and to close the Signature Credit 
Apply window. 
On the Apply Sales Document window, the Unapplied Amount displays any remaining unapplied credit memo 
amount. (As in the example above, $900 is displays in the Unapplied Amount.)
You can repeat the process to continue applying the credit memo to additional project invoices. 

To apply a credit memo to a project invoice:

To access the Apply Sales Documents window, go to Transactions > Sales > Apply Sales Documents. 
Enter the Customer ID used as the Bill to Customer for the project invoices or use the Customer ID lookup to 
select the appropriate customer.
In the Type field, selct Credit Memo. 
Select the Document Number you wish to apply as payment using the lookup provided. When using the lookup, 
a list of Open (unapplied) Cash Documents display.
You can either:

Apply a specific dollar amount to a project invoice by entering the amount in the Apply Amount field to 
the far right of the project invoice and then mark the project invoice checkbox to open the Signature 
Credit Apply window.
Apply the full amount of the credit memo by marking the checkbox to the left of the project invoice to 
open the Signature Credit Apply window.

In the Signature Credit Apply window, only the matching job numbers associated with the credit memo and the 
select project invoice display. 
Mark the checkbox(es) for the job numbers that the credit memo should be applied to. The maximum amount 
that can be applied is dependent on both the Unapplied Amount entered in the previous window (if entered) and 
the Document Amount for the job.
Select OK to apply the credit memo amount to the selected job number(s) and to close the Signature Credit 
Apply window. 
On the Apply Sales Document window, the Unapplied Amount displays any remaining unapplied credit memo 
amount. 
You can repeat the process to continue applying the credit memo to additional project invoices. 

Printing Project Number Reports
You can print Project Number reports directly from the Project Status window by choosing the printer button. Each 
report prints for the project you are viewing.

The following Project Number reports can be printed:

Backlog
Costs by Period
Employee Summary
Job Schedule
Labor Summary
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Over (Under) Billing
Profit and Loss
Project Billing
Retention

For examples of these reports, see Project number reports in the Dexterity reports section of the Signature Reports 
documentation.

Billing Project Allocated Revenue and Cost Plus Billing Projects
The Project Allocated Revenue and Cost Plus Billing project types allow for fixed and time and materials (T&M) projects, 
respectively. In addition, you can set up reimbursable expense jobs to bill projects for reimbursable expenses (such as 
travel, mileage, and hotels) incurred on jobs.

For fixed contract or cost of construction projects, you can calculate invoice billing amounts based on the percentage of 
revenue allocated per bill code for each job. The phases of a project are represented by bill codes, which define the 
amount of revenue allocated and billed per phase. The Project Allocated Revenue project type is used exclusively for 
fixed projects.

For T&M projects, you can bill project labor on an hourly basis, based on a flat rate per hour, using profit types and/or 
labor rates. You can also apply non-labor transactions. The Project Trx Level project type is used for Cost Plus jobs.

The setup and billing processes differ between Fixed and T&M projects. Refer to the appropriate section below for more 
information.

Project Allocated Revenue (PAR) Projects
Fixed contract projects are set up using the Project Allocated Revenue project type. Labor jobs assigned to this project 
use the Project Allocated Revenue billing type, and if any reimbursable expense jobs are included, they use the Project 
Transaction Level billing type. 

Complete these steps in the exact order shown below. Project bill codes are not added until later in the setup process. If 
the project contains reimbursable expenses, those bill codes will be set up before the project bill codes.

Step 1: Set up a PAR project (page 214)
Step 2: Create bill codes for reimbursable expenses (page 215)
Step 3: Set up jobs with contract amounts (page 215)
Step 4: Set up project bill codes (page 215)
Step 5: Allocate revenue percentage to job(s) per bill code (page 216)
Step 6: Enter billable amounts for current invoice per bill code (page 216)
Step 7: Confirm billing amounts for each job (page 216)
Step 8: Post the batch and view billed amounts (page 217)

Step 1: Set up a PAR project
You must set up a PAR project to use the Project Allocated Revenue project type.

Select Cards > Job Cost > Project. The Project Maintenance window opens.
Select a project or create a new one. In the Project Type field, select Project Allocated Revenue.
Save the project.
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Step 2: Create bill codes for reimbursable expenses
If you are billing for reimbursable expenses on this project, create bill codes for reimbursable expenses at this time. Bill 
codes serve as a holding tank; no dollar amounts are required here, as actual amounts come from posted transactions. 
Later, you will use these bill codes to create a reimbursable job to associate with this project. This allows you to bill 
reimbursable expenses against the project.

Select Bill Codes. The Project Bill Codes window opens.
Complete the necessary information, and mark the Reimbursable checkbox.
When you are finished, select Save.

Step 3: Set up jobs with contract amounts
In this step, you will create the jobs associated with the project, enter contract amounts, and set the necessary options 
for percentage of allocated revenue billing.

Select Cards > Job Cost > Job. The Job Maintenance window opens.
Select the Project Number for the fixed project that you set up earlier.
Enter the Functional Contract Amount expected for this job.
Complete the remaining fields, as necessary. The Contract Type is set automatically to Fixed. The Billing Type is 
set automatically to Project Allocated Revenue.
Save the job. Repeat these steps for the remaining jobs assigned to this project.

Creating reimbursable expense jobs

If you are billing for reimbursable expenses, you must create a reimbursable expense job. This allows you to bill for 
reimbursable expenses against this project. Reimbursable expense amounts are billed each time non-labor billable 
expenses are posted to the job, based on the profit amount (for profit type on cost code).

When you have set up the job to be reimbursable, you can assign a cost code to this reimbursable job, then select on 
the Bill Codes button. This will bring in the ONE bill code you have assigned to the project as "Reimbursable."

Select Cards > Job Cost > Job. The Job Maintenance window opens.
Select the Project Number for the fixed project that you set up earlier.
Mark the Reimbursable checkbox. The Contract Type is set automatically to Cost Plus. The Billing Type is set 
automatically to Project Trx Level.
Save the job.
Create the appropriate cost codes, with profit amount, for reimbursable expenses.
Select the Bill Codes button. The reimbursable bill code created for the project will be copied to the Job Bill 
Codes window. This will be the only bill code assigned to this job and all transactions posted to the job will be 
calculated using the profit type/billing amount, and then the sum of the billing amounts will be added to the one 
bill code.

Step 4: Set up project bill codes
In this step, you will set up project bill codes (for labor and other costs), and enter the percent of revenue allocated for 
each bill code. Later, these bill codes will be copied down to the appropriate jobs.

Select Cards > Job Cost > Project. The Project Maintenance window opens.
Select a project. Notice the Project Expected Contract field fills automatically. This amount represents the total 
fee for services rendered, and is the calculated as the sum of all contracts for all jobs that are associated with 
this project.
Select Project Level Bill Codes button. The Project Level Bill Codes window opens.
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Fill in the initial fields, including Bill Code Number, Cost Element, and so on.
In the % Allocated field, enter the percent of revenue allocated to this bill code; the dollar amount fills 
automatically based on this percentage. For example, if this bill code is for labor, and you estimate that labor 
will make up 60% of the cost for this bill code, enter 60%. You can also select to enter a dollar amount in 
the Revenue Allocated field instead, and the % Allocated is calculated automatically.
Save the bill code.

Repeat the steps above to add more bill codes, as needed. The allocated revenue for all bill codes must add up to 100%.

Step 5: Allocate revenue percentage to job(s) per bill code
In this step, you will distribute the revenue from each bill code across jobs, by entering the percentage or dollar amount 
allocated per bill code for that job. For example, if project bill code A is $400.00, and you want 50% of that amount to be 
allocated to job A, you would enter 50.00 or a dollar amount of $200.00.

Select Cards > Job Cost > Job. The Job Maintenance window opens.
Select a job.
Select the Bill Codes button. The Bill Codes window opens.
Enter either a Total Billable Amount or % Allocated. The field you do not fill in is calculated automatically.
Save the bill code. You will know it is 100% allocated when you see the Difference display field at $0.00.

Step 6: Enter billable amounts for current invoice per bill code
Once the project and job(s) are set up properly, you can create invoices. The first step is entering the billable amounts 
for invoices per bill code.

Select Cards > Job Cost > Project. The Project Maintenance window opens.
Select a project.
Enter either a percentage - in the % Complete field - or a dollar amount - in the Current Bill field, to specify the 
amount from this bill code to be billed to the customer each time.
Save the project. This billable amount will roll down to each job associated with the current project.

Billable amounts for reimbursable expense jobs

The billable amount for reimbursable expenses comes from the profit type/billing amount as defined by the profit type 
for the reimbursable job bill code. For billing amounts to appear on invoices, you must A) make sure the Profit Amount 
is filled for that cost code, and B) there are posted transactions against this job and cost code for expenses.

Step 7: Confirm billing amounts for each job
Select Cards > Job Cost > Job.
Select a job.
Select Bill Codes. Select a bill code. The amount to be billed on the next invoice appears in the Amount per 
Invoice field; the percentage appears in the Bill % field.

Invoicing

When projects and jobs have been set up, and billing amounts have been determined, you are ready to create invoices 
to send to the customer. You create invoices using the Project Invoice Entry window.

Go to Transactions > Job Cost > Project Level Billing. The Project Invoice Entry window opens.
Tab through and select a Project Number.
Enter a Batch ID and fill other fields, as necessary.
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Select the jobs to be billed. As soon as you mark the checkbox, the Current Billing Subtotal amount fills in.
Make changes, if necessary. Use the expansion button next to Current Billing Subtotal to view/change individual 
transactions associated with this invoice, and to change the current bill amount, if necessary. 
Select a transaction and then the Select button. Enter a new Current Bill amount and select Save.
From the Project Invoice Entry window, save to batch.

Step 8: Post the batch and view billed amounts
After you post the project invoice batch, you can view the updated billed totals in the project bill codes.

Cost Plus Billing / Project Transaction Level Projects
Time & Material (T&M) projects are set up using the Cost Plus Billing project type (for projects) and Project Trx Level 
billing type (for labor jobs). For projects that include reimbursable expense jobs, the billing type for those jobs is also 
Project Transaction Level. Make sure to follow the steps in the exact order shown below.

Step 1: Set up a Cost Plus Billing project (page 217)
Step 2: Set up jobs with cost codes and bill codes (page 217)
Step 3: Confirm project bill codes for Cost Plus Billing project (page 217)
Invoicing (page 218)

Moving a Cost Code Transaction (page 219)

Step 1: Set up a Cost Plus Billing project
In this step, you will create a T&M project but without bill codes; these will be copied from the T&M job that you will 
create in the next step.

Select Cards > Job Cost > Project. The Project Maintenance window opens.
Select a project or create a new one. Enter a Project Number and Description, then fill remaining fields as 
necessary.
In the Project Type field, select Cost Plus Billing.
Save the project.

Step 2: Set up jobs with cost codes and bill codes
In this step, you will create the T&M jobs, cost codes, and bill codes.

Select Cards > Job Cost > Job. The Job Maintenance window opens.
Select the Project Number for the Cost Plus Billing project that you set up earlier. The Contract Type is set 
automatically to Cost Plus. The Billing Type is set automatically to Project Trx Level.
Fill the remaining fields, as necessary.
Save the job.
Select Cost Codes. Create cost codes and save. These are saved as bill codes to the project.
Select Bill Codes. Bill codes will be created automatically based on the cost codes, and created the job bill codes.
Save all windows and the job.

Step 3: Confirm project bill codes for Cost Plus Billing project
In this step, you will re-open the Cost Plus Billing project and confirm that the bill codes were created from the T&M 
job(s). See Creating Project Invoices (page 210) for more information.
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Select Cards > Job Cost > Project. The Project Maintenance window opens.
Select the Cost Plus Billing project.
Select Bill Codes. Use the browse buttons to select the bill codes. Make any changes, if necessary.
Save the bill codes and the project.

Invoicing
When projects and jobs have been set up, and billing amounts have been determined, you are ready to create invoices 
to send to the customer. Use the Project Transaction Level Billing window to include/exclude transactions associated 
with the Bill Code. You can also use this window to move a cost transaction to either another job, cost code, or an 
unbillable cost code. 

Go to Transactions > Job Cost > Project Level Billing. 
In the Project Invoice Entry window, tab through and select a Project Number.
Enter a Batch ID and fill other fields, as necessary.
In the Bill column, mark the jobs to be billed. (You can manually mark/unmark or you can use the Mark All and/or 
Unmark All button on the menu bar.)
The Current Billing Subtotal amount updates to include the billing amounts from the marked jobs. Make 
changes, if necessary. 
Select a job and then use the expansion button next to the Current Billing Subtotal column header to open the 
Project Transaction Level Billing window. 
In the Project Transaction Level Billing window, the following fields default from the Project Invoice Entry 
window:

Document Type
Document Number
Project Number/Description
Job Number/Description
As of Date (this date can be edited)

To view the transactions associated with the Bill Code(s) in the bottom table, you can use the Filter 
Transactions By:

Bill Code 
You will need to select a bill code to view the associated transactions.
All 
Displays all transactions on associated bill codes.

In the footer section of the window, the Contract Remaining amount is broken out by the Contract to 
Date amount and the Gross Billed to Date amount.
In the table directly below the header information, the following bill code information associated with the job 
displays:

Bill Code/Description 
Displays the Bill Code and its description.
Schedule Value 
Displays the schedule value for the bill code.
Previous Billings 
Displays the total amount of previous billings.
Current Due 
Displays the current amount due.
Current Bill 
Displays the current bill. If you unmark a transaction for this bill code, the current bill amount updates.
Total Billed 
This displays the total amount billed for the displayed bill codes. If you've excluded any amounts in the 
table below, this amount updates.
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In the bottom table, the transactions display based on the Transaction Filter and include the following 
information:

Cost Code/Description 
Displays the Cost Code.
Source 
Displays the source abbreviation.
GL Post Date 
Displays the General Ledger Post Date.
QTY/Hours 
Displays the quantity or hours.
Employee ID 
Displays the Employee ID, if appropriate.
Last Name 
Displays the last name of the employee.
Bill Amount 
Displays the bill amount.

The Cost Codes default as marked (to be included). You can manually unmark/mark the individual transactions 
to exclude/include the transaction from the invoice or you can use the Unmark All/Mark All buttons on the menu 
bar. If you manually unmark a cost code transaction, the cost is marked to be Moved. If you select the checkbox 
again, the checkbox is cleared and will not be moved or included in the billing. 

Select Save to return to the Project Invoice Entry window. If you have excluded any transactions, the job's 
current billing subtotal amount is updated in the Project Invoice Entry window.
From the Project Invoice Entry window, Save.

Moving a Cost Code Transaction

You have the ability to move a cost code transaction to either another job, cost code, or an unbillable cost code. The 
date for the job transaction is the Document Date of the invoice.

In the Project Transaction Level Billing window, select the marked checkbox to the right of the cost transaction 

to be moved. The checkbox now displays the Move indicator .
From the menu bar, select Move. 

The Job Transaction Entry window opens. 
Enter the Reference.
The Credit entry is automatically filled with the cost transaction.
Enter the Debit entry.
Post or save this to a batch.

•

•

•

Notes:

The Mark All/Unmark All buttons are not available for Project Allocated Revenue (PAR) projects, 
Cost Plus Billing (CPB) jobs, and/or all reimbursable jobs.
Mark All will mark all transactions to be included. If a transaction is marked to be Moved and 
you select Mark All, the transaction checkbox changes the Move icon to a marked checkbox to 
be included in the billing.
Unmark All will unmark any transactions that have been marked to be included OR Moved.



If you have some transactions marked to be included in the billing and other transactions to be moved, 
the Move button is disabled.


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Project Manager’s Advisor Feature
The Project Manager Advisor (PMA) feature enhances the Project Level feature by adding security, a detailed labor 
breakdown view, and the capability to print automatically sorted project and job reports. The Project Level feature is 
not required to run the PMA feature. The PMA feature is optional. For more information, contact WennSoft Sales.

Setting up Project Manager Security
In addition to the standard security options specified in the User Profile Setup window, you can set security for viewing 
job status, job history, and divisions if you are using the Project Manager's Advisor feature.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Security Setup > User Profile.
Enter user profile information. See Setting up security (page 15) for more information.
Select one of the following options for the user's ability to Open Payroll Entry Zoom, View Job Status, View Job 
History, and View Divisions:

All
The user can view job details for all employees.
Assigned Jobs
The user can only view job details of jobs that the user is assigned to as project manager. If the Project 
Level feature is registered, the project managers will be limited to viewing their own projects.
None
The user cannot view job details.

Select Save.

Viewing Labor Breakdown
You can view details of labor units and amounts for open jobs in your project.

Select Inquiry > Job Cost > Job Status.
Select a Job, then select Labor Breakdown. You can view the breakdown of the estimate labor units (usually 
hours), actual units, and percentage complete for each cost code in the Labor Breakdown Unit window.
Select the Amount tab to open the Labor Breakdown Amount window where you can view the breakdown of 
cost amounts for each cost code on the job, including estimate cost, posted cost, gain or loss to date, estimate 
complete, projected cost, and trended gain or loss. The trended gain or loss is the predicted gain or loss for the 
cost code and is automatically calculated based on the field percent complete for the cost code. The field 
percent can be entered in the Cost Codes Detail window, which is opened by zooming on the cost code.
In either the unit or amount view, select the printer button to select a report to print. For more information, see 
Printing Project Manager Advisor Reports (page 221).
From either the unit or amount view, select a Cost Code and zoom on the Cost Code Number field to view cost 
code detail information.

Viewing Job Status by Project Manager
You can view the job status by project manager using the Project Manager Summary window.
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Select Inquiry > Job Cost > Job Status.
Select a Job, then select the ellipsis button in the Project Manager field. The Project Manager Summary window 
lists the contract and billing information for all jobs associated with the project manager.
Double-click a job to view the job status of any job associated with this project manager.

Printing Project Manager Advisor Reports
Project Manager Advisor (PMA) reports limit project managers to viewing reports for the jobs they are assigned. Each 
report prints only for the job you are viewing. PMA reports can be printed by choosing the printer button in the Job 
Status, Cost Code Summary, Cost Codes Detail, and Labor Breakdown windows.

The following PMA reports can be printed:

Job Labor
Job Status
Audit Costs
Audit Billing
Change Order Summary
Estimate Variance
Projected Variance
Quantity Variance
Profit and Loss
Job Schedule
Over (Under) Billing
Backlog
PM Billing
Retention
Committed Costs
Costs by Period

For examples of these reports, see Project manager reports in the Reports manual or help file. Go Help > Signature 
Manuals or Help > Signature Help.

Closing, History, and Maintenance
This section consists of procedures for closing jobs/fiscal periods and viewing job history.

You can also refer to this section if you need to re-open a closed Job Cost fiscal period or job. Purging non-job related 
detail, removing job history, validating dates, and clearing data are performed using Signature Utilities. See 
the Signature Utilities User Manual for information on these utilities.

Closing Procedures
When a job is complete and all billings and cost transactions have been posted, you can close the job. If you use the 
completed contract or percentage-of-completion revenue recognition method, Job Cost automatically creates journal 
entries to recognize the final cost and revenue for a job when you close it. You can also close each fiscal period.

When you close a month or fiscal period, the system prevents any future job-related transactions from posting to that 
period.



10 https://docs.key2act.io/display/1804b06/
Using+Microsoft+Dynamics+GP+Purchase+Order+Processing#UsingMicrosoftDynamicsGPPurchaseOrderProcessing-
job_cost_using_microsoft_dynamic_3768

11 https://docs.key2act.io/display/1804b06/Legacy+Job+Close+Window
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The year-end closing process clears all year-to-date balances and reclassifies the balances of prior year-to-date 
amounts for reporting purposes. If the Closing Jobs Journal Entry checkbox in the Posting Options window is marked, 
a general ledger journal entry will be created for each closed job.

A general ledger batch is created for each day's closed jobs. The batch ID contains the letters JCC, plus the day's date. 
For example, if jobs were closed on 01/02/16, the batch ID would be "JCC 1/2/2016."

Closing a Job
Once a job is complete, you can close it. When you close a job, transaction detail is moved to the job history file with 
detail and summary records for the job. When you close a job, the user-defined information from the Job User-Defined 
window also moves to history, except for the active user-defined field information. You can view transaction detail for 
closed jobs by choosing Inquiry > Job Cost > Job History. You can also print Job Detail or Job Summary History reports.

Before Closing a Job (page 222)
Closing a Job (page 222)
Opening a Closed Job (page 224)
Viewing an Audit Trail (page 225)

Before Closing a Job
Complete the following procedures before closing a job.

Completely bill the job, including retention. If you marked the Allow Job to Close if Net Billed Not Equal to 
Expected Contract checkbox in the Posting Options window, then the net billed doesn't have to equal the 
contract amount. Otherwise, the net billed must equal the contract amount to close a job.
Post all transactions. No unposted transactions for the job should exist in any Job Cost transaction work file.
Receive and invoice/match all purchase orders for the job to be closed. For more information, see Using 
Microsoft Dynamics GP purchase order processing10. If the Allow Job to Close if Committed Costs checkbox is 
marked in the Posting Options window, you can close a job without receiving all purchase orders.
Back up all job cost files. If you encounter difficulties during the closing process, restore the backup, and 
complete the procedure again.
Make sure all prior months' POC have been run BEFORE closing the current month's jobs.

Closing a Job
Once you have completed the steps before closing, you can close your job(s). When the Close Jobs window is open, all 
jobs that display in the window are temporarily made inactive. This prevents other users from linking transactions to a 
job you are in the process of closing. Once the Close Jobs window is closed, all jobs that have not been closed will be 
returned to active. To use the old Job Close window see Legacy Job Close Window11.

Once you close a job, the job is no longer included with the monthly POC or RPO  journal entries. This is 
because these entries calculate amounts for open jobs only. Also, no transactions may be posted to a closed 
job.



Notes:

https://docs.key2act.io/display/1804b06/Using+Microsoft+Dynamics+GP+Purchase+Order+Processing#UsingMicrosoftDynamicsGPPurchaseOrderProcessing-job_cost_using_microsoft_dynamic_3768
https://docs.key2act.io/display/1804b06/Legacy+Job+Close+Window
https://docs.key2act.io/display/1804b06/Using+Microsoft+Dynamics+GP+Purchase+Order+Processing#UsingMicrosoftDynamicsGPPurchaseOrderProcessing-job_cost_using_microsoft_dynamic_3768
https://docs.key2act.io/display/1804b06/Legacy+Job+Close+Window
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The Close Jobs window displays the jobs Available to Close and the Not Available to Close. When you close jobs through 
this window, you are posting to General Ledger. A batch job is created that you will need to post in order to post 
through General Ledger.

To open the Close Jobs window, go to Microsoft Dynamics GP > Tools > Routines > Job Cost > Close Jobs.
Select the Posting/Schedule Date. You cannot use a date that falls before the creation date of a job you are 
closing. A Status of Not Available appears for any jobs that were created prior to the posting date. Additionally, if 
the period prior to that of the posting date is still open, you will receive an error when you attempt to close the 
jobs.
Optional: Filter the Jobs Available to Close by selecting an available filter and enter the filter criteria.

All Jobs - Displays all jobs that are available to be closed.
Job - After marking this option, enter the job number in the field below the option or use the lookup to 
open the Job Lookup window. In the Job Lookup window, you can filter the jobs at the top of the window 
or scroll within the window. Double-click the job or click on the job and click Select. The job displays in 
the Available to Close section if it can be closed.
Project - Displays the jobs assigned to the project that you select.
Customer - Displays the jobs for the customer you select.
Division - Displays the jobs within the division that you select.

Option: Select the Sub Filter to narrow the displayed jobs further.
Completion Date - Select Scheduled or Actual and then select or enter the date. 
Mark to Exclude Blank Dates. This would exclude any jobs without a date.

Select Redisplay to display a list of jobs based on the Posting Date and any filter criteria.
The AVAILABLE TO CLOSE section displays the jobs that meet the filtering criteria and can be closed. 
The NOT AVAILABLE TO CLOSE section displays jobs that meet the filtering criteria, but are not able to 
be closed, display in the bottom section along with a reason each job cannot be closed.

Use the Mark All button to select all the available jobs or you can mark specific jobs. You can also use Unmark 
All to unselect any marked jobs.
Select Close Jobs to close the marked jobs and create the batch. The batch naming convention is JCC 
YYYY.MM.DD. 
You may receive one or more of the following message(s):

If a batch is created: “Batch Number XXX was created!”
If a batch is not created but ALL selected jobs were closed: “The close job process is complete.”
None of the jobs closed: “None of the selected jobs were closed. Review the (Not Available to Close) grid 
or report for the reasons why each job is not available.”
If a batch is not created but not ALL selected jobs were closed: “The close job process is complete. X of XX 
selected jobs closed.” This message will show you the number of jobs closed out of the total number 
selected. The user would have to view the Jobs Not Available list to see why.

After a job closes, you can print the Closed Jobs report. This report lists all jobs that closed successfully. If you 
chose to post the closing jobs journal entry through the general ledger, you may also print the general ledger 
posting journal, which displays the general ledger entry created as part of the closing process. 

Complete the purge process to delete non-job-related detail from the Job Transaction Open file. See 
the Signature Utilities User Manual for more information.

•
•

All jobs assigned to a project using project-level POC must be closed at the same time.
A subcontractor contract agreement cannot be completed and all remaining payments are created if 
any job on the agreement is closed. Please be aware of this functional requirement when closing 
related jobs.

We recommend you print these reports and store them with your records as part of each job's audit 
trail.


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Buttons on This Window

Close Jobs
Closes the selected available jobs. A batch is created that you need to post in order to post through the General 
Ledger.
Redisplay
Select to display a list of jobs that can be closed based on the Posting Date and any filtering criteria. 

Existing Schedule
Select to load an existing job close schedule. The schedule's Posting Date and jobs populate the Close Jobs 
window. The jobs that were marked when the schedule was saved will still be marked.  This button displays 
if Enable Save Schedule is marked in the Additional Job Close Setup12 window.
Save Schedule
Saves the entire list of jobs for the User ID and Posting Date for processing later or processing in a SQL job. This 
button displays if Enable Save Schedule is marked in the Additional Job Close Setup13 window.
Print
Select from the following SRS reports:

Available to Close
Prints a listing of jobs available to close based on the Posting Date and any filter criteria. This report lists 
the create date, manager, contract amount, actual cost, markup percent, billed amount, cash received, 
and contract earned amounts for all jobs you can close.
Not Available to Close
Prints a listing of jobs available to close based on the Posting Date and any filter criteria.
Closed Jobs
Prints a listing of jobs that were closed based on the Posting Date and any filter criteria.
Job Preparation Closing
This report shows which jobs may be ready for closing based on either percentage complete or a lack of 
GL postings over time. This helps you identify unposted costs and any other items that may need to be 
taken care of before a job can be closed. You specify the jobs that appear as ready for closing based on 
the date of the last GL post, the last billing date, the estimated percentage complete, and/or the actual 
percentage complete. You can also filter the report by Job Status and/or Job Number and sort the report 
by job then division, or division then job.

Opening a Closed Job
You can open a closed job that is in an open fiscal period. This may be useful if a job is closed accidentally, or if late 
costs come in or additional billings are sent out after a job is closed. When you open a closed job, any journal entries 
that were posted during the job close process are reversed using the same posting date, so GL costs and revenue are 
recorded accurately after the job is reopened. In addition, a new audit table, JC10400, keeps a record of the date, time, 
and user every time a job is closed and reopened. Opening a closed RPO job will open the job with all RPO codes 100% 
recognized.

If you've saved a Job Close Schedule, selecting Redisplay will also clear the saved schedule.

If the costs or billings that you need to post are immaterial in amount, for example, a $100 permit for a $2 
million job, rather than reopening the job, you may select to capture these amounts on a separate job, or a GP 



https://docs.key2act.io/display/1804b06/Additional+Job+Close+Setup
https://docs.key2act.io/display/1804b06/Additional+Job+Close+Setup
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You can only open a closed job if it is in an open JC fiscal year and period. Closed jobs in closed fiscal years cannot be 
opened at all; however, if you want to open a closed job that is in a closed JC fiscal period, you can reopen the period. 
When a period is reopened, closed jobs in that period are opened but marked inactive. See Opening a closed Job Cost 
fiscal period14 for information on when and how to open a closed fiscal period.

Select Microsoft Dynamics GP > Tools > Routines > Job Cost > Open Closed Jobs. If necessary, enter the 
administrator password when prompted. The Open Closed Jobs window opens. This window displays a list of all 
available closed jobs. Open jobs, as well as any closed jobs that are in a closed JC fiscal period, do not appear on 
this window. The column headers on the scrolling window allow you to order the list of jobs by Job Number, Job 
Name, Date Closed, or Closed By.
Select the job(s) that you wish to open. You can select one, multiple, or all available closed jobs. You can also use 
the Find button to search for a specific job number.
Enter a Reason for reopening the job(s). This is a required field; you cannot open a closed job without a reason. 
The reason is printed on the Opened Jobs List report, as well as saved in the audit table. You can only enter one 
reason at a time. If you are opening multiple closed jobs for multiple reasons, you must run this routine 
separately for each unique reason you want to record.
Select Open Jobs. The selected jobs are opened and set as active. Journal entries created by the "close job" 
process are reversed.
After processing is complete, select a destination for printing the General Posting Journal, which displays the 
JCC Reversing entry, and the Opened Jobs List, which shows the jobs that were opened successfully. Job 
information including Batch ID, Journal ID, and Last Date Closed prints on the Opened Jobs List report, along 
with the Reason for reopening the job.

Viewing an Audit Trail
Each time a job is closed or reopened, a record is written to the audit table JC10400. This table keeps track of the date, 
time, and user whenever a job is closed or reopened.
In addition:

The Journal Entry field displays the journal entry number of the JCC Reversing transaction that is created when 
a job is reopened.
Jobs that have been reopened have a Previous State of Closed and a New State of Open.
The Created Date shows the date that a job record was created, while the Posting Date and User ID fields 
display information from the most recent instance of the job being opened or closed.

Legacy Job Close Window
The original Job Close window is only available by adding a shortcut to the left navigation bar in Microsoft Dynamics 
GP. Please note that this window will be deprecated in a future release.

transaction that debits a "Callbacks and Adjustments" account. This is also useful for jobs that cannot be 
reopened.

A Journal ID of 0 indicates that no reversing entry was created. This may occur if the job had no posted costs 
and no journal entry was created during the job close process.


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Adding the Job Close window to the shortcut bar

Launch Microsoft Dynamics GP.
On the shortcut sidebar, located at the lower left-hand corner of the window, right-click and select Add > Add 
Window.
In the Add Window Shortcut window, from the list of available windows, select WennSoft Products > 3rd Party.
Select Close Jobs. You can rename the shortcut by editing the Name field.
Select Add to create a shortcut to the window on the sidebar.
Select Done.

Closing a job

Once you have completed the steps before closing, you can close your job(s). When the Close Jobs window is open, all 
jobs that display in the window are temporarily made inactive. This prevents other users from linking transactions to a 
job you are in the process of closing. Once the Close Jobs window is closed, all jobs that have not been closed will be 
returned to active.

Select Microsoft Dynamics GP > Tools > Routines > Job Cost > Close Jobs.
Select a Posting Date. You cannot use a date that falls before the create date of a job you are closing. 
A Status of Not Available appears for any jobs that were created prior to the posting date.

Additionally, if the period prior to that of the posting date is still open, you will receive an error when you 
attempt to close the jobs.
Select Print to print the following reports:

Jobs Available for Closing report
This report lists the create date, manager, contract amount, actual cost, markup percent, billed amount, 
cash received, and contract earned amounts for all jobs you can close.
Job Closing Preparation report
This SSRS report lists all reasons why a job cannot be closed.  This report does not include Contract 
Agreements. This report option is available if SSRS is installed.

Select a job to close by marking the checkbox in the Status column. The status changes from Available to 
Marked. To mark all available jobs for closing, select Mark All.
Select Close to begin the job closing process.
Once a job closes, you can print the Closed Jobs report. This report lists all jobs that closed successfully. If you 
chose to post the closing jobs journal entry through the general ledger, you may also print the general ledger 
posting journal, which displays the general ledger entry created as part of the closing process.
Note: We recommend you print these reports and store them with your records as part of each job’s audit trail.
Complete the purge process to delete non-job related detail from the Job Transaction Open file. See 
the Signature Utilities User Manual for more information.

What's New with Closing a Job
With Signature 2018 R4, the Job Close window has been updated and enhanced. The original Dexterity Job Close 
window has been replaced with a new .Net Job Close window. The new window opens from the existing Routines > Job 
Close > Close Jobs menu. Users now have the ability to filter jobs for immediate closing or saved into a schedule table 
for processing later. New SSRS reports include Available to Close, Not Available to Close, and Closed Jobs. The existing 
Job Preparation Closing report is still available. These new security tasks have been added to the Job Cost Power User 
Role for the new Close Jobs window: K2AADD_JOBCLOSE (Job Close) and K2AADD_JOBCLOSESET.

For Signature 2018 R4, you can still access the legacy Job Close window by adding a shortcut to the Microsoft 
Dynamics GP left navigation bar. This window will be deprecated in the next major release.


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New Security Tasks

These new security tasks have been added to the Job Cost Power User Role (WSJC POWERUSER) for the new Close Jobs 
window:

K2AADD_JOBCLOSE (Job Close)
K2AADD_JOBCLOSESET - This provides access to the new additional Job Close Setup window (page 228).

1.
2.

3.

4.
5.
6.

To add the legacy Job Close window shortcut:
Launch Microsoft Dynamics GP.
On the shortcut sidebar, located at the lower left-hand corner of the window, right-click and select Add 
> Add Window.
In the Add Window Shortcut window, from the list of available windows, select WennSoft Products > 
3rd Party.
Select Close Jobs. You can rename the shortcut by editing the Name field.
Select Add to create a shortcut to the window on the sidebar.
Select Done.
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New Close Jobs Posting Option

A new setup posting option has been added to the Job Cost Posting Options window. Setup > Job Cost > Job Cost Setup 
> Posting Options.

Allow Job to Close if Total Invoiced not equal to Cash Received
Mark this checkbox if you want the ability to close a job when the total invoiced amount does not equal the cashed 
received.

New Additional Job Close Setup window

Use the Additional Job Close Setup window to disable filters, indicate the columns that display related to jobs and 
projects, and to enable users to save a job close schedule. Go to Microsoft Dynamics GP > Tools > Setup > Job Cost > Job 
Cost Setup > Posting Options. In the Posting Options window, select Additional and then select Job Close Setup. This 
menu feature is only available for users who fall under the security task K2ADD_JOBCLOSESET (page 227).

The Report Folder and Reports fields default to display folder and report names. You only need to edit these 
fields if you have a custom report that may or may not reside in a different folder. See New SSRS Reports (page 
233) for more information about the reports listed here.
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In the Disable Filters section
Mark the filters that you do not want to show in the Close Jobs window. All four options display unless marked to 
disable. Note that you are required to have at least one filter displayed in the Close Job window.

All Jobs
Project
Customer
Division

In the Enable Job Columns section
Mark any additional job-related columns to display in the Available Jobs scrolling window. These default to none 
marked.

Job Name
Manager ID
Job Address
Contract Type
Billing Type

Enable Project Columns section
Mark any additional project-related columns to display in the Available Jobs scrolling window. These default to 
none marked.

Project Name/Description
Architect ID
Project Set-up Date
Project Closed Date

Close Job UI Processing Threshold section
Mark the number of minutes the job close SQL process may need. The default value is 2 minutes. We recommend 
that you only change this value if the process times out.
Enable Save Schedule
Mark to display the Save Schedule button in the Job Close window. This defaults to not marked. Saving a job 
close schedule allows users to save the entire list of jobs for the User ID and Posting Date for processing later. 
Any jobs that were marked prior to saving will still be marked when the saved schedule is opened again. 

Only one schedule per user can be saved at one time.
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New Close Jobs Window Overview

The window opens in an empty state waiting for user input. No jobs are displayed until you enter filter criteria and/or 
select Redisplay.

Evaluation Criteria

The evaluation criteria is determined by the filters defined in the Job Close window and the Job Close options selecting 
in the Posting Options window as well as other criteria defined by a WennSoft stored procedure. (For example, open 
appointments for the job, unposted costs for the job, etc.) You can update the stored procedure to include any other 

With the new Job Close window, you can post TO the GL but not through the GL.



231

•

•

•

•

•

•
•

•

•

•

•

criteria that you select. We recommend making a backup of this stored procedure as it may be overwritten by future 
Job Cost releases.

Posting/Schedule Date: This is the posting date to be 
used when the job closing batch is created. This date 
defaults to today and will also default into the "as of" 
date in sub filters. This is the system date, not the 
Dynamics GP user interface date.

Filter: This is a radio button - you can only select ONE 
option.

All Jobs - Displays all jobs that are available to be 
closed.
Project - Displays the jobs assigned to the project 
that you select.
Customer - Displays the jobs for the customer you 
select.
Division - Displays the jobs within the division 
that you select.

Subfilter: These are secondary filters applied in addition 
to the initial filter criteria.

Completion Date: You must pick which 
"scheduled" date we are evaluating to find jobs 
ready to close. These are fields on the job master:

Scheduled Completion Date
Actual Completion Date

As of (date): This is the date that is used to 
compare the "Scheduled" or "Actual" completion 
date of the job master, for inclusion in the Job 
Close process.  As in "include all jobs where Actual 
Completion Date is equal to or less than <date>".
Exclude Blank Dates: Check the box to exclude 
jobs where the (scheduled or actual) completion 
date is empty. Given '1/1/1900' is always before 
the 'as of' date, jobs with no planned completion 
date would be always be included in the criteria 
unless we offer an option to exclude them.

Available to Close section

This section of the window displays jobs that successfully pass the job close evaluation criteria as defined in the filters 
above as well as the Posting Options (page 228) selections. The jobs are listed by job number and project number order. 
Each job is listed only once.

Mark All/Unmark All: Use these buttons to select or deselect Jobs. Selected jobs are available for Close 
processing.
Available/Selected: These are the display-only record counts for each state shown in the Available to Close 
section. 
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Not Available to Close section

This section of the window will display all jobs that failed to pass the job close evaluation criteria. The jobs are listed by 
job number and project number order. A job will be listed once for each failed evaluation and the reason is noted.

Not Available: This is the display-only record count for the jobs listed in the Not Available to Close section.

Example of the Close Job window 

This screenshot shows one job 
that passed the evaluation 
criteria and jobs that failed one 
or more of the evaluation 
criteria.

In the Available to Close
section, the Available display-
only field displays that there is 
1 job available to close. The 
Selected field displays 0 
because the job is currently not 
selected to be closed. If you 
mark the checkbox on the job 
row, the Selected field would 
display 1.

In the Not Available to Close
section, Not Available displays 
17 as there are seventeen jobs 
that did not pass the evaluation 
criteria. The job will display for 
each criteria that it failed. So 
for example, if a job failed 3 
criteria, you will see the job 
listed three times. A comment 
field (not shown in this 
screenshot) to the right of each 
failed job listing displays the 
failed criteria.



233

•

•

•

•

•

•

Buttons on this window

Close Jobs: Select to immediately initiate the job close process for all Selected Jobs displayed in the Available to 
Close section.
Redisplay: Select to redisplay after setting the filter criteria. The Redisplay button will also clear a saved 
schedule.
Existing Schedule: Select to load a saved schedule. This button displays if you've turned on the option to save 
schedules (page 229) in the Additional Job Close setup window.
Save Schedule: Select to save the current schedule. Users can only have one saved schedule. This button 
displays if you've turned on the option to save schedules (page 229) in the Additional Job Close setup 
window. Electing to save a schedule sets aside all of the displayed jobs that meet your filter criteria (our 
available to close and not available to close) so that you can exit the window then return back to this point, at a 
future date/time.  While you have these jobs displayed in this window or while they are in a saved Schedule, they 
are inactive for posting purposes, so you should use caution when saving a schedule.   
Print: Select to display a list of the SSRS reports. Select the report to print. See New SSRS Reports (page 233) for a 
description of each report.

New SSRS Reports

New SSRS reports include:

Jobs Available to Close: Prints a listing of jobs available to close based on the Posting Date and any filter 
criteria. This report lists the create date, manager, contract amount, actual cost, markup percent, billed amount, 
cash received, and contract earned amounts for all jobs you can close. This report is printed from the new Job 
Close window.
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Jobs Not Available to Close: Prints a listing of jobs available to close based on the Posting Date and any filter 
criteria. The job will display for each criteria that it failed. This report is printed from the new Job Close window.

Closed Jobs: Prints a listing of jobs that were closed based on the Posting Date and any filter criteria. The data is 
retrieved from the Job Cost Close Audit (JC1040) and Job History (JC30001) tables. This report is printed from 
the new Job Close window.

Job Closed Preparation (existing report): 
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Actions When Closing a Job

After you select the Close Jobs button, this immediately initiates the job close process for all Selected Jobs 
displayed in the Available to Close grid.
The Financial GL batch is created (or appended) but only when transactions are necessary. 

Batches are named: "JCC YYYY.MM.DD" where YYYY.MM.DD is the Schedule Close Date.
The Jobs Not Available to Close section remains unchanged and these jobs are still "inactive" until the user 
clears the window.
The Financial Batch is generated when posting has occurred on a job. This batch will contain the final WIP →
COGSs entry.
Source document = "JCC"

Closing a Period or Month
You can close periods or months in Job Cost just as you close them in Microsoft Dynamics GP. Closing a period prevents 
posting any new Job Cost transactions to the period. In addition, the period closing procedure allows you to finalize 
cost and revenue amounts for the period as the first step in creating the percentage-of-completion journal entry.

When you close a period in the current fiscal year in Job Cost, you can no longer post from any Job Cost transaction 
entry windows using a transaction posting date that falls within that closed period. An exception to this is if a non-job 
related transaction entry posts to a Microsoft Dynamics GP module and the JC period check is disabled.

Before Closing a Period or Month (page 235)
Closing a Period or Month (page 236)
Opening a Closed Job Cost Fiscal Period (page 236)

Before Closing a Period or Month
Prior to closing the period or month, complete the following procedures:

Back up your Job Cost files. If you encounter difficulties during the closing process, restore the backup and 
complete the procedure again.
Close all completed jobs. See Closing a Job (page 222). In addition, complete the following steps only if you are 
using the POC or RPO revenue recognition method. After closing the period, you will create a POC journal entry.
Use the WIP reports to make sure your Job Cost WIP accounts balance with the WIP accounts in the General 
Ledger.
Print the POC/RPO edit list.

IMPORTANT: With the new Job Close window, you can post to the GL but not through the GL.
The Job Cost Setup window, in the Close Jobs section, still has the Post Through GL option, however 
this option only pertains to the legacy window. Regardless of having Post through the GL marked/
unmarked, the New Job Close window only lets you post to the GL.



•
•

You cannot close a fiscal period in Job Cost unless the previous fiscal period is already closed.
We recommend that you close the Microsoft Dynamics GP Series periods prior to closing the period or 
month. Failure to do so might cause transactions not to be posted to Job Cost.


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Closing a Period or Month
Select Microsoft Dynamics GP > Tools > Routines > Job Cost > Month-End Closing.
Select the fiscal Year that contains the period or month to close. Enter the Period ID. You cannot close any fiscal 
period unless the previous fiscal period is already closed.
Select Close. A progress window appears, indicating the status of the month-end closing process. Once the 
period closes successfully, a message alerts you that you can no longer post transactions to the closed period.
Select OK. If you are using the percentage-of-completion or recognized performance obligation revenue 
recognition method, you must create a POC/RPO entry after closing a period or month. Refer to Creating 
Percentage-of-Completion Journal Entries (page 162) or Creating Job Revenue Journal Entries (page 163) and 
complete the steps outlined in that section. If the edit list that prints after you close the period differs from the 
entry list that you printed before closing the period, contact WennSoft Support.

Opening a Closed Job Cost Fiscal Period
You may need to open a closed Job Cost fiscal period if significant costs come in after a fiscal period is closed, and you 
want to record those costs in the period in which they were incurred. Once you have re-opened the fiscal period, you 
can recognize revenue for the new costs and, if necessary, create more billings for the period.
You cannot re-open a Job Cost fiscal period if

The corresponding Microsoft Dynamics GP fiscal period is closed.
The fiscal year containing the period is closed.

You can only open the most recently closed fiscal period. For example, if periods 1, 2, and 3 have all been closed, you 
cannot open period 2 without first re-opening period 3. Likewise, if you need to open the last period in an open fiscal 
year, but the following year contains periods that have been closed, you must open the most recently closed periods 
before you can go back and open periods in the previous fiscal year.

Select Microsoft Dynamics GP > Tools > Setup > Job Cost > Job Cost Setup > Fiscal Periods. The Job Cost Fiscal 
Periods Setup window opens.
Unmark the Series Closed checkbox next to the period you wish to open. This row of checkboxes is disabled if 
the fiscal year containing the period is already closed.
Select OK to close the window.

After you finish posting costs for the now re-opened Job Cost fiscal period, you can close the period again. If you are 
using either the POC and/or RPO method to recognize revenue, you must re-build and post a new entry/entries.

•

•

•

•

If you had previously been using POC and are now switching to the RPO revenue recognition 
method, all entries for both POC and RPO are in one batch called REVR user date. Re-opening a closed 
fiscal period reverses all RPO and POC entries.
If you were not using POC or RPO but are now using the POC or RPO revenue recognition 
method, re-opening a closed fiscal period reverses any POC/RPO entry that has been posted. If a POC/
RPO entry has not yet been posted for the period, you receive a message indicating that a reversing 
entry did not need to be created. The batch ID for POC only  is POCR user date. The batch ID for RPO 
is REVR user date.
If you were previously using POC and will continue to use POC, all POC entries are in the batch POCR 
user date.
If you are not using POC or RPO, and you are using cost code posting accounts rather than division 
posting accounts, no reversing entry is created.


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Closing a Year
The year-end closing procedure removes all previous-year Job Cost transaction amounts and reclassifies them as prior-
year amounts for reporting purposes.

Before closing a year
Post all Job Cost transactions for the year. No unposted transactions for the year should exist in any Job Cost 
transaction work file.
Back up your Job Cost files. If you encounter difficulties during the closing process, restore the backup and 
complete the procedure again.
Perform the period closing for the final period in the fiscal year. See Closing a Period or Month (page 235).

Closing a year
Select Microsoft Dynamics GP > Tools > Routines > Job Cost > Year-End Closing.
The fiscal year to be closed appears as the default and cannot be changed. Select Close to close the fiscal year.

Viewing Job History
You can review the history of closed jobs in the Job History window and can drill down to view summary and detail 
history of cost codes, transactions, billings, user-defined information, and notes written for the job. You can also print 
historical job invoices.

Job history is useful for reviewing charges and estimates of closed jobs and for tracking performance and profitability. 
History information can also help you estimate future jobs and provide direction to your company when pursuing new 
jobs.

Select Inquiry > Job Cost > Job History. Information that can be viewed in the Job History window includes the 
Job number, Project Manager and Estimator for the job, and the Date the job was closed. The Posted Cost, 
Estimated Cost, and Forecasted Cost for the job are displayed for each cost element. You can drill down on 
posted costs to see the cost code and transaction history information. The Contract Type, Original Contract 
amount, Change Order Total amounts, and Total Contract amount are displayed in the lower-left corner of the 
window. The Estimated Hours, Actual Hours, Actual Markup, and Markup Percent are displayed in the lower right 
corner of the window.
Select the following buttons to access additional historical information:

Billing - Viewing billing history (page 238)
Within the History Billing Inquiry window, you can also zoom to view the cash receipts history (page 
238).

User-Defined - Viewing job user-defined history (page 238)
Change Orders - Viewing change order history (page 239)
Job expansion button - Viewing job maintenance history (page 239)

Within the Job Maintenance History window, you can select the RPO Codes button to view 
revenue code history.

Notes button - Viewing history notes (page 239)

You cannot close a fiscal year in Job Cost until the last fiscal period in the year is closed. Before closing a fiscal 
period in Job Cost, make sure to close the corresponding series on the Microsoft Dynamics GP Fiscal Periods 
Setup window (Microsoft Dynamics GP > Tools > Setup > Company > Fiscal Periods).


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Revenue Code - Viewing revenue code history (page 239)
Select the Print button to print the JC Job Status History report.

Job History window
This window allows you to view closed jobs in a window that is similar in look and feel to the Job Status window.
Select Inquiry > Job Cost > Job History.

Viewing billing history
You can view the billing history of a closed job in the History Billing Inquiry window. You can print a list of bills and view 
the history and details of job invoices. You can also print the invoices.

Select Inquiry > Job Cost > Job History.
Select a job, then select Billing.
To print the History Invoice Transactions Billing report, select File > Print.
Double-click a document in the History Billing Inquiry window to open the Job Invoice History window. Select 
Print to print the invoice. The invoice styles available are based on the job's billing type.
Select Schedule in the Job Invoice History window to view detailed history information of the invoice. The billing 
type for the job determines which window opens.

If the billing type is Standard, the Standard Invoice History window opens.
If the billing type is Cost Code or User-Defined, the Schedule Invoice History window opens.
If the billing type is Transaction Level, the History Transactions Inquiry window opens.

Viewing cash receipts history
Select Inquiry > Job Cost > Job History.
Select a job, then select the Billing button. The History Billing Inquiry window opens.
Select an invoice.
Zoom on Cash Received.

Viewing cash receipts history
Select Inquiry > Job Cost > Job History.
Select a job, then select the Billing button. The History Billing Inquiry window opens.
Select an invoice.
Zoom on Cash Received.

Viewing job user-defined history
You can view the user-defined information for a closed job in the Job User-Defined History window.

Select Inquiry > Job Cost > Job History.
Select a Job.
Select the User-Defined button to open the Job User-Defined History window, displaying the historical user-
defined information for the job. Active user-defined fields are not included in the window.

The user-defined history information is deleted when the Remove Job History utility is run in Signature Utilities.
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Viewing change order history
You can view change order details - including cash receipts - for historical (closed) jobs.

Select Inquiry > Job Cost > Job History.
Select a job.
Select the Change Orders button.
Double-click a change order to select. The Change Orders Zoom window opens.
Select Cost Codes to view cost code information.
Select Bill Codes to view bill code information.

Viewing transaction history
You can view the detail history of a cost code, including estimate and actual costs and production information in the 
Cost Codes Detail History window. You can also view transaction and production unit history summaries.

Select Inquiry > Job Cost > Job History.
Select a Job and zoom on a posted cost element.
Zoom on a cost code to open the Cost Codes Detail History window.
Select the View Transactions button or zoom on the actual amount to open the Transaction Summary History 
window.
Select File > Print to print the History Transaction Journal report.
In the Transaction Summary History window, double-click a transaction to view transaction detail. The cost 
element type determines which window opens. If the transaction is for a labor cost code, the Payroll History 
Zoom window opens. If the transaction is not a labor transaction, the Payables Transaction Entry Zoom window 
opens.
In the Cost Codes Detail History window, select View Production Units to open the Production Units History 
Summary window, showing the transaction, type, field percent, and production quantities for the cost code.

Viewing job maintenance history
This window provides a way to view historical job information. You access this window from the Job History window.

Select Inquiry > Job Cost > Job History.
Select a job, then select the expansion arrow in the Job field. The Job Maintenance History window opens.

Viewing history notes
You can view the history of notes written on the closed job in the History Notes Inquiry window.

Select Inquiry > Job Cost > Job History.
Select a job, then select the notepad button in the Job field.
Select a note in the History Notes Inquiry window and zoom on the Index Name field.

Viewing revenue code history
This window allows you to view revenue codes on closed jobs in a window that is similar in look and feel to the Revenue 
Code Status window.
Select Inquiry > Job Cost > Job History > Revenue Code.
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Utilities
Keeping accurate records requires proper maintenance. This includes activities such as reconciling files and re-creating 
summary files.

Reconciling Files (page 240)
Reconciling Jobs (page 240)
Reconciling Billing (page 241)
Reconciling Bill Codes (page 241)

Recreating the Summary File (page 241)

Reconciling Files
The reconciling procedure verifies the information in transaction open files and adjusts the totals in the master files if a 
discrepancy exists. You can reconcile jobs, billing, and bill codes. Back up your Job Cost data files before running 
reconcile. Make sure no one is logged into Microsoft Dynamics GP when you reconcile Job Cost data files. If other users 
are logged in, an alert message appears, and the Job Cost reconcile process will not run to completion. If the Print 
Report Only option is marked during the GP reconcile process (Microsoft Dynamics GP > Tools > Utilities > Sales > 
Reconcile-Remove Sales Documents), the transactions will not be moved to history. If the Print Report Only button is 
unmarked, records are moved to history. The Job Cost reconcile process will remove records from history.

Reconciling Jobs
This utility should only be run at the advisory of WennSoft Support. You can complete the reconcile procedure for a 
specific job, a range of jobs, or all jobs. Note that reconciling jobs does not update billing amounts. To reconcile billing 
amounts, run the Reconcile Billing utility.

Select Microsoft Dynamics GP > Tools > Utilities > Job Cost > Reconcile Jobs.
Mark the Validate Job Transactions checkbox to reconcile amounts with data validation. 

Mark the checkbox to print an audit report if you want to identify invalid transactions for the selected jobs.
Select whether to reconcile all jobs, a single job, or a range of jobs.
Select the jobs to reconcile in the Job Number field.
Select Reconcile. The Reconcile report displays, identifying any transactions with missing information.

If there are invalid transactions, you need to investigate why these transactions are invalid. You can then 
select Unmark in the Reconcile Jobs window to remove the delete status of invalid transactions or select 
Delete to remove the invalid transactions from the Job Cost Transaction Open file. Complete the 
reconcile procedure again after deleting any invalid transactions. 

Reconcile should ONLY be run on a job when you've identified an issue in the data that you cannot fix by using 
a function that exists in Job Cost. Reconciling should not be run as a general or routine practice. If you find an 
issue that can only be fixed with a reconcile or recreate summary, please contact WennSoft Support.



Do not mark this checkbox if you only want to recalculate amounts. Recalculating takes considerably 
less time than reconciling because recalculating does not check the validity of transactions. You cannot 
delete invalid transactions if you recalculate.


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If you want to recalculate the Job Cost detail totals, unmark the Validate Job Transactions option in the 
Reconcile Jobs window. Then reconcile again.
If there are no transactions on the report, the utility has found no errors and you can close the reconcile 
window. The procedure is complete.

Reconciling Billing
This utility should only be run at the advisory of WennSoft Support. Back up your data before you reconcile the files.

Select Microsoft Dynamics GP > Tools > Utilities > Job Cost > Reconcile Billing.
Use the lookup buttons in the From and To fields to select a range of jobs.
Select Insert >>.
Select Reconcile. A message appears asking if you want to reconcile. Select Yes.

Reconciling Bill Codes
This utility should only be run at the advisory of WennSoft Support. Back up your data before you reconcile the files.

Select Microsoft Dynamics GP > Tools > Utilities > Job Cost > Reconcile Bill Codes.
Use the lookup buttons in the From and To fields to select a range of jobs.
Select Insert >>.
Select Reconcile. A message appears asking if you want to reconcile. Select Yes.

Recreating the Summary File
The Recreate Summary File utility is used to populate the Job Detail Summary and Master Summary tables for 
customers who have migrated from another accounting system to Signature. If you think your Job Detail Summary or 
Master Summary tables are damaged or corrupted, contact WennSoft Support to assist you in running the Recreate 
Summary File utility.

The Master Summary file contains the costs-to-date by job at a cost element level for each closed period. The amounts 
in this file update each time a Job Cost period closes. These amounts are also used to create the percentage-of-
completion journal entry at the period end. The Job Detail Summary file contains the cost amounts for each period 
posted to each cost code. You can review these monthly amounts in the Job CC Monthly Costs window. See Viewing 
Posted Costs15.

If you select to delete invalid transactions (for example, if you delete discontinued items), you 
may need to create a job transaction entry or Microsoft Dynamics GP General Ledger journal 
entry to reflect the deleted transaction(s). The reconcile feature does not make any 
adjustments to Job Cost or the general ledger. The reconcile process re-adds the Job Cost detail 
totals.



Recreate Summary drops summary tables for the job and RECREATES table data. This means historical 
information could be changed.



https://docs.key2act.io/display/1805b07/Viewing+Posted+Costs
https://docs.key2act.io/display/1805b07/Viewing+Posted+Costs
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Select Microsoft Dynamics GP > Tools > Utilities > Job Cost > Recreate Summary File.
Back up your Job Cost data files.
Select to re-create the summary file for all jobs or one job. Enter the job number if re-creating by job number.
Select Recreate.

WIP Reconciliation Tool
The WIP Reconciliation tool allows you to compare your Job Cost and Service Management WIP subledgers to the 
General Ledger. Sorting and filtering functionality enables you to easily identify the discrepancies that are causing an 
imbalance in your WIP accounts.

Select Microsoft Dynamics GP > Tools > Routines > Service Management > Service > WIP Reconciliation. Or from Job 
Cost, select Microsoft Dynamics GP > Tools > Routines > Job Cost > WIP Reconciliation.
In the left pane of the WIP Reconciliation window, use the product indicator to select either Service Management 
or Job Cost.
Underneath the product indicator, select Work In Process (WIP).
On the right pane of the WIP Reconciliation window, use the Account drop-down menu to filter by a specific 
account or display all WIP accounts.
Select a date range. The From date defaults as the first day of the month. The To date defaults as today's date.
Select Go to display posting records from the selected date range. Each record indicates an amount that was 
posted to the General Ledger on a certain day. For each date, you can compare the subledger amount to the 
General Ledger total and see if any discrepancy exists between them. The records that appear in red indicate an 
imbalance.
Double-click a record to view transaction details for that date. Using the detail window, you can compare the 
transactions in the subledger to those in the General Ledger and identify the specific transactions that are 
causing the discrepancy. For information about the various sorting, grouping, and filtering options that are 
available for customizing what you see, see Working with the Reconciliation tool (page 243) below. You can also 
narrow down the list of transactions that appear on this window by marking the R checkboxes next to the 
transactions that were successfully posted to both the subledger and General Ledger. These transactions can be 
hidden using the Hide Reconciled button. You can continue to narrow down the list of records until only 
unreconciled transactions remain in the view. 

You can use the Export button to save the view you created for a list of records, including your sorting and 
grouping choices, as an .xls file. This allows you to close the WIP Reconciliation tool but continue to work with 
your list of unreconciled transactions as you fix any unbalanced accounts. If you export the detail window, two 
prompts appear, the first allowing you to save the Subledger Export, and the second allowing you to save the 
General Ledger Export. You can also save a Work in Process (WIP) Variance spreadsheet with the information 
from the main WIP Reconciliation window.

•

•

When you are using the Estimate by Period option when running the Recreate Summary File utility, any 
estimate revision entered since the start of the job will be treated as if it were entered at the time the 
job was created. That is, every period will contain that estimate.
We recommend you complete the reconcile procedure before re-creating the summary file.



The customizations that you make to the views in the Reconciliation tool, including flagged and hidden 
transactions, are not permanently saved. If you exit and re-open a window, any views that were 
previously used will be lost. Transactions that were previously flagged and hidden will display again.


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Working with the reconciliation tool
Records can be filtered and sorted until they are displayed in the manner that is best for you to narrow down to the 
source of any discrepancy.

You can change the sort order of the records that display by choosing on a column name, for example, sorting 
records per highest or lowest delta amount.
You can change the grouping of the records by dragging and dropping a column heading to the "Grouped by" 
toolbar, for example, grouping records by account number or date.
You can apply additional filters to show only the records that you want to display based on the values in each 
column, for example, showing only records of certain dates or with a delta that is not zero.

Example:

A record on the WIP Reconciliation window indicates an imbalance, with an extra $75.00 in the General Ledger.

Double-click the line to view transaction details. You can drag and drop a column header to the grouping toolbar to 
group the transactions and view a summary by, for example, journal entry number.
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Viewing cost amounts by group allows you to focus on a group and makes it easier to narrow down the list of 
transactions that may be out of balance. 

In the example below, two of the three journal entries (4800 and 4802) have the same amounts in the subledger and 
General Ledger. The unreconciled transactions belong to journal entry 4477.
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You can expand a category to view the transactions in that group.

Once you have ruled out certain transactions - or a certain group - as the cause of the imbalance, you can mark those 
transactions as reconciled and use the Hide Reconciled button to hide them from view.
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Only the transactions for journal entry 4477 remain.
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If you expand those groups, you can identify that one of the $75.00 transactions from this journal entry hit the General 
Ledger but did not hit your WIP subledger.

To save the custom view you have created before closing the WIP Reconciliation window and reconciling the 
unbalanced transactions, select Export.

Subledger Export

General Ledger Export
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Contact Information
Support

Phone: 262-317-3800
Email: support@wennsoft.com16 
Hours: Normal support hours are 7:00 a.m. to 6:00 p.m. Central Time. After-hours and weekend support is available for 
an additional charge. Please contact WennSoft Support for additional information. 

WennSoft will be closed in observance of the following holidays: New Year's Day, Memorial Day, Juneteenth, 
Independence Day, Labor Day, Veteran's Day, Thanksgiving Day, the day after Thanksgiving, Christmas Day, and the day 
after Christmas.

Support Plans

We're committed to providing the service you need to solve your problems and help your team maximize productivity.

We offer several Signature Enhancement and Support Plans to meet your needs and Extended Support Plans for retired 
product versions available at https://www.wennsoft.com/wsportal17.

Sales

Phone: 262-317-3700  
Fax: 262-317-3701

WennSoft Headquarters

Address: 
WennSoft
1970 S. Calhoun Rd.
New Berlin, WI 53151-1187 

Phone: 262-821-4100 or 866-539-2228
Email: info@wennsoft.com18

Website: www.wennsoft.com19 
Office hours: Monday through Friday from 8 a.m. to 5 p.m. Central Time.
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